zenon Analyzer

zenon Analyzer

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The zenon Analyzer offers near management and controlling views of all online and offline available data via system-spanning analyses. It summarizes tasks which were separated until now and it eliminates friction losses which emerge due to parallel set-ups, maintenance and the coordination of different IT systems. The zenon Analyzer:

  • condenses and accounts data from different sources in different formats
  • compares them to one another
  • display the results in graphical form as report

tutorial License information

The zenon Analyzer must be licensed. For further details see chapter Licensing

attention Attention

Only 64-bit operating systems are supported from Version 2.0 onwards.

Overview

When using the zenon Analyzer, the production process is not interrupted. The zenon Analyzer can be implemented in an existing production system without the need to reconfigure the system. At data collection and report creation the production system continues to run smoothly. The existing infrastructure is embedded in the reporting of the zenon Analyzer independent of the manufacturers.

For accessing the evaluation all you need is a browser. You do not have to install, adapt or maintain any additional software. You can embed evaluations without any additionally components or plug-ins in the intranet of a company. Default reports are already shipped with the zenon Analyzer. At any time you can create, save and distribute your own evaluations. To create reports from process level, you must install a Connector Container on the respective Runtime computers. This installation does not affect the running system.

info Information

The zenon Analyzer uses components from Microsoft Reporting Service.

You can find detailed instructions for the configuration of Microsoft Reporting Services on the Microsoft homepage:

  • German
  • English
  • French
  • Italian

Overview of the help of the zenon Analyzer

In the help of the zenon Analyzer you can find information about:

  • Basics about architecture, data structure and data preparation
  • Installation of the modules of the zenon Analyzer
  • Rights management
  • Configuration and operation of the Report Launcher (site, folders and Reports)
  • ZAMS - zenon Analyzer Management Studio: Create and administer reports, administer users, administer servers
  • Manual Data Editor: Used for the editing of the tables for price and standard values in a zenon Analyzer metadata database.
  • Supplied report templates: Documentation for the report templates supplied with the zenon Analyzer.
  • Example project

info Information

For the engineering of individual reports, please refer to the respective manual. You will receive this manual after completing the corresponding training at COPA-DATA. For information and training and the manual for developers, please contact sales@copadata.com by email.

Other topics in this chapter

Upgrade information

Technical basics

Installation and updates

configuration file zenAnalyzer.ini

Data preparation

ZAMS - zenon Analyzer Management Studio

Metadata database editors

Migration Tool

Supplied report templates

Example zenon

Event-driven report creation

Report Launcher

Analyzer Wizards

First steps


Upgrade information

zenon Analyzer -> Upgrade information

Note when switching to a version prior to version 3.00:

Activation number

For version 3.00, the algorithm was amended for the creation of the activation number. Activation numbers for zenon Analyzer versions 2.xx are no longer valid for versions from 3.00.

Export Wizard for Analyzer 3.00

The wizard for the export of metadata from zenon was amended and is now available as Export Wizard for Analyzer 3.00. It works with zenon from version 7.11 SP0 for zenon Analyzer 3.00.

Licensing in workgroups

zenon Analyzer can now also be licensed in workgroups. For details, read the Licensing in workgroups chapter.

Manual Data Editor

The Manual Data Editor has been revised completely.

The following were changed most of all:

  • Operation:
    Configuration is now carried out using several tabs.
  • Naming of norms:
    The previous norms have now been labeled standards.
  • New: Degree days.
    Degree days can now also be configured and linked.
  • Variable linking:
    Variables are linked in a separate tab. The following can be linked to each variable:
    • A price
    • A degree day
    • Several standards
  • ActiveX control:
    The possibility of starting the Editor using an ActiveX control, such as in zenon, has been removed.

New control for reports

For all report templates that use equipment models, there is a new control available - Equipment model - expanded levels. It allows, in ZAMS, the setting of how far levels of the equipment model are open during configuration in the Report Launcher.

SQL Server 2016 and new instance ZA3

MS SQL Server 2016 is used as an SQL server for the database.

The instance name for the database of zenon Analyzer version 3.00 is ZA3. This is issued as fixed and cannot be changed.

zenon Analyzer of versions 2.XX and 3.XX can be operated at the same time. components that can only be installed once per computer, such as Connector Container or the Licensing Service, work throughout all versions.

Hydroelectric power plant analysis theme updated

The Stored Procedures for reports from the hydroelectric power plant theme was changed.

In order for existing reports to be able to be used, they must be prepared again. In doing so, the query about overwriting elements must be responded to with yes.

Other topics in this chapter

NVARCHAR(MAX) data type for transfer parameters with list character

Connection security

Dynamic normalization and custom formulas

Renaming report templates and display of data


NVARCHAR(MAX) data type for transfer parameters with list character

zenon Analyzer -> Upgrade information -> NVARCHAR(MAX) data type for transfer parameters with list character

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

ZAMS now creates, for UDFs and SPs that serve to transfer a value list, the respective parameters with the data type NVARCHAR(MAX). This concerns, for example, equipment group multiple selection, variable multiple selection, etc.

The following transfer parameters now have the data type NVARCHAR(MAX) (grouped according to SP/UDF):

  • Alarm_Aggregate_Class
    • ProjectIDs
    • AlarmClasses
    • GroupPreFilter
  • Alarm_Aggregate_Class2
    • ProjectIDs
    • AlarmClasses
    • GroupPreFilter
  • Alarm_Aggregate_Comment
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_Aggregate_Comment2
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_Aggregate_Equipment
    • ProjectIDs
    • EquipmentIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_Aggregate_Equipment2
    • ProjectIDs
    • EquipmentIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_Aggregate_Group
    • ProjectIDs
    • AlarmGroups
    • ClassPreFilter
  • Alarm_Aggregate_Group2
    • ProjectIDs
    • AlarmGroups
    • ClassPreFilter
  • Alarm_Aggregate_Project
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_Aggregate_Project2
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_GetClassReferenceList
    • ClassIdList
  • Alarm_GetGroupReferenceList
    • GroupIdList
  • Alarm_List
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_List_Comment
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_List_Equipment
    • ProjectIDs
    • EquipmentIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_MostLong
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_MostLong2
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_MostLong_Equipment
    • ProjectIDs
    • EquipmentIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_MostLong_Equipment2
    • ProjectIDs
    • EquipmentIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_MostOften
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_MostOften2
    • ProjectIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_MostOften_Equipment
    • ProjectIDs
    • EquipmentIDs
    • ClassPreFilter
    • GroupPreFilter
  • Alarm_MostOften_Equipment2
    • ProjectIDs
    • EquipmentIDs
    • ClassPreFilter
    • GroupPreFilter
  • Archive_GetAggregatedData
    • Variables
  • Archive_GetDynamicAggregatedTrendData
    • Variables
  • Archive_GetPlainTrendData
    • Variables
  • ArchiveEx_GetAggregatedEquipmentCostData
    • Equipments
    • Projects
  • ArchiveEx_GetAggregatedEquipmentTrendData
    • Equipments
    • Projects
  • FNB_LossTimesLotHistory
    • PalletFilterValues
    • CrateFilterValues
    • BottleFilterValues
    • TankFilterValues
  • FNB_OeeData
    • PalletFilterValues
    • CrateFilterValues
    • BottleFilterValues
    • TankFilterValues
  • FNB_OeeLotHistory
    • PalletFilterValues
    • CrateFilterValues
    • BottleFilterValues
    • TankFilterValues
  • FNB_WaterfallData
    • PalletFilterValues
    • CrateFilterValues
    • BottleFilterValues
    • TankFilterValues
  • HppEventCounters
    • ActivePowerRanges
    • RpmRanges
  • ISO50001_GetCarpetPlotData
    • Variables
  • ISO50001_GetEquipmentLoadDurationCurveData
    • Projects
    • Equipments
  • ISO50001_GetLoadDurationCurveData
    • Variables
  • LineAnalysis_GetGanttData
    • Projects
    • Meanings
  • ListAlarmClasses
    • ActiveClasses
  • ListAlarmGroups
    • ActiveGroups
  • ListArchivesForProjects
    • Projects
  • ListEquipmentTree_ChildMeanings
    • RequiredVariableMeanings
  • ListEquipmentTree_Gantt
    • Projects
    • Meanings
  • ListEquipmentTree_Meanings
    • RequiredVariableMeanings
  • ListEquipmentTree_MeaningsAndChildMeanings
    • RequiredVariableMeanings
    • RequiredVariableChildMeanings
  • ListEquipmentTree_MeaningsWithPrefix
    • RequiredVariableMeanings
    • RequiredVariablePrefixMeanings
  • ListVariablesArchiveEx
    • ProjectIDs
    • EquipmentIDs
  • ListVariablesForArchives
    • Archives


Connection security

zenon Analyzer -> Upgrade information -> Connection security

Communication in zenon Analyzer can now be carried out in encrypted form. With the exception of encryption, the communication is to the Connector Container. For the secure connection, the respective components must be of version 3.00 or higher.
Configuration is via ZAMS and is used to establish a connection and for communication.

Encryption services

Service

Server

Client

SQL server

Decides on encryption.

No configuration necessary.

Report Server

Decides on encryption.

The server needs a certificate.

Clients for Report Launcher web server must use the URL for connection (HTTP or HTTPS).

License service

Decides on encryption.

Clients need the connection password.
A change password is required for authentication in the event that changes are made using ZAMS or the migration tool.

These passwords can be saved with connection profiles. Clients without a user interface read their configuration from the entries for the license service.

Note: Saved passwords can only be reused for unchanged PC hardware and the same Windows user.

You can also create the certificates required for encryption yourself.

info Information

For report developers, there is a tool that can be used to reset the configuration. For details, see the zenon Analyzer for developers manual; Tool: Analyzer Security Configuration section.

Protocols and encryption

Overview of services and their encryption:

Service/connection

Protocol

Encryption

Authentication

License service

TCP

AES 256

Hashes: SHA 256

Password.

  • Server: Passwords are encrypted depending on the hardware when saving.
  • Applications: Passwords can be saved as an option and are encrypted depending on the hardware and the user.

SQL Server Instance

TCP

SSl

Windows user (recommended) or separate password for SQL server.

Reporting services service

HTTP

SSl

Windows users.

SQL server instance connection to connector container

TCP

none

Recommendation: In the firewall before the Runtime server, only allow communication via port 50778 (connector container) to clients that need it.

Operation without encryption

If zenon Analyzer is operated without encryption activated, the following is recommended:

  • No Internet connection for computers with databases.
  • No Internet connection for license server.
  • Remote access via VPN only.


Dynamic normalization and custom formulas

zenon Analyzer -> Upgrade information -> Dynamic normalization and custom formulas

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Changes to tables were made for dynamic normalization. In addition, the calculation for custom formulas was enhanced.

Dynamic normalizations: Expansion of the NORM table and PRICE table

The NORM table for dynamic normalization was replaced with three new tables:

  • NORM_DEFINITION: Contains the definitions of the norm curves.
  • NORM_VALUES: Contains the value lists of the norm curves.
  • VARIABLENORM: Contains the allocation of the norm curves to the variables.

The PRICE table for dynamic normalization was replaced with three new tables:

  • PRICE_DEFINITION: Contains the definition of the price curves.
  • PRICE_VALUES: Contains the value lists of the price curves.
  • VARIABLEPRICE: Contains the allocation of the price curves to the variables.

Conversion

The following happens when converting the database from zenon Analyzer 2.20 to 3.00:

  • The new tables are created
  • Values of old tables are transferred to new tables:
  • Old tables are deleted

Process for transfer of values: A new curve is defined for variables in the old tables that have the same curve. All variables refer to this curve. The amount of data is thus minimized.

Amending reports

To keep existing reports compatible:

  1. Provide an example of each report concerned again after migration of the database via ZAMS.
  2. Activate the option to overwrite the SQL elements.

Formulas: Enhancement of the custom formulas

The dialog for the configuration of formulas was enhanced with tabs for standard fields and temperature normalization fields. To do this, stored procedures were enhanced and new UDFs were added.

Existing reports with custom formulas must be converted for the new version.
This concerns the following report templates:

  • Custom Formula Trend
  • Custom Formula Trend Comparison
  • Custom Formula Aggregated Trend
  • Custom Formula Aggregated Trend Comparison
  • Custom Formula Aggregation
  • Custom Formula Aggregation Comparison
  • Formula based Efficiency Report
  • Formula based Efficiency Comparison Report

There are two methods available for the conversion. They are different for:

  • Reports that were not edited in the Report Builder
  • Reports that must also be converted for the changes in the Report Builder

With both methods, it is important that the SQL elements must be overwritten in ZAMS.

Reports without subsequent editing in the Report Builder

To convert reports that were not edited in the Report Builder:

  1. Open all affected reports in ZAMS.
  2. Ensure that all elements are overwritten during preparation:
    • Report on the hard disk
    • Report on the server
    • SQL elements
  3. Prepare all reports.

Reports with changes in the Report Builder

To convert reports that were edited in the Report Builder:

  1. In ZAMS, for each report, open a report that is the same type as the report concerned.
  2. Ensure that reports on the server are not overwritten.
  3. Ensure that all SQL elements are overwritten during preparation.
  4. Prepare all reports.
  5. Open all reports concerned in the Report Builder.
  6. In the main Datasets, open the properties and click on Update fields. (you may need the access data for access to the SQL-Server instance.)

    Main datasets:

    • IndicatorData
    • IndicatorData1
    • IndicatorData2
    • EfficiencyData
    • EfficiencyData1
    • EfficiencyData2
  7. For the @Norms parameter, enter ="" as a value expression.
  8. For the @TemperatureNormalizations parameter, enter ="" as a value expression.
  9. Save the report.


Renaming report templates and display of data

zenon Analyzer -> Upgrade information -> Renaming report templates and display of data

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A number of report templates have been renamed. The forms of data display were also amended in the process.

Report templates

Amended report templates in the Extended Historian analysis theme:

Up to version 2.20 | From version 3.00
Trend per Variable | Historian Aggregated Trend with Equipment Group and Variable Selection
Trend per Variable Comparison | Historian Aggregated Trend Comparison with Equipment Group and Variable Selection
Trend per Equipment Group | Historian Aggregated Trend per Equipment Group
Trend per Equipment Group Comparison | Historian Aggregated Trend Comparison per Equipment Group
Relative Trend per Variable | Relative Historian Aggregated Trend with Equipment Group and Variable Selection
Relative Trend per Variable Comparison | Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection
Relative Trend to Standard | Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard
Relative Trend to Standard Comparison | Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard
Distribution per Variable | Relative Historian Aggregation with Equipment Group and Variable Selection
Distribution per Variable Comparison | Relative Historian Aggregation Comparison with Equipment Group and Variable Selection
Cost Distribution per Variable | Cost Aggregation with Equipment Group and Variable Selection
Cost Distribution per Variable Comparison | Cost Aggregation Comparison with Equipment Group and Variable Selection
Cost distribution per Equipment Group | Cost Aggregation per Equipment Group
Cost distribution comparison per Equipment Group | Cost Aggregation Comparison per Equipment Group

Data representation

The display of data for the Extended Historian analysis has been enhanced. The following is now available:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

attention Attention

Note for the renaming:

  • The previous table has been renamed to grouped table.
  • A table was introduced as a flat table.


Technical basics

zenon Analyzer -> Technical basics

The zenon Analyzer:

  1. acquires data
  2. compresses data
  3. manages meta data such as equipment structure
  4. manages templates
  5. manages access rights and authorizations
  6. calculates evaluations
  7. distributes evaluations to Clients

attention Attention

Variable names must not contain two or more consecutive spaces. If several consecutive spaces are included, this can lead to a Javascript error when called up in the Report Launcher (Error 500).

General requirements

zenon Analyzer needs for:

  • the creation and management of reports:
    • An SQL Server 2016 database and
    • the SQL Server 2016 reporting services
  • the display of reports: Browser

A good knowledge of SQL and MS Report Builder 3.0 is required in order for you to create your own reports.

For details about the technical requirements see chapter Technology.

Hardware and software requirements

Hardware

Analyzer Server:

Parameters | Recommended | Minimum
CPU | Quad-Core Server CPU (maximum 24 cores/4 sockets) | Quad-core
RAM | Up to 128 GB | 12 GB
Free memory | 200 GB | 10 GB

Engineering computer:

Parameters | Recommended | Minimum
CPU | Dual Core | Pentium IV
RAM | 4 GB | 1 GB
Free memory | 200GB | 2 GB
Monitor (pixels) | 1920 x 1080 | 1024 x 768

Software

Analyzer Server:

A 64-bit operating system is required for the database server. The following are supported:

  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows 8.1 64-Bit
  • Windows 8.1 Pro 64-Bit
  • Windows 8.1 Enterprise 64-Bit
  • Windows 8 64-Bit
  • Windows 8 Pro 64-Bit
  • Windows 8 Enterprise 64-Bit
  • Windows 10 Home 64-Bit
  • Windows 10 Professional 64-Bit
  • Windows 10 Enterprise 64-Bit

Note: An installed IIS service is required for the installation of the server.

Engineering computer:

The following are supported for ZAMS, the manual data editor, metadata editor and migration tool:

  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows 8.1 32-Bit and 64-Bit
  • Windows 8.1 Enterprise 32-Bit and 64-Bit
  • Windows 8 32-Bit and 64-Bit
  • Windows 8 Pro 32-Bit and 64-Bit
  • Windows 8 Enterprise 32-Bit and 64-Bit
  • Windows 10 Home 32-Bit and 64-Bit
  • Windows 10 Professional 32-Bit and 64-Bit
  • Windows 10 Enterprise 32-Bit and 64-Bit

Web browser:

  • Internet Explorer 11 (normal view only)
  • Internet Explorer 10 (normal view only)
  • Chrome
  • Firefox

    Note: Zoom in the report is only possible with Chrome.

Recommended HMI/SCADA system:

  • zenon 7.50.

.NET Framework 4.6.1:

  • .NET Framework 4.6.1 has to be already run capable on the target computer in order to end the installation successfully.

Data preparation

The data preparation is done in several levels. With this data from different sources and formats can be evaluated universally and maintained easily.

Data structures

The data origin either from static project data or from dynamic user data. For details see chapter Data structure.

Data collection

The zenon Analyzer accesses data non-invasively via connectors. Source systems need not be reconfigured. The existing infrastructure is embedded in the reporting of the zenon Analyzer independent of the manufacturers. For systems other than zenon 6.x, only a connector container is installed. This installation does not interfere in the Runtime system and does not interrupt the process.

Other topics in this chapter

Technology

Architecture

Time formats

Prerequisites


Technology

zenon Analyzer -> Technical basics -> Technology

In this section you learn about the technically needed requirements for

  • Server
  • Client
  • Data Sources
  • Development station

and the supported standards for

  • Interfaces

Server

SQL Server 2016 Database

In the database there are the meta data and possibly also user data saved in SQL. For the query, stored procedures (Level 2) are executed. They again revert to user defined functions for data acquisition and data abstraction. If needed, they load the connector stub which requests the user data from the target system online. In addition there are the user defined functions which provide auxiliary functions for the evaluation.

SQL Server 2016 Reporting Services

The reporting services run as web application and as web server provide the Clients with all reports for displaying in the web browser. In addition, the parameters for the data source, reports, etc. are set using the Report Launcher web front end.

The path to Report Launcher is: http://[computer name]/Reports_za3.

Reporting license service (zrsLicSrv)

The reporting license service checks the CodeMeter dongle and the license available at the Server and forwards the licensing information to all involved components. It also has the list of all Client leases.

Data source

Connector container

On all computers which can server as data source, the connector container together with its different connectors must be installed and started. The TCP port of the connector container must be reachable from outside.

Development station

Analyzer Export Wizard

The Analyzer Export Wizard is integrated in the zenon Editor and is used to import the metadata to the SQL Server 2016 database. The wizard offers full support for zenon 7.xx. Older versions of the zenon Editor are not supported.

Interfaces

The zenon Analyzer supports the following interfaces:

  • zenon Runtime 5.50, 6.x, 7.x
  • SQL

Other topics in this chapter

Client


Client

zenon Analyzer -> Technical basics -> Technology -> Client

There must be a web browser on the client to display and configure reports.

info Information

zenon Analyzer was designed and tested for the following browsers:

  • Microsoft Internet Explorer from version 10
  • Chrome
  • Firefox

Note:

  • Compatibility view must be deactivated for Internet Explorer.
  • Zoom is only available for the Chrome browser.

Double click in the tree structure for equipment model dependent on browser

Different browsers react differently to a double click on a node in the tree structure:

  • Internet Explorer:
    The opposite of the currently visible stats of the node that has been clicked on is passed on to the lower objects and transferred to the nodes.
    For example: The checkbox of the node is not ticked. Double clicking ticks the checkboxes of the node and all its sub-items.
  • Chrome and Firefox:
    The current status does not change and is passed on to the lower objects.
    For example: The checkbox of the node is not ticked. Double clicking does not tick the checkboxes of the node and all its sub-items.


Architecture

zenon Analyzer -> Technical basics -> Architecture

The zenon Analyzer links data from different, heterogeneous sources to valid reports in real time. The reports react dynamically to data base changes.

Communication from process point of view

Communication from data point of view

zenon Analyzer

The zenon Analyzer consists of:

  • Data sources
  • Connectors to the data sources
  • Container for connectors and data harmonization
  • Data filing
  • Report Builder with filter and calculations
  • zenon Analyzer Management Studio for creating and administering reports
  • Web Server
  • User interface at the Client for calling up and managing reports at the Client

Processes

Reports are configured and published by administrators or users.

Reports can also be created by the administrator using Microsoft Report Builder 3.0. Prerequisite is a wide knowledge in SQL. For information about MS Report Builder refer to the corresponding help of the Microsoft Report Builder. End-users call up reports via the interface of their Client.

Data required for the report is collected via connectors and harmonized before use. With this, reports are also meaningful for different sources, time zones, etc.


Time formats

zenon Analyzer -> Technical basics -> Time formats

Three time formats are used:

  • Local time: is used in reports
  • UTC: is used in abstracted historical and current values and in database tables
  • Unix time: is used in SQL tables

Local Time

Queries in the report and the display of results is done in local time.

UTC

Abstracted historical and current values are stated in UTC. For the display in the reports it is converted to local time.

UTC means Coordinated Universal Time. The time unit is second. UTC is the uniform basis for the international time determination and is made available to the public via time senders and other time services. Dependent on the time zone certain time periods must be added or subtracted to or from UTC. This time period can vary one hour because of the day light saving time.
Example:

Country | Local time
Alaska | UTC -9
Australia, Queensland | UTC +10
Bulgaria | UTC +2
United Kingdom | UTC
Korea | UTC +9
Central Europe (CET) | UTC +1
Central Europe (CET) Daylight Saving Time | UTC +2
Saudi Arabia | UTC +3
USA East coast | UTC -5
United Arabic Emirates | UTC +4

Consequences to the configuration

Engineered date and time mean different date and time depending on the execution location of the Runtime.

For example: In the Editor you engineer in the PFS for the execution of a function in time zone UTC +1 the local time 14:00 o' clock. After transferring the files to a Runtime in tiem zone UTC +10, the function is carried out at 23:00 o' clock. Unix time

In the SQL databases Unix time is used, e.g..:

  • evacuated archives
  • exported archives
  • exported alarms
  • exported CEL

Procedure

  • Query in reports are dispalyed in local time.
  • The hand over from report to the table valued user defined functions is done in UTC.
  • Query to SQL are converted to Unix time.
  • Results are converted to UTC and displayed in the report as local time.

Change standard time/day light saving time

The switch from standard time to daylight saving time and vice versa can lead to anomalies with intervals at the time of switching. These arise as a result of the functions provided by the .NET Framework , DateTime.ToLocalTime and DateTime.ToUniversalTime.

Intervals

Compression

DSTstart

DSTend

Minutes
  • Interval in local time: DSTstart – 1 minute, DSTstart + 1 hour)
  • Interval in UTC: 1 minute
  • Interval in local time: DSTend –1 minute, DSTend
  • Interval in UTC: 1 hour and 1 minute

Hour

Interval (DSTstart, DSTstart+1) is not present.
  • Interval in local time: DSTend –2, DSTend –1
  • Interval in UTC: 2 hours

Key:

  • DSTstart: Time of the switch from standard time to daylight-saving time in local time.
    This means: The clocks are moved forward by 1 hour at the time of DSTstart.
  • DSTEnd: Time of the switch from standard time to daylight-saving time in local time.
    This means: The hours are put back by 1 hour at the time of DSTend.

The zrsGetCompressionIntervallsCarpetPlot UDF is used for the calculations.


Prerequisites

zenon Analyzer -> Technical basics -> Prerequisites

The following prerequisites are applicable for work with the zenon Analyzer:

Analyzer server hardware and software

Hardware

Analyzer Server:

Parameters | Recommended | Minimum
CPU | Quad-Core Server CPU (maximum 24 cores/4 sockets) | Quad-core
RAM | Up to 128 GB | 12 GB
Free memory | 200 GB | 10 GB

Engineering computer:

Parameters | Recommended | Minimum
CPU | Dual Core | Pentium IV
RAM | 4 GB | 1 GB
Free memory | 200GB | 2 GB
Monitor (pixels) | 1920 x 1080 | 1024 x 768

Software

Analyzer Server:

A 64-bit operating system is required for the database server. The following are supported:

  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows 8.1 64-Bit
  • Windows 8.1 Pro 64-Bit
  • Windows 8.1 Enterprise 64-Bit
  • Windows 8 64-Bit
  • Windows 8 Pro 64-Bit
  • Windows 8 Enterprise 64-Bit
  • Windows 10 Home 64-Bit
  • Windows 10 Professional 64-Bit
  • Windows 10 Enterprise 64-Bit

Note: An installed IIS service is required for the installation of the server.

Engineering computer:

The following are supported for ZAMS, the manual data editor, metadata editor and migration tool:

  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows 8.1 32-Bit and 64-Bit
  • Windows 8.1 Enterprise 32-Bit and 64-Bit
  • Windows 8 32-Bit and 64-Bit
  • Windows 8 Pro 32-Bit and 64-Bit
  • Windows 8 Enterprise 32-Bit and 64-Bit
  • Windows 10 Home 32-Bit and 64-Bit
  • Windows 10 Professional 32-Bit and 64-Bit
  • Windows 10 Enterprise 32-Bit and 64-Bit

Web browser:

  • Internet Explorer 11 (normal view only)
  • Internet Explorer 10 (normal view only)
  • Chrome
  • Firefox

    Note: Zoom in the report is only possible with Chrome.

Recommended HMI/SCADA system:

  • zenon 7.50.

.NET Framework 4.6.1:

  • .NET Framework 4.6.1 has to be already run capable on the target computer in order to end the installation successfully.

Connectors

The following applies for connectors:

  • Timeout: 5 minutes (independent of report timeout)
  • Variables: Only variables that are listed in metadata are requested
  • String variable: maximum of 4000 characters

The performance of a connector depends on the:

  • Performance of the Analyzer server
  • Performance of the Runtime server
  • Load of the Runtime servers (connector runs with low priority)
  • Network performance and network load

Projects and filters

Reports on several projects can be created, except when using filters for shifts or lots. In this case, reports are limited to one project.

attention Attention

Only archive data with variables from its own project can be evaluated.

This means: For example, in an integration project, if a variable from a subproject is archived in an archive, then zenon Analyzer cannot access this variable.

Schedules

  • Days per month are limited to 1 - 28 (corresponds to February in non-leap years)
  • The "Month end" event is not available

Analyzer Export Wizard

The Analyzer Export Wizard works with zenon from version 7.10 SP0. There is a separate wizard available for each supported version of zenon.


Installation and updates

zenon Analyzer -> Installation and updates

The installation of zenon Analyzer consists of several components:

  • Analyzer Server:
    Central SQL server.
    Note: Before installation, the IIS service must be installed on the operating system.
  • zenon Analyzer Management Studio:
    Tool for the administration of zenon Analyzer and to create reports. It must be installed on the engineering computer:

You can find the hardware and software requirements in the Prerequisites chapter.

Note:

  • .NET Framework 4.6.1
    .NET Framework 4.6.1 has to be already run capable on the target computer in order to end the installation successfully. Otherwise, an error notification from the <CD-ZRS> setup will show up and the installation process will be canceled.
  • Remote installation
    The installation medium must be on the local computer. Network drives may not be available punctually for a reboot during installation. For remote installations and virtual installations, copy the content of the installation medium to a temporary folder on the computer and start the setup.

attention Attention

Ensure that you have the appropriate licenses.

Note for wizards

There are three wizards available from version 7.10 for zenon Analyzer for use with the SCADA system zenon:

  • Analyzer Export Wizard
  • Meaning and Waterfall Chart Wizard
  • Sankey Wizard

Wizards have no longer been installed with <CD_ZRS since zenon Analyzer 2.20 >. From zenon 7.20, installation is carried out with the installation of zenon. For zenon versions 7.10 and 7.11, the wizards can be installed or updated manually using build setups.

To install wizards manually:

  1. Open the \zenon_Build_Setups folder on the zenon Analyzer installation medium.
  2. Select the desired build.
  3. Start the installation.

Attention: With a build update, the complete version of zenon on the computer is updated to the selected build. Only builds for already-installed versions can be executed.

Carrying out the installation

To install zenon Analyzer components:

  1. Ensure that the components required for installation are already installed on the system.
    • General: .NET Framework 4.6.1
    • Server: IIS service
  2. Connect the installation medium to the computer or copy its contents to a local folder.
    If Autorun does not automatically start the setup, use the file named start.exe.
  3. Select the desired language from the drop-down list
  4. Accept the license agreements
  5. Click on the Next button.
  6. Select the desired components
  7. Click on the Next button.

    The installation or the update will start.

  8. Follow the instructions given to you by the installation wizard.

Start window

Parameters

Description

Drop-down list "Language"

Selection of the language for the installation. The following are available:

  • German
  • English
  • French
  • Italian
  • Spanish

License agreements

License agreement with conditions of use for zenon Analyzer. For installation, the requirements must be accepted by clicking on the I accept the conditions of the license agreement checkbox.

Next

Switches to the next step of the installation. Only active if the license agreements have been accepted.

Module selection

Parameters

Description

Module selection

Selection of the components to be installed by activating the corresponding checkbox.

  • Analyzer Server:
    Central SQL server.
    Requirement: 64-bit operating system and installed IIS service.
  • Demo project and demo reports:
    Example database
    Requirement: 64-bit operating system and zenon 7.50.
  • zenon Analyzer Management Studio:
    Tool to create and administer sever connections and reports.
    Pre-requisite: 32-bit or 64-bit operating system.
  • Metadata database editors

Serial Number

Entry of the serial number for licensing.

Only present if the Analyzer Server is to be installed. If there is already a serial number on the system, this is entered automatically.

Activation number

Entry of the activation number.

Only present if the Analyzer Server is to be installed. If there is already an activation number on the system, this is entered automatically.

Next

Starts the installation. Only active if modules are selected for installation.

Symbols module selection

Symbol | Meaning
 | Installation can be carried out.
 | Installation not possible.

Installation progress

The course of installation is shown in its own window with symbols:

Symbol | Meaning
 | Not yet installed
 | Is currently being installed
 | Installation OK
 | Installation failed

After successful installation of all desired components, end the installation wizard by clicking on the End button.

Installation on the Client

Only a current browser is needed on the client. The language that is set in the browser determines the language for the Report Launcher. The language for zenon Analyzer Management Studio is specified in the ZAMS options.

Other topics in this chapter

Licensing

Uninstallation of zenon Analyzer version 1.6 and 2.0

IIS Publishing service installation


Licensing

zenon Analyzer -> Installation and updates -> Licensing

In order to license the zenon Analyzer a CodeMeter dongle is a prerequisite.

There are the following restrictions without a valid license:

  • No external access via the default access site is possible.
  • There is no connector functionality
  • Report templates and reports cannot be used.
  • ZAMS only provides the following functionality without a license:
    • Information on servers and licenses
    • Input of licenses
    • Start Metadata Editor
    • Start Manual Data Editor
    • Start Migration Tool
    • Configuration of color scheme
    • RDL template
    • Configuration of settings
    • Displays of version information
    • Opening the help

Entry of the license data is carried out during installation for the Analyzer Server and via the zenon Analyzer Management Studio or the zenon licensing for all other components as required.

Note: A new zenon Analyzer license is only accepted if you have enough client licenses for all users with a dedicated license.

Licensing in workgroups

For licensing for computers that are not in domains, but in Windows workgroups, note the procedure in the Licensing in workgroups chapter.

Licensing via ZAMS - zenon Analyzer Management Studio

To enter new license data:

  1. Select, in the Analyzer Server menu or in the Display license dialog, the Enter new license command
  2. the drop-down list with the license information is opened
  3. enter serial number and activation number
  4. Click on Check new license
  5. If the result is positive, click on OK to activate the license

Enter dialog license

Parameters

Description

Serial number

Entry of the serial number.

Activation key

Entry of the activation key.

Test new license

Clicking on this button tests inputs before they are written to the license server, to see if:

  • License data entered has the correct syntax
  • a license can be occupied on a CodeMeter dongle with the data entered
  • The activation key corresponds with the serial number

In order for the test to be started, both serial number and activation key must have been entered.

Test result

Displays the test result of Test new license.

OK

Writes the license entered to the license service on the Analyzer server and closes the dialog. The result of writing the license is displayed in the output window.

In order for the license data to be written, both serial number and activation key must have been entered.

Cancel

Closes the dialog without writing data to the license service.

attention Attention

If incorrect license data is entered, the access to the Analyzer server is blocked for all clients. Always check the new license data by clicking on the Test new license button before you set the license by clicking on OK.

Entry in zenAnalyzer.ini

The license information are saved in file zenAnalyzer.ini in the zenon system folder.

  • Section [DEFAULT])
    • Entry SERIAL7=
    • Entry ACTIVATIONKEY7=

The CodeMeter check and management of simultaneous access is done via service zrsLicSrv.

For details about licensing and the CodeMeter dongle, see the Licensing manual, CodeMeter chapter.

Other topics in this chapter

Licensing in workgroups


Licensing in workgroups

zenon Analyzer -> Installation and updates -> Licensing -> Licensing in workgroups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Licensing for workgroups is different from the licensing for domains.

Requirements

For licensing within workgroups, the zenon Analyzer License Service must work in Workgroup mode.
To do this, the following requirements must be fulfilled:

  • The computer that acts as the Analyzer Server must be a member of the workgroup.
  • All users of the workgroup must also exist on the Analyzer Server.
  • The license service on the Analyzer Server must run in the user context of a user of the workgroup. Other computers of the workgroup are thus recognized as members of the group.

Changing license service user context

This is how you change the user context for the license service:

  1. Open the administration of the local services.
  2. Go to the zrsLicSrv service.
  3. Stop the service.
  4. Click on Properties in the context menu of the service.

    The dialog with the properties of the service is opened.

  5. Open the Log in tab.
  6. Activate the This account radio button.
  7. Enter the user name, password and password confirmation for the desired user.
  8. Close the dialog by clicking on OK.
  9. Start the service.


Uninstallation of zenon Analyzer version 1.6 and 2.0

zenon Analyzer -> Installation and updates -> Uninstallation of zenon Analyzer version 1.6 and 2.0

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

General recommendations

  • Test installations: These are best installed in a virtual environment.
  • Prerequisites: Can also be required by other programs. Only uninstall these if you are sure that they are no longer needed.
  • LOG files: Can be deleted in principle.
  • Registry: Changes to entries should only be made by qualified people.

Uninstallation

Depending on the components installed, the uninstallation processes are different for:

  • zenon Analyzer 1.6
  • zenon Analyzer 2.0

Other topics in this chapter

Uninstallation of zenon Analyzer 1.6

Uninstallation of zenon Analyzer from version 2.0


Uninstallation of zenon Analyzer 1.6

zenon Analyzer -> Installation and updates -> Uninstallation of zenon Analyzer version 1.6 and 2.0 -> Uninstallation of zenon Analyzer 1.6

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Installed components

The installation of zenon Analyzer 1.6 consists of the prerequisites and four main categories.

Prerequisites

  • Microsoft Visual C++ 2010 Redistributable Package (x86)

Categories

  • Analyzer (Server)
  • Analyzer Connector
  • Analyzer Wizard (can only be installed if the zenon 6.51 Editor is already present)
  • Analyzer Assistant

Uninstallation

Analyzer (Server)

  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer
  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: License
  • Delete folder: C:\ProgramData\COPA-DATA\zenonAnalyzer

Analyzer Connector

  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: Connectors
  • Delete folder: C:\Program Files (x86)\Common Files\COPA-DATA\Connectors
  • Delete the registry entry:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run]
    COPA-DATA Connector=C:\Program Files (x86)\COPA-DATA\zenonAnalyzer\zrsConnector.exe

Analyzer Export Wizard

  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: Export Wizard
  • Delete folder: C:\ProgramData\COPA-DATA\zenon651\WizardsVSTA\ZRS_MetadataExport
  • Configure the file C:\ProgramData\COPA-DATA\zenon651\WizardsVSTA\wizards.ini:

    [DEFAULT]
    COUNT=x -> decrement to x-1
    [WIZARD_X] -> delete complete entry with all sub-lines

Analyzer Assistant

  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: Report_Assistant
  • Delete folder: C:\Program Files (x86)\COPA-DATA\zenon Analyzer


Uninstallation of zenon Analyzer from version 2.0

zenon Analyzer -> Installation and updates -> Uninstallation of zenon Analyzer version 1.6 and 2.0 -> Uninstallation of zenon Analyzer from version 2.0

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Installed components

The installation of zenon Analyzer from version 2.0 consists of four main categories:

  • Analyzer (Server)
    • Demo projects
  • ZAMS (zenon Analyzer Management Studio)
  • Analyzer Connector
  • Analyzer Wizard

Uninstallation

Analyzer (server)/demo projects

  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: Server
  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: License
  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: Demo
  • Delete folder: C:\ProgramData\COPA-DATA\zenonAnalyzer
  • Delete the registry entry:
    HKEY_LOCAL_MACHINE\SOFTWARE\COPA-DATA\zenonAnalyzer

zenon Analyzer Management Studio (ZAMS)

  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: Management Studio
  • Delete folder: C:\ProgramData\COPA-DATA\zenonAnalyzer
  • Delete the registry entry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\COPA-DATA\zenonAnalyzer

Analyzer Connector

  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: Connectors
  • Delete folder: C:\Program Files (x86)\Common Files\COPA-DATA\Connectors
  • Delete the registry entry:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run]
    COPA-DATA Connector=C:\Program Files (x86)\COPA-DATA\zenonAnalyzer\zrsConnector.exe

Analyzer Export Wizard

  • Uninstall: Control Panel -> Programs and Features -> zenon Analyzer: Export_Wizard
  • Delete folder: C:\ProgramData\COPA-DATA\zenon700\WizardsVSTA\Wizard_Analyzer_Export
  • Configure the file C:\ProgramData\COPA-DATA\zenon700\WizardsVSTA\wizards.ini:

    [DEFAULT]

    COUNT=x -> decrement to x-1

    [WIZARD_X] -> delete complete entry with all underscores


IIS Publishing service installation

zenon Analyzer -> Installation and updates -> IIS Publishing service installation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The IIS publishing service must be installed before the installation of zenon Analyzer on the system. The details of the process are different for different operating systems.

Windows 8 and 8.1

To activate the IIS publishing service:

  1. Press the Windows key + R keyboard shortcut.

    The dialog to enter a command for the command input is opened.

  2. Enter appwiz.cpl in the input field.

    Click on OK.
    A new control panel window to configure programs and Windows features is opened.

  3. In this window, click on Turn Windows features on or off.

    The window to select features of the operating system is opened.

  4. Expand the Internet information services in this node.
  5. Activate all World Wide Web Services there.
  6. Expand the General HTTP features node.
  7. Activate the static content.
  8. Expand the Application development features node.
  9. Activate ASP.NET 4.5
  10. Expand the Web administration tools node.
  11. There, activate the IIS administration console.
  12. Expand the Security node.
  13. Activate Windows authentication.
  14. Click on OK.

Note: The WebSocket protocol must also be activated.

Windows 10

To activate the IIS publishing service:

  1. Press the Windows key + R keyboard shortcut.

    The dialog to enter a command for the command input is opened.

  2. Enter appwiz.cpl in the input field.

    Click on OK.
    A new control panel window to configure programs and Windows features is opened.

  3. In this window, click on Turn Windows features on or off.

    The window to select features of the operating system is opened.

  4. Expand the Internet information services in this node.
  5. Activate all World Wide Web Services there.
  6. Expand the General HTTP features node.
  7. Activate the static content.
  8. Expand the Application development features node.
  9. Activate ASP.NET 4.6
  10. Expand the Web administration tools node.
  11. There, activate the IIS administration console.
  12. Expand the Security node.
  13. Activate Windows authentication.
  14. Click on OK.

Note: The WebSocket protocol must also be activated.

Windows Server 2012 (R2)

Follow the instructions from Microsoft: https://technet.microsoft.com/en-us/library/hh831475.aspx

  1. Open the Assistant to add roles and features wizard.
  2. Go to the server roles.
  3. Activate the Webserver (IIS).
  4. Expand the General HTTP features node.
  5. Activate the static content.
  6. Expand the Security node.
  7. Activate Windows authentication.
  8. Expand the Application development node.
  9. Activate:
    • .NET expandability 4.5
    • ASP.NET 4.5
    • ISAPI extension
    • ISAPI filter
    • WebSocket protocol


configuration file zenAnalyzer.ini

zenon Analyzer -> configuration file zenAnalyzer.ini

Settings for zenon Analyzer are amended in the zenAnalyzer.ini configuration file. This documentation contains information for system administrators who want to edit the INI files directly.

You can find the INI file in the following path: %cd_system%.
It is only present if the Analyzer Server is installed. If there is only Report Launcher or ZAMS on the system, there is also no zenAnalyzer.ini.

info Information

Settings should primarily be made using the user interface of zenon Analyzer. Changes to the INI files are reserved for experienced users.

zenAnalyzer.ini contains the following sections:

Section: | Description
[DEFAULT] | General settings. Contains serial number and activation number.
[NETZ] | Settings for connection security.
[USER_LEVELS] | Information on users and user authorisations.
[DEDICATED_USERS] | Configuration of dedicated users.
[CONNECTION_ZA2] | Information for connections to version ZA2 databases.
[CONNECTION_ZAX] | Information for connections to version ZA3 databases and higher.
[DEBUG] | Activation of debugging.

The sequence of the sections and the entries in the sections can vary.

Format in which the INI files are saved

Due to the system, only ANSI and Unicode are supported for reading the INI files.

attention Attention

UTF-8 format is not supported!

You should therefore always save your INI files as a text file in ANSI or Unicode format.

Other topics in this chapter

General settings [DEFAULT]

Connection security [NETWORK]

User [USER_LEVELS]

Dedicated users [DEDICATED_USERS]

Connection to ZA2 [CONNECTION_ZA2]

Connection to ZA3 and higher [CONNECTION_ZAX]

Troubleshooting [DEBUG]


General settings [DEFAULT]

zenon Analyzer -> configuration file zenAnalyzer.ini -> General settings [DEFAULT]

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

General settings for the Analyzer Server instances ZA2 and higher.

These contain the serial number and the activation key. You change these settings in ZAMS using the license product dialog.

Entry

Description

[DEFAULT]

General settings for the ZA2 instance.

SERIAL7=

Serial number for licensing of a version 2.xx server. Is set by the license server.

Default: 0000

ACTIVATIONKEY7=

Activation key for activation of the license of a version 2.xx server. Is set by the license server.

Default: (empty)

[DEFAULT_X]

General settings for the ZA3 instance or higher.

X is a placeholder for the respective version of the instance.
Example: [DEFAULT_3] corresponds to instance ZA3.

SERIALX=

Serial number for licensing of the server from version 3.xx. Is set by the license server.

X is a placeholder for the respective version.
Example: SERIAL3= contains the serial number for version 3.xx.

Default: (empty)

ACTIVATIONKEYX=

Activation key for activation of the license of the server from version 3.xx. Is set by the license server.

X is a placeholder for the respective version.
Example: ACTIVATIONKEY3= contains the activation key for version 3.xx.

Default: (empty)

Serial number and activation key

These entries are set by the license server if it contains the command to use a new license. As long as the license server is running and has a valid license, these values are not read again. If the license server does not have a license or a valid license on starting, it reads these entries in an interval of 1 minute until it finds a valid license.

If one of the two entries SERIALX= or ACTIVATIONKEYX= has been amended manually in the INI file, the following situations can result:

  • The previously-used license was was invalid.
    The license server automatically reads the new entries at the next attempt to validate the license.
  • The previously-used license is valid.
    The license server does not read the new entries automatically.
    There are two methods to ensure that these new entries are read in:
    • Restart the zrsLicSrv license server service. This is the recommended method.
    • Ensure that the previously-used license becomes invalid.
      You can achieve this by removing the dongle for the previously-used license.
      Attention: Licenses for other applications that use the same dongle thus become invalid, for example zenon Editor or zenon Runtime. These applications are thus stopped.


Connection security [NETWORK]

zenon Analyzer -> configuration file zenAnalyzer.ini -> Connection security [NETWORK]

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Settings for the connection security.

These settings must only be set via ZAMS. To do this, use the Configure connection security dialog.

attention Attention

Manual changes to these entries in zenAnalyzer.ini can lead to no connection to the Analyzer Server, license server or report server being possible any more.


User [USER_LEVELS]

zenon Analyzer -> configuration file zenAnalyzer.ini -> User [USER_LEVELS]

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Settings for user authorizations.

These settings must only be set via ZAMS. To do this, use the Analyzer applications access rights dialog.

attention Attention

Manual changes to these entries in zenAnalyzer.ini may lead to the connection to Analyzer Server no longer being possible.

These entries are written by the license server if it receives a corresponding command. The entries are read when the license server starts. Manual changes to the INI file are only taken into account if the license server service zrsLicSrv is restarted.


Dedicated users [DEDICATED_USERS]

zenon Analyzer -> configuration file zenAnalyzer.ini -> Dedicated users [DEDICATED_USERS]

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Settings for dedicated users with a fixed license.
You change these settings in ZAMS using the Users with fixed license dialog.

These entries are written by the license server if it receives a corresponding command. The entries are read when the license server starts. Manual changes to the INI file are only taken into account if the license server service zrsLicSrv is restarted.

Entry

Description

[DEDICATED_USERS]

Assignment of fixed license to users of an Analyzer Server instance ZA2.

Configuration is carried out by means of the following entries:

  • DEDICATED_USERS_COUNT=: Number of dedicated users.
  • DEDICATED_USER_X=: Assignment of licenses to user names in consecutive numbering.

DEDICATED_USERS_COUNT=

Number of dedicated users.

Example: DEDICATED_USERS_COUNT=4 means that dedicated licenses have been given to four users.

Default: 0

DEDICATED_USER_X=

Assigns a dedicated license to a user If the value for DEDICATED_USERS_COUNT= is 0, this entry is empty.

X stands for the consecutive numbering of the users.

  • Minimum: 0
  • Maximum: Value from DEDICATED_USERS_COUNT= minus 1

Default: (empty)

[DEDICATED_USERS_X]

Configuration for users of an instance ZA3 or higher. Corresponds to the configuration in [DEDICATED_USERS].

X is a placeholder for the respective version of the instance.
Example: Entries in the [DEDICATED_USERS_3] section configure dedicated licenses for users of an Analyzer Server instance ZA3.

Example

[DEDICATED_USERS 3]

DEDICATED_USERS_COUNT=3

DEDICATED_USER_0=User1

DEDICATED_USER_1=User2

DEDICATED_USER_2=User3


Connection to ZA2 [CONNECTION_ZA2]

zenon Analyzer -> configuration file zenAnalyzer.ini -> Connection to ZA2 [CONNECTION_ZA2]

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Entries for the Connector Stubs connection to a Connector Container. These entries cannot be created with a tool. They must therefore be changed manually in the INI file if necessary.

The entries are read if the first Connector function after the SQL Server start that needs a connection with a Connector Conatainer is executed. If these entries are amended, it must be ensured that the Connector Stub uses the new entries. To do this, the SQL-Server instance that is used for Analyzer 2.xx must be restarted.

Entry

Description

[CONNECTION_ZA2]

Configuration of the database connection of the Connector Stub components that establish the connection to the Connector Container.

These settings only relate to the connection to an Analyzer Server instance ZA2. Connections to other instances are configured by means of the settings in Connection to ZA3 and higher [CONNECTION_ZAX].

USER=

User name for the connection.

Default: ReportingUser

PW=

Password for the connection.
The password can be entered as open or encrypted.

Note: Entry of an encrypted password is not possible via the INI file.

Default: Copa-Data

SQLINSTANCE=

Denotes the SQL server instance to which the connection is to be made.

Default: Localhost\ZA2


Connection to ZA3 and higher [CONNECTION_ZAX]

zenon Analyzer -> configuration file zenAnalyzer.ini -> Connection to ZA3 and higher [CONNECTION_ZAX]

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Entries for the Connector Stubs connection to a Connector Container. These entries cannot be created with a tool. They must therefore be changed manually in the INI file if necessary.

The entries are read if the first Connector function after the SQL Server start that needs a connection with a Connector Conatainer is executed. If these entries are amended, it must be ensured that the Connector Stub uses the new entries. To do this, the SQL-Server instance that is used for Analyzer 3.xx (or higher) must be restarted.

Entry

Description

[CONNECTION_ZAX]

Configuration of the database connection of the Connector Stub components that establish the connection to the Connector Container.

These settings only concern the connection to an Analyzer Server instance ZA3 or higher. Connections to instances of version 2.xx are configured using the settings in Connection to ZA2 [ CONNECTION_ZA2 ].

USER=

User name for the connection.

Default: ReportingUser

PW=

Password for the connection.
The password can be entered as open or encrypted.

Note: Entry of an encrypted password is not possible via the INI file.

Default: Copa-Data

SQLINSTANCE=

Denotes the SQL server instance to which the connection is to be made.

Default: Localhost\ZA3


Troubleshooting [DEBUG]

zenon Analyzer -> configuration file zenAnalyzer.ini -> Troubleshooting [DEBUG]

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Settings for debugging.

These settings can only be changed manually in the INI file.

Parameters

Description

[DEBUG]

Settings for the writing of enhanced LOG entries.

EXTENDEDLOG=

Switches the writing of enhanced log entries off or on:

  • 0: off
  • 1: on

At the time at whch the first log entry is to be written, write protection is still activated. To ensure that the first entry is also written, the license server service zrsLicSrv must be restarted.

Default: 0


Data preparation

zenon Analyzer -> Data preparation

The data preparation is done in several levels. With this data from different sources and formats can be evaluated universally and maintained easily.

  • Level 1: Data abstraction
    On the lowest level the data abstraction or data unification is done. It makes sure that the source data are always available in the same format and in the same type for the actual evaluation algorithm.
  • Level 2: Compression and calculation
    A level above the actual compression and calculation is done to create the data which should then be displayed in the report. This level is already independent of the data origin and therefore universal.
  • Level 3: Report
    The output data of the second level are then displayed graphically in the report as third level. The display in the report in turn is independent of the algorithms necessary for the calculation on the second level. This means that no calculation and no compression is carried out in the report, which exceed the mere display (e.g. formating of local times or similar).

Other topics in this chapter

Level 1: Data abstraction

Level 2: Compression and calculation

Level 3: Report


Level 1: Data abstraction

zenon Analyzer -> Data preparation -> Level 1: Data abstraction

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

At data abstraction there are two different categories of data:

  1. Engineering data

    They normally remain the same during the Runtime and are called meta data there.
    The metadata is abstracted or harmonized by the import wizard during import into the database. Regardless of their origin they are available in the format in which they are defined in chapter data structure.

  2. Runtime data
    The actual Runtime data are those data which are generally used as the base for all evaluations. They are called user data there.

    Runtime data is tapped via connectors. COPA-DATA provides a Runtime connector and SQL connector with zenon Analyzer. Individual additions can be integrated into the connectors by agreement with COPA-DATA.

Connector container

The connector container is an application (EXE) which runs at the source system and which loads and executes the connector plug-ins (DLLs). The connector container is a normal user process (no service) which is normally started together with the application which should deliver the data. The connector container opens a TCP port and waits for query requests from the connector stub whereon it loads the requested connector plug-in and invokes the fitting access function for the request. The return data is then sent to the connector stub. Several queries from different TCP connections can be executed in parallel if the source system supports this.

In normal operation the connector container is displayed as icon in the task tray and does not have an own main window. Additional status information can be displayed via a status dialog.

You can read more in the manual for report developers in the Connectors chapter.

Dialog

Parameters | Description
Number of connected Clients | Displays the number of clients connected.
Minimize | Minimizes the dialog into the info area of the task bar.
Exit | Closes the connector container.

Restart

If the connector container has been closed, it can be restarted by:

  • Restarting the computer.
  • Manual start.
    • From Windows 8: Task-Manager -> Tab -> Autostart -> Connector-Container -> Open file path-> Double-click on zrsConnector.exe.
    • Other operating systems: Open file path-> Double-click on zrsConnector.exe.
      32-bit path: %Program Files (x86)%\Common Files\COPA-DATA\Connectors


Level 2: Compression and calculation

zenon Analyzer -> Data preparation -> Level 2: Compression and calculation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

All sorts of compression and calculation of the user data prepared in level 1 is carried out in the Stored Procedures. If necessary, filter criteria are handed over to them via parameters.

The stored procedures are independent of the format of the user data and of the visual display of the result. They contain only the calculation algorithms and the filter methods with regards to the meta data.

So far as it is technical feasible, they are also independent of specific presumptions concerning the meta data; i.e. independent of specific variable names. If this is not possible, the allocation to these fixed meta data parts is implemented as an obvious block at the beginning of the stored procedures in order to separate project-specific and universal evaluation part.


Level 3: Report

zenon Analyzer -> Data preparation -> Level 3: Report

The result data generated in level 2 are formatted graphically in an SQL Server 2016 Reporting Services report. There is no calculation in the report itself. Also a direct access to database tables is never done but only to the stored procedures from level 2. With this the reports are:

  • completely independent of the database structure
  • universal and
  • interchangeable


ZAMS - zenon Analyzer Management Studio

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio

In zenon Analyzer Management Studio (ZAMS), you provide the reports that are called up, configured and displayed by users in Report Launcher.
You also start the external tools here:

  • Metadata Editor
  • Manual Data Editor
  • Migration tool

ZAMS is the main application for:

  • Configuration of the zenon Analyzer
  • Creation of reports from the templates supplied with COPA-DATA
  • Creation, editing and deleting report subscriptions and the attendant schedules on the Analyzer server
  • The display and editing of the license on the Analyzer server
  • The creation and deletion of linked servers in the SQL server instance of the Analyzer server
  • Editing of metadata databases
  • The migration of databases, reports and subscriptions

info Information

ZAMS is started in the language of the operating system. If this language is not implemented in ZAMS or the corresponding language file is missing, ZAMS is started in English. You can read details on the languages in the Language settings chapter.

Communication

ZAMS communicates with the Analyzer database using the Microsoft SQL Server 2016 Management Objects. It connects itself:

  • To the SQL Server 2016 Reporting Service Web Service endpoint ReportService2016 of the Analyzer server
  • to the selected database on the Analyzer server
  • To zrsLicSrv on the Analyzer server

Software requirements

The following software is required for the use of ZAMS:

  • Microsoft .NET Framework 4.6.1
    This must already be present on the computer before the installation of ZAMS.

Error Handling

Error messages, warnings and messages are saved in the output window, in accordance with the options that have been set.

Other topics in this chapter

Starting ZAMS

Example of configuration

Checklist for license problems

Main window

Analyzer Server and Reports

Managing SQL Server

Selection of folder in the network

Archive emulation

Calculated archives

User administration and access rights

Settings


Starting ZAMS

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Starting ZAMS

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The zenon Analyzer Management Studio (ZAMS) is installed together with zenon Analyzer.

During installation, the user who carries out the setup is entered as a user with dedicated license with authorization level 3.

To start ZAMS:

  1. In the Windows Start menu, select the COPA-DATA -> ZAMS entry
    or
    double click on a ZAMS report file ( .zams_rep)
  2. ZAMS starts and shows the started version and build number on the screen, provided that there is not another ZAMS version running:

  3. The connection dialog is opened, depending on the settings in the options,

  4. Select the desired connection by clicking on Connection profile or create a new connection
  5. Click on OK:
    • The connection test is carried out. A progress bar is displayed in the process.
    • The database structure is checked and the license is validated. A progress bar is displayed in the process.
    • the connection will be established. A progress bar is displayed in the process.
  6. ZAMS is opened.

Note: if the connection fails because there is no license, you can request the license status in ZAMS and enter new license data. Presettings for connection profiles, deployment of reports and messages in the output window can be set in the options in the Tools menu.

Acceptance of the configuration from a previous version

When a new version of ZAMS is started, provided there are not yet any configuration files available, the configuration of the prior versions is used. To do this, its configuration files must still be present on the computer. The transfer happens separately for each user.


Example of configuration

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Example of configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A company wants to use zenon Analyzer. The following computers are available in the company network:

  • The Analyzer server, called SRV
  • An engineering station, called ENG

Both are in the TEST domain. There are the following users in the domain:

  • TEST\Admin: Network administrator.
    Only this user can install programs on computers. This user should have access to the Analyzer as an administrator, however not permanently have a license.
  • TEST\ZamsAdmin: This user is the future Analyzer administrator.
    They should be able to use all Analyzer applications and be able to complete all administrative tasks on the Analyzer with ZAMS. A license should be reserved for this user.
  • TEST\ReportViewer1, TEST\ReportViewer2 and TEST\ReportViewer3: These three users should evaluate reports in the Analyzer and be able to execute them, however a license should not be assigned to any of these users permanently.

Configuration

  1. TEST\Admin executes the Analyzer server setup on the computer called SRV. Once the setup has been completed, this user is entered as a user with dedicated license with authorization level 3 on the license server. They have administration rights in both the SQL server instance and Report Launcher. No other user has access rights to the Analyzer.
  2. TEST\Admin executes the ZAMS setup on the computer called ENG.
  3. TEST\Admin starts the ZAMS on the computer called ENG. The connection to the server SRV\ZA3 and on this server to the database ZA_DATA is established. When making the connection, ZAMS recognizes that the user TEST\Admin has authorization level 3 but does not have a license written in the license server.
  4. The user TEST\Admin ensures that the dongle is connected to the computer SRV and enters the dongle license in ZAMS on the computer called ENG. The license is sent via the ZAMS connection to the Analyzer server SRV and saved there by the license server.
  5. ZAMS detects that the license on the server is valid and unlocks additional functions.
  6. The user TEST\Admin
    1. Starts the administration of the access rights to the Analyzer applications in ZAMS
    2. Adds the user TEST\ZamsAdmin
    3. Assigns the highest possible access right to this
    4. Confirms the dialog with OK.
  7. The user TEST\Admin
    1. Starts the administration of the Report Launcher access rights in ZAMS
    2. Adds the user TEST\ZamsAdmin as an administrator for the configuration of system access rights
    3. Adds the same user for the object access rights of the root folder
    4. Sets its access rights there to content manager
    5. Confirms the dialog with OK.
  8. The user TEST\Admin closes ZAMS and logs off from the ENG computer.
  9. The user TEST\ZamsAdmin logs on to the ENG computer and starts ZAMS. The connection to the server SRV\ZA3 and on this server to the database ZA_DATA is established. When establishing a connection, ZAMS detects that the user TEST\ZamsAdmin has the authorization level 3 and that a license for them could be established.
  10. The user TEST\ZamsAdmin
    1. Starts the administration of users with a dedicated license in ZAMS
    2. Adds itself
    3. Removes the user TEST\Admin from the list
    4. Closes the dialog.
  11. The user TEST\ZamsAdmin
    1. Starts the administration of the access rights for the Report Launcher in ZAMS
    2. Adds the three users TEST\ReportViewer1, TEST\ReportViewer2 and TEST\ReportViewer3 as a user for the configuration of the system access rights
    3. Adds the same three users for the object access rights of the root folder
    4. Leaves its access rights there on the browser
    5. Confirms the dialog with OK.

The configuration was carried out successfully.


Checklist for license problems

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Checklist for license problems

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

If ZAMS cannot establish a connection or the connection is broken due to problems with the license, check the following:

  • Can the dongle be accessed from the Analyzer Server?
  • Do the serial number and the activation key correspond to one another?
  • Is the TCP port 50779 open on the Analyzer Server?
  • Can the license client communicate with the license server?
    Note: Firewalls or network failures, for example, may prevent this.
  • Does the user have the required authorization levels?
  • Is a license available for the user?
    Note: Users with a dedicated license are assigned licenses even if they are not connected.
  • Is the report template or the report included in the scope of the license?


Main window

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The user interface of the ZAMS consists of:

  • Menus
  • Toolbar
  • Report area
  • Output window

Parameters | Description
Menu line | Contains menus with commands to configure the ZAMS and create and administer reports.
Toolbar | Contains symbols with commands to configure the ZAMS and create and administer reports.
Report area | Reports are created here.
Separator | Dividing line with which the size ratio between the report area and the output window is defined. To change the ratio. move the mouse with the line, hold down the left mouse button and drag the splitter in the desired direction.
Output window | Output of error messages, warnings and information.
Status line | Output of status messages.

Menus and symbols are only actively available if the corresponding function is available. This depends on whether there is a connection, whether there is a connection to the Analyzer server with a valid license and whether an action is running that blocks the function.

Whether a menu entry and the corresponding symbol is active depends on three factors:

  1. Has a connection been established and does it have a valid license?
  2. If reports have been opened and is the currently-active report write protected?
  3. Is there currently an action running in a background thread (such as Prepare, Open in Report Builder)?

For this, the following applies: A factor is only considered if all superordinate factors see the entry as active.

If a function that can change the connection or license status is to be executed, all reports are closed beforehand. The user is notified of this and can cancel closing. The function is not executed if it is not possible to close all reports.

When ending ZAMS, the position and size of the window and the position of the dividing line are blocked.

Other topics in this chapter

Menus

Toolbar

Report area

Output window

Status line


Menus

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Menus

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The following menus are available in the main ZAMS window:

  • Report
  • Analyzer server
  • Automation
  • SQL Server:
  • Tools
  • Help

Key combinations are available for many menu entries: These are displayed in the menus next to the respective command.

Other topics in this chapter

Report

Analyzer Server

Automation

SQL Server:

Tools

Help


Report

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Menus -> Report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Commands in the Report menu

Command | Description
New | Opens the dialog for creating a new report.
Open | Opens the dialog to select and open an existing report.
Most recently edited reports | List of the reports last worked on. Here, the reports that were open last are offered, sorted according to last use with the most recent report in the top position. The number of reports in the list is established in the Tools menu in the Options for connection profiles.
Store | Saves the active report.
Save as | Opens the dialog to save a report under a new name.
Save all | Saves all opened reports.
Deploy | Allows deployment of the active report.
Deploy all | Allows deployment of all opened reports.
Start Microsoft Report Builder | Opens Microsoft Report Builder. The Report Builder must already be present on the system for this. Note: The Report Builder is also installed for ZAMS. In the Report Launcher, the Report Builder can be downloaded from the Microsoft website using a button in the main directory.
Open in Microsoft Report Builder | Opens the active report in Microsoft Report Builder. Note: The Report Builder was only started if the report can be found on the server.
Open all in Microsoft Report Builder | Opens all opened reports in Microsoft Report Builder. Note: The Report Builder is only started for reports that can be found on the server. Attention: For each report to be opened, a separate Report Builder instance is opened for each language variant. If more than 10 instances are to be opened, a warning is shown and a dialog is shown, in which the opening process can be canceled.
Start Report Launcher | Starts the Report Launcher. When starting the Report Launcher or opening reports in the Report Launcher, Internet Explorer is addressed by ZAMS directly as ActiveX.
Open in Report Launcher | Opens the report currently displayed in ZAMS in the Report Launcher.
Open all in Report Launcher | Opens all reports currently open in ZAMS in the Report Launcher.
Close | Closes the active report.
Close all | Closes all opened reports.
Exit | Exits ZAMS.


Analyzer Server

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Menus -> Analyzer Server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Commands in the Analyzer Server menu:

Command

Description

Connect to server

Opens dialog with connection profiles.

Server: Version information

Opens window with information on:

  • Version of the operating system
  • Version of zenon Analyzer

Configure Reporting Services wake up call

Opens the dialog for configuring a wake up call.

This initializes the reporting services and prevents the cache being emptied. This periodic call up can shorten the waiting time when calling up Report Launcher and when connecting ZAMS and the migration tool.

Show current license

Opens dialog with:

  • Serial Number
  • Activation key
  • License status
  • License properties
  • Button to enter a new license

License product

Opens dialog to enter license data.

Assigning dedicated licenses to users

Opens dialog to administer the users with a dedicated license.

Manage Analyzer Tools access rights

Opens dialog to administer the access rights to the Analyzer tools.

Administer Report Launcher access rights

Opens dialog to administer the access rights to the objects in the Report Launcher.

Configure Analyzer server connection security

Opens the dialog for configuration of the connection security.

Note: This function is only available if ZAMS is running on the Analyzer server and is connected to an Analyzer database with a valid license on the same computer and there is no other task running in the background.


Automation

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Menus -> Automation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Commands in the Automation menu

Parameters | Description
Configure archive emulation | Opens the dialog for configuring the archive emulation.
Configure email server... | Opens the dialog to configure an email server. Note: This function is only available if ZAMS is running on the Analyzer server and is connected to an Analyzer database with a valid license on the same computer and there is no other task running in the background.
Manage schedules | Opens dialog to manage schedules for the distribution of reports.
Manage subscriptions | Opens dialog to manage report subscriptions.


SQL Server:

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Menus -> SQL Server:

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Commands in the SQL Server menu

Parameters | Description
Update connector functions | Renews the Connector functions. The result is displayed in the output window.
Create SCADA SQL connector | Opens the dialog to create an SQL connector.
Create 3rd party database connector | Starts the configuration of the connector for third-party databases.
Configure calculated archives | Starts the dialog to configure calculated archives.
New Analyzer database | Opens dialog to create a new Analyzer database.
Convert databases | Starts the conversion of databases, the version number of which is lower than the current version number.
Create database backups | Opens the dialog for creating a project backup.
Restore database backup | Opens the dialog for renaming a profile.
Restore database backup file as new database | Opens the dialog for restoring a database backup as a new database.
Restore Reporting Services database backup | Opens the dialog for restoring the reporting services database.
Administrate automated database backups | Opens the dialog to administer the automatically-created database backups.
Manage database backup files | Opens the dialog to administer the backup files of the database.
Manage linked server | Opens dialog to manage the linked servers.
Manage metadata indices | Opens the dialog to manage the metadata indices.


Tools

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Menus -> Tools

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Commands in the Options menu

Parameters

Description

Metadata Editor

Makes it possible to amend visual names and descriptions and to enter equipment information.

Manual Data Editor

Allows the editing of tables for price and norm values in a zenon Analyzer metadata database.

Migration tool

Allows the migration of Analyzer Server.

Manage color schemes

Opens the dialog to create and edit and administer color schemes.

Export color schemes

Opens the dialog for exporting color schemes.

Import color schemes

Opens the dialog for importing color schemes.

Manage RDL templates

Opens the dialog to administer RDL templates.

Refresh caches

Updates the ZAMS cache.

Settings

Opens the dialog for configuring settings for:

  • Connection profiles
  • Deployment
  • Output messages
  • Language settings
  • Database backups


Help

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Menus -> Help

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Commands in the Help menu

Parameters | Description
Info about | Opens window with ZAMS version information.
Help | Opens online help.


Toolbar

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Toolbar

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Parameters | Description
Connect to Analyzer server | Opens dialog with connection profiles.
New report | Opens the dialog for creating a new report.
Open report | Opens the dialog to select and open an existing report.
Save report | Saves active report.
Saving all reports | Saves all opened reports.
Deploy report | Allows deployment of the active report.
Deploy all reports | Allows deployment of all opened reports.
Start Microsoft Report Builder | Opens Microsoft Report Builder.
Open current report in Microsoft Report Builder | Opens the active report in Microsoft Report Builder. Note: The Report Builder was only started if the report can be found on the server.
Opening all reports in Microsoft Report Builder | Opens all opened reports in Microsoft Report Builder. Note: The Report Builder is only started for reports that can be found on the server. Attention: For each report to be opened, a separate Report Builder instance is opened for each language variant. If more than 10 instances are to be opened, a warning is shown and a dialog is shown, in which the opening process can be canceled.
Start Report Launcher | Starts the Report Launcher.
Open current report in Report Launcher | Opens the report currently displayed in ZAMS in the Report Launcher. When starting the Report Launcher or opening reports in the Report Launcher, Internet Explorer is addressed by ZAMS directly as ActiveX.
Open all reports in Report Launcher | Opens all reports currently open in ZAMS in the Report Launcher.
Manage subscriptions | Opens dialog to manage report subscriptions.


Report area

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Report area

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports are displayed in the report area between the toolbar and the output window.

Note:

  • If several reports are opened, each report is shown in its own tab. The name is displayed in the indicator of the tab.
  • If the mouse pointer is moved to above the indicator of the tab, the complete path to the save location is shown.
  • Reports that contain unsaved changes are highlighted with an asterisk next to the name.
  • Reports that are write-protected are displayed with a corresponding notice in brackets in the register title.

Design guidelines

The designs are designed with the following rules:

  • There are two versions of the parameter area:
    • Wide: For all comparative report templates and for alarm analyses and for OEE performance indicator lot archive.
    • Narrow: All other report templates
  • If possible, figures are given units (unit of measurement, currency, percent).
  • Decimal points:
    • Monetary amounts and percentage values always have 2 decimal places.

      Exception: Axes. Here, percentage values 0 to 2 can have decimal points.

      The number of decimal points of all other numerical values is defined individually using an input field. Exceptions to this are the vertical and horizontal axes and the value table of the archive distribution.

  • Data fonts for pie charts are always outside the pie segments.
  • All reports that are supplied by ZAMS have a footer.

    Attention: This footer is automatically inserted by ZAMS when provided. If there is a footer in the RDL template, it is overwritten!

Input elements

You can find details on the input elements in the report in the Elements in the report area chapter and in the documentation of the Report templates supplied.


Output window

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Output window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The output window lists error messages, warnings, information and status messages in a table. These notices can be filtered and deleted. The types of messages that are displayed are defined in Options.

Display in the output window

Parameters

Description

Buttons

Control the display of the messages Setting of the buttons is saved when ZAMS is closed.

Delete all

Clears the whole table.

Error

Displays the number of errors that can be displayed in the table. Clicking on the button switches the display in the table on or off.

Warnings

Displays the number of warnings that can be displayed in the table. Clicking on the button switches the display in the table on or off.

Messages

Displays the number of messages that can be displayed in the table. Clicking on the button switches the display in the table on or off.

Status messages

Displays the number of status messages that are displayed in the table. These cannot be hidden.

Table

Contains error messages, warnings, information and status messages.

  • Messages can be sorted with the column titles and according to columns. Clicking on the respective column head sorts the table according to this column. A second click inverts the sorting. The standard sorting increases in accordance with column 1 (Numbering).
  • Double clicking on a message in the table displays the report and the context in which the message was created in the report area of the main window. To do this, the report must already be open.
  • Messages are deleted when ZAMS is closed.

Numbering

Contains consecutive numbering. The numbers are assigned chronologically upon receipt.

Symbol

Symbol that displays the type of message. The symbols correspond to the symbols on the buttons.

Sorting sequence ascending:

  • Error
  • Warning
  • Information
  • Status information

Ascendant sorting is carried out in reverse order.

Timestamp

Displays the time stamp of the time at which the message was created.

Message ID

Unique ID of the message source.

Description

Explanation of the message.

Source

Name of the report concerned at the time the message was created. If the message was not created in the context of a report, this column remains empty.


Status line

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Main window -> Status line

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The status display of ZAMS informs you of the connection and objects.
It consists of several sections:

  • Symbol that shows the status of the connection;
    Possible statuses are:
    • No connection established
    • Connection established but the Analyzer server license is not valid
    • Connection established and the Analyzer server license is valid
    • Secured connection established, the license is valid
    • Secured connection established, the license is invalid
  • Connection message: Display of the server and the database
  • Display of the color scheme currently being used
  • Display of the RDL template currently being used.
  • Message that describes the current task
  • Progress display that is shown if necessary and displays the progress during longer working stages such as:
    • Open report
    • Saving all reports
    • Deploying all reports
    • Opening all reports in Report Builder

Separator: |


Analyzer Server and Reports

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In ZAMS, you can:

  • Manage Analyzer server
  • Configure connection security
  • Create and administer reports
  • Deploy reports
  • Manage RDL templates
  • Automate report handling
  • Display and enter licenses
  • Automating processes
  • Refresh caches

Missing UDF

With some actions, the database is checked to see that it is up to date. If missing UDFs are established, you receive an error message accordingly:

Available actions:

  • Yes: The missing UDFs are created automatically. You can continue with the desired configuration.
  • No: The action is canceled.

Circular dependencies with archives

When configuring, it must be ensured that no circular dependencies of variables are created. This could lead to the SQL server instance crashing. When configuring emulated archives, archives of 3rd party databases or calculated archives, a corresponding check is automatically carried out in ZAMS. Configurations that lead to circular dependencies are prevented.

Other topics in this chapter

Information about the Analyzer Server

Configure connection

Connection security

View license

Enter License...

Configure Reporting Services wake up call

Automation

Refresh caches

Creating, opening, saving and closing reports

Deploy reports

Opening reports in Microsoft Report Builder

Creating color definition for reports

Manage RDL templates


Information about the Analyzer Server

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Information about the Analyzer Server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You can do the following via the Analyzer Server menu:

  • Connect ZAMS to the Analyzer server
  • Request information on the Analyzer server
  • Configure an activation call for the Analyzer Server
  • Request the license status of the Analyzer server
  • Enter new license data
  • Configure the connection security

Server information

To receive information on the version of the Analyzer server:

  1. Select, in the Analyzer server menu, the Server version information command
  2. The information window is activated
  3. You receive information on:
    • The operating system of the computer with the Analyzer server
    • The version of Analyzer server that is running


Configure connection

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Configure connection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To create a new connection profile, select:

  • When starting ZAMS, Create new profile as a profile
    or
  • when ZAMS is running, the Connect to server command in the Analyzer server menu.

The dialog for the configuration is opened:

Parameters

Description

Connection profile

Selection of the connection profile from the drop-down list.
The profile consists of a path for server\database.

  • Create new profile: creates a new profile.

Credentials

Entry of the access data.

Use windows authentication

Active: Windows authentication is used.

Username

Entry of the user name.

If Use Windows authentication is active, display only.

Password

Entry of the password. Is not saved and must be reentered each time the connection is made.

If Use windows authentication is active, no input is necessary; input is also not possible.

Connection security

Settings for the connection security. The entries must correspond to the configuration on the server.

Secured connection

Activation or deactivation of the encrypted communication.

  • Active: Communication is encrypted. For each connection, depending on the degree of encryption, passwords must be entered for the license service.
  • Inactive: Communication is not encrypted.

Note: Secured communication cannot be configured for existing connection profiles. A new profile must be created.

License Server connection password

Entry of the password for the connection to the license server.
Input is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

License Server modification password

Entry of the change password on the license server.
Entry is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Save passwords

Stipulation of whether the connection parameters are saved in the connection profile.
Saving is carried out as a hardware-dependent and user-dependent hash of the password.

Refresh server list

A click starts a search for existing servers to which ZAMS can connect.

To do this, a list of all SQL server instance available in the network is checked to see if the attendant computers of the ReportService2010 Web Service endpoint and the license server can be reached.

Note: If a large amount of SQL servers are present in the system, the check can take a long period of time. The procedure is visualized by means of a progress display.

Specify database server

A click opens the dialog to enter a specific server.

This is the recommended procedure if the name of the computer and the SQL server instance of the Analyzer server are known.

Server computername

Selection of the computer name of the server to which ZAMS should connect, from a drop-down list.

If the desired server is not displayed, it can be added using the Update server list button or searched for via Enter database server.

Note: localhost is not a valid entry, because localhost is unknown in the domain. localhost is always replaced by the computer name.

Database

Selection of the database that ZAMS is to use from drop-down list.

OK

Accepts all inputs, validates them, creates them as a connection profile, closes the dialog and creates the connection.

Cancel

Rejects all inputs and closes the dialog without creating a connection.

Create new profile

When creating a new profile, the profile that was used last is used as a template. Authentication and server are transferred, the database list is filled again, whereby the database selection is also transferred. To create a new profile:

  1. Select the type of authentication and enter the user name and password if required.
  2. Select in the Connection profile property, the Create new profile option.
  3. Enter, if required, the data for the connection security.
  4. Select the server and database.
  5. Confirm the information by clicking on the OK button.

attention Attention

If, when creating a new profile, the profile on which it is based for the access data uses authentication with user name and password, these must be entered correctly before Create new profile is selected. Otherwise the database cannot be filled.

If the database list is empty, in can be refilled if you:

  1. Enter the access data correctly
  2. Click on the Specify database server button
  3. Confirm the dialog that opens by clicking on OK

Refresh server list

To update the list of servers displayed, click on the Refresh server list button on the dialog for the connection profile. The search for servers to which ZAMS can connect is started. In doing so, the progress display shows you the following:

  • The computer in the network that is currently being examined
  • The progress of the search (with a green bar)

The progress display is closed once the search has been completed. The servers found are shown in the Server computer name drop-down list.

Note: If a large amount of SQL servers are present in the system, the check can take a long period of time.

Select server manually

To define the computer name of the server manually, Enter database server button in the dialog for the connection profile. The dialog to connect to a specific server is opened.

Parameters | Description
Server computername | Entry of the computer name of the server to which ZAMS is to connect. For example: Server999 Note: localhost is not a valid entry, because localhost is unknown in the domain. localhost is always replaced by the computer name.
Progress bar | Shows the progress of the connection attempt. If the attempt is not successful, a window with an error message is displayed and an error report is displayed in the ZAMS output window.
OK | Applies changes, validates them and closes the dialog.
Cancel | Discards changes and closes dialog.


Connection security

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Connection security

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Communication in zenon Analyzer can be encrypted. With the exception of encryption, the communication is to the Connector Container.
Configuration is via ZAMS and is used to establish a connection and for communication. ZAMS saves the configuration and the connection profiles if a different tool is started from ZAMS. Manual Data Editor and Meta Data Editor check, when loading their own connection profiles, to see whether there is already a connection profile with the same name as their own connection profile for ZAMS. In this case, the connection profile with the most recent time stamp is loaded for use.

Encryption services

Service

Server

Client

SQL server

Decides on encryption.

No configuration necessary.

Report Server

Decides on encryption.

The server needs a certificate.

Clients for Report Launcher web server must use the URL for connection (HTTP or HTTPS).

License service

Decides on encryption.

Clients need the connection password.
A change password is required for authentication in the event that changes are made using ZAMS or the migration tool.

These passwords can be saved with connection profiles. Clients without a user interface read their configuration from the entries for the license service.

Note: Saved passwords can only be reused for unchanged PC hardware and the same Windows user.

You can also create the certificates required for encryption yourself.

info Information

For report developers, there is a tool that can be used to reset the configuration. For details, see the zenon Analyzer for developers manual; Tool: Analyzer Security Configuration section.

Protocols and encryption

Overview of services and their encryption:

Service/connection

Protocol

Encryption

Authentication

License service

TCP

AES 256

Hashes: SHA 256

Password.

  • Server: Passwords are encrypted depending on the hardware when saving.
  • Applications: Passwords can be saved as an option and are encrypted depending on the hardware and the user.

SQL Server Instance

TCP

SSl

Windows user (recommended) or separate password for SQL server.

Reporting services service

HTTP

SSl

Windows users.

SQL server instance connection to connector container

TCP

none

Recommendation: In the firewall before the Runtime server, only allow communication via port 50778 (connector container) to clients that need it.

Operation without encryption

If zenon Analyzer is operated without encryption activated, the following is recommended:

  • No Internet connection for computers with databases.
  • No Internet connection for license server.
  • Remote access via VPN only.

Other topics in this chapter

Certificates

Configure connection security

Extended settings

Switching from secure to non-secure


Certificates

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Connection security -> Certificates

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A certificate is required for securing the report server.
Appropriate certificates can be created with the Everywhere Certificate Creator.

Requirements

Requirements for report server certificates:

  • The complete domain name of the Analyzer server must be entered as a Subject. This is displayed in the URL.
    Otherwise the browser will report problems with the certificate security.
    Note: Some browsers also report an invalid certificate if the certificate used does not come from a location that is known to the browser.
  • The call-up URL of the Report Launcher and the name of the Analyzer servers for various tools, such as ZAMS for example, must correspond to the name given in the certificate. Otherwise the HTTPS connection cannot be established.

You can find further details for the requirements for in the Microsoft TechNet: https://technet.microsoft.com/en-us/library/ms189067(v=sql.105).aspx

Access by SQL Server

The SQL Server instance must be able to access the certificate's Private Key.
There are two possibilities for this:

  • Non-secure: Give the SQL Server instance (service user) local administrator rights. This procedure is expressly not recommended for reasons of system security.
  • Recommended: Give the service user of the SQL Server instance access rights.
    To do this:
    • Open the computer certificate administration.
    • Right-click on the certificate
    • Select Manage private keys.
    • Give the service user of the SQL Server instance access rights.


Configure connection security

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Connection security -> Configure connection security

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The connection security is configured in the Configuration of the connection security dialog.

To open the dialog, select the Configure Analyzer Server connection security entry in the Analyzer Server menu. The entry can only be selected if Analyzer Server and ZAMS are on the same computer.

Configure connection security

To configure the connection security:

  1. Select the desired type.
  2. Select the certificate with secure communication.
  3. Issue and confirm the connection password and the change password for the license server.
  4. Decide whether the license server also does not allow non-secure communication.
  5. If necessary, configure the standard behavior by clicking on the Advanced button for authentication and entry of incorrect password.
  6. Enter the authentication method and the attendant data.
  7. Decide whether the passwords are saved in the connection profile or reentered for each new connection.

Dialog for configuration of the connection security

Parameters

Description

Connection security type

Selection of the type of secure connection from a drop-down list.

  • Unsecured communication:
    All communication for all services is not secure. (not recommended)
  • Unsecured communication. Secured communication with License Server allowed:
    SQL Server instance and report server only communicate in unsecured form. The license server allows secure and non-secure communication.
  • Secured connection:
    All services use secure communication. With the license service, it is also possible to decide whether non-secure communication is permitted.
    (recommended)

Report Server Certificate

Selection of the certificate for the securing of the HTTP connections and the web service connections for the report server. All locally-created certificates are available.

Only available if all services are secure for Security type of the connection. An entry must be selected if this drop-down list is active.

SQL Server Certificate

Selection of the certificate for the securing of the connections for the SQL Server instance.

All locally-created certificates are available. Alternatively, certificates can be created by SQL Server.

Only available if all services are secure for Security type of the connection. An entry must be selected if this drop-down list is active.

License Server connection password

Entry of the password for the connection to the license server.
Input is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Note the requirements in the Rules for passwords section.

Only available if the license service can communicate in secure form.

Confirm password

Repetition of the password for the connection to the license server.

License Server modification password

Entry of the change password on the license server.
Entry is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established. Is used by ZAMS and the migration tool.

Note the requirements in the Rules for passwords section.

Only available if the license service can communicate in secure form.

Confirm password

Repetition of the password for changes to the license server.

License Server allows an unsecured communication

Stipulation of whether the license service, in addition to secure communication, also allows non-secure communication.

  • Active: License server also allows non-secure communication.
  • Inactive: License server only allows secure communication.

Possible settings and activity are determined by the security type:

  • Unsecured communication:
    Checkbox not available.
  • Unsecured communication. Secured communication with License Server allowed:
    Checkbox active and not available.
  • Secured connection:
    Checkbox active and can be deactivated.

Extended

When clicking on "Extended", the ZAMS dialog for advanced Analyzer Server connection security settings is started. If this is confirmed with OK, the changes from this dialog are applied.

Credentials for reconnecting

Entry of the access data.

Use windows authentication

Selection of the authentication type.

  • Active: Windows authentication is used.
  • Inactive: Access data must be entered manually.

User name

Entry of the user name.

If Use Windows authentication is active, display only.

Password

Entry of the password. Is not saved and must be reentered each time the connection is made.

If Use windows authentication is active, no input is necessary; input is also not possible.

Store passwords in connection profile

Stipulation of whether the connection parameters are saved in the connection profile.
Saving is carried out as a hardware-dependent and user-dependent hash of the password.

Not available if all services are to be secured. In addition, your activity is determined by the configuration present before the dialog is called up:

If the initial configuration is Secure communication, the checkbox is inactive until all passwords for the license server have been re-entered.

As long as no password has been re-entered, the checkbox is then active if there are saved passwords in the connection profile that is currently being used.

Example runtime behavior:

  • The dialog is started with a configuration for secure communication and a connection profile with saved passwords:
    Checkbox is inactive and not available.
  • One of the input fields for the license service passwords will be changed:
    Checkbox is inactive and not available.
  • The remaining input fields for license service passwords are amended:
    Checkbox is available in the moment in which the last unchanged password is amended.

Close dialog

Parameters | Description
OK | Click on OK to start the validation of the dialog. If validation errors occur, these are shown by means of a notification dialog and the dialog remains open. If no validation errors occur, the dialog is closed and the changes are applied.
Cancel | Discards all changes and closes the dialog.

Rules for passwords

The following is applicable when issuing passwords:

  • The input field must not be empty.
  • Minimum length 8 characters
  • Maximum length 20 characters
  • The password must not contain any empty characters or word wraps.
  • The password must contain at least one of the following categories from at least 3 of the following categories:
    • Capital letters: A-Z
    • lower case letters: a - z
    • Digits: 0-9
    • Special characters: all other valid characters.
      The following are not permitted: spaces, carriage return or vertical spacing.)
  • The password entered must correspond to the confirmation password entered.

Note: The passwords for login and changes to the license server can be identical. However it is recommended that different passwords are used.


Extended settings

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Connection security -> Extended settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this dialog, you configure the settings for errors when entering a password and the behavior of the server:

  • Number of permitted incorrect entries
  • Time period in which the incorrect entries must be entered in order to be counted together
  • Blocking time for the client in the event of multiple incorrect entries
  • Permitted time difference for authentication

Advanced settings dialog

Parameters

Description

Number of incorrect password attempts

Number of incorrect attempts after which a client is blocked:

  • Minimum: 1
  • Maximum: 1000

Default: 3

Failure forget time

Number of seconds after which a failed attempt is forgotten:

  • Minimum: 1
  • Maximum: 86400 (1 day)

Default: 60 (1 minute)

Client lock time

Number of seconds that a client remains blocked after a block:

  • Minimum: 1
  • Maximum: 86400 (1 day)

Default: 3600 (1 hour)

Allowed authentication time difference

Permitted deviation of the client's time stamp from the current time stamp of the server during authentication in seconds:

  • Minimum: 1
  • Maximum: 86400 (1 day)

Default: 10

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Switching from secure to non-secure

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Connection security -> Switching from secure to non-secure

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The switching from a secure connection to a non-secure connection depends on the setup in the computer:

  • Switching of an installation between secured and non-secured
  • Switching of 2 installations between secure and non-secure (for example 3.00 & 4.00)
  • Parallel operation of a secure and non-secure installation (for example 3.00 & 2.20)

Note: All installations are always on the same computer.

One installation

Switching of an installation between secured and non-secured:

  • Initial situation: There is only one zenon Analyzer installation on the computer. This allows secure connections.
  • Procedure: The configuration can be changed as desired using ZAMS, because no further installations on the computer are affected.

2 installations

Switching of 2 installations between secure and non-secure:

  • Initial situation: There are two zenon Analyzer installations (A and B) on the computer that allow secure communication.
  • Procedure: In order to guarantee complete connectivity, the right steps need to be carried out in the right sequence.

Switching from secure to non-secure

Starting point: A and B communicate in plain text.

Configuration:

  1. A is configured as a secure connection.
    The license service allows plain text communications.
    Result: A communicates in secure form, B communicates in plain text.
  2. B is configured as a secure connection. This is initially shown as partially secure in the dialog.
    The license service does not permit plain text connections.
    Result: A and B communicate in secure form.

Switching from secure to non-secure

Starting point: A and B communicate in secure form.

Configuration:

  1. A is configured as a partially secure connection.
    SQL Server and report server communicate in plain text.
    License service communicates in encrypted form and allows plain text.
    Result: A communicates in plain text, B communicates in secure form.
  2. B is configured as a non-secure connection.
    Result: A and B communicate in plain text.

Parallel operation

Parallel operation of a secure and non-secure installation.

  • Initial situation: There are two zenon Analyzer installations on the computer.
    A can operate with plain text and in secure form, B can only operate with plain text.
  • Procedure: In order to guarantee complete connectivity, the correct configuration must be selected when switching from non-secure to secure.
    No problems can occur when switching from secure to non-secure.

Switching from secure to non-secure

Starting point: A and B communicate in plain text.

Configuration:

  • A is configured as a secure connection.
    The license service allows plain text communications.
    Result: A communicates in secure form, B communicates in plain text.


View license

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> View license

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To display the license used by the Analyzer server:

  1. Select, in the Analyzer server menu, the Show current license command
  2. the drop-down list with the license information is opened

Parameters

Description

Serial Number

The serial number is displayed.

Activation key

The activation key is displayed.

License status

Status of the license:

  • This license is valid
  • Invalid license

License properties

Display of:

  • Number of licensed clients
  • License expiration date.

License product

Opens the dialog to enter license data.

OK

Closes the window.


Enter License...

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Enter License...

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To enter new license data:

  1. Select, in the Analyzer Server menu or in the Display license dialog, the Enter new license command
  2. the drop-down list with the license information is opened
  3. enter serial number and activation number
  4. Click on Check new license
  5. If the result is positive, click on OK to activate the license

Enter dialog license

Parameters

Description

Serial number

Entry of the serial number.

Activation key

Entry of the activation key.

Test new license

Clicking on this button tests inputs before they are written to the license server, to see if:

  • License data entered has the correct syntax
  • a license can be occupied on a CodeMeter dongle with the data entered
  • The activation key corresponds with the serial number

In order for the test to be started, both serial number and activation key must have been entered.

Test result

Displays the test result of Test new license.

OK

Writes the license entered to the license service on the Analyzer server and closes the dialog. The result of writing the license is displayed in the output window.

In order for the license data to be written, both serial number and activation key must have been entered.

Cancel

Closes the dialog without writing data to the license service.

attention Attention

If incorrect license data is entered, the access to the Analyzer server is blocked for all clients. Always check the new license data by clicking on the Test new license button before you set the license by clicking on OK.


Configure Reporting Services wake up call

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Configure Reporting Services wake up call

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The caches of the Reporting Services are regularly emptied by the server if they are not accessed. Applications that access these must then wait until it is built up again. This also applies if the content has not changed. The Reporting Services activation call regularly initializes the reporting services and prevents the cache being emptied. This periodic call up can shorten the waiting time when calling up Report Launcher and when connecting ZAMS and the migration tool.

To configure to a wake up call:

  1. Click, in the Analyzer Server menu, on the Reporting Services Activation call menu item.
  2. The dialog for configuration is opened.
  3. Select the desired interval from the drop-down list.
  4. Close the dialog by clicking on OK.

Reporting Services wake up call dialog

Parameters

Description

Enable the Reporting Services wake up call
  • Active: An activation call is configured and is executed. The interval of the call is established with the Interval of execution of the activation call.

Interval for performing the wake up call

Selection of the interval for the activation call from the drop-down list. The following are available:

  • 1 hour
  • 2 hours
  • 3 hours
  • 4 hours
  • 6 hours
  • 12 hours
  • 24 hours

Default: 6 hours

Note: Only values that can be divided into the number 24 without a remainder are available. This ensures that the call can always be periodic.

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Automation

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Automation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the following actions and start them in the Automation menu:

  • Emulation of archives
  • Server configuration for the sending of emails
  • Preparation of reports using schedules
  • Report subscriptions

Other topics in this chapter

Configure archive emulation

Configure email server...

Manage schedules

Administer report subscriptions


Configure archive emulation

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Automation -> Configure archive emulation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In ZAMS, you can emulate archives that exist from figures from entries in the AML, CEL and archives in zenon.

To configure the archive emulation:

  1. Select the Configure archive emulation entry in the Automation menu.
  2. Click on the New button to create a new emulated archive,
    or Edit to change an existing emulated archive

You can find details on archive emulation and the configuration of emulated archives in the archive emulation section.


Configure email server...

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Automation -> Configure email server...

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In order to be able to send reports by email, the SMTP server must be configured. This is carried out in ZAMS via the Configure email server menu item.

attention Attention

This function is only available if ZAMS is running on the Analyzer server and is connected to an Analyzer database with a valid license on the same computer and there is no other task running in the background.

You configure the email yourself with Administer report subscriptions in the Delivery method tab.

Configuration

To configure email delivery:

  1. Click on the Configure email server entry in the Automation menu.
  2. The dialog for configuration is opened. Entries that already exist are read and displayed. The existing configuration is saved in a separate file.
    If an error is detected when reading, a message is written to the output window and the dialog is ended.
  3. Configure the required properties in the dialog.
    For further details see chapter configuration dialog
  4. Confirm the changes by clicking on OK.
    The changes are written to the current configuration. If an error occurs, the previously-saved configuration is used.

Note: A progress bar is shown for actions that last longer.

Recommendation: Reconnect to the Analyzer Server once you have finished configuration.

Configuration dialog

Parameters

Description

SMTP server

Entering the SMTP server information

IP address, UNC name or fully-qualified domain name.

Ping

Clicking on the button executes a ping to the server entered.

Only available if a server has been entered. The result of the ping is output in a message box.

Port

Entry of the TCP port for SMTP at the given server.

Possible values: 0 to 65535.

Invalid inputs are shown in a tooltip and not accepted.

Account name

Entry of the account name.

If no account name has been configured for the SMTP server, the field can remain empty.

Use the Sender address property to stipulate an email account for the sending of reports.

Timeout (seconds)

States how many seconds are waited for a valid socket connection with the SMTP service. The process is canceled after that.

Possible values: Whole number greater than 0.

Default: 30 seconds.

Attention: The value is ignored if SMTP server in the network is selected as a sending method.

Invalid inputs are shown in a tooltip and not accepted.

SMTP service pickup folder

Entry of a local save path from which the SMTP service calls up outgoing emails.

It must be a fully-qualified local folder path (for example D:\rs-emails).

Browse...

Opens the dialog for selecting a folder.

Validate

Clicking on the button checks whether the path entered exists.

Only available if a path has been entered.

The result of the validation is output in a message box.

SSL usage

Determination of whether SSL can be used. Select from drop-down list:

  • SSL usage not specified
  • Do not use SSL
  • Use SSL

Sending method

Selection of the sending method for emails from drop-down list:

  • Sending method not specified
  • Local SMTP service pickup folder
  • SMTP server in the network

Authentication for the SMTP server in the network

Selection of authentication method. Select from drop-down list:

  • Authentication not specified
  • No authentication
  • NTLM authentication

Sender address

Entry of a sender address for emails. Necessary if you use an SMTP remote server.

Format: abc@host.xyz

The address should be a valid email account with the authorization to send emails.

In the event of incorrect entries, the background color is switched to red and a tooltip is displayed.

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Manage schedules

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Automation -> Manage schedules

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In order for the provision of reports to be automated using schedules, there must be a connection to an Analyzer server with a valid license.

To create and administer schedules for the deployment of reports:

  1. Select the Manage Schedules entry in the Automation menu.
  2. the dialog for administering the schedule is opened
  3. Preconfigured schedules are displayed
  4. Create a new schedule or edit an existing one

Parameters

Description

Available schedules

Display and filtering of the already-configured schedules.

Filter field

Entry of a filter for the List of schedules.

Only schedules that correspond to the filter criteria are shown in the list.

Wildcards:

  • ?: Wildcard for precisely 1 character
  • *: Wildcard for 0 or more characters

If there is no wildcard in the filter expression, a * is automatically added to the end when filtering.
For example:

  • „" (empty field) becomes *
  • test becomes test*
  • t?st remains t?st

List of schedules

List of all preconfigured and available schedules.

Schedule properties

Displays the preconfigured properties of the schedule highlighted in the list.

  • Schedule name
  • Details about the schedule
  • Start time of the schedule
  • End time of the schedule
  • Status of the schedule
  • Time of the last execution of the schedule
  • Time of the next execution of the schedule

Attention: The texts can be displayed in different languages. They come partly from ZAMS and partly from the web service. These can be configured in different languages.

New

Opens the dialog to create a new schedule.

Edit

Opens the dialog to edit a schedule.

Delete

Deletes the selected schedule from the list and from the Analyzer server.

If a schedule to be deleted is used for one or more subscriptions, then a warning is given for each subscription. The user must decide if all relevant subscriptions should be deleted with the schedule.

  • Yes: First the respective subscriptions are deleted, then the schedule.
  • No: Neither subscriptions nor the schedule are deleted.

Refresh

Refreshes List of schedules.

Close

Closes the dialog.

Creating and editing schedules

To create a new schedule:

  1. click on the button New
  2. The dialog is opened with the standard values for all input possibilities

To amend an existing schedule:

  1. Highlight the desired schedule in the list
  2. click on Edit
  3. The dialog is opened with the values for the selected schedule

To delete a schedule:

  1. Highlight the desired schedule in the list
  2. Click on Delete
  3. The schedule is deleted

Dialog to create and edit a schedule

Parameters

Description

General

General settings for the schedule:

  • Name
  • Recurrence configuration

Name

Name of the schedule.

Recurrence configuration

Recurrence configuration for the time plan. There are the following patterns:

  • Once
  • Minutes and hours
  • Days
  • Days in weeks
  • Days in months
  • Days in weeks of months

The patterns are configured in the Recurrence configuration section.

Start and expiration

Start and end times for the plan.

Start time

Start date.

Start time

Start time.

Schedule expires

Active: Time plan has a defined date of expiration.

Can only be activated if the pattern is not Once.

Date of expiration

Date of expiration.

Recurrence configuration

Configuration of the recurrences For details, see the "Configure recurrences" section.

OK

Applies the selected configuration and closes the dialog.

Cancel

Closes the dialog without executing any actions

Errors during the action prevent the dialog being confirmed with OK and are displayed via messages in the output window.

Configuring recurrences

Recurrences are configured in the right-hand section of the dialog. Only the Recurrence configuration area is shown in the manual for the description of the individual pattern.

attention Attention

If an already-configured schedule is called up for editing again, it can happen that the configuration does not correspond to the pattern entered previously. The execution times of the schedule remain the same, only the display of the configuration is affected.

Background: The web service examines the configuration of a schedule and converts it to a simpler pattern, regardless of its configuration.

For example: In weekdays, each day was activated and the week interval is set to 1. The web service makes the simpler pattern Days days out of this, with an interval of 1.

Once

Is only executed once. The settings for Recurrence configuration are thus not available.

Minutes and hours

Defines the interval between two executions of the schedule in hours and minutes.

Parameters | Description
hours | Hours are stated.
Minutes | Minutes are stated.

Note: If both properties are set to 0, this leads to an error.

Days

Defines the distance between two executions of the schedule in days.

Parameters | Description
Days | number of days between two executions.

Note: If 0 is set, this leads to an error.

Days in weeks

Defines the distance between two executions in weekdays and weeks of execution.

Parameters | Description
Interval in weeks | Interval between the executions in weeks.
Days in weeks | Weekdays on which the schedule is to be executed.

Example: A schedule for "every second Wednesday" would have Wednesday highlighted as the execution day and a weekly interval of 2.

Note: If no days are highlighted or 0 is set for weeks, this leads to an error.

Calendar days per month

Defines the interval between two executions of the schedule over days and weeks of execution.

Parameters | Description
Days per month | Activation of the active days via the checkboxes. Note: The possible execution dates are orientated to the shortest month, February. They are therefore limited to 28.
Month | Activation of the active months.

Note: If no entry is activated in one of the properties, this leads to an error.

Days in weeks of months

Defines the interval between two executions of the schedule in active weekdays according to week of execution and month of execution.

Parameters | Description
Days in weeks | Selection of the active weekdays.
Month | Selection of months in which the selected days are active..
Week in month | Selection of the week of the active month in which the schedule is executed.

Note: If no entry is activated in one of the properties, this leads to an error.

Limitations

  • Days per month are limited to 1 - 28 (corresponds to February in non-leap years)
  • The "Month end" event is not available


Administer report subscriptions

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Automation -> Administer report subscriptions

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Requirements: In order for reports to be subscribed to, there must be a connection to an Analyzer server with a valid license.

To subscribe to reports:

  1. Select the Manage subscriptions entry in the Automation menu.
  2. the dialog for administering the subscriptions is opened

Parameters

Description

List of report subscriptions

List of the already-configured subscriptions with detailed information:

  • Description: Description of the subscription.
  • Report: The report used in the subscription.
  • Owner: Owner of the subscription.
  • Subscription status: Status of the subscription.
  • Last Run: Time of the last execution of the subscription.

New

Opens the dialog to create a new subscription with the standard values for all input possibilities.

The table with the subscriptions is updated once the opened dialog has been confirmed.

Edit

Opens the dialog to edit the selected subscription with the values configured for the selected subscription.
The table with the subscriptions is updated once the opened dialog has been closed.

Delete

Deletes the highlighted subscription without asking for confirmation.
The table with the subscriptions is updated after the action has been carried out.

Refresh

Refreshes the List of report subscriptions.

Close

Closes the dialog.

attention Attention

There can be mixes of different languages in all dialogs of this function.

Background: The texts are created by ZAMS, by the web service and also by Microsoft Extension DLLs (for the dispatch methods of the subscriptions). Theses sources support different languages depending on installation and configuration.

Creating and editing subscriptions

To create a new subscription:

  1. click on the button New
  2. The dialog is opened with the standard values for all input possibilities

To amend an existing subscription:

  1. Highlight the desired subscription in the list
  2. click on Edit
  3. The dialog is opened with the values for the selected schedule

To delete a subscription:

  1. Highlight the desired subscription in the list
  2. Click on Delete
  3. The subscription is deleted

Dialog for creating or editing a subscription

Parameters | Description
General settings | Configuration of the general settings for the subscription.
Report parameters | Configuration of the parameters for the selected report.
Delivery method | Configuration of the delivery method for the report.
Previous | Switches to previous tab. Not active in this tab.
Next | Switches to the next tab.
OK | Accepts the configuration, creates the subscription and closes the dialog. Only available if no invalid data is present. Input fields with invalid content are stored in red.
Cancel | Discards changes and closes the dialog.

Note: Errors during configuration prevent the dialog being confirmed with OK and are displayed in the output window.

Other topics in this chapter

General settings

Report parameters

Delivery method


General settings

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Automation -> Administer report subscriptions -> General settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You select the report, delivery method and schedule in this report. You configure report parameters and delivery method in the following tabs.

Parameters

Description

General settings

General settings for the subscription:

Report

Selection of a report for the subscription from a drop-down list.
This selection determines which properties are offered in the Report parameters group.

Delivery method

Selection of a method with which the report is sent from a drop-down list:

  • Save report as shared file:
    The report is saved to a network drive in an approved folder.
    This option is always available. Other options depend on the configuration of the reporting services.
  • Send report via e-mail:
    The report is sent by email.
    Only available if the reporting services are configured accordingly.

This selection determines which properties are offered in the delivery method group.

Schedule

Selection of a schedule for the subscription.

Note: The schedule for the subscription can be created directly on the Analyzer server and saved with this. This is not supported by ZAMS.

Manage schedules

Opens the dialog to create ad edit schedules.

If this is executed, the table with the schedules is updated in the list of schedules.

Previous

Switches to previous tab.
Not active in this tab.

Next

Switches to the next tab.

OK

Accepts the configuration, creates the subscription and closes the dialog.

If the information provided is not valid, the dialog remains open without saving and the erroneous configurations are shown.

Cancel

Discards changes and closes the dialog.


Report parameters

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Automation -> Administer report subscriptions -> Report parameters

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The report parameters are configured in this tab. The control elements are displayed in groups, the groupings are automatically displayed from top to bottom in one or more languages.

Parameters

Description

Display of controls

Depending on the report selected in the General settings tab, the respective controls are offered for configuration. The labels above the controls for the parameters always come from the report.

Recommendation: In the Time span control, activate the Use standard value checkbox to use the configured values for the report.

Previous

Switches to previous tab.

Next

Switches to the next tab.

OK

Accepts the configuration, creates the subscription and closes the dialog.

If the information provided is not valid, the dialog remains open without saving and the erroneous configurations are shown.

Cancel

Discards changes and closes the dialog.

info Information

Note for parameters with multiple selection:

  • If the checkbox for use of the standard values of the parameters is deselected
  • and then all values activated in the selectable list of parameters are deselected,
  • Then the standard values are set for these parameters again.

Technical background: The report server sets all parameters that have standard values and are transferred without values back to standard values.


Delivery method

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Automation -> Administer report subscriptions -> Delivery method

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You define the delivery method for the report in this tab. Save report as an approved file is always available as a standard method. Other methods depend on the configuration of the reporting services. In this documentation, the Send report by email method is also presented in addition to the standard method. The method is selected in the General settings tab.

Entries in this tab are validated each time a parameter value is validated.

attention Attention

The language of the parameters for the delivery method corresponds to the language of SQL Server.

Save report as shared file

Parameters

Description

File name

Name of the file in which the report is saved.

Must not be empty and must contain a valid name.
The following characters are not permitted: /\?|<>:*"

Path

UNC path of the authorized folder in which the file is saved. Must not be empty and must contain a valid UNC file path. Clicking on the Browse button opens the dialog to select an approved folder on the network drive.

Attention: For technical reasons, it may be necessary to enter a user name and password in the UNC browser dialog. This entry relates to access for approved drives and is not the same as parameter fields for user name and password.

Render format

Selection of the data format from drop-down list for saving the report.

Write mode

Selection of what is to happen for a pre-existing file from a drop-down list:

  • None: The file is created, but rejected again. Nothing is written.
  • Automatic incrementation: Additional information is written.
  • Overwrite: The file is overwritten.

Filename extension

Configuration of whether an extension is added to the report file:

  • Yes: The file is supplemented with a file extension appropriate to the render format property.
  • No: The file is saved without a filename extension

User name

User name for access to the authorized folder.

Must be entered in order for the validation to be successful. Only the presence of the input is checked.

Password

Password for access to the authorized folder. This is not displayed in plain text and is not supplied by the web service when the subscription is called up again.

Must be entered in order for the validation to be successful. Only the presence of the input is checked.

Previous

Switches to previous tab.

Next

Switches to the next tab.

Not active in this tab.

OK

Accepts the configuration, creates the subscription and closes the dialog.

If the information provided is not valid, the dialog remains open without saving and the erroneous configurations are shown.

Cancel

Discards changes and closes the dialog.

Send report via e-mail:

In order for reports to be able to be sent by email, the SQL Server must be configured accordingly. Configuration is carried out in ZAMS via the AutomationConfigure email server... menu item.

Configuration of the dispatch method

Parameters

Description

To

Address of the recipient.

Must not be empty and must contain a valid list of email addresses. Requirements for addresses:

  • The following characters are permitted: a-z, A-Z, 0-9, !#$%&'*+-/=?^_`{|}~.
  • Syntax: [local part]@[domain part]
  • Several addresses are separated by a semi colon (;)
  • Exactly one @ character in the whole address
  • Two periods (..) must not appear consecutively
  • Rules for local part and domain:
    - must not start with period (.)
    - must not end with period (.)
    - must contain at least 1 valid character
    - must not contain any invalid character

Cc

Address of recipients of copies.

Can be empty. The content must contain a list of valid email addresses.

Bcc

Address of hidden recipients of copies.

Can be empty. The content must contain a list of valid email addresses.

Respond to

Address to whom a response is to be sent.

Can be empty. The content must contain a list of valid email addresses.

Include report

Selection of whether the report is sent.

  • Yes: Report is attached to the email as a file.
  • No: Only one email is sent, stating that that a report is available. The report itself is not sent.
    Hint: However a link to the report can be added using the Include link option.

Render format

Selection of the data format from drop-down list for saving the report.

Priority

Selection of the priority of the email from the drop-down list:

  • Higher
  • Normal
  • low

Subject

Subject of the email The following text blocks can be replaced automatically:

  • @ReportName: Name of the report
  • @ExecutionTime: Date and time of report creation.

Comment

Additional text for the email.

Include link

Selection of whether a link to a report is included in the message.

Yes: A hyperlink to the report is included in the email.

No: No hyperlink is included.

Previous

Switches to previous tab.

Next

Switches to the next tab.

Not active in this tab.

OK

Accepts the configuration, creates the subscription and closes the dialog.

Only available if no invalid data is present. Input fields with invalid content are stored in red.

Cancel

Discards changes and closes the dialog.


Refresh caches

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Refresh caches

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

If metadata has been changed or the data from the report templates has been updated, the cache must be deleted.

The cache is deleted as standard:

  • If ZAMS is connected to a different database, the data of which is required, and the data is called up
  • ZAMS is restarted

In addition, the deletion of the cache can be triggered manually by: Menu options-> Delete cache.
This action emulates objects of a ZAMS restart for the cache manager.

Note: This action is available regardless of the connection to the Analyzer server and regardless of whether there is a valid license.
This action is not available if one of the actions Open, Prepare, Prepare all, Open in report builder or Open all in report builder are executed.

info Information

This action Delete cache only relates to ZAMS and is not identical to the cache updating function in the Report Launcher.


Creating, opening, saving and closing reports

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating, opening, saving and closing reports

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For all report actions such as opening, saving etc., it is a requirement that there is a connection to an Analyzer server with a valid license and that the desired report template has been licensed.

info Information

Validation: When loading from the hard drive, report templates (RTP), SQL templates (STP), SQL script templates (SST) and code templates (CTP) carry out a self-test. In doing so, a check is made to see whether all necessary data files and all referenced templates are available and that the report template is included in the scope of the license. Contents of the data files are not checked. Structure errors in the template definition always dominate over validation errors. Errors are reported together at the end of the loading process. If an error occurs, the template concerned cannot be used. Users are thus already made aware of missing or corrupt data when a template is loaded and not just once a report has been created.

Create new report

To create a new report:

  1. Select, in the Report menu, the New command
    or press the key combination Ctrl+N
  2. The dialog for configuring a new report is opened

    In doing so, the RTC files stored in the data folder are read and the available color schemes for report templates are identified. As standard, these are located as a subfolder in : %ProgramData%\COPA-DATA\zenonAnalyzer\ZAMS_210.

Parameters | Description
Theme | Selection of a theme from the drop-down list. After selection, a description of the class is displayed below the drop-down list.
Report template | Selection of a report template from drop-down list. Only available if a color scheme has been selected. After selection, a description of the template is displayed below the drop-down list.
Preview | Displays a preview screen of the report template selected.
OK | Creates a new report that is based on the selected template. The dialog to save the report is opened. After saving, the report is displayed in the report area of ZAMS as an active report.
Cancel | Exits the dialog without creating a report.

Open report

To open a report:

  1. Select, in the Report menu, the Open command or press the key combination Ctrl+O
  2. The browser to select a saved report is opened, whereby the folder defined in the Options is preselected
  3. Select the desired reports (multiple selection is possible)
  4. confirm the selection by clicking on OK.
  5. All selected reports are loaded and displayed in the report area of the ZAMS; the last report that was selected is activated

A progress display is shown when several reports are opened. If a report that has already been opened is to be opened again, this report is not opened again but is instead displayed as active and a corresponding message is displayed in the output window. When checking the report, upper-case/lower-case letters are not taken into account.

List of the reports last opened.

Depending on the settings in the options, the reports that were open last are offered in a list. To open a report from this list, select, in the Report menu, the Most recently edited reports entry and select the desired report. The report that was edited last is shown at the top of the list. The number of reports offered is stipulated in the settings.

  • Minimum: 1
  • Maximum: 255
    If the permitted maximum is exceeded by a report that is being added, the oldest entry is deleted.

The reports that are currently open are also displayed in the list. An attempt to select a report that is already open is canceled with an error message. The corresponding report is then activated in the main window.

The entries are updated if:

  • A connection to an Analyzer database is established
  • A report is opened from the hard drive
  • An amended report is saved to the hard drive
  • The maximum number of reports to be displayed is changed in the settings

Opening a write-protected report

Report files that are write-protected can be opened. For these reports, in addition to the name, the notice (write protected) and a corresponding message are displayed in the output window. Changes to the report settings can only be saved in a new report file. The symbol and the Save command are not available.

Save report

To save a report:

  1. Select, in the Report menu, the Save command
    or press the key combination Ctrl+S
  2. If the report has not been saved before, the dialog to select a save location is opened
  3. If the report has already been saved under this name, the following is carried out regardless of the settings in the options:
    • The existing report is overwritten
    • The changes are not saved
    • A dialog to confirm the overwriting is opened

    Attention: The status message "Storing succeeded" in the output window only indicates that the process has been completed without problems, not that the changes have been saved. If changes are not saved, a warning is given and the asterisk next to the report name in the tab remains. A message is given if changes are saved.

Save under new name

In order to save amended reports under a new name, select the Save as command or the Ctrl+Shift+S keyboard shortcut. If there is already a report with the same name, this is either not saved, overwritten or overwritten after requesting confirmation, depending on the configuration of the Options. If an attempt is made to overwrite the saved file of another report that was open in the ZAMS, the process is canceled with an error message.

Save all open reports

To save all open reports, select the Save all command or the Ctrl+Alt+S keyboard shortcut. If there is already a report with the same name, this is either not saved, overwritten or overwritten after requesting confirmation, depending on the configuration of the Options. Files are only resaved if changes have actually been made.

When saving all reports:

  • A check is made to see if each report has a valid save path:
    If, in the event that there is not a valid path, the selection of a valid path is canceled, the saving is also canceled
  • If any conflicts are recognized:
    Conflicts lead to saving being canceled
  • If all necessary confirmations to overwrite existing data or entries in an individual dialog have been obtained:
    Saving is carried out if confirmation has been given, otherwise the process is aborted

Overwrite report when saving

If an existing report is to be overwritten, a dialog to confirm this is opened with the standard configuration of the options.

Parameters

Description

List of reports

Displays all reports that are overwritten when saved.

  • A tick in the check box allows the report to be overwritten.
  • An empty check box prevents overwriting.

Select all

Selects all reports displayed to be overwritten.

Deselect all

Prevents all displayed reports being overwritten.

OK

Accepts settings, executes defined actions (overwrite/do not overwrite) and closes dialog.

Cancel

Discards settings and closes the dialog.

Close report

To close a report:

  1. Select the Close command in the report menu
  2. If the report was changed and not saved, the dialog to save reports is opened.
    • If this dialog is exited, the report is not closed
    • If the dialog is confirmed with OK, the report is closed in accordance with the requirements and removed from the report area

Close all reports

To close all reports:

  1. Select the Close all command in the report menu
  2. Unchanged reports are closed
  3. For reports that have been changed and has not been saved yet, the dialog to save reports is opened.
    • If this dialog is exited, the reports are not closed
    • If the dialog is confirmed with OK, the reports are closed in accordance with the requirements and removed from the report area


Deploy reports

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Deploy reports

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In order for a report to be deployed, there must be a connection to an Analyzer server with a valid license.

Note: When checking the paths, capitalization of letters is not taken into account.

Preparing multilingual reports

To prepare multilingual reports:

  1. In the ZAMS menu, go to Options
  2. click on Settings
  3. Navigate to the Language settings tab
  4. Configure multilingual preparation
  5. Confirm the configuration by clicking on the OK button
  6. Navigate to the Report menu
  7. Select the Deploy or Deploy all command.

Progress bar in the status line

When deploying all reports, the progress bar in the status line is displayed. In doing so, each of the following steps initializes the progress bar and fills it completely during the course of progress:

  • Step 1 of 5: Analysis (validation) of the reports
  • Step 2 of 5: Saving of reports (this is skipped if no reports are to be saved)
  • Step 3 of 5: Creation of SPs and UDFs
  • Step 4 of 5: Creation of the RDL files on the server
  • Step 5 of 5: Opening of the reports in the Report Builder (this is skipped if no reports are to be opened in the Report Builder)

Using reports and carrying out actions in ZAMS

Recommendation: Do not execute any reports whilst actions are being carried out with ZAMS that relate to these reports. Most of all if ZAMS:

  • is deploying reports
  • is updating the connector functions in the database
  • is creating the SQL connector


Opening reports in Microsoft Report Builder

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Opening reports in Microsoft Report Builder

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports can be opened and edited in Microsoft Report Builder. In order for the Report Builder to be started and reports edited with it, there must be a connection to an Analyzer server with a valid license.

Start Report Builder

To start the Report Builder:

  1. Select the Start Microsoft Report Builder command in the report menu
  2. An Internet Explorer process with the URL of the Report Builder application is started
  3. If necessary, the application is downloaded
  4. The Report Builder is opened.
  5. The Internet Explorer process is ended

Open report in Report Builder

To open the report active in the report window in Report Builder:

  1. Select the Open in Microsoft Report Builder command in the report menu
  2. The Report Builder is opened.
  3. The report is opened in Report Builder

Note: If the Report Builder is not able to open the report from the path given, this does not cause an error message in ZAMS. The error is reported in Report Builder

Open all reports in Report Builder

To open all reports active in the report window in Report Builder:

  1. Select the Open all in Microsoft Report Builder command in the report menu
  2. Report Builder is opened.
  3. The reports are opened in Report Builder
  4. The progress display in the status bar informs you of the progress of the opening

Note: If the Report Builder is not able to open a report from the path given, this does not cause an error message in ZAMS. The error is reported in Report Builder


Creating color definition for reports

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The coloring of reports can be defined using a color scheme. All color schemes for reports are administered in ZAMS.

Color scheme

zenon Analyzer is supplied with the Analyzer Initial color scheme as standard. This color scheme can be supplemented with your own, individual color scheme.

COPA-DATA standard

The Analyzer Initial color scheme

  • Is fixed
  • Cannot be changed.
  • Cannot be exported.
  • Cannot be overwritten by imported files.

Individual color scheme

ZAMS users can do the following with individual color schemes:

  • Create and edit
  • export
  • import

Selecting a color scheme

To select a color scheme:

  1. open the menu Options
  2. Click on the Manage color scheme entry
  3. The dialog for administering the color scheme is opened

  4. Select the desired option from the drop-down list for the Active color schemes option
  5. Confirm your selection by clicking on the OK button

Other topics in this chapter

Creating and editing variables

Exporting a color scheme

Import color scheme


Creating and editing variables

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To administer a color scheme:

  1. open the menu Options
  2. Click on the Manage color scheme entry
  3. The dialog for administering the color scheme is opened

Parameters | Description
Active color scheme | Selection of a color scheme from the drop-down list. The standard color scheme is always displayed at the top of the list. The individual color scheme is sorted alphabetically.
Userdefined color schemes | Properties for the creation and editing of your own color scheme.
Filter conditions | Entry of a filter text that filters displayed elements in the list of Available color schemes. The filter criteria is met if the filter text appears at a desired location in the name of a color scheme. Capitalization of letters is ignored (not case sensitive).
Available color schemes | List of all available individual color schemes for the selection of a color scheme for editing or deleting.
New | Clicking on the button opens the dialog to create a color scheme. The new color scheme is entered at the same time with a standard name in the list of Available color schemes. Any filter text that may be present is removed, so that the color scheme is certain to be displayed in the list. If the standard name is already present in the list, it is supplemented with a counter in brackets.
Edit | Clicking on the button opens the dialog to edit the selected color scheme. A color scheme can also be renamed in this dialog.
Delete | Deletes selected color scheme without requesting confirmation. If a color scheme that is also entered as an active color scheme is deleted, the active color scheme is taken on as the standard color scheme.
OK | Applies settings and closes the dialog.
Cancel | Discards all changes and closes the dialog.

Creating a color scheme

To create a new color scheme:

  1. Open the dialog Manage color schemes.
  2. click on the button New
  3. The dialog for defining a color scheme is opened

Parameters

Description

Color scheme name

Entry of a freely-definable name for the color scheme to be configured.

A name is valid if it:

  • Is not blank
  • No other color scheme has the same name
    (if the standard name is left and this already exists, it is given a counter and accepted.)

Tabs for configuration

A color scheme for reports is configured using the following tabs:

  • Text fields
  • Parameter area
  • Footer
  • Chart background
  • Chart axis
  • Chart series
  • Area chart
  • Chart legend
  • Chart data labels
  • Chart data markers
  • Table cells
  • Gantt Chart

For details, see the corresponding subchapter.

OK

Accepts all changes in all tabs and closes the dialog.

Only active if a valid name has been entered.

Cancel

Discards all changes on all tabs and closes the dialog.

Edit color scheme

To edit a color scheme:

  1. Open the dialog Manage color schemes.
  2. Select the desired color scheme in the list of Available color schemes
  3. Click on the Edit button
  4. The dialog for defining a color scheme is opened

Rename color scheme

To rename a color scheme:

  1. Open the dialog Manage color schemes.
  2. Select the desired color scheme in the list of Available color schemes
  3. Click on the Edit button
  4. The dialog for defining a color scheme is opened
  5. Change the name in the Name of color scheme option
  6. Confirm the change by clicking on the OK button

Filtering the color scheme

The list of individually-created color schemes can also be displayed with filters:

To filter the list:

  1. Enter the filter criteria in the Filter condition option
    Note: Filters are case sensitive

  2. The list is shown after filtering

To show the list in full again, delete the filter criteria.

Other topics in this chapter

Text fields

Parameter area

Footer

Chart background

Chart axis

Chart series

Area chart

Radar chart

Chart legend

Chart data labels

Chart data markers

Table cells

Custom report items


Text fields

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Text fields

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of text fields:

Properties for text fields are available for the following text elements:

  • Report title font
  • Label font
  • Value font

The following options are available for each of these elements:

Parameters

Description

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Parameter area

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Parameter area

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the parameter area:

Parameters

Description

Parameter box

Definition of the properties for borders and background of the parameter output area

Border style

Selection of the border style from the drop-down list. The following values are available:

  • None
  • Solid
  • Double
  • Dashed
  • Dotted

Border width

Setting the border width:

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Border color

Display of the selected border color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Background color

Display of the selected background color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Parameter label font

Definition of the font properties of the text box for parameter names.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Parameter value font

Definition of the font properties of the text box for parameter values.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Footer

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Footer

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the footer:

Parameters

Description

Footer font

Configuration of the font properties of the text boxes in the footer.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Footer line

Configuration of the properties of the footer line.

Line width

Setting of the line width.

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Line color

Display of the selected line color. The setting is made using the Choose color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Chart background

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Chart background

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the chart background.

Parameters

Description

Grid lines

Configuration of the properties for grid lines in the background of the chart area.

Line style

Selection of the line style from the drop-down list. The following values are available:

  • None
  • Solid
  • Dashed
  • Dotted
  • DashDot
  • DashDotDot
  • Default: Solid

Line width

Setting of the line width.
Entry in the field or using the cursor keys.

  • Minimum: 1
  • Maximum: 100

Default: 1

Changing of the setting using the cursor keys is carried out in increments of 0,5.

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Line color

Display of the selected line color.

Select using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Chart area background color

Configuration of the settings for the background for the chart area. The background of the chart area is the area that is in the actual chart. The area is limited by axes.

The background of the chart area is colored alternately with the base color and the alternative color.

Pie charts always have a transparent background in this area.

Background color

Display of the selected background color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Background interlace color

Selection of alternative background color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Chart item background color

Configuration of the settings of the object background for charts. The object background is the area that comprises the chart in the report including keys and axes.

Background color

Display of the selected background color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Gradient end color

Display of the end color of the color gradient.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Gradient type

Selection of a color gradient type from drop-down list. The background is colored with the selected color gradient type, starting from the basic color through to the gradient end color. The following values are available:

  • None
  • LeftRight
  • TopBottom
  • Center
  • DiagonalLeft
  • VerticalCenter

Note: The values DiagonalRight and HorizontalCenter are not available. However if these values are nevertheless used, they can be selected in the Microsoft Report Builder in the properties of the graphic object. If these values are set using dynamic expressions, such as a VB.NET code call, then they are shown as TopBottom.

Background color of the circular graphic object

Configuration of the settings of the object background for pie charts.

The settings for pie charts are different to other diagrams in this area, because the background color of the chart is transparent.

Background color

Display of the selected background color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Gradient end color

Display of the end color of the color gradient.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Gradient type

Selection of a color gradient type from drop-down list. The background is colored with the selected color gradient type, starting from the basic color through to the gradient end color. The following values are available:

  • None
  • LeftRight
  • TopBottom
  • Center
  • DiagonalLeft
  • VerticalCenter

Note: The values DiagonalRight and HorizontalCenter are not available. However if these values are nevertheless used, they can be selected in the Microsoft Report Builder in the properties of the graphic object. If these values are set using dynamic expressions, such as a VB.NET code call, then they are shown as TopBottom.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Chart axis

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Chart axis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the chart axis:

Parameters

Description

Chart axis font

Configuration of the font sizes of the figures on the axis.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Chart axis line

Configuration of the settings for the axis lines

Line style

Selection of the line style from the drop-down list. The following values are available:

  • None
  • Solid
  • Dashed
  • Dotted
  • DashDot
  • DashDotDot
  • Default: Solid

Line width

Setting of the line width.
Entry in the field or using the cursor keys.

  • Minimum: 1
  • Maximum: 100

Default: 1

Changing of the setting using the cursor keys is carried out in increments of 0,5.

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Line color

Display of the selected line color.

Select using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Chart axis scale break

Configuration of the settings for the axis breaks

Border style

Selection of the line style from the drop-down list. The following values are available:

  • None
  • Solid
  • Dashed
  • Dotted
  • DashDot
  • DashDotDot
  • Default: Solid

Border width

Setting the border width:

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Border color

Display of the selected border color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Spacing

Setting of the distance between the two lines that mark a break.

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.

Note: Display of the values of the axis breaks in the PDF

For the PDF rendering engine of the SQL server 2016 reporting services, problems with the validation of values entered have been reported for certain values. If values different to the standard scheme are to be entered, the following procedure is recommended:

  1. Always change only one value at a time.
  2. Then confirm the dialog with OK.
  3. prepare a report with a chart (such as an archive trend with line chart) as a test.
  4. Execute the report and export it as a PDF.
  5. If the chart is not displayed in the PDF file with the report, the currently-changed value is not correctly recognized. Correct the value and test it again.


Chart series

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Chart series

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the chart series:

Parameters | Description
Color of chart series x | Display of the selected color of the chart series. x stands for the number of the chart series 1 to 10. The settings for the chart series 1 are also applied to the series 11, 21, 31, 41 etc. This applies in a similar manner to other series 2 (12, 22, ..) to 10 (20, 30, ...). The setting is made using the Choose color button below.
Choose color | Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Area chart

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Area chart

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of area charts:

Parameters

Description

Line color

Display of the selected color for the line of an area chart.

The setting is made using the Choose color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Area color

Settings for the color of an area chart.

Area color alpha value (Transparency)

Selection of the transparency of the surface color by means of direct import or using the arrow keys of the control element.

  • Minimum: 0 (full transparency)
  • Maximum: 100 (no transparency)

Area color

Display of the selected area color. The setting is made using the Choose color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Radar chart

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Radar chart

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of radar charts:

Parameters

Description

Area color alpha value (Transparency)

Selection of the transparency of the series colors for radar charts.
Direct entry of the value into the field or by means of the cursor keys of the control element.

  • Minimum: 0 (full transparency)
  • Maximum: 100 (no transparency)

Default: 45

Radar chart series 1 color

Display of the selected 1st series color for radar charts.

Select using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Radar chart series 2 color

Display of the selected 2nd series color for radar charts.

Select using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Radar chart series 3 color

Display of the selected 3rd series color for radar charts.

Select using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Radar chart series 4 color

Display of the selected 4th series color for radar charts.

Select using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Radar chart series 5 color

Display of the selected 5th series color for radar charts.

Select using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Radar chart series border

Selection of the line configuration with style, thickness and color.

Line style

Selection of the line style from the drop-down list. The following values are available:

  • None
  • Solid
  • Dashed
  • Dotted
  • DashDot
  • DashDotDot
  • Default: Solid

Line width

Setting of the line width.
Entry in the field or using the cursor keys.

  • Minimum: 1
  • Maximum: 100

Default: 1

Changing of the setting using the cursor keys is carried out in increments of 0,5.

Line color

Display of the selected line color.

Select using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Chart legend

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Chart legend

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the chart legend:

Chart legend font

Parameters

Description

Chart legend font

Configuration of the labeling properties for the legend entries.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Chart data labels

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Chart data labels

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the database labeling in graphics:

Data label box

Parameters

Description

Data label box

Configuration of the properties for borders and background of the data labeling areas

Border style

Selection of the border style from the drop-down list. The following values are available:

  • None
  • Solid
  • Double
  • Dashed
  • Dotted

Border width

Setting the border width:

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Border color

Display of the selected border color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Background color

Display of the selected background color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Data label font

Parameters

Description

Data label font

Configuration of the labeling properties for the data labeling.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Chart data markers

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Chart data markers

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the database marking in graphics:

Data marker

Parameters

Description

Data marker

Configuration of the properties of the data marking symbols.

Marker type

Selection of the data marking symbol. The following values are available:

  • Square
  • Circle
  • Diamond
  • Triangle
  • Cross
  • Star4
  • Star5
  • Star6
  • Star10

Attention: The value None is not available here, because reports where this property is used must have a marking symbol.

Marker size

Setting of the size of the marking symbol.

Entry is possible in levels with a precision of 0.25.

  • Minimum: 1
  • Maximum: 100

Marker color

Display of the selected marking color. The setting is made using the Choose color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Data marker border

Parameters

Description

Data marker border

Configuration of the properties of the border of the data marking.

Border width

Setting the border width:

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Border color

Display of the selected border color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Table cells

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Table cells

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of the cells in tables:

Cell background

Parameters | Description
Cell background | Configuration of the settings for the background for data cells in tables.
Background color for even cells | Display of the background color for rows with an even row number (2, 4, 6, …). The setting is made using the Choose color button below.
Choose color | Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Background color for odd cells

Parameters

Description

Background color for odd cells

Display of the background color for rows with an odd row number (1, 3, 5, …).

The setting is made using the Choose color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Header cell font

Configuration of the labeling properties for the heading entries.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Body cell font

Parameters

Description

Body cell font

Configuration of the labeling properties for the data cells.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Font weight

Selection of font thickness from drop-down list. Available are:

  • Thin
  • ExtraLight
  • Light
  • Normal
  • Medium
  • SemiBold
  • Bold
  • ExtraBold
  • Heavy

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Header cell border

Parameters

Description

Header cell border

Configuration of the properties of the borders for heading cells.

Border style

Selection of the border style from the drop-down list. The following values are available:

  • None
  • Solid
  • Double
  • Dashed
  • Dotted

Border width

Setting the border width:

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Border color

Display of the selected border color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Body cell border

Parameters

Description

Body cell border

Configuration of the properties of the borders for data cells.

Border style

Selection of the border style from the drop-down list. The following values are available:

  • None
  • Solid
  • Double
  • Dashed
  • Dotted

Border width

Setting the border width:

Input is possible in levels with a precision of 0.5.

  • Minimum: 1
  • Maximum: 100

Border color

Display of the selected border color. The setting is made using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Custom report items

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Creating and editing variables -> Custom report items

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the properties of user-defined report elements such as Gantt charts or efficency classes:

Title font

Parameters

Description

Title font

Configuration of the font properties of the diagram title.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Use bold font

Active: Text is formated in bold.

Axis and label font

Parameters

Description

Axis and label font

Configuration of the font properties for axis fonts.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Use bold font

Active: Text is formated in bold.

Text and axis color

Parameters | Description
Text and axis color | Display of the selected font color. Setting is carried out using the Select color button below.
Choose color | Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Chart area background color

Parameters | Description
Chart area background color | Display of the background color selected for the chart area. The setting is made using the Choose color button below.
Choose color | Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Chart item background color

Parameters | Description
Chart item background color | Display of the background color selected for the graphics object. The setting is made using the Choose color button below.
Choose color | Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Gantt chart only

Parameters | Description
Gantt chart only | Settings only for Gantt charts:
No event color | Display of the color selected for times without an event. The setting is made using the Choose color button below.
Choose color | Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Event default color

Parameters | Description
Event default color | Display of the standard color selected for events. The setting is made using the Choose color button below.
Choose color | Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Efficiency class font

Parameters

Description

Efficiency class font

Configuration of the font properties for efficency classes.

Font family

Selection of font type from drop-down list.

Font size

The font size is set using the cursor keys or by entering it in the number field.

  • Minimum: 1
  • Maximum: 100

Use bold font

Active: Text is formated in bold.

Font color

Display of the selected font color. Setting is carried out using the Select color button below.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Exporting a color scheme

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Exporting a color scheme

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Color schemes can be exported. To export a color scheme:

  1. open the menu Options
  2. Click on Export color scheme
  3. the dialog for selecting a color scheme is opened
  4. Select the desired color scheme by clicking on the checkbox
  5. click on OK
  6. The dialog to select a save location is opened
    (this dialog is always displayed in the language of the operating system)
  7. Select the save location and enter a file name
  8. click on OK
  9. The selected color scheme is saved as an XML file

Dialog to select the color scheme

Parameters | Description
List of color schemes | Lists all existing individually-created color schemes. These can be selected by clicking on the checkbox for export.
Select all | Selects all displayed color schemes for export.
Deselect all | Deactivates marking for all selected color schemes. No scheme is still selected for export.
OK | Accepts selection, closes the dialog and opens the dialog to select a save location for the export file.
Cancel | Cancels export and closes dialog.

The size and position of the dialog can be adjusted. These modifications are saved.


Import color scheme

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Creating color definition for reports -> Import color scheme

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Color schemes can be imported. To import a color scheme:

  1. open the menu Options
  2. Click on Import color scheme
  3. The dialog to select an export file is opened
    (this dialog is always displayed in the language of the operating system)
  4. Select the save location and the desired XML file
  5. click on OK
  6. The dialog for the import is opened.
  7. Select the color scheme to be imported.
  8. Select whether the color scheme to be imported will overwrite the existing color scheme in the event of conflicts or if it is to be saved under a new name
  9. click on OK
  10. The selected color schemes are imported and added to the list of individually-created color schemes

Import color scheme dialog

When importing an XML file with color scheme, all the color schemes contained therein are displayed in a dialog. Color schemes can be selected for import in the dialog and a decision can be made as to how conflicts are handled.

Parameters

Description

List of color schemes

Lists all existing individually-created color schemes. These can be selected by clicking on the checkbox for export.

Symbol

Shows whether a color scheme with this name already exists.

Color scheme name

Name of the color scheme to be imported. Clicking in the checkbox highlights the color scheme for import.

The width of this column can be adjusted.

Resolution of the collision

If there is already a color scheme with the same name, two options to resolve the conflict are offered. Select from drop-down list:

  • Rename imported scheme: The color scheme is imported under a different name Selection in the 'import name' option.
    Default: [existing name] (serial number].
  • Overwrite existing scheme: Imports color scheme and overwrites the existing one.

The width of this column can be adjusted.

Import name

Name of the color scheme to be imported if this is to be renamed on import. Clicking in the field allows editing of the proposed default name.

Select all

Selects all displayed color schemes for import.

Deselect all

Deactivates marking for all selected color schemes. No scheme is still selected for import.

OK

Accepts selection, closes this dialog and imports the selected color scheme.

Cancel

Cancels import and closes dialog.

The size and position of the dialog can be adjusted. These modifications are saved.


Manage RDL templates

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Manage RDL templates

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

RDL templates are used when preparing reports. They always contain the report header with all elements contained in this, such as text, graphics, etc.

RDL templates can be restored and administered in ZAMS. The following is possible:

  • Restoring of an RDL template from an RDL file to the computer.
  • Restoring of an RDL template from a report on the server.
  • Importing of RDL templates from other ZAMS versions.
  • Selection of the RDL template to be used for the provision.
  • Deletion of RDL templates.

Other topics in this chapter

Read from RDL file

Read from report on server

Import from other application versions


Read from RDL file

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Manage RDL templates -> Read from RDL file

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

RDL templates can be read from RDL files on the computer. To do this:

  1. Click in the RDL templates dialog on the Read from RDL file button.
  2. The file browser is opened.
  3. Navigate to the desired RDL file.
    The file must contain a header.
  4. The dialog to name the new template is opened.
  5. Please enter an unique name.
  6. Click on OK.
  7. The new template is entered in the list


Read from report on server

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Manage RDL templates -> Read from report on server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

RDL templates can be read from reports on the Analyzer Server. To do this:

  1. Click, in the Administer RDL templates dialog, on the Read from report in the server button.
  2. The dialog for selecting a report is opened
    All reports that are found are shown in a tree structure according to their save path.

  3. Navigate to the desired report.
    The report must contain a header.
  4. The dialog to name the new template is opened.
  5. Please enter an unique name.
  6. Click on OK.
  7. The new template is entered in the list


Import from other application versions

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Analyzer Server and Reports -> Manage RDL templates -> Import from other application versions

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

RDL templates can be read from RDL files on the computer. The files to be imported must be in the RDL templates subfolder of the ZAMS version. For example: %ProgramData%\COPA-DATA\zenonAnalyzer\ZAMS_[Version]\RDL_Templates.

To do this:

  1. Click, in the RDL templates dialog, on the Import from other application versions button.
  2. The dialog with the list of all RDL files of a different version with a header are opened.

  3. Select the desired templates.
  4. Select the desired version if required.
  5. If there are naming conflicts: Decide whether the template to be imported is to be renamed or the existing template is to be overwritten.
  6. Give it a new, unique name if required.
  7. Click on OK.
  8. The new templates are entered into the list

Import RDL templates dialog

Parameters

Description

Status symbol

Displays whether a template with this name already exists.

Checkbox

Selection of a template for import by ticking the checkbox.

RDL template name

Name of the selected RDL template.
Display only.

Import from version

Selection of the version of the selected RDL template from the drop-down list.

Only active if there are templates from different ZAMS versions with the same name.

Collision resolve type

Selection of actions for templates whose name is already in use:

  • Rename imported scheme: The schematic is renamed on import. The current name in the Import name field is supplemented with a figure in brackets. The name can be individually amended in this field.
  • Overwrite existing scheme: The existing RDL file is replaced by the RDL file that is to be imported.

Default: Rename imported scheme

Only active if there is a naming conflict during import.

Import name

Entry of a unique name for the template to be imported:

  • The name must not be empty.
  • The name must not be used by another template.

Only active if there is a naming conflict on import and the conflict is triggered by renaming.

Select all

Clicking this selects all displayed templates.

Deselect all

Clicking this deselects the current selection.

OK

Applies settings and closes the dialog.

If a pre-existing template is to be overwritten, confirmation is requested.

Cancel

Discards all changes and closes the dialog.


Managing SQL Server

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You can get to the tools to manage the SQL connections and the databases via the SQL server menu item:

Parameters | Description
Update connector functions | Renews the Connector functions. The result is displayed in the output window.
Create SCADA SQL connector | Opens the dialog to create an SQL connector.
Create 3rd party database connector | Starts the configuration of the connector for third-party databases.
Configure calculated archives | Starts the dialog to configure calculated archives.
New Analyzer database | Opens dialog to create a new Analyzer database.
Convert databases | Starts the conversion of databases, the version number of which is lower than the current version number.
Create database backups | Opens the dialog for creating a project backup.
Restore database backup | Opens the dialog for renaming a profile.
Restore database backup file as new database | Opens the dialog for restoring a database backup as a new database.
Restore Reporting Services database backup | Opens the dialog for restoring the reporting services database.
Administrate automated database backups | Opens the dialog to administer the automatically-created database backups.
Manage database backup files | Opens the dialog to administer the backup files of the database.
Manage linked server | Opens dialog to manage the linked servers.
Manage metadata indices | Opens the dialog to manage the metadata indices.

Other topics in this chapter

Update connector functions

Create SCADA SQL connector

Create 3rd party database connector

New Analyzer database

Convert databases

Manual database backups

Restore database backup file as new database

Restore Reporting Services database backup

Administrate automated database backups

Manage database backup files

Manage linked server

Manage metadata indices


Update connector functions

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Update connector functions

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This function is available if there is a connection to an Analyzer server with a valid license.

By selecting the Update connector functions action, you update the database assembly zrsUserFunctions or create this if it is not present and update the attendant SQL UDFs in the database. The assembly establishes the connection between the database and the connector stub. The following tasks are carried out in the process:

  1. All existing UDFs for the assembly are rejected.
  2. The assembly is rejected if it exists already.
  3. The assembly is created.
  4. All UDFs are created.
  5. The database is set so that the functions of the assembly can be executed.

Errors and confirmations are stated in the output window.

Existing SCADA SQL connectors are retained and are not discarded.


Create SCADA SQL connector

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create SCADA SQL connector

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In order to be able to create an SQL connector, there must be a connection to an Analyzer server with a valid license.

To create an SQL connector:

  1. Select, in the SQL Server menu, the Create SQL connector command
  2. The dialog to create an SQL connector with both tabs Databases and Projects is opened

info Information

In order to be able to create an SQL connector, there must be at least one project in the database that is currently connected.

Databases

Selection of databases and linked server where the search for tables is to be made.

Parameters

Description

Currently-connected SQL server instance

Properties of the SQL server instance to which ZAMS is currently connected.

Currently-connected database [NAME]
  • Active: A search for tables is to be made in the currently-connected database.

The name of the database that is currently connected is displayed at the end of the option.

Other databases on the currently connected SQL server instance

Selection of databases on the SQL server instance that is currently connected where a search for tables is to be carried out.

The selection is made by activating the checkboxes.

Linked Servers

Linked Server on the SQL server instance to which ZAMS is currently connected.

SQL

Only contains linked SQL servers.

Provider: SQLNCLI

The selection is made by activating the checkboxes.

Azure

Only contains linked SQL Azure servers.

Provider: SQLNCLI11

The selection is made by activating the checkboxes.

Oracle

Only contains linked Oracle servers.

Provider: OraOLEDB.Oracle

The selection is made by activating the checkboxes.

ODBC

Only contains linked ODBC servers.

Provider: MSDASQL

The selection is made by activating the checkboxes.

OK

Closes the dialog, saves the configuration of both tabs and opens the dialog to configure the SQL connector.

The parameters are set up via three tabs:

  • AML and CEL
  • Archive tables
  • Shift tables

For details, see the corresponding sections.

Cancel

Cancels the process of creating the SQL Connectors and closes the dialog.

Note: All data sources are activated by default.

Projects

In this tab, you define the data from the projects in the data sources defined in the prior tab are to be searched for according to tables.

Parameters

Description

Project selection

Selection of a project.

If a project is selected, the project configuration group is filled with the project configuration.

Project configuration

Configuration of the selected project.

Search for data for this project

Active: A search for tables is made in this project. Further options are shown.

Inactive: No search for tables is made in this project.

Search for AML data tables

Active: A search for AML tables is made (table name ends with _ALARM).

Search for CEL data tables

Active: A search for CEL tables is made (table name ends with _CEL).

Search for shift tables

Active: A search for shift data tables is made. The shift tables to be searched for are taken from the EQUIPMENTSHIFT metadata table.

Search for data tables for these archives

Selection of the projects for which searches for tables are to be made. Three tables are used in the process:

  • [project name]_[short archive description] -> archive data
  • [project name]_VARIABLES -> variables in the archive
  • [project name]_[short archive description]_LOT -> lot data. According to this table, a search is only made if the archive in the metadata is defined as a lot archive (LOTARCHIV column in the ARCHIVE metadata table).

OK

Closes the dialog, saves the configuration of both tabs and opens the dialog to configure the SQL connector.

The parameters are set up via three tabs:

  • AML and CEL
  • Archive tables
  • Shift tables

For details, see the corresponding sections.

Cancel

Cancels the process of creating the SQL connectors and closes the dialog.

Other topics in this chapter

Configuration of the SQL Connector

Configuration of the archive tables

Configuration of the shift tables

Configuration of the provider


Configuration of the SQL Connector

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create SCADA SQL connector -> Configuration of the SQL Connector

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Click on the OK button in the dialog for creating an SQL connector to open the dialog to configure the SQL connector. A standard configuration is created for each project before the dialog is opened.

The dialog consists of three tabs:

  • AML and CEL
  • Archives tabels
  • Shift tables

The settings are saved after configuration. The last settings saved are displayed the next time the dialog is called up.

AML table and CEL table dialog

Parameters

Description

Project selection

Selection of the project from the drop-down list makes requirements for the properties to be configured. The selection applies for all three tabs.

AML table selection

Configuration of the AML table to be used.

Selection of the desired AML table from the drop-down list. This contains all AML tables found and an entry for Do not create.

The description of the selected table is displayed below the drop-down list.

Note: With connections to an MS Azure server, the AZURE - is placed in front of the configuration as a prefix.

CEL table selection

Configuration of the CEL table to be used.

Selection of the desired CEL table from the drop-down list. This contains all CEL tables found and an entry for Do not create.

If no tables are found, the drop-down list displays a corresponding entry and is deactivated.

Note: With connections to an MS Azure server, the AZURE - is placed in front of the configuration as a prefix.

Restore default configuration

Resets the AML and CEL tables for the project currently being displayed back to the standard configuration.

OK

Saves settings of all three tabs, closes the dialog and creates the SQL connector.

Cancel

Cancels the process of creating the SQL connectors and closes the dialog.

Archive table dialog

Parameters

Description

Project selection

Selection of the project from the drop-down list makes requirements for the properties to be configured. The selection applies for all three tabs.

List of tables

Displays all archives that are switched to active when configuring the table search and the respective tables found. The following are displayed:

  • Archive name
  • Archive data table
  • Archive variable table
  • Lot table

If no archive data table is found for an archive or this is not to be integrated into the SQL connector, the columns for the variable table and lot table remain empty.

Configure tables

Opens the dialog to Configure the archive tables for the selected project. The table is updated after this dialog is closed.

Restore default configuration

Resets the archive tables for all archives of the project currently being displayed back to the standard configuration.

OK

Saves settings of all three tabs, closes the dialog and creates the SQL connector.

Cancel

Cancels the process of creating the SQL connectors and closes the dialog.

Shift tables dialog

Parameters

Description

Project selection

Selection of the project from the drop-down list makes requirements for the properties to be configured. The selection applies for all three tabs.

List of shifts

Displays the shift tables for all equipment groups selected in the configuration. The following are displayed:

  • Equipment group names
  • Shift table

If no shift tables were found for an equipment group or these were configured in such a way that they are not incorporated into the SQL connector, this is displayed in the table accordingly.

Configure tables

Opens the dialog to Configure the shift tables for the selected project. The table is updated after this dialog is closed.

Restore default configuration

Resets the shift tables for all equipment models of the project currently being displayed back to the standard configuration.

OK

Saves settings of all three tabs, closes the dialog and creates the SQL connector.

Cancel

Cancels the process of creating the SQL connectors and closes the dialog.


Configuration of the archive tables

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create SCADA SQL connector -> Configuration of the archive tables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Parameters

Description

Project selection

Selection of the project from the drop-down list. The project selected in Configuration of the SQL connector is already selected.

Overview

Displays the configuration of all archives in the project. The following are displayed:

  • Archive name
  • Archive data table
  • Archive variable table
  • Lot table

If no archive data tables are present for an archive, the columns for the archive variable table and the lot table for this archive remain empty.

Configuration

Configuration of the tables.

  • List on the left-hand side:
    Selection of an archive to be configured.
  • Tab on the right-hand side:
    Three tabs to configure the archive data table, the archive variable table and the lot table for the archive selected in the list.

Configuration of the tabs:

Each tab consists of a drop-down list and a text field.

If there are no tables, this is noted in the drop-down list and it is inactive.

If tables are present, the drop-down list contains all available tables and an entry to exclude the SQL connector (do not build).

If a table is selected in the drop-down list, the text field displays the description of the table.

If the selection in the drop-down list is changed, this has the following effect, depending on the tab:

  • Archive data table:
    If the entry for closing the SQL connector is selected, then this is also changed in the drop-down list for the variable table and the lot table.
    If a table is selected, then tables are set in the same database for the variable table and the lot table, if these are present.
    After this, the overview table and the warning list is updated.
  • Archive variable table:
    The overview table and the warning list are updated.
  • Lot table:
    The overview table and the warning list are updated.

Note: With connections to an MS Azure server, the AZURE - is placed in front of the configuration as a prefix.

Warnings

List of warnings in relation to the configuration Possible reasons:

  • A data table is set and no variable table is set.
  • The variable table is in a database as the data table.
  • A data table is set and it is a lot archive, a lot table is set and the lot table is in a different database to the data table.
  • A variable table is set, although no data table is set.
  • A lot table is set, although no data table is set.

OK

Checks to see if the maintenance list is empty.

  • Empty: The dialog is closed and the changes are saved.
  • Not empty: User Query, to find out if the configuration is to be saved despite the warnings:
    Nein: The dialog remains open and the changes to the configuration are not saved yet.
    Yes: The dialog is closed and the changes to the configuration are saved.

Cancel

Closes the dialog and discards the changes to the configuration.


Configuration of the shift tables

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create SCADA SQL connector -> Configuration of the shift tables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Parameters

Description

Project selection

Selection of the project from the drop-down list. The project selected in Configuration of the SQL connector is already selected.

Overview

Displays the configuration of all equipment models and all equipment groups for which a shift table is defined in the metadata for this project. The following are displayed:

  • Equipment model name
  • Shift table
  • Configuration of inheritance:
    Contains, with equipment models and equipment groups with active inheritance of the shift table, the name of the superordinate element.
    The construction of the inheritance hierarchy is explained in the warning bx under this table.

If no tables are found for an equipment model or this is excluded by the SQL connector, this is noted in the corresponding line in the 'Shift table' column.

Configuration

Consists of:

  • List with equipment models:
    Complete connection hierarchy of the equipment models for the project set
  • Checkbox for configuration applied from parent equipment model.
  • Drop-down list
  • Text field

List of equipment models

Selection of an equipment model by clicking on the desired model.

Configuration from parent equipment model inherited.
  • Active: Configuration is taken on by superordinate element.

Can only be activated if it is not a root element in the inheritance hierarchy of the equipment model for the selected project.

Drop-down list for shift table

Configuration of the shift table for the selected equipment model.

  • If there are no shift tables for the equipment model, this is displayed in the drop-down list and the list is set to inactive.
  • If the shift table is inherited by a superordinate entry, then the inherited shift table is entered into the drop-down list and the list is set to inactive.
  • In all other cases, the shift table can be configured and the drop-down list shows all shift tables available for the selected equipment model and an entry to exclude the equipment model from the SQL connector.
    If a change is made in the drop-down list, this is forwarded to all equipment models that inherit from the selected equipment model.

Note: With connections to an MS Azure server, the AZURE - is placed in front of the configuration as a prefix.

Text field

Contains the description of the shift table selected in the drop-down list.

OK

Saves all changes to the configuration and closes the dialog.

Cancel

Discards all changes to the configuration and closes the dialog.

When the dialog is opened, the inheritance hierarchy of the equipment model for each project is created and a decision is made on which inheritances are active.

attention Attention

This hierarchy does not need to correspond to the hierarchy in the equipment model in the zenon Editor, because the shift tables entered in the metadata are also taken into account here. The following decision-making guidelines were used in the process:

  • An equipment model can only inherit the shift table configuration from another equipment model Y if the equipment model X in the zenon is a direct child of equipment model Y and the collection of the available shift tables is identical for each equipment model.
  • If an element cannot inherit from any other, it it becomes a root element for the Equipment model list.
  • A possible inheritance is then active if an element and its superordinate element are configured for use of the same shift table.


Configuration of the provider

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create SCADA SQL connector -> Configuration of the provider

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A provider is a driver for SQL Server, which allows it access to other database systems. Similar to the drivers in an HMI/SCADA system such as zenon, the driver must be configured in order for communication to work. The linked servers of the following drivers can be addressed by the SQL connector:

  • SQLNCLI for Linked SQL server
  • SQLNCLI11 for SQL Azure
  • OraOLEDBOraOLEDB.Oracle for Linked Oracle server
  • MSDASQL for Linked ODBC server

You can find the providers in the SQL Server Management Studio in the Object Explorer; the path is:
[linked instance] -> Server Objects -> Linked Servers -> Providers

Settings that are made in the properties of the provider are only applicable for the instance under which the provider is entered in the Object Explorer.

"SQLNCLI" for linked SQL server

This provider can be left with the default settings.

Addressing the tables: [linked server name].[database name].[scheme name].[table name]

"SQLNCLI11" for Linked SQL Azure Server

This provider can be left with the default settings.

Addressing the tables: AZURE -[linked server name]..[scheme name].[table name]

Note: The AZURE - prefix is to distinguish identically-created Linked Oracle databases.

"OraOLEDB.Oracle" for linked Oracle server

The checkboxes in the properties of this provider must be as in the screenshot below:

Addressing the tables: [linked server name]..[scheme name].[table name]

Note: To be able to configure an Oracle provider, the oracle database client software must already be installed.
In addition to the provider, there must also be an entry for the database server in the configuration of the Oracle client. The configuration of this depends on the version of the Oracle client used. You can find information on this in the documentation of the Oracle client used.

"MSDASQL" for linked ODBC server

The checkboxes in the properties of this provider must be as in the screenshot below:

Addressing the tables: [linked server name]...[table name]

If one of these settings is changed, all linked servers that use this provider must be recreated in order for the changes to be accepted.

Note: The data source (DSN or ODBC connection string) must be configured so that only one database is used on the target database system. You can read how a database client for ODBC can be configured as a system DSN in the documentation of the database client used.


Create 3rd party database connector

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Third-party database connectors can also be configured in ZAMS. To do this, tables from third-party database are formed as virtual archives in ZAMS. These virtual archives are incorporated into reports as archives, along the same lines as zenon archives and emulated archives.

ZAMS amends the metadata and user-defined functions (UDFs) in the database accordingly when configuring the metadata. Only the metadata necessary for the creation of the UDF is saved in the database. No usage data at all is stored in the Analyzer database. The usage data is read directly from the source table each time there is a read request for a virtual archive.

In order to be able to create a 3rd party database connector, there must be a connection to an Analyzer server with a valid license.

info Information

For virtual archives with the 3rd party database Connector, the data source must be Archive. Variables from these archives are not available for the data sources AML or CEL.

Create connector

To create a 3rd party database connector:

  1. Select, in the SQL server menu, the 3rd party database connector command
  2. Confirm the selection by clicking OK The dialog for the selection of available databases is opened.
  3. Select the desired databases.
  4. The dialog for configuration of the archives for the 3rd party database connector is opened.
  5. Configure the archives with the wizard or manually.
  6. The archives are displayed in the archives for the 3rd party database connector and can be edited.
  7. Confirm the dialog by clicking on OK. The archives are created and can be used in reports.

info Information

ZAMS can search for importable tables in:

  • Databases on the currently-connected SQL Server instance.
  • Databases on linked SQL Server instances.
  • Via ODBC-linked databases. These are subject to limitations.
    Note: The configuration of the ODBC driver for SQL Server is described in the Configuration of the provider chapter.

The metadata for virtual archives is stored in new metadata tables. Attention: With linked SQL Servers, read access to the "master" database is required in order to list the databases on the linked SQL Server. With all databases on SQL Server instances, read access to the system views is required in order to be able to recognize the columns and their data types.

Limitations for data from ODBC sources

The following limitations apply to data that is incorporated via ODBC:

  • The data type of the variables is always defined by the data type of the value column. This concerns the value column of the table for Variable identification column and value column and the value column of the variables for One value column for each variable. These cannot be selected in the dialog.
  • An error is reported if the following conditions are applicable:
    • Data for an archive whose source table is connected via ODBC is queried.
    • The table is a variable identification column and value column table.
    • The variables in the archive have different data types.
  • The value range is limited for numeric values:
    • All values that are greater than 1010 are processed as 1010.
    • All values that are in the range of -(10-10) to 10-10 are processed as 0.
    • All values that are less than -(1010) are processed as -(1010).

Other topics in this chapter

Selection of available databases

New archive with wizard

Create or edit archive manually


Selection of available databases

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Selection of available databases

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In the dialog for the Selection of available databases, the databases that are to be searched for importable tables are selected. These can then be configured in the Archives for the 3rd party database connector dialog.

Selection of available databases

Parameters

Description

Databases on currently connected SQL Server instance

Display of databases on the currently-connected SQL server instance. Multiple selection is possible. Selected databases are added to the Included databases list by clicking on the Add button.

Add

Adds all databases selected in the list to the Included databases list. Only databases that are not already in the Included databases list or in the Databases that have to be included are added.

Add all

Adds all databases present in the list to the Included databases list. Only databases that are not already in the Included databases list or in the Databases that have to be included are added.

Databases on linked servers

Selection of a linked server from a drop-down list and display of its databases in the list. Multiple selection is possible.

Selected databases are added to the Included databases list by clicking on the Add button

If the linked server is an ODBC server, no database can be selected. A database identification text is inserted into the list instead. This constitutes the database for this linked server.

If there are problems with the connection to the linked ODBC servers:

  • Check whether the linked server has the correct system DSN and whether the correct login data has been entered. Also check the content of the system DSN.
  • Check whether the ODBC driver for SQL servers (name: MSDASQL) has the correct settings. For the settings, see the Configuration of the provider chapter.

Add

Adds all databases selected in the list to the Included databases list. Only databases that are not already in the Included databases list or in the Databases that have to be included are added.

Add all

Adds all databases present in the list to the Included databases list. Only databases that are not already in the Included databases list or in the Databases that have to be included are added.

Included databases

Display of all databases added. These are searched for importable tables by clicking on OK. Multiple selection is possible.

Databases can be removed from the list by clicking on the Remove button.

Databases that come from linked servers are shown in the syntax [Linked Server Name] [database name].

Remove

Removes all selected databases from the list.

Remove all

Removes all existing databases from the list.

Databases that have to be included

Display of all databases that must be searched for importable tables because an existing virtual archive refers to them. The list is only displayed and cannot be edited.

Databases that come from linked servers are shown in the syntax [Linked Server Name] [database name].

OK

Accepts all settings, closes the dialog, searches all selected databases for importable tables and opens the Archives for the 3rd party database connector dialog.

An error message is shown if the Included databases and Databases that have to be included lists are empty.

Cancel

Discards all configurations and closes the dialog.

Archives for the 3rd party database connector dialog

Configuration of the archives for the imported databases. Create new archives with the wizard or manually and edit existing archives.

The following symbols are used in the dialog:

  • Wizard:
  • : New
  • : Edit
  • : Delete

Parameters

Description

List of archives

Display of the configured archives with the following detailed information:

  • Archive name
  • Project name
  • Cycle time
  • Source database
  • Table in source database
  • Number of variables

The archives are displayed in the order of their creation:

Buttons to edit the list and the archives

The following symbols are available for editing:

Bar:

  • Wizard: Opens the wizard for creating an archive. Once an archive has been created, the dialog to edit an archive is automatically opened. Amend the created archive here
  • New: Opens the dialog for creating an archive.

Archives:

  • Edit: Opens the dialog to edit an archive. This corresponds to the dialog to create an archive. However no new variables can be created.
  • Delete: Deletes the archive without requesting confirmation.

OK

Applies all settings and closes the dialog.

Cancel

Discards all settings and closes the dialog.


New archive with wizard

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> New archive with wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Archives, data sources and rules are established with the archive and the variables are then created automatically. These can then be amended individually.

To create a new archive with the wizard:

  1. Click on the symbol for the wizard in the Archives for the 3rd party database connector dialog.
  2. Configure the tabs:
    • Data source
    • Archive metadata
    • Variable creation rules
  3. Check the configuration in the Summary and Execution tab.
  4. Click on Create variables.
  5. The configured variables are created.
  6. The dialog to create/edit an archive is opened.
  7. Amend the automatically-created configuration as required.
  8. Close the dialog.
  9. The archive is displayed in the list and can be opened using the Edit symbol for further amendments at any time.

Other topics in this chapter

Data source

Archive metadata

Variable creation rules

Summary and Execution


Data source

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> New archive with wizard -> Data source

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the data source:

Parameters

Description

Server

Selection of the database server from a drop-down list. The currently-connected server instance is identified by the suffixed note (currently connected).

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset.

The field must not be empty during validation.

Database

Selection of the database on the selected server from a drop-down list. All databases of the selected server are available.

Only available if a Server has been selected.

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset.

The field must not be empty during validation.

Table

Selection of the source table from a drop-down list. All tables present in the selected database are available.

Only available if a Database was selected.

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset.

The field must not be empty during validation.

Table type

Selection of the table type from a drop-down list. Available are:

  • Variable identification column and value column: flat list
  • One value column for each variable: pivoted

Only available if a table was selected.

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset.

The field must not be empty during validation.

Time stamp type

Selection of the time stamp from the drop-down list. Available are:

  • UTC timestamp object
  • Timestamp object in server local time
  • Unixtime
  • Unixtime and milliseconds in two columns
  • Unixtime and milliseconds in one column

Only available if a table was selected.

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset.

The field must not be empty during validation.

Timestamp column

Selection of the time stamp column from a drop-down list. All columns of the selected table whose data type is permitted for the current time stamp setting are available.

Only available if a table was selected.

The field must not be empty during validation.

Millisecond column

Selection of the millisecond column from a drop-down list. All columns of the selected table whose data type is permitted for a millisecond column are available.

Only available if a table has been selected and Unix time with milliseconds has been selected as a time stamp type.

The field must not be empty during validation if it is active.

Variable identification column

Selection of Variable identification column from drop-down list. All columns of the selected table whose data type is permitted for a variable identification column are available.

Only available if a table has been selected and Variable identification column and value column has been selected as a table type.

The field must not be empty during validation if it is active.

Value column

Selection of value column from drop-down list. All columns of the selected table whose data type is permitted for a value column are available.

Only available if a table has been selected and Variable identification column and value column has been selected as a table type.

The field must not be empty during validation if it is active.

Navigation

Button

Description

Previous

Switches to the previous tab.
Inactive in the first tab.

Next

Switches to the next tab.
Inactive in the last tab.

Create variables

Starts variable creation.

Only active in the last tab and only if no validation error has been established. If validation errors are found, these are displayed and the button remains inactive.

Once the variable has been created, the button changes to OK. The creation of the archive can thus be started.

Cancel

Discards all inputs and closes the dialog.


Archive metadata

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> New archive with wizard -> Archive metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the archive metadata:

Parameters | Description
Project | Project that is assigned to the archive. Select from drop-down list.
Reference | Archive reference. This must be unique for all archives within the project. The field must not be empty during validation.
Visual name | Visual name for the archive. This must be unique for all archives within the project. The field must not be empty during validation.

Navigation

Button

Description

Previous

Switches to the previous tab.
Inactive in the first tab.

Next

Switches to the next tab.
Inactive in the last tab.

Create variables

Starts variable creation.

Only active in the last tab and only if no validation error has been established. If validation errors are found, these are displayed and the button remains inactive.

Once the variable has been created, the button changes to OK. The creation of the archive can thus be started.

Cancel

Discards all inputs and closes the dialog.


Variable creation rules

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> New archive with wizard -> Variable creation rules

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the rules for the creation of variables:

Parameters

Description

Identification creation rules

Configuration of how the variable reference is created. This must be unique within the project and comply with the rules for names. Select from drop-down list:

  • Variable identification text
  • Variable identification text with prefix
  • Variable identification text with suffix
  • Variable identification text with prefix and suffix

The field must not be empty during validation.

Identification prefix

Entry of a prefix for the variable reference.

Only available if one of the reference creation variants with a prefix was selected.

The field must not be empty during validation if it is active.

Identification suffix

Entry of a suffix for the variable reference.

Only available if one of the reference creation variants with a suffix was selected.

The field must not be empty during validation if it is active.

Rules for the creation of visual names

Configuration of how the visual name of the variables is generated. This must be unique within the project and comply with the rules for names.

Select from drop-down list:

  • Variable identification text
  • Variable identification text with prefix
  • Variable identification text with suffix
  • Variable identification text with prefix and suffix

The field must not be empty during validation.

Visual name prefix

Entry of a prefix for the visual names.

Only available if one of the visual name creation variants with a suffix was selected.

The field must not be empty during validation if it is active.

Visual name suffix

Entry of a prefix for the visual names.

Only available if a creation variant for the visual name with suffix has been selected.

The field must not be empty during validation if it is active.

Data type setting rule

Configuration of the rule to set the data type. Select from drop-down list:

  • Always set data type to numeric
  • Always set data type to text
  • Recognize data type based on column data type

The field must not be empty during validation if it is active.

Recommendation: In the event of doubt, select Recognize data type based on column data type for this option. You thus ensure that there is no conversion error when creating or executing the UDF.

Navigation

Button

Description

Previous

Switches to the previous tab.
Inactive in the first tab.

Next

Switches to the next tab.
Inactive in the last tab.

Create variables

Starts variable creation.

Only active in the last tab and only if no validation error has been established. If validation errors are found, these are displayed and the button remains inactive.

Once the variable has been created, the button changes to OK. The creation of the archive can thus be started.

Cancel

Discards all inputs and closes the dialog.


Summary and Execution

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> New archive with wizard -> Summary and Execution

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display of the configuration and creation of an archive. When switching to this tab, the inputs in the other tabs are validated.

If the configuration is free of errors, then:

  • The Create variables button is active
  • Variables can be generated and an archive can be created

If errors are found, then:

  • The Create variables button is inactive
  • Configuration errors are displayed in the window

Configuration error found

Parameters | Description
Display of the configuration | Shows the result of the validation. Errors that have been found are listed.
Previous | Switches to the previous tab.
Next | Inactive.
Create variables | Inactive as long as there are configuration errors.
Cancel | Discards all inputs and closes the dialog.

Create variables and archive

If configuration has been carried out without errors, then the variables and then the archive can be created.

Create variables

Parameters | Description
Display of the configuration | Shows the result of the validation.
Previous | Switches to the previous tab.
Next | Inactive.
Create variables | Starts variable creation. Only active if no validation errors have been established. Once the variable has been created, the button changes to OK.
Cancel | Discards all inputs and closes the dialog.

Create archive

The archive can be created once the variables have been created.

Parameters | Description
Display of variable creation | Lists all created variables.
Previous | Switches to the previous tab.
Next | Inactive.
OK | Creates the configured archive and closes the dialog.
Cancel | Discards all inputs and closes the dialog.


Create or edit archive manually

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

With this dialog, metadata, data sources and variables are configured manually

This dialog is offered when:

  • Creating a new archive
  • Editing an existing archive
  • Amending an archive that has been created with the wizard

To create or edit an archive manually:

  1. In the Archives for the 3rd party database connector, click on the symbol for New archive.
  2. Configure the tabs:
    • Metadata
    • Data source
    • Variables
  3. Close the dialog.
  4. The archive is displayed in the list and can be opened using the Edit symbol for further amendments at any time.

Other topics in this chapter

Metadata

Data source

Variables

Metadata

Assigned equipment groups

Assigned meanings

Status texts

Rules for issuing names


Metadata

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually -> Metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the metadata:

Parameters | Description
Project | Project that is assigned to the archive. Select from drop-down list. Only available if a new archive is created. If the selection is changed, all variables that have already been created in the archive are deleted.
Reference | Archive reference. This must be unique for all archives within the project. Only available if a new archive is created. The field must not be empty during validation.
Visual name | Visual name for the archive. This must be unique for all archives within the project. The field must not be empty during validation.
Description | Descriptive text for the archive.
Cycle time | Configuration of the cycle time of the archive.
Assigned equipment group | Display of all available equipment models as a tree with checkboxes. Selection by activating the checkboxes in front of the desired equipment groups.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Closes the dialog and creates the archive. If validation errors are established, the process is canceled and a message with the errors that have been established is shown.
Cancel | Discards all inputs and closes the dialog.


Data source

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually -> Data source

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the data source:

Parameters

Description

Server

Selection of the database server from a drop-down list. The currently-connected server instance is identified by the suffixed note (currently connected).

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset. And all created variables are deleted.

The field must not be empty during validation.

Database

Selection of the database on the selected server from a drop-down list. All databases of the selected server are available.

Only available if a Server has been selected.

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset. And all created variables are deleted.

The field must not be empty during validation.

Table

Selection of the source table from a drop-down list. All tables present in the selected database are available.

Only available if a Database was selected.

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset. And all created variables are deleted.

The field must not be empty during validation.

Table type

Selection of the table type from a drop-down list. Available are:

  • Variable identification column and value column: flat list
  • One value column for each variable: pivoted

Only available if a table was selected.

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset. And all created variables are deleted.

The field must not be empty during validation.

Time stamp type

Selection of the time stamp from the drop-down list. Available are:

  • UTC timestamp object
  • Timestamp object in server local time
  • Unixtime
  • Unixtime and milliseconds in two columns
  • Unixtime and milliseconds in one column

Only available if a table was selected.

If the selection is changed during the configuration of the tab, the settings of this tab that depend on this are reset.

The field must not be empty during validation.

Timestamp column

Selection of the time stamp column from a drop-down list. All columns of the selected table whose data type is permitted for the current time stamp setting are available.

Only available if a table was selected.

The field must not be empty during validation.

Millisecond column

Selection of the millisecond column from a drop-down list. All columns of the selected table whose data type is permitted for a millisecond column are available.

Only available if a table has been selected and Unix time with milliseconds has been selected as a time stamp type.

The field must not be empty during validation if it is active.

Variable identification column

Selection of Variable identification column from drop-down list. All columns of the selected table whose data type is permitted for a variable identification column are available.

Only available if a table has been selected and Variable identification column and value column has been selected as a table type.

The field must not be empty during validation if it is active.

Value column

Selection of value column from drop-down list. All columns of the selected table whose data type is permitted for a value column are available.

Only available if a table has been selected and Variable identification column and value column has been selected as a table type.

The field must not be empty during validation if it is active.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Closes the dialog and creates the archive. If validation errors are established, the process is canceled and a message with the errors that have been established is shown.
Cancel | Discards all inputs and closes the dialog.


Variables

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually -> Variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the variables.

The following symbols are used in the dialog:

  • : New
  • : Edit
  • : Delete

Parameters

Description

List of variables

Display of the configured variables with the following detailed information:

  • Variable name
  • Variable identification text
  • Data type
  • Measuring unit

The variables are displayed in the order in which they were created:

Buttons to edit the list and the variables

The following symbols are available for editing:

Bar:

  • New: Opens the dialog to create a variable.
    Only active if variables could have been created due to the configuration.
    To do this:
    - A project must have been selected
    - The data source definition must be complete
    - With the pivoted table type, at least one variable identification text must be available

Variables:

  • Edit: Opens the dialog to edit a variable. This corresponds to the dialog to create a variable. However no new variables can be created.
  • Delete: Deletes the variable from the list without confirmation.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Closes the dialog and creates the archive. If validation errors are established, the process is canceled and a message with the errors that have been established is shown.
Cancel | Discards all inputs and closes the dialog.

Create variables

To create a new variable:

  1. Click on the New button (star).
  2. The dialog to create/edit variables is opened.
  3. Configure the tabs for:
    • Metadata
    • Assigned equipment groups
    • Assigned meanings
    • Status texts
  4. Close the dialog by clicking on OK.
  5. The variable is displayed in the list and can be edited or deleted at any time by means of the buttons.


Metadata

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually -> Metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The metadata of the variables are configured in this tab. Depending on the setting for table type in the configuration of the data source in the archive configuration, this tab is available in two versions:

Flat list table type: Variable identification text is entered into the field

Pivoted table type: Variable identification text is selected from the drop-down list

"Flat list" table type

Parameters

Description

Variable name

Name of the variable. This must be unique within the project and comply with the rules for names.

The field must not be empty during validation.

Visual name

Visual name of the variables stated. This must be unique within the project and comply with the rules for names.

The field must not be empty during validation.

Description

Descriptive text for the variables

Data type

Data type of the variable. Select from drop-down list:

  • Numerical value
  • Text

Note: If the column data type does not allow conversion to a numerical value, then Text is preselected here and the drop-down list is deactivated.

The field must not be empty during validation.

Measuring unit

Input of the measuring unit of the variables.

Variable identification text

Entry of the variable identification text. The possibility depends on the table type in the configuration of the data source in the archive configuration:

  • Flat list: Input field to enter the identification text of the variables.
  • Pivoted: Drop-down list for the selection of the identification text. All column names of the table are available.
    Exceptions: Column names that have already been used for the time stamp column, millisecond column or another variable in the archive.

The field must not be empty during validation.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Closes the dialog and creates the variable. If validation errors are established, the process is canceled and a message with the errors that have been established is shown.
Cancel | Discards all inputs and closes the dialog.

"Pivoted" table type:

Configuration as for the flat list table type.


Assigned equipment groups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually -> Assigned equipment groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the equipment groups:

Parameters | Description
Assigned equipment group | Display of all available equipment models as a tree with checkboxes. Selection by activating the checkboxes in front of the desired equipment groups.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Closes the dialog and creates the variable. If validation errors are established, the process is canceled and a message with the errors that have been established is shown.
Cancel | Discards all inputs and closes the dialog.


Assigned meanings

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually -> Assigned meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the meanings:

Parameters | Description
Assigned meaning | Entry of the meaning into the field
Add | A click adds the entry in the Assigned meaning field to the List of assigned meanings.
List of assigned meanings | Displays all currently-configured meanings. Multiple selection is possible.
Remove | Clicking removes all selected meanings from the List of assigned meanings.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Closes the dialog and creates the variable. If validation errors are established, the process is canceled and a message with the errors that have been established is shown.
Cancel | Discards all inputs and closes the dialog.


Status texts

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually -> Status texts

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the status text:

Parameters | Description
Numeric entry | Entry of the value for the status.
Text field | Entry of status text.
Add | Clicking adds the entry to the List of status texts.
List of status texts | Displays all currently-configured status texts. Display format: [Value]: [Text] Multiple selection is possible.
Remove | Clicking removes all selected status texts.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Closes the dialog and creates the variable. If validation errors are established, the process is canceled and a message with the errors that have been established is shown.
Cancel | Discards all inputs and closes the dialog.


Rules for issuing names

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Create 3rd party database connector -> Create or edit archive manually -> Rules for issuing names

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The following are not permitted for the variable name and visual name:

  • Comma
  • Vertical spacing
  • Paragraph spacing
  • Tabulators
  • Space

These properties are checked on transfer and amended to the rules.
That means:

  1. Commas, vertical spacing, paragraph spacing and tabulators are removed.
  2. Spaces at the start and end are removed.
  3. Several consecutive spaces in the text are combined into one space.
  4. Spaces in the text are replaced with underscores.


New Analyzer database

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> New Analyzer database

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In order for a new Analyzer database to be created, there must be a connection to an Analyzer server with a valid license.

To create a new Analyzer database:

  1. Click, in the SQL Server menu, on the New Analyzer database entry

    The dialog to create a new database is opened.

  2. Configure the settings.

Parameters

Description

Database name

Name of the database to be created.

If this field remains empty or the name of a database that already exists on the SQL server is entered, an error message is given.

Connect to the new database after creation
  • Active: Once the database has been created successfully, the current connection is closed and a connection to the database that has just been created is established.
    The authentication is determined via the properties in the Credentials area.
  • Inactive: Once the database has been created successfully, the connection to the current database remains intact

Credentials

Connection settings.

Only available if the Connect to the new database after creation option has been activated.

Use Windows authentication

Active: Windows authentication is used.

User name

Entry of the user name.

If Use Windows authentication is active, display only.

Password

Entry of the password. Is not saved and must be reentered each time the connection is made.

If Use windows authentication is active, no input is necessary; input is also not possible.

Connection security

Settings for the connection security. The entries must correspond to the configuration on the server.

Secure connection

Activation or deactivation of the encrypted communication.

  • Active: Communication is encrypted. For each connection, depending on the degree of encryption, passwords must be entered for the license service.
  • Inactive: Communication is not encrypted.

Note: Secured communication cannot be configured for existing connection profiles. A new profile must be created.

License Server connection password

Entry of the password for the connection to the license server.
Input is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

License Server modification password

Entry of the change password on the license server.
Entry is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Save password

Stipulation of whether the connection parameters are saved in the connection profile.
Saving is carried out as a hardware-dependent and user-dependent hash of the password.

OK

Accepts all inputs, creates the database, establishes connections if necessary and closes the dialog.

Cancel

Rejects all inputs and closes the dialog without creating a database.


Convert databases

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Convert databases

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Databases that were created with zenon Analyzer from version 2.0 can be converted to the respective later version being used. If a database with a lower version number than that of the ZAMS being executed is opened, this is converted into the newer version. Databases with a version less than zenon Analyzer 2.0 are not converted by ZAMS. The database structure and the license are checked during the conversion.

From version 2.10, ZAMS recognizes the version of the metadata structure definition of a database and can check its structure. All databases created with versions from 2.10 feature versioning of the database structure.

The checking of the version of the database is started if:

  • A connection to a database is established
  • Manual conversion of the databases is started

Convert database manually

To convert databases:

  1. Open the menu SQL-Server.
  2. Select the entry Convert databases.
  3. ZAMS checks the version and structure of all existing databases.
    The search and its results are documented in the output window.
  4. If convertible databases are found, these are offered for conversion:
    1. The dialog to configure the database conversion with two tabs is opened.
    2. Select the databases that are to be converted and the backup path.

      Note: Note the information in the comments. There may be other actions necessary after conversion, such as creating a new SCADA SQL connector.

    3. Start the conversion by clicking OK
  5. If no databases that can be converted are found, the search is ended and corresponding messages are displayed in the output window.

Dialog for configuration of the database conversion

This dialog allows the selection of the databases to be converted and configuration of the save path.

Databases

Selection of the databases to be converted.

Parameters

Description

List of databases

Lists all existing databases. If a line has a gray background, the database named therein cannot be converted. Details are in the Comments column.

The following are displayed:

  • Checkbox: Selection of database.
    Active: Database for conversion selected.
    Only databases that can be technically converted are selected.
    Default for convertible databases: active
  • Database name: Name of the database.
  • Version: Database version.
  • Comment: Reason why a database cannot be converted or from which to which version a database can be converted. Note the references to actions that must be carried out after conversion.

Open the LOG file folder after the conversion has finished.

Active: After conversion, the folder with the LOG files for conversion is opened.

OK

Accepts settings in all tabs and starts conversion.

Cancel

Discards settings in all tabs and cancels the conversion.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Backup path

Configuration of the path for backup files and selection of whether these are to be deleted after successful conversion.

Parameters

Description

Store the database backups in the same path as the database files

Active: The database backup files are stored locally in the same folder as the database files in the Analyzer server.

Because this can be a different computer to the ZAMS computer, access to its file system cannot be guaranteed. The backup files stored there thus cannot automatically be deleted by ZAMS after successful conversion.

Store the database backups in a network share

Active: The database backup files are

stored in a network share.

Input of the folder in the text field or selection from a dialog after clicking on the Browse button.

Attention: It must be ensured that the user in which context the SQL server instance is running has access to this network share with the following rights:

  • read
  • write:
  • overwrite

Browse

Opens the dialog for selecting a network share.

Delete database backups once they have been converted

Active: The database backup files are deleted after successful conversion of the database.

Requirements: The backup files are in a network share.

The option is executed for each database. If, for example, databases are converted and a conversion is unsuccessful, then:

  • Four backup files are deleted
  • If the backup file for the unsuccessful conversion is retained

Open the LOG file folder after the conversion has finished.

Active: After conversion, the folder with the LOG files for conversion is opened.

OK

Accepts settings in all tabs and starts conversion.

Cancel

Discards settings in all tabs and cancels the conversion.

Conversion notes

Note most of all when converting databases:

  • If a database that is a version less than 2 is converted, then the following applies for the conversion to:
    • Version 2 or higher: The SCADA SQL connector has to be created again in order to have emulated archives available in reports.
    • Version 3: The SCADA SQL connector has to be created again in order to have archives available for import from third-party databases.
  • If a database that is a version less than 3 is converted, then the following applies for the conversion to:
    • Version 3: The SCADA SQL connector has to be created again in order to have archives available for import from third-party databases.


Manual database backups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manual database backups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Databases can be saved manually. Backup files can be restored and administered. Whether a database can be saved or restored depends on its type.

Automated backups are described in the Automated data backups chapter.

Other topics in this chapter

Database types

Create database backups

Restore database backups


Database types

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manual database backups -> Database types

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A distinction is made between the following types of databases:

Type

Description

Saving

Restore

System databases

Name is

  • master
  • model
  • msdb
  • tempdb

-

-

Report server databases

Name starts with

  • ReportServer$

+

- *

Analyzer metadata databases
  • No system database
  • No report server database.
  • Analyzer metadata definition version can be established.

+

+

Other databases

None of the conditions for other types were met.

+

+

* Background: To restore Report server databases, the Report Server service must be stopped and restarted after the restore, for which administrator rights on the Analyzer server are needed.


Create database backups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manual database backups -> Create database backups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Backups of databases can be created provided their type allows this. You can find details on the restorable types in the Database types. chapter

Backup databases

To back up databases:

  1. open the menu SQL-Server
  2. Select the Create database backup entry
  3. the dialog for selecting a database is opened
  4. Activate the checkboxes in front of all databases to be backed up
  5. click on OK

Parameters

Description

List of databases

Displays all databases available

  • Checkbox: The checkbox must be activated to back up a database.
  • Database name: Displays database name.
  • Date and time of the latest backup: Shows date and time of the backup currently available.

The path and number of backups are defined in the Options menu, in the Database backups tab of the Settings.

Select all

Selects all displayed databases for backup.

Deselect all

Deselects database selection.

OK

Accepts selection, closes dialog and creates backups.

Cancel

Discards changes and closes dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Storage path for database backup files:

The first time a backup request is made and a path has not yet been established, you are requested to define a save path. This path is then used for all backups and restorations. This path is administered in the options in the Database backups tab of the Settings.

Note: It is recommended that a path on the Analyzer computer is used for backup.

Parameters

Description

Network share path for storing database backup files of [database]

A valid UNC path must be entered.

Clicking on the ... button opens the dialog to select a network share.

A check is made if:

  • The syntax of the path is valid if:
    Only valid paths unlock the OK button.
  • The path exists:
    When clicking on OK, the path is only accepted if it can also be accessed.
  • The path is different to that already used:
    If a path is defined that is different to a path that has already been used, a corresponding message is given. The path can be created. The pre-existing database backup job can then be activated, deactivated and deleted, but can no longer be edited.

The configured path is saved individually for each user.

Attention: The access rights to network shares must be set correctly. For details, see the Set access rights to network share correctly.

OK

Accepts the path and closes the dialog.

Cancel

Discards changes and closes the dialog.

Set access rights to network share correctly

In order for all database backup action to run correctly, the access rights to the network share must correspond to the database backup folder. For this, the following applies:

  • The folder must be on the Analyzer Server, because defined users must access it locally on the Analyzer Server.
  • Because the folder must be accessible by both the Analyzer Server and the ZAMS computer with the same path, it must be authorized in the network. The folder is then accessible with the same path via a UNC path everywhere in the network.
  • The following users must have full access to the network share:
    • NT SERVICE\MSSQL$ZA3: For the creation and restoration of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • NT SERVICE\SQLAgent$ZA3: For automatic creation of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • Every ZAMS user: To create and restore backups, administer backup files and administer automated backup jobs.

Backup file name

The file name of a database backup file follows this scheme: [database name]_yyyy_MM_dd_HH_mm_ss.bak

e.g.: ZA_DATA_2013_02_12_14_11_35.bak = backup of ZA_DATA on 12.2.2013 at 14:11:35


Restore database backups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manual database backups -> Restore database backups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Databases that have been backed up can be restored. You can find details on the restorable types in the Database types. chapter

Restoring database backups

To restore database backups:

  1. open the menu SQL-Server
  2. Select the entry Restore database backups....
  3. the dialog for selecting a database is opened
  4. Activate the checkboxes in front of all databases to be restored
  5. Select, in the Time stamp of most recent backup column, the desired version from the drop-down list
  6. click on OK

Parameters

Description

List of databases

Displays all databases available

  • Checkbox: The checkbox must be activated to restore a database.
  • Database name: Shows the database name.
  • Latest backup file timestamp: Shows drop-down list with data and time of all backups available.

Select all

Selects all displayed databases for backup.

Deselect all

Deselects database selection.

OK

Accepts selection, closes dialog and restores selected saved database backups. In doing so, please note:

  • If the currently-active metadata database is to be restored by a backup, the connection must be reestablished after the restore. The user must confirm this before starting the restore.
  • For each metadata database, after successful restoration, the version of the metadata structure in the database is established and a structure test is carried out. If an obsolete structure is established in at lest one database, the user has the possibility to start the database conversion directly. This option is inactive if the connection must be reestablished after the restore.

Cancel

Discards changes and closes dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Storage path for database backup files:

The first time a backup request is made and a path has not yet been established, you are requested to define a save path. This path is then used for all backups and restorations. This path is administered in the options in the Database backups tab of the Settings.

Note: It is recommended that a path on the Analyzer computer is used for backup.

Parameters

Description

Network share path for storing database backup files of [database]

A valid UNC path must be entered.

Clicking on the ... button opens the dialog to select a network share.

A check is made if:

  • The syntax of the path is valid if:
    Only valid paths unlock the OK button.
  • The path exists:
    When clicking on OK, the path is only accepted if it can also be accessed.
  • The path is different to that already used:
    If a path is defined that is different to a path that has already been used, a corresponding message is given. The path can be created. The pre-existing database backup job can then be activated, deactivated and deleted, but can no longer be edited.

The configured path is saved individually for each user.

Attention: The access rights to network shares must be set correctly. For details, see the Set access rights to network share correctly.

OK

Accepts the path and closes the dialog.

Cancel

Discards changes and closes the dialog.

Set access rights to network share correctly

In order for all database backup action to run correctly, the access rights to the network share must correspond to the database backup folder. For this, the following applies:

  • The folder must be on the Analyzer Server, because defined users must access it locally on the Analyzer Server.
  • Because the folder must be accessible by both the Analyzer Server and the ZAMS computer with the same path, it must be authorized in the network. The folder is then accessible with the same path via a UNC path everywhere in the network.
  • The following users must have full access to the network share:
    • NT SERVICE\MSSQL$ZA3: For the creation and restoration of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • NT SERVICE\SQLAgent$ZA3: For automatic creation of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • Every ZAMS user: To create and restore backups, administer backup files and administer automated backup jobs.

Backup file name

The file name of a database backup file follows this scheme: [database name]_yyyy_MM_dd_HH_mm_ss.bak

e.g.: ZA_DATA_2013_02_12_14_11_35.bak = backup of ZA_DATA on 12.2.2013 at 14:11:35


Restore database backup file as new database

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Restore database backup file as new database

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A database backup file can be restored as a new database. In doing so, the backup file can also come from a database that is not yet on the SQL server instance.

The database backup file must meet the following requirements:

  • The name of the database backup file must correspond to the following syntax: [database name]_[yyyy]_[MM]_[dd]_[HH]_[mm]_[ss].bak.
  • There is only one database backup in the database backup file.
  • The database saved in the backup file has the exact name that appears in the filename of the backup file.
  • The database backup file can be checked for corruption/manipulation by means of a checksum.

All backup files created with ZAMS meet these requirements.

The target database name can be identical to the source database name, provided there is not yet a database with this name. An existing database can thus be transferred from one Analyzer server to the other by:

  • Saving it on the original server
  • Copying the backup file
  • Restoring to the target server with new names that correspond to the old names

Restore database backup as new database

To restore a backup as a new database:

  1. Open the SQL Server menu.
  2. Select the Restore database backup as new database command.
  3. The dialog for selecting a backup file is opened
  4. Select the desired database
  5. Enter a name for the new database
  6. Close the dialog by clicking on OK.

Note: If there are conflicts when synchronizing the user access rights, the user is informed by means of a dialog and can decide whether the database should nevertheless be created.

Restoring a database backup file as a new database

Parameters

Description

Source database

Selection of the source database from a drop-down list.

The source database is the database that is contained in the backup file. All database files found are listed.

Backup file timestamp

Selection of the time stamp that is to be restored. All backup files of the selected database available are listed according to the time stamp of their backup.

Name of the new database

Entry of the name for the new database.

The name must meet the following criteria:

  • Must not remain empty.
  • Must not be used by a database that is already present on the target server.
    This check is not case sensitive. For example: The name DATA cannot be used if there is already a database called data.

The OK button can only be used if the validation of the name is successful.

Connect to the new database after completing the restore operation

Active: A connection to the new database is also established when restoring.

Activated and cannot be operated if the Create the SQL connector in the new database after connecting option is active.

Create the SQL connector in the new database after connecting
  • Active: When restoring, SQL connector creation is started after the connection to the new database has been established.

Can only be activated if the Connect to the new database after completing the restore operation option is active.

Configure the 3rd party database connector after connecting
  • Active: When restoring after establishing a connection to the new database, the configuration of the import from third-party databases is started.

Note: If Create the SQL connector in the new database after connecting and Configure the 3rd party database connector after connecting have been activated, the configuration is carried out in this sequence:

  • SQL-Connector
  • Import of third-party databases

Can only be activated if the Connect to the new database after completing the restore operation option is active.

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Restore Reporting Services database backup

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Restore Reporting Services database backup

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Backups of the reporting services database can be restored in ZAMS if the Analyzer server is on the same server as ZAMS.

To restore a backup:

  1. Select, in the SQL Server menu, the Restore Reporting Services database backup command.
    This is only available if ZAMS is connected to an Analyzer server that is on the same computer as ZAMS. The comparison is carried out via the NetBIOS names of the local computers supplied by the .NET framework and the NetBIOS names of the SQL Server computer supplied by the SQL Server connection object.
  2. The dialog for selecting a backup is opened
  3. Select the desired backup.
  4. Confirm the restore by clicking OK.

Restore backup file dialog

Parameters | Description
Drop-down list | Selection of the file to be restored. Identification is via the time stamp of the backup.
OK | Applies settings and closes the dialog.
Cancel | Discards all changes and closes the dialog.


Administrate automated database backups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Database backups can be made automatically. These backups can be administered in their own dialog.

Note: Automated backups should be configured so that they run when the Analyzer server has nothing to do. In doing so, report subscriptions must be taken into account. If, for example, subscriptions are processed every Sunday at 02:00:00, this is not a suitable tome to make a database backup.

To set up or edit an automated backup:

  1. open the menu SQL-Server
  2. Select the Manage Automated Database Backup Files entry.
  3. The dialog for administering the automated backups is opened

Parameters

Description

Symbol

Displays whether the backup job is active or inactive.

List of backup jobs

Table of all recognized backup jobs. The following are displayed:

  • Name: Distinct name of the backup job. Capitalization/use of small letters is not checked.
  • Description: Individual description of the job.
  • Status information: Note regarding whether the backup job is active, when it was carried out for the last time and what the result of th last execution was.
  • Schedule: Description of the assigned schedule
  • Storage path: Path for database backups.
  • Included databases: List of the databases to be backed up and a note stating whether there is a limit to the number of files for the backup files and if so, how many.

Only one job can be selected at a time.

Refresh

Updates the content of the list.

New

Creates a new backup job.

To do this, a dialog is opened with the configuration for:

  • General settings
  • Databases
  • Job schedules

Edit

Opens the selected backup job for editing with the dialog for:

  • General settings
  • Databases
  • Job schedules

Delete

Deletes the selected backup after requesting confirmation.

Enable Job

Activates the selected backup job.

Disable job

Activates the selected backup job.

Close

Closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Creating and editing backup jobs

Backup jobs are configured in a dialog with three tabs. The dialog is opened by clicking on the New or Edit button.

Parameters

Description

General settings

Configuration of the general settings for a database backup.

Databases

Selection of the databases to be backed up.

Job schedules

Schedules for the backup with details of:

  • General settings
  • Recurrence
  • In day recurrence
  • Duration

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.

Storage path for database backup files:

The first time a backup request is made and a path has not yet been established, you are requested to define a save path. This path is then used for all backups and restorations. This path is administered in the options in the Database backups tab of the Settings.

Note: It is recommended that a path on the Analyzer computer is used for backup.

Parameters

Description

Network share path for storing database backup files of [database]

A valid UNC path must be entered.

Clicking on the ... button opens the dialog to select a network share.

A check is made if:

  • The syntax of the path is valid if:
    Only valid paths unlock the OK button.
  • The path exists:
    When clicking on OK, the path is only accepted if it can also be accessed.
  • The path is different to that already used:
    If a path is defined that is different to a path that has already been used, a corresponding message is given. The path can be created. The pre-existing database backup job can then be activated, deactivated and deleted, but can no longer be edited.

The configured path is saved individually for each user.

Attention: The access rights to network shares must be set correctly. For details, see the Set access rights to network share correctly.

OK

Accepts the path and closes the dialog.

Cancel

Discards changes and closes the dialog.

Set access rights to network share correctly

In order for all database backup action to run correctly, the access rights to the network share must correspond to the database backup folder. For this, the following applies:

  • The folder must be on the Analyzer Server, because defined users must access it locally on the Analyzer Server.
  • Because the folder must be accessible by both the Analyzer Server and the ZAMS computer with the same path, it must be authorized in the network. The folder is then accessible with the same path via a UNC path everywhere in the network.
  • The following users must have full access to the network share:
    • NT SERVICE\MSSQL$ZA3: For the creation and restoration of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • NT SERVICE\SQLAgent$ZA3: For automatic creation of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • Every ZAMS user: To create and restore backups, administer backup files and administer automated backup jobs.

Backup file name

The file name of a database backup file follows this scheme: [database name]_yyyy_MM_dd_HH_mm_ss.bak

e.g.: ZA_DATA_2013_02_12_14_11_35.bak = backup of ZA_DATA on 12.2.2013 at 14:11:35

Other topics in this chapter

Definition of database backup job

General settings

Databases

Job schedules

Example of automated database backup


Definition of database backup job

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> Definition of database backup job

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Because many jobs are executed automatically on the SQL server, the identification of a job as a database backup is defined restrictively. This prevents database backup jobs influencing other jobs, such as subscriptions.

An SQL server agent job is only recognized as a database backup job if all conditions have been met:

  1. The job is a from the database maintenance category.
  2. The job only contains steps that correspond to one of the following conditions:
  • The name starts with Backup and the type is Transact SQL.
    Sub-conditions for these steps:
    • Fields for database names and file path are present in the command text and are filled with editable variables.
    • There is no other step for the database, neither Backup nor Reduce Files.
    • The command text corresponds to the SQL script template DbAutoBackup_RunBackup set up with the database name and file path.
  • The name starts with Reduce Files and the type is CMD Execute.
    Sub-conditions for these steps:
    • Fields for file path and database GUID are present in the command text and are filled with editable variables.
    • Combination of file path and database GUID leads to a BAT file.
    • The command text corresponds to the SQL script template DbAutoBackup_CallBat set up with the file path and database GUID.
    • In the BAT file, the fields for database name, file path and maximum number of files are present and filled with editable values.
    • There is not yet any other Reduce Files step for this database.
    • The script text in the BAT file corresponds to the SQL script template DbAutoBackup_BatReduceFiles set up with file path, database GUID, database name and maximum number of files.
  • Furthermore, all steps including the sub-points of the Reduce Files steps must use the same file path.


General settings

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> General settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

General settings for automated backups are configured in this tab.

Parameters | Description
Database backup job name | Entry of a unique name for the database backup.
Database backup job description | Entry of a description for the database backup job.
Database backup job is enabled | Active: The job is carried out according to its configuration and your schedule.
Backup file folders | Folder in which backup files are saved. Display only. The path and number of backups are defined in the Options menu, in the Database backups tab of the Settings.
Maximum number of database backup files | Maximum number of backup files that are saved. Display only. The path and number of backups are defined in the Options menu, in the Database backups tab of the Settings.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Databases

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> Databases

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The databases to be backed up are selected in this tab.

Parameters

Description

Available databases

List of databases that can be selected for the backup job. Already-selected databases are no longer shown in this list.

Buttons for assignment

Buttons to drag databases between lists:

  • >: Moves highlighted databases to the Included databases list.
  • >>: Moves all databases to the Included databases list.
  • <: Moves highlighted databases to the Available databases list.
  • <<: Moves all databases to the Available databases list.

Included databases

List of databases that are backed up with this job.

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

The button is deactivated if one of the required input fields is empty or not configured correctly.

Cancel

Discards all changes in all tabs and closes the dialog.


Job schedules

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> Job schedules

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The rules for the schedules for the backup jobs are configured in this tab.

Parameters | Description
Existing job schedules | Lists all schedules created for this job.
Description of the selected schedule | Shows details of the schedule selected in the Existing job schedules list.
New | Opens dialog to create a new schedule.
Edit | Opens dialog to edit the selected schedule.
Delete | Deletes the selected schedule.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Create new schedule or edit schedule

Clicking on the 'New or edit' button opens the dialog to configure a schedule:

Tabs | Description
General settings | General settings for the schedule.
Recurrence | Configuration of the recurrence for days. The controls available depend on the selection of the recurrence configuration in the General settings tab.
In day recurrence | Configuration of the recurrence within a day. The controls available depend on the selection of the recurrence pattern in the General settings tab.
Duration | Configuration of the time range in which the schedule is active
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.

Note: In ZAMS, only recurring schedules can be configured, because schedule types such as Execute once, Always when the CPU is idle or Always when SQL server agent services are started are not suitable for the execution of regular automated database backups.

Other topics in this chapter

General settings

Recurrence

In day recurrence

Duration


General settings

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> Job schedules -> General settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The sample for the recurrence of the backup job is saved in this tab.

Parameters

Description

Schedule name

Entry of the name for the schedule.

Recurrence configuration

Selection of the recurrence configuration from drop-down list:

  • Daily: The job is carried out at certain daily intervals.
  • Weekly: The job is carried out on certain weekdays at certain weekly intervals.
  • Monthly, day of month: The job is carried out on a certain day at certain monthly intervals.
  • Monthly, day of week of month: The job is carried out once a month with a certain monthly interval active, on a weekday in a certain week, for example every third month and then on Monday in the third week of this month.

Note: Details are configured in the respective Recurrence tab.

In day recurrence pattern

Selection of a recurring scheme for the day. This scheme determines how often and when the schedule triggers an event on active days. Select from drop-down list:

  • Once: The schedule triggers an event at a precise point in time on active days, for example at 02:00:00. Details are configured in the In day recurrence tab.
  • Recurring: On active days, the schedule triggers an event periodically with a certain interval, for example every 10 minutes from 02:00:00 to 05:00:00. Details are configured in the In day recurrence tab.

Display of the configuration

Displays the current configuration of the schedule.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.


Recurrence

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> Job schedules -> Recurrence

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The recurrence configuration is configured in this tab. The options available depend on the configuration in the General settings tab. The following are available:

  • Daily: The task is carried out at certain daily intervals.
  • Weekly: The task is carried out on certain weekdays at certain weekly intervals.
  • Monthly, day of month: The task is carried out on a certain day at certain monthly intervals.
  • Monthly, day of week of month: The task is active once a month with a certain monthly interval, on a weekday in a certain week.

"Daily" configuration

Parameters

Description

Days

Configuration of the number of days that pass for a day with an active schedule. Manual entry or configuration using the cursor keys.

  • Minimum: 1
  • Maximum: 99

Display of the configuration

Displays the current configuration of the schedule.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.

"Weekly" configuration

Parameters

Description

Weeks

Configuration of the number of weeks of the selected weekdays that are active in the Days in the week option. Manual entry or configuration using the cursor keys:

  • Minimum: 1
  • Maximum: 99

Days in week

Selection of the weekdays on which the job is carried out. Selection by activating the checkbox.

Display of the configuration

Displays the current configuration of the schedule.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.

Configuration of "Monthly, day of month"

Parameters

Description

Day in month

Selection of the active days in the month. Manual entry or selection using the cursor keys:

  • Minimum: 1
  • Maximum: 31

Months

Selection of the monthly interval between active days. Manual entry or selection using the cursor keys:

  • Minimum: 1
  • Maximum: 99

Display of the configuration

Displays the current configuration of the schedule.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.

Configuration of "Monthly, day of week in the month"

Parameters

Description

Day in week

Selection of the weekday on which the schedule is active, from a drop-down list:

  • monday
  • Tuesday
  • Wednesday
  • Thursday
  • Friday
  • Saturday
  • Sunday
  • Daily
  • Weekday
  • Weekend day

Week in month

Selection of a week in the month in which the previously-selected day is active, from a drop-down list:

  • First week
  • Second week
  • Third week
  • Fourth week
  • Last week

Months

Selection of the monthly interval between active days. Manual entry or selection using the cursor keys:

  • Minimum: 1
  • Maximum: 99

Display of the configuration

Displays the current configuration of the schedule.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.


In day recurrence

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> Job schedules -> In day recurrence

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The recurrence for the day is configured in this tab. This scheme determines how often and when the schedule triggers an event on active days. The options available depend on the configuration in the General settings tab. The following are available:

  • Once: The schedule triggers an event at a precise point in time on active days.
  • Recurring: The schedule triggers an event periodically in a certain time range with a certain interval on active days.

"Once" configuration

Parameters | Description
Schedule occurs at | Selection of the point in time when the schedule triggers an event on active days, in hours, minutes and seconds. Manual entry or selection using the cursor keys.
Display of the configuration | Displays the current configuration of the schedule.
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.

"Recurring" configuration

Parameters

Description

Schedule recurrence quantity

Number of recurrences Manual entry or configuration using the cursor controls:

  • Minimum: 1
  • Maximum: 99

Schedule recurrence granularity

Schedule recurrence period granularity. Select from drop-down list:

  • Second(s)
  • Minute(s)
  • Hour(s)

Recurrence starts at

Defines the start time of the activity period of the schedule on active days. Manual entry or configuration using the cursor controls.

Recurrence ends at

Defines the end time of the activity period of the schedule on active days. Manual entry or configuration using the cursor controls.

Display of the configuration

Displays the current configuration of the schedule.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.


Duration

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> Job schedules -> Duration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The period of validity of the schedule is configured in this tab.

Parameters

Description

Schedule starts on

Configuration of the start of the validity for this schedule. Manual input or selection from a drop-down calendar.

Only days from this date can be active days.
For example: Start date April 1, 2014. The first backup job can be started on April 1 at 00:00:00.

Schedule ends on

Active: An expiration date is stipulated for this schedule. Manual input or selection from a drop-down calendar.

Only days that are before this date can become active days. For example: End date May 1, 2014. The first backup job can be started on April 30 at 23:59:59.

The end date must be later than the start date.

Display of the configuration

Displays the current configuration of the schedule.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.


Example of automated database backup

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Administrate automated database backups -> Example of automated database backup

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For an example of automated database backup, it is assumed that:

  • An Analyzer server is put into operation on 1/1/2013.
    • The databases on the server are to be saved every Sunday at 20:00:00.
    • In doing so, there are no conflicts with subscriptions, because these are only started on Monday at 02:00:00.
    • The last 10 backup files should be retained for each database.
  • On March 11, 2013, it is established that the server suffered hardware damage to the hard drive on 10 March, 2013, before the backups were made.
    • Once the drive has been replaced, the last backups before the hardware damage should be restored.
    • The backups made by the faulty hard drives are to be deleted.

The example consists of 3 stages:

  1. Configuring automated backup
  2. Deleting unusable backup files
  3. Restoring correct backups

Configuring automatic backup

  1. The administration of automated database backups is started in ZAMS.
  2. In this, the procedure to create a new automated database backup job is started.
  3. All databases are included in the new job.
  4. The schedule of the job is set so that the job is always carried out on Sunday at 02:00:00:
    • Weekly, with a weekly interval
    • Only Sunday active day
    • Execute once a day, at 02:00:00
  5. The new database backup job is carried out.

Deleting unusable files

  1. The administration of database backup files is started in ZAMS.
  2. The file list is sorted according to time stamps.
  3. As a result, the backups created on March 10, 2013 are grouped together.
  4. The backup files of March 10, 2013 are deleted.

Restoring backups

  1. The procedure to restore database backups is started in ZAMS.
  2. All databases are highlighted.
  3. Because the most recent backup file is automatically selected, (from March 3, 2013, because the files from March 10, 2013 have been deleted), the restore can now be instigated by clicking on OK.


Manage database backup files

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manage database backup files

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Automated and manually-created backups can be administered in their own dialog.

To administer database backups:

  1. open the menu SQL-Server
  2. Select the entry Manage Database Backup Files.
  3. The dialog for administering the backup files is opened

Parameters

Description

Table of backup files

Displays all backup files created with the following information:

  • Name of the backup file: Filename in complete UNC format
  • Database name: Name of the database to which the file belongs
  • Date and time of the backup: Time stamp of the database backup that is in the file
  • Backup file state: Status text of whether the checksum of the backup is valid. Invalid means a corrupted backup file.

One file can be selected.

Separator

Separates both tables and can be moved with the mouse in order to enlarge the display area of a table.

Table of properties

Shows details on the file that was selected in the upper table. The table contains names and values of the properties.

You can read details of these properties at:

http://msdn.microsoft.com/en-us/library/ms178536.aspx.

Refresh

Refreshes the display.

Delete

Deletes the selected file and updates the view.

Open folder

Opens the folder with the backup files in Windows Explorer.

Close

Closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Storage path for database backup files:

The first time a backup request is made and a path has not yet been established, you are requested to define a save path. This path is then used for all backups and restorations. This path is administered in the options in the Database backups tab of the Settings.

Note: It is recommended that a path on the Analyzer computer is used for backup.

Parameters

Description

Network share path for storing database backup files of [database]

A valid UNC path must be entered.

Clicking on the ... button opens the dialog to select a network share.

A check is made if:

  • The syntax of the path is valid if:
    Only valid paths unlock the OK button.
  • The path exists:
    When clicking on OK, the path is only accepted if it can also be accessed.
  • The path is different to that already used:
    If a path is defined that is different to a path that has already been used, a corresponding message is given. The path can be created. The pre-existing database backup job can then be activated, deactivated and deleted, but can no longer be edited.

The configured path is saved individually for each user.

Attention: The access rights to network shares must be set correctly. For details, see the Set access rights to network share correctly.

OK

Accepts the path and closes the dialog.

Cancel

Discards changes and closes the dialog.

Set access rights to network share correctly

In order for all database backup action to run correctly, the access rights to the network share must correspond to the database backup folder. For this, the following applies:

  • The folder must be on the Analyzer Server, because defined users must access it locally on the Analyzer Server.
  • Because the folder must be accessible by both the Analyzer Server and the ZAMS computer with the same path, it must be authorized in the network. The folder is then accessible with the same path via a UNC path everywhere in the network.
  • The following users must have full access to the network share:
    • NT SERVICE\MSSQL$ZA3: For the creation and restoration of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • NT SERVICE\SQLAgent$ZA3: For automatic creation of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • Every ZAMS user: To create and restore backups, administer backup files and administer automated backup jobs.

Backup file name

The file name of a database backup file follows this scheme: [database name]_yyyy_MM_dd_HH_mm_ss.bak

e.g.: ZA_DATA_2013_02_12_14_11_35.bak = backup of ZA_DATA on 12.2.2013 at 14:11:35


Manage linked server

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manage linked server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This function is available if there is a connection to an Analyzer server with a valid license.

When this function is started, a list of the linked servers is obtained from the SQL Server instance. This list comes from the database to which ZAMS is connected.

Parameters | Description
List of linked servers | Contains all linked servers. The expression in brackets contains the provider for the connection. All linked servers are always shown, even if they are a type that is not supported.
New Microsoft SQL server | Gets all SQL Server instances available in the network and opens the dialog to configure a linked SQL server.
New Microsoft SQL Azure server | Opens the dialog to configure a linked Microsoft SQL Azure server. Note: Each database on an SQL Azure instance must be added as its own linked server for technical reasons. You can also find general information on MS Azure in the MS Azure manual.
New Oracle server | Opens the dialog to configure a linked Oracle server. Note: This button is only active if (OraOLEDB.Oracle) is found on the SQL server instance of the Oracle OLEDB provider.
New ODBC server | Opens the dialog to configure a linked ODBC server.
Delete | Deletes the server highlighted in the list.
Close | Closes the dialog

Further providers of linked servers are available with SQL Server 2016. Providers from third-party manufacturers are also available; the Oracle OLE DB provider is an example of this. If a provider that is different to the ones pre-configured here is to be used, the linked server can be set up manually using SQL Server Management Studio.

Other topics in this chapter

Linked SQL server

Linked Microsoft Azure server

Linked Oracle server

Linked ODBC server.


Linked SQL server

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manage linked server -> Linked SQL server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of a linked SQL server.

Parameters | Description
Server | Entry for SQL server instance. Either a selection from a drop-down list or details of its own instance. The entry is the name for the linked server at the same time, as described by the provider.
User name | User name.
Password | Password. Is not displayed in plain text.
OK | Applies settings and closes the dialog.
Cancel | Discards all changes and closes the dialog.


Linked Microsoft Azure server

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manage linked server -> Linked Microsoft Azure server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of a linked Microsoft Azure server

  1. In the dialog to administer the linked server, click on the New Microsoft Azure Server button.

    The dialog for configuring a server is opened.

  2. Assign a name for the server.
  3. Enter an instance name.
    Note: You can find this on Microsoft Azure.
  4. Enter the name of the database.
  5. Enter the user name for access.
  6. Enter the password for access.
  7. Click on OK.

    The linked server is created and the dialog for creation is closed.
    The new linked server is then given a connection test.
    If the test is not successful, there is a query asking whether the new settings are to be retained:

    • Yes: Settings are retained and are displayed in the list.
    • No: Settings are discarded and the server is removed from the list.

info Information

Each database on an SQL Azure instance must be added as its own linked server for technical reasons.

Dialog Configuration

Parameters | Description
Linked server name | Name of the linked server.
Microsoft SQL Azure instance name | Name of the SQL Azure instance. Can be read from Microsoft Azure. Syntax: [any desired character sequence].[database].windows.net
Database on Microsoft SQL Azure instance | Entry of the database name. Can be read from Microsoft Azure.
User name | Entry of the user name.
Password | Password. Is not displayed in plain text.
OK | Applies settings and closes the dialog. A connection test is carried out afterwards. If the connection cannot be established, the option to reject the configuration is offered.
Cancel | Discards all changes and closes the dialog.


Linked Oracle server

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manage linked server -> Linked Oracle server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of a linked Oracle server

Parameters | Description
Linked server name | Name of the linked Oracle server. The name must not have been issued to an existing linked server already.
Product name | Any desired product name.
Data source | Connection name for the Oracle OLEDB provider. You can find details on installation and setting up the parameters of the Oracle providers in the Oracle documentation.
Username | User name
Password | Password. Is not displayed in plain text.
OK | Applies settings and closes the dialog.
Cancel | Discards all changes and closes the dialog.


Linked ODBC server.

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manage linked server -> Linked ODBC server.

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of a linked ODBC server.

Parameters | Description
Name of connection server | Name of the new linked ODBC server. The name must not have been issued to an existing linked server already.
Product name | Any desired product name.
Data source (DSN) | Name of the DSN entry to be used. If nothing is entered here, the provider string must be specified in the Provider string field.
Provider-String | The provider string to be used is given here. If nothing is entered here, the DSN entry must be specified in the Data source (DSN) field.
User name | User name.
Password | Password. Is not displayed in plain text.
OK | Applies settings and closes the dialog. One the two fields, Data source (DSN) or Provider string can be empty.
Cancel | Discards all changes and closes the dialog.


Manage metadata indices

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manage metadata indices

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In order for metadata indices to be administered, there must be a connection to an Analyzer server with a valid license.

To administer the metadata indices:

  1. Select, in the SQL server menu, the Metadata indices command
  2. The dialog with the display of the fragmentation of the metadata indices is opened

The size of the window can be adjusted by dragging with the mouse. The position and size are saved depending on the user and the ZAMS version.

Parameters

Description

Table

Table name.

Index

Index name.

Records

Number of entires in the index.

Pages

Number of pages on which the index is saved.

Internal fragmentation

Value displays how much (in percent of pages on which the index is saved) is unused. A high degree of internal fragmentation increases the memory that the index occupies. This can reduce the index performance, because more pages have to be read. Critical values are accented in color:

  • Yellow: Value greater than 5%
  • red: Value greater than 30%

Indices without entries always have internal fragmentation of 100%. Indices that occupy 1 or 0 pages are excluded from highlighting.

External fragmentation

The value states how many of the pages of the index are not saved consecutively.

A page cannot be saved consecutively if its logical position between other index pages in the index is not equal to its physical position between other index pages on the memory medium.

A high degree of external fragmentation reduces the index performance, because it is often necessary to jump between save locations on the memory medium when reading the index.

Critical values are accented in color:

  • Yellow: Value greater than 5%
  • red: Value greater than 30%

Indices that occupy 1 or 0 pages always have an external fragmentation of 0%.

The table is in descending order according to this column as standard.

Index statistics

Opens the dialog for displaying the index statistics.

Index administration

Opens the dialog for index maintenance.

Close

Closes the dialog.

Index statistics

Parameters | Description
Index | Selection of the index from the drop-down list. The following tables are filled with data depending on this selection.
Statistic header | Header with metadata.
Density vector | Density vector to measure the correlations between columns.
Histogram | Histogram for distribution of the values.
Close | Closes the dialog.

You can find more information on interpretation of the values at, for example:

  • MSDN: http://msdn.microsoft.com/en-us/library/ms174384(v=sql.90).aspx
  • SQL ServerCentral: http://www.sqlservercentral.com/articles/Stairway+Series/72446/ (registration required)

Index administration

Parameters

Description

Index name

Name of the index.

Maintenance action

Possible maintenance actions. When switching, the appropriate maintenance action is pre-selected for each index. The dialog can usually be confirmed without changes by clicking on OK.

Select from drop-down list:

  • No maintenance:
    Do not carry out any action.
    Always available.
  • Recompute index statistics:
    Updates the statistics.
    Only available if the index occupies more than 0 pages.
    The action hardly needs to be carried out, because the SQL server has good automated mechanisms for carrying this out.
  • Reorganize index:
    Reorganize index (includes Recompute index statistics.)
    Only available if the index occupies more than 0 pages.
  • Rebuild index:
    Rebuilds the index. (includes Recompute index statistics.)
    Only available if the index occupies more than 0 pages.

OK

Executes the selected action and ends the dialog.

Cancel

Exits the dialog without carrying out any actions

If an action is not successful, a message window with the indices where maintenance was unsuccessful is displayed.

Other topics in this chapter

Best practice for maintenance action


Best practice for maintenance action

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Managing SQL Server -> Manage metadata indices -> Best practice for maintenance action

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The decision on what appropriate administrative action to take is orientated towards the Best Practices for index administration. It follows this scheme:

  1. If the index occupies more than one page and the external fragmentation is >= 5 %: Reconstruct index;

    otherwise continue

  2. If the index occupies more than one page and the internal fragmentation is >= 30 %: Reconstruct index;

    otherwise continue

  3. If the index occupies more than one page and the internal fragmentation is >= 5 %: Reorganize index;

    otherwise continue

  4. No administration

You can find further information on indexing in the Indexing of database tables - Best Practice chapter.


Selection of folder in the network

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Selection of folder in the network

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The dialog to select a network approval is displayed if a folder in the network is selected as a save location for files from ZAMS. The display of the dialog and its content is controlled by the operating system.

Parameters | Description
Network display | Displays the network. Clicking on the folder starts a search for computers in the network and shows these. Because it takes some time to list all computers available in the Windows network, the Network node can only be opened after some seconds.
OK | Accepts selection and closes dialog.
Cancel | Discards selection and closes dialog.

Parameters | Description
Network display | Displays computers present in the network. Clicking on the computer shows approved folders. Clicking on the folder highlights this for acceptance as the save location.
OK | Accepts selection and closes dialog.
Cancel | Discards selection and closes dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.


Archive emulation

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In ZAMS, you can emulate archives that are derived from figures from entries in the AML, CEL and archives in zenon. An emulated archive consists of metadata for archives and variables. These are calculated periodically according to the configuration.

Sources for basic archive and reset events:

  • Emulated zenon archives
  • Other emulated archives
  • Emulated archives from the 3rd party database Connector

For emulated archives that do not come from zenon, the data source must be called Archive. Variables from these archives are not available for the data sources AML or CEL.

Data from the emulated archives can be read directly from the Analyzer database regardless of the selected connector. For reports, the origin of the data - zenon archive or emulated archive - is transparent. Emulated archives are configured in ZAMS.

Configure archive emulation

To configure the archive emulation:

  1. Select the Configure archive emulation entry in the Automation menu.
  2. The current configuration of the emulated archive is loaded.
  3. The dialog to administer the emulated archive is displayed.
  4. Clicking on the 'OK' button accepts all changes made.

info Information

For the configuration of an emulated archive, the metadata must contain at least:

  • A project
  • A variable

For the configuration of an emulated archive variable, the data source Archive is only available if there is at least one archive present in the metadata.

Configuration dialog

The configuration dialog shows all existing emulated archives when it is started.

Parameters

Description

List of archives

Displays all configured archives. The list contains:

  • Archive name: Name of the archive
  • Project name: Name of the project that is assigned to the archive
  • Cycle time: configured cycle time of the archive
  • Number of variables: Number of variables in the archive
  • Execution of emulation tasks: Information on the last execution of the SQL Server agent jobs that are assigned to the archive
  • Buttons to create, edit and delete emulated archives

New

Opens the dialog for creating a new archive.

Edit

Opens the dialog for editing the selected archive.

X

Deletes the archive after a request for confirmation.

Attention: All data is deleted from the archive with the archive configuration.

Note: The archive can only be deleted if it is not used by another virtual archive (calculated archive, emulated archive, 3rd party database connector archive).

OK

Applies settings and closes the dialog.

ZAMS writes the changes to the database and to the SQL Server agent. If errors occur when writing the configuration, these are displayed in the output window of ZAMS.

Cancel

Discards all changes and closes the dialog.

Use of time stamps

Archive emulation only uses a time stamp if a variable has changed a value. It must be ensured that all value changes are available.

The following applies for the AML: There is also a time stamp available for Alarm cleared. This is not used, but replaced by the time stamp for Alarm received of the next alarm.

Background: A constant flow of data from the base variables is used for emulation. There must be no point in time when the variable does not have a value. With alarms, the time for Alarm cleared is less than the time for Alarm received of the next alarm. If an entry for a value change of the base variables is missing, the old value is still set for emulation, because this value change does not appear in the basis data for emulation. As a result of this, it is possible that a calculation error (negative values) may occur.

Deleting emulated archives

The following is applicable for the deletion of emulated archives:

  • Emulated archives and variables in emulated archives can only be deleted if no other emulated archives depend on them. In this check, all variables in the archive are take into account - including base variables for the value calculation and resetting.
  • If an existing emulated variable (in the database) is used as a basic variable or resetting variable for a new emulated variable, it can no longer be deleted. This also applies after the deletion of the new emulated variable - if there is no longer dependency - as long as the configuration of the emulated archive has not been ended.
    This also applies for the existing emulated archive from which the emulated variable came.
  • If an existing emulated variable or an existing emulated archive is deleted, these variables or this archive is no longer available when selecting the data source for new emulated variables, even if the change was not yet written to the database.
  • 3rd party database Connector archives and variables in these archives can only be deleted if no emulated archives depend on them.

Other topics in this chapter

Editing modes

Creating an emulated archive

Edit emulated archive

Notes for report developers:


Editing modes

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Editing modes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The New and Edit buttons open the respective configuration dialog,depending on the status of the archive:

  • Create new archive: A completely new archive is created. All settings for archive variables can be modified.
  • Edit newly-created archive: A newly-created archive that has not yet been written to the database is edited. Or an archive that has already been saved and has been made editable again.
    • Archive: All settings can be edited, with the exception of Assigned project and Reference.
    • Variables: All settings can be edited.
  • Edit existing Archive: An archive that was created and saved in a previous configuration is edited. This was already written to the database and thus has entries in the metadata tables.
    • Standard:

      Archive: Only the Data calculation can be changed.

      Variables: Only displayed as read-only.

    • Make editable: The editing of an archive can be enabled, with the exception of assigned project and Reference. Existing data is deleted in the process.


Creating an emulated archive

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To create a new emulated archive:

  1. Select the Configure archive emulation entry in the Automation menu.
  2. The dialog for configuring emulated archives is opened

  3. Click on the New symbol to create a new archive.
  4. The dialog for configuring an emulated archive is opened

Parameters | Description
Metadata | Configuration of the metadata.
Variables | Configuration of the variables.
Data calculation | Configuration of the data calculation.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. Only available if all necessary configuration has been carried out.
Cancel | Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Other topics in this chapter

Metadata

Variables

Data calculation


Metadata

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The metadata is configured in this tab.

Parameters

Description

Project name

Selection from the drop-down list with all existing project names.

The first project entered is selected by default for new projects.

Attention: If this selection is changed and there are already variables in the variable list, it is emptied!

Reference

Input of the identification for the archive.

  • Maximum length: 128 characters
  • Must not be empty.
  • Must not be used by another archive that is assigned to the same project. Capitalization is not taken into account.

Visual name

Entry of the visual name of the archive.

  • Maximum length: 128 characters
  • Must not be empty.
  • Must not be used by another archive that is assigned to the same project. Capitalization is not taken into account.

Detailed information

Entry of the description of the archive.

  • Maximum length: 256 characters

Archive starts at

Stipulation of data and time for the start of the archive.

  • Date: Entry of the date or selection from a calendar.
  • Time: Entry of the time or setting by means of cursor keys.

Entry in UTC.

Earliest time point: 1.1.2013 00:00:00

Cycle time

Stipulation of the cycle time for the archive. Entry of the interval or setting by means of cursor keys.

The value must be greater than 0

Default: 1 minute

Assigned equipment groups

Assignment of equipment group to the archive. Selection by activating the checkbox in front of the respective equipment group.

Clicking on the + sign expands the group.

Default: No Allocation.

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Note: Mandatory fields and fields that are empty that have a negative validation are displayed with a red background.

Differences when editing new archives

If already-created, but not-yet saved archives are edited, the dialog exhibits the following differences:

  • All fields: The values that have already been set are displayed instead of the standard values.
  • Project name: The drop-down list to select a project is deactivated.
  • Identification: The entry for the reference is deactivated.
  • Assigned equipment groups: If the equipment model or one of its elements has a active assignment, then the complete branch of the group is displayed.

Differences when editing saved archives

If already-saved archives are edited, the dialog exhibits the following differences as standard:

  • All fields: The values that have already been set are displayed instead of the standard values.
  • All input possibilities are deactivated.

The editing of archives that have already been saved can be activated again.


Variables

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Emulated variables are created and edited in this tab.

When validating the dialog to create a new emulated archive, at least one emulated variable must be present. Emulated variables that have the same base variable must also have the same data origin. This also includes variables that supply additional reset event for absolute counters. Variables can also be duplicated.

Parameters

Description

Variable list

Displays all configured variables. The list contains:

  • Visual name: Name with which the variable is displayed
  • Base variable visualname: Name of the variables for the value calculation
  • Emulated variable type:
  • Data source: Origin of base variables

This list is empty by default when a new archive is created.

Symbol: New

Opens the dialog for Creating new variables.

Symbol: Duplicate

Creates, on the basis of the selected variables, a new variable and opens the dialog to configure the variables. This dialog is filled with the values of the base variables. The name and visual name of the variables must be unique. These are always made clear with numbers in brackets in the duplicated variables.

Symbol: Edit

Opens the dialog for editing the selected variable.

Symbol: Delete

Deletes the selected variable.

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Differences when editing saved archives

If already-saved archives are edited, the dialog exhibits the following differences:

  • No new variables can be created.
  • No variables can be deleted.
  • No variables can be edited.
  • The Display symbol allows the configuration of variables to be displayed.

Other topics in this chapter

Emulation configuration

Metadata

Assigned equipment groups

Assigned meanings

Base variable rules

Additional reset events


Emulation configuration

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Variables -> Emulation configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The emulated variables are created in this tab.

Parameters

Description

Emulated variable type

Selection of the type of emulated variable from a drop-down list. Depending on the type selected, either all or only selected tabs are displayed and options may be deactivated.

Emulation types:

  • Absolute time counter
    All tabs are displayed.
    Default on initial configuration.
  • Relative time counter
    Settings from Additional reset events are not relevant and are not shown.
  • Absolute event counter
    All tabs are displayed.
  • Relative event counter
    Settings from Additional reset events are not relevant and are not shown.
  • Sum
    Settings from Base variable rules and Addittional reset events are not relevant and are not shown.
  • Time-corrected average
    Settings from Base variable rules and Additional reset events are not relevant and are not shown.
  • Minimum
    Settings from Base variable rules and Additional reset events are not relevant and are not shown.
  • Maximum
    Settings from Base variable rules and Additional reset events are not relevant and are not shown.
  • Difference counter
    Settings from Base variable rules and Additional reset events are not relevant and are not shown.

For further information on the emulation types, see the Details of emulation types section.

Initial value

Entry of the initial value of the variable at the time the archive is started.

Only available if the type of the emulated variables is an absolute counter (absolute time counter, absolute event counter).

  • Minimum: 0
  • Maximum: 1000000

Time counter resolution (seconds)

Resolution of the time counter in seconds.

Only available if the type of the emulated variables is a time counter (absolute time counter, relative time counter).

  • Minimum: 1
  • Maximum: 86400 (1 day)

Examples:

  • 60: Minute counter
  • 3600: Hour counter
  • 86400: Day counter

Data source

Selection of a data source for the base variable from drop-down list:

  • Alarm Message List
  • Chronological Event List
  • Archive

Source archive

Selection of a source archive from a drop-down list. The list contains all archives of the project that was selected in the metadata dialog. This also includes emulated archives that were already saved in the metadata.

Only available if archive was selected as a data source.

Base variable

Selection of a base variable from a drop-down list, the value of which is derived from the values of the emulated variables.

Depending on the data source, available for:

  • Data source alarm message list or chronological event list: All available variables of the project that was selected in the metadata dialog. This also includes emulated variables that were already saved in the metadata.
  • Data source Archive: All variables that are assigned in the metadata to the archive with an aggregation of Raw value (0). This also includes emulated archives that were already saved in the metadata.

Base variable initial value

Entry of the initial value of the base variables at the time the archive is started.

  • Minimum: 0
  • Maximum: 1000000

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Details of emulation types

In the Emulation configuration tab, there are eight emulation types available for selection in the Emulated variable type drop-down list.

The following applies to all emulation types: If there is no value at the start of the archive capsule (value change was carried out exactly with the start time of the archive capsule), then as a maximum at the start time of the emulated archive, an attempt is made to find a valid value before the start of the archive capsule for the base variable. If a corresponding value is found, this is used at the start time of the archive capsule. Otherwise the configured initial value is used.

Possible values for emulation types:

  • Absolute time counter

    In each archive capsule of the emulated archive, the set time filter setting is used to count how long the base variable was in one of the states set out in the Base variable rules. The counter can be set to 0 by means of the defined resetting rules (Base variable rules and Additional reset events tabs). At the end of the archive capsule, the value of the counter is written to the emulated variable in the emulated archive.

    Start value of the current archive capsule: End value of the last archive capsule.

    All tabs are displayed.

  • Relative time counter

    In each archive capsule of the emulated archive, the set time filter setting is used to count how long the base variable was in one of the states set out in the Base variable rules. A relative counter cannot be reset to 0. At the end of the archive capsule, the value of the counter is written to the emulated variable in the emulated archive.

    Start value of the current archive capsule: always 0.

    Settings from Additional reset events are not relevant and are not shown.

  • Absolute event counter

    In each archive capsule of the emulated archive, how often the base variable has changed to one of the states set out by the Base variable rules is counted. The counter can be set to 0 by means of the defined resetting rules (Base variable rules and Additional reset events tabs). At the end of the archive capsule, the value of the counter is written to the emulated variable in the emulated archive.

    Start value of the current archive capsule: End value of the last archive capsule.

    All tabs are displayed.

  • Relative event counter

    In each archive capsule of the emulated archive, how often the base variable has changed to one of the states set out by the Base variable rules is counted. A relative counter cannot be reset to 0. At the end of the archive capsule, the value of the counter is written to the emulated variable in the emulated archive.

    Start value of the current archive capsule: always 0.

    Settings from Additional reset events are not relevant and are not shown.

  • Sum

    All values of the base variables are added up in each archive capsule. The sum is written to the emulated variable in the emulated archive at the end of the archive capsule.

    Settings from Base variable rules and Additional reset events are not relevant and are not shown.

  • Time corrected average

    In each archive capsule, the time-corrected average value of all values of the base variables is calculated in the archive capsule. The time-corrected average value is written to the emulated variable in the emulated archive at the end of the archive capsule.

    Settings from Base variable rules and Additional reset events are not relevant and are not shown.

  • Minimum

    In each archive capsule, the minimum of all values of the base variables is calculated in the archive capsule. The minimum is written to the emulated variable in the emulated archive at the end of the archive capsule.

    Settings from Base variable rules and Additional reset events are not relevant and are not shown.

  • Maximum

    In each archive capsule, the maximum of all values of the base variables is calculated in the archive capsule. The maximum is written to the emulated variable in the emulated archive at the end of the archive capsule.

    Settings from Base variable rules and Additional reset events are not relevant and are not shown.

  • Difference counter

    Converts an absolute time counter in zenon or recorded in the archive emulation into a relative time counter.

    Settings from base variable rules and additional reset events are not relevant and are not displayed.
    You can find details on the calculation for developers in the Difference counter procedure chapter and in the zenon Analyzer for developers manual.

info Information

Milliseconds are not used for cyclical archives in zenon. They are calculated but not reset to >0. Exception: Alternate values.

This must be taken into account when the data is obtained. Because the minimum read time of a cyclical archive is 1 second, a maximum of 1 value per second can come.


Metadata

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Variables -> Metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The metadata is configured in this tab.

Parameters

Description

Variable name

Entry of the variable name.

  • Maximum length: 128 characters.
  • Must not be empty.
  • Must not contain a comma
  • Must not be used by another variable that is assigned to the same project. Capitalization is not taken into account.

Visual name

Entry of the visual name of the variables.

  • Maximum length: 128 characters
  • Must not be empty.
  • Must not contain a comma
  • Must not be used by another variable that is assigned to the same project. Capitalization is not taken into account.

Description

Description of the variables.

Maximum length: 256 characters

Measuring unit

Unit of measurement the variables.

Maximum length: 50 characters

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Note: Mandatory fields and fields that are empty that have a negative validation are displayed with a red background.


Assigned equipment groups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Variables -> Assigned equipment groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The equipment groups are configured in this tab.

Parameters

Description

Tree with equipment groups

Selection of the desired equipment group from the tree structure. They are selected by activating the checkboxes in front of the desired groups.

  • Display on new creation: closed tree
  • Display when editing: all activated groups are displayed and their trees are expanded

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.


Assigned meanings

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Variables -> Assigned meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The meanings are configured in this tab.

Parameters | Description
Input field | Entry of a meaning Maximum length: 50 characters
Add | Clicking on the button adds a meaning from the input field to the list of meanings.
List of meanings | Contains all assigned meanings. Multiple selection is possible with the Ctrl key + left mouse click or the Shift key + left mouse click.
Remove | Removes all highlighted entries from the list of meanings.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. Only available if all necessary configuration has been carried out.
Cancel | Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.


Base variable rules

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Variables -> Base variable rules

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The rules for the basic variables are configured in this tab.

Only available for the following types of emulated variables:

  • Absolute time counter
  • Relative time counter
  • Absolute event counter
  • Relative event counter

Parameters

Description

List of rules

Display of the configured rules.

The list is empty for newly-created variables. The following are displayed for pre-existing variables:

  • Comparison type
  • Comparison value
  • Triggers counter reset

In addition to configured rules, an empty rule is always offered if the dialog was opened in an editable mode and the rules (reset) allow it.

In an empty rule, all control elements, with the exception of the comparison type, are deactivated.

Comparison type

Selection of the comparison type from a drop-down list. Available are:

  • Equal (=)
  • Less (<)
  • Less or equal (<=)
  • Greater (>)
  • Greater or equal (>=)
  • Not equal (!=)
  • Range Compares two values to one another and shows further input fields for Comparison type and Comparison value.

Comparison value

Entry of the comparison value.

Reset counter
  • Active: The counter is reset if the rule is met.

Only available if the type of the emulated variables is an absolute counter (absolute time counter, absolute event counter).

Symbol: Delete

Clicking on the button deletes the rule.

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Areas

The 'areas' comparison type defines a range between two values. The following rules are available:

  • [number] < X < [number]
  • [number] < X <= [number]
  • [number] <= X < [number]
  • [number] <= X <= [number]

Note on validation:

When validating the entries before creating the variables, the legal regulations must not be exceeded.

Examples of overlapping:

  • 2 or more rules are set to Equal (=) and have the same value.
  • 1 or more rules are set to Equal (=) and have a value that is Greater than (>)/Less or equal to (<=) the comparison value of an existing Greater than (>)/Less than or equal to(<=) rule.
  • 2 rules both use a greater comparison (regardless of whether Greater than (>) or Greater than or equal to (>=)).
  • 2 rules both use a smaller comparison (regardless of whether Less than (<) or Less than or equal to (<=)).
  • The value ranges of a Greater than or equal to (>=) and a Less than or equal to (<=) rule overlap. At least one figure is present in both ranges.


Additional reset events

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Variables -> Additional reset events

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, events for absolute counters are configured, which lead to defined results, in addition to the events defined in the Base variable rules, to reset the base variables.

Only available for the following types of emulated variables:

  • Absolute time counter
  • Absolute event counter

Parameters

Description

Use additional reset events for the counter of base variables

  • Active: Events to reset the absolute counter are, in addition to configuration in the Base variable rules tab, set by another base variable. This resets the base variable selected in the Emulation configuration tab for the counter.

Data source

Selection of a data source list for the variables from which the reset event comes, from a drop-down list:

  • Alarm Message List
  • Chronological Event List
  • Archive

Source archive

Selection of source archive for the variables from which the reset events come, from a drop-down list: The list contains all archives of the project that was selected in the metadata dialog. This also includes emulated archives that were already saved in the metadata.

Only available if archive was selected as a data source.

Base variable

Selection of base variables from which the additional reset events come, from a drop-down list.

Depending on the data source, available for:

  • Data source alarm message list or chronological event list: All available variables of the project that was selected in the metadata dialog. This also includes emulated variables that were already saved in the metadata.
  • Data source Archive: All variables that are assigned in the metadata to the archive with an aggregation of Raw value (0). This also includes emulated archives that were already saved in the metadata.

List of rules

Display of the configured rules.

The list is empty for newly-created variables. The following are displayed for pre-existing variables:

  • Comparison type
  • Comparison value

In addition to configured rules, an empty rule is always offered if the dialog was opened in an editable mode and the rules (reset) allow it.

In an empty rule, all control elements, with the exception of the comparison type, are deactivated.

Comparison type

Selection of the comparison type from a drop-down list. Available are:

  • Equal (=)
  • Less (<)
  • Less or equal (<=)
  • Greater (>)
  • Greater or equal (>=)
  • Not equal (!=)
  • Range Compares two values to one another and shows further input fields for Comparison type and Comparison value.

Comparison value

Entry of the comparison value.

Symbol: Delete

Clicking on the button deletes the rule.

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

attention Attention

The list of rules for valid reset events must contain at least one rule during validation if the option Use additional reset events for the counter of base variables has been activated.

Areas

The 'areas' comparison type defines a range between two values. The following rules are available:

  • [number] < X < [number]
  • [number] < X <= [number]
  • [number] <= X < [number]
  • [number] <= X <= [number]

Note on validation:

When validating the entries before creating the variables, the legal regulations must not be exceeded.

Examples of overlapping:

  • 2 or more rules are set to Equal (=) and have the same value.
  • 1 or more rules are set to Equal (=) and have a value that is Greater than (>)/Less or equal to (<=) the comparison value of an existing Greater than (>)/Less than or equal to(<=) rule.
  • 2 rules both use a greater comparison (regardless of whether Greater than (>) or Greater than or equal to (>=)).
  • 2 rules both use a smaller comparison (regardless of whether Less than (<) or Less than or equal to (<=)).
  • The value ranges of a Greater than or equal to (>=) and a Less than or equal to (<=) rule overlap. At least one figure is present in both ranges.


Data calculation

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Creating an emulated archive -> Data calculation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The data calculation is configured in this tab. The options can be configured without limitations in all three editing modes.

Parameters

Description

Values are calculated

Active: Values for the emulated archive are calculated in the SQL server agent.

Maximum connector-
Data block time period (hours)

Stipulates the maximum time period in hours for which connectors can be obtained in a query. Entry in the field or configuration using the cursor keys.

  • Minimum: 1
  • Maximum 10000
  • Default: 1

If a larger time range is needed in total, several connector calls are carried out after one another.

Example:

  • Connector data from three days is to be obtained.
  • The query is to be made in three parts.
  • Entry in the field: 24

Background information: If very large amounts of data are obtained in a query, the working memory may be to small for the Runtime server. For archive data, for example, this leads to an "Out-Of-Memory" error. The corresponding message window then blocks the Runtime server until the message is confirmed on the server itself. This situation can be avoided with the appropriate configuration.

Minimum delta time (hours)

Stipulates how old, in hours, an archive capsule of the emulated archive must be before values for it are calculated. Entry in the field or configuration using the cursor keys.

Minimum: 0

Maximum: 10000

Default: 0

Example:

  • Entry: 10
  • Current time: 2013-06-06; 4:00 PM
  • Goal: From 00:00:00 on June 6, 2013, one archive capsule per hour is to be written.
  • Only values for the archive capsules from 00:00:00 to 05:00:00 on 2013/06/06 are calculated and written.
  • Reason: The archive capsules from 06:00:00 to 16:00:00 on 2013/06/06 are not older than 10 hours.

Background: If data can only be forwarded up to a certain time, for example up to the last SQL export, this can be configured here.

Connector

Selection from drop-down list that is to be used to obtain the data for the base variables.

Calculation schedule

Configuration of the time plan for the calculation of values.

Schedule starts on

Stipulation of the time from which the schedule is to run. Entry in the field or configuration using the cursor keys.

Once per day every N days

Active: The calculation is carried out every N days at a certain time.

  • N days: Configuration with the Number of days option
  • Time: Configuration with Execute at option

Number of days

Stipulation of the interval between two calculations in days. Entry in the field or configuration using the cursor keys.

Minimum: 1

Maximum: 100

Execute at

Stipulation of the time at which the calculation is carried out on day N. Entry in the field or configuration using the cursor keys.

Per N hours every day

Active: The calculation is carried out daily every N hours at a certain interval.

  • Distance: Configuration with the Number of hours option
  • Start time: Configuration with Start at option

Number of hours

Stipulation of the interval between two calculations in hours. Entry in the field or configuration using the cursor keys.

  • Minimum: 1
  • Maximum: 23

Starting at

Stipulation of the time at which the first daily calculation is carried out. Entry in the field or configuration using the cursor keys.

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Examples

Once a week

The calculation should be carried out every Sunday at 00:05:00 from now.

Configuration:

  1. Activate the Once a day every N days option
  2. Number of days: 7
  3. Execute at: 12:00:05 AM
  4. Schedule starts at: desired Sunday in the past

12 times a day

The calculation should be carried out from 1/1/2014 every 2 hours and 15 minutes after the hour.

Configuration:

  1. Activate the Every N hours daily option
  2. Per N hours every day: 2
  3. Starting at 12:15:00 AM
  4. Schedule starts on: 01.01.2014


Edit emulated archive

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Edit emulated archive

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To edit an emulated archive:

  1. If the dialog has not yet been opened, select the Configure archive emulation entry in the Automation menu
  2. The dialog for configuring emulated archives is opened

  3. Highlight the desired archive
  4. Click on the Edit button to change the configuration
  5. The dialog for configuring an emulated archive is opened

    Note: The settings that can be changed depend on the status of the archive.

Editing a new archive

A new archive has already been created and contains data, but was not yet written to the SQL server agent. This means: This dialog has not yet been closed since the first configuration.

  • Archive: All settings can be edited, with the exception of Project and Identification.
  • Variables: All settings can be edited.

Editing a saved archive

A saved archive is already created, contains data and was already written to the SQL server agent. This means: This dialog was closed after the initial configuration by clicking on OK and is now opened again.

  • Archive: In the basic setting, only the Data calculation can be changed.
    The Make editable button can be used to edit the archive again, with the exception of the project allocation and name. This button is only available if the emulated archive has already been saved and has not been unlocked for editing again.
    For details, see the Allow editing section.

  • Variables: Only displayed as read-only.

Make editable

To edit an emulated archive that has already been saved again:

  1. Click on the button Make editable
  2. Confirm this when requested to do so.
  3. The data in the EMULATED_DATA table is deleted.
  4. Edit the archive and save it again.


Notes for report developers:

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Archive emulation -> Notes for report developers:

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

An emulated archive consists of metadata for archives and variables. They are calculated periodically according to the configuration via an SQL server agent job.

The following metadata, SPs and UDFs are used for emulated archives:

Metadata

  • Emulated_Archive
  • Emulated_Variable
  • Emulated_Variable_Configuration
  • Emulated_Data
  • Stored Procedures

Stored Procedures

  • CalculateEmulatedArchiveValues

User Defined Function Blocks

  • GetTotalSeconds


Calculated archives

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Calculated archives

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Calculated archives provide other reports with formulas with calculated values as an archive. In doing so, the data is not saved, but is alway recalculated again.

Clicking on the New (star) button opens the dialog to configure a new calculated archive.

Key:

  • : New
  • : Edit
  • : Delete

Other topics in this chapter

Creating and editing a calculated archive


Creating and editing a calculated archive

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Calculated archives -> Creating and editing a calculated archive

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To start calculating archives:

  1. In the menu bar, open the SQL Server menu.
  2. Select the Configure calculated archives entry.

    The dialog to create and configure calculated archives is opened:

    Key:

    • new:
  3. Click on the symbol New:

    The dialog for configuration is opened.

  4. Configure the metadata and variables.

    The new entry is added to the list.

Key:

  • : New
  • : Edit
  • : Delete

Parameters

Description

List of calculated archives

Lists all configured calculated archives. The list shows:

  • Archive name: Visual name of the archive.
  • Project name: Visual name of the project that is assigned to the archive
  • Cycle time: Cycle time of the archive.
  • Number of variables: Number of variables in the archive.

Symbol new

Clicking opens the dialog to configure a new calculated archive with the metadata tab.

Edit symbol

Clicking opens the dialog to configure the calculated archive in order to make changes to the configuration.

Delete symbol

Clicking deletes the calculated archive and all variables calculated therein without requesting confirmation.

Note: The archive can only be deleted if it is not used by another virtual archive (calculated archive, emulated archive, 3rd party database connector archive).

OK

If clicked on, the dialog is closed and the changes are saved.

Cancel

If clicked on, the dialog is closed and the changes are discarded.

Other topics in this chapter

Metadata

Variables


Metadata

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Calculated archives -> Creating and editing a calculated archive -> Metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The archive metadata, the metadata and calculation tables of all variables contained in the archive are edited in this dialog.

If the dialog to edit an existing calculated archive is called up, the input elements in the dialog are initialized with the data of the archive.

Parameters

Description

Project

Selection of the project that is assigned to the archive from a drop-down list. All variables in the calculated archive are automatically assigned to this project.

If this entry is changed, all variables configured for this are deleted.

Note: The drop-down list is deactivated if at least one variable of this archive is used by another virtual archive.

Reference

Input of the identification for the archive.

The field must not be empty during validation.

Visual name

Entry of the visual name for the archive.

The field must not be empty during validation.

Description

Optional description for the archive.

Connector

Connector to get the variable field data for the calculation of values. Select from drop-down list.

Cycle time

Input of the cycle time for the archive.

  • dd: Days
  • HH: Hours
  • mm: Minutes
  • ss: Seconds

Entry in the field or configuration using the arrow symbols.

Assigned equipment groups

Equipment groups to which the archive is assigned. Selection by activating the checkbox in front of the respective group.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Validation

  • The following entries must be occupied with the archive:
    • Project selection
    • Archive reference
    • Archive visual name
    • Connector
  • Furthermore, the following archive entries must not have any conflicts with other archives in the global project:
    • Archive reference
    • Archive visual name
  • With variables, the following rules must be adhered to for all variables:
    • The variable name and visual name must be filled and must not lead to conflicts with other variables of the same project
    • Each variable must have an active field for the value calculation.


Variables

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Calculated archives -> Creating and editing a calculated archive -> Variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of calculated variables.

If the dialog to edit an existing calculated archive is called up, the input elements in the dialog are initialized with the data of the archive.

Key:

New:

Duplicate:

Delete:

Variables

Display and creation of the calculated variables.

Parameters

Description

Symbol new

Clicking on the symbol adds a new calculated variable to the list.

The variable name and variable visual name are generated automatically. Overlaps are avoided in the process.

The automatically-created entries can be amended in the metadata group.

Duplicate symbol

Clicking on the symbol duplicates all selected variables. The calculation formulas are also duplicated in the process.

Variable name and variable visual name are generated automatically based on the source variable. Overlaps are avoided in the process.

The automatically-created entries can be amended in the metadata group.

Delete symbol

All selected variables are deleted without requesting confirmation by clicking on the symbol.

Before deletion, a check is carried out to see whether one of the selected variables are used in a different archive. Deletion is refused if this is the case.

List of variables

The list contains all created variables with information on:

  • Variable name
  • Variable visual name
  • Description
  • Measuring unit
  • Number of assigned meanings
  • Number of assigned equipment groups
  • Number of status names

Multiple selection of variables is possible in the list.
The following applies with multiple selection:

  • Errors of the other input groups are always filled with the values of the first-selected variables.
  • Changes in an input field in one of the other input groups have an effect on all selected variables.

Metadata

Configuration of the metadata for the variables.

Parameters

Description

Variable name

Name of the variable.

  • Must not be empty.
  • Must be unique in the project.

Only available if precisely 1 variable has been selected.

Visual name

Visual name of the variables.

  • Must not be empty.
  • Must be unique in the project.

Only available if precisely 1 variable has been selected.

Description

Description of the variables.

Measuring unit

Unit of measurement the variables.

Assigned equipment groups

Configuration of the workgroups that are assigned to the variables.

Parameters | Description
Assigned equipment groups | Selection of the equipment groups that are assigned to the variables. Selection by activating the checkbox in front of the group.

Calculation formula

Configuration of the formula for the variable.

Parameters

Description

Formula field

Shows formula of the calculated variables.

If no formula is displayed despite the configuration of the calculation, this can be caused by the following:

  • No calculation field is assigned.
    This leads to a validation error.
  • The calculation field is not a formula field, but a cost field for example.

Configure formula

Opens the dialog to configure custom formulas without aggregation. Only available if precisely one variable in the list has been selected.

The dialog is started in the mode for calculated archives.
Attention: When configuring the formula, the Field for calculated variables option in the different tabs can only be selected once. This field must be a formula field.

Assigned meanings

Configuration and assignment of the meanings.

Parameters | Description
Meaning field | Entry of a new meaning.
Add | Assigns the meaning from the meaning field to the variables.
List of meanings | Displays all configured meanings. Multiple selection is possible.
Remove | Clicking on the button removes all meanings selected in the list.

Status names

Configuration and assignment of the status names.

Parameters | Description
numerical element | Entry of the value of the status. Must be unique.
Input field | Entry of the status text for this value. Must be unique.
Add | Adds the entered value with the given status text into the list field. Neither the value nor the text can already exist.
List of status names | Shows all existing entries. Multiple selection is possible. Format: [Value]: [Text]
Remove | Clicking on the button removes all status names selected in the list.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


User administration and access rights

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The user administration for zenon Analyzer is organized in ZAMS. It consists of the administration of the:

  • Users with dedicated license
  • Access rights in Report Launcher
  • Access rights to Analyzer applications

Set rights for users and objects in ZAMS and the Report Launcher are each set and applied after being confirmed in the dialog by clicking on OK.

Users can be administered throughout domains and in user groups. For Users with dedicated license and the administration of access rights for Analyzer Tools, each user must be individually administered in the selection dialog. Administration according to groups is possible via the configuration of the filter for user groups. To do this, the user group is entered as a filter condition and then the user is selected.

For the administration of access rights in the Report Launcher, user groups can be selected directly in the selection dialog.

Checking the user licenses

ZAMS

ZAMS checks, every 10 seconds, if a ZAMS license on the license server can be confirmed for the connected user on the connected Analyzer server. If a background thread is running at the time of verification, such as the preparation of a report, then the verification is postponed until the completion of this background thread.

Report Launcher

The Report Launcher confirms an Report Launcher license on the license server every 10 seconds for each user whose last access took place less than 15 minutes ago. On the license server, the client lifetime is 30 seconds since the last activity.

Error Handling

If problems occur with the licensing or the connection, please note the checklist in the event of license problems.

Other topics in this chapter

Configuration of user search

Selection of users and user groups

Users with dedicated license

Basic principles of user access rights

Access rights to Analyzer applications

Report Launcher access rights


Configuration of user search

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Configuration of user search

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When calling up dialogs to assign a user profile, a user search is opened if no users have yet been stored in ZAMS. Here, you define how and in which locations users are to be searched for the population of the user list.

  • Direct query:
    Targeted query of the domains and the caches only once users have been added. For this, the following applies:
    • Groups are only available in the filters if they are present in the cache. They must therefore have already been called up - regardless of whether they have been added.
    • Users and groups that have been found are cached.
    • Users defined locally on the Analyzer server cannot be added.
    • Groups defined locally on the Analyzer server cannot be added or filtered.
  • Cache users and groups
    When first querying users, all users and groups of the defined domains are searched for locally and cached. With domains with many users and groups, this can take a long time.

Dialog for searching for users and groups

Parameters

Description

Direct search for users and groups (in domains only)

Active: Users and groups are only searched for as required.

Confirmation before searching groups and users

Active: If no user is found when an object is searched for, a request for confirmation is made for a further search.

Background: If no user is found in the domain, a search for a group is carried out. If a group is found, all users contained if the group are searched for. This can take a long time.

Only available if Direct search for users and groups has been activated.

Load users and groups from these locations:

Active: Users and groups are searched for and updated immediately. This can take a long time with large domains.

Users defined locally on the Analyzer Server "[computer name]"

Active: A search for defined users and user groups is carried out locally on the Analyzer server.

Only available if Load users and groups from these locations: has been activated.

In the domain "[domain name]"

Active: A search for domain users and user groups is carried out in the domain of the currently-connected user.

Detection takes place in three steps:

  • Firstly, an attempt is made to return the names of the domains in which the user is defined.
  • If this is unsuccessful, an attempt is made to return the names of the domains in which the computer is integrated.
  • If this is unsuccessful, the computer name is returned.

Only available if Load users and groups from these locations: has been activated.

In the domains

Entry of a domain in which a search for users and user groups is to be carried out. Accept by clicking on the Add button.

Only available if Load users and groups from these locations: has been activated.

Add

Adds the domains stated in the In the domains input field to the list of domains.

The entry is only accepted if it:

  • Is not yet in the list
  • Is not identical to the domain of the user who is currently connected
  • Is not identical to the Analyzer Server computer name

Capitalization of letters is not taken into account during the check.

List of domains

Contains the domains that have been individually added. Multiple selection is possible.

Delete

Deletes all highlighted domains from the list of domains.

OK

Accepts and validates the configuration, closes the dialog and starts the search.

Cancel

Discards the configuration and closes the dialog.

Note: The selected setting is saved in the ZAMS configuration and selected as a presetting the next time the dialog is displayed. The selected setting applies for the complete ZAMS session.

Delete the cache of the user search

To change the type of search, either ZAMS must be restarted or the cache must be deleted.

To delete the cache of the user search:

  1. Open the menu Tools
  2. Select the Delete cache command
  3. Cached users and groups are removed from the cache.
  4. The next time a dialog to call up user administration is called up, the dialog to configure the user search is called up again


Selection of users and user groups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Selection of users and user groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Users and user groups are added differently depending on the configuration of the search:

  • Direct query: The Search for users and user groups dialog is opened. If a user is found, they are added. If a group is found, all members of this group are added.
  • Users and groups cached: The Select users and user groups dialog is opened. Cached users and groups are offered for selection.

When configuring the access rights for the Report Launcher, user groups and users can be selected from groups. For all other dialogs for user rights, users can be selected from groups, but not user groups.

Procedure

The following applies when obtaining user data:

  • If two users have the same visual name, the reading of the user data source that is currently being read is canceled.
  • If two user groups have the same visual name, the reading of the user data source that is currently being read is canceled.
  • If a group has the same visual name as a user, the user group concerned is ignored. However the reading is continued.

Other topics in this chapter

Search for users and user groups dialog

Select user dialog

Dialog for selecting users and user groups


Search for users and user groups dialog

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Selection of users and user groups -> Search for users and user groups dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

If, when configuring the user rights with a direct query, a search for a user or a user group is carried out, the search dialog is opened:

Parameters

Description

Full name of the entry to search for

Entry of the complete name of the object to be searched for. This consists of:

  • Domain
  • Backslash
  • User name

Example: MAIN\J.Doe

Search

Clicking on this starts the search for the search term entered.

Only active if:

  • The input field is not empty
  • The content has been changed since the last user

If the user is not found in the domain, there is a query to see if all user names of the domain are to be searched for.

Search result

Displays the search result.

OK

Accepts the user who has been found or all who have been found to the dialog.

Only available if the input field for the complete name has not been changed since the last successful search.

Cancel

Closes the dialog without accepting any users.


Select user dialog

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Selection of users and user groups -> Select user dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

If new user users are added in a configuration dialog for user rights, the following dialog is called up. (Exception: When configuring the access rights for the Report Launcher, the Select users and user groups dialog is called up.)

Parameters

Description

Username filter condition

Input of filter conditions for user names.

The list of the users displayed is updated each time a change is made in the input field. Only users who meet the filter criteria in the text with one of their name properties are displayed. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected users are not hidden.

User group filter condition

Input of filter conditions for user groups.

The list of the users displayed is updated each time a change is made in the input field. Only users that belong to one of the user groups that meet the condition are shown. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected users are not hidden.

Checkboxes

Active: User is selected for adding.

User list

Display of the users available for selection. This list is compiled according to the settings in the configuration of user search.

It contains:

  • Username: Display of the user name.
  • Member of groups: Display of the user groups that a user belongs to.
  • Description: Displays information on the user name and its origin.

Select all

Clicking on the button selects all displayed users according to the filter conditions.

Deselect all

Clicking on the button deselects the selection.

OK

Accepts selection, closes the dialog and adds selected users.

Cancel

Discards all changes and closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.


Dialog for selecting users and user groups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Selection of users and user groups -> Dialog for selecting users and user groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

If new users or user groups are added in the configuration dialog for the access rights for the Report Launcher, a selection dialog is called up. It is possible to add using two tabs:

  • Users
  • Groups

Users

Selection of users who are to be added.

Parameters

Description

Username filter condition

Input of filter conditions for user names.

The list of the users displayed is updated each time a change is made in the input field. Only users who meet the filter criteria in the text with one of their name properties are displayed. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected users are not hidden.

User group filter condition

Input of filter conditions for user groups.

The list of the users displayed is updated each time a change is made in the input field. Only users that belong to one of the user groups that meet the condition are shown. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected users are not hidden.

Checkboxes

Active: User is selected for adding.

User list

Display of the users available for selection. This list is compiled according to the settings in the configuration of user search.

It contains:

  • Username: Display of the user name.
  • Member of groups: Display of the user groups that a user belongs to.
  • Description: Displays information on the user name and its origin.

Select all

Clicking on the button selects all displayed users according to the filter conditions.

Deselect all

Clicking on the button deselects the selection.

OK

Accepts selection, closes the dialog and adds selected users.

Cancel

Discards all changes and closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Groups

Selection of user groups that are to be added.

Parameters

Description

Filter condition

Input of filter conditions for user groups.

The list of the user groups displayed is updated each time a change is made in the input field. Only the respective user groups that meet the condition are still shown. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected user groups are not hidden.

Checkboxes

Active: User group is selected for adding.

List of user groups

Display of the user groups available for selection. This list is compiled according to the settings in the configuration of user search.

It contains:

  • Group name: Display of the user groups that a user belongs to.
  • Description: Displays information on the user name and its origin.

Select all

Clicking on the button selects all displayed user groups according to the filter conditions.

Deselect all

Clicking on the button deselects the selection.

OK

Accepts selection, closes the dialog and adds selected user groups.

Cancel

Discards all changes and closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.


Users with dedicated license

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Users with dedicated license

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Users can have dedicated licenses in ZAMS. A license is always kept free for these. A user with a dedicated license thus also has a client license on the license server if they are not connected. The maximum number of users who can be created with a fixed license is the amount of client licenses present. When entering a new zenon Analyzer license, it is only accepted if you have enough client licenses for all users with a dedicated license.

Manage dedicated licenses to users

To assign or remove a user's dedicated license:

  1. Open the Analyzer Server menu item
  2. Select Assign users a dedicated license
  3. The dialog to administer the users with a fixed license is opened

Parameters

Description

Username filter conditions

Input of filter conditions for user names.

The list of the users displayed is updated each time a change is made in the input field. Only users who meet the filter criteria in the text with one of their name properties are displayed. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected users are not hidden.

User group filter conditions

Input of filter conditions for user groups.

The list of the users displayed is updated each time a change is made in the input field. Only users that belong to one of the user groups that meet the condition are shown. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected users are not hidden.

User List

Displays all configured users with a dedicated license. Belonging to a user group is also shown.

Multiple selection is possible:

  • Ctrl key + mouse click: selects an additional user with each click
  • Ctrl key + mouse click: selects all users who are between two clicks, from
  • Clicking on the Select all button selects all users in the list

Select all

Selects all users who are displayed in the List of users.

Deselect all

Deselects the users who are displayed in the List of users.

Add

Opens, depending on the configuration of the user search, a dialog to select users:

  • Direct query:
    The Search for users and user groups dialog is opened. If a user is found, they are added. If a group is found, all members of this group are added.
  • Users and groups cached:
    The Select users and user groups dialog is opened. Cached users and groups are offered for selection.

Users can only be added if there are sufficient licenses available. In the dialog to add users, all users who already have a corresponding license are filtered out. The dialog is only opened if at least one further user can be added. Note the corresponding message in the output window.

Remove

Deletes selected users from the list without requesting confirmation.

The successful removal of a user is documented in the output window, as is unsuccessful removal.

Close

Closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.


Basic principles of user access rights

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Basic principles of user access rights

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

There are four user authorization levels internally. Each level includes access to the permitted applications of the lower levels, however it defines its own data access rights. In the dialogs, the applications that are linked to the authorization levels are named instead of the authorization levels. As a result of the fact that access rights on the Report Launcher are handled separately from the access rights to the Analyzer tools - and thus to the database - it is also possible that, for example, a user can enter prices and norm values, but does not have access to the objects on the Analyzer server.

The four authorization levels:

  • 0: Users can only have a license for the Report Launcher.
    This authorization level is automatically issued to each user.

    Users with this authorization level have no database access.

  • 1: User can, in addition to the authorization level 0 applications, also use the Editor tool for price and norm values.

    These users each receive a login at user level in the SQL server instance. In each Analyzer metadata database on the SQL server instance, these users are each a user with read rights for all tables and write rights for the tables PRICE and NORM.

  • 2: Users can also use, in addition to authorization level 1 applications, the Metadata Editor and the Analyzer Export Wizard.

    The Wizard does not have a license for the user running it, but it must however have the corresponding database access rights that are usually granted with this authorization level. These users each receive a login at user level in the SQL server instance. In each Analyzer metadata database on the SQL server instance, these users are each a user with read rights for all tables and write rights for all tables.

  • 3: Users can also use ZAMS in addition to authorization level 2 applications.

    These users each receive a login at administration level in the SQL server instance. With the administrator login, these users are automatically given administrator access rights to all databases in the SQL server instance by the SQL server, including to non-Analyzer metadata databases. These users are therefore administrators on the SQL server instance, because they must create new databases, create, change and delete stored procedures and user-defined functions, administer indices, back up and restore databases, enter internal code into databases and administer user rights.


Access rights to Analyzer applications

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Access rights to Analyzer applications

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Analyzer applications include:

  • Manual Data Editor
  • Metadata Editor
  • ZAMS

The access rights to these applications are managed for all users in a dialog. In doing so, the appropriate access rights to all Analyzer metadata databases on the currently-active SQL server instance are regulated.

info Information

Access right, in the context of Analyzer applications, means that a user can connect to the Analyzer server with the application.

This means: A user can be a user with authorization level 3 on Analyzer Server A and at the same time be a user with authorization level 1 on Analyzer server B.

Other topics in this chapter

Configuration of the access rights

Warning details for different user access rights


Configuration of the access rights

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Access rights to Analyzer applications -> Configuration of the access rights

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To configure the access rights to the Analyzer applications:

  1. Open the Analyzer Server menu item
  2. Select the Manage access rights for Analyzer applications command
  3. The dialog for configuring access rights is opened

Parameters

Description

Username filter condition

Input of filter conditions for user names.

The list of the users displayed is updated each time a change is made in the input field. Only users who meet the filter criteria in the text with one of their name properties are displayed. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected users are not hidden.

Filter condition

Input of filter conditions for user groups.

The list of the users displayed is updated each time a change is made in the input field. Only users that belong to one of the user groups that meet the condition are shown. Filtering is carried out:

  • partially: it is sufficient if the character sequence appears in the name
  • Without taking capitalization into account

Already-selected users are not hidden.

User List

Display of all configured users.

The following is displayed for each user:

  • The user groups they belong to.
  • Authorizations for Analyzer applications. For details, see also the Basics of user access rights section. Authorizations can be changed by selecting the option fields in the Applications that can be used by the currently-highlighted users area.

Users with authorization levels 0 (Report Launcher) are not displayed, because the license server grants this to all level 0 users anyway.

Note: The user currently connected is shown with a gray background. Their rights cannot be changed. This prevents all users of the SQL server being locked out due to incorrect configuration.

Select all

Clicking on the button selects all displayed users according to the filter conditions.

Deselect all

Clicking on the button deselects the selection.

Add

Opens, depending on the configuration of the user search, a dialog to select users:

  • Direct query:
    The Search for users and user groups dialog is opened. If a user is found, they are added. If a group is found, all members of this group are added.
  • Users and groups cached:
    The Select users and user groups dialog is opened. Cached users and groups are offered for selection.

Users who have already been added are filtered out in the dialog. The dialog is only opened if at least one user can be added.

Remove

Deletes the selected users from the list without requesting confirmation.

The removal of a user is the same as setting the user to authorization level 0 (Report Launcher) because the license server grants level 0 to all users and the database access rights of the user can be deleted in both cases.

Tools that can be started by the selected user(s)

Selection of the authorization levels for the users selected in the list. The levels are arranged in a hierarchy. Level 1 elements are also included in level 2. Level 0 (Report Launcher) is given to all users. Rights for the Report Launcher are administered using the Report Launcher access rights.

Authorization levels:

  • Manual Data Editor: Level 1.
    Users can use the editor tool for price and norm values.
  • Metadata Editor: Level 2.
    Users can also use the Metadata Editor and the Analyzer Export Wizard.
  • zenon Analyzer Management Studio. Level 3. Users can also use ZAMS.

If several users are highlighted in the table, the authorization levels of the last-selected user are displayed. If no user is selected or the user who is currently connected is selected, the authorization level cannot be set.

For details on the access levels, see also the Basics of user access rights section.

Attention: If several users are highlighted, the amended configuration is set for all highlighted users in the event of a configuration change, regardless of whether it currently has different configurations.

Warnings

Only visible if errors are present. Consists of: Warning symbol, text with warning notice and button to display the details.

Condition for display of warnings:

  • The currently-connected user was selected for a configuration change.
    A warning notice is displayed. The button is not visible.
  • Two or more of the selected users have different configurations. The warning notice is displayed. Clicking on the Details button opens a window with details on the warning.

Attention: The display of a warning means that changes to the configuration and the confirmation of these also makes changes for objects with an original configuration that is different to the configuration displayed here. The original configuration for these objects is then lost.

OK

Applies configuration and closes the dialog.

Cancel

Discards all changes and closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.


Warning details for different user access rights

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Access rights to Analyzer applications -> Warning details for different user access rights

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

If users with different settings are selected for joint configuration, a warning notice is shown in the dialog to configure the access rights. The details are shown in a separate window. No inputs can be made in this dialog:

Parameters

Description

User List

Display of all configured users.

The first column shows the type of warning:

  • Gray circle: Basis for comparison. The configuration is selected on the basis of the last selected user.
  • Yellow triangle: Differs from the comparison basis.
  • Green check mark: Corresponds to comparison basis.

The other columns contain the user names and the display of the respective authorization levels.

Close

Closes the window.

The size and position of the dialog can be changed. These settings are saved as user-dependent.


Report Launcher access rights

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Report Launcher access rights

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

With the access rights for the Report Launcher user, a distinction is made between two types of rights:

  1. User profile

    These define whether a user can access objects on the Report Launcher and the underlying SQL server reporting services and whether they can change the configuration of the Report Launcher and the underlying SQL server reporting services. A distinction is made between users (object access only) and administrators (object access and configuration changes).

  2. Access rights to objects

    These define which user can access which objects and with which rights.

    Attention: The object access rights are only then applicable if the accessing user has system access rights as a user or administrator.

To configure the access rights:

  1. Open the Analyzer Server menu item
  2. Select the Manage Report Launcher access rights command
  3. The dialog to configure the access rights is opened; this has two tabs to be configured
    • Assign user profile
    • Define access rights

Other topics in this chapter

Assign user profile

Assign access rights

Warning details for different authorization levels


Assign user profile

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Report Launcher access rights -> Assign user profile

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Parameters

Description

List of Report Launcher users

Contains the currently-defined users of the SQL server reporting services on the Analyzer server.

Users can be added or removed using the Add and Remove button. The >> and << buttons are used to drag users to the list Report Launcher administrators or to add them from there.

Multiple selection is possible.

The rights of the currently logged-on user cannot be changed.

Add

Adding a user as an Report Launcher user.

Opens, depending on the configuration of the user search, a dialog to select users:

  • Direct query:
    The Search for users and user groups dialog is opened. If a user is found, they are added. If a group is found, the group is added.
  • Users and groups cached:
    The Select users and user groups dialog is opened. Cached users and groups are offered for selection.

Users who are already entered as Report Launcher administrators cannot be added using this dialog. These can be dragged using the << button.

Users who have already been added are filtered out in the dialog. The dialog is only opened if at least one user can be added.

Remove

Deletes the selected users from the list without requesting confirmation.

List of Report Launcher administrators

Contains the currently-defined administrators of the SQL server reporting services on the Analyzer server.

Users can be added or removed using the Add and Remove button. The >> and << buttons are used to drag users to the list Report Launcher administrators or to add them from there.

Multiple selection is possible.

Add

Adding a user as an Report Launcher user.

Opens, depending on the configuration of the user search, a dialog to select users:

  • Direct query:
    The Search for users and user groups dialog is opened. If a user is found, they are added. If a group is found, the group is added.
  • Users and groups cached:
    The Select users and user groups dialog is opened. Cached users and groups are offered for selection.

Users who are already entered as Report Launcher user cannot be added using this dialog. These can be dragged using the >> button.

Users who have already been added are filtered out in the dialog. The dialog is only opened if at least one user can be added.

Remove

Deletes the selected users from the list without requesting confirmation.

Button >>

Moves all highlighted users to the group of administrators.

Button <<

Moves all highlighted users to the group of users.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.


Assign access rights

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Report Launcher access rights -> Assign access rights

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Parameters

Description

Object list

Display of all objects in the Report Launcher in an expandable tree structure. Each object is assigned an icon in the tree structure, which reflects its data type. The following data types are displayed:

  • Folder
  • Data source
  • Report or linked report
  • Different type

There is also a symbol for each object, which shows that the object inherits its configuration.

Editing:

If an object is marked, it is unlocked for editing in the right part of the dialog.

Several projects can also be edited at the same time. To do this, they are selected by activating the check box in front of them. If several objects are selected for editing, the configuration of the object with the first path in alphabetical order (the furthest up in the tree) is displayed.

If objects with different configurations are selected together, a warning is shown.

Expand all

Clicking on this expands all nodes.

Collapse all

Clicking on this collapses all nodes. Only the root folder is displayed.

Select all

Activates the checkboxes of all visible elements.

Deselect all

Deactivates the checkboxes of all elements.

Separator

Left area (tree with objects) and right area (configuration) are divided by a separator. To change the ratio between the two, drag the separator with the mouse into the desired direction.

Define user access configuration for this item

Active: The rights of the user are defined for the selected objects with the following configuration elements.

The properties for the Home object, the uppermost object, must always be defined.

Inherit user access configuration from parent item

Active: The selected elements inherit their properties from the superordinate object.

If the configuration is inherited, the user rights can be displayed, but not changed.

Attention: If an Inherit access rights from superordinate object object is set, the configuration set before this is lost. The loss of the configuration can be prevented by closing the dialog. However all the changes that have been made before that are also lost.

Configured users and their access rights

List of all users assigned to the selected objects and their access rights. Each user is displayed in their own line. Several users can be selected at the same time.

The following are displayed:

  • User names
  • Roles assigned to the user; several roles are displayed separately by means of a comma

Scroll

The roles of the users are stipulated using the checkboxes below the list. Each user can have several roles at the same time.

If several users are highlighted in the table, the configuration of the last-selected user is displayed. Each change then has an effect on all highlighted users.

If a user does not have a role for an object, they are considered deleted when setting the configuration for this object. There are the following roles:

  • Browser
  • Content manager
  • My reports
  • Publisher
  • Report Builder

Only available if Define access rights for this object has been activated.

Add

Opens the dialog for adding users.

Only available if Define access rights for this object has been activated.Only users or user groups that have been configured in the Assign user profile tab can be selected. Users who have already been added are filtered out in the dialog. The dialog is only opened if at least one user can be added.

Remove

Deletes all selected users from the list.

Only available if Define access rights for this object has been activated.

Browser

Active: The role is assigned to selected users.

The user can see the folder and reports and subscribe to reports.

Content manager

Active: The role is assigned to selected users.

The user can manage content on the report server. This includes folder, reports and sources.

My reports

Active: The role is assigned to selected users.

The user can:

  • Publish reports and linked reports
  • Manage folders, reports and sources in a user's My reports folder

Publisher

Active: The role is assigned to selected users.

The user can publish reports and linked reports on the report server.

Report Builder

Active: The role is assigned to selected users.

The user can see report definitions and start the Report Builder.

Warnings

Only visible if errors are present. Consists of: Warning symbol, text with warning notice and button to display the details.

Condition for display of warnings:

  • Two or more objects are highlighted in the tree structure, the configurations of which are different The warning notice is displayed. Clicking on the Details button opens a window with details on the warning.
  • All objects highlighted in the tree structure have the same configuration, but two or more highlighted users have different configurations. The warning notice is displayed. Clicking on the Details button opens a window with details on the warning.

Attention: The display of a warning means that changes to the configuration and the confirmation of these also makes changes for objects with an original configuration that is different to the configuration displayed here. The original configuration for these objects is then lost.

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

attention Attention

In this tab, the rights of the user currently connected are not protected from changes. Erroneous configuration when assigning roles can thus lead to no users having sufficient administration rights on the report server.


Warning details for different authorization levels

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> User administration and access rights -> Report Launcher access rights -> Warning details for different authorization levels

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

If configurations are selected that are in conflict and could lead to the loss of previously-established configurations, a warning is shown in the configuration dialog. Warnings are shown if:

  • Two or more objects were highlighted in the tree structure, the configurations of which are different
  • Two or more highlighted users have different configurations

There are different access rights to objects on the report server

If several objects that have different settings are selected for configuration at the same time, a warning is displayed in the configuration dialog:

Clicking on the Details button opens a window with details on the warning. No inputs can be made in this dialog:

Parameters

Description

List of objects

Display of all selected objects.

The first column shows the type of warning:

  • Gray circle: Basis for comparison. The configuration of the object with the first path in alphabetical order (the furthest up in the tree) is selected as a basis.
  • Green check mark: Corresponds to comparison basis.
  • Yellow triangle: Differs from the comparison basis.

The second column shows the object path.

One line each can be selected in this list. The configuration details for the selected object are displayed in the lower area.

Separator

Upper area (objects) and lower area (user) are divided by a separator. To change the ratio between the two, drag the separator with the mouse into the desired direction.

Inherit user access configuration from parent item

The symbol shows whether the assignment of the configuration mode:

  • Is a basis for comparison (hash symbol) : Basis for comparison. The configuration of the object with the first path in alphabetical order (the furthest up in the tree) is selected as a basis.
  • Corresponds to comparison basis (blue circle)
  • Differs from comparison basis (yellow triangle)

The checkbox shows the configuration mode:

  • active: Object inherits configuration from superordinate object
  • inactive: Object is configured individually

List of users and their roles

Each row of this table constitutes a user and has one of the three following background colors:

  • White: The user is defined in both the comparison basis and the object currently being looked at.
  • Grey: The user is defined in the object currently being looked at, however they do not appear in the comparison basis.
  • Red: The user is defined in the comparison basis, however does not appear in the object being looked at.

The table consists of the following columns:

  • Symbol for the type of row. The symbols correspond to those in the List of objects area.
  • User names
  • Columns with the possible roles.
    Activated checkbox: The user has this role.

Close

Closes the window.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Roles for users

If users with different settings are selected for joint configuration, a warning notice is shown in the dialog to configure the access rights:

Clicking on the Details button opens a window with details on the warning. No inputs can be made in this dialog:

Parameters

Description

User List

Display of all configured users.

The first column shows the type of warning:

  • Hash: Basis for comparison. The configuration is selected on the basis of the last selected user.
  • Blue circle: Corresponds to comparison basis.
  • Yellow triangle: Differs from the comparison basis.

The other columns contain the user names and the display of the respective roles.
Activated checkbox: The user has this role.

Close

Closes the window.

The size and position of the dialog can be changed. These settings are saved as user-dependent.


Settings

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You can get to the settings for ZAMS via the Options menu item. They are available regardless of whether there is a connection to the Analyzer server and regardless of whether there is a valid license. The options are deactivated if one of the following actions is executed: Open, Deploy, Deploy all, Open in Microsoft Report Builder or Open all in Microsoft Report Builder.

The following are configured in the options:

  • Connection profiles
  • Deployment of reports
  • Messages in the output window
  • Language settings
  • Database backups

Other topics in this chapter

Connection profiles

Deployment

Output messages

Language settings

Database backups

Connecting the report definition files to the database


Connection profiles

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings -> Connection profiles

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, you define the starting behavior of the ZAMS.

Parameters

Description

Connection profiles

Settings for connection profiles.

Maximum number of connection profiles

Number of connection profiles that are saved. If the set number is exceeded by the creation of a new connection profile, then the profile that has not been used the longest is deleted.

Entry in the field or configuration using the cursor keys.

  • Minimum: 1
  • Maximum: 255

Manage connection profiles

Opens the dialog to manage the connection profiles.

Maximum number of files in the history of a connection profile

Number of reports that are displayed in the Report menu in the Most recently edited reports list.

  • Minimum: 1
  • Maximum: 255
    If the permitted maximum is exceeded by a report that is being added, the oldest entry is deleted.

This value applies for all connection profiles. The new maximum is written to the configuration by clicking on OK. All connection profiles are immediately checked for adherence to the maximum. The oldest entries are deleted if necessary.

Action on application start

Defines the action carried out when the ZAMS is started.

Do not show connection dialog

Active: Only the main window is shown.

Show connection dialog with default settings

Active: The dialog for establishing the connection is opened with the values for a new connection profile.

Show connection dialog with the most recently used profile

Active: The dialog for establishing the connection is opened with the values for the most recently used connection profile.

SQL Server statement timeout

Entry of the SQL server statement timeout.

This timeout enters into force if an individual SQL Statement runs for longer than is defined here, for example when backing up or when restoring a large database. With new connections, the currently-set value is used for the Timeout. If this is amended in the options, the existing connections are amended to the new value.

The Timeout can be set to a value between 1 minute and 7 days.

Input elements:

  • Number element:
    Entry of the quantity in the field directly or by means of the cursor keys.
    Possible values for :
    - days: 1 - 7
    - hours: 1 - 168
    - minutes: 1 - 10080
  • Drop-down list for granularity:
    Possible values:
    - minutes
    - hours
    - days
    This selection influences the value range of the number element.

Default: 4 hours

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Manage connection profiles


Manage connection profiles

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings -> Connection profiles -> Manage connection profiles

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Connection profiles are administered in their own dialog. Profiles can be deleted and the authentication method can be changed. The structure and the configuration are identical for:

  • ZAMS
  • Metadata Editor
  • Manual Data Editor

However only the profiles of the respective tools can be administered.
Connection profiles for the migration tool are administered in their own dialog.

attention Attention

Changes in this dialog are only executed if the superordinate dialog from which the administration of the profile was opened has also been confirmed, by clicking on OK.

Parameters

Description

List of connection profiles

The table displays all editable connection profiles.

Note: Metadata Editor and Manual Data Editor cannot edit the ZAMS connection profiles.

The following columns are shown:

  • Connection profile: Profile name
  • Server computername: Computer name of the SQL Servers
  • Database: linked database
  • Secured connection: Display by means of checkbox of whether communication is in secure form
  • Authentication: Type of authentication

Multiple selection is possible.

Select all

Highlights all entries

Deselect all

Deselects the highlighting of entries.

Edit

Opens the dialog for configuring a wake up call.

Delete

Deletes the highlighted connection profiles without requesting confirmation. Only available if at least one profile has been selected.

Close

Closes the dialog. The saving or rejection of changes is undertaken by the superordinate option dialog (see also the three option dialogs above).

Other topics in this chapter

Edit


Edit

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings -> Connection profiles -> Manage connection profiles -> Edit

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of authentication and activation or deactivation of the connection security for existing profiles.

Parameters

Description

Credentials

Configuration of authentication.

Use Windows authentication
  • Active: Windows authentication is used.

If several profiles have been selected, then:

  • The setting of the first selected profile is displayed
  • Changes are applied to all selected profiles

User name

Entry of the user name with authentication by means of user name and password.

Only active if at least one profile has been highlighted and the first highlighted profile uses authentication with user name and password. When selecting several profiles, the user name of the first of the selected profiles is automatically set.

Connection security

Settings for the connection security. The entries must correspond to the configuration on the server.

Secured connection

Activation or deactivation of the encrypted communication.

  • Active: Communication is encrypted. For each connection, depending on the degree of encryption, passwords must be entered for the license service.
  • Inactive: Communication is not encrypted.

License Server connection password

Entry of the password for the connection to the license server.
Input is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Only active if the Secured communication and Save passwords options have been activated.

License Server modification password

Entry of the change password on the license server.
Entry is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Only active if the Secured communication and Save passwords options have been activated.

Save passwords

Stipulation of whether the connection parameters are saved in the connection profile.
Saving is carried out as a hardware-dependent and user-dependent hash of the password.

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Deployment

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings -> Deployment

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, you define which actions happen automatically when a report is prepared or saved.

Three methods are available for all actions:

  • Yes: carries out action automatically
  • No: does not carry action out
  • Prompt: open dialog with prompt for the user to decide

Parameters | Description
Save report definitions before deployment | Decision on whether reports are saved on the hard drive before being deployed. Default: Prompt
Overwrite report defintions | Decision on whether reports are to be overwritten on the hard drive when saving. Default: Prompt
Overwrite reports on Analyzer server | Decision on whether reports on the Analyzer server are to be overwritten. Default: Prompt
Overwrite stored procedures and user-defined functions | Decision on whether SPs and UDFs are to be written to the database. Default: Prompt
Open reports in the Microsoft Report Builder after deployment | Decision on whether reports can be opened in Microsoft Report Builder after they have been deployed. Default: No
Storage path for report definition files | Folder in which reports are saved. Click on the ... button to open the browser to select a folder. Report files have the file name suffix.zams_rep. The path is saved for each user. Default: C:\Users\Public\Documents\Analyzer_Reports
Inherit parent access rights on new items | Active: Newly-created objects have the same access rights as the object that is superordinate to them.
Set access rights only for the currently connected user on new items | Active: Only the user connected at the time of creation of the new objects has access to these new objects. To do this, they are assigned the role of Content Manager.
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Output messages

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings -> Output messages

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, you define the display of messages in the output window.

Parameters | Description
Show errors in output window | Active: Errors are displayed in the output window.
Show warnings in output window | Active: Warnings are displayed in the output window.
Show messages in output window | Active: Messages are displayed in the output window.
Clear the output window whenever a deploy is started | Active: The output window is cleared as soon as a function to deploy a report is executed.
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Language settings

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings -> Language settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The language of the ZAMS user interface and the language for reports can be pre-defined in ZAMS, regardless of the language of the operating system.

ZAMS language when ZAMS is started

The language of the operating system is detected and set when ZAMS is started. If another language has been defined for the ZAMS user interface in the options, this is used. If it is not possible to switch to a pre-defined language, the language of the operating system remains active.

The switching of the ZAMS user interface language affects all areas of ZAMS, including report templates and data files.

Configuring the language

To configure the language settings:

  1. Navigate to the Options menu
  2. Select the command Options.
  3. open tab Language settings

Parameters

Description

Language for the zenon Analyzer Management Studio

Selection of the language for the ZAMS user interface from a drop-down list. The languages available are displayed in the writing convention of the respective language.

The language is immediately switched after the change is set and OK is clicked on.

Language settings for reports

Configuration of the languages for the preparation of reports.

Deployment in the language of the zenon Analyzer Management Studio

Active: Reports are always created in the language that was selected in the Language for the zenon Analyzer Management Studio option.

Inactive: Reports are prepared in languages for which the checkboxes have been activated in the Deploy reports in the following languages.

Default: active

Deploy reports in the following languages

The languages of reports can be defined individually. To select a language, the checkbox in front of the language must be activated.

Position of language code

Setting for the procedures of how reports are stored according to the assigned language and displayed in the All report deployment paths of the report configuration.
The following options are available:

  • First folder in the report path on the Analyzer Server
  • Last folder in the report path on the Analyzer Server
  • Prefix in the report name on the Analyzer Server
  • Suffix in the report name on the Analyzer Server

(for further information, see the following options.)
  • First folder in the report path on the Analyzer Server

Active: An independent folder system is created for each language. To do this, in the path for the report, a folder with the respective language designation is created, and below this there are the folders for the themes. The reports are stored in the folders assigned to them.

For example: /DE/Alarm analysis/Alarm list

/EN/Alarm analysis/Alarm list

  • Last folder in the report path on the Analyzer Server

Active: All languages have a common folder structure for the theme. To do this, a folder with the respective language designation is created for the report below the folder of the theme. The reports are stored in the folders assigned to them.

For example: /Alarm analysis/DE/Alarm list

/Alarm analysis/EN/Alarm list

  • Prefix in the report name on the Analyzer Server

Active: Language designators are placed before the report names. To do this, reports are stored in the respective folder for the theme. Each report contains a prefix with the language designation and an underscore..

For example: /Alarm analysis/DE_Alarm list

/Alarm analysis/EN_Alarm list

  • Suffix in the report name on the Analyzer Server

Active: Language designators are added to the report names. To do this, reports are stored for the respective theme in the folder. Each report contains a suffix with an underscore and the language designation.

For example: /Alarm analysis/Alarm list_DE

/Alarm analysis/Alarm list_DE

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.


Database backups

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings -> Database backups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The path for the database backup and the number of the backup files to be created is configured in this tab.

Parameters

Description

Backup file folders

Lists all configured database backup paths:

  • Name of the SQL server instance:
    Instance that is to be backed up.
  • Database backup path:
    Folder in which the backup is to be created

Precisely one row can be highlighted in the table. The highlighted row can be edited or deleted.

Note: At this point it should be added that the database backup always only works for the currently-connected SQL server instance. Editing in the dialog only works without an existing connection.

Edit

Opens the dialog for editing the backup path.

Delete

Deletes the selected entry.

Backup files

Configuration of the options for the backup files.

Compress database backup files

Setting of whether backup files are compressed.

  • Active: Backup files are compressed.

Setting has an effect on all:

  • from the changing of the option of manually-created backups
  • Newly-created or amended automated backups
  • New implicit database backups during database conversion

Existing database backup jobs are not changed. These must be explicitly amended using the appropriate menu item.

Database backup jobs are recognized and compressed or uncompressed and displayed accordingly. This detection and display depends on the status of this option.

Limit the number of backup files for each database

  • Active: The number of backup files created is limited. The limit is defined in the Number of backup files per database option.
    As soon as the maximum has been reached, the oldest backup file is deleted each time a new backup file is created.
  • Inactive: Unlimited backup files are created.
    Attention: Note the amount of memory available. If the limit of the storage medium is exceeded, no more backup files are created.

Maximum number of backup files per database

Setting for the maximum number of backup files to be created.

  • Minimum: 1
  • Maximum: 100
  • Default: 1

OK

Applies all changes in all tabs and closes the dialog.

Cancel

Discards all changes in all tabs and closes the dialog.

Storage path for database backup files:

The first time a backup request is made and a path has not yet been established, you are requested to define a save path. This path is then used for all backups and restorations. This path is administered in the options in the Database backups tab of the Settings.

Note: It is recommended that a path on the Analyzer computer is used for backup.

Parameters

Description

Network share path for storing database backup files of [database]

A valid UNC path must be entered.

Clicking on the ... button opens the dialog to select a network share.

A check is made if:

  • The syntax of the path is valid if:
    Only valid paths unlock the OK button.
  • The path exists:
    When clicking on OK, the path is only accepted if it can also be accessed.
  • The path is different to that already used:
    If a path is defined that is different to a path that has already been used, a corresponding message is given. The path can be created. The pre-existing database backup job can then be activated, deactivated and deleted, but can no longer be edited.

The configured path is saved individually for each user.

Attention: The access rights to network shares must be set correctly. For details, see the Set access rights to network share correctly.

OK

Accepts the path and closes the dialog.

Cancel

Discards changes and closes the dialog.

Set access rights to network share correctly

In order for all database backup action to run correctly, the access rights to the network share must correspond to the database backup folder. For this, the following applies:

  • The folder must be on the Analyzer Server, because defined users must access it locally on the Analyzer Server.
  • Because the folder must be accessible by both the Analyzer Server and the ZAMS computer with the same path, it must be authorized in the network. The folder is then accessible with the same path via a UNC path everywhere in the network.
  • The following users must have full access to the network share:
    • NT SERVICE\MSSQL$ZA3: For the creation and restoration of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • NT SERVICE\SQLAgent$ZA3: For automatic creation of backups.
      Defined Locally on the Analyzer server. Virtual user, derived from the SYSTEM, in whose context the SQL server instance is running.
    • Every ZAMS user: To create and restore backups, administer backup files and administer automated backup jobs.

Backup file name

The file name of a database backup file follows this scheme: [database name]_yyyy_MM_dd_HH_mm_ss.bak

e.g.: ZA_DATA_2013_02_12_14_11_35.bak = backup of ZA_DATA on 12.2.2013 at 14:11:35


Connecting the report definition files to the database

zenon Analyzer -> ZAMS - zenon Analyzer Management Studio -> Settings -> Connecting the report definition files to the database

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The report definition files (zams_rep) are connected to their database. The connection is made when saving and checked on opening.

When loading a report from a zams_rep file, the necessary connection information is read and interpreted:

  • If the SQL server instance name is not available, the error message W00128 (see Messages in the output window section) is given. The SQL server instance name of the current SQL server connection is then entered, so that the connection information indicates the current connection the next time it is saved.
  • If the SQL server instance name in the connection information is different to the SQL server instance names of the current SQL server connection, the error message W00129 is given. The SQL server instance name of the current SQL server connection is then entered, so that the connection information indicates the current connection the next time it is saved.
  • If the database name is not available, the error message W00130 is given. The database name of the current SQL server connection is then entered, so that the connection information indicates the current connection the next time it is saved.
  • If the database name in the connection information is different to that of the current SQL server connection, the error message W00131 is given. The database name of the current SQL server connection is then entered, so that the connection information indicates the current connection the next time it is saved.

Examples

Example 1

A zams_rep file saved with ZAMS 2.00 is then loaded. Because the file does not have any SQL server information, the error message W00128 (see list of error messages) is given. The database information is extracted and interpreted from an RTP parameter. If the database is different, the message W00131 is given.

Example 2

A database with the same name is read into a different SQL server instance. When the zams_rep file is opened, W00129 is given, because that of the new Analyzer server has a different name. The database is however identical.

Messages in the output window

Errors in the connection of the zams_rep file to its database are displayed by messages in the output window.

SQL server instance information comprises the address of the server and the instance together, for example CDSBG036\ZA3.

Message in the output window | ID | Description
The storage file does not contain any information about the Analyzer SQL Server instance it was created for. The report might have been created for a different Analyzer SQL Server instance which can cause a corrupted report. | W00128 | No SQL server instance information is present in the zams_rep file. It may possibly have been created for a different SQL server instance.
The report in the storage file was created for the Analyzer SQL Server instance ‚[Original SQL Server Instance Name]‘ but now it is loaded for the Analyzer SQL Server instance ‚[Neuer SQL Server Instanz Name]‘. This can cause a corrupted report. | W00129 | The zams_rep file was created for a different SQL server instance.
The storage file does not contain any information about the Analyzer metadata database it was created for. The report might have been created for a different Analyzer metadata database which can cause a corrupted report. | W00130 | No database information present in the zams_rep file. It may possibly have been created for a different SQL server instance.
The report in the storage file was created for the Analyzer metadata database ‚[Original Database Name]‘ but now it is loaded for the Analyzer metadata database ‚[Neuer Datenbank Name]‘. This can cause a corrupted report. | W00131 | The zams_rep file was created for a different SQL server instance.

Notes on dealing with warnings

  • Warnings W00128 and W00129: Less critical. The name of the SQL server instance has changed in each case.

    Recommendation: Check the report configuration if these warnings appear. This is because there is the possibility that there are databases on two different SQL server instances with different content that have the same name, such as standard database ZA_DATA.

  • Warnings W00130 and W00131: Must be checked.
    They can only be ignored if it is certain that the new database is a perfect clone of the old database.

    The cloning of Analyzer metadata databases (same content, new name) is only without risk if neither the SQL connector has been created nor are there stored procedures in the initial database.
    Background information: In the stored procedures, the database name is sent to the connector stub, so that this knows where the metadata can be found. The SQL connector checks these database names, because it is only aware of the metadata of the current database.


Metadata database editors

zenon Analyzer -> Metadata database editors

There are editors available to edit metadata in zenon Analyzer:

  • Manual Data Editor: Used for the editing of the tables for price and standard values in a zenon Analyzer metadata database.
  • Metadata Editor: Allows the editing of die labels and descriptions of various objects.

The applications can be can be started from ZAMS, from the Start menu and from Windows Explorer as independent programs.

Other topics in this chapter

Metadata Editor

Manual Data Editor


Metadata Editor

zenon Analyzer -> Metadata database editors -> Metadata Editor

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Metadata Editor makes it possible to:

  • Enter equipment information
  • Amend visual names and descriptions for equipment, event classes, event groups, users, projects, variables and archives
  • To create and edit efficiency class models

The Metadata Editor is typically used between the export of metadata with the Analyzer Export Wizard and the start of report creation with ZAMS.

The Metadata Editor is an independent process. It is available as an EXE file and allows database editing. This can be started directly from ZAMS, from the start menu item or directly via the file.

info Information

If visual names of objects are changed, it may be necessary to re-deploy or re-configure reports from ZAMS. It is generally sufficient to open the editing dialog once and to close it again.

Requirements

To be able to use the Metadata Editor with a database, the following requirements must be met:

  • The database must be a version 2.0 or higher Analyzer database with a valid structure.
  • The user must have the rights to edit the metadata.
    These rights can be configured in ZAMS.

ZAMS

To open the Metadata Editor in ZAMS:

  1. Navigate to the Options menu item in ZAMS.
  2. Select the Metadata Editor entry

    The Metadata Editor is started. The dialog toi establish a connection is opened at the same time.

Start as stand-alone application:

  • In the Windows Start menu, select the COPA-DATA -> Metadata Editor. entry.
    The Metadata Editor is started.

Keyboard shortcuts

The following key combinations are available to operate the Editor:

Key combination | Description
F1 | Opens help
Ctrl+Shift+C | Opens the dialog for creating a database backup.
Ctrl+S | Saves changes.
Alt+F4 | Closes the CD_PRODUCTNAME Editor
Ctrl+Z | Undo input
Ctrl+Y | Repeat input.

Other topics in this chapter

Establish connection

Main window

Actions

Settings


Establish connection

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Establish connection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Metadata Data Editor administers its own connection profile. The ZAMS connection profiles are also read on startup. If there are profiles in the Metadata Editor and in ZAMS with the same name, this dominates the connection profile of the Manual Data Editor.

To link the Manual Data Editor to a database:

  1. Start the Metadata Editor as a Stand alone Tool from the start menu or using the EXE file from the options in ZAMS.
    If the Metadata Editor has already been opened, select the Establish connection command in the File menu.

    The dialog to connect to a server is opened.

  2. Select the desired connection by clicking on Connection profile or create a new connection in a similar manner to that of ZAMS.

    Note: In this connection dialog, no change password is required for secure communication.

  3. Click OK.
    1. The connection is created.
    2. The user authorization is queried by the license server
    3. The database is checked to see that it is correct.
      Note: No connection is established if there are incorrect structures or versions. Conversion is only possible with ZAMS.
    4. Data is loaded
    5. The license is obtained.
    6. The loaded files are displayed in the Manual Data Editor.

Note: Unsaved changes are lost without warning when the connection is established.


Main window

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Main window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Range

Description

Menu bar

Menus to edit and save the objects.

Toolbar

Symbols to edit and save the objects.

Object type window

Selection of the object type to be edited. The following are available:

  • Equipment modeling:
    Clicking this shows the configured equipment models in the object selection window.
  • Event classes:
    Clicking this shows event classes in a filtered list with a project reference in the Object selection window.
  • Event groups:
    Clicking this shows event groups in a filtered list without reference to a project in the object selection window.
  • User:
    Clicking this shows users in a filtered list without reference to a project in the object selection window.
  • Projects:
    Clicking this shows projects in a filtered list without reference to a project in the object selection window.
  • Variables:
    Clicking this shows variables in a filtered list without reference to a project in the object selection window.
  • Archives:
    Clicking this shows archives in a filtered list without reference to a project in the object selection window.
  • Efficiency class models:
    Clicking shows configured efficiency class models in the Window object selection. These are created and edited in the editing area.
  • Reference curves:
    Selection of reference curves.

Object selection window

Selection of the objects according to the type of list by marking of checkboxes and marking the respective line.

Editing area

Entry and acceptance of changes.

Status bar

Display of status information on connection and actions.

Other topics in this chapter

Menu, toolbar and status line


Menu, toolbar and status line

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Main window -> Menu, toolbar and status line

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The menu and toolbar offer a range of commands to administer the Metadata Editor.

Note: The menu is only not available if the Metadata Editor is started from ZAMS as an EXE file, but not the control in zenon Runtime.

Menu

Entry | Description
File | Commands for general operations.
Establish connection | Opens the dialog to create a connection. Note: If the dialog to create a connection is confirmed by clicking on OK, then a new attempt to establish a connection is made. Unsaved changes are then discarded without confirmation being requested.
Save changes | Saves all changes made in the database.
Undo changes | Discards all changes made since the last save after requesting confirmation.
Settings | Opens the dialog to configure the settings.
Exit | Closes the Manual Data Editor.
Edit | Commands for repeating and undoing actions.
Undo | Undoes the last action.
Redo | Restores the last undone action
Help | Link to help and version information.
Info about | Opens a window with information on the current version.
Help | Opens online help.

Toolbar

Symbol | Description
Establish connection | Opens the dialog to create a connection. Note: If the dialog to create a connection is confirmed by clicking on OK, then a new attempt to establish a connection is made. Unsaved changes are then discarded without confirmation being requested.
Save changes | Saves all changes made.
Undo changes | Discards all changes made since the last save after requesting confirmation.
Undo | Clicking on the symbol undoes the last action. Clicking on the arrow of the drop-down list opens a window to select actions that are to be undone. Only the last chronological action or other subsequent actions can be undone as a block.
Redo | Clicking on the symbol restores the last undone action. Clicking on the arrow of the drop-down list opens a window to select actions that have been undone that are to be restored. Only the last chronological action or other subsequent actions can be restored as a block.

Status line

Informs you of the connection and objects.
Separator: |

Element

Description

Symbol

Shows the connection status.

The following are possible as a status:

  • No connection established
  • Connection established but the Analyzer server license is not valid
  • Connection established and the Analyzer server license is valid
  • Secured connection established, the license is valid
  • Secured connection established, the license is invalid

Connection information

Information on the active connection. Display of the server and the database.

Information [Objects], total

Information on the number, selection and status of the selected objects.

Separator: /

Note: If changes are undone, then the counter for the number of changed objects is not decremented but keeps its value.

Action

Information on current action


Actions

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Visual names and descriptions can be amended in the Metadata Editor and equipment information can be entered. Changes can be made to the following object types:

  • Equipment Modeling
  • Event classes
  • Event groups
  • Users
  • Projects
  • Variables
  • Archives
  • Efficiency class models
  • Reference curves

Save changes

Changes are transferred to the database by means of the command or the Save changes symbol and saved there. The transfer of changes is checked and confirmed once this has been carried out (Commit). If a change to a variable is not successful, the transaction is reversed (Rollback).

attention Attention

If an error occurs when completing one of the transactions (Rollback or Commit), the database can become corrupted and thus unusable.

Undo - Restore

Actions in the Manual Data Editor can be undone or restored.

Undo

To undo actions:

  1. Select the Undo command in the toolbar.
  2. Clicking directly on the symbol undoes the last action.
  3. Clicking on the button opens a window with the available actions:

  4. Highlight the desired actions.

    Several interrelated actions from the top (last to be have been carried out) to the bottom.

  5. The status line shows how many actions are being undone.
  6. Clicking on the selected action undoes it.

Restore

To restore actions:

  1. Select the Restore command in the toolbar.
  2. Clicking on the symbol directly restores the last action that has been undone.
  3. Clicking on the button opens a window with the available actions that were undone:

  4. Highlight the desired actions.

    Several interrelated actions from the top (last to be have been undone) to the bottom can be selected.

  5. The status line shows how many actions have been restored.
  6. Clicking on the selected action restores it.

Other topics in this chapter

Equipment Modeling

Event classes

Event groups

Users

Projects

Variables

Archives

Efficiency class models

Reference curves


Equipment Modeling

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Equipment Modeling

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Metadata and equipment information can be changed for equipment models. Two tabs are available for the configuration:

  • Metadata
  • Equipment information

Equipment modeling toolbar and context menu

Nodes can be expanded or collapsed and checkboxes can be activated or deactivated using the toolbar and a context menu. The functionality of toolbars and the context menu has a different effect:

  • Symbols: Have an effect on all entries in the complete tree. Only the visible elements are taken into account during selection/deselection.
  • Commands in the context menu: Has an effect on the selected nodes and all its subnodes, regardless of their visibility.

Toolbar

The symbols´ meaning from left to right:

Parameters | Description
Expand all nodes | Clicking expands all nodes of an equipment model.
Collapse all nodes | Clicking collapses all nodes of an equipment model. Only root folders are displayed.
Select all visible nodes | Clicking activates all checkboxes of all displayed equipment models and equipment groups. Collapsed branches are not activated.
Deselect all entries | Clicking deactivates all checkboxes of all equipment models and equipment groups.

Context Menu

Right clicking on an equipment model or an equipment group opens a context menu:

Parameters | Description
Expand node and all child nodes | Expands this node and all subordinate elements.
Collapse node and all child nodes | Clicking closes this node and all subordinate elements.
Select node and all visible child nodes | Activates the checkboxes for the selected entry and all subordinate entries.
Deselect entry and all subordinate entries | Deactivates the checkboxes for the selected entry and all subordinate entries.

Other topics in this chapter

Metadata

Equipment information


Metadata

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Equipment Modeling -> Metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To edit the metadata:

  1. In the Object type window, select the Equipment modeling area.
  2. In the Object selection window, select the desired object from the tree of the equipment groups.

    Note: You can also change the description for several objects at the same time.

  3. In the editing area, enter the desired changes for the visual name or the description.
  4. Click on the button Apply.
  5. Click on the Save changes symbol to write the changes to the database.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed.

Object selection window

Selection of the equipment groups to be changed.

The objects:

  • Are selected using checkboxes
  • Cannot be filtered
  • Are displayed in accordance with the following schematic:
    Visualname: "Description Text"
  • Receive an asterisk (*) as a suffix if a text has been changed

Editing area

Entry and acceptance of changes.

Visual name

Entry to change the visual name of an equipment group.

Only available if precisely 1 element has been selected. The following rules apply to the visual names:

  • must not be empty
  • Must be unique for equipment groups with the same superordinate equipment group

Description

Entry to change the description of equipment groups.

Note: If several objects with different descriptions are selected for change, the original description of the first element in the list is displayed in red. Changes have an effect on all highlighted objects.

Reference curve

Selection of a reference curve from drop-down list.

The selection only has an effect on all selected equipment groups. The No reference group entry can also be selected. All linkings to reference curves are thus released.

If different reference curves have been configured for the selected equipment groups, the drop-down list is shown with a red border.

Apply

Clicking on the button accepts the changes. These are only written by clicking on the command or the Save changes symbol in the database.

Only available if a change has been made and no rules have been broken.


Equipment information

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Equipment Modeling -> Equipment information

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To amend equipment information:

  1. In the Object type window, select the Equipment modeling area.
  2. In the Object selection window, select the desired object from the tree of the equipment groups.

    Note: You can also change equipment information for several objects at the same time.

  3. If equipment information is already present, these are displayed in the editing area.
  4. If you want to create equipment information from scratch, click on the New button.
  5. Enter the desired information in the editing area.

    In doing so, please note:

    • The identification must not be empty.
    • Each entry within an equipment group must have a unique identification.
  6. Add further lines if required.
  7. Delete lines that are not needed by clicking on the X button.
  8. Click on the button Apply.
  9. Click on the Save changes symbol to write the changes to the database.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed.

Object selection window

Selection of the equipment groups to be changed.

The objects:

  • Are selected using checkboxes
  • Cannot be filtered
  • Are displayed in accordance with the following schematic:
    Visualname: "Description Text"
  • Receive an asterisk (*) as a suffix if a text has been changed

Editing area

Each line in the editing area corresponds to an entry in the EQUIPMENTINFO table, which is assigned to the currently-selected equipment group. Several equipment groups can also be selected.

If several equipment groups with different entries are selected, then a warning is shown at the lower border of the editing area. The entries of the equipment group are then displayed with the lowest ID that has fewer than 0 entries.

Symbol: New

Clicking on the button adds a new line.

A line consists of the following elements:

  • Identification (mandatory)
  • Text value (optional)
  • Numeric value (optional)
  • Measuring unit (optional)

Reference

Input of the identification for the entry. In doing so, the following rules apply:

  • Identification must not be empty.
  • Each entry within an equipment group must have a unique identification.

Text value

Input of a text value for the entry.

Can be activated/deactivated by means of a checkbox.

Numeric value

Input of a numeric value for the entry. In doing so, the following rules apply:

  • If this option value is activated, there must be a valid floating point number.

Can be activated/deactivated by means of a checkbox.

Measuring unit

Input of a measuring unit for the entry.

Can be activated/deactivated by means of a checkbox.

X

Clicking on the symbol deletes the line from the list.

Apply

Clicking on the button accepts the changes. These are only written by clicking on the command or the Save changes symbol in the database.

Only available if a change has been made and no rules have been broken. A violation of the rules is displayed by the background color of the input field changing and a tooltip being displayed.


Event classes

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Event classes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To make changes for event classes:

  1. In the Object type window, select the Event classes area.
  2. If necessary, filter the list in the Window Object Selection.

    Highlight the desired entry.

    Note: You can also change the description for several objects at the same time.

  3. In the editing area, enter the desired changes for the visual name or the description.
  4. Click on the button Apply.
  5. Click on the Save changes symbol to write the changes to the database.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed.

Object selection window

Selection of the event classes to be changed.

The objects:

  • Can be filtered
  • Are selected by clicking on the line
    (multiple selection is possible)
  • Are highlighted in red if they have been changed
    (the highlighting is also retained if the change is undone.)

Each line is an entry.

Filter

Entry of filter criteria for the list of the event classes.

It is possible to filter according to:

  • Identification
  • Visualname
  • Description

Wildcards can be used:

  • *: any desired number of any desired characters
  • ?: precisely 1 desired character.

If a filter text does not contain a wild card, a * is automatically added.

Apply

Applies filter to list.

Delete

Resets filter

Editing area

Entry and acceptance of changes.

Visual name

Entry to change the visual name of an event class.

Only available if precisely 1 element has been selected. The following rules apply to the visual names:

  • must not be empty
  • Must be unique to the whole database

Description

Entry to change the description of event classes.

Note: If several objects with different descriptions are selected for change, the original description of the last element selected is displayed in red. Changes have an effect on all highlighted objects.

Apply

Clicking on the button accepts the changes. These are only written by clicking on the command or the Save changes symbol in the database.

Only available if a change has been made and no rules have been broken.


Event groups

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Event groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To make changes for event groups:

  1. In the Object type window, select the Event groups area.
  2. If necessary, filter the list in the Window Object Selection.

    Highlight the desired entry.

    Note: You can also change the description for several objects at the same time.

  3. In the editing area, enter the desired changes for the visual name or the description.
  4. Click on the button Apply.
  5. Click on the Save changes symbol to write the changes to the database.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed.

Object selection window

Selection of the event groups to be changed.

The objects:

  • Can be filtered
  • Are selected by clicking on the line
    (multiple selection is possible)
  • Are highlighted in red if they have been changed
    (the highlighting is also retained if the change is undone.)

Each line is an entry.

Filter

Entry of filter criteria for the list of the event classes.

It is possible to filter according to:

  • Identification
  • Visualname
  • Description

Wildcards can be used:

  • *: any desired number of any desired characters
  • ?: precisely 1 desired character.

If a filter text does not contain a wild card, a * is automatically added.

Apply

Applies filter to list.

Delete

Resets filter

Editing area

Entry and acceptance of changes.

Visual name

Entry to change the visual name of an event group.

Only available if precisely 1 element has been selected. The following rules apply to the visual names:

  • must not be empty
  • Must be unique to the whole database

Description

Entry to change the description of event groups.

Note: If several objects with different descriptions are selected for change, the original description of the last element selected is displayed in red. Changes have an effect on all highlighted objects.

Apply

Clicking on the button accepts the changes. These are only written by clicking on the command or the Save changes symbol in the database.

Only available if a change has been made and no rules have been broken.


Users

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Users

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To make changes for users:

  1. In the Object type window, select the User area.
  2. If necessary, filter the list in the Window Object Selection.

    Highlight the desired entry.

    Note: You can also change the description for several objects at the same time.

  3. In the editing area, enter the desired changes for the visual name or the description.
  4. Click on the button Apply.
  5. Click on the Save changes symbol to write the changes to the database.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed.

Object selection window

Selection of the users to be changed.

The objects:

  • Can be filtered
  • Are selected by clicking on the line
    (multiple selection is possible)
  • Are highlighted in red if they have been changed
    (the highlighting is also retained if the change is undone.)

Each line is an entry.

Filter

Entry of filter criteria for the list of users.

It is possible to filter according to:

  • Identification
  • Visualname
  • Description

Wildcards can be used:

  • *: any desired number of any desired characters
  • ?: precisely 1 desired character.

If a filter text does not contain a wild card, a * is automatically added.

Apply

Applies filter to list.

Delete

Resets filter

Editing area

Entry and acceptance of changes.

Visual name

Entry to change the visual name of a user.

Only available if precisely 1 element has been selected. The following rules apply to the visual names:

  • must not be empty
  • Must be unique to the whole database

Description

Entry to change the description of users.

Note: If several objects with different descriptions are selected for change, the original description of the last element selected is displayed in red. Changes have an effect on all highlighted objects.

Apply

Clicking on the button accepts the changes. These are only written by clicking on the command or the Save changes symbol in the database.

Only available if a change has been made and no rules have been broken.


Projects

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Projects

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To make changes for projects:

  1. In the Object type window, select the Projects area.
  2. If necessary, filter the list in the Window Object Selection.

    Highlight the desired entry.

    Note: You can also change the description for several objects at the same time.

  3. In the editing area, enter the desired changes for the visual name or the description.
  4. Click on the button Apply.
  5. Click on the Save changes symbol to write the changes to the database.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed.

Object selection window

Selection of the projects to be changed.

The objects:

  • Can be filtered
  • Are selected by clicking on the line
    (multiple selection is possible)
  • Are highlighted in red if they have been changed
    (the highlighting is also retained if the change is undone.)

Each line is an entry.

Filter

Entry of filter criteria for the list of projects.

It is possible to filter according to:

  • Identification
  • Visualname
  • Description

Wildcards can be used:

  • *: any desired number of any desired characters
  • ?: precisely 1 desired character.

If a filter text does not contain a wild card, a * is automatically added.

Apply

Applies filter to list.

Delete

Resets filter

Editing area

Entry and acceptance of changes.

Visual name

Entry to change the visual name of a project.

Only available if precisely 1 element has been selected. The following rules apply to the visual names:

  • must not be empty
  • Must be unique to the whole database

Description

Entry to change the description of projects.

Note: If several objects with different descriptions are selected for change, the original description of the last element selected is displayed in red. Changes have an effect on all highlighted objects.

Apply

Clicking on the button accepts the changes. These are only written by clicking on the command or the Save changes symbol in the database.

Only available if a change has been made and no rules have been broken.


Variables

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To make changes for variables:

  1. In the Object type window, select the Variables area.
  2. If necessary, filter the list in the Window Object Selection.

    Highlight the desired entry.

    Note: You can also change the description for several objects at the same time.

  3. In the editing area, enter the desired changes for the visual name or the description.
  4. Click on the button Apply.
  5. Click on the Save changes symbol to write the changes to the database.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed.

Object selection window

Selection of the variables to be changed.

The objects:

  • Can be filtered
  • Are selected by clicking on the line
    (multiple selection is possible)
  • Are highlighted in red if they have been changed
    (the highlighting is also retained if the change is undone.)
  • Each line is an entry.

Filter

Entry of filter criteria for the list of variables.

It is possible to filter according to:

  • Project
  • Identification
  • Visualname
  • Description

Wildcards can be used:

  • *: any desired number of any desired characters
  • ?: precisely 1 desired character.

If a filter text does not contain a wild card, a * is automatically added.

Apply

Applies filter to list.

Delete

Resets filter

Editing area

Entry and acceptance of changes.

Visual name

Entry to change the visual name of a variable.

Only available if precisely 1 element has been selected. The following rules apply to the visual names:

  • must not be empty
  • Must be unique within a project

Description

Entry to change the description of variables.

Note: If several objects with different descriptions are selected for change, the original description of the last element selected is displayed in red. Changes have an effect on all highlighted objects.

Apply

Clicking on the button accepts the changes. These are only written by clicking on the command or the Save changes symbol in the database.

Only available if a change has been made and no rules have been broken.


Archives

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Archives

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To make changes for archives:

  1. Select, in the Object type Window, the Archive area.
  2. If necessary, filter the list in the Window Object Selection.

    Highlight the desired entry.

    Note: You can also change the description for several objects at the same time.

  3. In the editing area, enter the desired changes for the visual name or the description.
  4. Click on the button Apply.
  5. Click on the Save changes symbol to write the changes to the database.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed.

Object selection window

Selection of the archives to be changed.

The objects:

  • Can be filtered
  • Are selected by clicking on the line
    (multiple selection is possible)
  • Are highlighted in red if they have been changed
    (the highlighting is also retained if the change is undone.)
  • Each line is an entry.

Filter

Entry of filter criteria for the list of the event classes.

It is possible to filter according to:

  • Project
  • Identification
  • Visualname
  • Description

Wildcards can be used:

  • *: any desired number of any desired characters
  • ?: precisely 1 desired character.

If a filter text does not contain a wild card, a * is automatically added.

Apply

Applies filter to list.

Delete

Resets filter

Editing area

Entry and acceptance of changes.

Visual name

Entry to change the visual name of an archive.

Only available if precisely 1 element has been selected. The following rules apply to the visual names:

  • must not be empty
  • Must be unique within a project

Description

Entry to change the description of archives.

Note: If several objects with different descriptions are selected for change, the original description of the last element selected is displayed in red. Changes have an effect on all highlighted objects.

Apply

Clicking on the button accepts the changes. These are only written by clicking on the command or the Save changes symbol in the database.

Only available if a change has been made and no rules have been broken.


Efficiency class models

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Efficiency class models

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Efficiency class models are administered in the Object selection window. In the Editing area, the attendant metadata is edited and efficiency classes are created and edited.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed. For efficiency class models, click on the symbol in the tree.

Object selection window

Selection of the efficiency class models to be edited.

The objects:

  • Can be filtered
  • Are selected by clicking on the line
    (multiple selection is possible)
  • Are highlighted in red if they have been changed
    (the highlighting is also retained if the change is undone.)

Each line is an entry.

Editing area

Entry and acceptance of changes.

Administer efficiency class models

Efficiency class models are displayed in the Object selection window. They can be filtered, as well as newly created, duplicated and deleted.

Key:

  • : new
  • : duplicate
  • : delete

Filter

Parameters

Description

Filter

It is possible to filter according to:

  • Visual name: Filtering according to visual name. Use of wild cards is possible.
  • Measuring unit: Filtering according to measuring unit. Use of wild cards is possible.
  • Normalization: Filtering for time normalization. Select from drop-down list.

Filtering with wild cards:

  • *: any desired number of any desired characters
  • ?: precisely 1 desired character.

If a filter text does not contain a wild card, a * is automatically added.

Apply

Applies filter to list.

Delete

Resets filter

List of efficiency class models

List of efficiency class models

Lists all existing efficiency class models. The following is displayed for each model:

  • Visual name:
    Name that is displayed with the model.
  • Measuring unit:
    Selected measuring unit
  • Normalization:
    Selected time normalization
  • Number of efficiency classes:
    Amount of efficiency classes contained in the model.

Several models can be selected at the same time. For selected models, the following is possible in the editing area:

  • Metadata can be configured
  • Efficiency classes can be created and edited

Symbol: New

Active if there is a connection to the database.

Clicking creates a new line for the configuration of a new efficiency class model, resets any existing filter and selects the new model for editing.

Symbol: Duplicate

Active if there is a connection to the database and at least one model has been selected.

Creates a duplicate of all selected models and opens the dialog to configure the duplicated models. Once the dialog has been confirmed with OK, the duplication is carried out, any existing filter is reset and the duplicated models are selected for editing.

Symbol: Delete

Active if there is a connection to the database and at least one model has been selected.

Deletes the selected modles without requesting confirmation.

Other topics in this chapter

Metadata

Efficiency classes

Duplicate Efficiency Class Models


Metadata

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Efficiency class models -> Metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Metadata for the efficiency class models is configured in the editing area window in the Metadata tab.

The inputs are always applicable for all selected efficiency class models.
Fields that have different configurations for different models are marked in red.

Parameters | Description
Visual name | The visual name must not be empty and must be unique throughout the database. A change is only possible if precisely one efficiency class model has been selected.
Measuring unit | Configuration of the unit of the selected efficiency class models. If several models with different units are selected, this is highlighted by the amended red font color.
Normalization | Configuration of the time normalization of the selected efficiency class models. If several models with different time normalization are selected, this is highlighted by a red border.
Apply | Only active if a change has been made and the visual names are valid or the input field has been deactivated for the visual name. Clicking on the button saves the changes for the selected efficiency class models. Attention: Unsaved changes in the Efficiency classes tab are lost in the process.


Efficiency classes

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Efficiency class models -> Efficiency classes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Efficiency classes for the efficiency class models are configured in the editing area window in the Efficiency classes tab.

The inputs are always applicable for all selected efficiency class models.
If different models have different configurations, this is shown by a message next to the Apply button.

Key:

  • : new
  • : delete

Configuration:

Parameters

Description

Symbol: New

Clicking on the button adds a new efficiency class with an upper and lower limit.

Visual name

Entry of the visual name of the efficiency class. This must be unique within a model.

Lower limit

Configuration of the lower limit.

There is exactly one class without a lower limit for each model.

Highest value

Configuration of the upper limit.

There is precisely one class without an upper limit for each model.

Efficiency class color

Configuration and preview of the color of the efficiency class.

  • Preview field: Shows the currently configured color.
  • Color button: Click to open the color palette for selecting a color. If this dialog is closed by clicking on OK, the selected color is accepted.

Symbol: Delete

Only present for efficiency classes with an upper limit and lower limit. Clicking on the button deletes the efficiency class for the attendant parts without requesting confirmation.

Apply

Only active if a change has been made and the visual names of all efficiency classes per model are unique and not empty.

Clicking on the button validates the entries. If no validation errors are discovered, the configured efficiency classes for the selected efficiency class models are saved.

Attention: Unsaved changes in the Metadata tab are lost in the process.

Note: The warning next to the button is only visible if efficiency classes with different efficiency configurations have been selected.

Validation

When clicking on the button, the following validations are carried out before saving:

  • All efficiency classes are checked for valid areas: Upper limit > Lower limit, if there are both.
  • A check for limit clashes is made.
    Clash: 2 classes have the same upper limit or the same lower limit.
  • Check to see whether all efficiency classes connect to each other cleanly:
    • Starting with class without lower limit.
    • Ordered in ascending sequence up to class without upper limit.
    • There must be no overlaps or gaps.

If validation errors are discovered, these are shown as an error message in a Popup.


Duplicate Efficiency Class Models

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Efficiency class models -> Duplicate Efficiency Class Models

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Clicking on the Duplicate symbol in the Object selection window of the efficiency class models opens a dialog with the efficiency class models to be duplicated. These can be configured here. Further models for duplication can also be added.

For duplication, the selected original models are shown in the left area of the dialog. The attendant duplicates can be configured in the right area.

Key:

  • : delete

Configuration:

Parameters

Description

Original model

Display of the visual name of the original model for the duplicate.
There is already a cell entered for all models selected in the Efficiency class models dialog.

Further models can be added for duplication.

To do this, select a model from the drop-down list in the empty entry of the last lines.
All other input fields are activated and visible as a result of this. If there is then no line for a new duplicate, a new line for a new duplicate is added.

Measuring unit

Display of the measuring unit of the original model.

Normalisation

Display of the time normalization of the original model.

New model

Entry of the visual name of the duplicate.
In doing so, the following applies:

  • The name must be unique throughout the database.
  • The initial value is the visual name of the original model with a counter appended.

Measuring unit

Input of the measuring unit of the dublicate.
In doing so, the following applies:

  • The initial value is the measuring unit of the original model.

Normalisation

Configuration of the time normalization of the duplicate.
In doing so, the following applies:

  • The original value is the normalization of the original model.
  • If this setting is changed, the class adjustment factor is reinitialized.

Class adjustment factor

Configuration of the adjustment factor for the class boundaries in the duplicate model using a counter element.

When duplicating, the classes in the duplicate model are generated as follows:

  • The classes from the initial model are duplicated.
  • Their limits are then multiplied by the factor set here.

When initializing, the factor is calculated as follows:
[Minutes of the normalization interval in the initial model]/[Minutes of the normalization interval in the duplicate]
In doing so, the following is applicable:

  • An hour has 60 minutes
  • A day has 24 hours = 1440 minutes
  • A week has 7 days = 7 * 1440 minutes
  • A month has 30 days = 30 * 1440 minutes
  • A quarter has 90 days = 90 * 1440 minutes
  • A year has 365 days = 365 * 1440 minutes

Symbol: Delete

Clicking on the button deletes the attendant duplicate configuration without requesting confirmation.

OK

Accepts configuration, closes dialog and shows duplicates in the Efficiency class models dialog.

Cancel

Cancels duplication and closes the dialog.


Reference curves

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Reference curves

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reverence curves are administered in the Object selection window. In the Editing area, the attendant metadata is edited and reverence curves are created and edited.

Parameters

Description

Object type window

Selection of the object type, for which objects are to be changed. For reverence curves, click on the symbol in the tree.

Object selection window

Selection of the reverence curve models to be edited.

The objects:

  • Can be filtered
  • Are selected by clicking on the line
    (multiple selection is possible)
  • Are highlighted in red if they have been changed
    (the highlighting is also retained if the change is undone.)

Each line is an entry.

Editing area

Entry and acceptance of changes.

Edit reverence curves

Reverence curves are displayed in the Object selection window. They can be filtered, as well as newly created and deleted.

Key:

  • : new
  • : delete

Filter

Parameters

Description

Filter

It is possible to filter according to:

  • Visual name:
    Filtering according to visual name.
  • Description:
    Filtering according to description.
  • X-axis indicator name:
    Filtering according to indicator name of the X-axis.
  • X-axis measuring unit:
    According to the measuring unit of the X-axis.
  • Y-axis indicator name:
    Filtering according to the indicator name of the Y-axis.
  • Y-axis measuring unit:
    Filtering according to the measuring unit of the Y-axis.

The use of wild cards is possible for the filter.
Filtering with wild cards:

  • *: any desired number of any desired characters
  • ?: precisely 1 desired character.

If a filter text does not contain a wild card, a * is automatically added.

Apply

Applies filter to list.

Delete

Resets filter

List of reference curve models

List of reference curve models

Lists all existing reference curve models. The following is displayed for each model:

  • Visual name:
    Name that is displayed with the reference curve model.
  • Description:
    Description.
  • X-axis indicator name:
    Indicator name of the X-axis.
  • X-axis measuring unit:
    Selected measuring unit of the X-axis.
  • Y-axis indicator name:
    Indicator name of the Y-axis.
  • Y-axis measuring unit:
    Selected measuring unit of the Y-axis.

Several reference curve models can be selected at the same time. For selected models, the following is possible in the editing area:

  • Metadata can be configured
  • Values of the reference curves can be created and edited

Symbol: New

Active if there is a connection to the database.

Clicking creates a new line for the configuration of a new reference class model, resets any existing filter and selects the new reference curve model for editing.

Symbol: Delete

Active if there is a connection to the database and at least one model has been selected.

Deletes the selected reference curve models without requesting confirmation.

Other topics in this chapter

Metadata

Reference curve values


Metadata

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Reference curves -> Metadata

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Metadata for the reference curves is configured in the editing area window in the Metadata tab.

The inputs are always applicable for all selected reference class models.
Fields that have different configurations for different models are marked in red.

Parameters | Description
Visual name | The visual name must not be empty and must be unique throughout the database. A change is only possible if precisely one reverence curve model has been selected.
Description | Description of the reference curve.
X-axis indicator name | Indicator name of the X-axis for the selected reference curve models.
X-axis measuring unit | Unit of the X-axis for the selected reference curve models.
Y-axis indicator name | Indicator name for the Y-axis.
Y-axis measuring unit | Unit of the Y-axis for the selected reference curve models.
Apply | Only active if a change has been made and the visual names are valid or the input field has been deactivated for the visual name. Clicking on the button saves the changes for the selected reference class models. Attention: Unsaved changes in the Values of the reference curve tab are lost in the process.

info Information

If several reference curve models are selected for configuration and their values are different, this is shown in red font in the respective property. When applying the changes, all selected equipment groups are overwritten with the new value.


Reference curve values

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Actions -> Reference curves -> Reference curve values

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Inputs of the support points of the reference curve are configured in this tab.

The inputs are always applicable for all selected reference class models.
If models with different values are selected, there is a notice next to the Apply button.

Parameters

Description

Curve input table

Table for curve input with columns for:

  • Horizontal value (X-axis)
  • Vertical value (Y-axis)

Edit table:

  • Add line: Enter a value into the lowest line in the cell, the value for horizontal value. A new line is created underneath.
  • Delete: Click on the cell in the line that is furthest to the left. The line is highlighted. Press the Del key.

The following is applicable for the the configuration of the table:

  • Values for horizontal value must be unique in the table and ascending.
  • No empty cells can be present, with the exception of the lowest line.
  • Entered values must be able to be converted to floating point numbers with double precision.

Preview

Clicking on the button shows the configured values as a preview screen.

Preview area

The table content is validated by clicking on the Preview button and a preview is displayed on the diagram.

Apply

Only active if a change has been made.

Clicking on the button validates the entries. If no validation errors are discovered, the configured reference curves for the selected reference class models are saved.

Attention: Unsaved changes in the Metadata tab are lost in the process.

Note: The warning next to the button is only visible if reference curve models with different reference curve configurations have been selected.


Settings

zenon Analyzer -> Metadata database editors -> Metadata Editor -> Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this dialog, you configure:

  • The number of permitted connection profiles
  • Administration of the connection profiles
  • The language of the user interface of the Editor

To configure the settings:

  1. Open the menu File
  2. Select the command Settings.

    The dialog for configuring settings is opened

Parameters

Description

Maximum number of connection profiles

Defines how many connection profiles can be created as a maximum for the Editor:

  • Minimum: 1
  • Maximum: 255
  • Default: 10

Configuration by manual entry or by clicking on arrows.

Note: Because the ZAMS connection profile can also be displayed in the dialog for establishing a connection, more than the permitted amount of connection profiles can be displayed in the drop-down list to select a profile.

Manage connection profiles

Opens the dialog to manage the connection profiles.

Language

Selection of the desired language for the user interface of the Editor from a drop-down list.

SQL Server statement timeout

Entry of the SQL server statement timeout.

This timeout enters into force if an individual SQL Statement runs for longer than is defined here, for example when backing up or when restoring a large database. With new connections, the currently-set value is used for the Timeout. If this is amended in the options, the existing connections are amended to the new value.

The Timeout can be set to a value between 1 minute and 7 days.

Input elements:

  • Number element:
    Entry of the quantity in the field directly or by means of the cursor keys.
    Possible values for :
    - days: 1 - 7
    - hours: 1 - 168
    - minutes: 1 - 10080
  • Drop-down list for granularity:
    Possible values:
    - minutes
    - hours
    - days
    This selection influences the value range of the number element.

Default: 5 minutes

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Manual Data Editor

zenon Analyzer -> Metadata database editors -> Manual Data Editor

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Manual Data Editor makes it possible, in a zenon Analyzer metadata database, to edit the tables for prices, standards and degree days and to link these to variables. The Manual Data Editor is an independent process. It is available as an EXE file and can be started from ZAMS, from the Start menu or via the file directly.

ZAMS

To open the Manual Data Editor in ZAMS:

  1. Navigate to the Options menu item in ZAMS.
  2. Select the Manual Data Editor entry.

    The Manual Data Editor is started. At the same time, the dialog to establish a connection is opened.

Start as stand-alone application:

  • In the Windows Start menu, select the COPA-DATA -> Manual Data Editor. entry.
    The Manual Data Editor is started.

Keyboard shortcuts

The following key combinations are available to operate the Editor:

Key combination | Description
F1 | Opens help
Ctrl+Shift+C | Opens the dialog for creating a database backup.
Ctrl+S | Saves changes.
Alt+F4 | Closes the CD_PRODUCTNAME Editor
Ctrl+Z | Undo input
Ctrl+Y | Repeat input.

Other topics in this chapter

Establish connection

Main window

Configuration

Actions

Settings


Establish connection

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Establish connection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Manual Data Editor administers its connection profiles. The ZAMS connection profiles are also read on startup. If there are profiles in the Manual Data Editor and in ZAMS profiles with the same names, the connection profile of Manual Data Editor dominates.

To connect the Manual Data Editor to a database:

  1. Start the Manual Data Editor as a Stand alone Tool from the start menu or using the EXE file from the options in ZAMS.
    If the Manual Data Editor has already been opened, select the Establish connection command in the File menu.

    The dialog to connect to a server is opened.

  2. Select the desired connection by clicking on Connection profile or create a new connection in a similar manner to that of ZAMS.

    Note: In this connection dialog, no change password is required for secure communication.

  3. Click on OK.
    1. The connection is created.
    2. The user authorization is queried by the license server
    3. The database is checked to see that it is correct.
      Note: No connection is established if there are incorrect structures or versions. Conversion is only possible with ZAMS.
    4. Data is loaded
    5. The license is obtained.
    6. The loaded files are displayed in the Manual Data Editor.

Note: Unsaved changes are lost without warning when the connection is established.


Main window

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Main window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The main window shows the definitions present in the currently-connected database or variables for the respective tab that is open.
The following are available:

  • Price (definitions)
  • Standard (definitions)
  • Degree day (definitions)
  • Variable (variables)

All entries can be sorted and filtered. The Price tab is displayed on starting. All existing data is shown as unfiltered.

Range

Description

Menu line

Menu items for:

  • File: Creating, amending and administering entries for the connection, settings and closing the Manual Data Editor.
  • Edit: Entries for Undoing entries for entries and repeating entries.
  • Help: Versions and link to online help.

Toolbar

Allows the following actions:

  • Connect: Opens the dialog for creating a connection.
  • Apply changes: Saves changes made.
  • Discard changes: Rejects changes made.
  • Undo: Undoes the last action.
  • Redo: Repeats the last action.

List of definitions/variables

Display and configuration of the configured trends, standards, degree day definitions or variables, depending on the current tab.

Horizontal separator

Allows the size ratios to be moved between List and entries with the mouse.

Entries

Display and configuration of entries, depending on the selected tab and variables.

Decimal points are displayed up to maximum of 3 places.

Diagram

Visualization of the data configured in the entries.
The diagram is automatically updated each time the values are changed.

Vertical separator

Allows the size ratios to be moved between list of entries and diagram.

Status line

Notice of linking and the current action.

  • Symbol: Shows the connection status.
  • Text: Provides connection status including linked server and linked database.
  • Text: Display of the number of objects for total number, filtered and selected.
  • Text: Current process.

Other topics in this chapter

Menu, toolbars and status line


Menu, toolbars and status line

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Main window -> Menu, toolbars and status line

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The menu and toolbar offer a range of commands to administer the Manual Data Editor and the filter rules.

Menu

File

Commands for general operations.

Entry | Description
Establish connection | Opens the dialog to create a connection. Note: If the dialog to create a connection is confirmed by clicking on OK, then a new attempt to establish a connection is made. Unsaved changes are then discarded without confirmation being requested.
Apply changes | Saves all changes made to variables in the database.
Undo changes | Discards all changes made to variables since the last save after requesting confirmation.
Settings | Opens the dialog to configure the settings.
Exit | Closes the Manual Data Editor.

Edit

Commands for repeating and undoing actions.

Entry | Description
Undo | Undoes the last action.
Redo | Restores the last undone action

Help

Link to help and version information.

Entry | Description
Info about | Opens a window with information on the current version.
Help | Opens online help.

Toolbar Editor

Symbol | Description
Establish connection | Opens the dialog to create a connection. Note: If the dialog to create a connection is confirmed by clicking on OK, then a new attempt to establish a connection is made. Unsaved changes are then discarded without confirmation being requested.
Apply changes | Saves all changes made to the price history and norm history.
Undo changes | Discards all changes made to the price history and norm history since the last save after requesting confirmation.
Undo | Clicking on the symbol undoes the last action. Clicking on the arrow of the drop-down list opens a window to select actions that are to be undone. Only the last chronological action or other subsequent actions can be undone as a block.
Redo | Clicking on the symbol restores the last undone action. Clicking on the arrow of the drop-down list opens a window to select actions that have been undone that are to be restored. Only the last chronological action or other subsequent actions can be restored as a block.

Toolbar list

Symbol | Description
New | Opens dialog of the respective object to create a new entry.
Edit | Opens the dialog to edit the selected object.
Delete | Deletes selected objects after a confirmation message.
Import | Opens dialog to select a file for import.
Show linked variables | Opens a dialog dialog to display the linked variables. With multiple selection, the variables for last-selected object are displayed.

Note: The symbols that are displayed depend on the selected tab.

Status line

Informs you of the connection and objects.
Separator: |

Element

Description

Symbol

Shows the connection status.

The following are possible as a status:

  • No connection established
  • Connection established but the Analyzer server license is not valid
  • Connection established and the Analyzer server license is valid
  • Secured connection established, the license is valid
  • Secured connection established, the license is invalid

Connection information

Information on the active connection. Display of the server and the database.

Information [Objects], total

Information on the number, filtering and election of the objects (prices, standards, variables).

Separator: /

Action

Information on current action


Configuration

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In the Manual Data Editor, prices, standard values (standards) and/or degree days are defined and linked to variables.

The parameters are defined in the tabs:

  • Price
  • Standard
  • Degree day

The definitions are linked to variables in the Variable tab.

During configuration, work stages that have not yet been saved are undone and also restored using the corresponding symbols and menu entries. Saving is carried out using the symbol or the Check in menu entry.

With tables, the column width can be amended by:

  • Double-clicking on the column separator
  • Drag the mouse to the column separator

Other topics in this chapter

Price

Standard

Degree day

Variable


Price

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Price

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Prices are configured in this tab.

The tab is divided in three areas:

  • Price trend: Display and configuration of the price trends (top).
  • Price entries: Display and configuration of the price entries (bottom left).
  • Diagram: Display of the trend of the defined price entries (bottom right).

List of price trends

The list contains the configured prices. Configuration is carried out by means of the symbols above the list.

Key:

  • : New
  • : Edit
  • : Delete
  • : Show linked variables

Parameters

Description

Symbols

Symbol for the configuration of the price trends.

  • Price curves are created and edited with New and edit.
  • Delete removes the selected price curves after requesting confirmation.
  • With Show linked variables, all variables linked to the price curve can be displayed.

Visual name

Unique name of the price trend.

Description

Description of the price trend.

Valid from

Date of validity of the most recent price value.

Value

Value of the most recent price value.

Currency

Currency of the most recent price value.

Create and edit price trend

To create a new price trend:

  1. Click on the New symbol.

    The dialog to configure a price curve is opened.

  2. Please enter an unique name.
  3. Enter a description (optional).
  4. Close the dialog by clicking on OK.
  5. Configure the desired price entries.

To edit a price curve, click on the Edit symbol. Change the desired options in the dialog.

List of price entries

In the list of price entries, add the prices to the list of price curves. Their curve is shown in the diagram next to the list.

Key:

  • : New
  • : Edit
  • : Delete

Parameters

Description

Symbols

Symbols for the configuration of the prices.

  • Prices are created and edited with New and Edit.
  • Delete removes the selected price after requesting confirmation.

Visual name

Unique name of the price.

Description

Description of the price.

Valid from

Date of validity of the price value.

Value

Value of the price value.

Currency

Currency of the price.

Create and edit price entry

To create a new price entry:

  1. Highlight the price curve for which the entry is to be created.
  2. Click on the New symbol in the list of price entries.

    The dialog to configure a price entry is opened.

  3. Configure the time stamp if necessary.
    This cannot be edited later.
  4. Enter the price.
  5. Enter the currency.
  6. Close the dialog by clicking on OK.

Note: New values are only applied when saved to the price curve.

To edit a price entry, click on the Edit symbol. Change the desired options in the dialog.

Other topics in this chapter

Price curve dialog

Price entry dialog


Price curve dialog

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Price -> Price curve dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Clicking on the New or Edit symbol in the list of the price curves opens the dialog to add a new price curve:

Parameters | Description
Visual name | Unique name of the price trend.
Description | Optional description of the price trend.
OK | Only active if all inputs are valid. Clicking closes the dialog and adds the new price trend.
Cancel | Closes the dialog without generating a new price trend.


Price entry dialog

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Price -> Price entry dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Clicking on the New or Edit symbol in the list of the price entries opens the dialog to add a new price entry:

Parameters

Description

Timestamp

Entry of the time point from when the new price entry is valid. This time can also be in the past.

Input is in:

  • Date field: Direct input without selection from a calendar. Clicking on the button opens the calendar.
  • Time field: Direct entry or configuration using the cursor keys.

A time point is only valid if it does not trigger a time stamp clash.

Note: Only available when creating from scratch. Cannot be edited later.

Price

Entry of the price. Input errors are not approved and displayed by means of a tooltip. The decimal separator corresponds to the settings of the language.

Currency

Entry of the currency for this price. Input errors are not approved and displayed by means of a tooltip.

OK

Only active if all inputs are valid. Clicking closes the dialog and adds the new price entry.

Cancel

Closes the dialog without generating a new price entry.


Standard

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Standard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Standards (norms) are configured in this tab.

The tab is divided in three areas:

  • Standards: Display and configuration of standards (top).
  • Default values: Display and configuration of standard values (bottom left).
  • Diagram: Display of the trend of the defined standard values (bottom right).

List of standards

The list contains the configured standards. Configuration is carried out by means of the symbols above the list.

Key:

  • : New
  • : Edit
  • : Delete
  • : Show linked variables

Parameters

Description

Symbols

Symbols for the configuration of the standards.

  • Standards are created and edited with New and Edit.
  • Delete removes the selected standards after requesting confirmation.
  • With Show linked variables, all variables linked to a standard can be displayed.

Visual name

Unique name of the standard.

Description

Description of the standard.

Valid from

Date of validity of the most recent standard value.

Value

Value of the most recent standard value.

Create and edit standard

To create a new standard:

  1. Click on the New symbol.

    The dialog to configure a standard is opened.

  2. Please enter an unique name.
  3. Enter a description (optional).
  4. Close the dialog by clicking on OK.
  5. Configure the desired standard values.

To edit a standard, click on the Edit symbol. Change the desired options in the dialog.

List of standard values

In the list of standard values, add the standard values to the standards. Their curve is shown in the diagram next to the list.

Key:

  • : New
  • : Edit
  • : Delete

Parameters

Description

Symbols

Symbols for the configuration of the standard values.

  • Standard values are created and edited with New and Edit.
  • Delete removes the selected standard value after requesting confirmation.

Visual name

Unique name of the standard value.

Description

Description of the standard value.

Valid from

Date of validity of the standard value.

Value

Value of the standard value.

Create and edit standard value

To create a new standard value:

  1. Highlight the standard for which the entry is to be created.
  2. Click, in the list of standard values, on the New symbol.

    The dialog to configure a standard value is opened.

  3. Configure the time stamp if necessary.
    This cannot be edited later.
  4. Enter the value.
  5. Close the dialog by clicking on OK.

Note: New values are only applied when saved to the standard.

To edit a standard value, click on the Edit symbol. Change the desired options in the dialog.

Other topics in this chapter

Standards dialog

Standard value dialog


Standards dialog

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Standard -> Standards dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Clicking on the New or Edit symbol in the list of standards opens the dialog to add a new standard:

Parameters | Description
Visual name | Unique name of the standard.
Description | Optional description of the standard.
OK | Only active if all inputs are valid. Clicking closes the dialog and adds the new standard.
Cancel | Closes the dialog without generating a new standard.


Standard value dialog

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Standard -> Standard value dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Clicking on the New or Edit symbol in the list of standard values opens the dialog to add a new standard value:

Parameters

Description

Timestamp

Entry of the time point from when the new standard value is valid. This time can also be in the past.

Input is in:

  • Date field: Direct input without selection from a calendar. Clicking on the button opens the calendar.
  • Time field: Direct entry or configuration using the cursor keys.

A time point is only valid if it does not trigger a time stamp clash.

Note: Only available when creating from scratch. Cannot be edited later.

Standard value

Entry of the standard value. Input errors are not approved and displayed by means of a tooltip. The decimal separator corresponds to the settings of the language.

OK

Only active if all inputs are valid. Clicking closes the dialog and adds the new standard value to the list.

Cancel

Closes the dialog without generating a new standard value.


Degree day

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Degree day

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Degree days are configured in this tab.

info Information

The number of degree days is a location-dependent parameter that reflects local climatic conditions. A distinction is made between:

  • GTZnorm for the long-term average
  • GTZspez for the current measurement

GTZspez is used for example for the climate adjustment of measured consumption values.

The degree day number Gt or GTZ is calculated as soon as the outside temperature is under the heating limit temperature.

The GTZ is the sum of the differences of a stipulated room interior temperature and the respective average daily value of the outside temperature over all days of a time period when the outside temperature is below the heating limit temperature of the building.

Data for Germany - Austria - Switzerland - Lichtenstein:

  • Germany:
    In accordance with VDI Guideline 2067/DIN 4108 T6, the interior temperature is assumed to be 20° C and the heating limit as 15° C (GTZ20/15).
    Temperature values can be obtained from Deutscher Wetterdienst.
    These values can be imported into the Manual Data Editor.
  • Austria:
    20° C is assumed as the interior temperature, the heating limit is 12° C (HGT20/12).
    Temperature values can be obtained from ZAMG.
  • Switzerland and Lichtenstein:
    20° C is assumed as the interior temperature, the heating limit is 12° C (HGT20/12).
    Temperature values can be obtained from MeteoSchweiz.

The Degree Day tab is divided into three areas:

  • Degree day definitions: Display and configuration of the degree day definitions (top).
  • Degree day values: Display and configuration of the degree day values (bottom left).
  • Diagram: Display of the trend of the defined degree day values (bottom right).

List of degree day definitions

The list contains the configured standard values. Configuration is carried out by means of the symbols above the list.

Key:

  • : New
  • : Edit
  • : Delete
  • : Import
  • : Show linked variables

Parameters

Description

Symbols

Symbols for the configuration of the degree day definitions.

  • Degree day definitions are created and edited with New and Edit.
  • Delete removes the selected degree day definition after requesting confirmation.
  • Import allows the import of degree day definitions from Deutschen Wetterdienst in XLS,XLSX and XLSM format. Actual
  • With Show linked variables, all variables linked to the degree day definition can be displayed.

Visual name

Unique name of the degree day definition.

Description

Description of the degree day definition.

Temperature scale

Temperature scale of the most-recent degree day value used.

Inside temperature

Inside temperature value.

Heating temperature

If the outside temperature is below this, the day is considered a heating day and the daily degree day is calculated.

Create and edit degree day definitions

To create a new degree day definition:

  1. Click on the New symbol.

    The dialog to configure a degree day definition is opened.

  2. Please enter an unique name.
  3. Enter a description (optional).
  4. Close the dialog by clicking on OK.
  5. Configure the desired degree day values.

To edit a degree day definition, click on the Edit symbol. Change the desired options in the dialog.

List of degree day values

In the list of standard values, add the degree day values to the degree day definitions. They are displayed in the diagram next to the list.

Key:

  • : New
  • : Edit
  • : Delete

Parameters

Description

Symbols

Symbols for the configuration of the degree day values.

  • Degree day values are created and edited with New and Edit.
  • Delete removes the selected degree day value after requesting confirmation.

Visual name

Unique name of the degree day value.

Description

Description of the degree day value.

Timestamp

Date of validity of the degree day value.

Degree day

A number that denotes how much the heating was active on this day.

Heating day

Display of whether this day is a heating day.

Outside air temperature

Temperature of the outside air on this degree day.

Average degree day

Long-term average, for example 10 years, of the daily degree day for this day in the year.

Average heating day number

Denotes how often this day was a heating day in the long-term average.

Daily average air temperature

Average value of the air temperature on this day.

Create and edit degree day value

To create a new degree day value:

  1. Highlight the degree day definition for which the entry is to be created.
  2. Click, in the list of degree day values, on the New symbol.

    The dialog to configure a degree day value is opened.

  3. Configure the time stamp if necessary.
    This cannot be edited later.
  4. Enter the value for daily degree day.
  5. Configure other values (optional):
    • Current outside air temperature
    • Average degree day
    • Average heating day count
    • Daily average air temperature
    • Heating day
  6. Close the dialog by clicking on OK.

Note: New values are only applied when saved to the degree day definitions.

To edit a standard value, click on the Edit symbol. Change the desired options in the dialog.

Other topics in this chapter

Degree day definition dialog

Degree day value dialog

Import degree day values


Degree day definition dialog

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Degree day -> Degree day definition dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Clicking on the New or Edit symbol in the list of degree day definitions opens the dialog to add a new degree day definition:

Parameters | Description
Visual name | Unique name of the degree day definition.
Description | Optional description of the degree day definition.
Temperature scale | Indication of the scale used.
Inside temperature | Value of the inside temperature that is used for the calculation of the degree day number. The temperature is shown precisely to 3 decimal places. The third place is rounded according to the other places.
Heating temperature | Indication of the temperature from which heating takes place. The temperature is shown precisely to 3 decimal places. The third place is rounded according to the other places.
OK | Only active if all inputs are valid. Clicking closes the dialog and adds the new degree day definition.
Cancel | Closes the dialog without generating a new degree day definition.


Degree day value dialog

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Degree day -> Degree day value dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Clicking on the New or Edit symbol in the list of standard values opens the dialog to add a new degree day value:

Parameters

Description

Timestamp

Entry of the time point from when the new degree day value is valid. This time can also be in the past.

Input is in:

  • Date field: Direct input without selection from a calendar. Clicking on the button opens the calendar.

A time point is only valid if it does not trigger a time stamp clash.

Note: Only available when creating from scratch. Cannot be edited later.

Daily degree day

Value calculated in accordance with the degree day.

Current outside air temperature

Indication of the current outside air temperature.

Average degree day

Average degree day value of the last 10 years.

Can remain empty.

Average heating day count

Indication of how often this day was a heating day in the last 10 years.

Daily average air temperature

Average air temperature of this day.

Heating day
  • Active: This day is evaluated as a heating day.

OK

Only active if all inputs are valid.
Clicking closes the dialog and adds the new degree day value to the list.

Cancel

Closes the dialog without generating a new degree day value.

Degree day formula

The degree day figure is the sum of the differences of the stipulated room interior temperature and the respective average daily value of the outside temperature over all days of a time period when the outside temperature is below the heating limit temperature of the building.


Import degree day values

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Degree day -> Import degree day values

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Degree day values can also be imported.

Clicking on the Import symbol in the tool bar of the degree day tag starts the import process.

The following can currently be imported:

  • Degree day figures from Deutsche Wetterdienst in the XLS,XLSX and XLSM format.

To import data:

  1. Click on the Import button.

    The operating system dialog for selecting a file is opened

  2. Select the desired GTZ file.
  3. Click on Open.

    The data is imported.

The import can be undone using the Undo command.


Variable

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Configuration -> Variable

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, you link price trends, standards and degree day definitions to variables.

The following can be linked to each variable:

  • A price curve
  • A degree day definition
  • Several standards
    Note: With several standards, one can be chosen as a default.

The tab is divided in three areas:

  • Variable list: Display of the selectable variables and their current configuration (top).
  • Selection of prices / degree days: Selection of a price curve and/or a degree day definition to link to a variable (bottom left).
  • Selection of standards: Selection of one or more standards to link to a variable and to establish a Default Standards (bottom left).

To link a variable:

  1. Select the desired variable
  2. Select the elements to be linked.
    1. Price
    2. Degree day
    3. Standards
      Define a standard as a Default if required.

Variable List

The variables to be edited are listed in the variable list. These can be filtered.

Several variables can be selected at the same time. In doing so, the usual Windows keyboard shortcuts can be used. When selecting several variables, in the configuration areas for price, degree day and standards, all fields that have a different configuration are highlighted in red.

If the table is repopulated by a change to the filter criteria, then an attempt is made to restore the previous selection of variables.

The list contains the following columns:

  • Project name: Name of the project from which the variable comes.
  • Variable name : Name of the variable.
  • Measuring unit: Unit of measurement for variable values.
  • Meaning: Several meanings of a variable are separated by line switchings.
  • Identification: Name of the variables in zenon Editor and Runtime.
  • Description: Description of the variables.
  • Data type: Data type of the variable.

    Attention: Technically, prices, standards and degree days for binary and string variables can also be entered. However this normally does not make sense, because there are generally neither costs nor target consumptions for these variables.

  • Price trend assigned: Display of whether a price trend has been linked.
  • Standard assigned: Display of whether standards have been linked.
  • Degree day definition assigned: Display of whether a degree day definition has been linked.

Selection of price and degree day definition

In this area, you select the price trend and/or degree day definition for the highlighted variables:

Parameters | Description
Price trend selection | Selection of a price curve from a drop-down list. To remove an entry that has already been selected, select the empty entry in the drop-down list.
Degree day definition selection | Selection of a degree day definition from drop-down list. To remove an entry that has already been selected, select the empty entry in the drop-down list.

If several variables with existing different price curves or degree day definitions have been selected, the respective field is shown as empty with a red border.

Standard selection

There are two lists available for the selection and assignment of standards:

Parameters

Description

Selection of the standard

Lists to link standards to variables.

List of selection of standards

Contains all standards that have not yet been selected.

Symbols for linking

Symbols to assign standards:

Buttons to drag standards between lists:

  • >:
    Moves highlighted standard to the List of linked standards.
  • >>:
    Moves all standards to the List of linked standards.
  • <:
    Moves highlighted standard to the List of selection of standards.
  • <<:
    Moves all standards to the List of selection of standards.

List of linked standards

Contains all standards that are already linked to the selected variables.

Default Standard

Selection of a standard as a Default.
Clicking in the checkbox selects the attendant standard as a Default.

It is always only one standard that can be selected as a Default.

If several variables with existing different standards have been selected, the selection fields are shown with a red border; standards that are only available for some variables are highlighted in red font.


Actions

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Actions

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In the Manual Data Editor, data for prices, standards and degree days can be entered manually and variables can be assigned, as well as displayed in a historic diagram. The variables can be displayed as filtered.

Actions

Available actions:

  • Data entry for:
    • Price and trend diagram
    • Standards and trend diagram
    • Degree days and trend diagram
  • Linking of variables to prices, standards and degree days
  • Actions in the Editor:
    • Sorting and filtering
    • Apply changes
    • Undo - Restore
    • Show linked variables

Other topics in this chapter

Filtering and sorting

Apply changes

Undo - Restore

Show linked variables


Filtering and sorting

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Actions -> Filtering and sorting

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Tables in the Manual Data Editor can be displayed as sorted and filtered.

Sort

To sort a table, click in the header of the column according to which the table is to be sorted. A second click inverts the sorting, for example from A - Z to Z - A.

Filter

To filter a table:

  1. Click in the desired column in the field for filtering.
    Note: For filtering of a column with binary values (such as heating day), click on the Arrow symbol.
  2. Enter the filter criterion.

    The table is amended to the criterion during entry.
    If the criterion is not correct and cannot be applied, the input field is highlighted in red.

  3. Enter further filter criteria in further columns if required.

Filter rules

The following is applicable for filter settings:

  • All active filters are always linked with a logical AND.
  • The * and % characters can be used as wildcards for the text search.
    Both characters stand for a desired number of characters in the text. They can be used at the start of the word, in the word and at the end of the word. With all entries in the filter, a * is automatically assumed at the end.
    Example: Pr* finds Preis and Price but not Par.
    Note: If a filter is active when a new entry is created and the new entry does not correspond to the filter rules, it is not shown.
  • The following is applicable for numbers:
    • =: Values that correspond to the argument are found.
      This is standard behavior. = does not need to be placed in front.
      Example: 5 finds all lines that contain the number 5 exactly.
    • <: Values that are less than or equal to the argument are found.
      Example: <5 finds all lines that contain values that are either less than 5 oder equal to 5.
    • >: Values that are greater than or equal to the argument are found.
      Example: >5 finds all lines that are either equal to 5 or greater than 5.
  • The following is applicable for dates: Values that correspond to the argument are found.

Incorrect entries are displayed with a red background color. Only the correct filter criteria are applied.


Apply changes

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Actions -> Apply changes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Changes are transferred to the database by means of the command or the Apply changes symbol and saved there. The transfer of changes is checked and confirmed once this has been carried out (Commit). If a change to a variable is not successful, the transaction is reversed (Rollback).

attention Attention

If an error occurs when completing one of the transactions (Rollback or Commit), the database can become corrupted and thus unusable.


Undo - Restore

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Actions -> Undo - Restore

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Actions in the Manual Data Editor can be undone or restored.
This action is possible for all configurations that have been set up since the last check in.

Undo

To undo actions:

  1. Select the Undo command in the toolbar.
  2. Clicking directly on the symbol undoes the last action.
  3. Clicking on the button opens a window with the available actions:

  4. Highlight the desired actions.

    Several interrelated actions from the top (last to be have been carried out) to the bottom.

  5. The status line shows how many actions are being undone.
  6. Clicking on the selected action undoes it.

Restore

To restore actions:

  1. Select the Restore command in the toolbar.
  2. Clicking on the symbol directly restores the last action that has been undone.
  3. Clicking on the button opens a window with the available actions that were undone:

  4. Highlight the desired actions.

    Several interrelated actions from the top (last to be have been undone) to the bottom can be selected.

  5. The status line shows how many actions have been restored.
  6. Clicking on the selected action restores it.

info Information

When executing the Check in and Undo check out commands, the lists for Undo and Restore are emptied. The Undo and restore functions are thus only available for actions that are executed after applying or rejecting.


Show linked variables

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Actions -> Show linked variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Variables that are linked to price curves, standards or degree day figures can be displayed in a dialog.
To show linked variables:

  1. Mark the desired element.
  2. Click on the Linked Variables symbol.

    The dialog is opened.

Linked variables dialog

The list shows all variables linked to the selected element. The list can be filtered and sorted.

The following are displayed:

  • Project name: Name of the project from which the variable comes.
  • Visual name: Name of the variable.
  • Default Standard: Display of whether the variable is the Default standard.
    (only available for standards)


Settings

zenon Analyzer -> Metadata database editors -> Manual Data Editor -> Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the following in the settings:

  • Number of connections to be saved.
  • Connection profiles
  • User interface language,
  • Lookback time for trend curves
  • Default currency
  • SQL Server timeout

To configure the settings:

  1. Open the menu File
  2. Select the command Settings.

    The dialog for configuring settings is opened

Parameters

Description

Maximum number of connection profiles

Defines how many connection profiles can be created as a maximum for the Editor:

  • Minimum: 1
  • Maximum: 255
  • Default: 10

Configuration by manual entry or by clicking on arrows.

Note: Because the ZAMS connection profile can also be displayed in the dialog for establishing a connection, more than the permitted amount of connection profiles can be displayed in the drop-down list to select a profile.

Manage connection profiles

Opens the dialog to manage the connection profiles.

Language

Selection of the desired language for the user interface of the Editor from a drop-down list.

Trend lookback time

Stipulates how far back in time the trend display of prices, standards and degree days goes. Entry is made by means of an input field and a drop-down list that define the time period.

Entry of the numeric value:

  • Minimum: 1
  • Maximum: 100
  • Default: 1

Configuration by manual entry or by clicking on arrows.

Selection of the unit from the drop-down list:

  • Hours
  • Days
  • Months
  • Years

Default: 1 year

If non-permitted values are entered manually, the standard value of 1 year is configured when the dialog is closed.

Default currency

Input of a character sequence for the standard currency.

SQL Server statement timeout

Entry of the SQL server statement timeout.

This timeout enters into force if an individual SQL Statement runs for longer than is defined here, for example when backing up or when restoring a large database. With new connections, the currently-set value is used for the Timeout. If this is amended in the options, the existing connections are amended to the new value.

The Timeout can be set to a value between 1 minute and 7 days.

Input elements:

  • Number element:
    Entry of the quantity in the field directly or by means of the cursor keys.
    Possible values for :
    - days: 1 - 7
    - hours: 1 - 168
    - minutes: 1 - 10080
  • Drop-down list for granularity:
    Possible values:
    - minutes
    - hours
    - days
    This selection influences the value range of the number element.

Default: 5 minutes

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Migration Tool

zenon Analyzer -> Migration Tool

The migration tool allows the migration of Analyzer servers. Migration is possible from servers of version 2.00 or higher.
The following can be migrated:

  • Servers at the same level
  • Servers from one level to a higher level

The following is migrated:

  • Metadata databases (including SP, UDF, SQL connector, 3rd party database connector, archive emulation)
  • Reporting Services (database, users, RDL files)
  • Users including their authorizations for SQL Server, Analyzer applications, Reporting Services
  • SQL Agent jobs
  • Database backup jobs
  • Linked Server
  • Configuration for email (local only)
  • Schedules and subscriptions (delivery method of email only if the email client is configured)
  • Customer-specific RDL template

info Information

Report definition files present on the Analyzer Server (*.zams_rep) are not applied during a migration. If these are also required on the target Analyzer, they must be transferred manually.

Start migration tool

The tool can be started from ZAMS or as a stand-alone application.

Start via ZAMS:

  1. Navigate to the Options menu item in ZAMS.
  2. Click on the Migration tool entry.

    The migration tool is started

Start as stand-alone application:

  • In the Windows Start menu, select the COPA-DATA -> Migration tool entry.
    The migration tool is started.

User interface

Parameters

Description

Menus

For the migration tool, the two menu items File and Help are available:

File:
Contains the sub-items:

  • Options: Opens the Options dialog.
  • Exit: Exits the application.

Help:

Contains the subpoints:

  • Info about: Displays information on the version and copyright.
  • Help: Opens online help.

Step display

Display of the step to be configured.

Configuration view

Can also be subdivided into tree view and detail view for a step.

Display of the status and configuration of the objects of the respective step.

Navigation

Navigate in the migration steps using the Back and Next buttons.

Output window

Display of errors, warnings and notifications.

This dialog saves the following settings in the configuration file and recreates these on the next start:

  • Window position
  • Window size
  • Size of the output window
  • Display options for groups of errors, warnings and messages in the output window.

Other topics in this chapter

Options

Navigation

Output window

Configuration


Options

zenon Analyzer -> Migration Tool -> Options

The dialog to configure the options can be reached via the File menu.

The options include:

  • Maximum number of connection profiles
  • Administration of the connection profiles
  • Selection of the user interface language

Configuration dialog settings

Parameters

Description

Maximum number of connection profiles

Number of connection profiles that are saved. If the set maximum number is exceeded when creating a new connection profile, then the profile that has not been used the longest is deleted.

Entry in the field or configuration using the cursor keys.

  • Minimum: 1
  • Maximum: 255

Manage connection profiles

Clicking on the button opens the dialog for administering the connection profiles.

Language

Selection of the user interface language from the drop-down list. The language is immediately switched after the change is set and OK is clicked on.

SQL Server statement timeout

Entry of the SQL server statement timeout.

This timeout enters into force if an individual SQL Statement runs for longer than is defined here, for example when backing up or when restoring a large database. With new connections, the currently-set value is used for the Timeout. If this is amended in the options, the existing connections are amended to the new value.

The Timeout can be set to a value between 1 minute and 7 days.

Input elements:

  • Number element:
    Entry of the quantity in the field directly or by means of the cursor keys.
    Possible values for :
    - days: 1 - 7
    - hours: 1 - 168
    - minutes: 1 - 10080
  • Drop-down list for granularity:
    Possible values:
    - minutes
    - hours
    - days
    This selection influences the value range of the number element.

Default: 4 hours

Compress database backup files

Setting of whether backup files are compressed.

  • Active: Backup files are compressed.

Setting has an effect on all:

  • Database backups created during database migration
  • Database backup jobs on the target server, regardless of the setting on the source server

Database backup jobs are recognized and compressed or uncompressed and displayed accordingly. This detection and display depends on the status of this option.

OK

Applies settings and closes the dialog.
Changes are applied and the dialog is closed.

Attention: All change in the Administer connection profiles subdialog only become effective if this dialog is closed with OK. No changes are made if this is closed.

Cancel

Discards all changes and closes the dialog.

Other topics in this chapter

Manage connection profiles


Manage connection profiles

zenon Analyzer -> Migration Tool -> Options -> Manage connection profiles

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Up to 255 connection profiles can be created for migration. These are administered in this dialog.

You can change the login data for the source server and destination server, and delete profiles from the connection list.

Parameters

Description

List of connection profiles

Lists all configured connections. The following is displayed for each connection:

  • Connection profile: Name of the connection profile including server name and Analyzer server version
  • Source server computername: Computer name of the source server
  • Destination server computername: Computer name of the destination server
  • Connection details: Show:
    Authentication method on the source server
    Authentication method on the target server
    Connection security on the target server

Clicking on the entry selects the connection for editing. Multi-selection is possible via keys Ctrl + click or keys Shift + click.

Select all

Clicking on the button selects all entries for editing.

Deselect all

Clicking on the button deselects the selection.

Edit

Opens the dialog for configuring a wake up call.

Delete

Clicking on the button deletes the selected connection profile from the list.

Close

Changes are applied and the dialog is closed.

Attention: All changes only become effective if the basic Options dialog is closed by clicking on OK. No changes are made if this is closed.

Note: To reverse changes, close this dialog by clicking on Close and leave the Options dialog by clicking on Cancel.

Other topics in this chapter

Edit


Edit

zenon Analyzer -> Migration Tool -> Options -> Manage connection profiles -> Edit

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of authentication and activation or deactivation of the connection security for existing profiles.

Registration information

Parameters

Description

Shared credentials

Options for joint login information for both servers.

Use shared credentials
  • Active: The same login data is used for the source server and destination server.
  • Inactive: The login data must be given each time for each server.

Use Windows authentication
  • Active: Authentication for both servers is carried out with the Windows login data of the Windows user who started the process.

User name

Entry of the user name for authentication.

Only available if the Use Windows authentication option has been deactivated.

Source server credentials

Options for login on the source server.

Only available if the Use shared credentials option has been deactivated.

Use Windows authentication
  • Active: Authenticaiton on the source server is carried out with the Windows login data of the Windows user who started the process.

User name

Entry of the user name for authentication on the source server.

Only available if the Use Windows authentication option has been deactivated.

Target server login information

Options for login on the target server.

Only available if the Use shared credentials option has been deactivated.

Use windows authentication on destination server
  • Active: Authentication on the destination server is carried out with the Windows login data of the Windows user who started the process.

User name on the target server

Entry of the user name for authentication on the destination server.

Only available if the Use Windows authentication option has been deactivated.

Connection security

The options for connection security are only available if all used connection profiles have the same availability of connection security.

Source server connection security

Settings for the connection security for the source server. The entries must correspond to the configuration on the server.

Only available if the zenon Analyzer is version >= 3 on the source server.

Secured connection:

Activation or deactivation of the encrypted communication.

  • Active: Communication is encrypted. For each connection, depending on the degree of encryption, passwords must be entered for the license service.
  • Inactive: Communication is not encrypted.

Connection password

Entry of the password for the connection to the license server.
Input is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Only active if the Secured communication and Save passwords options have been activated.

Save password

Stipulation of whether the connection parameters are saved in the connection profile.
Saving is carried out as a hardware-dependent and user-dependent hash of the password.

Destination server connection security

Settings for the connection security for the target server. The entries must correspond to the configuration on the server.

Only available if the zenon Analyzer is version >= 3 on the target server.

Secured connection:

Activation or deactivation of the encrypted communication.

  • Active: Communication is encrypted. For each connection, depending on the degree of encryption, passwords must be entered for the license service.
  • Inactive: Communication is not encrypted.

Connection password

Entry of the password for the connection to the license server.
Input is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Only active if the Secured communication and Save passwords options have been activated.

License Server modification password

Entry of the change password on the license server.
Entry is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Only active if the Secured communication and Save passwords options have been activated.

Save passwords

Stipulation of whether the connection parameters are saved in the connection profile.
Saving is carried out as a hardware-dependent and user-dependent hash of the password.

Close dialog

Parameters | Description
OK | Applies settings and closes the dialog.
Cancel | Discards all changes and closes the dialog.


Navigation

zenon Analyzer -> Migration Tool -> Navigation

The configuration dialog will run through in individual steps. These are displayed in a list on the left edge of the tool.

The display of the individual steps shows their current status:

Circle symbol | Labeling | Status
Full | gray | configured
Full | orange | Is currently being configured
empty | gray | not yet configured

The direct number of individual steps is not possible. The configuration dialog is navigated through using buttons. It is always possible to switch between two adjacent steps. When switching between two steps, all inputs of the active step are validated. The switch is only possible if the configuratiuon for migration is valid in this step.

The button to go forward to the next steps changes its function depending on the step.

Navigation between steps

General

Button

Description

Back

Clicking on the button goes one step back in the configuration.

Only available if:

  • It is not the first or last step that is active
  • The currently-active step activates the button

Next

Clicking on the button goes one step forward in the configuration.
Only available up to the migration overview and if the currently-active step activates the button.

Migration overview step

Button | Description
Back | Clicking on the button goes one step back in the configuration.
Start migration | Clicking on the button starts the migration. Only available if the check of the configuration activates the button. Attention: This can no longer be canceled once the migration is started.

Migration running step

Button | Description
Back | not available.
New migration | Clicking on the button switches to the first step in order to configure a new migration.


Output window

zenon Analyzer -> Migration Tool -> Output window

The output window lists error messages, warnings, information and status messages in a table. These notices can be filtered and deleted.

Display in the output window

Parameters

Description

Buttons

Control display of the messages and navigation. Setting of the buttons is saved when ZAMS is closed.

Delete all
(red X)

Clears the whole table.

Error
(white x in a red circle)

Displays the number of errors that can be displayed in the table. Clicking on the button switches the display in the table on or off.

Warnings
(yellow triangle)

Displays the number of warnings that can be displayed in the table. Clicking on the button switches the display in the table on or off.

Messages
(blue circle)

Displays the number of messages that can be displayed in the table. Clicking on the button switches the display in the table on or off.

Table

Contains error messages, warnings and information.

  • Messages can be sorted with the column titles and according to columns.
    Clicking on the respective column head sorts the table according to this column. A second click inverts the sorting.
    The standard sorting increases in accordance with column 1 (Numbering).
  • Double clicking on a message in the table displays the report and the context in which the message was created in the report area of the main window. To do this, the report must already be open.
  • Messages are deleted when ZAMS is closed.

Numbering

Contains consecutive numbering. The numbers are assigned chronologically upon receipt.

Symbol

Symbol that displays the type of message. The symbols correspond to the symbols of the buttons.

Sorting sequence ascending:

  • Error
  • Warning
  • Information

Descendant sorting is carried out in reverse order.

Timestamp

Displays the time stamp at which the message was created.

Message ID

Unique ID of the message source.

Description

Explanation of the message.


Configuration

zenon Analyzer -> Migration Tool -> Configuration

Configuration of migration takes place in individual steps:

  • Connect to Servers
  • General settings
  • Linked servers
  • Databases
  • Schedules
  • Reports and Subscriptions
  • Summary
  • Migrating

The process is gone through with the Back and Next buttons. Individual steps cannot be called up directly. Switching forwards and backwards is only possible if the current step has been validated positively.

Other topics in this chapter

Connect to Servers

General settings

Linked servers

Databases

Schedules

Reports and Subscriptions

Summary

Migrating


Connect to Servers

zenon Analyzer -> Migration Tool -> Configuration -> Connect to Servers

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this step, you configure the connection to the source server and to the target sever for the migration.

To establish a connection:

  1. Configure computer, Analyzer version and login data for the source server.
  2. Configure computer, Analyzer version and login data for the target server.
  3. Establish the connection by clicking on the Connect button.

Connection profile

Parameters | Description
Connection profile | Selection of an existing connection profile for connection or the creation of a new profile. When selecting a new profile, the entries of the previous profile are retained and can be edited. Only available if there is no connection. The connection profiles are managed in the options.

Shared credentials

Parameters

Description

Shared credentials

Configuration of a new connection. The options are only available if a new connection profile is created and there is no connection.

Note: The options Password and User name are only available if the Use Windows authentication option has been deactivated.

Use shared credentials

Stipulation of whether the login data is to be used for both servers.

  • Active: The login is carried out on both servers with the same data.
  • Inactive: The login data must be entered for each server.

Use Windows authentication
  • Active: With joint log-in, the log-in data of the Windows user who started the process is used.

Only available if the Use shared credentials option has been activated.

User name

Entry of the user name for authentication.

Only available if the Use shared credentials option has been activated and the Use Windows authentication option has been deactivated.

Password

Entry of the password for authentication.

Note: Passwords are not saved and must be reentered each time the connection is made.

Only available if the Use shared credentials option has been activated and the Use Windows authentication option has been deactivated.

Refresh server list

Clicking on the button starts the search for servers that can be accessed with the login data.

The drop-down lists for source server and target server are filled with the results.

Only available if the Use shared credentials option has been activated.

Source server

Parameters

Description

Source server

Configuration of a new connection. The options are only available if a new connection profile is created and there is no connection.

Note: The options Password and User name are only available if the Use Windows authentication option has been deactivated.

Use Windows authentication

Active: With joint log-in, the log-in data of the Windows user who started the process is used.

Only available if the Use shared credentials option has been deactivated.

User name

Entry of the user name for authentication.

Only available if the Use shared credentials options and Use Windows authentication options have been deactivated.

Password

Entry of the password for authentication.

Note: Passwords are not saved and must be reentered each time the connection is made.

Only available if the Use shared credentials options and Use Windows authentication options have been deactivated.

Connection security

Settings for the connection security. The entries must correspond to the configuration on the server.

Only available if the selected server version allows secure connections.

Secured connection

Activation or deactivation of the encrypted communication.

  • Active: Communication is encrypted. For each connection, depending on the degree of encryption, passwords must be entered for the license service.
  • Inactive: Communication is not encrypted.

Note: Secured communication cannot be configured for existing connection profiles. A new profile must be created.

License Server connection password

Entry of the password for the connection to the license server.
Input is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Save passwords

Stipulation of whether the connection parameters are saved in the connection profile.
Saving is carried out as a hardware-dependent and user-dependent hash of the password.

Refresh server list

Clicking on the button starts the search for source servers that can be accessed with the login data.

The drop-down list to select a server is filled with the results.

Only available if the Use shared credentials option has been deactivated.

Specify database server

Clicking on the button opens the dialog for manual entry of a source server.

Server version

Selection of the main Analyzer version of the source server from a drop-down list.
The list is filled with the results of the search or manual entry. With a secure connection, only versions that support a secure connection are offered.

Server computername

Selection of the computer name from a drop-down list.
The list is filled with the results of the search or manual entry.

Destination server

Parameters

Description

Destination server

Configuration of a new connection. The options are only available if a new connection profile is created and there is no connection.

Note: The options Password and User name are only available if the Use Windows authentication option has been deactivated.

Use Windows authentication

Active: With joint log-in, the log-in data of the Windows user who started the process is used.

Only available if the Use shared credentials option has been deactivated.

User name

Entry of the user name for authentication.

Only available if the Use shared credentials options and Use Windows authentication options have been deactivated.

Password

Entry of the password for authentication.

Note: Passwords are not saved and must be reentered each time the connection is made.

Only available if the Use shared credentials options and Use Windows authentication options have been deactivated.

Connection security

Settings for the connection security. The entries must correspond to the configuration on the server.

Only available if the selected server version allows secure connections.

Secured connection

Activation or deactivation of the encrypted communication.

  • Active: Communication is encrypted. For each connection, depending on the degree of encryption, passwords must be entered for the license service.
  • Inactive: Communication is not encrypted.

Note: Secured communication cannot be configured for existing connection profiles. A new profile must be created.

License Server connection password

Entry of the password for the connection to the license server.
Input is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

License Server modification password

Entry of the change password on the license server.
Entry is always hidden. The actual length is disguised. If the input field is active, it must be filled in order for a connection to be established.

Save passwords

Stipulation of whether the connection parameters are saved in the connection profile.
Saving is carried out as a hardware-dependent and user-dependent hash of the password.

Refresh server list

Clicking on the button starts the search for target servers that can be accessed with the login data.

The drop-down list to select a server is filled with the results.

Only available if the Use shared credentials option has been deactivated.

Specify database server

Clicking on the button opens the dialog for manual entry of a target server.

Server version

Selection of the main Analyzer version of the target server from a drop-down list.
The list is filled with the results of the search or manual entry. With a secure connection, only versions that support a secure connection are offered.

Server computername

Selection of the computer name from a drop-down list.
The list is filled with the results of the search or manual entry.

Connection

Parameters | Description
Connect | Clicking on the button starts the establishment of the connection with the configured connection data The result is shown under the button as text information.
Disconnect | Clicking on the button disconnects the existing connection. The result is shown under the button as text information.
Text information | Shows the current connection status of the migration tool. In addition, the background color of the information is set according to the connection status.

Navigation and output windows

Parameters

Description

Navigation

Navigation in the configuration steps by means of the Back and Next buttons.

  • Back: One step back.
    Only available if not the first or last step.
  • Next: One step further.
    Only available if the validation for the current configuration has been completed successfully.
    This button is replaced:
    In the Overview of migration step by Start migration.
    In the Migration is taking place by New migration.

Output window

Display of errors, warnings and notifications.

Other topics in this chapter

Specify database server


Specify database server

zenon Analyzer -> Migration Tool -> Configuration -> Connect to Servers -> Specify database server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Source and target server for the migration can be configured manually. Clicking on the Specify Database Server button in the Connect to server step opens the dialog to enter the Analyzer version and name of the server.

Parameters | Description
Server version | Select the main version of the Analyzer server from a drop-down list.
Server computername | Entry of the name of the computer on which the Analyzer server runs.
Progress bar | Shows the validation progress and any errors that are found.
OK | Starts process when entering a server. If this is successful, the dialog is closed and the changes are saved.
Cancel | Discards all changes and closes the dialog.


General settings

zenon Analyzer -> Migration Tool -> Configuration -> General settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this step, you configure the general settings for the migration:

  • Access rights for tools:
    • Manual Data Editor
    • Metadata Editor
    • ZAMS

    Note: The source server and target server must be higher than version 2.00, because these access rights are not available for version 2.00.

  • Access rights on the Analyzer Server:
    Basic access rights to web services and Report Launcher. Assignment of the roles for users and administrators.
  • SMTP settings on the Analyzer Server:
    Migration of the SMTP settings for report dispatch by email.

    Note: These settings can only be migrated if the following components are running on the same server:

    • Source server
    • Destination server
    • Migration Tool
  • Reporting Services wake up call

info Information

Members of the local administrators in the <PREDEFINED>\Administrators group cannot be migrated.

Background: This group is created by the operating system. It may get different names, depending on the operating system, language and other factors. It cannot therefore be clearly identified from the migration process.

In the Diagnosis Viewer, you get the error message E00060 in any case: Setting the access rights in the SQL Server Reporting Services on [Computer] for [version] has failed.

Configuration

Selection

Parameters

Description

Step display

Display of the step to be configured.

Selection tree

Display and selection of the components to be configured.

Detail view

Display of the status and configuration of the selected object.

Information is shown with a yellow background if the object cannot be migrated.

If the object can be migrated, the checkbox for activation of the migration and the objects to be migrated are shown.

Configuration:

  • Checkbox
    active: Object is to be migrated.
    Inactive: Object is not migrated.
  • Detail window: Display of the configuration to be migrated on the source server or notes on the current configuration on the target server.

For details, see the following sections.

  • Analyzer application access rights
  • Report Launcher user roles
  • Email server configuration
  • Reporting Services wake up call

Navigation and output windows

Parameters

Description

Navigation

Navigation in the configuration steps by means of the Back and Next buttons.

  • Back: One step back.
    Only available if not the first or last step.
  • Next: One step further.
    Only available if the validation for the current configuration has been completed successfully.
    This button is replaced:
    In the Overview of migration step by Start migration.
    In the Migration is taking place by New migration.

Output window

Display of errors, warnings and notifications.

Analyzer application access rights

Settings for the migration of the access rights for Analyzer applications.

To migrate the access rights for Analyzer applications:

  1. Select the Access rights for the Analyzer applications entry in the selection tree.
  2. Activate the Migrate Analyzer Tools access rights configuration checkbox.
  3. Check the objects to be migrated in the detail window.

Report Launcher user roles

Settings for the migration of the Report Launcher user roles.

To migrate the user roles:

  1. In the selection tree, select the Report Launcher user roles entry.
  2. Tick the Migrate Report Launcher user roles checkbox.

    Note: If the migration of the user roles is deactivated, the access rights to individual objects on the Analyzer server (folders, reports etc.) cannot be migrated. A corresponding warning is displayed.

  3. Check the objects to be migrated in the detail window.

Email server configuration

Settings for the migration of the email server configuration.

To migrate the email server configuration:

  1. Select the Email server configuration entry in the selection tree.
  2. Activate the Migrate email server configuration checkbox.
  3. In the detail window, check the SMTP configuration on the source server and the status of the email report sending expansion on the target server.

If the migration of the SMTP configuration has been deactivated by the user, the availability of the email report sending expansion is shown in the target server.

  • Email subscriptions can be migrated if the expansion is available.
  • If the expansion is not available, the migration of email subscriptions is not possible. A corresponding warning is displayed.

Reporting Services wake up call

Settings for the migration of the Reporting Services activation call.

To migrate a Reporting Services activation call configured on the source server:

  1. Select Reporting Services activation call in the selection tree.
  2. Tick the Migrate the Reporting Services activation call checkbox.
    Note: This is only available if the call exists on the source server and there is no communication error.
  3. Note the status report. This provides information on the migrateability and parameters of the activation call.


Linked servers

zenon Analyzer -> Migration Tool -> Configuration -> Linked servers

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

in this step, you configure the settings for the migration of the Linked Servers.

The Linked Server information with the attendant provider information is read from the source server. In order for a Linked Server to be able to be migrated, the following conditions must be met:

  • The attendant provider already exists on the target server.
    This means: There is a provider on the target server with the same name and identical configuration.
  • A valid password is stored for each required user.
  • The passwords have been validated successfully.

Configuration

Selection in the selection tree

Parameters

Description

Step display

[Linked server name]

Display and selection of the Linked-Server to be configured.

Clicking on a server offers the option to configure the selected Linked Servers in the detail view.

Status colors:

  • Yellow:
    Linked Server is not selected for migration.
  • Red:
    Linked Server is selected for migration and cannot be migrated.

Validate passwords

Start of validation and display of the validation status of the passwords.

Status colors:

  • Red: At least one password has not yet been validated.

Server configuration

Parameters

Description

Title

Name of the Linked Servers that is configured.

If there is configurable content, information is shown accordingly.

Migrate this Linked Server

Checkbox to select whether the server is migrated:

  • Active: This Linked Server is to be migrated.
  • Inactive: This Linked Server is not migrated.
    Note: If Linked Servers are excluded from migration, this can lead to problems in the migration process.

Status colors:

  • Yellow: Not selected for migration.
  • Red: Server is selected and cannot be migrated with the current configuration.

Text information on the status may be shown below the password field.

Passwords

Entry of the password for the user who is needed to create the linked server on the target server.

Note: If the computer is in a different domain, the path must be given as a Fully Qualified Domain Name.

Status colors:

  • Red: no password entered

Text information

Display of notices in the event of configuration problems.

Migration view deselected:

Validate passwords

You start validation of the passwords entered in the Check passwords detail area. Linked Servers can only be migrated if all configured connections have the correct password.

To set and check the passwords:

  1. Issue the required passwords for each Linked Server to be migrated.

    Servers that are selected for migration but do not have a valid password are displayed as saved in red.

  2. Click on the Check passwords for linked servers button.

    The passwords are checked.

    The result is shown in the list with the checking status.

Attention: If a password that has already been validated is amended, the validation must be carried out again.

Parameters

Description

Linked server password validation states

Display of the validation result for all configured Linked Servers:

  • Green check mark: Validation successful
  • Magnifying glass: Validation not carried out
  • Red circle: Validation failed

Validate Linked Server passwords

Clicking on the button starts the validation process.

The results are displayed on the list with the checking status.

Navigation and output windows

Parameters

Description

Navigation

Navigation in the configuration steps by means of the Back and Next buttons.

  • Back: One step back.
    Only available if not the first or last step.
  • Next: One step further.
    Only available if the validation for the current configuration has been completed successfully.
    This button is replaced:
    In the Overview of migration step by Start migration.
    In the Migration is taking place by New migration.

Output window

Display of errors, warnings and notifications.


Databases

zenon Analyzer -> Migration Tool -> Configuration -> Databases

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this step, you configure the settings for the migration of the databases:

  • Paths for databases backup files
  • Migratable databases
  • Database backup jobs

Configuration

To configure the databases for the migration:

  1. Select the Database entry in the selection tree.
  2. Select the desired object in the detail view.
    The status of a task is displayed in the detail window using messages and signal colors.
    • Paths for database backup files:
      Clicking on the object shows the input elements for necessary paths in the detail view. The worst validation results of a path are shown as a status color.
    • Databases to be migrated:
      Clicking on the object shows the input elements for database migration in the detail view. Each sub-element represents a database available for migration. The color of the sub-element shows the status of the database:
      Red: Necessary paths missing.
      Yellow: Cannot be migrated due to dependencies or is not selected for migration.
    • Database backup jobs on the source server:
      Clicking on the object shows the input objects for database backup jobs in the detail view. Each sub-element represents all database backup jobs available for migration on the source server. The status color is the status color of the worst sub-element. The color of the sub-element shows the status of the database backup job:
      Red: Necessary paths missing.
      Yellow: Cannot be migrated due to dependencies or is not selected for migration.
  3. Configure the selected objects in the detail window.

info Information

The demo database supplied by COPA-DATA cannot be migrated. Databases, database backup jobs, reports and subscriptions that are based on the demo database also cannot be migrated.

Databases that cannot be migrated are displayed in the tree with yellow highlighting.

Procedure

The process for the migration of the databases is as follows:

  • The databases of the source server are saved in a defined folder.
  • The databases are moved from the backup folder to a backup folder for the target server.

    This step is not necessary if the two backup folders are identical.

  • The databases are restored again on the target server.
  • Database backup jobs are set up again on the target server.

Paths for databases backup files

Paths for databases backup files

Parameters

Description

Paths for databases backup files

Settings for the database paths for migration.

Source server databases backup path for the migration process

Entry of the database backup path for the migration process on the source server.

When carrying out the migration, the databases in this path are saved by the source server.

Click the ... button and the dialog opens to select a path. The path can also be entered directly into the field as a UNC network path.
Syntax: \\Computer name\folder\subfolder

Note: This field is a mandatory field for migration.

Destination server databases backup path for the migration process

Entry of the database backup path for the migration process on the target server.

When carrying out the migration, the database backup files are moved to this path from the path on the source server and then restored by the target server from this path. The files are deleted afterwards.

Click the ... button and a dialog opens to select a path. The path can also be entered directly into the field as a UNC network path.
Syntax: \\Computer name\folder\subfolder

Note: This field is a mandatory field for migration.

Migrate automated database backup jobs

Stipulation of whether database backup jobs are to be migrated.

  • Active: Database backup jobs will be migrated A valid path must be issued in the Network enabling on the target server to save database backups.
  • Inactive: Database backup jobs will not be migrated.
    Status color: yellow

Destination server network share for database backups

Entry of the path to an enabled folder on the target server in which database backup jobs can be saved.

Click the ... button and a dialog opens to select a path. The path can also be entered directly into the field as a UNC network path.
Syntax: \\Computer name\folder\subfolder

Only available if the Migrate automated database backup jobs option has been activated.

Validation of the database backup paths

Click on the button to start validation of the configured paths. If the result is positive, the button to move forward in the process is enabled.

Status display

The status of the ability to migrate is displayed below the button for validation via symbols and messages:

  • Green check mark: Validation successful
  • Magnifying glass: Validation not carried out
  • Red circle: Validation failed

A written message informs you of the reason for the respective status.

Selection of databases

Database selection

Parameters

Description

Title

Name and type of database.

For example: Reporting (Analyzer database)

Migrate this database

Configuration of whether this database is to be migrated. Only available if the database can be migrated. A database can be migrated if the necessary paths for the migration process have been validated successfully and all dependencies are migrated.

  • Active: Database is to be migrated.
  • Inactive: Database is not migrated.
    Status color: yellow

Required Linked Servers

Shows all Linked Servers that depend on this database.
A database can only be migrated if all Linked Servers on which it depends are migrated.

Required databases

Shows all databases on which this database is dependent. A database can only be migrated if all databases on which it depends are migrated.

Display only available for Analyzer databases.

Status

Status display. Only available if a database is not migrated.

Text shows reason for non-migration and informs you, in the case of Analyzer databases, if these are not migrated.

Status colors:

  • Red: Paths missing.
  • Yellow: All other notices.

Navigation and output windows

Parameters

Description

Navigation

Navigation in the configuration steps by means of the Back and Next buttons.

  • Back: One step back.
    Only available if not the first or last step.
  • Next: One step further.
    Only available if the validation for the current configuration has been completed successfully.
    This button is replaced:
    In the Overview of migration step by Start migration.
    In the Migration is taking place by New migration.

Output window

Display of errors, warnings and notifications.

Database view is not migrated:

Paths for databases backup files

Parameters

Description

Title

Database backup job name

Migrate this database backup job

Configuration of whether this database backup job is to be migrated. Only available if the backup job can be migrated. A database backup can be migrated if the path for database backup jobs on the target server has been successfully validated and all dependencies have been migrated.

  • Active: Database backup job is to be migrated.
  • Inactive: Database backup job is not migrated.
    Status color: yellow

Text

Database backup job description

Required databases

List of all databases on which this database backup job depends. A database backup job can only be migrated if all databases on which it depends are migrated.

Status

Status display. Only available if a database backup job is not migrated.

Text shows reason for non-migration.

Status colors:

  • Red: Paths missing.
  • Yellow: All other notices.

Attention: If a database included in a database backup job no longer exists, this job can no longer be migrated.

Navigation and output windows

Parameters

Description

Navigation

Navigation in the configuration steps by means of the Back and Next buttons.

  • Back: One step back.
    Only available if not the first or last step.
  • Next: One step further.
    Only available if the validation for the current configuration has been completed successfully.
    This button is replaced:
    In the Overview of migration step by Start migration.
    In the Migration is taking place by New migration.

Output window

Display of errors, warnings and notifications.

View of invalid configuration:


Schedules

zenon Analyzer -> Migration Tool -> Configuration -> Schedules

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this step, you configure the settings for the migration of the schedules.

Selection in the selection tree

Parameters

Description

Step display

Display of the step to be configured.

Selection tree

Display and selection of the schedules to be configured.

Clicking on the schedule offers options for the configuration of the selected schedule in the detail view.

Status colors:

  • Yellow:
    Schedule is not selected for migration.

Configuration in detail view

Parameters

Description

Title

Name of the schedule that is configured.

If there is configurable content, information is shown accordingly.

Migrate report server schedule

Checkbox to select whether the schedule is migrated:

  • Active: This schedule is to be migrated.
  • Inactive: This schedule is not migrated.

Status colors:

  • Yellow: Not selected for migration.

Text information

Display of:

  • Description of the schedule.
  • Notes on the migration of subscriptions if the schedule is not migrated.

Migration view deselected:


Reports and Subscriptions

zenon Analyzer -> Migration Tool -> Configuration -> Reports and Subscriptions

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this step, you configure the settings for the migration of reports and subscriptions. Reports and subscriptions that are not migrated or cannot be migrated are highlighted in yellow. Note the dependency when migrating subscriptions for reports and passwords.

Standard configuration

To migrate all elements in the Root:

  1. Tick the Migrate this object checkbox.

    Note: At least one object must be able to be migrated

  2. Select the configuration for Migrate policy of the root item from the source server.
  3. Enter the required passwords in the Enter passwords node.

Parameters

Description

Step display

Display of the step to be configured.

Selection tree

Lists all reports available in Report Launcher.

In addition, the subscriptions configured for each report are displayed.

The Enter password node allows the input of all passwords required for the provision of passwords. Only present if there are subscriptions.

Title

Shows name [root].

Migrate this item

Configuration of whether object is migrated.

  • Active: All objects in the root folder that can be migrated are highlighted for migration.
  • Inactive: No objects are migrated.

Status colors:

  • Yellow: Object has not been selected for migration or cannot be migrated due to dependencies.

Migrate policy of the root item from the source server.

Configuration for acceptance of authorizations.

  • Active: Authorization of the root element on the source server is transferred to target server.
  • Inactive: Authorization of the root element on the target server is not changed.

Navigation and output windows

Parameters

Description

Navigation

Navigation in the configuration steps by means of the Back and Next buttons.

  • Back: One step back.
    Only available if not the first or last step.
  • Next: One step further.
    Only available if the validation for the current configuration has been completed successfully.
    This button is replaced:
    In the Overview of migration step by Start migration.
    In the Migration is taking place by New migration.

Output window

Display of errors, warnings and notifications.

Migrate reports and subscriptions

To migrate reports and subscriptions:

  1. For each desired object, activate the Migrate this object checkbox.
  2. Select the configuration for Migrate policy of the root item from the source server for folders.

    Note: At least one object must be able to be migrated

  3. Enter the required passwords in the Enter passwords node.

Parameters

Description

Step display

Display of the step to be configured.

Selection tree

Lists all reports available in Report Launcher.

In addition, the subscriptions configured for each report are displayed.

The Enter password node allows the input of all passwords required for the provision of passwords. Only present if there are subscriptions.

Title

Displays the name of the object to be migrated.

Migrate this item

Configuration of whether the selected object is migrated. Report themes, reports and subscriptions can be migrated.

  • Active: Object is migrated.
  • Inactive: Object is not migrated.

Status colors:

  • Yellow: Object has not been selected for migration or cannot be migrated due to dependencies.

Migrate policy of the root item from the source server.

Configuration for acceptance of authorizations.

  • Active: Authorization of the root element on the source server is transferred to target server.
  • Inactive: Authorization is taken on by superordinate element.

Dependencies of this item

Display of the dependencies for selected report or selected subscription.

Passwords

Entry of the passwords required for the migration of subscriptions.

Parameters

Description

Enter Passwords

Options for entry and validation of the passwords.

Migrate subscriptions with an empty password as inactive subscriptions

Process for a workaround, such as with subscriptions that do not have a password.

  • Active: Subscriptions with an empty password field are not migrated but are switched to inactive on the target server.
  • Inactive: For each subscription, the required password must be entered correctly and validated.

Enter Passwords

Entry of the passwords that are needed for subscriptions. For each password, a symbol with the validation result is displayed.

Display of validation result:

  • Green check mark: Validation successful
  • Magnifying glass: Validation not carried out
  • Red circle: Validation failed

Validate passwords for subscriptions

Clicking on the button starts the validation process.

The results are shown in the list of passwords.

Attention: If the user of a subscription is also the user who started the migration tool, access, including reading and writing, is also possible with an incorrect password.

Background: When creating the access structure, the operating system checks whether the current user context of the process already has access for the given user on the given path if the same user name is contained in the context and in the query. If this is the case, the user context of the process is used and not the user name and the password from the query.


Summary

zenon Analyzer -> Migration Tool -> Configuration -> Summary

All migration steps are displayed as a summary in the Overview step. You can check all configured steps here. Only objects activated for migration are displayed. Entries in the root directory are always displayed, even if they do not contain any objects to be migrated.

Change configuration

In order to change the configuration, use the Back button to go back to the desired step and amend the configuration. Then go back to the overview with the Next button.

Start migration

Click on the Start Migration button to start migration.
Attention: This process cannot be canceled!

Overview display

Structure

  • Source and target server:
    Subnodes: Configured server.
  • General Settings:
    Subnodes: A node each for general settings to be migrated.
  • Linked Server:
    Subnodes: a node each per Linked Server
  • Databases and database backup jobs:
    Subnodes: One database each per node and per database backup job.
  • Schedules:
    Subnodes: A subnode each per schedule.
  • Report Server objects:
    Subnodes: Report Server folder structure, starting with the root element.
    The subscriptions are not shown individually, but the number of subscriptions to be migrated per report is shown if this is greater than 0.


Migrating

zenon Analyzer -> Migration Tool -> Configuration -> Migrating

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The migration is carried out in this step.

attention Attention

The migration tool cannot be operated whilst the migration is carried out:

  • The Options dialog is blocked. Language switching is not possible.
  • All buttons are deactivated.
  • The user interface cannot be closed.

Attention: Do not end the process using the Task Manager either. In this case, the target server will remain in an undefined status.

Carry out migration

To start the migration:

  1. In the Overview step, click on the Start migration button.

    The migration is started. The process is visualized by means of a progress display.

    The result is displayed once the migration has been completed.

    Details can be found in the output window.

    If the process has been canceled by the tool, only the Back button is available.

    If the process has been completed successfully, only the New Migration button is available.

  2. Close the dialog with File -> Close or configure a new migration procedure by clicking on the New Migration button.

    If you start the migration again, the connection is separated and the first stage in the migration tool is called up.

Progress bar

The progress display consists of two progress bars:

  • The upper progress bar shows the overall progress of the migration.
  • The lower progress bar shows the progress of the respective partial step.
    The migration consists of 6 partial steps:
    • Connection test
    • Migration of the general settings
    • Migration of the linked servers
    • Migration of the databases and database backup jobs with the following substeps for databases:
      - Create backup on the source server
      - Move backup file from the source server to the target server
      - Restore backup on the target server
    • Migration of the schedules
    • Migration of the reports and subscriptions


Supplied report templates

zenon Analyzer -> Supplied report templates

With zenon Analyzer - depending on the licensing - pre-configured report templates are supplied for the creation of reports with ZAMS. Report templates are configured in ZAMS. You can find details on the input elements at the respective report template and in the Elements in the report area chapter.

Note for developers of reports: These reports use stored procedures and user-defined function blocks, that are described in the documentation for developers.

info Information

Handling with time interval for archive aggregation and display in the report:

  • Interval less or equal to 60 minutes:
    The correct time interval in UTC is noted for aggregation.
  • Interval greater than 60 minutes:
    The correct time interval in the server's local time is noted for aggregation.
  • Local time is always used for the display. If the user and server are in different time zones, there may be differences.

License report templates

Report templates must be licensed in order to be able to use them. Different license packages are available. You can find details on licenses for report themes and report templates form the price list or contact your COPA-DATA contact partner.

Supplied report templates

The following report templates are available:

Alarm and Events Analysis

Report templates for the evaluation of alarms and events.

  • Alarm List: Creates a list of alarms in table form for a time range.
  • Top N Alarms: Gets a defined number (N) of alarms that occur most frequently in a time range or have been active for the longest.
  • Alarm Aggregation: Gets the sum of all alarms triggered in a time range and adds up the duration of the different alarms
  • Event list: Creates a list of events in table form for a time range.
  • Top N Events: Gets a defined number (N) of events that occur most frequently in a time range.

Custom Formula Analysis

Report templates for custom formulas.

  • Custom Formula Trend: Trend display of user-defined formulas for a time range.
  • Custom Formula Trend Comparison: Trend display of user-defined formulas for two time ranges.
  • Custom Formula Aggregated Trend: Trend display of aggregated user-defined formulas for a time range.
  • Custom Formula Aggregated Trend Comparison: Trend display of aggregated user-defined formulas for two time ranges.
  • Custom Formula Aggregation: Trend display of aggregated, user-defined formulas for a time range.
  • Custom Formula Aggregation Comparison: Trend display of aggregated, user-defined formulas for two time ranges.

Historian Analysis

Report templates for the evaluation and direct or aggregated display of archive data.

  • Historian Trend: Gets archive data for a time range and displays this without aggregation in a trend
  • Historian Trend Comparison: Gets archive data for two time ranges and provides this without aggregation of each trend for comparison.
  • Historian Aggregated Trend: Gets archive data for a time range, aggregates this in intervals in the time range and displays it as a trend.
  • Historian Aggregated Trend Comparison: Gets archive data for two time ranges, aggregates this in intervals in the time range and displays it as a trend for comparison.
  • Historian Aggregated Trend with online variable selection: Gets archive data for a time range, aggregates this in intervals in the time range and displays these aggregations as a trend.
  • Historian Aggregated Trend Comparison with online variable selection: Gets archive data for two time ranges, aggregates these in intervals in the time range and provides these aggregations each in a separate trend per time range.
  • Historian Aggregation: Gets archive data for a time range, aggregates this and displays each of the aggregation results separately
  • Historian Aggregation Comparison: Gets archive data for two time ranges, aggregates this and displays each of the aggregation results for both time ranges separately
  • Historian Distribution: Gets archive data for a variable, rounds this up to a configurable rounding factor and displays the distribution of the values. In addition, the types of aggregation are calculated and displayed with markers.
  • Historian Distribution Comparison: Gets archive data for a variable from two time ranges, rounds this up to a configurable rounding factor and displays the distribution of the values. In addition, the types of aggregation are calculated and displayed with markers.

Efficiency Class Analysis

Report templates for efficiency analyses based on efficiency class models in conjunction with archives, equipment or user-defined formulas.

  • Archive based efficiency report: Carries out an efficincy analysis based on archive data for a certain time period.
  • Archive based efficiency comparison report: Carries out an comparative efficiency analysis based on archive data for two periods.
  • Equipment group based efficiency report: Carries out an efficiency analysis based on equipment groups for a time period.
  • Equipment group based efficiency comparison report: Carries out a comparative efficiency analysis based on equipment groups for two time periods.
  • Formula based efficiency report: Carries out a formula-based efficiency analysis for a certain time period.
  • Formula based efficiency comparison report: Carries out a comparative formula-based efficiency analysis for two time periods.

Energy Data Management

Report templates from the themes Historian analysis, Extended Historian analysis and ISO 50001 for the analysis of energy data management systems.

Historian Analysis:

  • Historian Trend
  • Historian Aggregated Trend with online variable selection
  • Historian Aggregation

Extended Historian Analysis:

  • Historian Trend with Equipment Group and Variable Selection
  • Historian Aggregated Trend per Equipment Group
  • Distribution per Variable
  • Cost Distribution per Variable Comparison
  • Cost Distribution per Equipment Model

ISO 50001:

  • Load Duration Curve with Variable Selection
  • Load Duration Curves for Equipment Groups

Extended Historian Analysis

Report templates for archive aggregation or archive distribution, taking into account prices, norm values and production counters.

  • Historian Trend with Equipment Group and Variable Selection: Creates a trend analysis without aggregation for a time period with a trend for each variable.
  • Historian Trend Comparison with Equipment Group and Variable Selection: Creates a trend analysis without aggregation for two time periods with a trend for each variable.
  • Historian Trend per Equipment Group: Creates a trend analysis without aggregation for a time period with a trend for each equipment group.
  • Historian Trend Comparison per Equipment Group: Creates a trend analysis without aggregation for two time periods with a trend for each equipment group.
  • Historian Aggregated Trend with Equipment Group and Variable Selection: Creates an aggregated trend analysis for a time period with a trend for each variable.
  • Historian Aggregated Trend Comparison with Equipment Group and Variable Selection: Creates an aggregated trend analysis for two time periods with a trend for each variable.
  • Historian Aggregated Trend per Equipment Group: Creates an aggregated trend analysis for a time period with a trend for each equipment model.
  • Historian Aggregated Trend Comparison per Equipment Group: Creates an aggregated trend analysis for two time periods with a trend for each equipment model.
  • Historian Trend with Equipment Group and Variable Selection: Calculates, for each variable, aggregated archive data for a time period with the aggregation functions sum, average, minimum and maximum.
  • Historian Trend Comparison with Equipment Group and Variable Selection: Calculates, for each variable, aggregated archive data for two time periods with the aggregation functions sum, average, minimum and maximum.
  • Historian Aggregation per Equipment Group: Calculates, for each equipment group, aggregated archive data for a time period with the aggregation functions sum, average, minimum and maximum.
  • Historian Aggregation Comparison per Equipment Group: Calculates, for each equipment group, aggregated archive data for two time periods with the aggregation functions sum, average, minimum and maximum.
  • Relative Historian Aggregated Trend with Equipment Group and Variable Selection: Creates a relative aggregated trend analysis for a time period with a trend for each variable.
  • Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection: Creates a relative aggregated trend analysis for two time periods with a trend for each variable.
  • Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard: Creates a relative aggregated trend analysis for a time period for a variable with a comparison with standard values.
  • Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard: Creates a relative aggregated trend analysis for two time periods for a variable with a comparison with standard values.
  • Relative Historian Aggregation with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for a time period that is based on variables.
  • Relative Historian Aggregation Comparison with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for two time periods that are based on variables.
  • Relative Historian Aggregation per Equipment Group: Calculates aggregated distribution data for equipment groups for a time period.
  • Relative Historian Aggregation Comparison per Equipment Group: Calculates aggregated distribution data for equipment groups for two time periods.
  • Cost Aggregation with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for a time period that is based on variables.
  • Cost Aggregation Comparison with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for two time periods that are based on variables.
  • Cost Aggregation per Equipment Group Calculates the aggregated cost distributions for a time period that is based on equipment models.
  • Cost Aggregation Comparison per Equipment Group: Calculates the aggregated cost distributions for two time periods that are based on equipment models.

ISO 50001

Report templates for ISO 50001:

  • Load Duration Curve with variable selection: Creates a load duration curve that is based on variable selection.
  • Load Duration Curve Comparison with variable selection: Creates a comparison between two load duration curves that is based on variable selection.
  • Load Duration Curve for Equipment Groups: Creates a load duration curve that is based on variable selection per equipment group.
  • Load Duration Curve Comparison for Equipment Groups: Creates a comparison between two load duration curves that is based on variable selection for each equipment group.
  • Carpet Plot: Gets and aggregates data for a carpet plot.
  • Sankey Diagram: Reads the Sankey definitions, gets data and aggregates it, integrates dynamic loss detection if required and displays the result as a diagram or table.
  • Sankey Diagram (double width): Displays the Sankey diagram in double width or places tables next to one another.

Plus all report templates from the Extended Historian Analysis and Custom Formula Analysis themes.

Production Analysis Line Based

Report templates for Production Analysis Line Based.

  • Gantt Chart: Analyzes lots, shifts and variables - specified through meanings, from AML, CEL or archive - and displays the results as a Gantt chart and as a table.
  • Gantt chart with area assignment: Analyzes lots, shifts and variables and displays the result as a Gantt chart and in table form. Variables are specified through meanings from AML, CEL or archive. Numerical values are assigned from classes derived from REMA-STATENAMES.
  • Line Losses Analysis (with lot tracking): Analyzes archive data and calculates aggregated loss times for a time period, based on an equipment group and a waterfall model.
  • Line Productivity Indicators Analysis (with lot tracking): Analyzes archive data and calculates aggregated productivity indicators for a time period, based on an equipment group.
  • Comprehensive Line Productivity Analysis (with lot tracking): Combines the Line Losses Analysis (with lot tracking) and Line Productivity Indicators Analysis (with lot tracking) templates.
  • Line Losses Analysis (without lot tracking): Analyzes archive data and calculates aggregated loss times for a time period, based on an equipment group and a waterfall model.
  • Line Productivity Indicators Analysis (without lot tracking): Analyzes archive data and calculates aggregated productivity indicators for a time period, based on an equipment group.
  • Comprehensive Line Productivity Analysis (without lot tracking): Combines the Line Losses Analysis (without lot tracking) and Line Productivity Indicators Analysis (without lot tracking) templates.
  • Line Losses Lot History (with lot tracking): Analyzes archive data and calculates aggregated loss times for each lot, based on an equipment group.
  • Line Productivity Indicators Lot History (with lot tracking): Analyzes archive data and calculates aggregated production indicators for each lot in a time period, based on an equipment group.
  • Comprehensive Line Productivity Lot History (with lot tracking): Combines the Line Losses Lot History (with lot tracking) and Line Productivity Indicators Lot History (with lot tracking) templates.

Production Analysis Machine Based

Report templates for the analysis of loss times and productivity, based on standards.

  • Losses Analysis: Analyze archive data and calculate aggregated loss times for a time period, based on an equipment group and a waterfall model.
  • Productivity Indicators Analysis: Analyze archive data and calculate aggregated productivity indicators for a time period, based on an equipment group.
  • Comprehensive Productivity Analysis: Combines the Losses Analysis and Produktivity indicators Analysis report templates.
  • Losses Lot History: Analyze archive data and calculate aggregated loss times for each lot, based on an equipment group.
  • Productivity Indicators Lot History: Analyze archive data and calculate aggregated production indicators for each lot in a time period, based on an equipment group.
  • Comprehensive Productivity Lot History: Combines the Losses Lot History and Productivity Indicators Lot History templates.

OEE Analysis

Report templates available that calculate and display OEE indicators.

  • OEE Indicator: Calculates the OEE performance figures for a selected equipment model in a time period and displays the performance figures in graphic form
  • OEE Indicator Lot History: Calculates the OEE indicators for a selected equipment model for each lot in a period of time and displays the performance figures in graphic form and table form

Target Actual Analysis

Reports for the comparison of any desired machine-related measured sizes.

  • Target Actual Aggregated Trend (absolute): Gets the target and actual values for the set meanings and the selected equipment group and calculates absolute counters from this.
  • Target Actual Aggregated Trend (relative): Gets the target and actual values for the set meanings and the selected equipment group and calculates relative counters from this.
  • Scatter Plot: Creates a scatter plot for the comparison of any desired machine-related measured sizes with set values.
  • Scatter Plot with Reference Curve: Creates a scatter plot of a value pair for a time period.

Hydroelectric Power Plant Analysis

Report templates that determine and display various counters for hydroelectric power plants.

  • Operating Time per Operation Mode and Machine Component: Calculates operating times for the individual operating modes of a machine and machine components.
  • Operating Time per Operation Mode or Frequency Control Mode: Calculates operating times for a machine including times in which the machine is running in either operating or frequency regulation mode.
  • Operating Time per Machine Component: Analyzes absolute operating times of components of an item of equipment or several items of equipment since they were last replaced and since they were last inspected.
  • Operating Time per Power Range: Calculates operating times for a machine per power range.
  • Circuit Breaker Switching Cycles (Switchyard single selection): Calculates switching cycles for circuit breakers with individual selection of equipment models.
  • Circuit Breaker Switching Cycles (Circuit Breaker multiple selection): Calculates switching cycles for circuit breakers with multiple selection of equipment models.
  • Active and Reactive Energy Meters (Parent Machine single selection): Calculates counter values for active and reactive power on the basis of an equipment group with subgroups.
  • Active and Reactive Energy Meters (Machine multiple selection): Calculates counter values for active and reactive power on the basis of selected equipment groups.
  • Power Line Frequency: Calculates time counters for different frequency bands of the network frequency of a machine.
  • Machine Event Counters (Machine single selection): Calculates counters for different events that may occur for a machine.
  • Set Point Change Event Counters (Machine multiple selection): Determines counters for different machine events: Switching on and off as well as changes to the set value.
  • Nozzle Mode Change Event Counters (Machine multiple selection): Determines counters for different machine events: Switching on and off as well as changes to the nozzle mode.
  • Load Shedding Active Power Ranges Event Counters (Machine multiple selection): Determines counters for different machine events: Switching on and off as well as load shedding in configurable active power ranges.
  • Load Shedding Turbine Speed Ranges Event Counters (Machine multiple selection): Determines counters for different machine events: Switching on and off as well as load shedding in configurable turbine speed ranges.
  • Machine Start Counters: Show starts of the machine sets for turbine and pump operation.

From Target Actual Analysis theme:

  • Scatter Plot: Creates a scatter plot for the comparison of any desired machine-related measured sizes with set values.
  • Scatter Plot with Reference Curve: Creates a scatter plot of a value pair for a time period.

Wind Power Plant Analysis

Report templates that determine and display various counters for wind power plants.

  • Wind Rose: Displays aggregated indicator values of equipment groups, grouped according to wind direction.

From Target Actual Analysis theme:

  • Scatter Plot: Creates a scatter plot for the comparison of any desired machine-related measured sizes with set values.
  • Scatter Plot with Reference Curve: Creates a scatter plot of a value pair for a time period.

Note on reports and actions with SP/UDF

When an SP or UDF of ZAMS is overwritten in the database, it is not present for the duration of this process. This can lead to errors when executing existing reports, if these access the SP or UDF at precisely the moment between deletion and recreation.

Recommendation: Do not execute any reports whilst actions are being carried out with ZAMS that relate to these reports. Most of all if ZAMS:

  • is deploying reports
  • is updating the connector functions in the database
  • is creating the SQL connector

Other topics in this chapter

Elements in the report area

Report templates

Metadata, stored procedures and user-defined function blocks


Elements in the report area

zenon Analyzer -> Supplied report templates -> Elements in the report area

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports are configured using different inputs. The possibilities for input depend on the RDL file and are automatically arranged. If the size of the window is exceeded, scroll bars are automatically displayed.

Note: Not all documented input possibilities are shown in the screenshot.

Depending on the report template loaded, different elements are displayed for the configuration of the report. Elements that are related to each other are arranged in input groups.

Entries in dialogs can generally also be confirmed and completed by pressing the Enter key.

Input groups

Input groups that consist of more than one element can be minimized.

  • To minimize a group, click on the - button in the top right corner of the group.
  • To maximize a group, click on the + button in the top right corner of the group.

Elements

The following inputs are possible for a report in ZAMS:

Archives

Archives

Aggregation and configuration of the archive. For details, see the Configure archives section.

Lot archive selection

Select a lot archive.

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)

maximum data (aggregated archive)

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.

Information on report templates

Information on report templates

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Miscellaneous

Action

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Selection equipment model

Selection of an Equipment model.

Input fields and drop-down lists

Various input fields and drop-down lists for the input of data and selection of parameters:

  • Single selection: Selection of a value from drop-down list:
  • Text input: Input of free text
  • Numerical input: Input of numerical values

For details, see Inputs and selection from drop-down list.

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Other topics in this chapter

Alarm filters and event filters

Alarm look back time

Alarm prefiltering

Equipment group labels

Equipment model selection

Equipment model - Tree expand level

Archives

Archive variable input

Archive variables and production counter

Target and actual value meanings

Scatter plot meanings

Custom formulas

Labels for operating modes

Labeling of circuit breakers

Lot archive selection

Lot times on equipment groups

Connector selection

Drop-down lists, inputs and selection

Efficiency classes

Event-prefiltering

Gantt Chart

Iterative data collection

Load shedding

Machine labels

Maximum Iterations for Lot Discovery

Availability gauge ranges

Decimal places

OEE calculation

Production data filters

Line production indicators

Machine production indicators

Visualize production loss times depending on projects

Visualize production loss times throughout projects

Carpet Plot Colors

RDL file - path

Report templates

Shift data origin

Element sort order

Variance tolerance for loss detection

Wind Rose configuration

XY axis configuration

Time filter

Component operating time assignments

Operating time assignments

Operating time per power range assignments

Machine start counter assignments

Switching cycles assignments

Active and reactive power counter assignments

Power line frequency assignments

Event counter assignments

Operating hours assignments for operating modes


Alarm filters and event filters

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Alarm filters and event filters

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the events or alarms to be displayed in the report from a pre-defined drop-down list.

Alarm filter

Alarm filter (dynamic)

Parameters

Description

Alarm filter (dynamic)

Selection of alarm filtering:

  • Project only
  • Project and alarm class
  • Project and alarm group
  • Project and equipment group
  • Project and alarm comment

Event filter

Parameters

Description

Event filter (dynamic)

Selection of event filtering from drop-down list:

  • Project only
  • Project and event class
  • Project and event group
  • Project and equipment group
  • Project and event comment


Alarm look back time

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Alarm look back time

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of a lookback time for alarms.

This allows alarms that have occurred before the start of the time filter but that still have an effect in the range of the time filter to be taken into account.

Parameters

Description

Alarm look back time

Time range, which should be taken into account from the start of the time filter retrospectively.

For details, see the Alarm Lookback time chapter.

Time input

Numerical input for the quantity. It is also possible to make changes using the spin control.

Selecting the granularity

Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years


Alarm prefiltering

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Alarm prefiltering

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Alarms can be prefiltered. The filtering includes:

  • Alarm groups
  • Alarm Classes

Both filters are connected to one another.

Prefiltering alarm groups

Activation via option: Alarm groups prefiltering

Parameters

Description

Alarm groups prefiltering

Filtering of the alarm groups by means of activation/deactivation of checkboxes.

List of alarm groups

This list is for prefiltering alarm groups. It contains a checkbox for each EVENTGROUP metadata table entry, with the entries being displayed in the VISUALNAME column.

Alarm group prefiltering is inactive if nothing is selected. If something is selected, only alarms of the active alarm groups are allowed through.

Select all

Activates all checkboxes, selection of alarm groups.

Deselect all

Deactivates all checkboxes, deselection of all alarm groups.

Prefiltering of alarm classes

Activation via option: Alarm classes prefiltering

Parameters

Description

Alarm classes prefiltering

Filtering of the alarm classes by means of activation/deactivation of checkboxes.

List of alarm classes

The list serves to prefilter alarm classes. It contains a checkbox for each EVENTCLASS metadata table entry, with the entries being displayed in the VISUALNAME column.

Alarm class prefiltering is inactive if nothing is selected. If something is selected, only alarms of the active alarm classes are allowed through.

Select all

Activates all checkboxes, selection of alarm classes.

Deselect all

Deactivates all checkboxes, deselection of all alarm classes.


Equipment group labels

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Equipment group labels

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of how equipment illustrations are to be shown.

Parameters

Description

Equipment group labels

Selection of the equipment identification from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name without parent elements

Default: Equipment group name without parent elements


Equipment model selection

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Equipment model selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of a root element of the equipment model from drop-down list. The equipment model is read form the metadata. An independent entry in the drop-down list allows the use of all models present in the list.


Equipment model - Tree expand level

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Equipment model - Tree expand level

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of how equipment groups are displayed in the Report Launcher when opening the drop-down list. The following are available:

  • Only the upper-most level
  • All levels
  • A defined depth of levels (up to 25)

Control element

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.


Archives

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Archives

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The archives to be aggregated and pivoted are configured using the following elements:

  • Aggregation function
  • Archive configuration

Parameters

Description

Archive aggregation configuration

Archive aggregation configuration

Aggregation function

The following are available for aggregation:

  • Summation
  • Calculate average values
  • Determine minimum values
  • Determine maximum values

Select from drop-down list.

Configuration of the archive

Display of the archive variables in a tree structure. This structure is constructed as follows:

  • Project name
  • Archive name
  • Variable name
  • Aggregation type of the variables in the archive

Selection by clicking on the desired object.

If the report is linked to a project via the parameters of the time filter, a check is made to ensure that only archives and variables from the project to which the report is linked are used.

Configure archives

Clicking on the button opens the dialog to select the archives and variables. For details, see the Configure archives section.

Configure archives

Clicking on the Configure archives button opens the dialog for configuring the archives. The size of the dialog can be changed by dragging it with the mouse. The division of the left and right (variable) space can be changed by dragging the dividing bar.

Parameters

Description

Projects

Selection from the list of available projects. These are taken from the metadata.

If the report is tied to a project (see Configuring time filter section) only the tied project can be seen.

Activation or deactivation of checkboxes influences the display of objects in other lists.

Archives

Display of all archives that are available in the projects selected in Projects.

Syntax: [project name]#[archive name] ([cycle time])

If an entry is activated or deactivated via the checkbox, the objects available in the Normalize to 1 second cycle time and Variables lists are updated.

Normalize to 1 second cycle time

Lists all archives activated in the previous list with the same display syntax.

Checkbox activated: The archive is accepted into the list, which is to be converted to a 1-second cycle.

Note: Activation only makes sense if time-corrected average values for variables from a spontaneous archive are to be displayed!

Variables

Lists all variables that are present in variables that have been activated in the Archives list.

  • Checkbox activated:
    The archive variables are accepted into the Archive configuration list in the report area.
  • Syntax: [Project name]#[Archive name] – [Variable name] ([Aggregation type], Text identifier)
    Note: Text identifier is only present for STRING variables.

OK

Applies changes and closes the dialog.

Cancel

Discards changes and closes the dialog.

Archives for string variables.

Recommendations for archives with text values that are used in reports:

  • Record on change or event triggered.
    Otherwise the same text value appears several times consecutively in the report.
  • In ZAMS, apply the option: Normalize to 1 second cycle time.

The following is applicable when aggregating texts:

  • Sequence: Sequence of archive time stamp.
  • Separator: \r\n (carriage return).
  • Empty text values are ignored.
  • Text values are not shown in diagrams.


Archive variable input

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Archive variable input

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The archive variables for Extended Historian Analysis reports are entered using a display and a configuration dialog.

Parameters

Description

Select archives and variables.
  • Display and configuration of the archive variables.

List field

Shows the current configuration.

Display schematic:

  • Project
  • Archive
  • Variable and data aggregation

Archive aggregation variable configuration

Clicking on the button opens the dialog to configure the archive variables for Extended Historian Reports.

If the report is tied to a project using the time filter settings, then the entries are filtered. Only archives and variables of the tied project can be displayed and configured.


Archive variables and production counter

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Archive variables and production counter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The archive variables for Extended Historian Analysis reports are entered using a display and a configuration dialog. Some of this type of report use the production counter to calculate relative consumers.

Parameters

Description

Production counter configuration

Settings for production counter.

List field

Overview table with information on:

  • Selected project
  • Selected equipment model
  • Assignment for the total production counter
  • Archive for counter variables
  • Compression function of the counter variables in the archive

Configure production counter

Clicking on the button opens the dialog for configuration of the product counter for Extended Historian reports.

If the report is tied to a project using the time filter settings, the project is accepted here.

Archive variables configuration

Settings for archive variables.

List field

Displays current configuration

Display schematic:

  • Project
  • Archive
  • Variable and data aggregation

Archive aggregation variable configuration

Clicking on the button opens the dialog to configure the archive variables for Extended Historian Reports.

The button is only active if the report was tied to a project via the upper grouping or the time filter settings.

Other topics in this chapter

Configuration of production counter

Archive variable configuration


Configuration of production counter

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Archive variables and production counter -> Configuration of production counter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The total production counter for Extended Historian Analysis report templates is configured using a dialog. This dialog is configured by clicking on the Configure production counter button in the ZAMS report window:

General

Parameters | Description
General | Selection of project and equipment model for the overall production counter.
Project | Selection of the project from the drop-down list. Deactivated if the report is tied to a project.

Equipment group

Parameters | Description
Equipment group | Selection of the equipment model.

Production counter variable

Parameters

Description

Production counter variable

Settings for meaning, archives and aggregation function.

Assignment of total unit counter

Input of the meaning for the counter variable for the total figure.

Default: TotalUnits

Set default configuration

Sets the values automatically:

  • Meaning: TotalUnits
  • Archive: Short description C1, if present in project
  • Aggregation function: Raw value

Validation

Parameters | Description
Validation | Starts validation of the configuration. Results are displayed in the list field.
List field | Displays results of the validation.
OK | Applies all changes and closes the dialog.
Cancel | Discards all changes and closes the dialog.


Archive variable configuration

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Archive variables and production counter -> Archive variable configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Archive variables for extended Extended Historian reports are configured using a dialog. The dialog is opened by clicking on the Configure archive button in the ZAMS report window.

Parameters

Description

Overview and manual configuration

Overview table of the current configuration with a display of:

  • Variable name
  • Archive name
  • Description

If a variable is selected in the overview table, the drop-down list with all archives in which the variable is kept are filled.

Archive for the selected variable

Selection of the archive configuration for the variables selected in the list.

The field below the drop-down list shows the description of the variables and the selected archive.

Automatic configuration

Settings for the automated configuration of all variables. There are different algorithms available for this:

  • Prefer the basis archive with the shortest cycle time
  • Prefer the aggregated archive with the longest cycle time
  • Prefer the archive whose cycle time is closest to the defined cycle time

Prefer the basis archive with the shortest cycle time

For maximum resolution.

Base archive with the lowest cycle time

Prefer the aggregated archive with the longest cycle time

For a minimum amount of data.

Aggregated archive with the longest cycle time.

Attention: Only the SUM compression type is used for the configuration in aggregated archives.

Prefer the archive whose cycle time is closest to the defined cycle time

User defined.

The archive with the cycle time that has the lowest difference to the target cycle time is used. In doing so, an archive with a lower cycle time than the target cycle time is considered better than an archive with a cycle time that is too long.

User-defined cycle time

Only available if the Prefer the archive whose cycle time is closest to the defined cycle time option has been activated.

Definition of cycle time.

There are three possibilities available to determine this:

  • 1 year
  • 1 month
  • User defined:
    days
    hours
    minutes
    seconds
    maximum: 1000 days

Execute automatic configuration

Clicking on the button starts the automated configuration.

OK

Clicking on the button accepts changes and closes the dialog.

Cancel

Clicking on the button discards the changes and closes the dialog.


Target and actual value meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Target and actual value meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This group shows the configured meanings for set values and actual values that are being searched for an equipment group, and allows these to be configured.

Parameters | Description
Target and actual value meanings | Display and configuration of the meanings for set points and actual values.
List of meanings | Table with the current settings for the meanings for the set points and actual values.
Configure target and actual value meanings | Clicking on the button opens the dialog for configuring the meanings.

Other topics in this chapter

Configure target and actual value meanings


Configure target and actual value meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Target and actual value meanings -> Configure target and actual value meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the meanings for set values and actual values.

Parameters

Description

Meaning for variables with set value

Enter the meaning for set values.

Meaning for variables with actual value

Enter the meaning for actual values.

Validate configuration

Clicking on the button checks the entries in both input fields.

The following is checked:

  • Whether the report is linked to a project or an equipment model
  • The equipment groups for which, with the meanings entered precisely, one variable each can be addressed

OK

Applies settings and closes the dialog.

Button is only available if all input fields are filled.

Cancel

Discards all changes and closes the dialog.


Scatter plot meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Scatter plot meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This group shows the configured meanings for indicators that are being searched for, for an equipment group, and allows these to be configured.

Parameters | Description
Meanings for indicators of the scatter plot | Display and configuration of the meaning for indicators.
Horizontal indicator meaning | Display of the meaning for the horizontal indicator.
Vertical indicator meaning | Display of the meaning for the vertical indicator.
Configure scatter plot | Clicking on the button opens the dialog for configuring the meanings.


Configure scatter plot

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Scatter plot meanings -> Configure scatter plot

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the scatter plot.

Parameters

Description

Meaning for x-axis indicator variable

Entry of the meaning for the indicator variable of the x-axis

This field must not be empty.

Meaning for y-axis indicator variable

Entry of the meaning for the indicator variable of the y-axis

This field must not be empty.

Validate configuration

Clicking on the button checks the entries in both input fields.

Criteria for positive validation:

  • Both options must have an entry.
  • Precisely one variable can be addressed for each of the two axes.

OK

Applies settings and closes the dialog.

Button is only available if all input fields are filled.

Cancel

Discards all changes and closes the dialog.


Custom formulas

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of custom formulas. Custom formulas can be configured for:

  • Reports without aggregation over the time range
  • Reports with aggregation over the time range

Parameters

Description

Custom formulas

List and buttons to display and configure user-defined formulas.

List of custom formulas

Display all configured user-defined formulas.

If individual colors are configured, these are displayed. Standard colors from the ZAMS color scheme are represented.

Attention: If the configuration of a formula is changed, the individual sorting is lost.

Configure custom formulas

Opens the dialog to configure user-defined formulas.

The dialog is different for:

  • Reports without aggregation over the time range
  • Reports with aggregation over the time range

Arrange and colorize formula results

Opens the dialog to sort and color user-defined formulas.

Note: Formulas can be exported and imported via XML. You can therefore easily transfer formulas from one report to another.

Other topics in this chapter

Configure custom formulas

Replacing variables and fields in calculated fields

Cleanup fields

Formula editor

Export and import formulas

Arrange and colorize formula results


Configure custom formulas

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This dialog is used for:

  • Custom formulas in reports
  • Calculated variables in calculated archives (Configuration of custom formulas without aggregation) only

The user interface of the dialog is slightly different for the two applications. Screenshots relate to use in reports with custom formulas. The differences are described in the description.

Custom formulas are used in the following types of reports:

  • Custom Formula Analysis.
    A distinction is made between:
    • Reports without aggregation over the time range
    • Reports with aggregation over the time range
  • Efficiency Class Analysis:
    In doing so, precisely one field must be marked as visible in the Aggregation fields tab or in the Calculated fields after aggregation tab, so that the report is validated as valid.

Configuration of custom formulas without aggregation

Parameters | Description
Variable selection | Selection of which fields are to be read with which variable values from which archives. With calculated variables: Optional selection of variable use.
Calculation of costs | Selection of which variable raw data fields should have cost fields.
Constant Fields | Definition of constant values.
Standard fields | Definition of standard fields. These can be applied during aggregation. Use in the report depends on the configuration.
Temperature normalization fields | Definition of the temperature normalization fields. These can be applied during aggregation. Use in the report depends on the configuration.
Calculated fields | Configuration of formulas with fields from the other tabs.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Configuration of custom formulas with aggregation

Parameters

Description

Variable selection

Selection of which fields are to be read with which variable values from which archives.

Costs calculation

Selection of which variable raw data fields should have cost fields.

Constant Fields

Definition of constant values.

Standard fields

Definition of standard fields.

These can be applied with calculated fields:

  • Before the aggregation
  • If the report does not contain any aggregation

Use in the report depends on the configuration.

Temperature normalization fields

Definition of the temperature normalization fields.

These can be applied during aggregation. Use in the report depends on the configuration.

Calculated fields before aggregation

Configuration of formulas with fields from the other tabs.

Aggregation fields

Configuration of aggregation from all fields of the previous tabs.

Calculated fields after aggregation

Configuration of formulas with fields from the Configuration fields tab.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Other topics in this chapter

Variable selection

Costs calculation

Constant Fields

Standard fields

Temperature normalization fields

Calculated fields

Calculated fields before aggregation

Aggregation fields

Calculated fields after aggregation


Variable selection

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Variable selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, which fields are to be read, and with which variable values, and from which archives is configured.

In the upper area of the tab, metadata is displayed; fields are displayed in the lower area.

Parameters

Description

Metadata area

Filtering and selecting the metadata.

Filter

Selection of the filters to be applied on the Metadata table. The following is available:

  • Project name
  • Archive name
  • Variable name
  • Measuring unit
  • Meanings
  • Equipment Groups

The filtering is carried out by entering a sequence of characters in the desired input fields. Clicking on the Apply button updates the list.

You can use wild cards here:

  • ?: precisely 1 desired character.
  • *: any desired number of any desired characters
  • If no wildcard is used, a * is automatically attached to the filter text.

The filters are linked with a logical AND. This means that a row must meet all filter criteria in order for it to be displayed.

Apply

Applies filter criteria to the Metadata table.

Delete

Deletes the content of all filter fields, resets the filter and displays all rows in the Metadata table.

Metadata table

Lists all existing metadata. These can be shown with filtering and added to the Field area.

Rows of the table can be highlighted for selection. Multiple-selection is possible using the key combination Ctrl+mouse click or shift+mouse click.

Add

Clicking adds a field in the field area for each row highlighted in the table. Variables can also be added by double clicking.

in doing so, a combination of variables, archive and aggregation of variables in the archive can always only occur once as a field. Attempts to add an existing combination again are ignored.

Add all

Clicking adds a field in the field area for each row visible in the table.

in doing so, a combination of variables, archive and aggregation of variables in the archive can always only occur once as a field. Attempts to add an existing combination again are ignored.

Invisible rows, which are suppressed by the filter, are ignored.

Field area

Contains a row for each field.

The following parameters are displayed:

  • Variable use:
    Stipulates if this field is visible in the report. Is not available for Formulas with aggregation.
    Variable use with calculated variables:
    Selection Field for calculated variable.
  • Data origin:
    Project name, archive name, variable name and aggregation of the variables in the archive are displayed.
  • Field name:
    Is used for the display of the field in other areas of this dialog and in the report. Standard: Variable name from the metadata.
  • Measuring unit:
    Measuring unit of the field.

Visible in report

Active: This field is visible in the report.

Default: Inactive

Is not available for Formulas with aggregation, because variable raw data fields cannot be visible with aggregation in the report.

Field name

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Default: Variable name from the metadata.
However if this would lead to a clash, a counter is added to the name.

Measuring unit

Measuring unit of the field.

Maximum: 256 characters

Default: Variable unit from the metadata.

X

Clicking on the button deletes the field.

If a different field relates to the field to be deleted, you are asked to confirm deletion beforehand. If this is confirmed, this field and all (including indirect) fields thereof are deleted.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.


Costs calculation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Costs calculation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, the variable raw data fields for which there are to be cost fields are defined.

Note: only variables that contain prices are displayed.

Parameters

Description

Table of fields

Table with fields to calculate costs.

Field name

Display of the field name from the variable selection.

Costs calculation

Active: There is a cost field for this variable raw data field.

If another field relates to this cost field and an attempt is made to set the checkbox to inactive, you are asked to confirm this. If the user confirms this, this cost field and all (including indirect) dependent fields are deleted.

Default: Inactive

The availability of the other fields depends on the status of the checkbox.

Cost field usage

Active: Cost field is visible in the report.

Default. Inactive

Is not available for Formulas with aggregation, because cost fields cannot be visible in the report.

Visibility for calculated variables:
Selection Field for calculated variable.

Costs field name

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Default: Variable name from the metadata to which this cost field is assigned.
However if this would lead to a clash, a counter is added to the name.

Currency

Stipulation of the unit (currency) of the cost field.

Maximum: 256 characters

Default: The first currency in the alphabet that is assigned to the variables in the metadata, from which the variable raw data field is fed in.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.


Constant Fields

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Constant Fields

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Constant values are defined in this tab.

Parameters

Description

List of fields

Lists all configured fields with constant values.

New

Clicking on the button adds a new line with a new constant.

Constant usage

Active: This field is visible in the report.

Default: Inactive

Is not available for Formulas with aggregation, because constant fields cannot be visible in the report.

Use of the constants with calculated variables:
Optional selection of field for calculated variable.

Constant name

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Default: Variable name from the metadata.
However if this would lead to a clash, a counter is added to the name.

Constant value

Input of the constant value.

  • Must not be empty.
  • Must contain a valid floating point number (whole numbers are valid floating point numbers).

Default: 1

Measuring unit

Determining the unit of the field.

Maximum: 256 characters

Default: empty

X

Clicking on the button deletes the field.

If a different field relates to the field to be deleted, you are asked to confirm deletion beforehand. If this is confirmed, this field and all (including indirect) fields thereof are deleted.

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.


Standard fields

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Standard fields

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the standard fields in this tab. A row is created for each of the standard definitions available in the database.

Parameters

Description

Standard name

Name of the standard field. Display only.

Related fields

Shows variables that are assigned to the standard field. The content that is displayed depends on the variables selected in the Variable Selection tab.

Standard field creation
  • Active: The standard field is created and is available for formulas.
  • Inactive: The standard field is not available for formulas. All other properties of the field remain inactive.

Standard field usage
  • Active: The field is visible in the report.

Standard field name

Entry of a name for the standard field.

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Measuring unit

Entry of a measuring unit for the standard field.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.


Temperature normalization fields

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Temperature normalization fields

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, the variable raw data fields for which there are to be temperature normalization fields are defined. it is possible to configure as many temperature normalization fields as you want.

Prerequisite: There must be at least one field for a variable with assigned degree day. There must also be at least one degree day definition.
For configuration, only the normalized fields of variables that were assigned a degree day are available

Parameters

Description

Use of normalization field name
  • Active: The field is visible in the report.
  • Use of the normalization field for calculated variables:
    Optional selection of field for calculated variable.

Visibility for calculated variables:
Selection Field for calculated variable.

Normalization field name

Entry of a name for the normalization field.

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Measuring unit

Entry of a measuring unit for the standard field.

Normalized field

Selection of the variables

Normalization type

There are three normalization types available: Select from drop-down list:

  • Local long term average:
    Long-term average of the assigned degree day. Degree day name cannot be configured.
  • External degree day:
    Current value of the selected degree day.
  • External long term average:
    Long-term average of the selected degree day.

Formula for all types: [normalized]= [original]*[comparison degree day]/[current degree day]
The following is applicable in the process: The current degree day is always the appropriate value of the assigned degree day at the value time stamp.

Degree day name

Selection of the degree day name from a drop-down list.

Is only available if, in the normalization type property, external degree day or external long-term means has been selected.

X

Clicking on the button deletes the field.

If a different field relates to the field to be deleted, you are asked to confirm deletion beforehand. If this is confirmed, this field and all (including indirect) fields thereof are deleted.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.


Calculated fields

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Calculated fields

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Only available for reports without aggregation.

Formulas for reports without aggregation over the time range are configured in this tab. These can use all the fields defined in the previous tabs. Each formula corresponds to a line in the list of formulas. In doing so, each formula can address all fields defined before it (lines above the line in question).

Parameters

Description

List of formulas

Lists all configured formulas.

Formula usage

Displays visibility in the report.

Use this field

Active: Formula is visible in the report.

Default. Inactive

Not available for Formulas with aggregation, because base data formula fields cannot be visible with aggregation in the report.

Use of the formula with calculated variables:
Optional selection of field for calculated variable.

Formula name

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Only once a valid name has been issued are all other elements unlocked for editing. There is always an empty line displayed, for entering a new formula.

In addition, a valid formula must be entered.

Measuring unit

Determining the unit of the field.

Maximum: 256 characters

Calculation formula

Preview screen of the formula. Displays the calculation formula set in the formula editor for this field. If the name of one of the fields referenced in the formula is changed, the preview screen is removed.

A formula must be configured for each formula name.

Symbol: Export Formulas

Opens the dialog to export formulas into an XML file.

Symbol: Import Formulas

Opens the dialog to import formulas from an XML file.

Symbol: Edit

Clicking on the button opens the formula editor to edit the formula.

Symbol: Delete

Clicking on the button deletes the field.

If a different field relates to the field to be deleted, you are asked to confirm deletion beforehand. If this is confirmed, this field and all (including indirect) fields thereof are deleted.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Sorting

When closing this dialog by clicking on OK, the element sorting is adjusted to the original element sorting. In doing so, the sorting numbers are recreated in accordance with the following criteria:

  • All elements that were already visible before the dialog was started and have not been deleted are retained in the sorting.
  • New visible elements are inserted behind these elements, with a consecutive number after their ID.

Example:

  • Basis:
    • Indicator1: ID = 3
    • Indicator2: ID = 2
    • Indicator3: ID = 1
  • Changes in the dialog:
    • Indicator2: is deleted.
    • Indicator0: is added and gets ID 1
    • Indicator4: is added and gets ID 4
  • Result:
    • Indicator1: ID = 3, but previous sorting = 1
    • Indicator3: ID = 2, but previous sorting = 3
    • Indicator0: ID = 1, no previous sorting

Indicator4: ID = 4, no previous sorting


Calculated fields before aggregation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Calculated fields before aggregation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Only available for reports with aggregation.

Formulas for reports with aggregation over the time range are configured in this tab. These can use all the fields defined in the previous tabs. Each formula corresponds to a line in the list of formulas. In doing so, each formula can address all fields defined before it (lines above the line in question).

Parameters

Description

List of formulas

Lists all configured formulas.

Formula name

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Only once a valid name has been issued are all other elements unlocked for editing. There is always an empty line displayed, for entering a new formula.

In addition, a valid formula must be entered.

Measuring unit

Determining the unit of the field.

Maximum: 256 characters

Calculation formula

Preview screen of the formula. Displays the calculation formula set in the formula editor for this field. If the name of one of the fields referenced in the formula is changed, the preview screen is removed.

A formula must be configured for each formula name.

Symbol: Export Formulas

Opens the dialog to export formulas into an XML file.

Symbol: Import Formulas

Opens the dialog to import formulas from an XML file.

Symbol: Edit

Clicking on the button opens the formula editor to edit the formula.

Symbol: Delete

Clicking on the button deletes the field.

If a different field relates to the field to be deleted, you are asked to confirm deletion beforehand. If this is confirmed, this field and all (including indirect) fields thereof are deleted.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Sorting

When closing this dialog by clicking on OK, the element sorting is adjusted to the original element sorting. In doing so, the sorting numbers are recreated in accordance with the following criteria:

  • All elements that were already visible before the dialog was started and have not been deleted are retained in the sorting.
  • New visible elements are inserted behind these elements, with a consecutive number after their ID.

Example:

  • Basis:
    • Indicator1: ID = 3
    • Indicator2: ID = 2
    • Indicator3: ID = 1
  • Changes in the dialog:
    • Indicator2: is deleted.
    • Indicator0: is added and gets ID 1
    • Indicator4: is added and gets ID 4
  • Result:
    • Indicator1: ID = 3, but previous sorting = 1
    • Indicator3: ID = 2, but previous sorting = 3
    • Indicator0: ID = 1, no previous sorting
    • Indicator4: ID = 4, no previous sorting


Aggregation fields

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Aggregation fields

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Only available for reports with aggregation.

Aggregations for fields from the previous tabs are configured in this tab. Each one is entered in its own row.

There are two types of row:

  • Constant Fields: Only have one subline for the constant aggregation.
  • All other fields: Have a subline each for the aggregation functions that are independent from one another:
    • Sum
    • Average
    • Minimum
    • Maximum

Parameters

Description

List of aggregations

Lists all configured aggregations.

Field name

Display of the field name of the aggregated field.

Active aggregation types

Display of the status of the aggregation types.

Checkbox in front of the active aggregation type: There is an aggregation field with this type of compression for this base data field

If another field relates to this aggregation field and an attempt is made to deactivate the checkbox, you are asked to confirm this. If the user confirms this, this aggregation field and all (including indirect) dependent fields are deleted.

Default: Checkbox inactive

The status of the checkbox determines whether the other input fields are active or not.

Aggregation field visibility

Shows if this aggregation field is visible in the report.

Active: Aggregation field is visible in the report.

Default: Inactive

Aggregation field name

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Default: Name of the base data field that is assigned to the archive If this would lead to a clash, a counter is added.

Aggregation field unit

Stipulation of the unit of the aggregation field.

Maximum: 256 characters

Default: Unit of the base data field.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.


Calculated fields after aggregation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Configure custom formulas -> Calculated fields after aggregation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Only available for reports with aggregation.

In this tab, formulas with fields from the Aggregation fields tab are configured. In doing so, each formula can address all fields defined before it (lines above the line in question).

Parameters

Description

List of formulas

Lists all configured formulas.

Formula visibility

Displays visibility in the report.

Visible in report

Active: Formula is visible in the report.

Default. Inactive

Not available for Formulas with aggregation, because base data formula fields cannot be visible with aggregation in the report.

Formula name

Is used for the display of the field in other areas of this dialog and in the report.

  • Must be unique.
  • Must not be empty.
  • Must not contain a comma

Maximum: 256 characters

Only once a valid name has been issued are all other elements unlocked for editing. There is always an empty line displayed, for entering a new formula.

In addition, a valid formula must be entered.

Measuring unit

Determining the unit of the field.

Maximum: 256 characters

Calculation formula

Preview screen of the formula. Displays the calculation formula set in the formula editor for this field. If the name of one of the fields referenced in the formula is changed, the preview screen is removed.

A formula must be configured for each formula name.

Symbol: Export Formulas

Opens the dialog to export formulas into an XML file.

Symbol: Import Formulas

Opens the dialog to import formulas from an XML file.

Symbol: Edit

Clicking on the button opens the formula editor to edit the formula.

Symbol: Delete

Clicking on the button deletes the field.

If a different field relates to the field to be deleted, you are asked to confirm deletion beforehand. If this is confirmed, this field and all (including indirect) fields thereof are deleted.

Navigation and maintenance

Parameters

Description

Previous

Switches to previous tab.
(Deactivated in the first tab)

Next

Switches to the next tab.
(Deactivated in the last tab)

Substitute fields

Opens the dialog to replace fields in calculated fields. Only available if there is at least one calculatable field.

If invalid variable assignments are detected when the Configure custom formulas dialog is opened, the dialog to replace these is opened automatically.

Cleanup fields

Opens the dialog to clean up fields.

OK

Applies all changes in all tabs and closes the dialog.

Only available if all necessary configuration has been carried out.

Cancel

Discards all changes in all tabs and closes the dialog. If data has already been entered, a request for confirmation is made before the changes are discarded.

Sorting

When closing this dialog by clicking on OK, the element sorting is adjusted to the original element sorting. In doing so, the sorting numbers are recreated in accordance with the following criteria:

  • All elements that were already visible before the dialog was started and have not been deleted are retained in the sorting.
  • New visible elements are inserted behind these elements, with a consecutive number after their ID.

Example:

  • Basis:
    • Indicator1: ID = 3
    • Indicator2: ID = 2
    • Indicator3: ID = 1
  • Changes in the dialog:
    • Indicator2: is deleted.
    • Indicator0: is added and gets ID 1
    • Indicator4: is added and gets ID 4
  • Result:
    • Indicator1: ID = 3, but previous sorting = 1
    • Indicator3: ID = 2, but previous sorting = 3
    • Indicator0: ID = 1, no previous sorting

Indicator4: ID = 4, no previous sorting


Replacing variables and fields in calculated fields

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Replacing variables and fields in calculated fields

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The dialog makes it possible to replace variables, standards or degree days that have been assigned to fields with other variables, standards or degree days.

The dialog is opened

  • Manually, by clicking on the Replace variables button in the Variable Selection tab.
    This button is only available if there is at least one field with assigned variables, standards or degree days.
  • Automatically if, when opening the Configure custom formulas dialog, invalid assignments are detected.
    A reference is invalid if the combination of archive, variable and aggregation used does not exist in the connected metadata database.
    The possible causes could be, among other things: Variables have been deleted from the database or the report is opened for another metadata database. If the automatically-opened dialog is closed, configuration is also ended. Invalid assignments must be removed from further configuration.
    Attention: Variables are identified by means of their ID, not their name.

Dialog to replace variables in calculated fields

The variables that are offered in the dialog depend on the variable fields that are required:

Variable | Condition
All: | No cost field. No temperature normalization field.
With degree day figures: | At least one temperature normalization field. No cost field.
With costs: | A cost field. No temperature normalization field.
With degree day figures and costs: | A cost field. At least one temperature normalization field.

Parameters

Description

Field name

Displays the field name for each element of the list.

Very long field names are shown in shortened form (suffix: ...). The complete text is shown in the tool tip.

Measuring unit

Displays the measuring unit of the field.

Very long measuring units are shown in shortened form (suffix: ...). The complete text is shown in the tool tip.

Field usage information

Shows which fields depend on this field.

Project and archive name

Selection of the archive from a drop-down list, from which the variable for this field is to be read. All available archives including project relationship are offered for selection.

Archive name syntax: [Projectname]#[Archivename]

Initial value when calling up, if the variable reference of the field:

  • invalid: empty
  • valid: The archive stated in the variable reference.

Note: Standard fields do not have a project reference.

Variables, standard or degree day name

Selection of the element from a drop-down list, from which the value for this field is to be read.

Notes for variables:
Only available for variables if an archive has been selected in the Project and archive name column. All variables recorded in the selected archive, including aggregation, are offered.

Variable name syntax: [Variablename] – [Aggregation type in the archive]

Each time a change is made to the Project and archive name column, the drop-down list is filled again and reset to no selection.
Initial value when called up:

  • Field reference invalid: empty
  • Field reference valid: The variable stated in the reference and aggregation type.

OK

Validates and closes the dialog.

In the event of a validation error, the dialog remains open and a message is shown accordingly.

Cancel

Cancels the replacement of variables.

If the dialog was opened automatically, the configuration of the user-defined errors is canceled after confirmation is requested.


Cleanup fields

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Cleanup fields

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The cleanup removes fields that are not required. As a result, the necessary data is obtained and calculated. It is most of all applied for performance optimization of the report on the server after preparation.

The following advantages can be obtained through the cleanup of the fields:

  • Less data needs to be obtained via the connector.
  • Fewer fields need to be calculated.
  • Less output data is to be displayed
  • An increased clarity of reports, because identical values for several columns or diagram lines can be avoided.

Cleanup fields

To clean up fields:

  1. Click, in the dialog for custom formulas, on the Cleanup fields button.

    A notification of the fields that are removed is displayed:

  2. Click on Yes

    The cleanup is carried out and information with the result of the cleanup is displayed.

  3. Click on Close.


Formula editor

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Formula editor

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The formula editor allows the creation of a formula.

Parameters

Description

Operations

Available operations. These can be moved by dragging & dropping into the Formula area.

Five groups of operations are available.

  • Basic operations
  • Mathematical operations
  • Rounding operations
  • Trigonometric operations
  • Aggregating operations

Details on the operations are shown hereafter.

Formula name

Name of the formula that is currently being created.

  • Must not be empty.
  • Must not be used by another formula.

Name is displayed in the Formula area.

Available operands

Fields that are available as operands. These can be moved to the respective input fields for operands by dragging & dropping them into the Formula area.

The list of operations can be filtered. Filtering is carried out by entering a sequence of characters in the input field. Each change of the filter text triggers a direct update.

You can use wild cards here:

  • ?: precisely 1 desired character.
  • *: any desired number of any desired characters
  • If no wildcard is used, a * is automatically attached to the filter text.

Formula area

Contains the Formula name and input fields for operations and operands. These input fields are populated by dragging & dropping.

Creation of a formula:

  • If an operation is placed by a drag & drop on the input field in the Formula area, this is replaced by the operation identifier and the input fields of the operation.
  • If an operand is placed on an input field in the Formula area, the field name replaces the input field.

A formula is valid if at least one operation is present and each operation has a sufficient number of assigned fields.

OK

Applies settings and closes the dialog.

To do this, the following criteria must be met:

  • valid name
  • valid formula

Cancel

Discards all changes and closes the dialog.

The size and position of the dialog can be changed. These settings are saved as user-dependent.

Creating formulas

To create formulas:

  1. Drag & drop an operation to the input field in the Formula area.

  2. The field shows the corresponding operation. New input fields are created.
  3. Move them by dragging & dropping them into the input fields:
    • New operations (this is how you create more complex formulas)

    • Desired operands
  4. Add further operations or operands until your formula is completed.

Example:

Rules for the formula editor

  • Brackets are automatically placed in the formula editor to clarify the method of calculation.
  • All brackets and slashes automatically scale their size, based on the fields and operations that are subordinate to them.
  • Fields that are still empty are automatically put in focus.

Resetting inputs

An input field can be reset to remove operations or operands.

Two working methods are available for this:

  1. Replacement of operations or operands by drag&drop:
    1. Drag a new operation or an operand to the existing field. If fields are already populated with data, the field that is to be replaced is shown with a border.
    2. By carrying out the drag&drop process, the fields with a border are emptied and replaced by the new operations or operands.
  2. Deletion of operands by means of keyboard commands
    1. Highlight a field with a left mouse click. The field is highlighted with a frame.
      Individual sections of a formula or the complete formula can be highlighted.
    2. Press the Del or Backspace key.
    3. The field is emptied or deleted.
      If the field is part of an aggregation operation, it is completely removed from an aggregation operation. Aggregation operations always offer an empty field at the right edge.

Examples for the highlighting of formula elements

  • Highlighting of an operand:

  • Highlighting of an operation:

  • Highlighting of the complete formula:

Operations

The following operations are possible in the formula editor:

  • Basic operations
  • Mathematical operations
  • Rounding operations
  • Trigonometric operations
  • Aggregating operations

Basic operations

  • Addition: Input field is replaced by two new input fields, separated by a plus sign (+).
  • Subtraction: Input field is replaced by two new input fields, separated by a minus sign (+).
  • Multiplication: Input field is replaced by two new input fields, separated by a multiplication sign (x).
  • Division/Fraction: Input field is replaced by two new input fields, separated by a fraction bar (-).

Mathematical operations

  • Absolute value: Input field is replaced by a function identifier, brackets and a new input field.
  • Power (of relation): Input field is replaced by a function identifier, a numerical field for the constant exponents, brackets and a new input field.
  • Root: Input field is replaced by a function identifier, a numerical field for the constant root order, brackets and a new input field.
  • Exponential function with Euler's number as a basis: Input field is replaced by a function identifier, brackets and a new input field.
  • exponential function: Input field is replaced by a function identifier, a numerical field for the constant base, brackets and a new input field.
  • Logarithm for the base of Euler's number: Input field is replaced by a function identifier, brackets and a new input field.
  • Base 10 logarithms: Input field is replaced by a function identifier, brackets and a new input field.
  • Logarithm: Input field is replaced by a function identifier, a numerical field for the constant base, brackets and a new input field.

Rounding operations

  • Rounding up to the next whole figure: Input field is replaced by a function identifier, brackets and a new input field.
  • Rounding down to the next whole figure: Input field is replaced by a function identifier, brackets and a new input field.
  • Round: Input field is replaced by a function identifier, a drop-down selection field for the precision, brackets and a new input field.

Trigonometric operations

  • Sine: Input field is replaced by a function identifier, brackets and a new input field.
  • Cosine: Input field is replaced by a function identifier, brackets and a new input field.
  • Tangent: Input field is replaced by a function identifier, brackets and a new input field.
  • Cotangent: Input field is replaced by a function identifier, brackets and a new input field.
  • Arcsine: Input field is replaced by a function identifier, brackets and a new input field.
  • Arcosine: Input field is replaced by a function identifier, brackets and a new input field.
  • Arctangent: Input field is replaced by a function identifier, brackets and a new input field.
  • Radians to Degrees: Input field is replaced by a function identifier, brackets and a new input field.
  • Degrees to Radians: Input field is replaced by a function identifier, brackets and a new input field.

Aggregating operations

  • Sum: Input field is replaced by a function identifier, brackets and a new input field. This is an operation with any desired number of operands. If something is moved to the new input field, an additional new input is provided.
  • Average: Input field is replaced by a function identifier, brackets and a new input field. This is an operation with any desired number of operands. If something is moved to the new input field, an additional new input is provided.
  • Minimum: Input field is replaced by a function identifier, brackets and a new input field. This is an operation with any desired number of operands. If something is moved to the new input field, an additional new input is provided.
  • Maximum: Input field is replaced by a function identifier, brackets and a new input field. This is an operation with any desired number of operands. If something is moved to the new input field, an additional new input is provided.


Export and import formulas

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Export and import formulas

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Import and export of formulas with XML makes it possible to transfer formulas from one report to another.
The following is applicable when importing formulas: The aggregation type must correspond.
That means:

  • An export file with formulas before aggregation or without aggregation can only be imported into a collection of formulas before aggregation.
  • An export file with formulas after aggregation can only be imported into a collection of formulas before aggregation.

The field definitions can be amended during import.

In the dialog for custom formulas, you can find the corresponding symbols in each tab, from which the formulas can be exported:

Clicking on the symbol opens the dialog to configure the XML export of formulas.

Clicking on the symbol opens the dialog to configure the XML import of formulas.

Other topics in this chapter

Export formulas into a file

Import formulas from file


Export formulas into a file

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Export and import formulas -> Export formulas into a file

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To export formulas:

  1. click on the symbol for the XML export.

    The dialog for the configuration of the export is opened.

  2. Select the desired formulas.

    Note: Dependent formulas are automatically selected and are grayed out.

  3. Click on the OK button.

    The file browser is opened

  4. Select the desired saving location
  5. Select the desired name for the XML export file.
  6. Close the export by clicking on OK.

Export formulas dialog

Parameters

Description

List of formulas

List of configured formulas. Select by clicking in the checkbox in front of a formula.

The following is displayed for each formula:

  • Export formula checkbox: Selection of a formula for export.
  • Formula name: Name of the formula.
  • Measuring unit: Linked measuring unit.
  • Calculation formula: Display of the formula.

If a formula that contains another formula is selected, the linked formula is also selected. The checkbox for the linked formula is deactivated.

Select all

Clicking on the button selects all formulas

Deselect all

Clicking on the button deselects all formulas.

OK

Accepts selection and opens the dialog to save the XML file.

Cancel

Discards configuration and closes the dialog. No formulas were exported.


Import formulas from file

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Export and import formulas -> Import formulas from file

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To import formulas:

  1. click on the symbol for the XML import.

    The dialog for selecting the file to be imported is opened:

  2. Select the desired XML file.
  3. The Import dialog is opened.
  4. Select the desired formulas.

    Note: Dependent formulas are automatically selected and are grayed out.

  5. Click on the OK button.

    The Interpret import data dialog is opened.

  6. In the Interpret fields tab, configure dependencies for the import.
    In the event of conflicts, decide which elements of a formula will be transferred or newly created.
  7. Check the configuration in the Check configuration tab.
  8. Close the export by clicking on the OK button

Import formulas dialog

Parameters

Description

List of formulas

List of formulas that are available for import. Select by clicking in the checkbox in front of a formula.

The following is displayed for each formula:

  • Import formula checkbox: Selection of a formula for import.
  • Formula name: Name of the formula.
  • Measuring unit: Linked measuring unit.
  • Calculation formula: Display of the formula.

If a formula that contains another formula is selected, the linked formula is also selected. The checkbox for the linked formula is deactivated.

Select all

Clicking on the button selects all formulas

Deselect all

Clicking on the button deselects all formulas.

OK

Accepts selection and opens the Interpret import data dialog for configuration of the variables and constants for import.

Cancel

Discards configuration and closes the dialog. No formulas are imported.

Interpret import data dialog

In this dialog, variables and constant fields are amended to the import. For each formula, you can decide whether existing fields are used or new ones are created. The dialog consists of two tabs:

  • Resolve fields: Selection of fields for the import.
  • Validate configuration: Summary of the configuration for the import.

The variables that are offered in the dialog depend on the variable fields that are required:

Variable | Condition
All: | No cost field. No temperature normalization field.
With degree day figures: | At least one temperature normalization field. No cost field.
With costs: | A cost field. No temperature normalization field.
With degree day figures and costs: | A cost field. At least one temperature normalization field.

Resolve fields

List of fields

Parameters

Description

Import field type

Display of the field type:

  • Variable
  • Standard field
  • Constant

Import field visual name

Visual name of the field to be imported.

Definition in imported file

Definition of the field in the import file.

Definition for import procedure

Definition of the field during import:

  • Use existing field:
    A pre-existing field is used for the import.
    The selection is made from the drop-down list.
  • Create new field:
    A new field is created in the report for the import.
    If a variable is imported, there are further fields available for the configuration:
    - Project
    - Equipment model group
    - Variable

Note: Variables for which there are already fields in the report are not available for the definition of new fields.

Navigation

Parameters | Description
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Accepts all changes, closes the dialog and imports the configured formulas. Only available if all necessary configuration has been carried out.
Cancel | Discards all changes and closes the dialog.

Validate configuration

Parameters | Description
Validate configuration | Text field lists all configured definitions for variables and constants. Changes can be made in the Interpret fields tab.

Navigation

Parameters | Description
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Accepts all changes, closes the dialog and imports the configured formulas. Only available if all necessary configuration has been carried out.
Cancel | Discards all changes and closes the dialog.


Arrange and colorize formula results

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Custom formulas -> Arrange and colorize formula results

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this dialog, you can color custom formulas and sort their sequence.

To open the dialog:

  1. In the Custom formulas group, click on the Arrange and colorize formula results group
  2. The dialog is opened

Each visible formula is represented by a line in the list. The sequence of the formulas in this dialog also defines their sequence for display in ZAMS and in actual charts and tables in the report.

Parameters

Description

Formula names

Name of the formula.

Standard coloring

The status of the checkbox defines whether the formula is assigned its color from the respective graphics object from the colors of the ZAMS color scheme or if it receives individual coloring.

  • Active: Standard colors from the ZAMS color scheme are used.
  • Inactive: Individual colors are used.
    The Color and Color preview buttons are shown for configuration purposes.

Color preview

Display of the color defined individually for this formula.

Initial value: White

Color

Click on the color to open the standard color palette for selecting a color.

In the dialog, the 10 standard colors from the active ZAMS color scheme are offered as Userdefined color schemes.

Cursor keys

Clicking on a button changes the sequence of the highlighted formula. A formula is highlighted if the complete line is highlighted or an element in the line is selected.

Action:

  • Clicking on the first arrow key moves the formula up one position. If the formula is already in the top line, the arrow key remains inactive.
  • Clicking on the second arrow key moves the formula down one position. If the formula is already in the bottom line, the arrow key remains inactive.

Attention: If the configuration of a formula is changed, the individual sorting is lost.

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Labels for operating modes

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Labels for operating modes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This grouping is for the selection of the labeling for operating modes.

Parameters

Description

Origin of operation mode labels

Selection of the marking for operating modes from drop-down list:

  • Variable visual name
  • Descriptive text for the variables


Labeling of circuit breakers

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Labeling of circuit breakers

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This grouping is for the selection of the labeling for circuit breaker.

Parameters

Description

Origin of circuit breaker labels

Selection of the identification for circuit breakers from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements
  • Relative counter variable visual name
  • Relative counter variable description text


Lot archive selection

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Lot archive selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the lot archive from the drop-down list for the comparison of OEE indicators.

Parameters | Description
Lot archive selection | Configuration of the lot archive.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Lot archive | Selection of a lot archive for the selected project from the drop-down list.


Lot times on equipment groups

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Lot times on equipment groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the lot time table for equipment groups.

Parameters

Description

Lot times on equipment groups

Selection of the lot time table from a drop-down list:

  • Lot time table
  • No lot time table

Default: Lot time table


Connector selection

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Connector selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of a connector from the drop-down list.

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)


Drop-down lists, inputs and selection

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Drop-down lists, inputs and selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Input fields and drop-down lists allow input of text, numerical values and given elements:

  • Single selection: Selection of a value from drop-down list:
  • Text input: Input of free text
  • Numerical input: Entering numeric values

Selection of an individual entry

Selection of an entry from a list of given values.

Examples:

  • Data representation:
    Selection of the display of data from the drop-down list.
    • Line chart and pivot table
    • Column chart and pivot table
    • Line chart
    • Column chart
    • Pivot table
  • Archive compression selection:
    Selection of the type of aggregation for the variables stored in the archive:
    • Raw value
    • Sum
    • Average
    • Minimum
    • Maximum

Text input

Free input of text in the text field.

Numeric input

Input of numeric values.

The values can also be increased or reduced with the spin control. Minimum and maximum values and an increase or reduction using the spin control and display of decimal points is defined by the report developer.


Efficiency classes

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Efficiency classes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For the configuration of efficiency classes, there are different input modules available depending on the report type:

  • Efficiency class diagram visualisation
  • Efficiency class formula and filter configuration
  • Efficiency class model and variable filtering

Other topics in this chapter

Efficiency class diagram visualisation

Efficiency class formula and filter configuration

Efficiency class model and variable filtering


Efficiency class diagram visualisation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Efficiency classes -> Efficiency class diagram visualisation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of how diagrams of the efficiency classes are displayed.

Parameters

Description

Efficiency class diagram visualisation

Properties for the configuration of the diagram display for efficiency classes.

Show separator line
  • Active: A dividing line is displayed in the report between the efficiency class arrows and the assignment arrow.

Show assignment line
  • Active: An assignment line from the assignment arrow to the respective efficiency class arrow is displayed in the report.

Placement of the assignment indicator

Configuration of where the assignment arrow is drawn. Select from drop-down list:

  • Sliding inside efficiency class:
    The assignment arrow is moved within the assigned class in such a way that it reflects the position of the value within the class.
  • Centered to assigned efficiency class:
    The assignment arrow is always precisely pointed towards the assigned class.

Efficiency class labels

Configuration of the labeling of the arrows in the report. Select from drop-down list:

Defines how the arrows in the CRI are to be labeled:

  • Class name and boundaries
    Class name and class boundaries
  • Class name only: Class name
  • Class boundaries only: Class boundaries


Efficiency class formula and filter configuration

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Efficiency classes -> Efficiency class formula and filter configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the efficiency class formula and its filtering. The Configure custom formulas dialog is used to create formulas.

Parameters

Description

Efficiency class formula and filter configuration

Configuration of the efficiency class formula and its filtering.

Formula

Displays the visual name of the field in the report that is currently active. This is configured in the dialog to configure user-defined formulas with aggregation after clicking on the Configure formula button.

Configure formula

Clicking on the button opens the dialog to configure user-defined formulas with aggregation.

When clicking on OK, precisely one field must be marked as visible in the Aggregation fields tab or in the Calculated fields according to aggregation carried out tab.

Filter for efficiency class model names

Entry of the filter for the display names of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter for efficiency class model based on measuring unit of the efficiency class model

Active: The unit of the active field is used for the filtering of the efficiency class model list.


Efficiency class model and variable filtering

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Efficiency classes -> Efficiency class model and variable filtering

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of efficiency class model and variable filter.

Parameters

Description

Efficiency class model and variable filtering

Properties for the configuration of efficiency class model and variable filter.

Filter for efficiency class model names

Entry of the filter for the display names of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.

Several consecutive * characters are compressed into one.

Filter for efficiency class model measuring unit

Entry of the filter for the units of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter variables based on measuring unit
  • Active: Variable list is filtered in the report when executing in Report Launcher on the basis of the unit of the selected efficiency class model.


Event-prefiltering

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Event-prefiltering

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Results can be pre-filtered. The filtering includes:

  • Event groups
  • Event classes
  • Event type

attention Attention

Only the filtering for event type can include system events.

Prefiltering and filtering for event classes cannot be applied to system events. This prefiltering and filtering is always only applied to events for known variables and events for unknown variables.

Prefiltering of event groups

Activation via option: Event groups prefilter

Parameters

Description

Event groups prefilter

Properties for prefiltering the event groups.

Enable event groups prefiltering

Active: The list of the event group prefilters can be configured and used.

List of event groups

This list is for prefiltering event groups. It contains a checkbox for each EVENTGROUP metadata table entry, with the entries being displayed in the VISUALNAME column.

Event class prefiltering is inactive if nothing is selected. If something is selected, only events of the active event groups are allowed through.

Select all

Activates all checkboxes, selection of event groups.

Deselect all

Deactivates all checkboxes, deselection of all event groups.

Prefiltering of event classes

Activation via option: Event class prefilter

Parameters

Description

Event class prefilter

Properties for prefiltering the event classes.

Enable event class prefiltering

Active: The list of the event group prefilters can be configured and used.

List of event classes

The list serves to prefilter event classes. It contains a checkbox for each EVENTCLASS metadata table entry, with the entries being displayed in the VISUALNAME column.

Event class prefiltering is inactive if nothing is selected. If something is selected, only events of the active event classes are allowed through.

Select all

Activates all checkboxes, selection of event classes.

Deselect all

Deactivates all checkboxes, deselection of all event classes.

Prefiltering of event type

Activation via option: Event type selection

Parameters

Description

Events for known variables
  • Active: Event class for variables that exist in the database are included.

Events for unknown variables
  • Active: Events for variables that do not exist in the database are included.

System events
  • Active: System events are included.

Note: At least one event type must be selected.


Gantt Chart

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Gantt Chart

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The control element consists of a display of the current settings and a button to configure these settings.

Parameters | Description
Display settings | Display of the current settings for the Gantt diagram.
Configure gantt chart analysis | The dialog to configure the Gantt analysis is started by clicking on the button. For details, see Gantt-Diagram.

Configuring Gantt chart analysis

The Gantt chart analysis is configured with the following dialog:

To configure the analysis:

  1. Click, in the control element in the report template, on the Configure gantt chart analysis button.
  2. Configure the tabs:
    • Shifts and lots
    • Analysis groups
    • Chart settings
    • Validation
  3. Close the dialog by clicking on OK.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Shifts and lots

Analysis groups

Chart settings

Validation


Shifts and lots

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Gantt Chart -> Shifts and lots

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The inclusion of shifts and lots into the Gantt analysis is configured in this tab.

Parameters

Description

Include shifts in analysis

Selection from a drop-down list of how shifts are included in the Gantt analysis:

  • Not included: A search for shifts is carried out.
  • Included for the selected equipment group: A search is only carried out for shifts in the equipment group selected in the report.
  • Included for all equipment groups: A search is carried out for shifts for all active equipment groups in the analysis.

Label for shift analysis group

Defines visual name for the analysis group for shifts of a plant. Free entry in the text field.

Only available if not included has not been selected for Include shifts in analysis

Connector for shift data

Selection of the connector to get shift data from a drop-down list.

Include lots in analysis

Selection from a drop-down list of how lots are included in the Gantt analysis:

  • Not included: Lots can also be searched for.
  • Included for the selected equipment group: A search is only carried out for lots in the equipment group selected in the report.
  • Included for all equipment groups: A search is carried out for lots for all active equipment groups in the analysis.

Label for lot analysis group

Defines visual name for the analysis group for lots of a plant. Free entry in the text field.

Only available if not included has not been selected for Include lots in analysis

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Analysis groups

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Gantt Chart -> Analysis groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The analysis groups are configured in this tab. Each analysis group means a line in the Gantt diagram or a grouping at the lower grouping level of a table. The complete name of an analysis group always follows the syntax [equipment group name]: [analysis group name].

Parameters

Description

Data source for analysis group

Selection of the data source for the analysis groups from a drop-down list:

  • Alarm Message List
  • Chronological Event List
  • Archives

Analysis group label

Entry of the visual name of an analysis group.

Meaning

Entry of the meaning for the variable whose events are to be analyzed in the analysis group.
Corresponds to Resources label property in Value attributes group up to zenon 7,11; Meaning property in Analyzer group from zenon 7.20.

Add

Clicking this adds the analysis group defined with the fields Analysis group label and meaning to the List of analysis groups if the following conditions are met:

  • Both fields have content
  • There are still not any analysis groups with the visual names entered
  • There are still not any analysis groups with the meaning entered

List of analysis groups

All defined analysis groups are listed here. The display sequence in this table corresponds to the sequence in the Gantt diagram or in the tables in the report.

Multiple selection is possible.

Cursor keys

Sequence of analysis groups in the list. Click on:

  • Arrow upwards: all highlighted analysis groups are moved up one place
  • Arrow downwards: all highlighted analysis groups are moved down one place

Delete

Clicking on the button deletes all analysis groups highlighted in the list without requesting confirmation.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Chart settings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Gantt Chart -> Chart settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The diagram settings are configured in this tab.

Parameters

Description

Show state name in the gantt chart

Stipulation of the display; whether for variables with numeric values that are to be converted to states via a reaction matrix, the limit value text from the REMA is to be displayed in the Gantt chart.

First alternating color for text based analysis groups

Display of the selected first alternating color for events of analysis groups for shifts, lots and variables with string values.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Second alternating color for text based analysis groups

Display of the selected second alternating color for events of analysis groups for shifts, lots and variables with string values.

Choose color

Selection of the color. Clicking on the button opens the standard selection dialog in the language of the operating system.

Equipment group sorting

Selection from a drop-down list of how the equipment groups of a level (same superordinate equipment group) are to be sorted:

  • Same order as in database: Each [ID] column in the [EQUIPMENT] table is sorted in ascending order.
  • Inverse database order: Each [ID] column in the [EQUIPMENT] table is sorted in descending order.
  • Ascending sort per equipment group name: Sorting is carried out in according to the visual names in ascending order.
  • Descending sort per equipment group name: Sorting is carried out in according to the visual names in descending order.
  • Ascending sort per equipment information Sorting is carried out in ascending order according to the numerical value of one of the fields assigned to the equipment group in the EQUIPMENTINFO table. Equipment groups that are not assigned to such a field are filtered out.
  • Descending sort per equipment information: Sorting is carried out in descending order according to the numerical value of one of the fields assigned to the equipment group in the EQUIPMENTINFO table. Equipment groups that are not assigned to such a field are filtered out.

Equipment identification field for sorting

Entry of the character sequence for equipment identification, which the element for the sorting value is to be searched for in the EQUIPMENTINFO table.

Only available if, in equipment group sorting, either Ascending sort per equipment information or Descending sort per equipment information has been selected.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Gantt Chart -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The entries are validated in this tab.

The following applies for validation:

  1. A value must be selected or entered in all active input elements in the other tabs.
    Exception: Analysis group label and Meaning in the Analysis groups tab.
  2. There must be at least one analysis group defined.
  3. If one of the previous conditions is not met, it is canceled.
    If conditions 1 and 2 are met, then the following points are checked for each of the equipment groups:
    1. If the equipment model filter in the report is active, the equipment group must be assigned to the selected model.
    2. The equipment group must be assigned at least one variable with one of the meanings of the analysis groups. In doing so, the data source and any possible projects that are tied to the report are taken into account.
    3. If sorting with use of a fields in the EQUPMENTINFO table has been selected, the equipment group must be assigned such a field with a numerical value and the given identification.

Parameters | Description
List | All messages for validation and a completion message with the number of analyzable equipment groups are written to the list. The listbox does not allow the selection of entries.

Navigation

Button | Description
Previous | Switches to the previous tab. Inactive in the first tab.
Next | Switches to the next tab. Inactive in the last tab.
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Iterative data collection

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Iterative data collection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Allows the configuration of an interval and the abort time stamp for the iterative data collation by stored procedures.

This configuration is necessary for archives with record on change. With these archives, it is possible that variables in the period under review do not have a value. That would lead to an undefined or incorrect result.

If all variables have not yet given valid values in the period under review then older data is read with retroactive effect for interactive data collection. This happens interactively in the Iteration interval until each variable has a valid value. If no valid value can be found up to the time stamp cancel, a 0 is assumed as a replacement.

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time

Default: 01.01.2013 00:00:00


Load shedding

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Load shedding

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For report templates for hydro-electric power plants, there are elements for searching according to active power and turbine speed after load shedding.

Elements

Load shedding: Active power lookback seconds

Parameters

Description

Load shedding: Active power lookback seconds

Selection of the number of seconds for how far before load shedding the maximum active power at the time of load shedding is searched for.

Formula: Active power = Max(active power) from time range (load shedding – configured seconds) until load shedding.

Load shedding: Turbine speed lookfront seconds

Parameters

Description

Load shedding: Turbine speed lookfront seconds

Selection of the number of seconds for how far, after load shedding, the maximum turbine speed at the time of load shedding is searched for.

Formula: Load shedding turbine speed = Max(turbine speed) from time period up to (load shedding + configured seconds).


Machine labels

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Machine labels

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the machine labels from the drop-down list.

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements


Maximum Iterations for Lot Discovery

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Maximum Iterations for Lot Discovery

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the maximum iteration for lot detection.

Parameters

Description

Maximum Iterations for Lot Discovery

Configuration of the maximum iteration for lot detection. Direct entry in the field or selection using the cursor keys. Clicking on an arrow increase or reduces the selected figure by the value 1.

  • Maximum: 10
  • Minimum: 1

Default: 3


Availability gauge ranges

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Availability gauge ranges

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration and display for measurement device color areas. The elements can be used in a report for different areas.

Parameters

Description

Availability gauge ranges

Configuration of the color ranges:

  • Low range
  • Medium range
  • High range

The upper limit of the low range is the lower value of the high range. The lower limit of the high range is the upper value of the low range. Both limits are inclusive limits. Both elements can be set to the same value. In this case, there is no medium range. The lower limit for the low range and the upper limit for the high range come from the report template.

Low range goes until

Defines the limit between the low (red) and medium (yellow) range in the measuring device.

High range starts at

Defines the limit between the medium (yellow) and high (green) range in the measuring device.

Display of the areas.

Preview of the configured color ranges.


Decimal places

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Decimal places

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Stipulation of the decimal places for the counters of a report.

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.


OEE calculation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> OEE calculation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Clicking on the Configure assignments button in the ZAMS dialog for variable assignments for OEE calculation opens a dialog for the assignment of projects, archives and variables:

Parameters

Description

Project

Selection of a project from the drop-down list.

The corresponding archives are available, depending on the project.

Basic variables for calculation

Configuration of the variables for the OEE calculation.

Archive for basic calculation variables

Selection of a non-cyclical archive.

Assignment of planned production time

Assignment of the variables for the planned production time.

Default: EffectiveWorkingTime

Assignment of real production time

Assignment of the variables for the actual production time.

Default: Operating Time

Assignment of construction speed

Assignment of the variables for the planned equipment speed.

Default: DesignedSpeed

Counter variables

Configuration of the counter variables.

Archive for counter variables

Selection of a cyclical archive.

Assignment of total unit counter

Assignment of the variables for the total production quantity.

Default: TotalUnits

Assignment of good unit counter

Assignment of the variables for the total quantity of good units produced.

Default: GoodUnits

Set default assignments and archives

Clicking on the button enters the standard configuration for assignments and archives.

Validation

Validation of the configuration entered

Validate configuration

Clicking on the button checks:

  • Are all input fields populated?
  • For how many and which equipment models is it possible to calculate the OEE key figures with the given configuration?

The result of checking is shown in the input field.

OK

Accepts all inputs and closes dialog.

Cancel

Discards all changes and closes dialog.

Note:

  • The term Assignment corresponds to the Meaning table column.
  • OEE calculations require the corresponding configuration in zenon.


Production data filters

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Production data filters

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration and display of the optional data filtering for Production Analysis Line Based and Production Analysis Machine Based. Both configurations differ in terms of project connection and validation in the dialog.

Production Analysis Line Based

With Production Analysis Line Based, there must be no project connection.

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production Analysis Machine Based

With Production Analysis Machine Based, project connection is mandatory.

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters. Note: To be able to switch the dialog, a project must be selected in the configuration.

Other topics in this chapter

Configuration of data filter


Configuration of data filter

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Production data filters -> Configuration of data filter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

With this dialog:

  • Data filters, if present, are activated or deactivated
  • Enter meaning, which is used for addressing the variables for this data filtering

Parameters

Description

Data filter type

Activation and deactivation of the data filter types.

Meaning for data filter variable

Enter the meaning for data filter variables.

The input field is only active if the checkbox in front of it is active. If the input field is empty when the checkbox is activated, it is populated with the standard value for the meaning.

Pallet type

  • Active: It is filtered according to the pallet type.

The input field next to the checkbox is for entering the meaning (Meaning) for the addressing of the variables for this filter.

Crate type

  • Active: It is filtered according to the crate type.

The input field next to the checkbox is for entering the meaning (Meaning) for the addressing of the variables for this filter.

Bottle type

  • Active: It is filtered according to the bottle type.

The input field next to the checkbox is for entering the meaning (Meaning) for the addressing of the variables for this filter.

Bottling tank number
  • Active: It is filtered according to the bottling tank number.

The input field next to the checkbox is for entering the meaning (Meaning) for the addressing of the variables for this filter.

Validate configuration

Clicking on the button validates the inputs and provides the results in the list field. For further details see chapter Validation.

OK

Applies settings and closes the dialog. If one of the input fields is activated but empty, the button is not shown.

Cancel

Discards all changes and closes the dialog.

Validation

The checks carried out during validation depend on the type of production analysis:

Production Analysis Line Based

The following is checked during validation:

  • Equipment groups with subgroups: Are there variables for each active filter for all subgroups?

There is no check of the individual equipment groups to see that they are usable.

Production Analysis Machine Based

The following is checked during validation:

  • Is the report linked to a project or an equipment model?
  • For which equipment groups can precisely one variable each per active filter be addressed with the meanings entered?


Line production indicators

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Line production indicators

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration and display of the indicators for lines and the initial variables for their calculation.

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Other topics in this chapter

Configuration indicators


Configuration indicators

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Line production indicators -> Configuration indicators

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The indicators are configured in four tabs:

  • Mandatory indicator meaning
  • Optional indicators
  • Optional indicator meaning
  • Validation

Mandatory indicator meaning

Parameters | Description
Field in formula | Time counters for the formula. Meanings must be set for these, because the attendant variables are needed for the main indicators.
Meaning | Input of the meaning for the addressing of the variables for the following time counters. If one of the input fields is empty when the dialog is called up, it is filled with the standard value.
Loading time | Meaning for planned running time of the main machine. Default: LoadingTime
Operating time | Meaning for actual running time of the main machine. Sum of effective running time and downtimes. Default: OperatingTime
Net operating time | Meaning for productivity running time without speed losses from the main machine. Default: NetOperatingTime
Valuable operating time | Meaning for productivity running time without quality losses from the main machine. Result of the net operating time minus losses due to a lack of quality or damage. Default: ValuableOperatingTime
Scrap time (side equipment groups) | Meaning for loss times of the auxiliary machines. Default: ScrapTime
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Optional indicators

Optional indicators are activated and deactivated using this tab.

Parameters

Description

Activation of the optional indicators

The following indicators can be activated or deactivated as required by activating the checkboxes:

  • Total units
  • Good units
  • Average output
  • Degree of utilisation
  • Effective output
  • Line efficiency
  • Line delivery efficiency

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

The button is deactivated if one of the required input fields is empty or not configured correctly.

Cancel

Discards all changes in all tabs and closes the dialog.

Optional indicator meaning

Parameters

Description

Field in formula

Fields for the formula. Meanings must be set for these if the indicators are to be used.

  • Total units
  • Good units
  • Scrap quantity (side equipment groups)
  • Filled and sealed units
  • Work time
  • General running time
  • Machine nominal output
  • Machine set output

Meaning

Input of the meaning for the addressing of the variables for the following indicators. The input field is only active if at least one of the indicators that uses the field that is assigned to the input field is active.

If one of the input fields is empty when the dialog is called up, it is filled with the standard value.

Field

Used by

Total units

Meaning for total production of the main machine.
Only available if the Total amount indicator has been activated.

Default: Total Units

Good units

Meaning for good units from the main machine.
Only available if the Good units indicator has been activated.

Default: Good Units

Scrap quantity (side equipment groups)

Meaning for amount of loss due to quality of the auxiliary machines.
Only available if at least one of the indicators Good units, Average output or Effective output have been activated.

Default: ScrapQuantity

Filled and sealed units

Meaning for good units of the main machine.
Only available if at least one of the indicators Average output or Effective output have been activated.

Default: FilledAndSealedUnits

Work time

Meaning for working time of the main machine.
Only available if the Average output indicator has been activated.

Default: WorkingTime

General running time

Meaning for running time of the main machine.
Only available if Effective output has been activated.

Default: GeneralRunTime

Machine nominal output

Meaning for nominal speed of the main machine.
Only available if at least one of the indicators degree of usage or Line delivery efficiency have been activated

Default: MachineNominalOutput

Machine set output

Meaning for set speed of the main machine.
Only available if the Line efficiency indicator has been activated.

Default: MachineSetOutput

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

The button is deactivated if one of the required input fields is empty or not configured correctly.

Cancel

Discards all changes in all tabs and closes the dialog.

Validation

Parameters | Description
Validate configuration | Clicking on the button validates the inputs and provides the results in the list field. For further details see chapter Validation.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Validation

Validation is carried out in 2 stages:

  1. Depending on the equipment group, it is determined whether it is a main machine or an auxiliary machine and the meanings are validated accordingly.
  2. Depending on the equipment group, all direct subgroups are run through in order to determine whether the equipment group can be used for the report.

Validation criteria:

  • A meaning is considered applicable and successfully validated for an equipment group if there is precisely one variable from precisely one archive that can be read for this meaning and for this equipment group.
  • Based on the meanings Loading time, Operating time, „Net operating time and Valuable operating time, a decision is made on whether an equipment group is a main machine. If none of the meanings has been successfully validated for the equipment group, the equipment group is considered an auxiliary machine, otherwise it is considered a main machine.
  • Main machine validation criteria:
    • Successful validation of all meanings of tab 1, except Bad units time.
    • Successful validation of all active meanings of tab 3, except Bad units.
  • Auxiliary machine validation criteria:
    • Successful validation of the meaning Bad units time of tab 1.
    • Successful validation of the meaning Bad units of tab 3, if active.
  • Line validation criteria:
    • Precisely one main machine.
    • 0 or more auxiliary machines.


Machine production indicators

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Machine production indicators

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration and display of the indicators for machines and the output variables for their calculation.

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Other topics in this chapter

Configuration indicators


Configuration indicators

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Machine production indicators -> Configuration indicators

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The indicators are configured in four tabs:

  • Mandatory indicator meaning
  • Optional indicators
  • Optional indicator meaning
  • Validation

A project must be selected in order to be able to configure the indicators.

Mandatory indicator meaning

Parameters | Description
Field in formula | Time counters for the formula. Meanings must be set for these, because the attendant variables are needed for the main indicators.
Meaning | Input of the meaning for the addressing of the variables for the following time counters. If one of the input fields is empty when the dialog is called up, it is filled with the standard value.
Loading time | Planned running time. Default: Loading Time
Operating time | Actual running time. Sum of effective running time and downtimes. Default: Operating Time
Net operating time | Net running time. Default: NetOperating Time
Valuable operating time | Valuable running time. Result of the net operating time minus losses due to a lack of quality or damage. Default: ValuableOperating Time
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Calculation of the main indicators

The four main indicators are calculated according to these formulas:

Optional indicators

Optional indicators are activated and deactivated using this tab.

Parameters

Description

Activation of the optional indicators

The following indicators can be activated or deactivated as required by activating the checkboxes:

  • Mean time between stoppages (MTBS)
  • Mean time between failures (MTBF)
  • Mean time to repair (MTTR)
  • Mean time between touch (MTBT)
  • Total units
  • Good units
  • Machine efficiency
  • Effective output
  • Delivery efficiency
  • Utilization factor

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

The button is deactivated if one of the required input fields is empty or not configured correctly.

Cancel

Discards all changes in all tabs and closes the dialog.

Optional indicator meaning

Parameters

Description

Field in formula

Fields for the formula. Meanings must be set for these if the indicators are to be used.

  • MTBS time counter
  • MTBS event counter
  • MTBF time counter
  • MTBF event counter
  • MTTR time counter
  • MTTR event counter
  • MTBT time counter
  • MTBT event counter
  • Total units
  • Good units
  • Effective running time
  • General running time
  • Filled and sealed units
  • Machine nominal output
  • Machine set output

Meaning

Input of the meaning for the addressing of the variables for the following indicators. The input field is only active if at least one of the indicators that uses the field that is assigned to the input field is active.

If one of the input fields is empty when the dialog is called up, it is filled with the standard value.

Field

Used by

MTBS time counter

Mean Time Between Stoppage

MTBS event counter

Mean Time Between Stoppage

MTBF time counter

Mean Time Between Failures

MTBF event counter

Mean Time Between Failures

MTTR time counter

Mean Time To Repair

MTTR event counter

Mean Time To Repair

MTBT time counter

Mean Time Between Touches

MTBT event counter

Mean Time Between Touches

Total units

Total Units

Good units

Good Units

Effective running time

Machine Efficiency

General running time

Machine Efficiency, Effective Output and Delivery Efficiency

Filled and sealed units

Effective Output and Delivery Efficiency

Machine nominal output

Delivery Efficiency and Utilization Factor

Machine set output

Utilization Factor

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

The button is deactivated if one of the required input fields is empty or not configured correctly.

Cancel

Discards all changes in all tabs and closes the dialog.

Calculation of the optional indicators

The optional indicators are calculated according to these formulas:

Validation

Parameters

Description

Validate configuration

Clicking on the button validates the inputs and provides the results in the list field.

The following is checked during validation:

  • Whether the report is linked to a project or an equipment model
  • For which equipment groups precisely one variable each per active filter can be addressed with the meanings entered

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

The button is deactivated if one of the required input fields is empty or not configured correctly.

Cancel

Discards all changes in all tabs and closes the dialog.


Visualize production loss times depending on projects

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Visualize production loss times depending on projects

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration and display of the meanings for loss times depending on project.

Parameters | Description
Production loss time visualization | Configuration and display of the meanings for the loss times.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Loss time visualization configuration | Table with the current settings for the meanings for the loss times.
Configure loss times visualization | Clicking on the button opens the dialog to configure the visualization of the loss times.

Other topics in this chapter

Configure visualization


Configure visualization

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Visualize production loss times depending on projects -> Configure visualization

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The dialog allows the input of the meanings for variables that are to be displayed in relative or absolute loss time diagrams.

The dialog is opened by clicking on the Configure loss times visualization button. To do this, a project must be selected beforehand.

Parameters

Description

Meaning for variables in relative loss time chart

Input of the meaning, which leads to the variable being included in the relative loss time diagram.

Meaning for variables in absolute loss time chart

Input of the meaning, which leads to the variable being included in the absolute loss time diagram.

Validate configuration

Clicking on the button validates the inputs and provides the results in the list field.

The following is checked during validation:

  • Whether the report is linked to a project or an equipment model
  • For which equipment groups precisely one variable each per active filter can be addressed with the meanings entered

OK

Applies settings and closes the dialog.

The button is not shown if one of the input fields is empty.

Cancel

Discards all changes and closes the dialog.


Visualize production loss times throughout projects

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Visualize production loss times throughout projects

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration and display of the meanings for production loss times throughout a project.

Parameters | Description
Production loss time visualization | Configuration and display of the meanings for the loss times.
Loss time visualization configuration | Table with the current settings for the meanings for the loss times.
Configure loss times visualization | Clicking on the button opens the dialog to configure the visualization of the loss times.

Other topics in this chapter

Configure visualization


Configure visualization

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Visualize production loss times throughout projects -> Configure visualization

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The dialog allows the input of the meanings for variables that are to be displayed in relative or absolute loss time diagrams.

The dialog is opened by clicking on the Configure loss times visualization button.

Parameters | Description
Meaning for variables in absolute loss time chart | Meaning for counter that is to be included in the absolute diagram.
Meaning for variables in relative loss time chart from main equipment group | Meaning for counters that are to be included in the relative diagram and which do not require line-dependent amendment.
Meaning for variables in relative loss time chart from side equipment group | Meaning for counters that are to be included in the relative diagram and which are used as auxiliary machine counters during line-dependent amendment.
Meaning for variables in relative loss time chart for adding side losses | Meaning for counters that are to be included in the relative diagram and which are to be increased by the auxiliary machine losses during line-dependent amendment.
Meaning for variables in relative loss time chart for subtracting side losses | Meaning for counters that are to be included in the relative diagram and to be reduced by the auxiliary machine losses during line-dependent amendment.
Validate configuration | Clicking on the button validates the inputs and provides the results in the list field. For further details see chapter Validation.
OK | Applies settings and closes the dialog. The button is not shown if one of the input fields is empty.
Cancel | Discards all changes and closes the dialog.

Validation

Validation criteria:

  • An equipment group is considered usable if it has precisely one main machine and at least 0 auxiliary machines.
  • An equipment group is then considered a usable main machine if it:
    • Has at least 0 usable variables for the absolute diagram.
    • Has at least 1 usable variable for the relative diagram without line amendment.
    • Has precisely 1 usable variable for the relative diagram for the subtraction of the additional losses.
    • Has 0 or 1 usable variables for the relative diagram for the addition of the additional losses.
  • An equipment group is considered a usable auxiliary machine if it:
    • Has at least 0 usable variables for the absolute diagram.
    • Has 0 usable variables for the relative diagram without line amendment.
    • Has at least 1 usable variable for the relative diagram as non-productive time.
  • A variable can be used if:
    • It has the appropriate meaning
      and
    • is assigned to the equipment group
      and
    • can be read from precisely one of the archives assigned to the equipment group


Carpet Plot Colors

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Carpet Plot Colors

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the colors for the carpet plot.

Only colors at the border of the HSV color circle are available for selection. S and V are fixed at 1 and H is gone through. The color gradient between minimum and maximum color is defined by the shortest connection route at the border of the HSV color circle.

HSV for carpet plot colors

  • H: Color value as hue on the color circle.
    • 0°: Red
    • 120°: Green
    • 240°: Blue
  • S: Saturation at an interval of zero to one: Fixed value 1
  • V: Lightness value from zero to one, also called darkness level. Fixed value 1

Control element for carpet plot colors

Parameters | Description
Carpet Plot Colors | Color selection for start and end color of the color gradient in the carpet plot.
Minimum color | Color of the minimum value. Configuration using the slider.
Maximum color | Color of the maximum value. Configuration using the slider.
Color gradient preview | Preview of the configured color.


RDL file - path

zenon Analyzer -> Supplied report templates -> Elements in the report area -> RDL file - path

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The RDL file path is displayed and configured using four elements:

Parameters | Description
Report file name | Text field for the input of a name for the RDL file. The name may not contain any of the following characters: ;?:@&=+$,\*<>|"/
Report file path | Show the current RDL file path.
Choose report file path | Opens the dialog for configuring the path.
All report deployment paths | Shows all paths for language-dependent folders configured in the options.

Configuring the path

To configure the path for the RDL file:

  1. Click on the Select RDL folder path button in the report window
  2. The dialog for selecting and creating a folder is opened
  3. Enter the path directly or select it in the tree
  4. click on OK

Dialog to select report path on server

Parameters

Description

Enter report file path

Active: The file path is entered into the field manually.

The following applies for the input of the name:

  • The slash at the start of the name is set automatically
  • The length of the complete path must not exceed 260 characters
  • The name must not be empty nor consist solely of dots or spaces
  • The name must not be the same as one of the language designators (EN, DE, ...)
  • The name must not contain any non-permitted characters
    The following are not permitted: ;?:@&=+$,\*<>|"/

Choose report file path

Active: The file path is selected from the list.

The list contains the current folder structure, whereby language folders are not shown. For example:
Folder EN/folder 1 or folder1/EN are always displayed as folder1.

List field

Displays the folder structure of the Analyzer server. The currently-selected folder is highlighted.

A folder can be selected in the list.

New folder

Opens dialog to add a new folder.
Only active if Select report file path has been activated.

For details, see the Creating a new folder section.

OK

Checks the inputs to ensure that they are valid, accepts the entered or selected folder including language variants as the path to store the RDL file and closes the dialog.

Cancel

Closes the dialog without changing the path.

Create new folder

Clicking on the New folder button in the dialog to select the folder for the RDL file opens the dialog to create a folder:

Parameters

Description

Current path

Display of the current superordinate folder, under which the new folder is to be created. The folder highlighted in the Select report file path dialog is given.

Name for new folder

Entry of the name for the folder.

The following applies for the input of the name:

  • The slash at the start of the name is set automatically
  • The length of the complete path must not exceed 260 characters
  • The name must not be empty nor consist solely of dots or spaces
  • The name must not be the same as one of the language designators (EN, DE, ...)
  • The name must not contain any non-permitted characters
    The following are not permitted: ;?:@&=+$,\*<>|"/

OK

Accepts settings and creates new folder. This is displayed in the list.

Cancel

Rejects all inputs and closes the dialog without creating a folder.


Report templates

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Report templates

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Information on the report templates:

Parameters

Description

Information on report templates

Information on the report template, consisting of:

  • Theme
  • Report template

Both localized names are read from the RTC at the time of the creation of the zams_rep file and then saved in the zams_rep file. Changes in the RTC file are thus not implemented here!

Theme

Localized name of the report template class from which the report template for the report comes.

Display only.

Report template

Localized name of the report template used.

Display only.


Shift data origin

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Shift data origin

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The group Shift list linked to equipment group in the dialog to configure alarm reports allows the assignment of alarm groups to shifts. Some reports use the shift data to determine the net waiting time for alarms.

Parameters | Description
Net alarm time calculation | Properties to calculate the net time.
Consider shift breaks | Active: Shift breaks are taken into account.
Shift list linked to equipment group | ID of the equipment model for which the shift data is to be obtained from drop-down list
List field | Shows the projects where the currently-selected equipment model is assigned a shift model.
Connector for shift data | Selection of the connector from where the shift data is to be obtained from a drop-down list.

If the report is tied to a project via the time filter settings, the entries in the drop-down list are filtered to the equipment model selection. Only entries that are assigned a shift model in the tied project are available.

If a variant with shift filtering is selected for the time filter settings, then the shift data is accepted once the time filtering has been confirmed.


Element sort order

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Element sort order

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the sorting of the modes of operation and the components.

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending


Variance tolerance for loss detection

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Variance tolerance for loss detection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Defines the precision for loss detection.

Parameters

Description

Variance tolerance for loss detection

Denotes how many tenths of a percent the sum of the entries must deviate from the absolute difference of the sum of all entries and the sum of all outputs of a node in order to be recognized as a loss.

  • Minimum: 0
  • Maximum: 1000 - loss detection deactivated.

Entry in the field or configuration using the cursor keys.


Wind Rose configuration

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Wind Rose configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the wind rose in reports with a wind power theme.

Parameters | Description
Wind Rose configuration | Display and configuration of the parameters of a wind rose.
Meaning for wind direction | Display of the meaning for the wind speed.
Meaning for indicator variable | Display of the meaning for the indicator.
Indicator visual name | Display of the indicator name.
Wind Rose granularity | Display of the number of wind directions: 4, 8 or 16.
Angular measurement | Display of the selected measurement system for the wind direction: Degree, Radian or Gradient.
Aggregation shown in wind rose chart | Display of the selected aggregation function for display in the diagram: Sum, average, minimum, maximum.
Aggregation shown in table | Display of the selected aggregation functions for display in the table: Sum, average, minimum, maximum. At least one of these must be selected.
Configure wind rose | Opens the dialog for configuring the wind rose.

Other topics in this chapter

Configure wind rose


Configure wind rose

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Wind Rose configuration -> Configure wind rose

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The parameters of the wind rose are configured in this dialog. The dialog is opened by clicking on the Configure wind rose button on the Wind rose configuration control element.

Parameters

Description

Wind Rose configuration

Configuration of the wind rose.

Meaning for wind direction

Entry of the meaning for wind direction.

The field must not be empty during validation.

Meaning for indicator variable

Entry of the meaning for the indicator.

The field must not be empty during validation.

Indicator visual name

Entry of the visual name for the indicator.

The field must not be empty during validation.

Wind Rose granularity

Configuration of the number of wind directions displayed. Possible selection:

  • 4: North, East, South, West
  • 8: as 4 plus four intermediate values
  • 16: as 4 plus twelve intermediate values

Angular measurement

Measurement system for the wind direction Meaning for indicator variable:

  • Degree: 0° - 360°
  • Radian: 0 rad - 2p rad
  • Gradiant: 0 gon – 400 gon

Default: degrees

Report settings

Configuration of the report settings.

Aggregation shown in wind rose chart

Selection of an aggregation function that is displayed in the diagram. The following can be selected:

  • Sum
  • Average
  • Minimum
  • Maximum

Default: Average

Aggregation shown in table

Selection of an aggregation function that is displayed in the table. The following can be selected:

  • Sum
  • Average
  • Minimum
  • Maximum

Default: Average, Minimum, Maximum

At least one aggregation type must be selected.

Validation results

Start of the validity of the configuration and display of the results.

Validate configuration

Click on the button to start validation of the configuration. :

  • Check to see whether all mandatory fields have been configured.
  • Check to see how many equipment groups can uniquely address the two meanings Meaning for wind direction and Meaning for indicator variable. This corresponds to one of the precisely-assigned combinations of archive, variable and project per meaning, whereby both variable and archive are assigned to the equipment group.
    The individual equipment groups and the number of the equipment groups that can be used are issued in the List of results.

If the validation is successful, the OK button to save the configuration and close the dialog is activated.

List of results

Shows the results of validation and the number of equipment groups used.

Close dialog

Parameters | Description
OK | Applies settings and closes the dialog.
Cancel | Discards all changes and closes the dialog.

Meanings and equipment groups

Meanings relate to variables that are assigned to certain projects and equipment groups. For each equipment group transferred, precisely one variable for wind direction and precisely one variable for the indicator from one archive each must be present, taking the transferred projects into account. The variables can be in the same archive. However there must not be 2 archives per variable present.

Granularity of the wind direction

For the wind direction, the value for a full angle is set on the basis of the measurement system for a complete angle. The wind directions are then calculated from this, depending on the number:

  • 4 wind directions:
    • N if direction <= 1/8 of the full angle OR direction > 7/8 of the full angle
    • E if direction >= 1/8 of the full angle AND direction < 3/8 of the full angle
    • S if direction >= 3/8 of the full angle AND direction < 5/8 of the full angle
    • W if direction >= 5/8 of the full angle AND direction < 7/8 of the full angle
  • 8 wind directions:
    • N if direction <= 1/16 of the full angle OR direction > 15/16 of the full angle
    • NE if direction >= 1/16 of the full angle AND direction < 3/16 of the full angle
    • E if direction >= 3/16 of the full angle AND direction < 5/16 of the full angle
    • SE if direction >= 5/16 of the full angle AND direction < 7/16 of the full angle
    • S if direction >= 7/16 of the full angle AND direction < 9/16 of the full angle
    • SW if direction >= 91/16 of the full angle AND direction < 11/16 of the full angle
    • W if direction >= 11/16 of the full angle AND direction < 13/16 of the full angle
    • NW if direction >= 13/16 of the full angle AND direction < 15/16 of the full angle
  • 16 wind directions:
    • N if direction <= 1/32 of the full angle OR direction > 31/32 of the full angle
    • NNE if direction >= 1/32 of the full angle AND direction < 3/32 of the full angle
    • NE if direction >= 3/32 of the full angle AND direction < 5/32 of the full angle
    • ENE if direction >= 5/32 of the full angle AND direction < 7/32 of the full angle
    • E if direction >= 7/32 of the full angle AND direction < 9/32 of the full angle
    • ESE if direction >= 9/32 of the full angle AND direction < 11/32 of the full angle
    • SE if direction >= 11/32 of the full angle AND direction < 13/32 of the full angle
    • SSE if direction >= 13/32 of the full angle AND direction < 15/32 of the full angle
    • S if direction >= 15/32 of the full angle AND direction < 17/32 of the full angle
    • SSW if direction >= 17/32 of the full angle AND direction < 19/32 of the full angle
    • SW if direction >= 19/32 of the full angle AND direction < 21/32 of the full angle
    • WSW if direction >= 21/32 of the full angle AND direction < 23/32 of the full angle
    • W if direction >= 23/32 of the full angle AND direction < 25/32 of the full angle
    • WNW if direction >= 25/32 of the full angle AND direction < 27/32 of the full angle
    • NW if direction >= 27/32 of the full angle AND direction < 29/32 of the full angle
    • NNW if direction >= 29/32 of the full angle AND direction < 31/32 of the full angle


XY axis configuration

zenon Analyzer -> Supplied report templates -> Elements in the report area -> XY axis configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the X/Y axes.

Parameters

Description

X/Y configuration

Selection of the values for the X and Y axis from the drop-down list:

  • Hours/Minutes
  • Days/Hours
  • Months/Days


Time filter

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Time filter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The time filter consists of several components:

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Other topics in this chapter

Time filter settings

Default time range


Time filter settings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Time filter -> Time filter settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The settings for the time filter are changed by means of a dialog:

The dialog has different configuration features depending on the selection of the time filter type. For details, see the respective time filter types:

  • Absolute and relative time filter
  • Lots
  • Shift

Configuring the time filter

To configure the time filter:

  1. Select the desired time filter type.
  2. Select the desired granularity. It determines what selection options are available in the Report Launcher.
  3. Set the parameters for the default values: The configuration possibilities depend on the type and granularity of the time filter.

Other topics in this chapter

Absolute and relative time filter

Lots

Shift


Absolute and relative time filter

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Time filter -> Time filter settings -> Absolute and relative time filter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the absolute time filter and relative time filter.

Parameters

Description

Time filter type

Selection of the time filter type from a drop-down list.

  • Absolute time filter Date and time per time range.
  • Relative time filter: Time span per time range.

Use different prefilter time ranges

Only available for comparative report templates:

  • Active: Two time filter ranges are used.
  • Inactive: One time filter range is used.

Usage:

  • If the report only has one time range, the checkbox is not checked and is deactivated.
  • If the report has two time ranges and was selected as an absolute or relative time filer type, the checkbox is checked and activated.
  • If the report has two time ranges and was selected as a lot or shift selection with absolute or relative time range as a pre-filter, then the checkbox is activated.

OK

Saves configuration in the report area in the Time filter configuration list field and closes the dialog.

Cancel

Discards changes and closes the dialog.

For other time filter ranges, see the Lots and Shift chapters.


Lots

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Time filter -> Time filter settings -> Lots

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Parameters

Description

Time filter type

Selection of the type of time filtering from the drop-down list. The following are available for lots:

  • Lot selection with date and time prefilter: Selection of the lot with date and time per time range
  • Lot selection with time span prefilter: Selection of the lot with time span per time range

Use different prefilter time ranges

Only available for comparative report templates:

  • Active: Two time filter ranges are used.
  • Inactive: One time filter range is used.

Usage:

  • If the report only has one time range, the checkbox is not checked and is deactivated.
  • If the report has two time ranges and was selected as an absolute or relative time filer type, the checkbox is checked and activated.
  • If the report has two time ranges and was selected as a lot or shift selection with absolute or relative time range as a pre-filter, then the checkbox is activated.

Project

Selection of a project from the drop-down list from which the lot data should come. The report is tied to this project as soon as the dialog is confirmed with OK.

Lot archive

List of the lot archives of the selected project. One of the archives must be selected.

OK

Saves configuration in the report area in the Time filter configuration list field and closes the dialog.

Cancel

Discards changes and closes the dialog.

Possible result in the report area:


Shift

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Time filter -> Time filter settings -> Shift

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

If the combobox is set to "Shift selection with datetime prefilter" or "Shift selection with timespan prefilter", additional controls are shown and the dialog will look as follows:

Parameters

Description

Time filter type

Selection of the type of time filtering from the drop-down list; the following are available for shift data:

  • Shift selection with date and time prefilter: Selection of the shift data with date and time per time range
  • Shift selection with time span prefilter: Selection of the shift data with time span per time range

Use different prefilter time ranges

Only available for comparative report templates:

  • Active: Two time filter ranges are used.
  • Inactive: One time filter range is used.

Usage:

  • If the report only has one time range, the checkbox is not checked and is deactivated.
  • If the report has two time ranges and was selected as an absolute or relative time filer type, the checkbox is checked and activated.
  • If the report has two time ranges and was selected as a lot or shift selection with absolute or relative time range as a pre-filter, then the checkbox is activated.

Project

Selection of a project from the drop-down list from which the shift data should come. The report is tied to this project as soon as the dialog is confirmed with OK.

Equipment Model

Lists all the entries in the equipment model for which shift data is to be displayed in the selected project. For this, the following applies:

  • If an equipment group and all its subordinate equipment groups do not contain a shift model, the equipment group is not displayed.
  • For all models with shift data, the entries are shown up to the root node, even if the superordinate nodes drawn do not contain any shift data.
  • If an element is displayed as unusable in the tree is clicked, the first subordinate and usable element assigned to this element is used instead of this.
  • There must be an equipment model with shift data selected.

Connector for shift data

Selection of the connector to get shift data from drop-down list

A connector must be selected.

Attention: The SCADA runtime connector cannot get any shift data.

OK

Saves configuration in the report area in the Time filter configuration list field and closes the dialog.

Cancel

Discards changes and closes the dialog.

Possible result in the report area:

attention Attention

Each equipment group in zenon may only be assigned to one individual time model.

If several time model groups are assigned, the Analyzer Wizard Export uses the first that it finds and exports this to the metadata of the Analyzer. Other time model groups are ignored.


Default time range

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Time filter -> Default time range

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The standard time range is stipulated using a separate dialog. The display of the dialog depends on the settings for the Use different prefilter time ranges option in the time filter configuration.
Option:

  • Inactive: One time range
  • Active: Two time ranges

Other topics in this chapter

One time range

Two time ranges


One time range

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Time filter -> Default time range -> One time range

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the default time range if the Use different prefilter time ranges option is inactive:

End of time range

Parameters

Description

End of time range

Stipulates how the end of the time range is determined. Select an option:

  • Fixed time stamp
  • Current time stamp with adjustment
  • Current time stamp with fixed components and adjustment

The selection determines which options can be configured at the lower range of the dialog.

Fixed time stamp

Fixed time stamp with lookback time.

The End time stamp is UTC and Lookback time options can be configured.

Current time stamp with adjustment

Fixed time stamp with adjustment and lookback time.

The Adjustment and Lookback time options can be configured.

Current time stamp with fixed components and adjustment

Fixed time stamp with individual adjustment and lookback time.

The Time, as well as Adjustment and Lookback time options can be configured.

Time range settings

Parameters

Description

Time range settings

Elements to set the detail parameters of the time range. The elements that are available depend on the setting for End of time range.

Set minutes to

  • Checkbox active: Minute is fixed.
    Only available if the time filter granularity and the setting for End of time range allow the use of minutes.
  • numerical element : Input of the fixed minute.
    Possible values: 0 to 59

Set hours to

  • Checkbox active: Hour is fixed.
    Only available if the time filter granularity and the setting for End of time range allow the use of hours.
  • numerical element : Input of the fixed hour.
    Possible values: 0 to 23

Set day to

  • Checkbox active: Day is fixed.
    Only available if the time filter granularity and the setting for End of time range allows the use of days.
  • numerical element : Input of the fixed day.
    Possible values: 1 to 28.
    Limited to 28, because the value for all months of a year must be valid.

Set month to

  • Checkbox active: Month is fixed.
    Only available if the time filter granularity and the setting for End of the time range allow the use of months.
  • numerical element : Input of the fixed month.
    Possible values: 1 to 12

Set year to

  • Checkbox active: Year is fixed.
    Only available if the time filter granularity and the setting for End of the time range allow the use of years.
  • numerical element : Input of the fixed year.
    Possible values: 1900 to 3999

End time stamp is UTC

Stipulates whether the fixed end time that has been entered is UTC or local time.

  • Active: End time is UTC. Only available if the time filter granularity and the setting for End of the time range allow its use.

Adjustment

Adjustment of the end time. Only available if Fixed time stamp has been selected for End of the time range.

Possible values for quantity: -1000 to 1000

Granularity with selection from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Look back time

Stipulation of the length of the time range for the lookback time.

Possible values for quantity: 1 to 1000

Granularity with selection from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Description and sample time range

Parameters | Description
Description and sample time range | Display of the current settings.
Description | Text description of the settings.
Example time range | Display of the default value calculated for the time range with the current settings.

Close dialog

Parameters | Description
OK | Applies settings and closes the dialog.
Cancel | Discards all changes and closes the dialog.


Two time ranges

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Time filter -> Default time range -> Two time ranges

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the default time ranges if the Use different prefilter time ranges option is active. The following are configured:

  • Later time range
  • Earlier time range

Later time range

Configuration of the later time range.

End of time range

Parameters

Description

End of time range

Stipulates how the end of the time range is determined. Select an option:

  • Fixed time stamp
  • Current time stamp with adjustment
  • Current time stamp with fixed components and adjustment

The selection determines which options can be configured at the lower range of the dialog.

Fixed time stamp

Fixed time stamp with lookback time.

The End time stamp is UTC and Lookback time options can be configured.

Current time stamp with adjustment

Fixed time stamp with adjustment and lookback time.

The Adjustment and Lookback time options can be configured.

Current time stamp with fixed components and adjustment

Fixed time stamp with individual adjustment and lookback time.

The Time, as well as Adjustment and Lookback time options can be configured.

Time range settings

Parameters

Description

Time range settings

Elements to set the detail parameters of the time range. The elements that are available depend on the setting for End of time range.

Set minutes to

  • Checkbox active: Minute is fixed.
    Only available if the time filter granularity and the setting for End of time range allow the use of minutes.
  • numerical element : Input of the fixed minute.
    Possible values: 0 to 59

Set hours to

  • Checkbox active: Hour is fixed.
    Only available if the time filter granularity and the setting for End of time range allow the use of hours.
  • numerical element : Input of the fixed hour.
    Possible values: 0 to 23

Set day to

  • Checkbox active: Day is fixed.
    Only available if the time filter granularity and the setting for End of time range allows the use of days.
  • numerical element : Input of the fixed day.
    Possible values: 1 to 28.
    Limited to 28, because the value for all months of a year must be valid.

Set month to

  • Checkbox active: Month is fixed.
    Only available if the time filter granularity and the setting for End of the time range allow the use of months.
  • numerical element : Input of the fixed month.
    Possible values: 1 to 12

Set year to

  • Checkbox active: Year is fixed.
    Only available if the time filter granularity and the setting for End of the time range allow the use of years.
  • numerical element : Input of the fixed year.
    Possible values: 1900 to 3999

End time stamp is UTC

Stipulates whether the fixed end time that has been entered is UTC or local time.

  • Active: End time is UTC. Only available if the time filter granularity and the setting for End of the time range allow its use.

Adjustment

Adjustment of the end time. Only available if Fixed time stamp has been selected for End of the time range.

Possible values for quantity: -1000 to 1000

Granularity with selection from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Look back time

Stipulation of the length of the time range for the lookback time.

Possible values for quantity: 1 to 1000

Granularity with selection from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Description and sample time range

Parameters | Description
Description and sample time range | Display of the current settings.
Description | Text description of the settings.
Example time range | Display of the default value calculated for the time range with the current settings.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.

Earlier time range

Configuration of the earlier time range.

Attach earlier time range before later time range with the same look back time

Parameters

Description

Attach earlier time range before later time range with the same look back time

Stipulation of whether the two time ranges to be compared border one another directly or are the same length.

  • Active: The end of the earlier time range is also the start of the later time range. Both time ranges are the same length.
    All control elements in this tab have been deactivated.
  • Inactive: Control elements in this tab are active. The earlier time range can be configured individually.

End of time range

Parameters

Description

End of time range

Stipulates how the end of the time range is determined. Select an option:

  • Fixed time stamp
  • Current time stamp with adjustment
  • Current time stamp with fixed components and adjustment

The selection determines which options can be configured at the lower range of the dialog.

Fixed time stamp

Fixed time stamp with lookback time.

The End time stamp is UTC and Lookback time options can be configured.

Current time stamp with adjustment

Fixed time stamp with adjustment and lookback time.

The Adjustment and Lookback time options can be configured.

Current time stamp with fixed components and adjustment

Fixed time stamp with individual adjustment and lookback time.

The Time, as well as Adjustment and Lookback time options can be configured.

Time range settings

Parameters

Description

Time range settings

Elements to set the detail parameters of the time range. The elements that are available depend on the setting for End of time range.

Set minutes to

  • Checkbox active: Minute is fixed.
    Only available if the time filter granularity and the setting for End of time range allow the use of minutes.
  • numerical element : Input of the fixed minute.
    Possible values: 0 to 59

Set hours to

  • Checkbox active: Hour is fixed.
    Only available if the time filter granularity and the setting for End of time range allow the use of hours.
  • numerical element : Input of the fixed hour.
    Possible values: 0 to 23

Set day to

  • Checkbox active: Day is fixed.
    Only available if the time filter granularity and the setting for End of time range allows the use of days.
  • numerical element : Input of the fixed day.
    Possible values: 1 to 28.
    Limited to 28, because the value for all months of a year must be valid.

Set month to

  • Checkbox active: Month is fixed.
    Only available if the time filter granularity and the setting for End of the time range allow the use of months.
  • numerical element : Input of the fixed month.
    Possible values: 1 to 12

Set year to

  • Checkbox active: Year is fixed.
    Only available if the time filter granularity and the setting for End of the time range allow the use of years.
  • numerical element : Input of the fixed year.
    Possible values: 1900 to 3999

End time stamp is UTC

Stipulates whether the fixed end time that has been entered is UTC or local time.

  • Active: End time is UTC. Only available if the time filter granularity and the setting for End of the time range allow its use.

Adjustment

Adjustment of the end time. Only available if Fixed time stamp has been selected for End of the time range.

Possible values for quantity: -1000 to 1000

Granularity with selection from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Look back time

Stipulation of the length of the time range for the lookback time.

Possible values for quantity: 1 to 1000

Granularity with selection from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Description and sample time range

Parameters | Description
Description and sample time range | Display of the current settings.
Description | Text description of the settings.
Example time range | Display of the default value calculated for the time range with the current settings.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.


Component operating time assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Component operating time assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignments for operating times to machine components.

Parameters | Description
Operating time assignments | Display and configuration of the assignments for power station operating times per machine component.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Component operating time assignments -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Component operating time assignments. Dialog is started by clicking on the Configure assignments button. The dialog consists of two tabs:

Parameters | Description
Meanings | Configuration of the meanings.
Validation | Validation of the configuration.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Meanings

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Component operating time assignments -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

Parameters | Description
Relative operating hours | Meaning for the general relative time counter. There must be precisely one per item of equipment.
Component exchanged | Entry of the meaning for all variables for component exchange events. Permitted number: 0 to N per item of equipment.
Component inspected | Entry of the meaning for all variables for component testing events. Permitted number: 0 to N per item of equipment.
Parent component | Entry of the identification for the field in the metadata table that determines the extent of superordinance the parent company has in relation to a component. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant group | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Note: The following is applicable for all input fields:

  • If an input field is empty, this input field is marked with a color. The OK button is deactivated.

If an input field was left empty when a dialog was called up, because the configuration of the report does not have any content for it, then this is filled with the standard value.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Component operating time assignments -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

In order for the validation to start, each entry field in the Meanings tab must be populated with a value.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Operating time assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating time assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignments for power station operating times per machine component and operating mode.

Parameters | Description
Operating time assignments | Display and configuration of the assignments for power station operating times per machine component and operating mode.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating time assignments -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Operating time assignments. Dialog is started by clicking on the Configure assignments button. The dialog consists of two tabs:

Parameters | Description
Meanings | Configuration of the meanings.
Validation | Validation of the configuration.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Meanings

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating time assignments -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

Parameters | Description
Absolute operating hours | Entry of the meaning for the absolute operating hours counter of a machine.
Relative operating hours | Entry of the meaning for the relative operating hours counter of a machine.
Relative hours in an operation mode | Entry of the meaning for all relative operating hours counters for the operation modes of a machine.
Component exchanged | Entry of the meaning for all variables for component exchange events.
Components inspected | Entry of the meaning for all variables for component inspection events.
Parent component | Entry of the identification for the field in the metadata table that determines the extent of superordinance the parent company has in relation to a component. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant group | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Note: The following is applicable for all input fields:

  • If an input field is empty, this input field is marked with a color. The OK button is deactivated.
  • If an input field was left empty when a dialog was called up, because the configuration of the report does not have any content for it, then this is filled with the standard value.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating time assignments -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

In order for the validation to start, each entry field in the Meanings tab must be populated with a value.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Operating time per power range assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating time per power range assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignments for power station operating times per load area.

Parameters | Description
Operating time per power range assignments | Display and configuration of the assignments for power station operating times per load area.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating time per power range assignments -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Operating time per power range assignments. Dialog is started by clicking on the Configure assignments button. The dialog consists of two tabs:

Parameters | Description
Meanings | Configuration of the meanings.
Validation | Validation of the configuration.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Meanings

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating time per power range assignments -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

Parameters | Description
Active power generator range | Input of the meaning for all time counters for operating time in an active power range in generator operation.
Active power generator maximum | Input of the meaning for the time counters for operating time at maximum active power in generator operation.
Active power generator minimum | Input of the meaning for the time counters for operating time at minimum active power in generator operation.
Active power pump range | Input of the meaning for all time counters for operating time in an active power range in pump operation.
Active power pump maximum | Input of the meaning for operating time at maximum active power in pump operation
Active power pump minimum | Input of the meaning for operating time at maximum active power in pump operation.
Reactive power generator range | Input of the meaning for all time counters for operating time in a reactive power range in generator operation.
Reactive power generator maximum | Input of the meaning for the time counters for operating time at maximum reactive power in generator operation.
Reactive power generator minimum | Input of the meaning for the time counters for operating time at minimum reactive power in generator operation.
Reactive power pump range | Input of the meaning for all time counters for operating time in reactive power range in pump operation.
Reactive power pump maximum | Input of the meaning for the time counters for operating time at maximum reactive power in pump operation.
Reactive power pump minimum | Input of the meaning for the time counters for operating time at minimum reactive power in pump operation.
Power plant | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant group | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Note: The following is applicable for all input fields:

  • If an input field is empty, this input field is marked with a color. The OK button is deactivated.

If an input field was left empty when a dialog was called up, because the configuration of the report does not have any content for it, then this is filled with the standard value.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating time per power range assignments -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

In order for the validation to start, each entry field in the Meanings tab must be populated with a value.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Machine start counter assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Machine start counter assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignments for machine start counter.

Parameters | Description
Assignments for machine counters | Display and configuration of the assignments for machine start counter.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Machine start counter assignments -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Machine start counter assignments. Dialog is started by clicking on the Configure assignments button. The dialog consists of two tabs:

Parameters | Description
Meanings | Configuration of the meanings.
Validation | Validation of the configuration.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Meanings

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Machine start counter assignments -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

Parameters | Description
Absolute starts as turbine | Meaning for absolute starts as turbine.
Relative starts as turbine | Meaning for relative starts as turbine.
Absolute starts as pump | Meaning for absolute starts as pump.
Relative starts as pump | Meaning for relative starts as pump.
Power plant | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant group | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Note: The following is applicable for all input fields:

  • If an input field is empty, this input field is marked with a color. The OK button is deactivated.
  • If an input field was left empty when a dialog was called up, because the configuration of the report does not have any content for it, then this is filled with the standard value.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Machine start counter assignments -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

In order for the validation to start, each entry field in the Meanings tab must be populated with a value.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Switching cycles assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Switching cycles assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignment for power switching cycles.

Parameters | Description
Switching cycles assignments | Display and configuration of the assignment for power switching cycles.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Switching cycles assignments -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Switching Cycles assignments . Dialog is started by clicking on the Configure assignments button. The dialog consists of two tabs:

Parameters | Description
Meanings | Configuration of the meanings.
Validation | Validation of the configuration.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Meanings

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Switching cycles assignments -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

Parameters | Description
Relative switching counter | Enter the meaning for the relative switching counter.
Circuit breaker inspection | Enter the meaning for the circuit breaker inspection event variable.
Circuit breaker exchange | Enter the meaning for the circuit breaker exchange variable.
Power plant | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant group | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Switching cycles assignments -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

In order for the validation to start, each entry field in the Meanings tab must be populated with a value.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Active and reactive power counter assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Active and reactive power counter assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignments for power station real and wattless power.

Parameters | Description
Active and reactive power counter assignments | Display and configuration of the assignments for active and reactive power counters.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Active and reactive power counter assignments -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Active and reactive power counter assignments. Dialog is started by clicking on the Configure assignments button. The dialog consists of two tabs:

Parameters | Description
Meanings | Configuration of the meanings.
Validation | Validation of the configuration.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Meanings

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Active and reactive power counter assignments -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

Parameters | Description
Active power production | Input of the meaning for the active power production.
Active power consumption | Input of the meaning for the active power consumption.
Reactive power production | Input of the meaning for the reactive power production.
Reactive power consumption | Input of the meaning for the reactive power consumption.
Power plant | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant group | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Active and reactive power counter assignments -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

In order for the validation to start, each entry field in the Meanings tab must be populated with a value.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Validation process

The following is checked during validation:

  1. Whether it is possible to read from an archive for the equipment group:
    • Precisely 1 active power counter for production
    • Precisely 1 reactive power counter for production
    • At most 1 active power counter for consumption
    • At most 1 reactive power counter for consumption

    If this is not the case, the equipment group cannot be used and the procedure is ended for this equipment group.

  2. The equipment group is arranged in a list.
  3. The equipment tree is built up in such a way that each equipment group that is present in the list in item 2 is present.
  4. The equipment groups are given.


Power line frequency assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Power line frequency assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignment for power line frequency.

Parameters | Description
Power line frequency assignments | Display and configuration of the assignment for power line frequency.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Power line frequency assignments -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Power line frequency assignments. Dialog is started by clicking on the Configure assignments button. The dialog consists of two tabs:

Parameters | Description
Meanings | Configuration of the meanings.
Validation | Validation of the configuration.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Meanings

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Power line frequency assignments -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

Parameters

Description

Power Line Frequency

Entry of the meaning for the power line frequency of a machine.

Frequency band time counter

Entry of the meaning for the relative time counter for a frequency band of a machine.

All variables that are assigned to the equipment group and whose meaning starts precisely with the text entered here (and possible a suffix), are included in the report.

Meaning of the variables either correspond precisely with the meaning entered or must start with the meaning entered.

Attention: The suffix of the meaning of the variables must be numerical, because it might lead to a conversion error otherwise.

Power plant

Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine.

Note for developer: ID for field in EQUIPMENTINFO table.

Power plant group

Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine.

Note for developer: ID for field in EQUIPMENTINFO table.

Nominal frequency

Input of the identification for the field in the metadata table that defines the nominal frequency for the machine.

Note for developer: ID for field in EQUIPMENTINFO table.

Previous

Switches to previous tab. (Deactivated in the first tab)

Next

Switches to the next tab. (Deactivated in the last tab)

OK

Applies all changes in all tabs and closes the dialog.

The button is deactivated if one of the required input fields is empty or not configured correctly.

Cancel

Discards all changes in all tabs and closes the dialog.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Power line frequency assignments -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

In order for the validation to start, each entry field in the Meanings tab must be populated with a value.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Event counter assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Event counter assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignment for power station event counters.

This control element uses a dialog to configure assignments for event counters for the following report templates:

  • Machine Event Counters
  • Set Point Change Event Counters
  • Nozzle Mode Change Event Counters
  • Load Shedding Active Power Ranges Event Counters
  • Load Shedding Turbine Speed Ranges Event Counters

Not every property and not every tab in the dialog is available for each report template. For details, see the Configuring assignments section.

Control element

Parameters | Description
Event counter assignments | Display and configuration of the assignments for the event counter. The properties that can be displayed and configured depend on the type of report template.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Event counter assignments -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Event counter assignments. Dialog is started by clicking on the Configure assignments button. The dialog consists of several tabs, depending on the report template to be configured.

Parameters | Description
Meanings | Configuration of the meanings.
Active power ranges | Configuration of the active power ranges. Only for Load Shedding Active Power Ranges Event Counters report templates.
Turbine speed ranges | Configuration of the turbine speed ranges. Only for Load Shedding Turbine Speed Ranges Event Counters report templates.
Validation | Validation of the configuration.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Overview of availability of properties for report templates

Property | Machines | Set value | Switch | Active power | Turbines
On-off switch | X | X | X | X | X
Set value | X | X | -- | -- | --
Nozzle mode | X | -- | X | -- | --
Operation mode | X | X | -- | -- | --
Circuit breaker | X | -- | -- | X | X
Active power | X | -- | -- | X | --
Turbine speed | X | -- | -- | -- | X
Power plant | X | X | X | X | X
Power plant group | X | X | X | X | X
Nominal output | X | -- | -- | X | --
Nominal turbine speed | X | -- | -- | -- | X
Active power ranges | X | -- | -- | X | --
Turbine speed ranges | X | -- | -- | -- | X

Key:

  • Machines: Machine Event Counters
  • Set value: Set Point Change Event Counters
  • Switch: Nozzle Mode Change Event Counters
  • Active power: Load Shedding Active Power Ranges Event Counters
  • Turbines: Load Shedding Turbine Speed Ranges Event Counters
  • X: available
  • --: not available

Other topics in this chapter

Meanings

Active power ranges

Turbine speed ranges

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Event counter assignments -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

The properties that are available for configuration depend on the type of report template to be configured.

Parameters

Description

On-off switch

Entry of the meaning for the machine's on/off switch.

The data source for the variables that are referenced via this meaning are selected from the drop-down list next to the input field. Available are:

  • Alarm Message List
  • Archive
  • Chronological event list and selection.

Default: Archive

Set value

Input of the meaning for the set value for the machine power.

The data source for the variables that are referenced via this meaning are selected from the drop-down list next to the input field. Available are:

  • Alarm Message List
  • Archive
  • Chronological event list and selection.

Default: Archive

Nozzle mode

Enter the meaning for the nozzle mode.

The data source for the variables that are referenced via this meaning are selected from the drop-down list next to the input field. Available are:

  • Alarm Message List
  • Archive
  • Chronological event list and selection.

Default: Archive

Operation mode

Enter the meaning for the operation mode.

The data source for the variables that are referenced via this meaning are selected from the drop-down list next to the input field. Available are:

  • Alarm Message List
  • Archive
  • Chronological event list and selection.

Default: Archive

Circuit breaker

Enter the meaning for the circuit breaker.

The data source for the variables that are referenced via this meaning are selected from the drop-down list next to the input field. Available are:

  • Alarm Message List
  • Archive
  • Chronological event list and selection.

Default: Archive

Active power

Enter the meaning for the active power.

Turbine speed

Enter the meaning for the turbine speed.

Power plant

Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine.

Note for developer: ID for field in EQUIPMENTINFO table.

Power plant group

Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine.

Note for developer: ID for field in EQUIPMENTINFO table.

Nominal active power

Input of the identification for the field in the metadata table that defined the nominal active power.

Note for developer: ID for field in EQUIPMENTINFO table.

Nominal turbine speed

Input of the identification for the field in the metadata table that defines the nominal turbine speed.

Note for developer: ID for field in EQUIPMENTINFO table.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Active power ranges

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Event counter assignments -> Configure assignments -> Active power ranges

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments of the active power ranges are configured in this tab.
Only available for Load Shedding Active Power Ranges Event Counters report templates.

Parameters

Description

Area list

The area list shows previously-configured performance areas. The pre-existing areas are displayed:

  • Comparison type
  • Comparison value

Comparison type

Selection of the comparison type from the drop-down list. The following are available:

  • Less (<)
  • Less or equal (<=)
  • Greater (>)
  • Greater or equal (>=)
  • Range: Compares two values to one another and shows further input fields for Comparison type and Comparison value.

Comparison value

Entry of the comparison value.

  • Numeric value
  • Maximum: 2147483647

Symbol: New

Click on button

  • Creates a new area
  • Initializes this with 0 <= X <= 100
  • Inserts it as a new row at the bottom end of the list

X

Clicking on the button removes the attendant area from the list.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Comparison types and areas

The following comparison types are available:

  • Lower: X < [number]
  • Lower or equal: X <= [number]
  • Greater than: X > [number]
  • Greater than or equal to: X >= [number]
  • Areas

Areas

The 'areas' comparison type defines a range between two values. The following rules are available:

  • [number] < X < [number]
  • [number] < X <= [number]
  • [number] <= X < [number]
  • [number] <= X <= [number]


Turbine speed ranges

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Event counter assignments -> Configure assignments -> Turbine speed ranges

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments of the turbine speeds are configured in this tab.
Only available for Load Shedding Turbine Speed Ranges Event Counters report templates.

Parameters

Description

Area list

The area list shows previously-configured performance areas. The pre-existing areas are displayed:

  • Comparison type
  • Comparison value

Comparison type

Selection of the comparison type from the drop-down list. The following are available:

  • Less (<)
  • Less or equal (<=)
  • Greater (>)
  • Greater or equal (>=)
  • Range: Compares two values to one another and shows further input fields for Comparison type and Comparison value.

Comparison value

Entry of the comparison value.

  • Numeric value
  • Maximum: 2147483647

Symbol: New

Click on button

  • Creates a new area
  • Initializes this with 0 <= X <= 100
  • Inserts it as a new row at the bottom end of the list

X

Clicking on the button removes the attendant area from the list.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Comparison types and areas

The following comparison types are available:

  • Lower: X < [number]
  • Lower or equal: X <= [number]
  • Greater than: X > [number]
  • Greater than or equal to: X >= [number]
  • Areas

Areas

The 'areas' comparison type defines a range between two values. The following rules are available:

  • [number] < X < [number]
  • [number] < X <= [number]
  • [number] <= X < [number]
  • [number] <= X <= [number]


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Event counter assignments -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

In order for the validation to start, all other tabs - depending on the type of report template - must be configured correctly.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.
Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Operating hours assignments for operating modes

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating hours assignments for operating modes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Display and configuration of the assignments of operating hours for operating modes.

Parameters | Description
Operating hours assignments for operating modes | Display and configuration of the assignments of operating hours for operating modes.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Other topics in this chapter

Configure assignments


Configure assignments

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating hours assignments for operating modes -> Configure assignments

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Dialog to configure the Operating hours assignments for operating modes . Dialog is started by clicking on the Configure assignments button. The dialog consists of two tabs: No input field can remain empty during configuration.

Parameters | Description
Meanings | Configuration of the meanings.
Validation | Validation of the configuration.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Other topics in this chapter

Meanings

Validation


Meanings

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating hours assignments for operating modes -> Configure assignments -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the assignments of the meanings in this tab.

Parameters | Description
Absolute operating hours | Meaning for the general absolute time counter. There must be precisely one per item of equipment.
Relative operating hours | Meaning for the general relative time counter. There must be precisely one per item of equipment.
Mode type | Selection of operating mode or frequency regulation from drop-down list.
Absolute operating hours for operation modes | Meaning for absolute time counter for operating mode. Permitted number: 0 to N per item of equipment.
Relative operating hours for operation modes | Meaning for relative time counter for operating mode. Permitted number: 0 to N per item of equipment.
Power plant | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.
Power plant group | Input of the identification for the field in the metadata table that determines the extent of superordinance the power station group has in relation to a machine. Note for developer: ID for field in EQUIPMENTINFO table.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.

Note: The following is applicable for all input fields:

  • If an input field is empty, this input field is marked with a color. The OK button is deactivated.

If an input field was left empty when a dialog was called up, because the configuration of the report does not have any content for it, then this is filled with the standard value.


Validation

zenon Analyzer -> Supplied report templates -> Elements in the report area -> Operating hours assignments for operating modes -> Configure assignments -> Validation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The assignments are validated in this tab.

Validation starts as soon as the tab is opened.

Parameters | Description
List of results of the verification | Lists all results of the validation of the assignments.

Navigation

Previous | Switches to previous tab. (Deactivated in the first tab)
Next | Switches to the next tab. (Deactivated in the last tab)
OK | Applies all changes in all tabs and closes the dialog. The button is deactivated if one of the required input fields is empty or not configured correctly.
Cancel | Discards all changes in all tabs and closes the dialog.


Report templates

zenon Analyzer -> Supplied report templates -> Report templates

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The following pre-configured report templates are available for zenon Analyzer:

  • Alarm and Events Analysis: Evaluation of alarms and events
  • Custom Formula Analysis: Evaluations with custom formulas
  • Historian Analysis: Evaluation of archives
  • Efficiency Class Analysis: Analysis of efficiency classes
  • Energy Data Management: Analysis of energy data
  • Extended Historian Analysis: Extended evaluation of archives
  • ISO 50001: Report templates with the theme ISO 5001, Custom Formula Analysis and Extended Historian Analysis
  • Production Analysis Machine Based: Analysis of loss times and productivity, based on standards such as DIN 8782, DIN 8743, Weihenstephan standards and the best practices of some manufacturing companies
  • OEE analysis: Evaluation of OEE performance indicators Target Actual Analysis Calculates absolute or relative counters from set values or actual values for selected equipment groups.
  • Hydroelectric Power Plant Analysis. Determines various counters for hydroelectric power plants.
  • Wind Power Plant Analysis: Determines various counters for wind power plants.

For some reports, entries in zenon are necessary (meaning, waterfall for example).

Syntax for inputs in zenon

Input in in zenon depends on the version of zenon that is used.

Up to zenon 7.11

Up to and including zenon version 7.11, the meaning and waterfall model is entered in the zenon Resources label property. These can contain meanings for several categories.

The following is applicable to entries in the resource label property:

  • Categories are separated by a semicolon (;).
  • Areas within a category are separated by a comma (,).
  • Categories are marked by an index:
    • ME=: Identifies a (Meaning).
      Syntax: ME=[main meaning as text],[additional meaning as text],[additional meaning as text],…;
      Example: ME=Station_1,Station_2;
    • WF=: Identifies a variable for the waterfall display.
      Syntax: WF=[model name text],[line index INT],[index in column INT],[color code as text #XXXXXX];
    • Every other entry is also understood as a Meaning

Complete syntax for the Resources label property: ME=[meaning1],[meaning2],…,[meaningN];WF=[model name],[row index],[index in row],[color code];

Attention: The Resources label property is limited to 256 characters in the zenon Editor.

From zenon 7.20

From zenon 7.20, there are separate properties in zenon for the definition of Meaning and waterfall, as well as the input of a display name. These entries do not need an identification in front of them.

The following properties in the zenon Analyzer variable properties group provide information for reports in the zenon Analyzer:

  • Visual name: Entry of a display name of the variable in zenon Analyzer. This must be unique in the project. The check is not carried out when issued in zenon, but when imported into zenon Analyzer. If this property is changed after the first export to a zenon Analyzer, these changes are not applied in the zenon Analyzer.
  • Meaning: Entry of the (Meaning) of a variable in the zenon Analyzer. Entry is manual or by means of the Meaning and Waterfall Chart Wizard. Several meanings are separated by a comma.
    Syntax:[Meaning1],[Meaning2],…,[MeaningN]
  • Parameter for waterfall diagram: Parameters of a variable for a waterfall diagram in zenon Analyzer. Entry is manual or by means of the Meaning and Waterfall Chart Wizard. The individual parameters are separated by a comma. Several waterfalls are divided by a semicolon.
    Syntax: [model name],[row index],[index in row],[color code];

Attention: All these input fields are limited to 256 characters in the zenon Editor.

Other topics in this chapter

Alarm and Events Analysis

Custom Formula Analysis

Historian Analysis

Efficiency Class Analysis

Energy Data Management

Extended Historian Analysis

ISO 50001

Production Analysis Line Based

Production Analysis Machine Based

OEE Analysis

Target Actual Analysis

Hydroelectric Power Plant Analysis

Wind Power Plant Analysis


Alarm and Events Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Alarm and Events Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide a range of report templates that assist in the evaluation of alarms and events:

  • Alarm List: Creates a list of alarms in table form for a time range.
  • Top N Alarms: Gets a defined number (N) of alarms that occur most frequently in a time range or have been active for the longest.
  • Alarm Aggregation: Gets the sum of all alarms triggered in a time range and adds up the duration of the different alarms
  • Event list: Creates a list of events in table form for a time range.
  • Top N Events: Gets a defined number (N) of events that occur most frequently in a time range.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar
  2. The dialog for selecting a template is opened

  3. In the Theme drop-down list, select Alarm Analysis
  4. Select the template you want to use as a report template from the drop-down list

Metadata

Metadata used: General
 | used | If not used
Projects | + | mandatory.
Alarm/Event class | + | No filtering or prefiltering for alarm/event classes.
Alarm/Event groups | + | No filtering or prefiltering for alarm/event groups.
Users | + | Alarm List: No display of the user who acknowledges the alarms.
Equipment Modeling | + | No filtering for equipment groups (such as machines).
Archives | - |
Variables | + | mandatory.
Prices | - |
Norm values | - |
Metadata used: Time filter
Lots | + | No reports possible with lot filter.
Shifts | + | No reports possible with shift filter.

Other topics in this chapter

Alarm List

Top N Alarms

Alarm Aggregation

Event List

Top N Events


Alarm List

zenon Analyzer -> Supplied report templates -> Report templates -> Alarm and Events Analysis -> Alarm List

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are base on this template create an alarm list in table form for a time range. In doing so, alarm filtering is possible according to the following criteria:

  • Project only
  • Project and alarm class
  • Project and alarm group
  • Project and equipment group
  • Project and alarm comment

Application examples

For example, alarm list reports are suitable for:

Alarm analysis

Filter
  • A machine in a certain time period

Equipment Groups
  • The most urgent alarms

Alarm Classes
  • Specific alarm groups, such as emergency stops, machine problems, external faults, etc.

Alarm groups
  • For a production lot

Lots
  • A shift

Shift
  • The alarms with specific alarm comments

Alarm comment

Create report

To create an alarm list report:

  1. Select Alarm and Event Analysis in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Alarm list as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Alarm group prefilter (static)

Parameters | Description
Alarm group prefilter (static) | Properties for prefiltering the alarm groups.
Enable alarm group prefiltering | Active: The list of the alarm group prefilters can be configured and used.
List of alarm group filters | Selection of the criteria for the prefiltering of the alarm groups. Click in the check box to select the alarm group. Clicking on the corresponding button selects or deselects all alarm groups. For details, see the Alarm prefiltering chapter.

Alarm class prefilter (static)

Parameters | Description
Alarm class prefilter (static) | Properties for prefiltering the alarm classes.
Enable alarm class prefiltering | Active: The list of the alarm group prefilters can be configured and used.
List of alarm class filters | Selection of the criteria for the prefiltering of the alarm classes. Click on the check box to select alarm classes. Click on the corresponding button to select or deselect all alarm classes. For details, see the Alarm prefiltering chapter.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Alarm filter (dynamic)

Parameters

Description

Alarm filter (dynamic)

Selection of alarm filtering:

  • Project only
  • Project and alarm class
  • Project and alarm group
  • Project and equipment group
  • Project and alarm comment
  • For details see Alarm filter and Event filter.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Note: If the report is linked to a project via time filtering, the project selection is set to the linked project and a check is made to ensure that only archives from this project can be selected in both groupings.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for project selection (if not deactivated by time filtering)
  • 1 x multiple-selection drop-down list for alarm class filtering (if activated via alarm filtering in ZAMS)
  • 1 x multiple-selection drop-down list for alarm group filtering (if activated via alarm filtering in ZAMS)
  • 1 x multiple-selection drop-down list (tree) for equipment model selection (if activated via alarm filtering in ZAMS)
  • 1 x text input for alarm comment (if activated via alarm filtering in ZAMS)

Data representation

The alarm data is always displayed as a table in this template.
The table has the following columns:

  • Variable name (can be sorted dynamically)
  • Description
  • Alarm group (can be sorted dynamically)
  • Alarm class (can be sorted dynamically)
  • Value of the variables.
  • Unit of the variable
  • Limit value index
  • Alarm text
  • Incoming time (can be sorted dynamically)
  • Outgoing time (can be sorted dynamically)
  • Acknowledgment time (can be sorted dynamically)
  • Reactivated time (can be sorted dynamically)
  • Number denoting how often the alarm was reactivated
  • Comment
  • Username

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListAlarmClasses
  • ListAlarmGroups
  • ListEquipmentTree
  • Alarm_GetGroupReferenceList
  • Alarm_GetClassReferenceList
  • Alarm_List
  • Alarm_List_Equipment
  • Alarm_List_Comment


Top N Alarms

zenon Analyzer -> Supplied report templates -> Report templates -> Alarm and Events Analysis -> Top N Alarms

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get a defined number (N) of alarms that occur most frequently in a time range or have been active for the longest. In doing so, different types of alarm filtering are made possible. As an option, the calculation of the active time can also take planned downtime due to shift breaks and shift gaps (time between 2 shifts) into account. Alarm filtering is possible according to the following criteria:

  • Most frequent alarms per project
  • Most frequent alarms per project and alarm class
  • Most frequent alarms per project and alarm group
  • Most frequent alarms per project and equipment group
  • Longest alarm duration per project
  • Longest alarm duration per project and alarm class
  • Longest alarm duration per project and alarm group
  • Longest alarm duration per project and equipment group

Application examples

Top N alarm reports are also suitable for:

Alarm analysis

Filter
  • The most frequent alarms of a machine in a certain time period

Equipment Groups
  • The most frequent urgent alarms

Alarm Classes
  • The most frequent alarms that have led to emergency stops, machine errors, etc.

Alarm groups
  • The most frequent alarms during a production lot

Lots
  • The most frequent alarms during a shift

Shift
  • The alarms for a machine that were active the longest in a certain time period

Equipment Groups
  • The urgent alarms that were active the longest

Alarm Classes
  • The most alarms that were active the longest that have led to emergency stops, machine errors, etc.

Alarm groups
  • The alarms that were active the longest during a production lot

Lots
  • The alarms that were active the longest during a shift

Shift

Create report

To create a Top N alarms report:

  1. Select Alarm and Event Analysis in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Top N alarms as a report template

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Alarm group prefilter (static)

Parameters | Description
Alarm group prefilter (static) | Properties for prefiltering the alarm groups.
Enable alarm group prefiltering | Active: The list of the alarm group prefilters can be configured and used.
List of alarm group filters | Selection of the criteria for the prefiltering of the alarm groups. Click in the check box to select the alarm group. Clicking on the corresponding button selects or deselects all alarm groups. For details, see the Alarm prefiltering chapter.

Alarm class prefilter (static)

Parameters | Description
Alarm class prefilter (static) | Properties for prefiltering the alarm classes.
Enable alarm class prefiltering | Active: The list of the alarm group prefilters can be configured and used.
List of alarm class filters | Selection of the criteria for the prefiltering of the alarm classes. Click on the check box to select alarm classes. Click on the corresponding button to select or deselect all alarm classes. For details, see the Alarm prefiltering chapter.

Alarm look back time

Parameters | Description
Alarm look back time | Time range, which should be taken into account from the start of the time filter retrospectively. For details, see the Alarm Lookback time chapter.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Net alarm time calculation

Parameters | Description
Net alarm time calculation | Properties to calculate the net time.
Consider shift breaks | Active: Shift breaks are taken into account.
Shift list linked to equipment group | Selection of an equipment group for the shift model from the drop-down list. For details, see the Origin of shift data chapter.
Connector for shift data | Selection of a connector for the shift data from a drop-down list. For details, see the Origin of shift data chapter.

Default value for N

Parameters

Description

Default value for N

Definition of the standard value for N.

  • Minimum: 1
  • Maximum: 100
  • Default: 10

Input directly into the field in whole numbers between 1 and 100 or using the Spincontrol arrow (granularity= 1).

Top N calculation

Parameters

Description

Top N calculation

Selection of the calculation method:

  • Most frequent alarms per project
  • Most frequent alarms per project and alarm class
  • Most frequent alarms per project and alarm group
  • Most frequent alarms per project and equipment model
  • Longest pending alarm per project
  • Longest active alarm per project and alarm class
  • Longest active alarm per project and alarm group
  • Longest active alarm per project and equipment model
  • For details see Top N calculation.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Note: If the report is linked to a project via time filtering, the project selection is set to the linked project and a check is made to ensure that only archives from this project can be selected in both groupings.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for project selection (if not deactivated by time filtering)
  • 1 x multiple-selection drop-down list for alarm class filtering (if activated via alarm filtering in ZAMS)
  • 1 x multiple-selection drop-down list for alarm group filtering (if activated via alarm filtering in ZAMS)
  • 1 x multiple-selection drop-down list (tree) for equipment model selection (if activated via alarm filtering in ZAMS)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: Each alarm gets a column. Depending on the Top N calculation, either the number of times the alarm has occurred or active times of all instances of an alarm, summated and corrected for shift breaks and shift gaps, determines the height of the columns.
  • Pie chart: Each alarm has a sector in the diagram. The size of the sector is calculated on the same lines as the calculation of a column in the bar chart.
  • Data table:
    The data table contains the following columns:
    • Variable name (can be sorted dynamically)
    • Alarm text
    • Number denoting how often the alarm has occurred (can be sorted dynamically)
    • Total active duration of all instances of an alarm without shift data correction (gross time, can be sorted dynamically)
    • Total active duration of all instances of the alarm with shift data correction (net time, can be sorted dynamically)
    • Alarm group (can be sorted dynamically)
    • Alarm class (can be sorted dynamically)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListAlarmClasses
  • ListAlarmGroups
  • ListEquipmentTree
  • Alarm_GetGroupReferenceList
  • Alarm_GetClassReferenceList
  • Alarm_GetSecondsWithoutShift
  • Alarm_MostOften
  • Alarm_MostOften2
  • Alarm_MostOften_Equipment
  • Alarm_MostOften_Equipment2
  • Alarm_MostLong
  • Alarm_MostLong2
  • Alarm_MostLong_Equipment
  • Alarm_MostLong_Equipment2


Alarm Aggregation

zenon Analyzer -> Supplied report templates -> Report templates -> Alarm and Events Analysis -> Alarm Aggregation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template obtain the sum of all alarms in a time range and add up the duration of the different alarms. In doing so, the duration of overlapping alarms is only calculated once (overlap adjustment). As an option, the pending time can also take into account planned down times that occur due to shift breaks and gaps between shifts. In addition, alarm filtering is possible according to the following criteria:

  • Project only
  • Project and alarm class
  • Project and alarm group
  • Project and equipment group
  • Project and alarm comment

Application examples

For example, alarm list reports are suitable for:

Alarm analysis

Filter
  • The complete duration of a machine fault during a shift

Shift and equipment groups
  • The complete duration of a machine fault during a production lot

Lot and equipment groups
  • The complete down times of an item of equipment in a time period

Equipment Groups
  • The complete duration of an emergency stop, machine fault, external fault, etc. in a time period

Alarm groups

Create report

To create an Alarm Aggregation report:

  1. Select Alarm and Event Analysis in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Alarm Aggregation as a report template

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Alarm group prefilter (static)

Parameters | Description
Alarm group prefilter (static) | Properties for prefiltering the alarm groups.
Enable alarm group prefiltering | Active: The list of the alarm group prefilters can be configured and used.
List of alarm group filters | Selection of the criteria for the prefiltering of the alarm groups. Click in the check box to select the alarm group. Clicking on the corresponding button selects or deselects all alarm groups. For details, see the Alarm prefiltering chapter.

Alarm class prefilter (static)

Parameters | Description
Alarm class prefilter (static) | Properties for prefiltering the alarm classes.
Enable alarm class prefiltering | Active: The list of the alarm group prefilters can be configured and used.
List of alarm class filters | Selection of the criteria for the prefiltering of the alarm classes. Click on the check box to select alarm classes. Click on the corresponding button to select or deselect all alarm classes. For details, see the Alarm prefiltering chapter.

Alarm look back time

Parameters | Description
Alarm look back time | Time range, which should be taken into account from the start of the time filter retrospectively. For details, see the Alarm Lookback time chapter.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Net alarm time calculation

Parameters | Description
Net alarm time calculation | Properties to calculate the net time.
Consider shift breaks | Active: Shift breaks are taken into account.
Shift list linked to equipment group | Selection of an equipment group for the shift model from the drop-down list. For details, see the Origin of shift data chapter.
Connector for shift data | Selection of a connector for the shift data from a drop-down list. For details, see the Origin of shift data chapter.

Alarm filter (dynamic)

Parameters

Description

Alarm filter (dynamic)

Selection of alarm filtering:

  • Project only
  • Project and alarm class
  • Project and alarm group
  • Project and equipment group
  • Project and alarm comment
  • For details see Alarm filter and Event filter.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Note: If the report is linked to a project via time filtering, the project selection is set to the linked project and a check is made to ensure that only archives from this project can be selected in both groupings.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for project selection (if not deactivated by time filtering)
  • 1 x multiple-selection drop-down list for alarm class filtering (if activated via alarm filtering in ZAMS)
  • 1 x multiple-selection drop-down list for alarm group filtering (if activated via alarm filtering in ZAMS)
  • 1 x multiple-selection drop-down list (tree) for equipment model selection (if activated via alarm filtering in ZAMS)
  • 1 x text input for alarm comment (if activated via alarm filtering in ZAMS)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: Each aggregation object (project, combination of project and alarm class, combination of project and alarm groups, combination of project and equipment model, combination of project and comment) has a column. The active duration of all instances of an alarm, summated and corrected for shift breaks and shift gaps determines the height of the column.
  • Pie chart: Each aggregation object has a sector in the diagram. The size of the sector is calculated on the same lines as the calculation of a column in the bar chart.
  • Data table:
    The data table contains the following columns:
    • Name of the aggregation object (can be expanded)
    • Variable name
    • Alarm text
    • Alarm group (not present if contained in the aggregation)
    • Alarm class (not present if contained in the aggregation)
    • Equipment model (not present if contained in the aggregation)
    • Alarm comment (not present if contained in the aggregation)
    • Incoming time
    • Outgoing time
    • Active duration without correction (gross time, sum per aggregation object)
    • Active duration with correction (net time, sum per aggregation object)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjectsWithShift
  • ListLots
  • ListShifts
  • ListAlarmClasses
  • ListAlarmGroups
  • ListEquipmentTree
  • Alarm_GetGroupReferenceList
  • Alarm_GetClassReferenceList
  • Alarm_GetSecondsWithoutShift
  • Alarm_Aggregate_Project
  • Alarm_Aggregate_Project2
  • Alarm_Aggregate_Class
  • Alarm_Aggregate_Class2
  • Alarm_Aggregate_Group
  • Alarm_Aggregate_Group2
  • Alarm_Aggregate_Equipment
  • Alarm_Aggregate_Equipment2
  • Alarm_Aggregate_Comment
  • Alarm_Aggregate_Comment2


Event List

zenon Analyzer -> Supplied report templates -> Report templates -> Alarm and Events Analysis -> Event List

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are base on this template create an event list in table form for a time range. In doing so, filtering is possible according to the following criteria:

  • Project only
  • Project and event class
  • Project and event group
  • Project and equipment group
  • Project and event comment

Application examples

For example, event list reports are suitable for:

Event evaluation

Filter
  • A machine in a certain time period

Equipment Groups
  • The most urgent events

Event classes
  • Specific event groups, such as emergency stops, machine problems, external faults, etc.

Event groups
  • The events with specific event comments

Event comments

Create report

To create a Event list report:

  1. Select Alarm and Event Analysis in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Event list as a report template

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Event groups prefilter (static)

Parameters | Description
Event groups prefilter (static) | Properties for prefiltering the event groups.
Enable event groups prefiltering | Active: The list of the event group prefilters can be configured and used.
List of event groups filters | Selection of the criteria for the prefiltering of the event groups. Click in the check box to select the event group. Clicking on the corresponding button selects or deselects all event groups. For details, see the event prefiltering chapter.

Event class prefilter (static)

Parameters | Description
Event groups prefilter (static) | Properties for prefiltering the event classes.
Enable event groups prefiltering | Active: The list of the event group prefilters can be configured and used.
List of event groups filters | Selection of the criteria for the prefiltering of the event classes. Click in the check box to select the event class. Clicking on the corresponding button selects or deselects all event classes. For details, see the event prefiltering chapter.

Selection of event type

Parameters

Description

Events for known variables
  • Active: Event class for variables that exist in the database are included.

Events for unknown variables
  • Active: Events for variables that do not exist in the database are included.

System events
  • Active: System events are included.

Note: At least one event type must be selected.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Event filter (dynamic)

Parameters

Description

Event filter (dynamic)

Selection of event filtering from drop-down list:

  • Project only
  • Project and event class
  • Project and event group
  • Project and equipment group
  • Project and event comment

For details see Alarm filter and Event filter.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Note: If the report is linked to a project via time filtering, the project selection is set to the linked project and a check is made to ensure that only archives from this project can be selected in both groupings.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection

Other parameters

  • 1 x multiple-selection drop-down list for project selection (if not deactivated by time filtering)
  • 1 x multiple-selection drop-down list for event class filtering (if activated via event filtering in ZAMS)
  • 1 x multiple-selection drop-down list for event groups filtering (if activated via event filtering in ZAMS)
  • 1 x multiple-selection drop-down list (tree) for equipment model selection (if activated via event filtering in ZAMS)
  • 1 x text input for event comment (if activated via event filtering in ZAMS)

Data representation

The alarm data is always displayed as a table in this template.
The table has the following columns:

  • Variable name (can be sorted dynamically)
  • Description
  • Event group (can be sorted dynamically)
  • Event class (can be sorted dynamically)
  • Value of the variables.
  • Unit of the variable
  • Limit value index
  • Event text
  • Incoming time (can be sorted dynamically)
  • User name

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListAlarmClasses
  • ListAlarmGroups
  • ListEquipmentTree
  • Alarm_GetGroupReferenceList
  • Alarm_GetClassReferenceList
  • Event_List
  • Event_List_Comment
  • Event_List_Equipment


Top N Events

zenon Analyzer -> Supplied report templates -> Report templates -> Alarm and Events Analysis -> Top N Events

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that relate to this template get a defined number (N) of events that occur most frequently in a time period. In doing so, different types of event filtering are made possible. Event filtering is possible according to the following criteria:

  • Most frequent events per project
  • Most frequent events per project and event group
  • Most frequent events per project and event group
  • Most frequent events per project and equipment group

Application examples

Top N events reports are also suitable for:

Event evaluation

Filter
  • The most frequent events of a machine in a certain time period

Equipment Groups
  • The most frequent urgent events

Event classes
  • The most frequent events that have led to specific events, such as emergency stops, machine errors, external errors, etc.

Event groups

Create report

To create a Top N events report:

  1. Select Alarm and Event Analysis in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Top N events as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Event groups prefilter (static)

Parameters | Description
Event groups prefilter (static) | Properties for prefiltering the event groups.
Enable event groups prefiltering | Active: The list of the event group prefilters can be configured and used.
List of event groups filters | Selection of the criteria for the prefiltering of the event groups. Click in the check box to select the event group. Clicking on the corresponding button selects or deselects all event groups. For details, see the event prefiltering chapter.

Event class prefilter (static)

Parameters | Description
Event groups prefilter (static) | Properties for prefiltering the event classes.
Enable event groups prefiltering | Active: The list of the event group prefilters can be configured and used.
List of event groups filters | Selection of the criteria for the prefiltering of the event classes. Click in the check box to select the event class. Clicking on the corresponding button selects or deselects all event classes. For details, see the event prefiltering chapter.

Selection of event type

Parameters

Description

Events for known variables
  • Active: Event class for variables that exist in the database are included.

Events for unknown variables
  • Active: Events for variables that do not exist in the database are included.

System events
  • Active: System events are included.

Note: At least one event type must be selected.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Default value for N

Parameters

Description

Default value for N

Definition of the standard value for N.

  • Minimum: 1
  • Maximum: 100
  • Default: 10

Input directly into the field in whole numbers between 1 and 100 or using the Spincontrol arrow (granularity= 1).

Top N calculation

Parameters

Description

Top N calculation

Selection of the calculation method:

  • Most frequent alarms per project
  • Most frequent alarms per project and alarm class
  • Most frequent alarms per project and alarm group
  • Most frequent alarms per project and equipment model
  • Longest pending alarm per project
  • Longest active alarm per project and alarm class
  • Longest active alarm per project and alarm group
  • Longest active alarm per project and equipment model
  • For details see Top N calculation.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Note: If the report is linked to a project via time filtering, the project selection is set to the linked project and a check is made to ensure that only archives from this project can be selected in both groupings.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection

Other parameters

  • 1 x multiple-selection drop-down list for project selection (if not deactivated by time filtering)
  • 1 x multiple-selection drop-down list for event class filtering (if activated via event filtering in ZAMS)
  • 1 x multiple-selection drop-down list for event groups filtering (if activated via event filtering in ZAMS)
  • 1 x multiple-selection drop-down list (tree) for equipment model selection (if activated via event filtering in ZAMS)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: Each alarm gets a column. Depending on the Top N calculation, either the number of times the alarm has occurred or active times of all instances of an alarm, summated and corrected for shift breaks and shift gaps, determines the height of the columns.
  • Pie chart: Each alarm has a sector in the diagram. The size of the sector is calculated on the same lines as the calculation of a column in the bar chart.
  • Data table:
    The data table contains the following columns:
    • Variable name (can be sorted dynamically)
    • Event text
    • Event group (can be sorted dynamically)
    • Event class (can be sorted dynamically)
    • Number denoting how often the event has occurred (can be sorted dynamically)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListAlarmClasses
  • ListAlarmGroups
  • ListEquipmentTree
  • Alarm_GetGroupReferenceList
  • Alarm_GetClassReferenceList
  • Event_List
  • Event_List_Comment
  • Event_List_Equipment
  • Event_MostOften
  • Event_MostOften_Equipment


Custom Formula Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Custom Formula Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports for this theme provide report templates for user-defined formulas:

  • Custom Formula Trend: Trend display of user-defined formulas for a time range.
  • Custom Formula Trend Comparison: Trend display of user-defined formulas for two time ranges.
  • Custom Formula Aggregated Trend: Trend display of aggregated user-defined formulas for a time range.
  • Custom Formula Aggregated Trend Comparison: Trend display of aggregated user-defined formulas for two time ranges.
  • Custom Formula Aggregation: Trend display of aggregated, user-defined formulas for a time range.
  • Custom Formula Aggregation Comparison: Trend display of aggregated, user-defined formulas for two time ranges.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar
  2. The dialog for selecting a template is opened

  3. In the Theme drop-down list, select Custom Formula Analysis
  4. Select the template you want to use as a report template from the drop-down list

Configuring user-defined formulas in the ZAMS

To configure user-defined formulas in a report of this topic in the ZAMS:

  1. Open a report template
  2. Configure the report as usual
  3. Open the Configure custom formulas dialog
  4. Filter the desired variables
  5. Add the fields and set the parameters for these
  6. Set the parameters for the cost fields
  7. Add the constants as required
  8. Create the basic data formulas
  9. For reports with archive aggregation:
    1. Configure the aggregations
  10. For reports with archive aggregation, trend archiving and variants thereof with a comparison:
    1. Set the parameters for the aggregation formulas
  11. Confirm the configuration by clicking on OK.
  12. Open the Arrange and colorize formula results dialog
  13. Sort the formulas
  14. Define, if desired, individual colors
  15. Confirm the configuration by clicking on OK.

info Information

Formulas are validated in the Report Launcher before output.

Other topics in this chapter

Custom Formula Trend

Custom Formula Trend Comparison

Custom Formula Aggregated Trend

Custom Formula Aggregated Trend Comparison

Custom Formula Aggregation

Custom Formula Aggregation Comparison

Example for configuration in the ZAMS


Custom Formula Trend

zenon Analyzer -> Supplied report templates -> Report templates -> Custom Formula Analysis -> Custom Formula Trend

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend display of user-defined formulas for a time range. The data can be displayed in graphics and tables.

Create report

To create a Custom Formula Trend report:

  1. In the Theme drop-down list, select Custom Formula Analysis
  2. from the drop-down list, select Custom Formula Trend as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Custom formulas

Parameters

Description

Custom formulas

List and buttons to display and configure user-defined formulas.

Configure custom formulas

Opens the dialog to configure user-defined formulas.

The dialog is different for:

  • Reports without aggregation over the time range
  • Reports with aggregation over the time range

Arrange and colorize formula results

Opens the dialog to sort and color user-defined formulas.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Column chart and table
  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Column chart
  • Table
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values.
  • Line chart (optional): Trend of the detail values with one line per variable.
  • Bar diagram (optional): Trend of the detail values with a set of columns per variable.
  • Data as a table (optional) with the columns:
    • Indicator color (no text; if a color is set, this is used as a background color)
    • Indicator name
    • Timestamp
    • Value (with unit of measurement)
  • Data as a pivot table (optional):
    • 1st Column: Timestamp
    • After this, a column per indicator with:
      Indicator names as a heading (if a color is set, this is used as a background color) and
      value (with unit of measurement) as content

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • CustomIndicators_Trend
  • CustomIndicators_GetBaseData
  • CustomIndicators_PerformCalculations


Custom Formula Trend Comparison

zenon Analyzer -> Supplied report templates -> Report templates -> Custom Formula Analysis -> Custom Formula Trend Comparison

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend display of user-defined formulas for two time ranges. The data can be displayed in graphics and tables.

Create report

To create a Custom Formula Trend Comparison report:

  1. In the Theme drop-down list, select Custom Formula Analysis
  2. from the drop-down list, select Custom Formula Trend Comparison as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Custom formulas

Parameters

Description

Custom formulas

List and buttons to display and configure user-defined formulas.

Configure custom formulas

Opens the dialog to configure user-defined formulas.

The dialog is different for:

  • Reports without aggregation over the time range
  • Reports with aggregation over the time range

Arrange and colorize formula results

Opens the dialog to sort and color user-defined formulas.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Column chart and table
  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Column chart
  • Table
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values.
  • Line chart (optional): Trend of the detail values with one line per variable.
  • Bar diagram (optional): Trend of the detail values with a set of columns per variable.
  • Data as a table (optional) with the columns:
    • Indicator color (no text; if a color is set, this is used as a background color)
    • Indicator name
    • Timestamp
    • Value (with unit of measurement)
  • Data as a pivot table (optional):
    • 1st Column: Timestamp
    • After this, a column per indicator with:
      Indicator names as a heading (if a color is set, this is used as a background color) and
      value (with unit of measurement) as content

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • CustomIndicators_Trend
  • CustomIndicators_GetBaseData
  • CustomIndicators_PerformCalculations


Custom Formula Aggregated Trend

zenon Analyzer -> Supplied report templates -> Report templates -> Custom Formula Analysis -> Custom Formula Aggregated Trend

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend display of aggregated user-defined formulas for a time range. The values are aggregated in intervals within the time range. This aggregated data is displayed in the trend as graphics and tables.

Create report

To create a Custom Formula Aggregated Trend report:

  1. In the Theme drop-down list, select Custom Formula Analysis
  2. from the drop-down list, select Custom Formula Aggregated Trend as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Custom formulas

Parameters

Description

Custom formulas

List and buttons to display and configure user-defined formulas.

Configure custom formulas

Opens the dialog to configure user-defined formulas.

The dialog is different for:

  • Reports without aggregation over the time range
  • Reports with aggregation over the time range

Arrange and colorize formula results

Opens the dialog to sort and color user-defined formulas.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Column chart and table
  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Column chart
  • Table
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list for the selection of the interval size in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values.
  • Line chart (optional): Trend of the aggregated values with a line per variable.
  • Bar diagram (optional): Trend of the aggregated values with a set of columns per variable.
  • Data as a table (optional) with the columns:
    • Indicator color (no text; if a color is set, this is used as a background color)
    • Indicator name
    • Time stamp - interval start
    • Time stamp - interval end
    • Value (with unit of measurement)
  • Data as a pivot table (optional):
    • 1st Column: Time stamp - interval start
    • 2. Column: Time stamp - interval end
    • After this, a column per indicator with:
      Indicator names as a heading (if a color is set, this is used as a background color) and
      value (with unit of measurement) as content

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • CustomIndicators_AggregatedTrend
  • CustomIndicators_GetBaseData
  • CustomIndicators_PerformCalculations
  • CustomIndicators_PerformAggregations


Custom Formula Aggregated Trend Comparison

zenon Analyzer -> Supplied report templates -> Report templates -> Custom Formula Analysis -> Custom Formula Aggregated Trend Comparison

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend display of aggregated user-defined formulas for two time ranges. The values are aggregated in intervals within the time range. This aggregated data is displayed in the trend as graphics and tables.

Create report

To create an archive aggregation trend comparison with user-defined formulas report:

  1. In the Theme drop-down list, select Custom Formula Analysis
  2. Select, as a report template, Archive aggregation trend comparison with user-defined formulas from the drop-down list

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Custom formulas

Parameters

Description

Custom formulas

List and buttons to display and configure user-defined formulas.

Configure custom formulas

Opens the dialog to configure user-defined formulas.

The dialog is different for:

  • Reports without aggregation over the time range
  • Reports with aggregation over the time range

Arrange and colorize formula results

Opens the dialog to sort and color user-defined formulas.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Column chart and table
  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Column chart
  • Table
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list for the selection of the interval size in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values.
  • Line chart (optional): Trend of the aggregated values with a line per variable.
  • Bar diagram (optional): Trend of the aggregated values with a set of columns per variable.
  • Data as a table (optional) with the columns:
    • Indicator color (no text; if a color is set, this is used as a background color)
    • Indicator name
    • Time stamp - interval start
    • Time stamp - interval end
    • Value (with unit of measurement)
  • Data as a pivot table (optional):
    • 1st Column: Time stamp - interval start
    • 2nd Column: Time stamp - interval end
    • After this, a column per indicator with:
      Indicator names as a heading (if a color is set, this is used as a background color) and
      value (with unit of measurement) as content

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • CustomIndicators_AggregatedTrend
  • CustomIndicators_GetBaseData
  • CustomIndicators_PerformCalculations
  • CustomIndicators_PerformAggregations


Custom Formula Aggregation

zenon Analyzer -> Supplied report templates -> Report templates -> Custom Formula Analysis -> Custom Formula Aggregation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend display of aggregated, user-defined formulas for a time range. The following aggregation functions are available:

  • Sum
  • Average
  • Minimum
  • Maximum

Each formula can be aggregated with all functions. Each combination of a formula and an aggregation function is treated as a separate field. The data can be displayed as graphics and an optional table.

Create report

To create an Custom Formula Aggregation report:

  1. In the Theme drop-down list, select Custom Formula Analysis
  2. Select Custom Formula Aggregation from the drop-down list as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Custom formulas

Parameters

Description

Custom formulas

List and buttons to display and configure user-defined formulas.

Configure custom formulas

Opens the dialog to configure user-defined formulas.

The dialog is different for:

  • Reports without aggregation over the time range
  • Reports with aggregation over the time range

Arrange and colorize formula results

Opens the dialog to sort and color user-defined formulas.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list for the selection of the interval size in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values.
  • Bar diagram (optional): Display of the aggregation values in a bar chart.
  • Pie chart (optional): Display of the aggregation values in a pie chart.
  • Data as a table (optional) with the columns:
    • Indicator color (no text; if a color is set, this is used as a background color)
    • Indicator name
    • Value (with unit of measurement)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • CustomIndicators_Aggregation
  • CustomIndicators_GetBaseData
  • CustomIndicators_PerformCalculations
  • CustomIndicators_PerformAggregations


Custom Formula Aggregation Comparison

zenon Analyzer -> Supplied report templates -> Report templates -> Custom Formula Analysis -> Custom Formula Aggregation Comparison

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend display of aggregated, user-defined formulas for two time ranges. The following aggregation functions are available:

  • Sum
  • Average
  • Minimum
  • Maximum

Each formula can be aggregated with all functions. Each combination of a formula and an aggregation function is treated as a separate field. The data can be displayed as graphics and an optional table.

Create report

To create a Custom Formula Aggregation Comparison report:

  1. In the Theme drop-down list, select Custom Formula Analysis
  2. from the drop-down list, select Custom Formula Aggregation Comparison as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Custom formulas

Parameters

Description

Custom formulas

List and buttons to display and configure user-defined formulas.

Configure custom formulas

Opens the dialog to configure user-defined formulas.

The dialog is different for:

  • Reports without aggregation over the time range
  • Reports with aggregation over the time range

Arrange and colorize formula results

Opens the dialog to sort and color user-defined formulas.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list for the selection of the interval size in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values.
  • Bar diagram (optional): Display of the aggregation values in a bar chart.
  • Pie chart (optional): Display of the aggregation values in a pie chart.
  • Data as a table (optional) with the columns:
    • Indicator color (no text; if a color is set, this is used as a background color)
    • Indicator name
    • Value (with unit of measurement)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • CustomIndicators_Aggregation
  • CustomIndicators_GetBaseData
  • CustomIndicators_PerformCalculations
  • CustomIndicators_PerformAggregations


Example for configuration in the ZAMS

zenon Analyzer -> Supplied report templates -> Report templates -> Custom Formula Analysis -> Example for configuration in the ZAMS

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In a report:

  • The average water costs per 1000 bottles are to be displayed
  • A performance indicator value per report period is calculated and displayed as a bar chart and in a table
  • The average costs in relation to the good units is to be colored green
  • The average costs in relation to the total amount are to be colored yellow

The data for this example comes from the Analyzer 2.0 demo project ZAD_GBL.

To create this report:

  1. Create a report based on the Archive aggregation with user-defined formulas report template.

  2. In the report, click on the Configure custom formulas... button.

  3. Configure the water meter:
    1. These are logged in an archive called WATER CYCLIC DATA. Set the filter for the archive name accordingly.
    2. Click on Add all.
    3. Assign a suitable name

  4. Carry out the same step for the production counters from the PRODUCTION CYCLIC DATA archive:

  5. Configure the Cost calculation for both water meters:

  6. Switch to the Constant Fields tab and set the parameters for the constants:

  7. Configure the aggregation fields: Activate the checkboxes for:
    1. Sum of Good Units
    2. Sum of Total Units
    3. Sum of WaterCostsM2
    4. Sum of WaterCostsM4
    5. And for the constant value 1000_

  8. Switch to the tab of calculated fields after aggregation:
    1. Enter a formula name for the water costs: WaterCosts.
    2. Click on the symbol Editing:
    3. The formula editor is opened.
  9. Calculate the water costs:

  10. These are then used to calculate the first desired formula for the water costs for a total amount of 1000 bottles in a new calculated field:

  11. With the calculation of the two formulas and the configuration of visibility and units of measurement, editing in the formula editor is concluded.

  12. In the ZAMS, click on the Arrange and color formula results button.

    The dialog to configure sorting and coloring of the formula results is started:

  13. Define the coloring. To do this:
    1. Set the checkboxes in front of Standard coloring to inactive.
    2. The color preview and the button for the color configuration are displayed.
    3. Click on Color.
    4. Select the desired color

Results in the Report Launcher:


Historian Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports of this theme provide report templates that aid the evaluation and direct or aggregated display of archive data:

  • Historian Trend: Gets archive data for a time range and displays this without aggregation in a trend
  • Historian Trend Comparison: Gets archive data for two time ranges and provides this without aggregation of each trend for comparison.
  • Historian Aggregated Trend: Gets archive data for a time range, aggregates this in intervals in the time range and displays it as a trend.
  • Historian Aggregated Trend Comparison: Gets archive data for two time ranges, aggregates this in intervals in the time range and displays it as a trend for comparison.
  • Historian Aggregated Trend with online variable selection: Gets archive data for a time range, aggregates this in intervals in the time range and displays these aggregations as a trend.
  • Historian Aggregated Trend Comparison with online variable selection: Gets archive data for two time ranges, aggregates these in intervals in the time range and provides these aggregations each in a separate trend per time range.
  • Historian Aggregation: Gets archive data for a time range, aggregates this and displays each of the aggregation results separately
  • Historian Aggregation Comparison: Gets archive data for two time ranges, aggregates this and displays each of the aggregation results for both time ranges separately
  • Historian Distribution: Gets archive data for a variable, rounds this up to a configurable rounding factor and displays the distribution of the values. In addition, the types of aggregation are calculated and displayed with markers.
  • Historian Distribution Comparison: Gets archive data for a variable from two time ranges, rounds this up to a configurable rounding factor and displays the distribution of the values. In addition, the types of aggregation are calculated and displayed with markers.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar.

    The dialog for selecting a template is opened.

  2. In the Theme drop-down list, select Historian Analysis
  3. Select the template you want to use as a report template from the drop-down list.

Metadata

Metadata used: General
 | used | If not used
Projects | + | mandatory.
Alarm/Event class | - |
Alarm/Event groups | - |
Users | - |
Equipment Modeling | - |
Archives | + | mandatory.
Variables | + | mandatory.
Prices | - |
Norm values | - |
Metadata used: Time filter
Lots | + | No reports possible with lot filter.
Shifts | + | No reports possible with shift filter.

Other topics in this chapter

Historian Trend

Historian Trend Comparison

Historian Aggregated Trend

Historian Aggregated Trend Comparison

Historian Aggregated Trend with online variable selection

Historian Aggregated Trend Comparison with online variable selection

Historian Aggregation

Historian Aggregation Comparison

Historian Distribution

Historian Distribution Comparison


Historian Trend

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Trend

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get archive data for a time range and display this without aggregation in a trend.

Application examples

Historian Trend reports are suitable for the display of the course of all types of measurement values (such as pressures, temperatures etc.) within a freely-selectable time period, lot or shift.

Create report

To create a Historian Trend report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Trend as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Column chart and table
  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Column chart
  • Table
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects (if not prescribed by the time filter)
  • 1 x multiple-selection drop-down list for selection of the archives
  • 1 x multiple-selection drop-down list for selection of the variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart: A trend line covering the curve is shown for each variable
  • Column chart: The trend is constructed as a bar chart over the time period. In doing so, each variable gets a column for each time stamp.
  • Archive data table:
    Table with the following columns:
    • Variable name (can be sorted dynamically)
    • Time stamp (can be sorted dynamically)
    • Value
    • Text value
  • Pivot table: A table with a column for the time stamp and a column each for the value of each variable.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • ListLots
  • ListShifts
  • Archive_GetPlainTrendData


Historian Trend Comparison

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Trend Comparison

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get archive data for two time ranges and display this without aggregation in a trend as a comparison.

Application examples

Historian Trend Comparison reports are suitable for the comparison of the development of all types of measured values (such as pressures, temperatures, etc.) over two time periods, lots or shifts.

Create report

To create a Historian Trend Comparison report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Trend Comparison as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Column chart and table
  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Column chart
  • Table
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects (if not prescribed by the time filter)
  • 1 x multiple-selection drop-down list for selection of the archives
  • 1 x multiple-selection drop-down list for selection of the variables

Data representation

  • The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:
  • Line chart: A trend line covering the curve is shown for each variable
  • Column chart: The trend is created as a group of columns or bars over the time period. In doing so, each variable gets a column for each time stamp.
  • Archive data table:
    Table with the following columns:
    • Variable name (can be sorted dynamically)
    • Time stamp (can be sorted dynamically)
    • Value
    • Text value
  • Pivot table: A table with a column for the time stamp and a column each for the value of each variable.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • ListLots
  • ListShifts
  • Archive_GetPlainTrendData


Historian Aggregated Trend

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Aggregated Trend

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get archive data for a time range, aggregate this into intervals in the time range and display it as a trend.

info Information

This report can process numeric variables and string variables. However, diagrams must have numeric variables.

If the data display has a diagram and there are only string variables, the diagram is not added into the report. It is replaced by an empty space.

Create report

To create a Historian Aggregated Trend report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Aggregated Trend as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Archive aggregation configuration

Parameters

Description

Archive aggregation configuration

Archive aggregation configuration

Aggregation function

The following are available for aggregation:

  • Summation
  • Calculate average values
  • Determine minimum values
  • Determine maximum values

Select from drop-down list.

Archive configuration

Display of the archive variables in a tree structure. This structure is constructed as follows:

  • Project name
  • Archive name
  • Variable name
  • Aggregation type of the variables in the archive

Selection by clicking on the desired object.

If the report is linked to a project via the parameters of the time filter, a check is made to ensure that only archives and variables from the project to which the report is linked are used.

Archive aggregation variable configuration

Clicking on the button opens the dialog to select the archives and variables. For details, see the Configure archives section.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Bar chart
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the aggregation interval

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart: A trend curve over the time period is shown for each variable. STRING variables are not displayed.
  • Column chart: The trend is constructed as a bar chart over the time period. Each variable gets a column for each time stamp. STRING variables are not displayed.
  • Pivot table: A table with columns for From and To of the aggregation interval and, for each column, for the value of each variable.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • Archive_ConvertToOneSecondCycle (UDF)
  • ListLots
  • ListShifts
  • Archive_GetAggregatedTrendData


Historian Aggregated Trend Comparison

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Aggregated Trend Comparison

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get archive data for two time ranges, aggregate this into intervals in the time range and display these as a trend for comparison.

info Information

This report can process numeric variables and string variables. However, diagrams must have numeric variables.

If the data display has a diagram and there are only string variables, the diagram is not added into the report. It is replaced by an empty space.

Create report

To create a Historian Aggregated Trend Comparison report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Aggregated Trend Comparison as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Archive aggregation configuration

Parameters

Description

Archive aggregation configuration

Archive aggregation configuration

Aggregation function

The following are available for aggregation:

  • Summation
  • Calculate average values
  • Determine minimum values
  • Determine maximum values

Select from drop-down list.

Archive configuration

Display of the archive variables in a tree structure. This structure is constructed as follows:

  • Project name
  • Archive name
  • Variable name
  • Aggregation type of the variables in the archive

Selection by clicking on the desired object.

If the report is linked to a project via the parameters of the time filter, a check is made to ensure that only archives and variables from the project to which the report is linked are used.

Archive aggregation variable configuration

Clicking on the button opens the dialog to select the archives and variables. For details, see the Configure archives section.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Bar chart
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list for selection of the aggregation interval

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart: A trend curve over the time period is shown for each variable. STRING variables are not displayed.
  • Column chart: The trend is constructed as a bar chart over the time period. Each variable gets a column for each time stamp. STRING variables are not displayed.
  • Pivot table: A table with columns for From and To of the aggregation interval and, for each column, for the value of each variable.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • Archive_ConvertToOneSecondCycle (UDF)
  • ListLots
  • ListShifts
  • Archive_GetAggregatedTrendData


Historian Aggregated Trend with online variable selection

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Aggregated Trend with online variable selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Gets archive data for a time range
  • Aggregates this in intervals in the time range
  • Displays these aggregations in a trend

Difference to Historian Aggregated Trend: All reports with this template use a common main stored procedure and the variables are selected in the Report Launcher.

Create report

To create an Hisotrian Aggregated Trend with online variable selection report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Hisotrian Aggregated Trend with online variable selection as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Column chart and table
  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Column chart
  • Table
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects (if not prescribed by the time filter)
  • 1 x multiple-selection drop-down list for selection of the archives
  • 1 x multiple-selection drop-down list for selection of the variables
  • 1 x single-selection drop-down list to select the aggregation function (sum, average value, minimum, maximum)
  • 1 x single-selection drop-down list to select the aggregation interval (1 minute, 15 minutes, 30 minutes, 1 hour, 2 hours, 6 hours, 12 hours, 1 day, 1 week, 1 month, 1 quarter, 1 year)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart: A trend curve over the time period is shown for each variable
  • Column chart: The trend is constructed as a bar chart over the time period. Each variable gets a column for each time stamp.
  • Archive data table: A table with the following columns:
    • Variable name (can be sorted dynamically)
    • Time stamp from the start of the aggregation interval (can be sorted dynamically)
    • Time stamp from the end of the aggregation interval (can be sorted dynamically)
    • Numerical value with unit or text value (is decided on the basis of the data type)
  • Pivot table: A table with a column each for:
    • Time stamp from the start and end of the aggregation interval
    • Numerical value with unit or text value (decided on the basis of the data type)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • Archive_GetDynamicAggregatedTrendData
  • ListLots
  • ListShifts


Historian Aggregated Trend Comparison with online variable selection

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Aggregated Trend Comparison with online variable selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get archive data for two time ranges
  • Aggregates this in intervals in the time range
  • Display these aggregations in a separate trend per time range

The difference to Historian Aggregated Trend Comparison: All reports with this template use a common main stored procedure and the variables are selected in the Report Launcher.

Create report

To create an Historian Aggregated Trend Comparison with online variable selection report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Aggregated Trend Comparison with online variable selection as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Column chart and table
  • Line chart and pivot table
  • Column chart and pivot table
  • Line chart
  • Column chart
  • Table
  • Pivot table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects (if not prescribed by the time filter)
  • 1 x multiple-selection drop-down list for selection of the archives
  • 1 x multiple-selection drop-down list for selection of the variables
  • 1 x single-selection drop-down list to select the aggregation function (sum, average value, minimum, maximum)
  • 1 x single-selection drop-down list to select the aggregation interval (1 minute, 15 minutes, 30 minutes, 1 hour, 2 hours, 6 hours, 12 hours, 1 day, 1 week, 1 month, 1 quarter, 1 year)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart: A trend curve over the time period is shown for each variable
  • Column chart: The trend is constructed as a bar chart over the time period. Each variable gets a column for each time stamp.
  • Archive data table: A table with the following columns:
    • Variable name (can be sorted dynamically)
    • Time stamp from the start of the aggregation interval (can be sorted dynamically)
    • Time stamp from the end of the aggregation interval (can be sorted dynamically)
    • Numerical value with unit or text value (is decided on the basis of the data type)
  • Pivot table: A table with a column each for:
    • Time stamp from the start and end of the aggregation interval
    • Numerical value with unit or text value (decided on the basis of the data type)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • Archive_GetDynamicAggregatedTrendData
  • ListLots
  • ListShifts


Historian Aggregation

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Aggregation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get archive data for a time range, aggregate this and display each of the following aggregation types separately:

  • Sum
  • Average
  • Minimum
  • Maximum

Create report

To create a Historian Aggregation report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Aggregation as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects (if not prescribed by the time filter)
  • 1 x multiple-selection drop-down list for selection of the archives
  • 1 x multiple-selection drop-down list for selection of the variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: A column chart is drawn for each aggregation function. The respective aggregation result of each variable contains a column
  • Pie chart: A pie chart is drawn for each aggregation function. The respective aggregation result of each variable contains a sector.
  • Table: A table with the following columns:
    • Variable name (can be sorted dynamically)
    • Sum (can be sorted dynamically)
    • Minimum (can be sorted dynamically)
    • Average (can be sorted dynamically)
    • Maximum (can be sorted dynamically)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • Archive_GetAggregatedData
  • ListLots
  • ListShifts


Historian Aggregation Comparison

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Aggregation Comparison

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get archive data for two time ranges and display each of the following aggregation types for both time ranges separately:

  • Sum
  • Average
  • Minimum
  • Maximum

Create report

To create a Historian Aggregation report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Aggregation as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects (if not prescribed by the time filter)
  • 1 x multiple-selection drop-down list for selection of the archives
  • 1 x multiple-selection drop-down list for selection of the variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: A column chart is drawn for each aggregation The respective aggregation of each variable contains a column
  • Pie chart: A pie chart is drawn for each aggregation. The respective aggregation of each variable contains a sector.
  • Table: A table with the following columns:
    • Variable name (can be sorted dynamically)
    • Sum (can be sorted dynamically)
    • Minimum (can be sorted dynamically)
    • Average (can be sorted dynamically)
    • Maximum (can be sorted dynamically)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • Archive_GetAggregatedData
  • ListLots
  • ListShifts


Historian Distribution

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Distribution

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get archive data for a variable, round this up to a configurable rounding factor and display the distribution of the values. In addition, the following types of aggregation are calculated and displayed with markers:

  • Minimum
  • Average
  • Maximum

Application examples

Historian Trend reports are suitable for the graphic display of distributions of measured values. This can establish how many production items are within the permitted tolerances. In addition, it is possible to assess whether the measured values tend to deviate upwards or downwards.

Create report

To create a Historian Distribution report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Distribution as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Column chart and table
  • Column chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list for selection of the projects (if not prescribed by the time filter)
  • 1 x single-selection drop-down list for selection of the archive
  • 1 x single-selection drop-down list for selection of the variables
  • 1 x single-selection drop-down list for selection of the rounding intervals

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: For the distribution, a trend is drawn using the X axis. Each variable value has a column. The height of this shows how often the value has occurred. Markers for minimum, average and maximum are drawn
  • Table: There are 2 tables.

    Columns table 1:

    • Minimum
    • Average
    • Maximum

    Columns table 2:

    • Variable value
    • Number denoting how often the value occurred.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • Archive_GetAggregatedData
  • Archive_GetDistributionData
  • ListLots
  • ListShifts


Historian Distribution Comparison

zenon Analyzer -> Supplied report templates -> Report templates -> Historian Analysis -> Historian Distribution Comparison

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get archive data for a variable from two time ranges, round this up to a configurable rounding factor and display the distribution of the values as a comparison. In addition, the following types of aggregation are calculated and displayed with markers:

  • Minimum
  • Average
  • Maximum

Application examples

Historian Trend reports are suitable for the graphic display of the distribution of measured values between two lots.

Create report

To create a Historian Distribution Comparison report:

  1. In the Theme drop-down list, select Historian Analysis
  2. from the drop-down list, select Historian Distribution Comparison as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Column chart and table
  • Column chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list for selection of the projects (if not prescribed by the time filter)
  • 1 x single-selection drop-down list for selection of the archive
  • 1 x single-selection drop-down list for selection of the variables
  • 1 x single-selection drop-down list for selection of the rounding intervals

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: For the distribution, a trend is drawn using the X axis. Each variable value has a column. The height of this shows how often the value has occurred. Markers for minimum, average and maximum are drawn.
  • Table: There are 2 tables.

    Columns table 1:

    • Minimum
    • Average
    • Maximum

    Columns table 2:

    • Variable value
    • Number denoting how often the value occurred.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • Archive_GetAggregatedData
  • Archive_GetDistributionData
  • ListLots
  • ListShifts


Efficiency Class Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Efficiency Class Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The report templates in this topic carry out an efficiency analysis based on the efficiency class models. The data can be processed on the basis of archives, equipment groups or formulas.

  • Archive based efficiency report: Carries out an efficincy analysis based on archive data for a certain time period.
  • Archive based efficiency comparison report: Carries out an comparative efficiency analysis based on archive data for two periods.
  • Equipment group based efficiency report: Carries out an efficiency analysis based on equipment groups for a time period.
  • Equipment group based efficiency comparison report: Carries out a comparative efficiency analysis based on equipment groups for two time periods.
  • Formula based efficiency report: Carries out a formula-based efficiency analysis for a certain time period.
  • Formula based efficiency comparison report: Carries out a comparative formula-based efficiency analysis for two time periods.

info Information

Period under review and normalization interval:

  • Amendment of value sum:
    The main SPs for this report template take the time normalization of the selected efficiency class model into account. Therefore the value sum in the period under review must be amended to the time normalization of the model in the SPs. This happens by means of linear amendment.
    If the period under review is shorter than the normalization interval, the result becomes imprecise, because time-related variations of the values are not also calculated with it.
  • Example:
    For a period under review of 1 day and 1 week normalization interval, the value sum of the day is calculated up on a linear basis and multiplied by 7. Value differences between weekday and weekend are not also included in the calculation.
  • Recommendation:
    Select the period under review of a report that is always greater than the normalization interval of the efficiency class model.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar.
  2. The dialog for selecting a template is opened.

  3. In the Theme drop-down list, select Efficiency Class Analysis.
  4. Select the template you want to use as a report template from the drop-down list.

Other topics in this chapter

Archive based efficiency report

Archive based efficiency comparison report

Equipment Group based Efficiency Report

Equipment Group based Efficiency Comparison Report

Formula based efficiency report

Formula based Efficiency Comparison Report


Archive based efficiency report

zenon Analyzer -> Supplied report templates -> Report templates -> Efficiency Class Analysis -> Archive based efficiency report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template carry out an efficiency analysis on the basis of archive data for a certain time period. The data is normalized on the basis of the requirements of the efficiency class model. The efficiency data can be displayed in an efficiency class diagram and efficiency class tables.

Create report

To create a Archive based efficiency report:

  1. In the Theme drop-down list, select Efficiency Class Analysis
  2. From the drop-down list, select Archive based efficiency report as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Efficiency class model and variable filtering

Parameters

Description

Efficiency class model and variable filtering

Properties for the configuration of efficiency class model and variable filter.

Filter for efficiency class model names

Entry of the filter for the display names of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter for efficiency class model measuring unit

Entry of the filter for the units of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter variables based on measuring unit
  • Active: Variable list is filtered in the report when executing in Report Launcher on the basis of the unit of the selected efficiency class model.

Efficiency class diagram visualisation

Parameters

Description

Efficiency class diagram visualisation

Properties for the configuration of the diagram display for efficiency classes.

Show separator line
  • Active: A dividing line is displayed in the report between the efficiency class arrows and the assignment arrow.

Show assignment line
  • Active: An assignment line from the assignment arrow to the respective efficiency class arrow is displayed in the report.

Placement of the assignment indicator

Configuration of where the assignment arrow is drawn. Select from drop-down list:

  • Sliding inside efficiency class:
    The assignment arrow is moved within the assigned class in such a way that it reflects the position of the value within the class.
  • Centered to assigned efficiency class:
    The assignment arrow is always precisely pointed towards the assigned class.

Efficiency class labels

Configuration of the labeling of the arrows in the report. Select from drop-down list:

Defines how the arrows in the CRI are to be labeled:

  • Class name and boundaries
    Class name and class boundaries
  • Class name only: Class name
  • Class boundaries only: Class boundaries

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Efficiency class diagram and tables
  • Efficiency class diagram
  • Efficiency class tables

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects (if not prescribed by the lot or shift filter)
  • 1 x multiple-selection drop-down list for selection of the archives
  • 1 x multiple-selection drop-down list for selection of the variables
  • 1 x multiple-selection drop-down list for selection of the efficiency class model
  • 1 x bool selection for class sorting (influences all elements of the display)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Efficiency class diagram
  • Class list table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class,
    • Floor
    • Ceiling
  • Arrangement table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class
    • Current value

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchivesWithUnitFilter
  • ListEfficiencyClassModels
  • ListEfficiencyClassModelUnit
  • ECM_CalculateTimeNormalisationFactor
  • ECM_GetArchiveBasedData


Archive based efficiency comparison report

zenon Analyzer -> Supplied report templates -> Report templates -> Efficiency Class Analysis -> Archive based efficiency comparison report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template carry out an efficiency analysis on the basis of archive data for two time periods. The data is normalized on the basis of the requirements of the efficiency class model. The efficiency data can be displayed next to each another in an efficiency class diagram and efficiency class tables for comparison.

Create report

To create a Archive based efficiency comparison report:

  1. In the Theme drop-down list, select Efficiency Class Analysis
  2. From the drop-down list, select Archive based efficiency comparison report as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Efficiency class model and variable filtering

Parameters

Description

Efficiency class model and variable filtering

Properties for the configuration of efficiency class model and variable filter.

Filter for efficiency class model names

Entry of the filter for the display names of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter for efficiency class model measuring unit

Entry of the filter for the units of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter variables based on measuring unit
  • Active: Variable list is filtered in the report when executing in Report Launcher on the basis of the unit of the selected efficiency class model.

Efficiency class diagram visualisation

Parameters

Description

Efficiency class diagram visualisation

Properties for the configuration of the diagram display for efficiency classes.

Show separator line
  • Active: A dividing line is displayed in the report between the efficiency class arrows and the assignment arrow.

Show assignment line
  • Active: An assignment line from the assignment arrow to the respective efficiency class arrow is displayed in the report.

Placement of the assignment indicator

Configuration of where the assignment arrow is drawn. Select from drop-down list:

  • Sliding inside efficiency class:
    The assignment arrow is moved within the assigned class in such a way that it reflects the position of the value within the class.
  • Centered to assigned efficiency class:
    The assignment arrow is always precisely pointed towards the assigned class.

Efficiency class labels

Configuration of the labeling of the arrows in the report. Select from drop-down list:

Defines how the arrows in the CRI are to be labeled:

  • Class name and boundaries
    Class name and class boundaries
  • Class name only: Class name
  • Class boundaries only: Class boundaries

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Efficiency class diagram and tables
  • Efficiency class diagram
  • Efficiency class tables

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x lot selection with 4 x date and time selection for prefiltering of the lots (each lot list has its own prefilter)
  • 2 x lot selection with 2 x time range selection for prefiltering of the lots (each lot list has its own prefilter)
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts
  • 2 x shift selection with 4 x date and time selection for prefilitering of the shifts (each lot list has its own prefilter)
  • 2 x shift selection with 2 x time range selection for prefiltering of the shifts (each lot list has its own prefilter)

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects (if not prescribed by the lot or shift filter)
  • 1 x multiple-selection drop-down list for selection of the archives
  • 1 x multiple-selection drop-down list for selection of the variables
  • 1 x multiple-selection drop-down list for selection of the efficiency class model
  • 1 x bool selection for class sorting (influences all elements of the display)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Efficiency class diagram
  • Class list table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class,
    • Floor
    • Ceiling
  • Arrangement table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class
    • Current value

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchivesWithUnitFilter
  • ListEfficiencyClassModels
  • ListEfficiencyClassModelUnit
  • ECM_CalculateTimeNormalisationFactor
  • ECM_GetArchiveBasedData


Equipment Group based Efficiency Report

zenon Analyzer -> Supplied report templates -> Report templates -> Efficiency Class Analysis -> Equipment Group based Efficiency Report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template carry out an efficiency analysis on the basis of equipment groups for a certain time period. The data is normalized on the basis of the requirements of the efficiency class model. The efficiency data can be displayed in an efficiency class diagram and efficiency class tables.

Create report

To create a Equipment group based efficiency report:

  1. In the Theme drop-down list, select Efficiency Class Analysis
  2. From the drop-down list, select Equipment group based efficiency report as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Efficiency class model and variable filtering

Parameters

Description

Efficiency class model and variable filtering

Properties for the configuration of efficiency class model and variable filter.

Filter for efficiency class model names

Entry of the filter for the display names of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter for efficiency class model measuring unit

Entry of the filter for the units of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter variables based on measuring unit
  • Active: Variable list is filtered in the report when executing in Report Launcher on the basis of the unit of the selected efficiency class model.

Efficiency class diagram visualisation

Parameters

Description

Efficiency class diagram visualisation

Properties for the configuration of the diagram display for efficiency classes.

Show separator line
  • Active: A dividing line is displayed in the report between the efficiency class arrows and the assignment arrow.

Show assignment line
  • Active: An assignment line from the assignment arrow to the respective efficiency class arrow is displayed in the report.

Placement of the assignment indicator

Configuration of where the assignment arrow is drawn. Select from drop-down list:

  • Sliding inside efficiency class:
    The assignment arrow is moved within the assigned class in such a way that it reflects the position of the value within the class.
  • Centered to assigned efficiency class:
    The assignment arrow is always precisely pointed towards the assigned class.

Efficiency class labels

Configuration of the labeling of the arrows in the report. Select from drop-down list:

Defines how the arrows in the CRI are to be labeled:

  • Class name and boundaries
    Class name and class boundaries
  • Class name only: Class name
  • Class boundaries only: Class boundaries

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Efficiency class diagram and tables
  • Efficiency class diagram
  • Efficiency class tables

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for projects (if not prescribed by the lot or shift filter)
  • 1 x single selection from the equipment tree
  • 1 x multiple-selection drop-down list for selection of the efficiency class model
  • 1 x bool selection for class sorting (influences all elements of the display)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Efficiency class diagram
  • Class list table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class,
    • Floor
    • Ceiling
  • Arrangement table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class
    • Current value

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListProjects
  • ListEquipmentTree
  • ListEfficiencyClassModels
  • ListEfficiencyClassModelUnit
  • ECM_CalculateTimeNormalisationFactor
  • ECM_GetArchiveBasedData


Equipment Group based Efficiency Comparison Report

zenon Analyzer -> Supplied report templates -> Report templates -> Efficiency Class Analysis -> Equipment Group based Efficiency Comparison Report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template carry out an efficiency analysis on the basis of equipment groups for two time periods. The data is normalized on the basis of the requirements of the efficiency class model. The efficiency data can be displayed next to each another in an efficiency class diagram and efficiency class tables for comparison.

Create report

To create a Equipment group based efficiency comparison report:

  1. In the Theme drop-down list, select Efficiency Class Analysis
  2. From the drop-down list, select Equipment group based efficiency comparison report as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Efficiency class model and variable filtering

Parameters

Description

Efficiency class model and variable filtering

Properties for the configuration of efficiency class model and variable filter.

Filter for efficiency class model names

Entry of the filter for the display names of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter for efficiency class model measuring unit

Entry of the filter for the units of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter variables based on measuring unit
  • Active: Variable list is filtered in the report when executing in Report Launcher on the basis of the unit of the selected efficiency class model.

Efficiency class diagram visualisation

Parameters

Description

Efficiency class diagram visualisation

Properties for the configuration of the diagram display for efficiency classes.

Show separator line
  • Active: A dividing line is displayed in the report between the efficiency class arrows and the assignment arrow.

Show assignment line
  • Active: An assignment line from the assignment arrow to the respective efficiency class arrow is displayed in the report.

Placement of the assignment indicator

Configuration of where the assignment arrow is drawn. Select from drop-down list:

  • Sliding inside efficiency class:
    The assignment arrow is moved within the assigned class in such a way that it reflects the position of the value within the class.
  • Centered to assigned efficiency class:
    The assignment arrow is always precisely pointed towards the assigned class.

Efficiency class labels

Configuration of the labeling of the arrows in the report. Select from drop-down list:

Defines how the arrows in the CRI are to be labeled:

  • Class name and boundaries
    Class name and class boundaries
  • Class name only: Class name
  • Class boundaries only: Class boundaries

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Efficiency class diagram and tables
  • Efficiency class diagram
  • Efficiency class tables

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x lot selection with 4 x date and time selection for prefiltering of the lots (each lot list has its own prefilter)
  • 2 x lot selection with 2 x time range selection for prefiltering of the lots (each lot list has its own prefilter)
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts
  • 2 x shift selection with 4 x date and time selection for prefilitering of the shifts (each lot list has its own prefilter)
  • 2 x shift selection with 2 x time range selection for prefiltering of the shifts (each lot list has its own prefilter).

Other parameters

  • 1 x multiple-selection drop-down list for projects (if not prescribed by the lot or shift filter)
  • 1 x single selection from the equipment tree
  • 1 x multiple-selection drop-down list for selection of the efficiency class model
  • 1 x bool selection for class sorting (influences all elements of the display)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Efficiency class diagram
  • Class list table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class,
    • Floor
    • Ceiling
  • Arrangement table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class
    • Current value

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListProjects
  • ListEquipmentTree
  • ListEfficiencyClassModels
  • ListEfficiencyClassModelUnit
  • ECM_CalculateTimeNormalisationFactor
  • ECM_GetArchiveBasedData


Formula based efficiency report

zenon Analyzer -> Supplied report templates -> Report templates -> Efficiency Class Analysis -> Formula based efficiency report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template carry out a formula-based efficiency analysis for a certain time period. The data is normalized on the basis of the requirements of the efficiency class model. The efficiency data can be displayed in an efficiency class diagram and efficiency class tables.

Create report

To create a Formula based efficiency report:

  1. In the Theme drop-down list, select Efficiency Class Analysis
  2. From the drop-down list, select Formula based efficiency report as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Efficiency class formula and filter configuration

Parameters

Description

Efficiency class formula and filter configuration

Configuration of the efficiency class formula and its filtering.

Formula

Displays the visual name of the field in the report that is currently active. This is configured in the dialog to configure user-defined formulas with aggregation after clicking on the Configure formula button.

Configure formula

Clicking on the button opens the dialog to configure user-defined formulas with aggregation.

When clicking on OK, precisely one field must be marked as visible in the Aggregation fields tab or in the Calculated fields according to aggregation carried out tab.

Filter for efficiency class model names

Entry of the filter for the display names of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter for efficiency class model based on measuring unit of the efficiency class model

Active: The unit of the active field is used for the filtering of the efficiency class model list.

Efficiency class diagram visualisation

Parameters

Description

Efficiency class diagram visualisation

Properties for the configuration of the diagram display for efficiency classes.

Show separator line
  • Active: A dividing line is displayed in the report between the efficiency class arrows and the assignment arrow.

Show assignment line
  • Active: An assignment line from the assignment arrow to the respective efficiency class arrow is displayed in the report.

Placement of the assignment indicator

Configuration of where the assignment arrow is drawn. Select from drop-down list:

  • Sliding inside efficiency class:
    The assignment arrow is moved within the assigned class in such a way that it reflects the position of the value within the class.
  • Centered to assigned efficiency class:
    The assignment arrow is always precisely pointed towards the assigned class.

Efficiency class labels

Configuration of the labeling of the arrows in the report. Select from drop-down list:

Defines how the arrows in the CRI are to be labeled:

  • Class name and boundaries
    Class name and class boundaries
  • Class name only: Class name
  • Class boundaries only: Class boundaries

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Efficiency class diagram and tables
  • Efficiency class diagram
  • Efficiency class tables

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the efficiency class model
  • 1 x bool selection for class sorting (influences all elements of the display)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Efficiency class diagram
  • Class list table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class,
    • Floor
    • Ceiling
  • Arrangement table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class
    • Current value

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEfficiencyClassModels
  • ListEfficiencyClassModelUnit
  • ECM_CalculateTimeNormalisationFactor
  • ECM_GetFormulaBasedData
  • CustomIndicators_GetBaseData
  • CustomIndicators_PerformCalculations
  • CustomIndicators_PerformAggregations


Formula based Efficiency Comparison Report

zenon Analyzer -> Supplied report templates -> Report templates -> Efficiency Class Analysis -> Formula based Efficiency Comparison Report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template carry out a comparative formula-based efficiency analysis for two time periods. The data is normalized on the basis of the requirements of the efficiency class model. The efficiency data can be displayed in an efficiency class diagram and efficiency class tables.

Create report

To create a Formula based efficiency comparison report:

  1. In the Theme drop-down list, select Efficiency Class Analysis
  2. From the drop-down list, select Formula based efficiency comparison report as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Efficiency class formula and filter configuration

Parameters

Description

Efficiency class formula and filter configuration

Configuration of the efficiency class formula and its filtering.

Formula

Displays the visual name of the field in the report that is currently active. This is configured in the dialog to configure user-defined formulas with aggregation after clicking on the Configure formula button.

Configure formula

Clicking on the button opens the dialog to configure user-defined formulas with aggregation.

When clicking on OK, precisely one field must be marked as visible in the Aggregation fields tab or in the Calculated fields according to aggregation carried out tab.

Filter for efficiency class model names

Entry of the filter for the display names of the efficiency class models.

For this, the following applies:

  • Only figures, characters, spaces and * are permitted.
    Initial and final spaces are removed; several consecutive spaces in the text are reduced to one.
  • * is a wild card for any desired amount of characters.
  • If the text does not contain a wild card, * is added at the end. This is removed in the report display.
  • Several consecutive * characters are compressed into one.

Filter for efficiency class model based on measuring unit of the efficiency class model

Active: The unit of the active field is used for the filtering of the efficiency class model list.

Efficiency class diagram visualisation

Parameters

Description

Efficiency class diagram visualisation

Properties for the configuration of the diagram display for efficiency classes.

Show separator line
  • Active: A dividing line is displayed in the report between the efficiency class arrows and the assignment arrow.

Show assignment line
  • Active: An assignment line from the assignment arrow to the respective efficiency class arrow is displayed in the report.

Placement of the assignment indicator

Configuration of where the assignment arrow is drawn. Select from drop-down list:

  • Sliding inside efficiency class:
    The assignment arrow is moved within the assigned class in such a way that it reflects the position of the value within the class.
  • Centered to assigned efficiency class:
    The assignment arrow is always precisely pointed towards the assigned class.

Efficiency class labels

Configuration of the labeling of the arrows in the report. Select from drop-down list:

Defines how the arrows in the CRI are to be labeled:

  • Class name and boundaries
    Class name and class boundaries
  • Class name only: Class name
  • Class boundaries only: Class boundaries

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Efficiency class diagram and tables
  • Efficiency class diagram
  • Efficiency class tables

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x lot selection with 4 x date and time selection for prefiltering of the lots (each lot list has its own prefilter)
  • 2 x lot selection with 2 x time range selection for prefiltering of the lots (each lot list has its own prefilter)
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts
  • 2 x shift selection with 4 x date and time selection for prefilitering of the shifts (each lot list has its own prefilter)
  • 2 x shift selection with 2 x time range selection for prefiltering of the shifts (each lot list has its own prefilter).

Other parameters

  • 1 x multiple-selection drop-down list for selection of the efficiency class model
  • 1 x bool selection for class sorting (influences all elements of the display)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Efficiency class diagram
  • Class list table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class,
    • Floor
    • Ceiling
  • Arrangement table with the columns:
    • Color (no text, only coloring of the cells),
    • Name of the efficiency class
    • Current value

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEfficiencyClassModels
  • ListEfficiencyClassModelUnit
  • ECM_CalculateTimeNormalisationFactor
  • ECM_GetFormulaBasedData
  • CustomIndicators_GetBaseData
  • CustomIndicators_PerformCalculations
  • CustomIndicators_PerformAggregations


Energy Data Management

zenon Analyzer -> Supplied report templates -> Report templates -> Energy Data Management

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports of this theme provide reports from the themes Historian analysis, Extended Historian analysis and ISO 50001 for the analysis of energy data management systems:

Historian Analysis:

  • Historian Trend
  • Historian Aggregated Trend with online variable selection
  • Historian Aggregation

Extended Historian Analysis:

  • Historian Trend with Equipment Group and Variable Selection
  • Historian Aggregated Trend per Equipment Group
  • Distribution per Variable
  • Cost Distribution per Variable Comparison
  • Cost Distribution per Equipment Model

ISO 50001:

  • Load Duration Curve with Variable Selection
  • Load Duration Curves for Equipment Groups

You can find further templates for energy analysis in the ISO 50001 theme.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar
  2. The dialog for selecting a template is opened

  3. In the Theme drop-down list, select Energy Data Management
  4. Select the template you want to use as a report template from the drop-down list


Extended Historian Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide report templates for archive aggregation or archive distribution, taking prices, norm values and production counters into account. The use of equipment modeling is obligatory for these reports.

The following are available for the evaluation of archive aggregation or archive distribution:

  • Historian Trend with Equipment Group and Variable Selection: Creates a trend analysis without aggregation for a time period with a trend for each variable.
  • Historian Trend Comparison with Equipment Group and Variable Selection: Creates a trend analysis without aggregation for two time periods with a trend for each variable.
  • Historian Trend per Equipment Group: Creates a trend analysis without aggregation for a time period with a trend for each equipment group.
  • Historian Trend Comparison per Equipment Group: Creates a trend analysis without aggregation for two time periods with a trend for each equipment group.
  • Historian Aggregated Trend with Equipment Group and Variable Selection: Creates an aggregated trend analysis for a time period with a trend for each variable.
  • Historian Aggregated Trend Comparison with Equipment Group and Variable Selection: Creates an aggregated trend analysis for two time periods with a trend for each variable.
  • Historian Aggregated Trend per Equipment Group: Creates an aggregated trend analysis for a time period with a trend for each equipment model.
  • Historian Aggregated Trend Comparison per Equipment Group: Creates an aggregated trend analysis for two time periods with a trend for each equipment model.
  • Historian Trend with Equipment Group and Variable Selection: Calculates, for each variable, aggregated archive data for a time period with the aggregation functions sum, average, minimum and maximum.
  • Historian Trend Comparison with Equipment Group and Variable Selection: Calculates, for each variable, aggregated archive data for two time periods with the aggregation functions sum, average, minimum and maximum.
  • Historian Aggregation per Equipment Group: Calculates, for each equipment group, aggregated archive data for a time period with the aggregation functions sum, average, minimum and maximum.
  • Historian Aggregation Comparison per Equipment Group: Calculates, for each equipment group, aggregated archive data for two time periods with the aggregation functions sum, average, minimum and maximum.
  • Relative Historian Aggregated Trend with Equipment Group and Variable Selection: Creates a relative aggregated trend analysis for a time period with a trend for each variable.
  • Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection: Creates a relative aggregated trend analysis for two time periods with a trend for each variable.
  • Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard: Creates a relative aggregated trend analysis for a time period for a variable with a comparison with standard values.
  • Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard: Creates a relative aggregated trend analysis for two time periods for a variable with a comparison with standard values.
  • Relative Historian Aggregation with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for a time period that is based on variables.
  • Relative Historian Aggregation Comparison with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for two time periods that are based on variables.
  • Relative Historian Aggregation per Equipment Group: Calculates aggregated distribution data for equipment groups for a time period.
  • Relative Historian Aggregation Comparison per Equipment Group: Calculates aggregated distribution data for equipment groups for two time periods.
  • Cost Aggregation with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for a time period that is based on variables.
  • Cost Aggregation Comparison with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for two time periods that are based on variables.
  • Cost Aggregation per Equipment Group Calculates the aggregated cost distributions for a time period that is based on equipment models.
  • Cost Aggregation Comparison per Equipment Group: Calculates the aggregated cost distributions for two time periods that are based on equipment models.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar
  2. The dialog for selecting a template is opened

  3. In the Theme drop-down list, select Extended Historian Analysis
  4. Select the template you want to use as a report template from the drop-down list

Metadata

Metadata used: General
 | used | If not used
Projects | + | mandatory.
Alarm/Event class | - |
Alarm/Event groups | - |
Users | - |
Equipment Modeling | + | mandatory.
Archives | + | mandatory.
Variables | + | mandatory.
Prices | + |
Norm values | + |
Metadata used: Time filter
Lots | + | No reports possible with lot filter.
Shifts | + | No reports possible with shift filter.

Other topics in this chapter

Historian Trend with Equipment Group and Variable Selection

Historian Trend Comparison with Equipment Group and Variable Selection

Historian Trend per Equipment Group

Historian Trend Comparison per Equipment Group

Historian Aggregated Trend with Equipment Group and Variable Selection

Historian Aggregated Trend Comparison with Equipment Group and Variable Selection

Historian Aggregated Trend per Equipment Group

Historian Aggregated Trend Comparison per Equipment Group

Historian Trend with Equipment Group and Variable Selection

Historian Trend Comparison with Equipment Group and Variable Selection

Historian Aggregation per Equipment Group

Historian Aggregation Comparison per Equipment Group

Relative Historian Aggregated Trend with Equipment Group and Variable Selection

Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection

Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard

Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard

Relative Historian Aggregation with Equipment Group and Variable Selection

Relative Historian Aggregation Comparison with Equipment Group and Variable Selection

Relative Historian Aggregation per Equipment Group

Relative Historian Aggregation Comparison per Equipment Group

Cost Aggregation with Equipment Group and Variable Selection

Cost Aggregation Comparison with Equipment Group and Variable Selection

Cost Aggregation per Equipment Group

Cost Aggregation Comparison per Equipment Group


Historian Trend with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Trend with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend analysis for a time period without aggregation. Variables and archives are filtered by selecting from projects and equipment groups. Each trend represents a variable. The data is shown as a diagram or table.

Create report

To create an Historian Trend with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Historian Trend with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart
  • Bar chart
  • Grouped table:
    In the group line, there is the minimum of the start and the maximum of the end of the aggregation intervals and the aggregated value of all interval values.
  • Pivoted table with the following columns:
    • Timestamp
    • A value column per variable / equipment group
  • Table with the following columns:
    • Variable name / equipment group name
    • Start of the interval
    • End of the interval
    • Value at the time

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetTrendDataPerVariable
  • ArchiveEx300_GetTrendDataPerEquipment


Historian Trend Comparison with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Trend Comparison with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend analysis for two time periods without aggregation. Variables and archives are filtered by selecting from projects and equipment groups. Each trend represents a variable. The data is shown for comparison as a diagram or a table.

Create report

To create an Historian Trend Comparison with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Historian Trend Comparison with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 4 x date and time selection for prefiltering of the lots; one prefilter range per lot list
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots; same prefilter range
  • 2 x lot selection with 2 x time range selection for prefiltering of the lots; one prefilter range per lot list
  • 1 x lot selection with 2 x time range selection for prefiltering of the lots; same prefilter range
  • 2 x shift selection with 4 x date and time selection for prefilitering of the shifts; one prefilter range per shift list
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts; same prefilter range
  • 2 x shift selection with 2 x time range selection for prefiltering of the shifts; one prefilter range per shift list
  • 1 x shift selection with 2 x time range selection for prefiltering of the shifts; same prefilter range

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart
  • Bar chart
  • Grouped table:
    In the group line, there is the minimum of the start and the maximum of the end of the aggregation intervals and the aggregated value of all interval values.
  • Pivoted table with the following columns:
    • Timestamp
    • A value column per variable / equipment group
  • Table with the following columns:
    • Variable name / equipment group name
    • Start of the interval
    • End of the interval
    • Value at the time

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetTrendDataPerVariable


Historian Trend per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Trend per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend analysis for a time period without aggregation. Variables and archives are filtered by selecting from projects and equipment groups. Each trend represents an equipment group. The data is shown as a diagram or table.

Create report

To create an Historian group per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. From the drop-down list, select Historian Trend per Equipment Group as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart
  • Bar chart
  • Grouped table:
    In the group line, there is the minimum of the start and the maximum of the end of the aggregation intervals and the aggregated value of all interval values.
  • Pivoted table with the following columns:
    • Timestamp
    • A value column per variable / equipment group
  • Table with the following columns:
    • Variable name / equipment group name
    • Start of the interval
    • End of the interval
    • Value at the time

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetTrendDataPerEquipment


Historian Trend Comparison per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Trend Comparison per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a trend analysis for two time periods without aggregation. Variables and archives are filtered by selecting from projects and equipment groups. Each trend represents an equipment group. The data is shown for comparison as a diagram or a table.

Create report

To create a Historian trend comparison per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. From the drop-down list, select Historian Trend Comparison per Equipment Group as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 4 x date and time selection for prefiltering of the lots; one prefilter range per lot list
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots; same prefilter range
  • 2 x lot selection with 2 x time range selection for prefiltering of the lots; one prefilter range per lot list
  • 1 x lot selection with 2 x time range selection for prefiltering of the lots; same prefilter range
  • 2 x shift selection with 4 x date and time selection for prefilitering of the shifts; one prefilter range per shift list
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts; same prefilter range
  • 2 x shift selection with 2 x time range selection for prefiltering of the shifts; one prefilter range per shift list
  • 1 x shift selection with 2 x time range selection for prefiltering of the shifts; same prefilter range

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart
  • Bar chart
  • Grouped table:
    In the group line, there is the minimum of the start and the maximum of the end of the aggregation intervals and the aggregated value of all interval values.
  • Pivoted table with the following columns:
    • Timestamp
    • A value column per variable / equipment group
  • Table with the following columns:
    • Variable name / equipment group name
    • Start of the interval
    • End of the interval
    • Value at the time

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetTrendDataPerEquipment


Historian Aggregated Trend with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Aggregated Trend with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get consumption data for variables over a time range, add this up into intervals within the time range and display the data as a trend and in a table.

Create report

To create an Historian Aggregated Trend with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Historian Aggregated Trend with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple-selection tree display list for selection of the active equipment models
  • 1 x multiple-selection drop-down list for selection of the variables
  • Single selection of the compression function. Values:
    • Sum
    • Average
    • Minimum
    • Maximum
  • 1 x single-selection drop-down list for the selection of the compression in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart
  • Bar chart
  • Grouped table:
    In the group line, there is the minimum of the start and the maximum of the end of the aggregation intervals and the aggregate value of all interval values. This was always the sum previously, now it is controlled by the aggregation function selection parameters.
  • Pivoted table with the following columns:
    • Start of the interval
    • End of the interval
    • A value column per variable / equipment group
  • Table with the following columns:
    • Variable name / equipment group name
    • Start of the interval
    • End of the interval
    • Value in the interval

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedTrendDataPerVariable


Historian Aggregated Trend Comparison with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Aggregated Trend Comparison with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get consumption data for variables over two time ranges, add this up into intervals within the time range and display the data as a trend and in a table. Both time ranges are displayed separately.

Create report

To create an Historian Aggregated Trend Comparison with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Historian Aggregated Trend Comparison with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.

    The report template is opened

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple-selection tree display list for selection of the active equipment models
  • 1 x multiple-selection drop-down list for selection of the variables
  • Single selection of the compression function. Values:
    • Sum
    • Average
    • Minimum
    • Maximum
  • 1 x single-selection drop-down list for the selection of the compression in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart
  • Bar chart
  • Grouped table:
    In the group line, there is the minimum of the start and the maximum of the end of the aggregation intervals and the aggregate value of all interval values. This was always the sum previously, now it is controlled by the aggregation function selection parameters.
  • Pivoted table with the following columns:
    • Start of the interval
    • End of the interval
    • A value column per variable / equipment group
  • Table with the following columns:
    • Variable name / equipment group name
    • Start of the interval
    • End of the interval
    • Value in the interval

End of the interval value in the interval notice for report developers: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedTrendDataPerVariable


Historian Aggregated Trend per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Aggregated Trend per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get consumption data for all variables from the selected equipment groups over a time range, add this up into intervals within the time range and display the data as a trend and in a table.

Create report

To create a Historian Aggregated Trend per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. From the drop-down list, select Historian Aggregated Trend per Equipment Group as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple-selection tree display list for selection of the active equipment models
  • Single selection of the compression function.
    Values:
    • Sum
    • Average
    • Minimum
    • Maximum
  • 1 x single-selection drop-down list for the selection of the compression in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart
  • Bar chart
  • Grouped table:
    In the group line, there is the minimum of the start and the maximum of the end of the aggregation intervals and the aggregate value of all interval values. This was always the sum previously, now it is controlled by the aggregation function selection parameters.
  • Pivoted table with the following columns:
    • Start of the interval
    • End of the interval
    • A value column per variable / equipment group
  • Table with the following columns:
    • Variable name / equipment group name
    • Start of the interval
    • End of the interval
    • Value in the interval

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ArchiveEx300_GetAggregatedTrendDataPerEquipment


Historian Aggregated Trend Comparison per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Aggregated Trend Comparison per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get consumption data for variables over two time ranges, add this up into intervals within the time range and display the data as a trend and in a table. Both time ranges are displayed separately.

Create report

To create a Historian Aggregated Trend Comparison per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. From the drop-down list, select Historian Aggregated Trend Comparison per Equipment Group as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and grouped table
  • Line chart and pivot table
  • Line chart and table
  • Bar chart and grouped table
  • Bar chart and pivot table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Grouped table
  • Pivot table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple-selection tree display list for selection of the active equipment models
  • Single selection of the compression function.
    Values:
    • Sum
    • Average
    • Minimum
    • Maximum
  • 1 x single-selection drop-down list for the selection of the compression in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart
  • Bar chart
  • Grouped table:
    In the group line, there is the minimum of the start and the maximum of the end of the aggregation intervals and the aggregate value of all interval values. This was always the sum previously, now it is controlled by the aggregation function selection parameters.
  • Pivoted table with the following columns:
    • Start of the interval
    • End of the interval
    • A value column per variable / equipment group
  • Table with the following columns:
    • Variable name / equipment group name
    • Start of the interval
    • End of the interval
    • Value in the interval

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ArchiveEx300_GetAggregatedTrendDataPerEquipment


Historian Trend with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Trend with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this template calculate, for each variable, aggregated archive data for a time period with the aggregation functions sum, average, minimum and maximum. The variables are filtered on the basis of the equipment groups. The data is shown as diagrams or tables.

Create report

To create a Historian aggregation with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Historian Aggregation with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The output is for each variable.
The following elements are available for display:

  • 4 pie charts with a section for each output grouping
  • 4 bar charts with a section for each output grouping
  • Tables with the following columns (all can be sorted dynamically):
    • Name of the output grouping
    • Sum of all values for this output grouping
    • Average value of all values for this output grouping
    • Minimum of all values for this output grouping
    • Maximum of all values for this output grouping

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedDataPerVariable


Historian Trend Comparison with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Trend Comparison with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this template calculate, for each variable, aggregated archive data for two time periods with the aggregation functions sum, average, minimum and maximum. The variables are filtered on the basis of the equipment groups. The data is shown for comparison as diagrams or tables.

Create report

To create an Historian Aggregation Comparison with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Historian Aggregation Comparison with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 4 x date and time selection for prefiltering of the lots; one prefilter range per lot list
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots; the same prefilter range for both lot lists
  • 2 x lot selection with 2 x time range selection for prefiltering of the lots; one prefilter range per lot list
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots; the same prefilter range for both lot lists
  • 2 x shift selection with 4 x date and time selection for prefilitering of the shifts; one prefilter range per shift list
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts; the same prefilter range for both shift lists
  • 2 x shift selection with 2 x time range selection for prefiltering of the shifts; one prefilter range per shift list
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts; the same prefilter range for both shift lists

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The output is for each variable.
The following elements are available for display:

  • 4 pie charts with a section for each output grouping
  • 4 bar charts with a section for each output grouping
  • Tables with the following columns (all can be sorted dynamically):
    • Name of the output grouping
    • Sum of all values for this output grouping
    • Average value of all values for this output grouping
    • Minimum of all values for this output grouping
    • Maximum of all values for this output grouping

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
    • ArchiveEx300_GetAggregatedDataPerVariable


Historian Aggregation per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Aggregation per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this template calculate, for each equipment group, aggregated archive data for a time period with the aggregation functions sum, average, minimum and maximum. The variables are recognized on the basis of the equipment groups and aggregated for each equipment group. The data is shown as diagrams or tables.

Create report

To create a Historian Aggregation per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. From the drop-down list, select Historian Aggregation per Equipment Group as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The output is for each variable.
The following elements are available for display:

  • 4 pie charts with a section for each output grouping
  • 4 bar charts with a section for each output grouping
  • Tables with the following columns (all can be sorted dynamically):
    • Name of the output grouping
    • Sum of all values for this output grouping
    • Average value of all values for this output grouping
    • Minimum of all values for this output grouping
    • Maximum of all values for this output grouping

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ArchiveEx300_GetAggregatedDataPerEquipment


Historian Aggregation Comparison per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Historian Aggregation Comparison per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this template calculate, for each equipment group, aggregated archive data for two time periods with the aggregation functions sum, average, minimum and maximum. The variables are recognized on the basis of the equipment groups and aggregated for each equipment group. The data is shown for comparison as diagrams or tables.

Create report

To create a Historian Aggregation Comparison per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. From the drop-down list, select Historian Aggregation Comparison per Equipment Group as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for two time ranges)
  • 2 x time range selection
  • 2 x lot selection with 4 x date and time selection for prefiltering of the lots; one prefilter range per lot list
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots; the same prefilter range for both lot lists
  • 2 x lot selection with 2 x time range selection for prefiltering of the lots; one prefilter range per lot list
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots; the same prefilter range for both lot lists
  • 2 x shift selection with 4 x date and time selection for prefilitering of the shifts; one prefilter range per shift list
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts; the same prefilter range for both shift lists
  • 2 x shift selection with 2 x time range selection for prefiltering of the shifts; one prefilter range per shift list
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts; the same prefilter range for both shift lists

Other parameters

  • 1 x multiple-selection drop-down list for selection of the projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The output is for respective equipment groups.
The following elements are available for display:

  • Pie charts with a section for each output grouping
  • Bar charts with a column for each output grouping
  • Tables with the following columns (all can be sorted dynamically):
    • Name of the output grouping
    • Sum of all values for this output grouping
    • Average value of all values for this output grouping
    • Minimum of all values for this output grouping
    • Maximum of all values for this output grouping

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ArchiveEx300_GetAggregatedDataPerEquipment


Relative Historian Aggregated Trend with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Relative Historian Aggregated Trend with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get consumption data for variables over a time range,
  • add these up in intervals within the time range,
  • divide the interval amounts by the production in the interval (if this is not 0) and
  • display the data as a trend and as a table.

Create report

To create an Relative Historian Aggregated Trend with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Relative Historian Aggregated Trend with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production counter configuration

Parameters | Description
Production counter configuration | Display of the configuration of the production counter.
Configure production counter | Opens the dialog for configuring the production counter.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection tree display list for selection of the active equipment models
  • 1 x multiple-selection drop-down list for selection of the variables
  • 1 x single-selection drop-down list for the selection of the interval size in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Interval amounts (optional):
    • Trend with a line per variable
    • Trend with a set of columns per variable
  • Data as a table (optional) with the columns:
    • Variable name (can be expanded)
    • Interval Start
    • Interval End
    • Relative consumption
    • Unit
    • Production counter

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedTrendProductionDataPerVariable


Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get consumption data for variables over two time ranges,
  • add these up in intervals within the time range,
  • divide the interval amounts by the production in the interval (if this is not 0) and
  • display the data as a trend and as a table.

Both time ranges are displayed separately.

Create report

To create an Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Relative Historian Aggregated Trend with Equipment Group and Variable Selection per Variable as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production counter configuration

Parameters | Description
Production counter configuration | Display of the configuration of the production counter.
Configure production counter | Opens the dialog for configuring the production counter.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection tree display list for selection of the active equipment models
  • 1 x multiple-selection drop-down list for selection of the variables
  • 1 x single-selection drop-down list for the selection of the interval size in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Interval amounts (optional):
    • Trend with a line per variable
    • Trend with a set of columns per variable
  • Data as a table (optional) with the columns:
    • Variable name (can be expanded)
    • Interval Start
    • Interval End
    • Relative consumption
    • Unit
    • Production counter

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedTrendProductionDataPerVariable


Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get consumption data for a variable over a time range,
  • add these up in intervals within the time range,
  • divide the interval amounts by the production in the interval (if this is not 0),
  • display the data as a trend and as a table and
  • get a norm value for comparison purposes for the value from the NORM table and include this in the display of data.

Create report

To create an Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production counter configuration

Parameters | Description
Production counter configuration | Display of the configuration of the production counter.
Configure production counter | Opens the dialog for configuring the production counter.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Column chart and table
  • Column chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection tree display for selection of the active equipment model
  • 1 x single-selection drop-down list for selection of the variables
  • 1 x single-selection drop-down list for the selection of the interval size in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Relative consumption (optional): Trend with a set of columns per variable and a line for the norm value
  • Data as a table (optional) with the columns:
    • Variable name (can be expanded)
    • Interval Start
    • Interval End
    • Relative consumption
    • Norm value
    • Unit
    • Production counter

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedTrendProductionNormDataPerVariable


Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get consumption data for a variable over two time ranges,
  • add these up in intervals within the time range,
  • divide the interval amounts by the production in the interval (if this is not 0),
  • display the data as a trend and as a table and
  • get a norm value for comparison purposes for the value from the NORM table and include this in the display of data.

Both time ranges are displayed separately.

Create report

To create an Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production counter configuration

Parameters | Description
Production counter configuration | Display of the configuration of the production counter.
Configure production counter | Opens the dialog for configuring the production counter.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Column chart and table
  • Column chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection tree display list for selection of the active equipment models
  • 1 x multiple-selection drop-down list for selection of the variables
  • 1 x single-selection drop-down list for the selection of the interval size in the time range

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Relative consumption (optional, 1 x per time range): Trend with a set of columns per variable and a line for the norm value
  • Data as a table (optional) with the columns:
    • Variable name (can be expanded)
    • Interval Start
    • Interval End
    • Relative consumption
    • Norm value
    • Unit
    • Production counter

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedTrendProductionNormDataPerVariable


Relative Historian Aggregation with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Relative Historian Aggregation with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get consumption data for variables over a time range, add this up and display the consumption amounts graphically and in a table for comparison.

Application examples

Distribution per Variable reports are suited, for example, to the comparison of the deviation of the measured value distribution between two lots.

Create report

To create an Relative Historian Aggregation with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Relative Historian Aggregation with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Chart data selection

Parameters

Description

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple selection of projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Data (optional):
    • Pie chart with the absolute or relative overall consumption in a segment for each variable
    • Bar chart with the absolute or relative overall consumption in a segment for each variable
  • Data as a table (optional) with the columns:
    • Variable name
    • Total consumption
    • Unit
    • Relative consumption

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedDataPerVariable


Relative Historian Aggregation Comparison with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Relative Historian Aggregation Comparison with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get consumption data for variables over two time periods, add this up and display the consumption amounts graphically and in a table for comparison. Both time ranges are displayed separately.

Application examples

Distribution per Variable Comparison reports are suited, for example, to the comparison of the deviation of the measured value distribution between two lots.

Create report

To create an Relative Historian Aggregation Comparison with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Relative Historian Aggregation Comparison with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Chart data selection

Parameters

Description

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple selection of projects
  • 1 x multiple selection of equipment groups
  • 1 x multiple selection of variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Data (optional):
    • Pie chart with the absolute or relative overall consumption in a segment for each variable; 1x per time range
    • Bar chart with the absolute or relative overall consumption in a segment for each variable; 1x per time range
  • Data as a table (optional) with the columns:
    • Variable name
    • Total consumption
    • Unit
    • Relative consumption

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedDataPerVariable


Relative Historian Aggregation per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Relative Historian Aggregation per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate distribution data for a time period. The variables are recognized on the basis of the equipment groups and aggregated for each equipment group. The display is shown as a diagram or table.

Create report

To create a Relative Historian Aggregation per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. From the drop-down list, select Relative Historian Aggregation per Equipment Group as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Chart data selection

Parameters

Description

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple selection of projects
  • 1 x multiple selection of equipment groups

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Pie chart with absolute values
  • Pie chart with relative values
  • Bar chart with absolute values
  • Bar chart with relative values
  • Data table with the following dynamic sortable columns:
    • Equipment group name
    • Absolute value
    • Relative value

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ArchiveEx300_GetAggregatedDataPerEquipment


Relative Historian Aggregation Comparison per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Relative Historian Aggregation Comparison per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate aggregated distribution data for two time periods. The variables are recognized on the basis of the equipment groups and aggregated for each equipment group. The display is shown as a diagram or table.

Create report

To create a Relative Historian Aggregation comparison per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. From the drop-down list, select Relative Historian Aggregation Comparison per Equipment Group as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Chart data selection

Parameters

Description

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 4 x date and time selection for prefiltering of the lots; one prefilter range per lot list
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots; the same prefilter range for both lot lists
  • 2 x lot selection with 2 x time range selection for prefiltering of the lots; one prefilter range per lot list
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots; the same prefilter range for both lot lists
  • 2 x shift selection with 4 x date and time selection for prefilitering of the shifts; one prefilter range per shift list
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts; the same prefilter range for both shift lists
  • 2 x shift selection with 2 x time range selection for prefiltering of the shifts; one prefilter range per shift list
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts; the same prefilter range for both shift lists

Other parameters

  • 1 x multiple selection of projects
  • 1 x multiple selection of equipment groups

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Pie chart with absolute values
  • Pie chart with relative values
  • Bar chart with absolute values
  • Bar chart with relative values
  • Data table with the following dynamic sortable columns:
    • Equipment group name
    • Absolute value
    • Relative value

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ArchiveEx300_GetAggregatedDataPerEquipment


Cost Aggregation with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Cost Aggregation with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get consumption data for variables over a time range,
  • link the consumption values with the respective applicable prices from the Price table, in order to get the costs,
  • add up the costs and
  • display the cost sums graphically and in a table for comparison.

Create report

To create an Cost Aggregation with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Cost Aggregation with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Chart data selection

Parameters

Description

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the active projects
  • 1 x multiple-selection tree display list for selection of the active equipment models
  • 1 x multiple-selection drop-down list for selection of the variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Data (optional):
    • Pie chart with the absolute or relative overall consumption in a segment for each variable
    • Bar chart with the absolute or relative overall consumption in a segment for each variable
  • Data as a table (optional) with the columns:
    • Variable name
    • Total costs, absolute
    • Total costs, relative

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedCostDataPerVariable


Cost Aggregation Comparison with Equipment Group and Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Cost Aggregation Comparison with Equipment Group and Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get consumption data for variables over two time ranges,
  • link the consumption values with the respective applicable prices from the Price table, in order to get the costs,
  • add up the costs and
  • display the cost sums graphically and in a table for comparison.

Both time ranges are displayed separately.

Create report

To create an Cost Aggregation Comparison with Equipment Group and Variable Selection report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Cost Aggregation Comparison with Equipment Group and Variable Selection as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Chart data selection

Parameters

Description

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the active projects
  • 1 x multiple-selection tree display list for selection of the active equipment models
  • 1 x multiple-selection drop-down list for selection of the variables

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Data (optional):
    • Pie chart with the absolute or relative overall consumption in a segment for each variable; 1 x per time range
    • Bar chart with the absolute or relative overall consumption in a segment for each variable; 1 x per time range
  • Data as a table (optional) with the columns:
    • Variable name
    • Total costs, absolute
    • Total costs, relative

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListVariablesForProjectsAndEquipments
  • ArchiveEx300_GetAggregatedCostDataPerVariable


Cost Aggregation per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Cost Aggregation per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get consumption data for all variables of the selected equipment models over a time range,
  • link the consumption values with the respective applicable prices from the Price table, in order to get the costs,
  • add up the costs per equipment model and
  • display the cost sums graphically and in a table for comparison.

Create report

To create a Cost Aggregation per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Cost Aggregation per Equipment Group as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Chart data selection

Parameters

Description

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the active projects
  • 1 x multiple-selection tree display list for selection of the active equipment models

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Data (optional):
    • Pie chart with the absolute or relative overall consumption in a segment for each variable
    • Bar chart with the absolute or relative overall consumption in a segment for each variable
  • Data as a table (optional) with the columns:
    • Equipment name
    • Total costs, absolute
    • Total costs, relative

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ArchiveEx300_GetAgregatedCostDataPerEquipment


Cost Aggregation Comparison per Equipment Group

zenon Analyzer -> Supplied report templates -> Report templates -> Extended Historian Analysis -> Cost Aggregation Comparison per Equipment Group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get consumption data for all variables of the selected equipment models over a two time ranges,
  • link the consumption values with the respective applicable prices from the Price table, in order to get the costs,
  • add up the costs per equipment model and
  • display the cost sums graphically and in a table for comparison.

Both time ranges are displayed separately.

Create report

To create a Cost Aggregation Comparison per Equipment Group report:

  1. In the Theme drop-down list, select Extended Historian Analysis
  2. from the drop-down list, select Cost Aggregation Comparison per Equipment Group as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Pie chart and table
  • Bar chart and table
  • Pie chart
  • Bar chart
  • Table

Chart data selection

Parameters

Description

Chart data selection

Selection of the value type to be displayed from drop-down list:

  • Absolute values
  • Relative values

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 4 x date and time selection ("from" and "to" for one time range)
  • 2 x time range selection
  • 2 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 2 x lot selection with 1 x time range selection for prefiltering of the lots
  • 2 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 2 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple-selection drop-down list for selection of the active projects
  • 1 x multiple-selection tree display list for selection of the active equipment models

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Parameter area: Is always present and shows the report parameter values
  • Data (optional):
    • Pie chart with the absolute or relative overall consumption in a segment for each variable, 1 x per time range
    • Bar chart with the absolute or relative overall consumption in a segment for each variable, 1 x per time range
  • Data as a table (optional) with the columns:
    • Equipment name
    • Total costs, absolute
    • Total costs, relative

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ArchiveEx300_GetAgregatedCostDataPerEquipment


ISO 50001

zenon Analyzer -> Supplied report templates -> Report templates -> ISO 50001

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide report templates from the ISO50001, Extended Historian Analysis and Custom Formula Analysis themes:

ISO 50001

  • Load Duration Curve with variable selection: Creates a load duration curve that is based on variable selection.
  • Load Duration Curve Comparison with variable selection: Creates a comparison between two load duration curves that is based on variable selection.
  • Load Duration Curve for Equipment Groups: Creates a load duration curve that is based on variable selection per equipment group.
  • Load Duration Curve Comparison for Equipment Groups: Creates a comparison between two load duration curves that is based on variable selection for each equipment group.
  • Carpet Plot: Gets and aggregates data for a carpet plot.
  • Sankey Diagram: Reads the Sankey definitions, gets data and aggregates it, integrates dynamic loss detection if required and displays the result as a diagram or table.
  • Sankey Diagram (double width): Displays the Sankey diagram in double width or places tables next to one another.

Extended Historian Analysis

  • Historian Trend with Equipment Group and Variable Selection: Creates a trend analysis without aggregation for a time period with a trend for each variable.
  • Historian Trend Comparison with Equipment Group and Variable Selection: Creates a trend analysis without aggregation for two time periods with a trend for each variable.
  • Historian Trend per Equipment Group: Creates a trend analysis without aggregation for a time period with a trend for each equipment group.
  • Historian Trend Comparison per Equipment Group: Creates a trend analysis without aggregation for two time periods with a trend for each equipment group.
  • Historian Aggregated Trend with Equipment Group and Variable Selection: Creates an aggregated trend analysis for a time period with a trend for each variable.
  • Historian Aggregated Trend Comparison with Equipment Group and Variable Selection: Creates an aggregated trend analysis for two time periods with a trend for each variable.
  • Historian Aggregated Trend per Equipment Group: Creates an aggregated trend analysis for a time period with a trend for each equipment model.
  • Historian Aggregated Trend Comparison per Equipment Group: Creates an aggregated trend analysis for two time periods with a trend for each equipment model.
  • Historian Trend with Equipment Group and Variable Selection: Calculates, for each variable, aggregated archive data for a time period with the aggregation functions sum, average, minimum and maximum.
  • Historian Trend Comparison with Equipment Group and Variable Selection: Calculates, for each variable, aggregated archive data for two time periods with the aggregation functions sum, average, minimum and maximum.
  • Historian Aggregation per Equipment Group: Calculates, for each equipment group, aggregated archive data for a time period with the aggregation functions sum, average, minimum and maximum.
  • Historian Aggregation Comparison per Equipment Group: Calculates, for each equipment group, aggregated archive data for two time periods with the aggregation functions sum, average, minimum and maximum.
  • Relative Historian Aggregated Trend with Equipment Group and Variable Selection: Creates a relative aggregated trend analysis for a time period with a trend for each variable.
  • Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection: Creates a relative aggregated trend analysis for two time periods with a trend for each variable.
  • Relative Historian Aggregated Trend with Equipment Group and Variable Selection to Standard: Creates a relative aggregated trend analysis for a time period for a variable with a comparison with standard values.
  • Relative Historian Aggregated Trend Comparison with Equipment Group and Variable Selection to Standard: Creates a relative aggregated trend analysis for two time periods for a variable with a comparison with standard values.
  • Relative Historian Aggregation with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for a time period that is based on variables.
  • Relative Historian Aggregation Comparison with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for two time periods that are based on variables.
  • Relative Historian Aggregation per Equipment Group: Calculates aggregated distribution data for equipment groups for a time period.
  • Relative Historian Aggregation Comparison per Equipment Group: Calculates aggregated distribution data for equipment groups for two time periods.
  • Cost Aggregation with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for a time period that is based on variables.
  • Cost Aggregation Comparison with Equipment Group and Variable Selection: Calculates the aggregated cost distributions for two time periods that are based on variables.
  • Cost Aggregation per Equipment Group Calculates the aggregated cost distributions for a time period that is based on equipment models.
  • Cost Aggregation Comparison per Equipment Group: Calculates the aggregated cost distributions for two time periods that are based on equipment models.

Custom Formula Analysis

  • Custom Formula Trend: Trend display of user-defined formulas for a time range.
  • Custom Formula Trend Comparison: Trend display of user-defined formulas for two time ranges.
  • Custom Formula Aggregated Trend: Trend display of aggregated user-defined formulas for a time range.
  • Custom Formula Aggregated Trend Comparison: Trend display of aggregated user-defined formulas for two time ranges.
  • Custom Formula Aggregation: Trend display of aggregated, user-defined formulas for a time range.
  • Custom Formula Aggregation Comparison: Trend display of aggregated, user-defined formulas for two time ranges.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar.

    The dialog for selecting a template is opened.

  2. In the Theme drop-down list, select ISO 50001
  3. Select the template you want to use as a report template from the drop-down list.

Other topics in this chapter

Load Duration Curve with Variable Selection

Load Duration Curve Comparison with Variable Selection

Load Duration Curves for Equipment Groups

Load Duration Curve Comparison for Equipment Groups

Carpet Plot

Sankey Diagram

Sankey Diagram (double width)


Load Duration Curve with Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> ISO 50001 -> Load Duration Curve with Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get data for a load duration curve
  • Display these as a line chart, area chart or table

Create report

To create an Load Duration Curve with variable selection report:

  1. In the Theme drop-down list, select ISO 50001
  2. From the drop-down list, select Load Duration Curve with variable selection as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Area chart and table
  • Line chart
  • Area chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering for a time range.
  • Project multiple selection (not available if the report has been tied to a project through filter settings)
  • Archive multiple selection
  • Variable multiple selection
  • Aggregation function single selection.
    Value list:
    • Sum
    • Average
    • Minimum
    • Maximum
  • Time aggregation interval single selection.
    Value list:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year
  • Interval size for the consumption intervals single selection.
    Value list:
    • 0,00001
    • 0,0001GetLoadDurationCurveData
    • 0,001
    • 0,01
    • 0,1
    • 1
    • 10
    • 100
    • 1000
    • 10000
    • 100000

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart:
    • Horizontal axis: Number of time intervals
    • Vertical axis: Consumption
  • Area chart with the same axis settings as the line chart
  • Table with the columns:
    • Consumption (with unit of measurement)
    • Number of intervals in which at least the consumption stated in this line was present

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • Archives
  • ListLots
  • ListShifts


Load Duration Curve Comparison with Variable Selection

zenon Analyzer -> Supplied report templates -> Report templates -> ISO 50001 -> Load Duration Curve Comparison with Variable Selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get data for two load duration curves
  • Display these as a line chart, area chart or table

Create report

To create a Load Duration Curve Comparison with variable selection report:

  1. In the Theme drop-down list, select ISO 50001
  2. from the drop-down list, select Load Duration Curve Comparison with variable selection as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Area chart and table
  • Line chart
  • Area chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering for the selection of two time periods
  • Project multiple selection (not available if the report has been tied to a project through filter settings)
  • Archive multiple selection
  • Variable multiple selection
  • Aggregation function single selection.
    Value list:
    • Sum
    • Average
    • Minimum
    • Maximum
  • Time aggregation interval single selection.
    Value list:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year
  • Interval size for the consumption intervals single selection.
    Value list:
    • 0,00001
    • 0,0001
    • 0,001
    • 0,01
    • 0,1
    • 1
    • 10
    • 100
    • 1000
    • 10000
    • 100000

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart:
    • Horizontal axis: Number of time intervals
    • Vertical axis: Consumption
  • Area chart with the same axis settings as the line chart
  • Table with the columns:
    • Consumption (with unit of measurement)
    • Number of intervals in which at least the consumption stated in this line was present

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • ISO50001_GetLoadDurationCurveData
  • ListLots
  • ListShifts


Load Duration Curves for Equipment Groups

zenon Analyzer -> Supplied report templates -> Report templates -> ISO 50001 -> Load Duration Curves for Equipment Groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get data by equipment group for the load duration curve
  • Display these as a line chart, area chart or table

Create report

To create a Load Duration Curve for Equipment Groups report:

  1. In the Theme drop-down list, select ISO 50001
  2. from the drop-down list, select Load Duration Curve for Equipment Groups as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Area chart and table
  • Line chart
  • Area chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering for a time range.
  • Project multiple selection (not available if the report has been tied to a project through filter settings)
  • Equipment groups multiple selection
  • Aggregation function single selection.
    Value list:
    • Sum
    • Average
    • Minimum
    • Maximum
  • Time aggregation interval single selection.
    Value list:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • Hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year
  • Interval size for the consumption intervals single selection.
    Value list:
    • 0,00001
    • 0,0001
    • 0,001
    • 0,01
    • 0,1
    • 1
    • 10
    • 100
    • 1000
    • 10000
    • 100000

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart:
    • Horizontal axis: Number of time intervals
    • Vertical axis: Consumption
  • Area chart with the same axis settings as the line chart
  • Table with the columns:
    • Consumption (with unit of measurement)
    • Number of intervals in which at least the consumption stated in this line was present

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListEquipmentTree
  • ISO50001_GetLoadDurationCurveData
  • ListLots
  • ListShifts


Load Duration Curve Comparison for Equipment Groups

zenon Analyzer -> Supplied report templates -> Report templates -> ISO 50001 -> Load Duration Curve Comparison for Equipment Groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get data by equipment group for two load duration curves
  • Display these as a line chart, area chart or table

Create report

To create a Load Duration Curve Comparison for Equipment Groups report:

  1. In the Theme drop-down list, select ISO 50001
  2. from the drop-down list, select Load Duration Curve Comparison for Equipment Groups as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Area chart and table
  • Line chart
  • Area chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering for the selection of two time periods
  • Project multiple selection (not available if the report has been tied to a project through filter settings)
  • Equipment groups multiple selection
  • Aggregation function single selection.
    Value list:
    • Sum
    • Average
    • Minimum
    • Maximum
  • Time aggregation interval single selection.
    Value list:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year
  • Interval size for the consumption intervals single selection.
    Value list:
    • 0,00001
    • 0,0001
    • 0,001
    • 0,01
    • 0,1
    • 1
    • 10
    • 100
    • 1000
    • 10000
    • 100000

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart:
    • Horizontal axis: Number of time intervals
    • Vertical axis: Consumption
  • Area chart with the same axis settings as the line chart
  • Table with the columns:
    • Consumption (with unit of measurement)
    • Number of intervals in which at least the consumption stated in this line was present

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListEquipmentTree
  • ISO50001_GetLoadDurationCurveData
  • ListLots
  • ListShifts


Carpet Plot

zenon Analyzer -> Supplied report templates -> Report templates -> ISO 50001 -> Carpet Plot

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Get and aggregate data for a carpet plot.
  • Assign colors to this
  • Display this as a carpet plot or table

Create report

To create a Carpet Plot report:

  1. In the Theme drop-down list, select ISO 50001
  2. from the drop-down list, select Carpet Plot as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Carpet plot and table
  • Carpet Plot
  • Table

Configuration of XY-axes Configuration of XY-axes

Parameters

Description

X/Y Axis configuration

Selection of the values for the X and Y axis from the drop-down list:

  • Hours/Minutes
  • Days/Hours
  • Months/Days

Carpet Plot Colors

Parameters | Description
Carpet Plot Colors | Color selection for start and end color of the color gradient in the carpet plot.
Minimum color | Color of the minimum value. Configuration using the slider.
Maximum color | Color of the maximum value. Configuration using the slider.
Color gradient preview | Preview of the configured color.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

The following are available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering for a from-to time and a time window
  • Project multiple selection (not available if the report has been tied to a project through filter settings)
  • Archive multiple selection
  • Variable multiple selection
  • Compression function single selection.
    Value list:
    • Sum
    • Average
    • Minimum
    • Maximum
  • Value Minimum
  • Value maximum
  • Number of colors

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Carpet Plot:
    • Longer time periods are plotted against shorter ones
  • Table with the columns:
    • Grouped according to longer time intervals

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListArchivesForProjects
  • ListVariablesForArchives
  • ISO50001_GetCarpetPlotData
  • ListLots
  • ListShifts
  • ListTimeWindowFrom
  • ListTimeWindowTo


Sankey Diagram

zenon Analyzer -> Supplied report templates -> Report templates -> ISO 50001 -> Sankey Diagram

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Reads off the Sankey definitions
  • Get data and aggregate this over the defined time period
  • Integrate dynamic loss detection if required
  • Display the result as a diagram or table

Create report

To create a Sankey Diagram report:

  1. In the Theme drop-down list, select ISO 50001
  2. from the drop-down list, select Sankey Diagram as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Variance tolerance for loss detection

Parameters

Description

Variance tolerance for loss detection

Denotes how many tenths of a percent the sum of the entries must deviate from the absolute difference of the sum of all entries and the sum of all outputs of a node in order to be recognized as a loss.

  • Minimum: 0
  • Maximum: 1000 - loss detection deactivated.

Entry in the field or configuration using the cursor keys.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Diagram and table
  • Diagram
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

The following are available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering
  • Select Sankey diagram from drop-down list

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Diagram
  • Tables:
    • One below the other
    • Decimal points with relative display: always 2 (0.00 %)
    • Decimal points in the relative value columns of the table: always 2 (0.00 %)
    • Vertical text alignment of the column headings in the tables: always Top
    • Horizontal text alignment of the column headings for source and target nodes: always Left

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ISO50001_GetSankeyDiagramData
  • ListAvailableSankeyDiagrams
  • ListLots
  • ListShifts
  • ListSankeyRelAbsCalc


Sankey Diagram (double width)

zenon Analyzer -> Supplied report templates -> Report templates -> ISO 50001 -> Sankey Diagram (double width)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template:

  • Reads off the Sankey definitions
  • Get data and aggregate this over the defined time period
  • Integrate dynamic loss detection if required
  • Display the result in reports of double width
  • with graphics over the complete width or tables next to one another

Create report

To create an Sankey Diagram (double width) report:

  1. In the Theme drop-down list, select ISO 50001
  2. from the drop-down list, select Sankey Diagram (double width) as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Variance tolerance for loss detection

Parameters

Description

Variance tolerance for loss detection

Denotes how many tenths of a percent the sum of the entries must deviate from the absolute difference of the sum of all entries and the sum of all outputs of a node in order to be recognized as a loss.

  • Minimum: 0
  • Maximum: 1000 - loss detection deactivated.

Entry in the field or configuration using the cursor keys.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Diagram and table
  • Diagram
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

The following are available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering
  • Select Sankey diagram from drop-down list

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Diagram
    • Double width (33.2 cm)
    • Graphics cover the whole width
  • Tables:
    • Next to one another
    • Decimal points with relative display: always 2 (0.00 %)
    • Decimal points in the relative value columns of the table: always 2 (0.00 %)
    • Vertical text alignment of the column headings in the tables: always Top
    • Horizontal text alignment of the column headings for source and target nodes: always Left

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ISO50001_GetSankeyDiagramData
  • ListAvailableSankeyDiagrams
  • ListLots
  • ListShifts
  • ListSankeyRelAbsCalc


Production Analysis Line Based

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide a range of report templates that assist in the evaluation and display of line-based production analyzes:

  • Gantt Chart: Analyzes lots, shifts and variables - specified through meanings, from AML, CEL or archive - and displays the results as a Gantt chart and as a table.
  • Gantt chart with area assignment: Analyzes lots, shifts and variables and displays the result as a Gantt chart and in table form. Variables are specified through meanings from AML, CEL or archive. Numerical values are assigned from classes derived from REMA-STATENAMES.
  • Line Losses Analysis (with lot tracking): Analyzes archive data and calculates aggregated loss times for a time period, based on an equipment group and a waterfall model.
  • Line Productivity Indicators Analysis (with lot tracking): Analyzes archive data and calculates aggregated productivity indicators for a time period, based on an equipment group.
  • Comprehensive Line Productivity Analysis (with lot tracking): Combines the Line Losses Analysis (with lot tracking) and Line Productivity Indicators Analysis (with lot tracking) templates.
  • Line Losses Analysis (without lot tracking): Analyzes archive data and calculates aggregated loss times for a time period, based on an equipment group and a waterfall model.
  • Line Productivity Indicators Analysis (without lot tracking): Analyzes archive data and calculates aggregated productivity indicators for a time period, based on an equipment group.
  • Comprehensive Line Productivity Analysis (without lot tracking): Combines the Line Losses Analysis (without lot tracking) and Line Productivity Indicators Analysis (without lot tracking) templates.
  • Line Losses Lot History (with lot tracking): Analyzes archive data and calculates aggregated loss times for each lot, based on an equipment group.
  • Line Productivity Indicators Lot History (with lot tracking): Analyzes archive data and calculates aggregated production indicators for each lot in a time period, based on an equipment group.
  • Comprehensive Line Productivity Lot History (with lot tracking): Combines the Line Losses Lot History (with lot tracking) and Line Productivity Indicators Lot History (with lot tracking) templates.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar.
  2. The dialog for selecting a template is opened.

    R

  3. In the Theme drop-down list, select Production Analysis Line Based.
  4. Select the template you want to use as a report template from the drop-down list.

Other topics in this chapter

Gantt Chart

Gantt Chart with Range Classification

Line Losses Analysis (with lot tracking)

Line Productivity Indicators Analysis (with lot tracking)

Comprehensive Line Productivity Analysis (with lot tracking)

Line Losses Analysis (without lot tracking)

Line Productivity Indicators Analysis (without lot tracking)

Comprehensive Line Productivity Analysis (without lot tracking)

Line Losses Lot History (with lot tracking)

Line Productivity Indicators Lot History (with lot tracking)

Comprehensive Line Productivity Lot History (with lot tracking)


Gantt Chart

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Gantt Chart

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze lots, shifts and variables - specified through meanings, from AML, CEL or archive - and display the results as a Gantt chart and as a table.

Create report

To create a Gantt chart report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. from the drop-down list, select Gantt chart as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Gantt Chart Analysis Configuration

Parameters | Description
Display settings | Display of the current settings for the Gantt diagram.
Configure gantt chart analysis | The dialog to configure the Gantt analysis is started by clicking on the button. For details, see Gantt-Diagram.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Gantt chart, aggregated table and detailed table
  • Gantt chart and aggregated table
  • Gantt chart and detailed table
  • Aggregated table and detailed table
  • Gantt Chart
  • Aggregation table
  • Detailed table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

The following are available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering with:
    • 2 x date and time selection (from and to for one time range)
    • 1 x time range selection.
    • 1 x lot selection with 2 x date and time selection for prefiltering of the lots.
    • 1 x lot selection with 1 x time range selection for prefiltering of the lots.
    • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts.
    • 1 x shift selection with 1 x time range selection for prefiltering of the shifts.
  • Multiple project selection (not available with lot or shift filter).
  • Single selection from the equipment tree. Only analyzable equipment groups are available.

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Gantt Chart
  • Aggregation table:
    1. First grouping: Equipment group name
    2. Second grouping: complete name of the analysis group
    3. Detail column per analysis group:

      Complete duration of all events in the analysis group. Calculation down to millisecond precision. Only within the time filter is relevant for the calculation.

      Status text: Shift name, lot name, text value of the variables if text data type, status name from the reaction matrix assigned from the variables for numerical data type.

      Numeric value for numeric data type of the variables.

  • Detail table:
    1. First grouping: Equipment group name
    2. Second grouping: complete name of the analysis group
    3. Detail columns per event of an analysis group:

      Incoming time.

      Outgoing time.

      Duration of the event: Calculation down to millisecond precision. Only within the time filter is relevant for the calculation.

      Status text: Shift name, lot name, text value of the variables if text data type, status name from the reaction matrix assigned from the variables for numerical data type.

      Numeric value for numeric data type of the variables.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Gantt
  • LineAnalysis_GetGanttBaseData
  • LineAnalysis_GetGanttData

Recommendations

Equipment Groups

For all equipment groups of an equipment model, use the same identification in the EQUIPMENTINFO table for the sorting field, provided this is used for the sorting.

Archives

Use the following for the recording of data for analysis groups:

  • AML
  • CEL
  • Archives with record on change

The stored procedure can also work with cyclical archives and event-controlled archives, but this is expressly not recommended.

Background:

  • Minimization of the amount of data for saving, evacuating and querying.
  • Only the recommended recording types provide a correct millisecond time stamp for the incoming time of an event.


Gantt Chart with Range Classification

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Gantt Chart with Range Classification

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze lots, shifts and variables and display the results as a Gantt chart and as a table. Variables are specified through meanings from AML, CEL or archive. Numerical values are assigned from classes derived from REMA-STATENAMES.

Create report

To create a Gantt Chart with Range Classification report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. from the drop-down list, select Gantt Chart with Range Classification as a report template.

  3. Click on the OK button.
  4. The report template is opened.
  5. Save the report with the desired name.
  6. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Gantt Chart Analysis Configuration

Parameters | Description
Display settings | Display of the current settings for the Gantt diagram.
Configure gantt chart analysis | The dialog to configure the Gantt analysis is started by clicking on the button. For details, see Gantt-Diagram.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Gantt chart, aggregated table and detailed table
  • Gantt chart and aggregated table
  • Gantt chart and detailed table
  • Aggregated table and detailed table
  • Gantt Chart
  • Aggregation table
  • Detailed table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

The following are available in the Report Launcher, depending on the parameters set up in ZAMS:

  • Configured time filtering with:
    • 2 x date and time selection (from and to for one time range)
    • 1 x time range selection.
    • 1 x lot selection with 2 x date and time selection for prefiltering of the lots.
    • 1 x lot selection with 1 x time range selection for prefiltering of the lots.
    • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts.
    • 1 x shift selection with 1 x time range selection for prefiltering of the shifts.
  • Multiple project selection (not available with lot or shift filter).
  • Single selection from the equipment tree. Only analyzable equipment groups are available.

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Gantt Chart
  • Aggregation table:
    1. First grouping: Equipment group name
    2. Second grouping: complete name of the analysis group
    3. Detail column per analysis group:

      Complete duration of all events in the analysis group. Calculation down to millisecond precision. Only within the time filter is relevant for the calculation.

      Status text: Shift name, lot name, name from the class assigned from the variables derived from the reaction matrix.

      Lower limit for variable analysis groups.

      Upper limit for variable analysis groups.

  • Detail table:
    1. First grouping: Equipment group name
    2. Second grouping: complete name of the analysis group
    3. Detail columns per event of an analysis group:

      Incoming time.

      Outgoing time.

      Duration of the event: Calculation down to millisecond precision. Only within the time filter is relevant for the calculation.

      Status text: Shift name, lot name, name from the class assigned from the variables derived from the reaction matrix.

      Lower limit for variable analysis groups.

      Upper limit for variable analysis groups.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects
  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Gantt
  • LineAnalysis_GetGanttBaseData
  • LineAnalysis_GetGanttRangeData

Recommendations

Equipment Groups

For all equipment groups of an equipment model, use the same identification in the EQUIPMENTINFO table for the sorting field, provided this is used for the sorting.

Archives

Use the following for the recording of data for analysis groups:

  • AML
  • CEL
  • Archives with record on change

The Stored Procedure can also work with cyclical archives and event-controlled archives, but this is expressly not recommended.

Background:

  • Minimization of the amount of data for saving, evacuating and querying.
  • Only the recommended recording types provide a correct millisecond time stamp for the incoming time of an event.


Line Losses Analysis (with lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Line Losses Analysis (with lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze archive data and calculate aggregated loss times for a time period, based on an equipment group and a waterfall model. Using the lots of the selected equipment groups, the data of the directly subordinate equipment groups is tracked and recorded. The report always works throughout a project. The results can be displayed as a waterfall diagram, Pareto diagram or as a table. The lot times of the subordinate equipment groups can be displayed as a table.

Create report

To create a Line Losses Analysis (with lot tracking):

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Line Losses Analysis (with lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Maximum Iterations for Lot Discovery

Parameters

Description

Maximum Iterations for Lot Discovery

Configuration of the maximum iteration for lot detection. Direct entry in the field or selection using the cursor keys. Clicking on an arrow increase or reduces the selected figure by the value 1.

  • Maximum: 10
  • Minimum: 1

Default: 3

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Selection of the waterfall diagram type:

Parameters

Description

Used for selecting the intended purpose

Selection of the waterfall diagram from a drop-down list:

  • Horizontal, compact, absolute
  • Horizontal, compact, relative
  • Horizontal detailed absolute
  • Horizontal, detailed, relative
  • Vertical, compact, absolute
  • Vertical, compact, relative
  • Vertical, detailed, absolute
  • Vertical, detailed, relative
  • No waterfall diagram

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Lot times on equipment groups

Parameters

Description

Lot times on equipment groups

Selection of the lot time table from a drop-down list:

  • Lot time table
  • No lot time table

Default: Lot time table

Equipment group labels

Parameters

Description

Equipment group labels

Selection of the equipment identification from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name without parent elements

Default: Equipment group name without parent elements

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • 1 x single-selection from pre-defined values for waterfall model name
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Waterfall chart (horizontal/vertical, compact/detailed, absolute/relative)
    • Horizontal, compact, absolute
    • Horizontal, compact, relative
    • Horizontal detailed absolute
    • Horizontal, detailed, relative
    • Vertical, compact, absolute
    • Vertical, compact, relative
    • Vertical, detailed, absolute
    • Vertical, detailed, relative
  • Pareto chart; absolute or relative
  • Time table (all times / only loss times) with the following columns:
    • Input color (clicking in the column header sorted according to index)
    • Name
    • Absolute counter
    • Relative counter (% of the total time)
  • Table with the times of the lots on the equipment groups with the following columns:
    • Lot name
    • Lot start and lot end per equipment group

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListWaterfallModelsForLine
  • ListFilterValuesForLine
  • GetFullEquipmentGroupName
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetLotList
  • LineAnalysis_GetWaterfallDataWithLotTracking
  • LineAnalysis_GetLotListPerLineWaterfall


Line Productivity Indicators Analysis (with lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Line Productivity Indicators Analysis (with lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze archive data and calculate aggregated productivity indicators for a time period, based on an equipment group. The data of the directly-subordinate equipment groups is tracked and recorded using the lots of the selected equipment group. The four main OEE indicators can be displayed as a bar chart or with four measurement instruments. The additional indicators are displayed as a table. The lot times of the subordinate equipment groups can be displayed as a table.

Create report

To create a Line Productivity Indicators Analysis (with lot tracking) report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Line Productivity Indicators Analysis (with lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Maximum Iterations for Lot Discovery

Parameters

Description

Maximum Iterations for Lot Discovery

Configuration of the maximum iteration for lot detection. Direct entry in the field or selection using the cursor keys. Clicking on an arrow increase or reduces the selected figure by the value 1.

  • Maximum: 10
  • Minimum: 1

Default: 3

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Gauge controls and table
  • Table

Lot times on equipment groups

Parameters

Description

Lot times on equipment groups

Selection of the lot time table from a drop-down list:

  • Lot time table
  • No lot time table

Default: Lot time table

Equipment group labels

Parameters

Description

Equipment group labels

Selection of the equipment identification from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name without parent elements

Default: Equipment group name without parent elements

Availability gauge ranges

Parameters

Description

Availability gauge ranges

Availability color ranges.

Configuration of the color ranges:

  • Low range
  • Medium range
  • High range

The upper limit of the low range is the lower value of the high range. The lower limit of the high range is the upper value of the low range. Both limits are inclusive limits. Both elements can be set to the same value. In this case, there is no medium range. The lower limit for the low range and the upper limit for the high range come from the report template.

Low range goes until

Defines the limit between the low (red) and medium (yellow) range in the measuring device.

High range starts at

Defines the limit between the medium (yellow) and high (green) range in the measuring device.

Display of ranges

Preview of the configured color ranges.

Performance gauge ranges

Performance color ranges

Configuration similar to Availability gauge ranges.

Quality gauge ranges

Quality color ranges

Configuration similar to Availability gauge ranges.

OEE gauge ranges

OEE color ranges

Configuration similar to Availability gauge ranges.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the main indicators Availability, Output, Quality and OEE.
  • Measurement devices for the main indicators Availability, Output, Quality and OEE.
  • Table with name and value of all indicators.
  • Table with the times of the lots on the equipment groups with the following columns:
    • Lot name
    • Lot start and lot end per equipment group

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListFilterValuesForLine
  • GetFullEquipmentGroupName
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetLotList
  • LineAnalysis_GetOeeDataWithLotTracking
  • LineAnalysis_GetLotListPerLineWaterfall


Comprehensive Line Productivity Analysis (with lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Comprehensive Line Productivity Analysis (with lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template combine the templates Line Losses Analysis (with lot tracking) and Line Productivity Indicators Analysis (with lot tracking). They analyze archive data and calculate aggregated loss times and productivity indicators for a time period, based on an equipment group. The data of the directly subordinate equipment groups is tracked and recorded using the lots of the selected equipment group. The four main OEE indicators can be displayed as a bar chart or with four measurement instruments. The additional indicators are displayed as a table.

Create report

To create a Comprehensive Line Productivity Analysis (with lot tracking) report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Comprehensive Line Productivity Analysis (with lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Maximum Iterations for Lot Discovery

Parameters

Description

Maximum Iterations for Lot Discovery

Configuration of the maximum iteration for lot detection. Direct entry in the field or selection using the cursor keys. Clicking on an arrow increase or reduces the selected figure by the value 1.

  • Maximum: 10
  • Minimum: 1

Default: 3

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Gauge controls and table
  • Table

Selection of the waterfall diagram type:

Parameters

Description

Used for selecting the intended purpose

Selection of the waterfall diagram from a drop-down list:

  • Horizontal, compact, absolute
  • Horizontal, compact, relative
  • Horizontal detailed absolute
  • Horizontal, detailed, relative
  • Vertical, compact, absolute
  • Vertical, compact, relative
  • Vertical, detailed, absolute
  • Vertical, detailed, relative
  • No waterfall diagram

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Lot times on equipment groups

Parameters

Description

Lot times on equipment groups

Selection of the lot time table from a drop-down list:

  • Lot time table
  • No lot time table

Default: Lot time table

Equipment group labels

Parameters

Description

Equipment group labels

Selection of the equipment identification from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name without parent elements

Default: Equipment group name without parent elements

Availability gauge ranges

Parameters

Description

Availability gauge ranges

Availability color ranges.

Configuration of the color ranges:

  • Low range
  • Medium range
  • High range

The upper limit of the low range is the lower value of the high range. The lower limit of the high range is the upper value of the low range. Both limits are inclusive limits. Both elements can be set to the same value. In this case, there is no medium range. The lower limit for the low range and the upper limit for the high range come from the report template.

Low range goes until

Defines the limit between the low (red) and medium (yellow) range in the measuring device.

High range starts at

Defines the limit between the medium (yellow) and high (green) range in the measuring device.

Display of ranges

Preview of the configured color ranges.

Performance gauge ranges

Performance color ranges

Configuration similar to Availability gauge ranges.

Quality gauge ranges

Quality color ranges

Configuration similar to Availability gauge ranges.

OEE gauge ranges

OEE color ranges

Configuration similar to Availability gauge ranges.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • 1 x single-selection from pre-defined values for waterfall model name
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the main indicators Availability, Output, Quality and OEE.
  • Measurement devices for the main indicators Availability, Output, Quality and OEE.
  • Table with name and value of all indicators.
  • Waterfall chart (horizontal/vertical, compact/detailed, absolute/relative)
    • Horizontal, compact, absolute
    • Horizontal, compact, relative
    • Horizontal detailed absolute
    • Horizontal, detailed, relative
    • Vertical, compact, absolute
    • Vertical, compact, relative
    • Vertical, detailed, absolute
    • Vertical, detailed, relative
  • Pareto chart; absolute or relative
  • Time table (all times / only loss times) with the following columns:
    • Input color (clicking in the column header sorted according to index)
    • Name
    • Absolute counter
    • Relative counter (% of the total time)
  • Table with the times of the lots on the equipment groups with the following columns:
    • Lot name
    • Lot start and lot end per equipment group

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListWaterfallModelsForLine
  • ListFilterValuesForLine
  • GetFullEquipmentGroupName
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetLotList
  • LineAnalysis_GetOeeDataWithLotTracking
  • LineAnalysis_GetLotListPerLineWaterfall


Line Losses Analysis (without lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Line Losses Analysis (without lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze archive data and calculate aggregated loss times for a time period, based on an equipment group and a waterfall model. The data is recorded by the directly-subordinate equipment groups. The results can be displayed as a waterfall diagram, Pareto diagram or as a table.

Create report

To create a Line Losses Analysis (without lot tracking) report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Line Losses Analysis (without lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Selection of the waterfall diagram type:

Parameters

Description

Used for selecting the intended purpose

Selection of the waterfall diagram from a drop-down list:

  • Horizontal, compact, absolute
  • Horizontal, compact, relative
  • Horizontal detailed absolute
  • Horizontal, detailed, relative
  • Vertical, compact, absolute
  • Vertical, compact, relative
  • Vertical, detailed, absolute
  • Vertical, detailed, relative
  • No waterfall diagram

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • 1 x single-selection from pre-defined values for waterfall model name
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Waterfall chart (horizontal/vertical, compact/detailed, absolute/relative)
    • Horizontal, compact, absolute
    • Horizontal, compact, relative
    • Horizontal detailed absolute
    • Horizontal, detailed, relative
    • Vertical, compact, absolute
    • Vertical, compact, relative
    • Vertical, detailed, absolute
    • Vertical, detailed, relative
  • Pareto chart; absolute or relative
  • Time table (all times / only loss times) with the following columns:
    • Input color (clicking in the column header sorted according to index)
    • Name
    • Absolute counter
    • Relative counter (% of the total time)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListWaterfallModelsForLine
  • ListFilterValuesForLine
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetWaterfallData


Line Productivity Indicators Analysis (without lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Line Productivity Indicators Analysis (without lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze archive data and calculate aggregated productivity indicators for a time period, based on an equipment group. The data is recorded by the directly-subordinate equipment groups. The four main OEE indicators can be displayed as a bar chart or with four measurement instruments. The additional indicators are displayed as a table.

Create report

To create a Line Productivity Indicators Analysis (without lot tracking) report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Line Productivity Indicators Analysis (without lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Gauge controls and table
  • Table

Availability gauge ranges

Parameters

Description

Availability gauge ranges

Availability color ranges.

Configuration of the color ranges:

  • Low range
  • Medium range
  • High range

The upper limit of the low range is the lower value of the high range. The lower limit of the high range is the upper value of the low range. Both limits are inclusive limits. Both elements can be set to the same value. In this case, there is no medium range. The lower limit for the low range and the upper limit for the high range come from the report template.

Low range goes until

Defines the limit between the low (red) and medium (yellow) range in the measuring device.

High range starts at

Defines the limit between the medium (yellow) and high (green) range in the measuring device.

Display of ranges

Preview of the configured color ranges.

Performance gauge ranges

Performance color ranges

Configuration similar to Availability gauge ranges.

Quality gauge ranges

Quality color ranges

Configuration similar to Availability gauge ranges.

OEE gauge ranges

OEE color ranges

Configuration similar to Availability gauge ranges.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the main indicators Availability, Output, Quality and OEE.
  • Measurement devices for the main indicators Availability, Output, Quality and OEE.
  • Table with name and value of all indicators.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListFilterValuesForLine
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetOeeData


Comprehensive Line Productivity Analysis (without lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Comprehensive Line Productivity Analysis (without lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template combine the templates Line Losses Analysis (without lot tracking) and Line Productivity Indicators Analysis (without lot tracking). They analyze archive data and calculate aggregated loss times and productivity indicators for a time period, based on an equipment group. The data of the directly-subordinate equipment groups is recorded using the selected equipment group. The four main OEE indicators can be displayed as a bar chart or with four measurement instruments. The additional indicators are displayed as a table.

Create report

To create a Comprehensive Line Productivity Analysis (with lot tracking) report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Comprehensive Line Productivity Analysis (without lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Gauge controls and table
  • Table

Selection of the waterfall diagram type:

Parameters

Description

Used for selecting the intended purpose

Selection of the waterfall diagram from a drop-down list:

  • Horizontal, compact, absolute
  • Horizontal, compact, relative
  • Horizontal detailed absolute
  • Horizontal, detailed, relative
  • Vertical, compact, absolute
  • Vertical, compact, relative
  • Vertical, detailed, absolute
  • Vertical, detailed, relative
  • No waterfall diagram

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Availability gauge ranges

Parameters

Description

Availability gauge ranges

Availability color ranges.

Configuration of the color ranges:

  • Low range
  • Medium range
  • High range

The upper limit of the low range is the lower value of the high range. The lower limit of the high range is the upper value of the low range. Both limits are inclusive limits. Both elements can be set to the same value. In this case, there is no medium range. The lower limit for the low range and the upper limit for the high range come from the report template.

Low range goes until

Defines the limit between the low (red) and medium (yellow) range in the measuring device.

High range starts at

Defines the limit between the medium (yellow) and high (green) range in the measuring device.

Display of ranges

Preview of the configured color ranges.

Performance gauge ranges

Performance color ranges

Configuration similar to Availability gauge ranges.

Quality gauge ranges

Quality color ranges

Configuration similar to Availability gauge ranges.

OEE gauge ranges

OEE color ranges

Configuration similar to Availability gauge ranges.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • 1 x single-selection from pre-defined values for waterfall model name
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the main indicators Availability, Output, Quality and OEE.
  • Measurement devices for the main indicators Availability, Output, Quality and OEE.
  • Table with name and value of all indicators.
  • Waterfall chart (horizontal/vertical, compact/detailed, absolute/relative)
    • Horizontal, compact, absolute
    • Horizontal, compact, relative
    • Horizontal detailed absolute
    • Horizontal, detailed, relative
    • Vertical, compact, absolute
    • Vertical, compact, relative
    • Vertical, detailed, absolute
    • Vertical, detailed, relative
  • Pareto chart; absolute or relative
  • Time table (all times / only loss times) with the following columns:
    • Input color (clicking in the column header sorted according to index)
    • Name
    • Absolute counter
    • Relative counter (% of the total time)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListWaterfallModelsForLine
  • ListFilterValuesForLine
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetWaterfallData
  • LineAnalysis_GetOeeData


Line Losses Lot History (with lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Line Losses Lot History (with lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The reports that are based on this template analyze archive data and calculate aggregated loss times and productivity indicators for each lot in a time period, based on an equipment group. Using the lots of the selected equipment groups, the data of the directly subordinate equipment groups is tracked and recorded. The results can be displayed as a bar chart or as a table. The lot times of the subordinate equipment groups can be displayed as a table.

Create report

To create a Line Losses Lot History (with lot tracking) report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Line Losses Lot History (with lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production loss time visualization

Parameters | Description
Production loss time visualization | Configuration and display of the meanings for the loss times.
Loss time visualization configuration | Table with the current settings for the meanings for the loss times.
Configure loss times visualization | Clicking on the button opens the dialog to configure the visualization of the loss times.

Maximum Iterations for Lot Discovery

Parameters

Description

Maximum Iterations for Lot Discovery

Configuration of the maximum iteration for lot detection. Direct entry in the field or selection using the cursor keys. Clicking on an arrow increase or reduces the selected figure by the value 1.

  • Maximum: 10
  • Minimum: 1

Default: 3

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Bar chart and table
  • Bar chart
  • Table

Lot times on equipment groups

Parameters

Description

Lot times on equipment groups

Selection of the lot time table from a drop-down list:

  • Lot time table
  • No lot time table

Default: Lot time table

Equipment group labels

Parameters

Description

Equipment group labels

Selection of the equipment identification from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name without parent elements

Default: Equipment group name without parent elements

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart distribution diagram with the counters for the relative diagram (value axis goes from 0 to 100%)
  • Bar chart with the counters for the absolute diagram
  • Table with all available times Columns:
    • Lot name
    • Lot start time
    • Lot end time
    • One value column per time counter
  • Table with the times of the lots on the equipment groups with the following columns:
    • Lot name
    • Lot start and lot end per equipment group

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListFilterValuesForLine
  • GetFullEquipmentGroupName
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetLotList
  • LineAnalysis_GetLossTimesDataLotHistory
  • LineAnalysis_GetLotListPerMeaning


Line Productivity Indicators Lot History (with lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Line Productivity Indicators Lot History (with lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The reports that are based on this template analyze archive data and calculate aggregated loss times and productivity indicators for each lot in a time period, based on an equipment group. The data of the directly subordinate equipment groups is tracked and recorded using the lots of the selected equipment group. The four main OEE indicators can be displayed as a bar chart or as a line diagram. The additional indicators are displayed as a table. The lot times of the subordinate equipment groups can be displayed as a table.

Create report

To create a Line Productivity Indicators Lot History (with lot tracking) report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Line Productivity Indicators Lot History (with lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Maximum Iterations for Lot Discovery

Parameters

Description

Maximum Iterations for Lot Discovery

Configuration of the maximum iteration for lot detection. Direct entry in the field or selection using the cursor keys. Clicking on an arrow increase or reduces the selected figure by the value 1.

  • Maximum: 10
  • Minimum: 1

Default: 3

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Line chart and table
  • Table

Lot times on equipment groups

Parameters

Description

Lot times on equipment groups

Selection of the lot time table from a drop-down list:

  • Lot time table
  • No lot time table

Default: Lot time table

Equipment group labels

Parameters

Description

Equipment group labels

Selection of the equipment identification from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name without parent elements

Default: Equipment group name without parent elements

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the main indicators Availability, Output, Quality and OEE.
  • Line diagram with the main indicators Availability, Output, Quality and OEE.
  • Table with name and value of all indicators.
  • Table with the times of the lots on the equipment groups with the following columns:
    • Lot name
    • Lot start and lot end per equipment group

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListFilterValuesForLine
  • GetFullEquipmentGroupName
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetLotList
  • LineAnalysis_GetOeeDataLotHistory
  • LineAnalysis_GetLotListPerMeaning


Comprehensive Line Productivity Lot History (with lot tracking)

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Line Based -> Comprehensive Line Productivity Lot History (with lot tracking)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template combine the templates Line Losses Lot History (with lot tracking) and Line Productivity Indicators Lot History (with lot tracking). They analyze archive data and calculate the aggregated loss times and aggregated productivity indicators for a time period, based on an equipment group. The data of the directly subordinate equipment groups is tracked and recorded using the lots of the selected equipment group. The four main OEE indicators can be displayed as a bar chart or as a line diagram. The additional indicators are displayed as a table.

Create report

To create a Comprehensive Line Productivity Lot History (with lot tracking) report:

  1. Select Production Analysis Line Based in the drop-down list in the dialog to create new reports as a theme.
  2. From the drop-down list, select Comprehensive Line Productivity Lot History (with lot tracking) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Data filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production loss time visualization

Parameters | Description
Production loss time visualization | Configuration and display of the meanings for the loss times.
Loss time visualization configuration | Table with the current settings for the meanings for the loss times.
Configure loss times visualization | Clicking on the button opens the dialog to configure the visualization of the loss times.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Maximum Iterations for Lot Discovery

Parameters

Description

Maximum Iterations for Lot Discovery

Configuration of the maximum iteration for lot detection. Direct entry in the field or selection using the cursor keys. Clicking on an arrow increase or reduces the selected figure by the value 1.

  • Maximum: 10
  • Minimum: 1

Default: 3

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Line chart and table
  • Table

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Lot times on equipment groups

Parameters

Description

Lot times on equipment groups

Selection of the lot time table from a drop-down list:

  • Lot time table
  • No lot time table

Default: Lot time table

Equipment group labels

Parameters

Description

Equipment group labels

Selection of the equipment identification from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name without parent elements

Default: Equipment group name without parent elements

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input
  • 1 x time range input
  • 2 x absolute time input and 1 x lot single selection
  • 1 x time range input and 1 x lot single selection
  • 2 x relative time input and 1 x shift single selection
  • 1 x time range input and 1 x shift single selection

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the main indicators Availability, Output, Quality and OEE.
  • Line diagram with the main indicators Availability, Output, Quality and OEE.
  • Table with name and value of all indicators.
  • Bar chart distribution diagram with the counters for the relative diagram (value axis goes from 0 to 100%).
  • Bar chart with the counters for the absolute diagram.
  • Table with all available times Columns:
    • Lot name
    • Lot start time
    • Lot end time
    • One value column per time counter
  • Table with the times of the lots on the equipment groups with the following columns:
    • Lot name
    • Lot start and lot end per equipment group

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree
  • ListFilterValuesForLine
  • GetFullEquipmentGroupName
  • LineAnalysis_GetMetaDataEntries
  • LineAnalysis_GetLotList
  • LineAnalysis_GetOeeDataLotHistory
  • LineAnalysis_GetLossTimesDataLotHistory
  • LineAnalysis_GetLotListPerMeanings


Production Analysis Machine Based

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Machine Based

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide report templates for the analysis of loss times and productivity, based on standards such as DIN 8782, DIN 8743, Weihenstephan Standards and the best practices of some manufacturing companies:

  • Losses Analysis: Analyze archive data and calculate aggregated loss times for a time period, based on an equipment group and a waterfall model.
  • Productivity Indicators Analysis: Analyze archive data and calculate aggregated productivity indicators for a time period, based on an equipment group.
  • Comprehensive Productivity Analysis: Combines the Losses Analysis and Produktivity indicators Analysis report templates.
  • Losses Lot History: Analyze archive data and calculate aggregated loss times for each lot, based on an equipment group.
  • Productivity Indicators Lot History: Analyze archive data and calculate aggregated production indicators for each lot in a time period, based on an equipment group.
  • Comprehensive Productivity Lot History: Combines the Losses Lot History and Productivity Indicators Lot History templates.

All report templates in this theme allow the filtering of archived production data according to pallet type, crate type, bottle type and number of the filling tank. These four optional data filters can also be used for other filters. In this case, it is recommended that the parameters concerned are changed after the report has been provided in ZAMS.

Recommendation: Each waterfall model should have an unique name.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar
  2. The dialog for selecting a template is opened

  3. In the Theme drop-down list, select Production Analysis Machine Based
  4. Select the template you want to use as a report template from the drop-down list

Other topics in this chapter

Losses Analysis

Productivity Indicators Analysis

Comprehensive Productivity Analysis

Losses Lot History

Productivity Indicators Lot History

Comprehensive Productivity Lot History

Configuration of the reports for machine-based production analysis in zenon


Losses Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Machine Based -> Losses Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze archive data and calculate aggregated loss times for a time period, based on an equipment group and a waterfall model. The results can be displayed as a Waterfall diagram, Pareto diagram or as a table.

Create report

To create a Losses Analysis report:

  1. Select Production Analysis Machine Based in the drop-down list in the dialog to create new reports as a theme
  2. from the drop-down list, select Losses Analysis as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Project | Selection of the project that is to be linked to a project from a drop-down list.
Data Filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Selection of the waterfall diagram type:

Parameters

Description

Used for selecting the intended purpose

Selection of the waterfall diagram from a drop-down list:

  • Horizontal, compact, absolute
  • Horizontal, compact, relative
  • Horizontal detailed absolute
  • Horizontal, detailed, relative
  • Vertical, compact, absolute
  • Vertical, compact, relative
  • Vertical, detailed, absolute
  • Vertical, detailed, relative
  • No waterfall diagram

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model
  • 1 x single-selection from pre-defined values for waterfall model name
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • One of the eight waterfall diagrams (optional):
    • Horizontal, compact, absolute
    • Horizontal, compact, relative
    • Horizontal detailed absolute
    • Horizontal, detailed, relative
    • Vertical, compact, absolute
    • Vertical, compact, relative
    • Vertical, detailed, absolute
    • Vertical, detailed, relative
  • Absolute or relative Pareto diagram (optional). If no table is used, a Pareto diagram must be used.
  • Table with all rows or table with the loss times (optional). If no Pareto diagram is used, a table must be used.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListFilterValueForEquipment
  • ListWaterfallModelsForEquipment
  • FNB_GetMetaDataEntries
  • FNB_WaterfallData


Productivity Indicators Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Machine Based -> Productivity Indicators Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze archive data and calculate aggregated productivity indicators for a time period, based on an equipment group. The four central OEE indicators can be displayed as a bar chart or in four measurement devices. The additional optional indicators are displayed in a table.

Create report

To create a Productivity Indicators Analysis report:

  1. Select Production Analysis Machine Based in the drop-down list in the dialog to create new reports as a theme
  2. from the drop-down list, select Productivity Indicators Analysis as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Project | Selection of the project that is to be linked to a project from a drop-down list.
Data Filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Gauge controls and table
  • Table

Availability gauge ranges

Parameters

Description

Availability gauge ranges

Availability color ranges.

Configuration of the color ranges:

  • Low range
  • Medium range
  • High range

The upper limit of the low range is the lower value of the high range. The lower limit of the high range is the upper value of the low range. Both limits are inclusive limits. Both elements can be set to the same value. In this case, there is no medium range. The lower limit for the low range and the upper limit for the high range come from the report template.

Low range goes until

Defines the limit between the low (red) and medium (yellow) range in the measuring device.

High range starts at

Defines the limit between the medium (yellow) and high (green) range in the measuring device.

Display of ranges

Preview of the configured color ranges.

Performance gauge ranges

Performance color ranges

Configuration similar to Availability gauge ranges.

Quality gauge ranges

Quality color ranges

Configuration similar to Availability gauge ranges.

OEE gauge ranges

OEE color ranges

Configuration similar to Availability gauge ranges.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart or four measurement devices for the main indicators (optional).
  • Table with all indicators Cells for indicators that are not calculated remain empty.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListFilterValueForEquipment
  • FNB_GetMetaDataEntries
  • FNB_OeeData


Comprehensive Productivity Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Machine Based -> Comprehensive Productivity Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This template combines the Losses Analysis and Productivity Indicators Analysis report templates.

Reports that are based on this template analyze archive data and calculate aggregated loss times and aggregated productivity indicators for a time period, based on an equipment group and a waterfall model. The four central OEE indicators can be displayed as a bar chart or in four measurement devices. The additional optional indicators are displayed in a table. The loss times can be displayed as a Waterfall diagram, Pareto diagram or as a table.

Create report

To create a Comprehensive Productivity Analysis report:

  1. Select Production Analysis Machine Based in the drop-down list in the dialog to create new reports as a theme
  2. from the drop-down list, select Comprehensive Productivity Analysis as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Project | Selection of the project that is to be linked to a project from a drop-down list.
Data Filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Gauge controls and table
  • Table

Selection of the waterfall diagram type:

Parameters

Description

Used for selecting the intended purpose

Selection of the waterfall diagram from a drop-down list:

  • Horizontal, compact, absolute
  • Horizontal, compact, relative
  • Horizontal detailed absolute
  • Horizontal, detailed, relative
  • Vertical, compact, absolute
  • Vertical, compact, relative
  • Vertical, detailed, absolute
  • Vertical, detailed, relative
  • No waterfall diagram

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Availability gauge ranges

Parameters

Description

Availability gauge ranges

Availability color ranges.

Configuration of the color ranges:

  • Low range
  • Medium range
  • High range

The upper limit of the low range is the lower value of the high range. The lower limit of the high range is the upper value of the low range. Both limits are inclusive limits. Both elements can be set to the same value. In this case, there is no medium range. The lower limit for the low range and the upper limit for the high range come from the report template.

Low range goes until

Defines the limit between the low (red) and medium (yellow) range in the measuring device.

High range starts at

Defines the limit between the medium (yellow) and high (green) range in the measuring device.

Display of ranges

Preview of the configured color ranges.

Performance gauge ranges

Performance color ranges

Configuration similar to Availability gauge ranges.

Quality gauge ranges

Quality color ranges

Configuration similar to Availability gauge ranges.

OEE gauge ranges

OEE color ranges

Configuration similar to Availability gauge ranges.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model
  • 1 x single-selection from pre-defined values for waterfall model name
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart or four measurement devices for the main indicators (optional).
  • Table with all indicators Cells for indicators that are not calculated remain empty.
  • One of the eight waterfall diagrams (optional):
    • Horizontal, compact, absolute
    • Horizontal, compact, relative
    • Horizontal detailed absolute
    • Horizontal, detailed, relative
    • Vertical, compact, absolute
    • Vertical, compact, relative
    • Vertical, detailed, absolute
    • Vertical, detailed, relative
  • Absolute or relative Pareto diagram (optional). If no table is used, a Pareto diagram must be used.
  • Table with all rows or table with the loss times (optional). If no Pareto diagram is used, a table must be used.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListFilterValueForEquipment
  • ListWaterfallModelsForEquipment
  • FNB_GetMetaDataEntries
  • FNB_WaterfallData
  • FNB_OeeData


Losses Lot History

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Machine Based -> Losses Lot History

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The reports that are based on this template analyze archive data and calculate aggregated loss times and productivity indicators for each lot in a time period, based on an equipment group. The results can be displayed as a bar chart or as a table.

Create report

To create a Losses Lot History report:

  1. Select Production Analysis Machine Based in the drop-down list in the dialog to create new reports as a theme
  2. from the drop-down list, select Losses Lot History as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Project | Selection of the project that is to be linked to a project from a drop-down list.
Data Filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production loss time visualization

Parameters | Description
Production loss time visualization | Configuration and display of the meanings for the loss times.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Loss time visualization configuration | Table with the current settings for the meanings for the loss times.
Configure loss times visualization | Clicking on the button opens the dialog to configure the visualization of the loss times.

Lot archive selection

Parameters | Description
Lot archive selection | Configuration of the lot archive.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Lot archive | Selection of a lot archive for the selected project from the drop-down list.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar charts with relative and absolute display of the configured losses (optional). If no table is used, a bar chart must be used.
  • Table with the configured loss times (optional). If no bar chart is used, a table must be used.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListFilterValueForEquipment
  • FNB_GetMetaDataEntries
  • FNB_LossTimesLotHistory


Productivity Indicators Lot History

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Machine Based -> Productivity Indicators Lot History

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The reports that are based on this template analyze archive data and calculate aggregated loss times and productivity indicators for each lot in a time period, based on an equipment group. The results can be displayed as a bar chart or as a line chart. The additional optional indicators are displayed in a table.

Create report

To create a Productivity Indicators Lot History report:

  1. Select Production Analysis Machine Based in the drop-down list in the dialog to create new reports as a theme
  2. from the drop-down list, select Productivity Indicators Lot History as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Project | Selection of the project that is to be linked to a project from a drop-down list.
Data Filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Lot archive selection

Parameters | Description
Lot archive selection | Configuration of the lot archive.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Lot archive | Selection of a lot archive for the selected project from the drop-down list.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Gauge controls and table
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart or line chart for the main indicators (optional).
  • Table with all indicators Cells for indicators that are not calculated remain empty.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListFilterValueForEquipment
  • FNB_GetMetaDataEntries
  • FNB_OeeLotHistory


Comprehensive Productivity Lot History

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Machine Based -> Comprehensive Productivity Lot History

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The report template combines the templates Losses Lot history and Productivity Indicators Lot History.

The reports that are based on this template analyze archive data and calculate compressed loss times and productivity indicators for each lot in a time period, based on an equipment group. The four central OEE indicators can be displayed as a bar chart or as a line chart. The additional optional indicators are displayed in a table. The losses can be displayed as a bar chart or as a table.

Create report

To create a Comprehensive Productivity Lot History report:

  1. Select Production Analysis Machine Based in the drop-down list in the dialog to create new reports as a theme
  2. from the drop-down list, select Comprehensive Productivity Lot History as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Production data filters

Parameters | Description
Production data filters | Configuration and display of the production data filter.
Project | Selection of the project that is to be linked to a project from a drop-down list.
Data Filter configuration | Table with the current settings for data filtering.
Configure data filters | Clicking on the button opens the dialog for configuring the data filters.

Production loss time visualization

Parameters | Description
Production loss time visualization | Configuration and display of the meanings for the loss times.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Loss time visualization configuration | Table with the current settings for the meanings for the loss times.
Configure loss times visualization | Clicking on the button opens the dialog to configure the visualization of the loss times.

Production indicators

Parameters | Description
Production indicators | Configuration and display of the production indicators.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Optional indicators | Table with the current settings for the optional indicators.
Assigned meanings | Table with the configuration of the field meanings for the calculation of the indicators.
Configure indicators | Clicking on the button opens the dialog for configuring the indicators.

Lot archive selection

Parameters | Description
Lot archive selection | Configuration of the lot archive.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Lot archive | Selection of a lot archive for the selected project from the drop-down list.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Indicator data representation

Parameters

Description

Indicator data representation

Selection of the display type for the indicators from the drop-down list:

  • Bar chart and table
  • Gauge controls and table
  • Table

Loss times data representation

Parameters

Description

Loss times data representation

Selection of the display type for the time distribution from the drop-down list.

  • Pareto diagram (absolute) and table with all times
  • Pareto diagram (relative) and table with all times
  • Pareto diagram (absolute) and table with the loss times
  • Pareto diagram (relative) and table with the loss times
  • Pareto diagram (absolute)
  • Pareto diagram (relative)
  • All times table
  • Table with the loss times

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model
  • Optional:
    • 1 x multiple selection from pre-defined values for pallet type filter (if activated)
    • 1 x multiple selection from pre-defined values for crate type filter (if activated)
    • 1 x multiple selection from pre-defined values for bottle type filter (if activated)
    • 1 x multiple selection from pre-defined values for tank number type filter (if activated)

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart or line chart for the main indicators (optional).
  • Table with all indicators Cells for indicators that are not calculated remain empty.
  • Bar charts with relative and absolute display of the configured losses (optional). If no table is used, a bar chart must be used.
  • Table with the configured loss times (optional). If no bar chart is used, a table must be used.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListFilterValueForEquipment
  • FNB_GetMetaDataEntries
  • FNB_LossTimesLotHistory
  • FNB_OeeLotHistory


Configuration of the reports for machine-based production analysis in zenon

zenon Analyzer -> Supplied report templates -> Report templates -> Production Analysis Machine Based -> Configuration of the reports for machine-based production analysis in zenon

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You can find notes on configuration of the data basis in zenon for Production Analysis Machine Based reports.

The project and/or the metadata must provide the following data:

  • Variables for filter
  • Variables for the OEE calculation
  • Variables for the calculation of performance indicators
  • Variables for waterfall and loss time diagram
  • Archives

Variables for filter:

Each variable must be assigned to a reaction matrix that contains the available filter details. For this, the following applies:

  • Only numerical reaction matrices are permitted.
  • The assignment must be made with =. The characters > and < are not permitted.
  • The default setting of the reaction matrix is ignored.
  • If the same assignment exists more than once (for example: xy = 3), only the one that is found first is used. All others are ignored.
  • The name displayed in the filter is the limit value text. The language of this cannot be switched; existing control characters are cut off (@).

The use of individual variables is optional. Only the variables that are needed for the filter need to be configured.

Variables for the OEE calculation

Note:

  • * Variables must, for each equipment group for which an evaluation is possible, be created and linked to the equipment model. The same variables are, labeled otherwise (with WF=), also used for the waterfall diagram.
  • These variables must be defined in zenon depending on the version in the Resources label (up to 7.11) with ME=… (for example: ME=OperatingTime, …) or from zenon 7.20 in Meaning (OperatingTime, …).

Variables for the calculation of performance indicators

Note:

  • * Variables must, for each equipment group for which an evaluation is possible, be created and linked to the equipment model.
  • These variables must be defined in zenon depending on the version in the Resources label (up to 7.11) with ME=… (M E=MTBS_TimeCounter, … or from zenon 7.20 in Meaning (MTBS_TimeCounter, …) .

Variables for Waterfall and loss time diagram

Note:

  • * Proposed name in zenon. Not relevant to zenon Analyzer.
  • ** Identical names identify related variables for the waterfall display.
    This also applies to the loss time diagram.
  • *** [Index] provides the position for the display in the waterfall diagram as a row number or column number.
  • These variables must be defined in zenon depending on the version in the Resources label (up to 7.11) with WF=… (for example: WF=01,01,#FFAD5B; …) or from zenon 7.20 in Parameter for waterfall diagram (01,01,#FFAD5B; …).

Archives

Note: * Archive is linked to the equipment group.


OEE Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> OEE Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide report templates that calculate and display OEE indicators:

  • OEE Indicator: Calculates the OEE performance figures for a selected equipment model in a time period and displays the performance figures in graphic form
  • OEE Indicator Lot History: Calculates the OEE indicators for a selected equipment model for each lot in a period of time and displays the performance figures in graphic form and table form

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar
  2. The dialog for selecting a template is opened

  3. In the Theme drop-down list, select OEE Analysis
  4. Select the template you want to use as a report template from the drop-down list

Metadata

Metadata used: General
 | used | If not used
Projects | + | mandatory.
Alarm/Event class | - |
Alarm/Event groups | - |
Users | - |
Equipment Modeling | + | mandatory.
Archives | + | mandatory.
Variables | + | mandatory.
Prices | - |
Norm values | - |
Metadata used: Time filter
Lots | + | No reports possible with lot filter.
Shifts | + | No reports possible with shift filter.

Other topics in this chapter

OEE Indicator

OEE Indicator Lot History

Configuration of the OEE reports in zenon


OEE Indicator

zenon Analyzer -> Supplied report templates -> Report templates -> OEE Analysis -> OEE Indicator

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate the OEE indicators of an equipment group and display the performance figures in graphic form. These reports are always linked to a certain project.

Application examples

Alarm list reports are suited, for example, to determining the quality indicators in a shift, lot or certain time period for:

  • A critical machine in the production process
  • A production line
  • A complete factory

Create report

To create an OEE performance figure report:

  1. In the Theme drop-down list, select OEE Analysis
  2. from the drop-down list, select OEE performance figures as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Variable assignment for OEE calculation

Parameters | Description
Variable assignment for OEE calculation | Assignment of the project, the archive and the variables. Field shows the current configuration.
Configure assignments | Clicking on the button opens the dialog for configuring the assignments.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Column chart and pointer instruments
  • Bar chart
  • Gauge controls

Availability gauge ranges

Parameters

Description

Availability gauge ranges

Availability color ranges.

Configuration of the color ranges:

  • Low range
  • Medium range
  • High range

The upper limit of the low range is the lower value of the high range. The lower limit of the high range is the upper value of the low range. Both limits are inclusive limits. Both elements can be set to the same value. In this case, there is no medium range. The lower limit for the low range and the upper limit for the high range come from the report template.

Low range goes until

Defines the limit between the low (red) and medium (yellow) range in the measuring device.

High range starts at

Defines the limit between the medium (yellow) and high (green) range in the measuring device.

Display of ranges

Preview of the configured color ranges.

Performance gauge ranges

Performance color ranges

Configuration similar to Availability gauge ranges.

Quality gauge ranges

Quality color ranges

Configuration similar to Availability gauge ranges.

OEE gauge ranges

OEE color ranges

Configuration similar to Availability gauge ranges.

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Note: If the report is linked to a project via time filtering, the project selection is set to the linked project and a check is made to ensure that only archives from the project can be selected in both groupings.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list with the equipment models for which the OEE performance figures can be calculated. Each equipment model contains the complete hierarchy path in its name.

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: Each indicator (OEE, availability, performance, quality) has a column with data annotation.
  • Measurement devices: Each indicator has a measurement device.
    These have the following ranges:
    • OEE:
      Red from 0% to 65%,
      Yellow from 65% to 85%,
      Green from 85% to 100%
    • Availability, Performance and Quality:
      Red from 0% to 85 %,
      Yellow from 85 % to 95 %,
      Green from 95 % to 100%

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListEquipments_OEE
  • OEE_GetCounters
  • OEE_GetStates
  • OEE_Indicators
  • ListLots
  • ListShifts


OEE Indicator Lot History

zenon Analyzer -> Supplied report templates -> Report templates -> OEE Analysis -> OEE Indicator Lot History

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this template calculate the OEE indicators of lots of an equipment group in a time period and display the performance figures graphically and in tables. In doing so, the performance figures are calculated separately for each lot. These reports are always linked to a certain project.

Application examples

Alarm list reports are suited, for example, to checking the development of performance indicators during a shift or in a certain time period for:

  • A critical machine
  • A production line
  • A complete factory

Create report

To create an OEE performance figure lot archive report:

  1. In the Theme drop-down list, select OEE Analysis
  2. from the drop-down list, select OEE performance figure lot archive as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Variable assignment for OEE calculation

Parameters | Description
Variable assignment for OEE calculation | Assignment of the project, the archive and the variables. Field shows the current configuration.
Configure assignments | Clicking on the button opens the dialog for configuring the assignments.

Lot archive selection

Parameters | Description
Lot archive selection | Configuration of the lot archive.
Project | Selection of the project that is to be linked to a project from a drop-down list. If a project is selected, this project is forwarded to all other groupings in the report that offer project selection. If this grouping receives a message about a linked project from another grouping, this project is set in the drop-down list and the drop-down list is deactivated.
Lot archive | Selection of a lot archive for the selected project from the drop-down list.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Note: If the report is linked to a project via time filtering, the project selection is set to the linked project and a check is made to ensure that only archives from the project can be selected in both groupings.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single-selection drop-down list with the equipment models for which the OEE performance figures can be calculated. Each equipment model contains the complete hierarchy path in its name.

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Column chart: A column chart for the time period is drawn. For each lot, a column is drawn for each indicator at the start time.
  • Line chart: A trend line is drawn for each indicator. The times are the lot start times.
  • Table: a table with the following columns:
    • Lot name (can be sorted dynamically)
    • Start time (can be sorted dynamically)
    • End time stamp (can be sorted dynamically)
    • OEE in %
    • Availability in %
    • Performance in %
    • Quality in %
    • Total production quantity in units
    • Good production quantity in units
    • Actual operating time in minutes
    • Planned operating time in minutes
    • Number of units that were possible with the planned equipment speed in the actual operating time

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListEquipments_OEE
  • OEE_GetCounters
  • OEE_GetStates
  • OEE_Indicators_LotHistory
  • ListLots
  • ListShifts


Configuration of the OEE reports in zenon

zenon Analyzer -> Supplied report templates -> Report templates -> OEE Analysis -> Configuration of the OEE reports in zenon

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For the calculation of the OEE performance indicators, certain metadata must be provided and configured in zenon.

OEE performance indicator in accordance with Weihenstephan standard

The project and/or the metadata must provide the following data:

  • Variables for filter
  • Variables for OEE calculation
  • Variables for calculation of performance indicators
  • Variables for relative loss times
  • Variables for absolute loss times
  • Archives

Variables for filter:

Each variable must be assigned to a reaction matrix that contains the available filter details. For this, the following applies:

  • Only numerical reaction matrices are permitted.
  • The assignment must be made with =. The characters > and < are not permitted.
  • The default setting of the reaction matrix is ignored.
  • If the same assignment exists more than once (for example: xy = 3), only the one that is found first is used. All others are ignored.
  • The name displayed in the filter is the limit value text. The language of this cannot be switched; existing control characters are cut off (@).
  • The use of individual variables is optional. Only the variables that are needed for the filter need to be configured.

Variables for OEE calculation:

Note:

  • * Variables must, for each equipment group for which an evaluation is possible, be created and linked to the equipment model. The same variables are, labeled otherwise (with WF=), also used for the waterfall diagram.
  • These variables must be defined in zenon depending on the version in the Resources label (up to 7.11) with ME=… (for example: ME=OperatingTime, …) or from zenon 7.20 in Meaning (OperatingTime, …).

Variables for performance figure calculation:

Note:

  • * Variables must, for each equipment group for which an evaluation is possible, be created and linked to the equipment model.
  • These variables must be defined in zenon depending on the version in the Resources label (up to 7.11) with ME=… (M E=MTBS_TimeCounter, … or from zenon 7.20 in Meaning (MTBS_TimeCounter, …) .

Variables for relative loss times

Note:

  • * Proposed name in zenon. Not relevant to zenon Analyzer.
  • These variables must be defined in zenon depending on version in the Resources label (up to 7.11) with ME=RelativeTimeLosses or from zenon 7.20 in Meaning with RelativeTimeLosses.

Variables for absolute loss times

Note:

  • * Proposed name in zenon. Not relevant to zenon Analyzer.
  • These variables must be defined in zenon depending on version in the Resources label (up to 7.11) with ME=AbsoluteTimeLosses or from zenon 7.20 in Meaning with AbsoluteTimeLosses.

Archives:

Note: * Archive is linked to the equipment group.

OEE_Indicator Standard

The project and/or the metadata must contain the following data:

Variables

Variable name | Assignment (meaning) | Data type | Archive | Connector
Freely selectable*. | Freely selectable. Default: Operating Time | BOOL** | Freely selectable. Identical for all three variables. Default: S1 | SQL/zenonV6
Freely selectable*. | Freely selectable. Default: EffectiveWorkingTime | BOOL** |  | SQL/zenonV6
Freely selectable*. | Freely selectable. Default: DesignedSpeed | REAL |  | SQL/zenonV6
Freely selectable*. | Freely selectable. Default: GoodUnits | UDINT | Freely selectable. Identical for both variables. Default: C1 | SQL/zenonV6
Freely selectable*. | Freely selectable. Default: TotalUnits | UDINT |  | SQL/zenonV6
  • * All variables are assigned to the same equipment group that is offered in the report as a filter. For each equipment group for which OEE evaluations are possible, variables with this meaning are created and linked to the equipment group.
  • ** The times are calculated in the report and provide the time in which the variable was in the Period under review = 1.

Archives

Archive short description | Archive name | Recording type | Connector
Freely selectable. e.g.: S1 | Freely selectable. | On-change. | SQL/zenonV6
Freely selectable. e.g.: C1 | Freely selectable. | Cyclical or event-controlled*. | SQL/zenonV6
  • * The counters must be set to 0 after successful archiving.

OEE_Indicator per Batch

This report calculates the OEE performance indicators for each lot of an equipment group in a time period and provides these figures graphically and in a table.

Variables

Variable name | Assignment (meaning) | Data type | Archive | Connector
Freely selectable*. | Freely selectable. Default: Operating Time | BOOL** | Freely selectable. Identical for all three variables. Default: S1 | SQL/zenonV6
Freely selectable*. | Freely selectable. Default: EffectiveWorkingTime | BOOL** |  | SQL/zenonV6
Freely selectable*. | Freely selectable. Default: DesignedSpeed | REAL |  | SQL/zenonV6
Freely selectable*. | Freely selectable. Default: GoodUnits | UDINT | Freely selectable. Identical for both variables. Default: C1 | SQL/zenonV6
Freely selectable*. | Freely selectable. Default: TotalUnits | UDINT |  | SQL/zenonV6
For batch names, freely selectable. | - | STRING | Freely selectable. Default: OE | SQL/zenonV6
  • * All variables are assigned to the same equipment group that is offered in the report as a filter. For each equipment group for which OEE evaluations are possible, variables with this meaning are created and linked to the equipment group.
  • ** The times are calculated in the report and provide the time in which the variable was in the Period under review = 1.

Archives

Archive | Archive name | Recording type | Connector
S1 | Freely selectable. | On-change. | SQL/zenonV6
C1 | Freely selectable. | Cyclical or event-controlled*. | SQL/zenonV6
OE* | Freely selectable. | Event-triggered. | SQL/zenonV6
  • * The batch archive OE must be started and stopped using zenon functions. In the event of a stop, the value of the batch variable in the archive is saved as a batch name with start and stop time.


Target Actual Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Target Actual Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide report templates that allow the comparison of nay desired machine-related measured sizes with prescribed values. In doing so, the actual values always come from an archive. The target values can come from an archive. If these are not archived, the target values are, if possible, extracted from the NORM table. The variables are addressed using equipment groups and meanings.

For this, the following applies:

  • Variables that can be used for the target-actual analysis.
    • Are addressed using meanings
    • Must be linked to the respective equipment group
  • The archive in which the actual values are saved must be linked to the respective equipment group.
  • If these target values come from an archive instead of from the NORM table, then this archive must be linked to the respective equipment group.

Report templates

The following report templates are available:

  • Target Actual Aggregated Trend (absolute): Gets the target and actual values for the set meanings and the selected equipment group and calculates absolute counters from this.
  • Target Actual Aggregated Trend (relative): Gets the target and actual values for the set meanings and the selected equipment group and calculates relative counters from this.
  • Scatter Plot: Creates a scatter plot for the comparison of any desired machine-related measured sizes with set values.
  • Scatter Plot with Reference Curve: Creates a scatter plot of a value pair for a time period.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar
  2. The dialog for selecting a template is opened

  3. In the Theme drop-down list, select OEE Analysis
  4. Select the template you want to use as a report template from the drop-down list

Other topics in this chapter

Target Actual Aggregated Trend (absolute)

Target Actual Aggregated Trend (relative)

Example of target-actual comparison with absolute counters

Scatter Plot

Scatter Plot with Reference Curve


Target Actual Aggregated Trend (absolute)

zenon Analyzer -> Supplied report templates -> Report templates -> Target Actual Analysis -> Target Actual Aggregated Trend (absolute)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get the set values and actual values for the set meanings and the selected equipment group. The absolute counters are calculated and displayed from this.

Create report

To create a Target Actual Aggregated Trend (absolute) report:

  1. In the Theme drop-down list, select Target Actual Analysis
  2. from the drop-down list, select Target Actual Aggregated Trend (absolute) as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Target and actual value meanings

Parameters | Description
Target and actual value meanings | Display and configuration of the meanings for set points and actual values.
List of configured meanings for set values and actual values | Table with the current settings for the meanings for the set points and actual values.
Configure target and actual value meanings | Clicking on the button opens the dialog for configuring the meanings.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart with the data
  • Bar chart with the data
  • Table with the following columns:
    • Interval Start
    • Interval End
    • Set value (heading: Variable name)
    • Actual value (heading: Variable name)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • TargetActualComparison_Absolute


Target Actual Aggregated Trend (relative)

zenon Analyzer -> Supplied report templates -> Report templates -> Target Actual Analysis -> Target Actual Aggregated Trend (relative)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template get the set values and actual values for the set meanings and the selected equipment group. The relative counters are calculated and displayed from this.

Create report

To create a Target Actual Aggregated Trend (relative) report:

  1. In the Theme drop-down list, select Target Actual Analysis
  2. from the drop-down list, select Target Actual Aggregated Trend (relative) as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Target and actual value meanings

Parameters | Description
Target and actual value meanings | Display and configuration of the meanings for set points and actual values.
List of configured meanings for set values and actual values | Table with the current settings for the meanings for the set points and actual values.
Configure target and actual value meanings | Clicking on the button opens the dialog for configuring the meanings.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Line chart and table
  • Bar chart and table
  • Line chart
  • Bar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • Hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Line chart with the data
  • Bar chart with the data
  • Table with the following columns:
    • Interval Start
    • Interval End
    • Set value (heading: Variable name)
    • Actual value (heading: Variable name)

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • TargetActualComparison_Relative


Example of target-actual comparison with absolute counters

zenon Analyzer -> Supplied report templates -> Report templates -> Target Actual Analysis -> Example of target-actual comparison with absolute counters

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Aim

An analysis is to take place for five machines, using a comparison of target and actual values with absolute counters:

  • Production quantity
  • Electricity consumption
  • Operating temperature

Preparatory work

  • A separate report is configured for each statistic.
  • Each report works with different meanings.
  • In zenon, archived variables are present for the desired statistics.
  • The meanings are set as follows for all machines:
Variable | Meaning
Production quantity – target | ProdTarget
Production quantity – actual | ProdActual
Electricity consumption – target | PowerTarget
Electricity consumption – actual | PowerActual
Operating temperature – target | TempTarget
Operating temperature – actual | TempActual

Report

In the next step, three reports are created on the basis of the report template TargetActualComparison_Absolute:

Report name

Meanings

Report provides:

Target Actual Analysis – Production
  • ProdTarget
  • ProdActual

Target-actual comparison for production quantity for all five machines.

Target Actual Analysis – Power
  • PowerTarget
  • PowerActual

Target-actual comparison for electricity consumption for all five machines.

Target Actual Analysis – Temperature
  • TempTarget
  • TempActual

Target-actual comparison for operating temperature for all five machines.


Scatter Plot

zenon Analyzer -> Supplied report templates -> Report templates -> Target Actual Analysis -> Scatter Plot

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a scatter plot for the comparison of any desired machine-related measured values with default values. The value pairs are displayed as an X and Y value in a two-dimensional grid as a point. The values can be compressed with the average aggregation function. No reference curves are displayed in the diagram.

This report template is offered in the following themes:

  • Target Actual Analysis
  • Hydroelectric Power Plant Analysis
  • Wind Power Plant Analysis

Create report

To create a Scatter plot report:

  1. Select, in the dialog to create new reports, one of the following themes in the drop-down list:
    • Target Actual Analysis
    • Hydroelectric Power Plant Analysis
    • Wind Power Plant Analysis
  2. From the drop-down list, select Scatter Plot as a report template.

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Scatter plot meanings

Parameters | Description
Meanings for indicators of the scatter plot | Display and configuration of the meaning for indicators.
Horizontal indicator meaning | Display of the meaning for the horizontal indicator.
Vertical indicator meaning | Display of the meaning for the vertical indicator.
Configure scatter plot | Clicking on the button opens the dialog for configuring the meanings.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Scatter plot and data table
  • Scatter Plot
  • Data table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input (from to), 1 x project selection (multiple-selection drop-down)
  • 1 x relative time input (time period), 1 x project selection (multiple-selection drop-down)
  • 2 x absolute time input (from to), 1 x lot selection
  • 1 x relative time input (time period), 1 x lot selection
  • 2 x absolute time input (from to), 1 x shift selection
  • 1 x relative time input (time period), 1 x shift selection

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Scatter Plot
  • Data table with the following columns:
    • Equipment group: Grouping, sortable, expandable and collapsible
    • Value on the horizontal axis, sortable
    • Value on the vertical axis, sortable

Value on the vertical axis: sortable Note for report developers: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects (if neither lots nor shifts are used for time filtering)
  • ListLots (if lots are used for time filtering)
  • ListShifts (if shifts are used for time filtering)
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • TargetActualScatter_WithoutReferenceCurve


Scatter Plot with Reference Curve

zenon Analyzer -> Supplied report templates -> Report templates -> Target Actual Analysis -> Scatter Plot with Reference Curve

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template create a scatter plot of a value pair for a time period. The value pairs are displayed as an X and Y value in a two-dimensional grid as a point. The values can be compressed with the average aggregation function. A reference curve is also displayed in the diagram.

This report template is offered in the following themes:

  • Target Actual Analysis
  • Hydroelectric Power Plant Analysis
  • Wind Power Plant Analysis

Create report

To create a scatter plot with reference curve:

  1. Select, in the dialog to create new reports, one of the following themes in the drop-down list:
    • Target Actual Analysis
    • Hydroelectric Power Plant Analysis
    • Wind Power Plant Analysis
  2. From the drop-down list, select Scatter plot withe reference curve as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Scatter plot meanings

Parameters | Description
Meanings for indicators of the scatter plot | Display and configuration of the meaning for indicators.
Horizontal indicator meaning | Display of the meaning for the horizontal indicator.
Vertical indicator meaning | Display of the meaning for the vertical indicator.
Configure scatter plot | Clicking on the button opens the dialog for configuring the meanings.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Scatter plot and data table
  • Scatter Plot
  • Data table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input (from to), 1 x project selection (multiple-selection drop-down)
  • 1 x relative time input (time period), 1 x project selection (multiple-selection drop-down)
  • 2 x absolute time input (from to), 1 x lot selection
  • 1 x relative time input (time period), 1 x lot selection
  • 2 x absolute time input (from to), 1 x shift selection
  • 1 x relative time input (time period), 1 x shift selection

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Scatter Plot
  • Data table with the following columns:
    • Equipment group: Grouping, sortable, expandable and collapsible
    • Value on the horizontal axis, sortable
    • Value on the vertical axis, sortable

Value on the vertical axis: sortable Note for report developers: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects (if neither lots nor shifts are used for time filtering)
  • ListLots (if lots are used for time filtering)
  • ListShifts (if shifts are used for time filtering)
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • TargetActualScatter_WithReferenceCurve


Hydroelectric Power Plant Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide report templates that determine and display various counters for hydraulic power plants.

The following report templates are available:

  • Operating Time per Operation Mode and Machine Component: Calculates operating times for the individual operating modes of a machine and machine components.
  • Operating Time per Operation Mode or Frequency Control Mode: Calculates operating times for a machine including times in which the machine is running in either operating or frequency regulation mode.
  • Operating Time per Machine Component: Analyzes absolute operating times of components of an item of equipment or several items of equipment since they were last replaced and since they were last inspected.
  • Operating Time per Power Range: Calculates operating times for a machine per power range.
  • Circuit Breaker Switching Cycles (Switchyard single selection): Calculates switching cycles for circuit breakers with individual selection of equipment models.
  • Circuit Breaker Switching Cycles (Circuit Breaker multiple selection): Calculates switching cycles for circuit breakers with multiple selection of equipment models.
  • Active and Reactive Energy Meters (Parent Machine single selection): Calculates counter values for active and reactive power on the basis of an equipment group with subgroups.
  • Active and Reactive Energy Meters (Machine multiple selection): Calculates counter values for active and reactive power on the basis of selected equipment groups.
  • Power Line Frequency: Calculates time counters for different frequency bands of the network frequency of a machine.
  • Machine Event Counters (Machine single selection): Calculates counters for different events that may occur for a machine.
  • Set Point Change Event Counters (Machine multiple selection): Determines counters for different machine events: Switching on and off as well as changes to the set value.
  • Nozzle Mode Change Event Counters (Machine multiple selection): Determines counters for different machine events: Switching on and off as well as changes to the nozzle mode.
  • Load Shedding Active Power Ranges Event Counters (Machine multiple selection): Determines counters for different machine events: Switching on and off as well as load shedding in configurable active power ranges.
  • Load Shedding Turbine Speed Ranges Event Counters (Machine multiple selection): Determines counters for different machine events: Switching on and off as well as load shedding in configurable turbine speed ranges.
  • Machine Start Counters: Show starts of the machine sets for turbine and pump operation.

From Target Actual Analysis theme:

  • Scatter Plot: Creates a scatter plot for the comparison of any desired machine-related measured sizes with set values.
  • Scatter Plot with Reference Curve: Creates a scatter plot of a value pair for a time period.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar
  2. The dialog for selecting a template is opened

  3. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  4. Select the template you want to use as a report template from the drop-down list

Other topics in this chapter

Operating Time per Operation Mode and Machine Component

Operating Time per Operation Mode or Frequency Control Mode

Operating Time per Machine Component

Operating Time per Power Range

Circuit Breaker Switching Cycles (Switchyard single selection)

Circuit Breaker Switching Cycles (Circuit Breaker multiple selection)

Active and Reactive Energy Meters (Parent Machine single selection)

Active and Reactive Energy Meters (Machine multiple selection)

Power Line Frequency

Machine Event Counters (Machine single selection)

Set Point Change Event Counters (Machine multiple selection)

Nozzle Mode Change Event Counters (Machine multiple selection)

Load Shedding Active Power Ranges Event Counters (Machine multiple selection)

Load Shedding Turbine Speed Ranges Event Counters (Machine multiple selection)

Machine Start Counters


Operating Time per Operation Mode and Machine Component

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Operating Time per Operation Mode and Machine Component

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate operating times for the individual operating modes of a machine. In addition, the operating times per machine component since the last inspection of the components are calculated.

The display is a data table that contains all time counters. In addition, the time counters for the operating modes can be displayed graphically as a sum or aggregation trend.

Create report

To create an Operating Time per Operation Mode and Machine Component report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. from the drop-down list, select Operating Time per Operation Mode and Machine Component as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Operating time assignments

Parameters | Description
Operating time assignments | Display and configuration of the assignments for power station operating times per machine component and operating mode.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • aggregated column chart and table
  • aggregated pie chart and table
  • Aggregated trend bar chart and table
  • Aggregated trend line chart and table
  • Table

Origin of mode labels

Parameters

Description

Origin of mode labels

Selection of the marking for operating modes from drop-down list:

  • Variable visual name
  • Descriptive text for the variables

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the sums of the relative counters for operating modes.
  • Pie chart with the sums of the relative counters for operating modes.
  • Bar chart with the aggregation trends of the relative counters for operating modes.
  • Line chart with the aggregation trends of the relative counters for operating modes.
  • Table with the following structure:

    Detail cells: Always contain the counter value for the column group in the interval.

    Sum row: Has the sum for relative counters and the last value for absolute counters.

    Row groups: Time intervals within the report period under review.

    There are the following column groupings:

    • Absolute and relative counter for machine operating time.
    • Relative counter for operation modes.
      The sorting configuration takes effect within this group.
    • Components that do not use a component name (such as a running wheel) and do not have a superordinate component.
      The sorting configuration takes effect within this group.
    • Components that use a component name (such as a running wheel) but do not have a superordinate component.
      The sorting configuration takes effect within this group.
    • Components that do not use a component name (such as a running wheel) but do have a superordinate component.
      The sorting configuration takes effect within this group.
    • Components that use a component name (such as a running wheel) and have a superordinate component.
      The sorting configuration takes effect within this group.

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • ListHppStructureNames
  • GetChildEquipments
  • HppOperatingHours


Operating Time per Operation Mode or Frequency Control Mode

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Operating Time per Operation Mode or Frequency Control Mode

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate operating times for a machine including times in which the machine is running in either operating mode or frequency regulation mode.
The data table contains all time counters. In addition, the comparison of absolute and relative time counters between machines and modes can be displayed graphically.

Create report

To create an Operating Time per Operation Mode or Frequency Regulation report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. from the drop-down list, select Operating Time per Operation Mode or Frequency Control Mode as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

Tipp Hint

Use the description text for labels and sort on the basis of names. This way you ensure that it is possible to group properly.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Operating hours assignments for operating modes

Parameters | Description
Operating hours assignments for operating modes | Display and configuration of the assignments of operating hours for operating modes.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives. For details, see the Assignments of operating hours for operating modes section.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for mode comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for mode comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Origin of mode labels

Parameters

Description

Origin of mode labels

Selection of the marking for operating modes from drop-down list:

  • Variable visual name
  • Descriptive text for the variables

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x single entry for absolute time
  • 1 x time range selection
  • 2 x single entry for absolute time and 1 x lot selection
  • 1 x time period selection and 1 x lot selection
  • 2 x single entry for absolute time and 1 x shift selection
  • 1 x time period selection and 1 x shift selection

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar charts with end values of the absolute time counters, one of the following forms:
    • Horizontal axis = modes
      Groupings = equipment groups, optimized for equipment comparison
    • Horizontal axis = equipment groups
      Groupings = modes, optimized for mode comparison
  • Bar charts with end values of the absolute time counters, one of the following forms:
    • Horizontal axis = modes
      Groupings = equipment groups, optimized for equipment comparison
    • Horizontal axis = equipment groups
      Groupings = modes, optimized for mode comparison
  • Table with the following structure:

    Equipment group (grouping, drill-down)

    From (start of interval)

    To (end of interval)

    There are the following column groupings:

    • General absolute time counter
    • General relative time counter
    • Mode counter (absolute and relative; 0 to N columns)

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • ListHppStructureNames_MS
  • GetChildEquipments
  • HppOperatingHours
  • HppModeOperatingHours
  • GetFullEquipmentGroupName


Operating Time per Machine Component

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Operating Time per Machine Component

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze absolute operating times of components of an item of equipment or several items of equipment since they were last replaced and since they were last inspected.

Create report

To create an Operating Time per Machine Component report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Operating Time per Machine Component as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

Tipp Hint

Use the description text for labels and sort on the basis of names. This way you ensure that it is possible to group properly.

Use larger interval lengths and shorter review periods in order to speed up the retrospective interpretation of data.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Component operating time assignments

Parameters | Description
Component operating time assignments | Display and configuration of the assignments for power station operating times per machine component.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives. For details, see the Assignments of operating times for components section.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for component comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for component comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x single entry for absolute time
  • 1 x time range selection
  • 2 x single entry for absolute time and 1 x lot selection
  • 1 x time period selection and 1 x lot selection
  • 2 x single entry for absolute time and 1 x shift selection
  • 1 x time period selection and 1 x shift selection

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar charts with end values of the absolute time counters, one of the following forms:
    • Horizontal axis = components
      Groupings = equipment groups, optimized for equipment comparison
    • Horizontal axis = equipment groups
      Groupings = components, optimized for component comparison
  • Table with the following structure:

    Equipment group (grouping, drill-down)

    From (start of interval)

    To (end of interval)

    There are the following column groupings:

    • Component absolute time counter, possible with:
      Component description, if the components can have a name
      since replacement or
      since inspection
      0 to N columns

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • ListHppStructureNames_MS
  • GetChildEquipments
  • HppComponentOperatingHours
  • GetFullEquipmentGroupName


Operating Time per Power Range

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Operating Time per Power Range

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate operating times for a machine per power range.

The display is a data table that contains all time counters. In addition, the time counters for the power ranges can be displayed graphically as a sum or aggregation trend.

Create report

To create an Operating Time per Power Range report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. from the drop-down list, select Operating Time per Power Range as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Operating time per power range assignments

Parameters | Description
Operating time per power range assignments | Display and configuration of the assignments for power station operating times per load area.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • aggregated column chart and table
  • aggregated pie chart and table
  • Aggregated trend bar chart and table
  • Aggregated trend line chart and table
  • Table

Origin of mode labels

Parameters

Description

Origin of mode labels

Selection of the marking for operating modes from drop-down list:

  • Variable visual name
  • Descriptive text for the variables

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the sums of the relative counters for power range operating time.
  • Pie chart with the sums of the relative counters for power range operating time.
  • Bar chart with the aggregation trends of the relative counters for power range operating time.
  • Line chart with the aggregation trends of the relative counters for power range operating time.
  • Table with the following structure:

    Detail cells: Always contain the counter value for the column group in the interval.

    Sum row: Has the sum for relative counters and the last value for absolute counters.

    Row groups: Time intervals within the report period under review.

    There are the following column groupings:

    • Active power generator range.
      The sorting configuration takes effect within this group.
    • Active power generator maximum.
    • Active power generator minimum.
    • Active power pump range.
      The sorting configuration takes effect within this group.
    • Active power pump maximum.
    • Active power pump minimum.
    • Reactive power generator range.
      The sorting configuration takes effect within this group.
    • Reactive power generator maximum.
    • Reactive power generator minimum.
    • Reactive power pump range.
      The sorting configuration takes effect within this group.
    • Reactive power pump maximum.
    • Reactive power pump minimum.

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • ListHppStructureNames
  • HppPowerHours


Circuit Breaker Switching Cycles (Switchyard single selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Circuit Breaker Switching Cycles (Switchyard single selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate switching cycles for circuit breakers. Based on a relative switching cycle counter, absolute switching cycle counters for a circuit breaker are calculated. These absolute counters are reset if the circuit breaker is inspected or replaced. An equipment model can be selected for the report.

The display is a data table that contains all data. In addition, the most recent absolute counters can be displayed in a bar chart.

Create report

To create a Circuit Breaker Switching Cycles (Switchyard single selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. Select Circuit Breaker Switching Cycles (Switchyard single selection) from the drop-down list as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Switching cycles assignments

Parameters | Description
Switching cycles assignments | Display and configuration of the assignment for power switching cycles.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Bar chart (ungrouped) and table
  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Origin of circuit breaker labels

Parameters

Description

Origin of circuit breaker labels

Selection of the identification for circuit breakers from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements
  • Relative counter variable visual name
  • Relative counter variable description text

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Ungrouped bar chart and table
  • Bar chart for equipment comparison, bar chart for equipment comparison and table.
  • Bar chart for equipment comparison and table
  • Bar chart for equipment comparison and table
  • Table with the following structure:

    Detail cells: Always contain the counter value for the column group in the interval.

    Sum row: Has the sum for relative counters and the last value for absolute counters.

    Row groups: Time intervals within the report period under review.

    The column grouping is primarily based on the name of the counter (origin can be controlled in ZAMS). In doing so, the defined sorting sequence is used. Within these groups:

    • First there is the relative counter,
    • then the absolute counter since inspection and
    • then the absolute counter since replacement

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • ListHppStructureNames
  • GetChildEquipments
  • GetFullEquipmentGroupName
  • HppSwitchingCycles


Circuit Breaker Switching Cycles (Circuit Breaker multiple selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Circuit Breaker Switching Cycles (Circuit Breaker multiple selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate switching cycles for circuit breakers. Based on a relative switching cycle counter, absolute switching cycle counters for a circuit breaker are calculated. These absolute counters are reset if the circuit breaker is inspected or replaced. Several equipment models can be selected for the report.

The display is a data table that contains all data. In addition, the most recent absolute counters can be displayed in a bar chart.

Create report

To create a Circuit Breaker Switching Cycles (circuit breaker - multiple selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. Select Circuit Breaker Switching Cycles (circuit breaker - multiple selection) from the drop-down list as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Switching cycles assignments

Parameters | Description
Switching cycles assignments | Display and configuration of the assignment for power switching cycles.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Bar chart (ungrouped) and table
  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Origin of circuit breaker labels

Parameters

Description

Origin of circuit breaker labels

Selection of the identification for circuit breakers from a drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements
  • Relative counter variable visual name
  • Relative counter variable description text

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Ungrouped bar chart and table
  • Bar chart for equipment comparison, bar chart for equipment comparison and table.
  • Bar chart for equipment comparison and table
  • Bar chart for equipment comparison and table
  • Table with the following structure:

    Detail cells: Always contain the counter value for the column group in the interval.

    Sum row: Has the sum for relative counters and the last value for absolute counters.

    Row groups: Time intervals within the report period under review.

    The column grouping is primarily based on the name of the counter (origin can be controlled in ZAMS). In doing so, the defined sorting sequence is used. Within these groups:

    • First there is the relative counter,
    • then the absolute counter since inspection and
    • then the absolute counter since replacement

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • ListHppStructureNames_MS
  • GetFullEquipmentGroupName
  • HppSwitchingCyclesMultipleSwitches


Active and Reactive Energy Meters (Parent Machine single selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Active and Reactive Energy Meters (Parent Machine single selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate counter values for active and reactive power.

The display is a data table that contains all data. In addition, the counter values can be displayed as an aggregation or aggregation trend in various diagrams.

Create report

To create an Active and Reactive Energy Meters (Parent Machine single selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Active and Reactive Energy Meters (Parent Machine single selection) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Active and reactive power counter assignments

Parameters | Description
Active and reactive power counter assignments | Display and configuration of the assignments for active and reactive power counters.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • aggregated column chart and table
  • aggregated pie chart and table
  • Aggregated trend bar chart and table
  • Aggregated trend line chart and table
  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with the sums of the counters.
  • Pie chart with the sums of the counters.
  • Bar chart with the aggregation trends of the counters.
  • Line chart with the aggregation trends of the counters.
  • Bar chart with equipment groups as groupings in the key and counters as grouping of the horizontal axis.
  • Bar chart with counters as groupings in the key and equipment group as a grouping of the horizontal axis.
  • Table with the following structure:

    Detail cells: Always contain the counter value for the column group in the interval.

    First level of the column groupings: Is always the name of the machine.

    Second level of the column groupings: consists of these elements in this sequence:

    • Active power production
    • Active power consumption
    • Reactive power production
    • Reactive power consumption

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_AtLeastOneOfMeanings
  • ListHppStructureNames
  • GetChildEquipments
  • GetFullEquipmentGroupName
  • HppActiveReactiveCounters


Active and Reactive Energy Meters (Machine multiple selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Active and Reactive Energy Meters (Machine multiple selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate counter values for active and reactive power. All equipment groups to be analyzed are selected directly by means of multiple selection.

The display is a data table that contains all data. In addition, the counter values can be displayed as an aggregation or aggregation trend in various diagrams.

Create report

To create an Active and Reactive Energy Meters (Machine multiple selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Active and Reactive Energy Meters (Machine multiple selection) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Active and reactive power counter assignments

Parameters | Description
Active and reactive power counter assignments | Display and configuration of the assignments for active and reactive power counters.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x input absolute time
  • 1 x input time period
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparisons and table.
  • Aggregated bar chart for equipment comparison and table.
  • Aggregated bar chart for counter comparisons and table.
  • Table with the following structure:
    • Equipment group (drill-down)
    • Start of the interval
    • End of the interval
    • One value column per counter

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_AtLeastOneOfMeanings
  • ListHppStructureNames_MS
  • GetFullEquipmentGroupName
  • HppActiveReactiveCountersMultipleMachines


Power Line Frequency

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Power Line Frequency

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate time counters for different frequency bands of the network frequency of a machine.
Archives with the following recording type are processed:

  • cyclic
  • on change

The display is:

  • Aggregation trend of the network frequency with minimum, maximum and average network frequency
  • Data table with the time counters of all frequency counters
  • Diagrams with the configured time counters for frequency counters

Create report

To create a Power Line Frequency report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. from the drop-down list, select Power Line Frequency as a report template

  3. Click on the OK button.
  4. The report template is opened
  5. Save the report with the desired name
  6. Configure the report

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Power line frequency assignments

Parameters | Description
Power line frequency assignments | Display and configuration of the assignment for power line frequency.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for frequency band time counter
  • Aggregated pie chart for frequency band time counter
  • Aggregated trend - bar chart for frequency band time counter
  • Aggregated trend - line chart for frequency band time counter
  • Power line frequency trend line chart and table

Origin of mode labels

Parameters

Description

Origin of mode labels

Selection of the marking for operating modes from drop-down list:

  • Variable visual name
  • Descriptive text for the variables

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart sorted according to frequency bands with the sums of the relative counters for frequency bands.
  • Bar chart sorted according to counter values with the sums of the relative counters for frequency bands.
  • Pie chart with the sums of the relative counters for frequency bands.
  • Bar chart with the aggregation trends of the relative counters for frequency bands.
  • Line chart with the aggregation trends of the relative counters for frequency bands.
  • Line chart with the aggregation trends for average, minimum and maximum of the network frequency.
  • Table with the following structure:
    • The time intervals within the report period under review always act as the row groups.
    • The frequency band variables always act as column groups.
    • The sorting is created on the basis of the SORT_ORDER column in the HppFrequencyCounters SP.

    Detail cells always contain the counter value for the column group in the interval.

    The sum row has the sum of the relative counters.

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_MeaningsWithPrefix
  • ListHppStructureNamesWithFrequency
  • HppFrequencyTrend
  • HppFrequencyCounters


Machine Event Counters (Machine single selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Machine Event Counters (Machine single selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template calculate counters for different events that can occur on a machine. Counters can be calculated for the following events:

  • Switching the machine on and off
  • Changes to the target value for the machine
  • Changes to nozzle mode
  • Load shedding events in configurable active power ranges and turbine speed ranges

All counters are displayed in a table.

Create report

To create a Machine Event Counters (Machine single selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Machine Event Counters (Machine single selection) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Event counter assignments

Parameters | Description
Event counter assignments | Display and configuration of the assignments for the event counter. The properties that can be displayed and configured depend on the type of report template.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Load shedding: Active power lookback seconds

Parameters

Description

Load shedding: Active power lookback seconds

Selection of the number of seconds for how far before load shedding the maximum active power at the time of load shedding is searched for.

Formula: Active power = Max(active power) from time range (load shedding – configured seconds) until load shedding.

Load shedding: Turbine speed lookfront seconds

Parameters

Description

Load shedding: Turbine speed lookfront seconds

Selection of the number of seconds for how far, after load shedding, the maximum turbine speed at the time of load shedding is searched for.

Formula: Load shedding turbine speed = Max(turbine speed) from time period up to (load shedding + configured seconds).

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Origin of mode labels

Parameters

Description

Origin of mode labels

Selection of the marking for operating modes from drop-down list:

  • Variable visual name
  • Descriptive text for the variables

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x date and time selection ("from" and "to" for one time range)
  • 1 x time range selection
  • 1 x lot selection with 2 x date and time selection for prefiltering of the lots
  • 1 x lot selection with 1 x time range selection for prefiltering of the lots
  • 1 x shift selection with 2 x date and time selection for prefilitering of the shifts
  • 1 x shift selection with 1 x time range selection for prefiltering of the shifts

Other parameters

  • 1 x single selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The data is always displayed using a data table once it has been created. The table has the following structure:

  • The time intervals within the report period under review always act as the row groups.
  • There are the following column groupings:
    • Switch-on and switch-off events.
    • Overall changes to target values (always first) and per operating mode (sorting can be configured).
    • Change to nozzle mode (counter states how often a change to this mode has been made, sorting can be configured).
    • Active power when load is switched off (same sequence as in the configuration dialog).
    • Turbine speed when load is switched off (same sequence as in the configuration dialog).

    Detailed cells always contain the counter value for the column group in the interval, sum row has the sum.

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_MeaningsAndChildMeanings
  • ListHppStructureNamesWithNominalPowerAndRpm
  • GetChildEquipments
  • HppEventCounters


Set Point Change Event Counters (Machine multiple selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Set Point Change Event Counters (Machine multiple selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template determine counters for different machine events:

  • Switching on and off
  • Amendments to the set value

All counters are displayed in a bar chart and a table.

Reports based on this template allow the selection of several machines.

Create report

To create an Event Counter for Changes to Set values (machines - multiple selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Event Counter for Changes to Set values (machines - multiple selection) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Event counter assignments

Parameters | Description
Event counter assignments | Display and configuration of the assignments for the event counter. The properties that can be displayed and configured depend on the type of report template.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Origin of mode labels

Parameters

Description

Origin of mode labels

Selection of the marking for operating modes from drop-down list:

  • Variable visual name
  • Descriptive text for the variables

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time single input
  • 1 x relative time single input
  • 2 x absolute time single input and 1 x lot single selection
  • 1 x relative time single input and 1 x lot single selection
  • 2 x absolute time single input and 1 x shift single selection
  • 1 x relative time single input and 1 x shift single selection

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with equipment groups as groupings in the key and counters as a grouping of the horizontal axis.
    Not available for counters for switching on and off.
  • Bar chart with counters as groupings in the key and equipment groups as grouping in the horizontal axis.
    Not available for counters for switching on and off.
  • Data table with the following structure:
    • Equipment group (drill-down)
    • Start time of the aggregation interval
    • End time of the aggregation interval
    • One bar per counter

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree_MeaningsAndChildMeanings
  • ListHppStructureNames_MS
  • GetChildEquipments
  • GetEquipmentTreeForGroup
  • GetFullEquipmentGroupName
  • HppEventCounters_SetPointChangesPerOperationMode


Nozzle Mode Change Event Counters (Machine multiple selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Nozzle Mode Change Event Counters (Machine multiple selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template determine counters for different machine events:

  • Switching on and off
  • Changes to nozzle mode

All counters are displayed in a bar chart and a table.

Reports based on this template allow the selection of several machines.

Create report

To create a Event Counter for Nozzle Mode Switches (machines - multiple selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Event Counter for Nozzle Mode Switches (machines - multiple selection) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Event counter assignments

Parameters | Description
Event counter assignments | Display and configuration of the assignments for the event counter. The properties that can be displayed and configured depend on the type of report template.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Origin of mode labels

Parameters

Description

Origin of mode labels

Selection of the marking for operating modes from drop-down list:

  • Variable visual name
  • Descriptive text for the variables

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time single input
  • 1 x relative time single input
  • 2 x absolute time single input and 1 x lot single selection
  • 1 x relative time single input and 1 x lot single selection
  • 2 x absolute time single input and 1 x shift single selection
  • 1 x relative time single input and 1 x shift single selection

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with equipment groups as groupings in the key and counters as a grouping of the horizontal axis.
    Not available for counters for switching on and off.
  • Bar chart with counters as groupings in the key and equipment groups as grouping in the horizontal axis.
    Not available for counters for switching on and off.
  • Data table with the following structure:
    • Equipment group (drill-down)
    • Start time of the aggregation interval
    • End time of the aggregation interval
    • One bar per counter

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree_MeaningsAndChildMeanings
  • ListHppStructureNames_MS
  • GetChildEquipments
  • GetEquipmentTreeForGroup
  • GetFullEquipmentGroupName
  • HppEventCounters_NozzleModes


Load Shedding Active Power Ranges Event Counters (Machine multiple selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Load Shedding Active Power Ranges Event Counters (Machine multiple selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template determine counters for different machine events:

  • Switching on and off
  • Load shedding in configurable active power ranges

All counters are displayed in a bar chart and a table.

Reports based on this template allow the selection of several machines.

Create report

To create an Event Counter for Load Shedding - active power ranges (machines - multiple selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Event Counter for Load Shedding - active power ranges (machines - multiple selection) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Event counter assignments

Parameters | Description
Event counter assignments | Display and configuration of the assignments for the event counter. The properties that can be displayed and configured depend on the type of report template.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Load shedding: Active power lookback seconds

Parameters

Description

Load shedding: Active power lookback seconds

Selection of the number of seconds for how far before load shedding the maximum active power at the time of load shedding is searched for.

Formula: Active power = Max(active power) from time range (load shedding – configured seconds) until load shedding.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time single input
  • 1 x relative time single input
  • 2 x absolute time single input and 1 x lot single selection
  • 1 x relative time single input and 1 x lot single selection
  • 2 x absolute time single input and 1 x shift single selection
  • 1 x relative time single input and 1 x shift single selection

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with equipment groups as groupings in the key and counters as a grouping of the horizontal axis.
    Not available for counters for switching on and off.
  • Bar chart with counters as groupings in the key and equipment groups as grouping in the horizontal axis.
    Not available for counters for switching on and off.
  • Data table with the following structure:
    • Equipment group (drill-down)
    • Start time of the aggregation interval
    • End time of the aggregation interval
    • One bar per counter

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree_MeaningsAndChildMeanings
  • ListHppStructureNamesWithNominalPowerAndRpm_MS
  • GetChildEquipments
  • GetEquipmentTreeForGroup
  • GetFullEquipmentGroupName
  • HppEventCounters_ActivePowerOnLoadShedding


Load Shedding Turbine Speed Ranges Event Counters (Machine multiple selection)

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Load Shedding Turbine Speed Ranges Event Counters (Machine multiple selection)

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template determine counters for different machine events:

  • Switching on and off
  • Load shedding in configurable turbine speed ranges

All counters are displayed in a bar chart and a table.

Reports based on this template allow the selection of several machines.

Create report

To create a Event Counter for Load Shedding - turbine speed ranges (machines - multiple selection) report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Event Counter for Load Shedding - turbine speed ranges (machines - multiple selection) as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Event counter assignments

Parameters | Description
Event counter assignments | Display and configuration of the assignments for the event counter. The properties that can be displayed and configured depend on the type of report template.
Configure assignments | Clicking on the button opens the dialog for configuring the archives.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Load shedding: Turbine speed lookfront seconds

Parameters

Description

Load shedding: Turbine speed lookfront seconds

Selection of the number of seconds for how far, after load shedding, the maximum turbine speed at the time of load shedding is searched for.

Formula: Load shedding turbine speed = Max(turbine speed) from time period up to (load shedding + configured seconds).

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time single input
  • 1 x relative time single input
  • 2 x absolute time single input and 1 x lot single selection
  • 1 x relative time single input and 1 x lot single selection
  • 2 x absolute time single input and 1 x shift single selection
  • 1 x relative time single input and 1 x shift single selection

Other parameters

  • 1 x multiple selection from the equipment model.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with equipment groups as groupings in the key and counters as a grouping of the horizontal axis.
    Not available for counters for switching on and off.
  • Bar chart with counters as groupings in the key and equipment groups as grouping in the horizontal axis.
    Not available for counters for switching on and off.
  • Data table with the following structure:
    • Equipment group (drill-down)
    • Start time of the aggregation interval
    • End time of the aggregation interval
    • One bar per counter

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • ListEquipmentTree_MeaningsAndChildMeanings
  • ListHppStructureNamesWithNominalPowerAndRpm_MS
  • GetChildEquipments
  • GetEquipmentTreeForGroup
  • GetFullEquipmentGroupName
  • HppEventCounters_OverRevolutionsOnLoadShedding


Machine Start Counters

zenon Analyzer -> Supplied report templates -> Report templates -> Hydroelectric Power Plant Analysis -> Machine Start Counters

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template show starts of machine sets for turbine and pump operation.

The data table contains all counters. The counters can also be shown graphically. In doing so, absolute and relative time counters are compared between machine and operating type.

Create report

To create a Machine Start Counters report:

  1. In the Theme drop-down list, select Hydroelectric Power Plant Analysis
  2. From the drop-down list, select Machine Start Counters as a report template

  3. Click on the OK button.

    The report template is opened.

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Machine start counter assignments

Parameters | Description
Machine start counter assignments | Display and configuration of the assignments for machine start counter.
List of assignments | Display of the configured assignments.
Configure assignments | Clicking on the button opens the dialog for configuring the archives. For details, see the Assignments for machine start counter section.

Data collection iteration configuration

Parameters

Description

Data collection iteration configuration

Configuration for iteration interval and cancel time.

Iteration interval

Configuration of the iteration interval in:

  • Minuten
  • Hours
  • Days

Minimum: 1

Maximum: 1000

Default: 1 day

Start of archiving

Start of archiving

  • Date
  • Time
  • Default: 01.01.2013 00:00:00

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Aggregated bar chart for equipment comparison, aggregated bar chart for counter comparison and table
  • Aggregated bar chart for equipment comparison and table
  • Aggregated bar chart for counter comparison and table
  • Table

Machine labels

Parameters

Description

Machine labels

Selection of machine descriptions from drop-down list:

  • Equipment group name without parent elements
  • Equipment group name including parent elements

Element sort order

Parameters

Description

Element sort order

Selection of the sorting criteria from the drop-down list:

  • Element ID ascending (same order as metadata table)
  • Element ID descending (inverse order as metadata table)
  • Name alphabetically ascending
  • Name alphabetically descending

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x single entry for absolute time
  • 1 x time range selection
  • 2 x single entry for absolute time and 1 x lot selection
  • 1 x time period selection and 1 x lot selection
  • 2 x single entry for absolute time and 1 x shift selection
  • 1 x time period selection and 1 x shift selection

Other parameters

  • 1 x multiple selection from the equipment model.
    Only equipment groups and their superordinate levels that are assigned to at least one of the necessary meanings are shown.
  • 1 x single selection of the aggregation interval. The following values are available:
    • 1 minute
    • 15 minutes
    • 30 minutes
    • 1 hour
    • 2 hours
    • 6 hours
    • 12 hours
    • 1 day
    • 1 week
    • 1 month
    • 1 quarter
    • 1 year

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Bar chart with absolute counters:
    The counters are entered on the horizontal axis; the key entries are the equipment groups.
  • Bar chart with relative counters:
    The counters are entered on the horizontal axis; the key entries are the equipment groups.
  • Bar chart with absolute counters:
    The equipment group counters are entered on the horizontal axis; the key entries are the counters.
  • Bar chart with relative counters:
    The equipment groups are entered on the horizontal axis; the key entries are the counters.
  • Data table with the following columns:

    Equipment group (drill-down, sum line)

    Start time of the aggregation interval

    End time of the aggregation interval

    One value column with value in the aggregation interval per counter:

    • With relative counters: Sum of all individual counter values in the aggregation interval.
    • With absolute counters: Last valid counter value in the aggregation interval.

attention Attention

If several elements in the table have the same name and one of the marking-based sorting variants (alphabetical) was selected, then these fields overlap and their values are combined.

If a sorting variant based on the ID is selected, this effect does not occur. In this case, there are several columns with the same marking in the table.

Several elements with the same name can be present if, for example, the descriptive text is selected as a marking and descriptive texts are identical.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListLots
  • ListShifts
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_ChildMeanings
  • ListHppStructureNames_MS
  • GetFullEquipmentGroupName
  • HppMachineStartsMultipleMachines


Wind Power Plant Analysis

zenon Analyzer -> Supplied report templates -> Report templates -> Wind Power Plant Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports with this theme provide report templates that determine and display various counters for wind power plants.

The following report templates are available:

  • Wind Rose: Displays aggregated indicator values of equipment groups, grouped according to wind direction.

From Target Actual Analysis theme:

  • Scatter Plot: Creates a scatter plot for the comparison of any desired machine-related measured sizes with set values.
  • Scatter Plot with Reference Curve: Creates a scatter plot of a value pair for a time period.

Report template selection

To create a report based on this template:

  1. Select the New entry in the Report menu or click on the corresponding symbol in the toolbar.
  2. The dialog for selecting a template is opened.

  3. In the Theme drop-down list, select Wind Power Plant Analysis.
  4. Select the template you want to use as a report template from the drop-down list.

Other topics in this chapter

Wind Rose


Wind Rose

zenon Analyzer -> Supplied report templates -> Report templates -> Wind Power Plant Analysis -> Wind Rose

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template display aggregated indicator values of equipment groups, grouped according to wind direction.

Create report

To create a Wind Rose report:

  1. In the Theme drop-down list, select Wind Power Plant Analysis
  2. From the drop-down list, select Wind Rose as a report template.

  3. Click on the OK button.

    The report template is opened:

  4. Save the report with the desired name.
  5. Configure the report.

Configuring the report

You can also find details on the control elements in the report window in the Elements in the report area chapter.

File storage

Parameters | Description
File storage | Name and path of the report on the Analyzer server.
Report file name | Name of the report file on the server.
Report file path | Current path of the report file. Display only.
Choose report file path | Opens dialog to select a folder on the Analyzer server or the RDL file. New folders can also be created. For details, see the Path to RDL file section.
All report deployment paths | List of the language-dependent paths defined in the options for distribution of the reports.

Information on the report template

Parameters

Description

Information on the report template

Information on the report template, consisting of:

  • Theme: selected superordinate theme of the report template
  • Report template: selected report template

For further details see chapter Report templates

Theme

Selected theme for report templates.

Display only.

Report template

Selected report template.

Display only.

Time filter (dynamic)

Parameters

Description

Time filter (dynamic)

Setting the parameters for the time filters.

Time filter settings

Display of details on the current configuration of the time filter. The list can contain the following information, depending on the configuration:

  • Type of the time filtering
  • Project from which the lot or shift data comes, if lot selection or shift selection is active. This is also the project to which the report is linked.
  • Lot archive from which the lot data comes, if lot selection is active.
  • Equipment model from which the shift data is to be read is shift selection is active.

If information is only displayed in part due to its length, move the mouse over the corresponding element. The complete information is then displayed in a tooltip.

Time filter configuration

Clicking on the button Time filter configurationopens the dialog to configure the time filter.

For further details see chapter Time filter configuration.

Time filter granularity

Setting for the granularity for the time filter. Select from drop-down list:

  • Minutes
  • hours
  • Days
  • Months
  • Years

Default time range

Display of the requirements for standard values of the report time period.

Default time range configuration

Clicking on the standard time period configuration button opens the dialog for configuration.
For details, see standard time period .

Equipment model selection

Parameters | Description
Equipment model selection | Selection of one or several equipment models from drop-down list.

Equipment model - Tree expand level

Parameters

Description

Equipment model - Tree expand level

Configuration of the display of equipment groups in the Report Launcher.

Expand all nodes

All nodes are displayed in expanded form.

Collapse all nodes

All nodes are displayed as closed. Only the uppermost level is visible.

Expand nodes until nesting level

Nodes are expanded up to the set level. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 25

If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Wind Rose configuration

Parameters | Description
Wind Rose configuration | Display and configuration of the parameters of a wind rose.
Meaning for wind direction | Display of the meaning for the wind speed.
Meaning for indicator variable | Display of the meaning for the indicator.
Indicator visual name | Display of the indicator name.
Wind Rose granularity | Display of the number of wind directions: 4, 8 or 16.
Angular measurement | Display of the selected measurement system for the wind direction: Degree, Radian or Gradient.
Aggregation shown in wind rose chart | Display of the selected aggregation function for display in the diagram: Sum, average, minimum, maximum.
Aggregation shown in table | Display of the selected aggregation functions for display in the table: Sum, average, minimum, maximum. At least one of these must be selected.
Configure wind rose | Opens the dialog for configuring the wind rose.

Connector selection

Parameters

Description

Connector selection

Selection of the connector from the drop-down list.

The drop-down list contains the name of the available connectors:

  • SCADA Runtime Connector (zenonV6)
  • SCADA SQL Connector (zenonSQL)

Archive compression selection

Parameters

Description

Archive compression selection

The following types of archive aggregation are available. Select from drop-down list:

  • Raw data (basic archive)
  • added up data (aggregated archive)
  • average data (aggregated archive)
  • minimum data (aggregated archive)
  • maximum data (aggregated archive)

Decimal places

Parameters

Description

Decimal places

Selection of the decimal places to be displayed. Selection by means of cursor keys or direct input in the field.

  • Minimum: 0
  • Maximum: 10
  • If the maximum is exceeded using the cursor keys, it jumps back to the minimum; if the minimum is gone below, it jumps to the maximum.

Data representation

Parameters

Description

Data representation

Configuration of the data display. Select from drop-down list. Possible settings:

  • Polar chart and table
  • Radar chart and table
  • Polar chart
  • Radar chart
  • Table

Actions

Parameters

Description

Actions

Possible actions for the report:

  • Save report definition: Opens dialog for saving reports. If there is already a report with this name, you are asked to confirm that you wish to overwrite this.
  • Deploy report: Instigates preparation of the report. If existing elements are overwritten in the process, you will be asked to confirm this.
  • Open report in Microsoft Report Builder: Opens the report in Microsoft Report Builder.
  • Open report in Report Launcher: opens the report in the web browser with the Report Launcher.
  • Close report: Closes the report.

Select by clicking on the respective button.

Appearance in the Report Launcher

Time filtering

One of the following report parameter groups is available in the Report Launcher, depending on the parameters set up in ZAMS:

  • 2 x absolute time input (from - to)
    plus 1 x project selection (multiple selection drop-down list)
  • 1 x relative time input (time range)
    plus 1 x project selection (multiple selection drop-down list)
  • 2 x absolute time input (from - to)
    plus 1 x lot selection
  • 1 x relative time input (time range)
    plus 1 x lot selection
  • 2 x absolute time input (from - to)
    plus 1 x shift selection
  • 1 x relative time input (time range)
    plus 1 x shift selection

Other parameters

  • 1 x multiple selection from the equipment model.

Data representation

The display of data after report creation depends on the setting in ZAMS. The following elements are available for the display:

  • Indicator-via-wind-direction-polar-chart: selected aggregation function per equipment group
  • Indicator-via-wind-direction-radar-chart: selected aggregation function per equipment group
  • Table with the following structure:
    • Equipment group:
      Grouping
      Sortable
      Expandable and collapsible
    • Wind direction:
      Sortable
    • Sum of the indicator values:
      Only if activated in the report
      Sortable
    • Average of the indicator values:
      Only if activated in the report
      Sortable
    • Minimum of the indicator values:
      Only if activated in the report
      Sortable
    • Maximum of the indicator values:
      Only if activated in the report
      Sortable

Notes on the coloring of the charts:

  • Chart background: First color of the background of the drawing area of bar charts / line charts, without grading or alternating color.
  • Standard coloring:
    • The polar chart works like the line chart.
    • The radar chart contains 5 standard colors and a limit lime for the network areas from the color scheme.

Note for report developer: SPs and UDFs

Reports that are based on this template use the following SPs and UDFs:

  • ListProjects (if neither lots nor shifts are used for time filtering)
  • ListLots (if lots are used for time filtering)
  • ListShifts ((if shifts are used for time filtering)
  • GetEquipmentTreeForGroup
  • ListEquipmentTree_Meanings
  • WindPower_GetWindRoseData


Metadata, stored procedures and user-defined function blocks

zenon Analyzer -> Supplied report templates -> Metadata, stored procedures and user-defined function blocks

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For the report templates, metadata, table valued user-defined functions, stored procedures and user-defined function blocks are used.

These are described in the section on data structures.


Example zenon

zenon Analyzer -> Example zenon

On the installation medium you can find a zenon example project and reports which are used by this project as data source.

To get to know the zenon Analyzer we recommend that you open the workspace of the example project in zenon and you try out the interaction with the reports.

  • start the Runtime
  • in the start screen you can see a F&B bottle filling line

  • switch to the Line Overview via
    • Online status
    • Graphic analysis
    • Counter

The data from screen Counter are directly processed in the reports.

Example consumption of a medium in time comparison

Topic alarming

  • Entries in Alarm Message List

  • are the basis for a report for displaying interruptions

You can adapt the project and the reports according to your needs and set the reports to your own data sources.


Event-driven report creation

zenon Analyzer -> Event-driven report creation

Event-triggered report creation makes it possible to use an event - such as a change of value, for instance - as a trigger for the creation and sending of a report. These reports can be created:

  • By means of a zenon function (from zenon version 7.20)
  • By means of VSTA programming

Other topics in this chapter

Create an Analyzer report using the zenon function

VSTA programming


Create an Analyzer report using the zenon function

zenon Analyzer -> Event-driven report creation -> Create an Analyzer report using the zenon function

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Requirements

In order for you to be able to create an event-triggered report for the zenon Analyzer via the zenon Analyzer: Create report function, the following requirements must be met:

  • zenon version 7.20 or higher
  • Connection with corresponding rights to an Analyzer server version 2 or higher
  • Analyzer Server Wrapper must be installed. Installation is carried out by means of a selection item in the zenon setup.
  • Runtime and Editor must both be restarted after installation of the Analyzer Server Wrapper, so that they can find the installed Analyzer Server Wrapper DLLs.
  • Recommendation: In order to be sure that the Windows authentication works, the Analyzer server should be in the same domain as zenon Editor and zenon Runtime.

Problem solution

  • Communication problems with the Analyzer server: Check the communication in the network as well as the authentication (user and access rights).
  • Reports are rendered but do not contain any data: Check the license of the Analyzer server:

Creating a function

To create the function:

  1. Create a new function.
  2. Navigate to the Report Generator / Report Viewer / Analyzer group in the selection dialog.

  3. Select the Analyzer: Create Report function.
  4. The dialog for configuration is opened:
  5. Configure, in the General settings tab, the connection parameters and select the desired report.

    Attention: Before a switch is made to the second tab, a connection must be made and a report must be selected!

  6. Configure the report parameters in the Parameter list tab.
    When switching to the second tab, an attempt is made to set values that already exist for the parameter input. If this is not successful, the list of set parameter values is displayed as empty.

    Default values can be replaced by individual values. To do this, deactivate the checkbox in front of the value and click on the value. A dialog to enter the new value is opened

  7. Connect the function with a button or an event in order to be able to access it in Runtime

Procedure in Runtime

Procedure when triggering the function to create a report in Runtime:

  1. The configured connection is established.
  2. The selected report is set.
  3. The selected parameter values are set for this report.
  4. The report is created and output in the desired form.
  5. The file name is generated and the file is saved in the export folder of the project.
  6. The complete file name is written to the selected variable.


General settings

zenon Analyzer -> Event-driven report creation -> Create an Analyzer report using the zenon function -> General settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, the connection to the Analyzer server is configured and selected in the report. This tab must be configured before the switch to parameter list.

General settings tab

Analyzer Server

Parameters

Description

Analyzer Server

Configuration of the connection to the Analyzer server.

Version

Select the version of the Analyzer server from the drop-down list. Only available if there is no connection.

Computer name

Entry of the name of the computer on which the Analyzer server runs. Only available if there is no connection.

Use Windows authentication

Selection of the type of authentication:

  • Active: Windows authentication is used.
  • Inactive: The user must enter the user name and password.

User name

Entry of the user name.

Only available if Use Windows authentication is inactive and there is no connection.

Password

Entry of the password for authentication.

The characters entered are not shown and the length of the password is hidden. The password is saved in encrypted form and is only decrypted to establish a connection.

Only available if Use Windows authentication is inactive and there is no connection.

Secure connection

Active: The connection is established as secure.

Only available for zenon Analyzer from version 3.00.

Extended

Advanced settings for the connection waiting time. This can be a maximum of 1 day.

Clicking on the button opens the dialog for configuration.

Only available for zenon Analyzer from version 3.00.

Establish connection

Clicking on the button establishes a connection to the analyzer server.

Once the connection has been successfully established, the drop-down lists for report and format are updated.

Close connection

Clicking on the button disconnects the existing connection.

Report creation

Parameters

Description

Report creation

Configuration of the basis data for the report.

Report

Selection of the report from a drop-down list.

Format

Selection of the output format from a drop-down list:

  • CSV
  • Excel
  • MHTML (Web Archive)
  • PDF
  • TIFF file
  • Word
  • XML file with report data

Include time stamp in file name
  • Active: The execution time stamp is included in the file name.

Sequence of file name creation:

  • The report name without a path is the starting point.
    Example: Alarms
  • The time stamp is then added if activated. Example on 15/8/2014 at 15:20:00: Alarms_2014_08_15_15_20_00
  • The file name extension is then added according to the selected output format.
    Example: Alarms_2014_08_15_15_20_00.pdf
  • If there is already a file with this name in the export folder of the project, a counter is added until the file name is unique.
    Example:
    Alarms_2014_08_15_15_20_00.pdf
    Alarms_2014_08_15_15_20_00 (2).pdf
    Alarms_2014_08_15_15_20_00 (3).pdf

Variable for path to file created

Shows the currently-selected zenon variable that contains the path to the written report file.

Click on button ... in order to open the dialog for selecting a variable.

Hint: Thus when a lot archive is closed or if a limit value is breached, a script can send an event-triggered report by E‑mail from zenon. In doing so, this variable is used to define the attachment of the Message Control function Send a Message.
Procedure:

  • Firstly, the report function that writes the variable is executed.
  • Then the Send a Message function is executed, which reads the attachment path from the variables.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.
Help | Opens online help.

Other topics in this chapter

Advanced settings for secure connection


Advanced settings for secure connection

zenon Analyzer -> Event-driven report creation -> Create an Analyzer report using the zenon function -> General settings -> Advanced settings for secure connection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the connection waiting time. The dialog is opened by clicking on the Advanced button in the General Settings tab.

Parameters

Description

Connection timeout

Waiting time for establishing a connection in seconds. The establishment of the connection is canceled if this is exceeded.

  • Minimum: 1
  • Maximum: 86400 (1 day)

Default: 100

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Parameter List

zenon Analyzer -> Event-driven report creation -> Create an Analyzer report using the zenon function -> Parameter List

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You configure the report parameters in this tab. The controls that are offered depend on the selection of the report in the General settings tab.

Parameter list tab

Parameters

Description

Parameter List

Display of the report parameters. The sequence corresponds to the sequence in the report.

Recommendation: Configure the parameters from top to bottom.

Parameter Name

Display of the parameter name.
Cannot be configured here.

Standard

Defines whether the parameter is set to its default value.

  • Active: The default value from the report is used.
  • Inactive: The value is selected individually by clicking in the Value column.

Clicking with the mouse or pressing the empty button with the parameter highlighted switches the checkbox. If a parameter has a default value, the checkbox is grayed out and inactive.

Value

Display of the current value of the parameter.

  • If the Standard checkbox is activated, the text default value is displayed here and the cell does not allow any input.
  • If the Standard checkbox is deactivated, the currently-configured value is shown here.
    Clicking on the cell or pressing the Enter key with the parameter highlighted opens the input dialog for the respective value.

If a parameter cannot be entered, the text not available is displayed and the cell is deactivated. This can mean, for example, that values for a different parameter must be set first in order to fill the list of values.

Close dialog

Parameters | Description
OK | Applies all changes in all tabs and closes the dialog.
Cancel | Discards all changes in all tabs and closes the dialog.
Help | Opens online help.

Tip for lot/shift reports

In Runtime, the value of a zenon string variable is read. A search for this string as a label is carried out in the list of predefined values for the parameter. The value of the label to be corresponded to is then the parameter value, i.e. the selected shift or lot.

The lot variables of a lot archive can be used here. For the lot report, carry out the Analyzer: Create report function when closing the lot archive. The report then has the last lot of this archive as a time filter.


Configuration of the values

zenon Analyzer -> Event-driven report creation -> Create an Analyzer report using the zenon function -> Parameter List -> Configuration of the values

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For the configuration of the parameter values, there are appropriate dialogs available for each input. The configuration is carried out depending on the input possibility for:

  • A value without a predefined value: Entry of the value.
  • Several values without predefined values: Entry of the values and adding to a list.
  • A value with predefined value: Selection from drop-down list or list.
  • Several values with pre-defined values: Select from list.

The dialogs that are offered depend on the report selection:

Examples of frequently-used dialogs:

Equipment Groups

Selection of desired equipment groups:

  1. Select the desired equipment groups in the top list.
  2. Click on Add.
    The selected groups are added to the lower list.
  3. If you want to remove equipment groups again, highlight these in the lower list and click on Remove.
  4. To transfer all selected equipment groups to the report, click on OK.

Archives

  1. Select the desired archive in the upper list.
  2. Click on Add.
    the selected archives are added to the lower list.
  3. If you want to remove archives again, highlight these in the lower list and click on Remove.
  4. To transfer all selected archives groups to the report, click on OK.

Compression

  1. Select the desired compression from the drop-down list
  2. Click on OK.

  1. Select the desired compression function from the drop-down list.
  2. Click on OK.

Maximum value

  1. Enter the desired value into the field.
  2. Click on OK.

Minimum value

  1. Enter the desired value into the field.
  2. Click on OK.

Projects

  1. Select the desired project in the upper list.
  2. Click on Add.
    the selected projects are added to the lower list.
  3. If you want to remove projects again, highlight these in the lower list and click on Remove.
  4. To transfer all selected projects to the report, click on OK.

Variables

Selection of the desired variables.

  1. Select the desired variables in the upper list.
  2. Click on Add.
    The selected variables are added to the lower list.
  3. If you want to remove variables, highlight these in the lower list and click on Remove.
  4. To transfer all selected variables to the report, click on OK.

Time span

  1. Select the desired date and the time for
    1. From
    2. To
  2. Click on OK.


VSTA programming

zenon Analyzer -> Event-driven report creation -> VSTA programming

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For programming with VSTA, you need, in addition to zenon Analyzer, a data source that can be addressed via VSTA, and knowledge of VSTA. In this manual, the HMI/SCADA system zenon from version 7.0 is used as a data source.

  • Event Driven Report Generation (EDRG): Event-driven creation and saving of a report. Consists of VSTA macros.
  • Event Driven Report Subscription (EDRS): Automatic sending of a report generated via EDRG as an email attachment via zenon SMTP Mail

To use event-driven report creation, you need:

  • the zenon Analyzer
  • A data source that can be addressed via VSTA such as zenon from COPA-DATA
  • For sending by email, a solution that can be addressed via VSTA such as Message Control in zenon from Version 7.0

Other topics in this chapter

Basics

Referencing of the web services

Examples


Basics

zenon Analyzer -> Event-driven report creation -> VSTA programming -> Basics

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To implement EDRG or EDRS, you must:

  1. Start the VSTA development environment for C#
  2. Reference the necessary web services of the Analyzer server
  3. Create the desired VSTA macro functions
    Recommendation: The macro functions should create their own thread for the macro logic. Otherwise the main thread of zenon Runtime is blocked for the duration of the macro that is dependent on the duration of the report creation.
  4. Implementing the macro logic

For the macro logic:

  1. Read in parameters from Runtime or have the user enter these.
  2. If necessary, validate the parameters against predefined values of the report parameter.
  3. Ensure that the rendering extension is present
  4. Have the report with the desired parameters of the selected rendering extension created
  5. Optional: Save the report on the hard drive (in the folder for historical reports, for example)
  6. Optional: If EDRS is desired, save the report in the attachment path for the SMTP message sending function and instigate execution of the SMTP message sending function.

Certain parts of this process can be swapped over, as long as they are not necessary preconditions of one another.

  • Main process: Steps 2 and 3 can change places, but must be between steps 1 and 4.
  • Macro logic: Step 3 can be before step 1 or 2. Steps 5 and 6 can change places, as long as they are not after step 4.

attention Attention

One of the two optional steps 5 or 6 must be implemented in the macro logic. If both steps are left out, the macro is useless, because the report is neither saved nor sent.

This procedure is used in all examples.


Referencing of the web services

zenon Analyzer -> Event-driven report creation -> VSTA programming -> Referencing of the web services

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

There are two web services that can be referenced:

  • ReportExecution2005 is required to create reports
  • ReportService2010 is required for the validation of the selected values for the report parameters as compared to the given values

The following details only relate to the ReportExecution2005 web service. There are two methods available for creating a reference suitable for VSTA on a web service:

  • Creation of the reference with VSTA Editor GUI: pre-defined namespace of the web service reference; creates several code files
  • Creation of the reference via the command line with wsdl.exe: Part of the Windows SDK; grants the user with full control over the name space in which the web service reference is located; creates one code file only

After the reference has been created, a communication object can be created, the parameters of which must be configured via the URL of the web service on the Analyzer server.

info Information

The complete documentation of the web services of the Microsoft SQL Server Reporting Service can be found at: http://msdn.microsoft.com/en-us/library/ms152787.aspx

Other topics in this chapter

Creation of the reference with VSTA Editor GUI

Creation of the reference via the command line with wsdl.exe:


Creation of the reference with VSTA Editor GUI

zenon Analyzer -> Event-driven report creation -> VSTA programming -> Referencing of the web services -> Creation of the reference with VSTA Editor GUI

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The following steps are necessary to create a web service reference with the VSTA Editor GUI:

  1. Open the dialog to add a reference. To do this, right click on References in the Project Explorer and select Add Service Reference… in the context menu.

  2. In the dialog that opens, click on Advanced… in the bottom left corner.

  3. In the dialog that opens, click on Add Web Reference… in the bottom left corner.

  4. In the dialog that opens, enter:
    1. The URL for the web service
      The URL follows this pattern: http://[name of the Analyzer server]/reportserver_za2/ReportExecution2005.asmx?wsdl.
      In doing so, the [name of the Analyzer server] must be replaced by the computer name or the IP address of the Analyzer server.
      The URL input field is in the upper part of the dialog. After the URL has been entered, clicking on the Go button of the web service, which can be reached via this URL, an analysis is carried out and its components are displayed in the list field under the URL input field.
    2. The name for the reference.
      In the following screenshot, ReportServer was chosen as a name.
      Clicking on the Add Reference button creates the reference and closes all dialogs opened in this process.

  5. The VSTA Editor now displays the reference to the web service that has just been created:

  6. The communication main class in the reference created is called ReportExecutionService.
    The reference is always in the namespace [project name].[reference name]. For the reference created here, the main class can be addressed via ProjectAddin.ReportServer.ReportExecutionService.


Creation of the reference via the command line with wsdl.exe:

zenon Analyzer -> Event-driven report creation -> VSTA programming -> Referencing of the web services -> Creation of the reference via the command line with wsdl.exe:

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The command line tool wsdl.exe is an alternative to the VSTA Editor GUI. In contrast to the VSTA Editor GUI, this tool grants full control to the user in terms of the namespace that the web service reference is in. It creates a precise code file with all necessary information for the reference whilst the VSTA Editor GUI creates several files (data source, map, WSDL and code).

This tool is primarily suitable if the reference:

  • is to be stored in a certain namespace
    or
  • is to be encapsulated in a file

Both can help make it easier to reuse the reference created in other projects.

To create a reference with wsdl.exe:

  1. Open the Windows command line (cmd.exe).
  2. Execute the following command:
    "C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin\wsdl.exe" http://[Name des Analyzer Servers]/reportserver_za2/ReportExecution2005.asmx?wsdl /namespace:[gewünschter Namespace] /out:"[Pfad zur Zieldatei]"
    The individual placeholders must be replaced as follows:
    • [name of the Analyzer server]: Enter computer name or the IP address of the Analyzer server
    • [desired namespace]: Name space where the reference is to be stored
    • [path to target file]: File path where the reference file is to be stored

    The following screenshot shows such a command; here, the namespace "COPA_DATA.zenon.Analyzer" and the save path "C:\WebReference.cs" was chosen:

  3. Add the file created in this manner in the VSTA Editor GUI. To do this:
    1. Open the context menu by right clicking on the project Project Explorer
    2. Select Add
    3. Select Existing Item…

  4. In the dialog that is now open, go to the saved file that was previously configured with the command line. The following screenshot displays this for the example file C:\WebReference.cs.

  5. Because the web service reference needs certain components of the .NET framework that are not integrated into the project as standard, you must now add these. To do this:
    1. Open the dialog to add a reference by right clicking on References in the Project Explorer
    2. Select Add Reference…
    3. The following dialog is opened

    4. Select the .NET component System.Web.Services
    5. Close the dialog by clicking on the OK button
  6. The communication main class in the reference created is called ReportExecutionService and is in the selected namespace. For the reference created here, the main class can be addressed via COPA_DATA.zenon.Analyzer.ReportExecutionService.


Examples

zenon Analyzer -> Event-driven report creation -> VSTA programming -> Examples

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Two examples show the creation of event-controlled reports:

  • Example 1: Saving and sending a report without predefined values: A report, the parameters of which do not contain any predefined values, is saved in a folder for historical reports by EDRG and sent by EDRS via Message Control.
  • Example 2: Saving a report with predefined values: A report, the parameters of which contain predefined values, is saved in a folder for historical reports by EDRG.

You can find the codes used in the examples on the zenon Analyzer installation medium in the Samples folder.

This contains the following files:

  • ComboBoxSelection.cs, ComboBoxSelection.Designer.cs and ComboBoxSelection.resx:
    Dialog to select a value from predefined values.
  • ManagerReference.cs:
    Reference to ReportService2010 web service.
  • WebReference.cs:
    Reference to ReportExecution2005 web service.
  • ThisProject.cs:
    Example macro with EDRG, EDRS and a report that has only parameters without predefined values, the values of which come from Runtime variables.
  • ThisProject (2).cs:
    Example macro with EDRG and a report that has parameters with predefined values, the values of which can be obtained via Runtime variable with validation and via user selection.

attention Attention

Note the correct identification of the SQL instance:

  • for zenon Analyzer 2.0 : za2
  • for versions before 2.0: zrs

Other topics in this chapter

Example 1: Saving and sending a report without predefined values:

Example 2: Saving a report with predefined values:


Example 1: Saving and sending a report without predefined values:

zenon Analyzer -> Event-driven report creation -> VSTA programming -> Examples -> Example 1: Saving and sending a report without predefined values:

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A report, the parameters of which do not contain any predefined values, is saved in a folder for historical reports by EDRG and sent by EDRS via Message Control.

The following data from the folder on the installation medium is used:

  • WebReference.cs
  • ThisProject.cs

Aim

In this example, a VSTA macro named Macro_CreateReport_Simple is to be created. This:

  • reads the parameters from Runtime
  • Creates the TestReportForAutomation report with the parameters read in PDF format
  • Saves the report as C:\[report name]_[year]_[month]_[day]_[hour]_[minute]_[second].pdf
  • Sends the report with the SendReportSmtp function

Error and success messages are displayed using a message window.

Requirements

  • The Runtime server runs on the same computer as zenon Analyzer.
  • On the Analyzer server, there is a report with the name TestReportForAutomation in the root folder with the following parameters:
    • Parameter From: a date and time parameter without predefined values
    • Parameter To: a date and time parameter without predefined values
    • Parameter VariableName: a text parameter without predefined values
    • Parameter Interval: a whole number parameter without predefined values
  • There are the following variables in the zenon project:
    • Variable VarName: A STRING data type variable that can be assigned to the VariableName report parameter.
    • Variable StartDate: A DATE_AND_TIME data type variable that can be assigned to the From report parameter.
    • Variable EndDate: A DATE_AND_TIME data type variable that can be assigned to the To report parameter.
    • Variable WIZ_VAR_10: A UINT data type variable that can be assigned to the Interval report parameter.
  • In the zenon project, there is an E-mail via SMTP type Send message function for the Message Control module with the name SendReportSmtp. This reads an attachment from C:\MessageControl\SmtpMailAttachment.pdf and sends this to a defined group of recipients via E-mail via SMTP. You can read more about the sending of messages via Message Control in zenon in the zenon "Message Control" documentation.

Implementation

In the VSTA Editor, the reference file WebReference.cs must be included as described.

The ThisProject.cs file contains the solution for the example.

Explanation of the solution:

  • The method Macro_CreateReport_Simple (code lines18 to 23) is the macro function that is visible in the editor and can be started from Runtime.
  • In order for the main thread of Runtime to be able to run again as quickly as possible, this method starts its own thread with the macro logic that is encapsulated in the method CreateReport_Simple (code lines 25 to 164).
  • Here there is a breakdown of what happens in the Create Report_Simple method. Each of the try-catch blocks in the code serves to catch errors. Each error is issued in a message window and leads to the process being aborted. (This includes not just errors that are caught in a try-catch block, it also includes those that are recognized by validation queries.)

Details:

  • Code lines 27 to 30:
    Here, the communication object is created, the URL for the ReportExecution2005-Webservice is set on the server Analyzer server and the use of the log-in data of the user who is currently logged in is set.
  • Code lines 32 to 62:
    Here, the parameter values of the zenon Runtime variables are obtained and it is ensured that no variable has an empty value.
  • Code lines 64 to 78:
    Here, the date and time variables in zenon format are converted to the format expected by the web service.
  • Code lines 80 to 102:
    Here, a check is made to see if the rendering extension for the PDF format is available.
  • Code lines 104 to 163:
    Here, the report is created, saved on the hard drive and sent via Message Control. The individual stages now follow.
    • Code lines 107 to 112:
      Here, the transfer parameters for the creation method are initialized.
    • Code lines 114 to 127:
      Here, the parameters for the report are compiled.
    • Code lines 129 to 138:
      Here, the creation of the report is prepared. A session with the web service is started, the report is loaded into the session and the report parameters are set.
    • Code lines 140 to 141:
      The report is created here. This methods blocks until creation has been completed, which is why a separate thread for the macrologics is necessary.
    • Code lines 143 to 148:
      Here, the report is saved with the required file name and path.
    • Code lines 150 to 154:
      Here, the report is saved in the attachment path of the Message Control message sending function and the function is started.
    • Code lines 156 to 157:
      This point in the code is only reached if everything was successful. A success message is therefore given.

This macro can now be linked with the desired event - for example by clicking on a button, with a limit value violation that occurs or the closure of an archive.


Example 2: Saving a report with predefined values:

zenon Analyzer -> Event-driven report creation -> VSTA programming -> Examples -> Example 2: Saving a report with predefined values:

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A report, the parameters of which contain predefined values, is saved in a folder for historical reports by EDRG. The parameters with predefined values are set in two ways:

  1. A value is read from a Runtime variable and a check is made to see if this value is in the list of predefined values.
  2. A selection dialog is used for the selection of a predefined value by the user.

The following data from the folder on the installation medium is used:

  • WebReference.cs
  • ManagerReference.cs
  • ThisProject (2).cs
  • ComboBoxSelection.cs, ComboBoxSelection.Designer.cs and ComboBoxSelection.resx

Aim

In this example, a VSTA macro named Macro_CreateReport_Complex is to be created. This:

  • reads the parameters from Runtime
  • Creates, with the parameters read and the value selected by the user for the Lot parameter, the report TestReportForAutomation_Complex in PDF format
  • Saves the report as C:\[report name]_[year]_[month]_[day]_[hour]_[minute]_[second].pdf

Requirements

  • The server Runtime runs on the same computer as the Analyzer.
  • On the Analyzer server, there is a report with the name "TestReportForAutomation_Complex" in the root folder with the following parameters:
    • Parameter From: a date and time parameter without predefined values
    • Parameter To: a date and time parameter without predefined values
    • Parameter VariableName: a text parameter without predefined values
    • Parameter Interval: a whole number parameter without predefined values
    • Lot parameter: A text parameter that is shown as a lot selection and obtains its predefined values from a data set that depends on the parameters From and To
    • Lot_Type parameter: A hidden text parameter that contains the standard value 2 and serves for configuration of the Lot parameter for the use of the lot selection control on the front-end Report Launcher
  • There are the following variables in the zenon project:
    • Variable VarName: A STRING data type variable that can be assigned to the VariableName report parameter. Validation must take place here.
    • Variable StartDate: A DATE_AND_TIME data type variable that can be assigned to the From report parameter.
    • Variable EndDate: A DATE_AND_TIME data type variable that can be assigned to the To report parameter.
    • Variable WIZ_VAR_10: A UINT data type variable that can be assigned to the Interval report parameter.

Implementation

In the VSTA Editor, the reference files WebReference.cs and ManagerReference.cs must be included as described. The files ComboBoxSelection.cs, ComboBoxSelection.Designer.cs and ComboBoxSelection.resx must also be added to the project so that the dialog for the user to select a value is available.

The dialog class ComboBoxSelection displays a drop-down list, in which the user can select a precise value from the list. The list is filled using the FillComboBox method and the selection is read by GetSelectedItem.

The file named ThisProject (2).cs contains the solution for the example.

Explanation of the solution

  • The method Macro_CreateReport_Complex (code lines18 to 23) is the macro function that is visible in the editor and can be started from Runtime.
  • In order for the main thread of Runtime to be able to run again as quickly as possible, this method starts its own thread with the macro logic that is encapsulated in the methods CreateReport_Complex (code lines 25 to 326).
  • Here, there is a breakdown of what happens in the Create Report_Complex method. Each of the try-catch blocks in the code serves to catch errors. Each error is issued in a message window and leads to the process being aborted. (This includes not just errors that are caught in a try-catch block, it also includes those that are recognized by validation queries.)

Details:

  • Code lines 27 to 33:
    Here, communication objects for both web services are created. The parameters for the communication objects are set with the attendant URLs and the user rights of the user at the time.
  • Code lines 35 to 65:
    The values of the Runtime variables are read here. A check is made to see if each Runtime variable contains a value.
  • Code lines 67 to 81:
    Here, the date and time values in zenon format are converted to the format expected by the web service.
  • Code lines 83 to 105:
    Here, a check is made to ensure that the rendering extension for PDF is available.
  • Code lines 107 to 267:
    Here, the parameters are set with predefined values. Because this setting consists of several steps, these are explained in the following points.
    • Code lines 107 to 110:
      Here, the C# variables for the report path on the server and the parameters with predefined values are initialized.
    • Code lines 113 to 123:
      The parameters that are already known are packed into a collection here.
    • Code lines 125 to 256:
      In this line, which has a maximum repetition count of 5, the predefined values are obtained and the inputs are evaluated.
    • Code lines 130 to 133:
      Here, the predefined values are read via the web service.
    • Code lines 135 to 255:
      Each report goes through this loop.
    • Code lines 138 to 187:
      The VariableName report parameter is handled here.
    • Code lines 140 to 144:
      If the parameter has already been successfully handled, it is not handled again.
    • Code lines 146 to 151:
      If the list for the predefined parameters is still empty, the loop in code lines 125 to 256 is gone through again.
    • Code lines 153 to 172:
      A check is carried out to see if the set value is in the list of available values. In doing so, first the labels and then the values are used for validation.
    • Code lines 174 to 179:
      If the value of the zenon Runtime variables is not in the list of available values, this is an error.
    • Code lines 181 to 186:
      The value found is inserted for the next run in the collection.
    • Code lines 188 to 254:
      The Lot parameter is handled here.
    • Code lines 190 to 194:
      If the parameter has already been successfully handled, it is not handled again.
    • Code lines 196 to 201:
      If the list for the predefined parameters is still empty, the loop in code lines 125 to 256 is gone through again.
    • Code lines 203 to 208:
      If the list of predefined values is present and report that it is empty, this is an error.
    • Code lines 210 to 239:
      Here, the ComboBoxSelection selection dialog is created and populated, whereby empty labels or empty values in a predefined value lead to this being skipped and duplicates are not displayed.
    • Code lines 241 to 242:
      the selection dialog is displayed.
    • Code lines 244 to 253:
      The selection in the dialog is evaluated. In doing so, the selection is written to the C# variable and in the collection for further runs.
    • Code lines 257 to 261:
      If we land here, the user has either not selected anything or the maximum repetition count for the loop was exceeded. Both events are errors.
  • Code lines 269 to 324:
    The report is created and saved here. Because this consists of several shifts, the individual steps are explained below.
    • Code lines 272 to 276:
      Here, the transfer parameters for the creation method are initialized.
    • Code lines 278 to 294:
      Here, the report parameters for the creation are compiled.
    • Code lines 296 to 305:
      Here, the creation of the report is prepared, in that a session with the web service is started, the report is loaded into the session and the parameters are set.
    • Code lines 307 to 308:
      The report is created here. This method blocks until the creation has been concluded. This is the reason why the macro logic runs in its own thread.
    • Code lines 310 to 315:
      Here, the created report is saved in the desired save location.
    • Code lines 317 to 318:
      If we land here, everything has worked. A success message is therefore given.

This macro can now be linked with the desired event - for example by clicking on a button, with a limit value violation that occurs or the closure of an archive.


Report Launcher

zenon Analyzer -> Report Launcher

Reports display data from online sources or archives according to defined rules. The zenon Analyzer is shipped with prepared report templates which can be adapted individually. You can also create your own reports. The necessary table structure is described in chapter Basics.

To call up and display reports on the client computer, all you need is a supported browser. All reports are displayed and adapted in the browser. Which settings are possible, depends on the rights of the user. Reports can be exported in other formats. Thus being used in other applications.

As supplied, pre-configured folders with reports on the respective topic areas are displayed for the demo project when zenon Analyzer is started.

info Information

Only reports that are included in the scope of the zenon Analyzer license that has been purchased are displayed.

Configuration of reports

Reports can be configured in the browser.

The settings are made in ZAMS - zenon Analyzer Management Studio.

info Information

Handling with time interval for archive aggregation and display in the report:

  • Interval less or equal to 60 minutes:
    The correct time interval in UTC is noted for aggregation.
  • Interval greater than 60 minutes:
    The correct time interval in the server's local time is noted for aggregation.
  • Local time is always used for the display. If the user and server are in different time zones, there may be differences.

Projects and filters

Reports on several projects can be created, except when using filters for shifts or lots. In this case, reports are limited to one project.

attention Attention

Only archive data with variables from its own project can be evaluated.

This means: For example, in an integration project, if a variable from a subproject is archived in an archive, then zenon Analyzer cannot access this variable.

Other topics in this chapter

Rights management

Report Launcher: Configuration and operation

Create report

Call up report

Toolbar Report

Configure and export reports

Manage reports

Validation of formulas

Error logging


Rights management

zenon Analyzer -> Report Launcher -> Rights management

The zenon Analyzer uses role-based rights management. It controls the access to the data sources, folders, reports and all other elements. At this certain rights are assigned to a user or a group. Users and groups must already exist in the Window user administration. Authentication is not done by the zenon Analyzer but by the operating system.

User rights are set and administered in the ZAMS.


Report Launcher: Configuration and operation

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The zenon Analyzer is called up via the web browser or started via the ZAMS:

  • Calling it up via the user interface:
    Entry of connection in address line or click on the link in the start menu of the installation computer (COPA-DATA section)
  • Start via ZAMS:
    The following actions start the web browser with the Report Launcher for the connection set up in ZAMS:
    • Selection of the corresponding command from the Report menu
    • Click on the corresponding symbol in the toolbar
    • Click on the Open report in the Report Launcher button in a report in the ZAMS

info Information

Internet Explorer 10 or higher, Firefox or Google Chrome can be used as a browser.

When starting the Report Launcher or opening reports in the Report Launcher, Internet Explorer is addressed by ZAMS directly as ActiveX.

Report Launcher

The user interface of the Report Launcher gives you the possibility to:

  • configure the Report Launcher
  • To configure and call up reports

The Report Launcher can be called up in two views:

  • Tile view
  • Detail view

Error Handling

attention Attention

Error messages for parameters:

For some parameters, the values available must be loaded via a Stored Procedure of Microsoft SQL Server. If this Stored Procedure is not successfully called up or the Stored Procedure returns an error, an error message is activated in the Report Launcher. For example, if Runtime cannot be reached, the SQL connector has not been created, etc.

For some parameters, no standard value can be issued under some circumstances, because a parameter that is to be handled beforehand does not contain a value.
For example: Time filters are based on shifts, but there is no shift data available. in this case, the issue of standard values is only possible if at least 1 shift has been written.

Browser

zenon Analyzer is called up using a browser.

info Information

zenon Analyzer was designed and tested for the following browsers:

  • Microsoft Internet Explorer from version 10
  • Chrome
  • Firefox

Note:

  • Compatibility view must be deactivated for Internet Explorer.
  • Zoom is only available for the Chrome browser.

Other topics in this chapter

Tile view

Detail view

Settings

Folder, reports and database context menus

Move elements

Download report

Languages and time formats

Parameters - input and selection

Site Settings

Data source

Folder

Upload file


Tile view

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Tile view

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration menu

Parameters

Description

Configuration menu

Home

Switches to the highest level.

Site Settings

Opens the administration of general settings of the site.

Help

Opens the online-help for the Report Launcher.

Search field

Search in the Report Launcher.

Entry of the search term in the search field. Click on the magnifying glass symbol to start the search.

Note: Clicking on the symbol does not trigger any action in Firefox or Chrome. Instead, press the Enter key.

Main menu

Parameters

Description

Main menu

New folder

Creates a new folder.

New Data Source

Creates a new data source.

Download Report Builder

Opens the Microsoft website to download the Report Builder.

Report Builder

Opens the Microsoft Report-Builder.
Requirement: The Microsoft Report-Builder must already be present on the system.
Any supported browser can be used to open it.

Upload file

Opens the dialog for uploading resources such as reports, models, data sets, etc.

Details view - Tile view

Switches from detail view to symbol view.

Tile view: Shows all folder and reports in a compact view. In this view folders can be hidden.

Detail View: Shows details on reports and folders and allows them to be sorted by clicking on the respective header:

  • Object type (2nd column)
  • Name
  • Description
  • Last run
  • Modified Date
  • Modified By

Both views provide a context menu with frequently-required commands for folders, reports and databases.

List field Reports

Parameters | Description
List field Reports | Shows all databases, folders and reports. The display can be in a symbol view or detail view. The possible actions depend on the type of the display. Reports for configuration and display are selected here.


Detail view

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Detail view

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration menu

Parameters

Description

Configuration menu

Home

Switches to the highest level.

Site Settings

Opens the administration of general settings of the site.

Help

Opens the online-help for the Report Launcher.

Search field

Search in the Report Launcher.

Entry of the search term in the search field. Click on the magnifying glass symbol to start the search.

Note: Clicking on the symbol does not trigger any action in Firefox or Chrome. Instead, press the Enter key.

Main menu

Parameters

Description

Main menu

Expand all

Clicking on the button opens all elements in the tree view.

Collapse all

Clicking on the button collapses all elements in the tree view. Only the highest level is displayed.

Delete

Deletes selected reports or folders. The selection takes place by activating the check box in front of the report/folder.

Move

Moves selected reports or folders. The selection takes place by activating the check box in front of the report/folder.

Download Report Builder

Opens the Microsoft website to download the Report Builder.

Report Builder

Opens the Microsoft Report-Builder.
Requirement: The Microsoft Report-Builder must already be present on the system.
Any supported browser can be used to open it.

Tile view

Switches from detail view to symbol view.

Tile view: Shows all folder and reports in a compact view. In this view folders can be hidden.

Detail View: Shows details on reports and folders and allows them to be sorted by clicking on the respective header:

  • Object type (2nd column)
  • Name
  • Description
  • Last run
  • Modified Date
  • Modified By

Both views provide a context menu with frequently-required commands for folders, reports and databases.

List field Reports

Parameters | Description
List field Reports | Shows all databases, folders and reports. The display can be in a symbol view or detail view. The possible actions depend on the type of the display. Reports for configuration and display are selected here.


Settings

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Data sources and reports are managed and configured via menu bars and context menus.

See also:

  • Configuration and operation
  • Site
  • Folder
  • Reports


Folder, reports and database context menus

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Folder, reports and database context menus

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Databases, folders and reports have a context menu for configuration. Its contents sometimes also depend on which view is displayed in the Report Launcher.
To select a command from the context menu:

  1. Move the mouse over the desired object.

    A red border and red arrow are displayed.

  2. Click on the arrow.

    The context menu is displayed.

  3. select the desired command.

Context menu folder

The context menu of folders contains different commands, regardless of the Report Launcher view.

Tile view

Parameters | Description
Move | Opens dialog for selecting the new saving location.
Delete | Deletes selected folder.
Manage | Opens the dialog for managing the folder.

Detail view

Parameters | Description
Move | Opens dialog for selecting the new saving location.
Delete | Deletes selected folder.
Manage | Opens the dialog for managing the folder.
New folder | Opens dialog to create a new folder.
New Data Source | Opens the dialog to select a new data source.
Upload File | Opens the dialog for uploading a new file.

Report context menu

The context menu of reports contains commands for their administration. The context menu is identical for both views of the Report Launcher.

Parameters | Description
Move | Opens menu for selecting the new saving location.
Delete | Deletes selected reports.
Create linked report... | Opens the dialog for creating a linked report which is based on the selected report.
Display report history | Opens the display of the report history.
Manage | Opens the dialog for managing the report.
Download | Makes it possible to locally save reports. Opens Windows dialog for saving a file.
Editing in the Report Builder | Opens the report in the MS Report Builder.

Database context menu

The context menu of databases contains commands for their administration. The context menu is identical for both views of the Report Launcher.

Parameters | Description
Move | Opens menu for selecting the new saving location.
Delete | Deletes selected reports.
Generate Report Model | Opens the dialog to generate a new model for the data source.
View Dependent Items | Displays all reports based in this data source and makes it possible to delete or move them.
Manage | Opens the dialog to administer the database.


Move elements

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Move elements

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To change the save location of an object:

  1. Highlight the object (folder, report, database).
  2. Click on the arrow.
  3. in the context menu, select the Move command.

    The dialog for selecting a new save location is opened.

  4. Enter, in the Save location input field, the desired location or select it from the list of the folders.
  5. Confirm the selection by clicking OK.

Move dialog elements

Parameters | Description
Storage directory | State the desired save location. Entry in the field or selection from the Folder selection tree.
Folder selection | Selection of a folder as a save location. Clicking on the folder accepts the selection in the Save location field.
OK | Applies settings and closes the dialog.
Cancel | Discards all changes and closes the dialog.


Download report

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Download report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports can be downloaded from the Server to the local computer in order to edit or present them offline.

To download a report:

  1. Move the mouse over the report.
  2. Click on the arrow.
  3. Select the command Download

    The dialog to save documents is displayed.

  4. Select thea saving location on the local computer.


Languages and time formats

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Languages and time formats

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

User interface language

The zenon Analyzer can be displayed in several languages on the web client. As far as selected in the browser, the user interface is displayed in:

  • Chinese (simplified Chinese)
  • German
  • English
  • French
  • Italian
  • Russian
  • Spanish
  • Czech

For all other languages the default language - English - is used. You configure the language in the browser using the respective dialog for language selection.

Time formats

Time formats correspond to the conventions of the language set in the browser.

Note: If one of the following errors occurs, check the settings for language and time stamp formats:

  • Drop-down list for date and time selection does not work
  • Report Launcher reports an incorrectly-formatted time stamp

Texts

Texts are displayed as they are entered in the report or output by the server.

Other topics in this chapter

Change standard time/day light saving time


Change standard time/day light saving time

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Languages and time formats -> Change standard time/day light saving time

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The switch from standard time to daylight saving time and vice versa can lead to anomalies with intervals at the time of switching. These arise as a result of the functions provided by the .NET Framework , DateTime.ToLocalTime and DateTime.ToUniversalTime.

Intervals

Compression

DSTstart

DSTend

Minutes
  • Interval in local time: DSTstart – 1 minute, DSTstart + 1 hour)
  • Interval in UTC: 1 minute
  • Interval in local time: DSTend –1 minute, DSTend
  • Interval in UTC: 1 hour and 1 minute

Hour

Interval (DSTstart, DSTstart+1) is not present.
  • Interval in local time: DSTend –2, DSTend –1
  • Interval in UTC: 2 hours

Key:

  • DSTstart: Time of the switch from standard time to daylight-saving time in local time.
    This means: The clocks are moved forward by 1 hour at the time of DSTstart.
  • DSTEnd: Time of the switch from standard time to daylight-saving time in local time.
    This means: The hours are put back by 1 hour at the time of DSTend.


Parameters - input and selection

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The user defines via dialogs and input fields (controls) the values which should be displayed in a report. The dialogs for parameter input are displayed when a report is opened which needs parameters. At this default values can already be set.

By clicking button View report, the parameters are sent to the zenon Analyzer. It checks the values entered by the user to see that they are valid. For valid parameters the respective report is displayed; otherwise an error message is displayed.

Adapt drop-down list

There is a drop-down list available for input, selection and filtering. The size of most of the drop-down lists can be adjusted. The exceptions to this are the parameters for the input of a time range and the selection of date and time.

To adjust the size of the drop-down list:

  1. Move the mouse to the touch area in the lower right corner until the mouse pointer becomes a double-arrow.

  2. With the left mouse button pressed, drag it to the desired size
    Note: the original size is the minimum size

Validation

At the data transmission between browser and Analyzer the values of a parameter are always transmitted as text. The following parameters must always have valid values:

  • Bool
  • Date and time

The following conditions are checked at the parameter validation. Errors are displayed in the view window of the zenon Analyzer:

Entry

Limitation

Value available

A value must have be entered or selected. This validation is always carried out before sending the parameter to the zenon Analyzer server.

String validation

For parameters of data type Text no additional validations are carried out.

Boolean validation

For parameters of data type Bool the value must be either true or false. Capitalization/use of small letters is not checked.

Comment: The Boolean selection dialog sends valid values but at the direct control of the zenon Analyzer via URLs the validation may be needed.

Integer validation

For parameters of data type Integer the value must not contain another character as the following:

  • A plus or a minus character as first character.
  • All numbers allowed in the culture of the user.
  • The thousands separator in the culture of the user.
    All included thousands separator are removed at the beginning of the integer validation.

Float validation

For parameters of data type Float the value must not contain another character as the following:

  • A plus or a minus character as first character.
  • All numbers allowed in the culture of the user.
  • The thousands separator in the culture of the user.
    All thousand separators that are included are removed at the beginning of the integer validation.
  • Exactly one decimal separator in the culture of the user.
    If there are no numbers in front of or after the decimal separator, a 0 is assumed.
    Note: No numbers in front of and after the decimal separator is not allowed.

Date and time validation

For parameters of data type date and time the following criteria must be adhered to:

  • The value of the parameter must correspond to a valid date and time format of the culture of the user.
  • The numbers in date and time must be able to be assigned to a valid value.
    For example, the character string 45.18.2011 35:68:99 is invalid as there is no such date or time.
  • If the character string does not contain a time, 00:00:00 is assumed.
  • The time is rounded to minutes. If a time contains seconds, it is rounded to the preceding minute if the value is smaller the 30. For values larger or equal to 30 it is rounded to the next minute. The rounding considers jumps for minutes, hours, days, months and years.
  • The rounded result must lie within the following limits: Minimum = 1.1.1900 00:00:00
    Maximum = 1.1.[current year + 3] 00:00:00
    The maximum complies to the end of the year of the year after next from the current date.

Conditions for values of the parameter

At the definition of a report (e.g. in the Report Builder) you must adhere to the following restrictions for parameters with predefined values:

  • The value must not be NULL.
  • The label can be NULL, with the exception of those for equipment group and shift. In this case the value is used as label.
  • Each value must be unique.
    Different predefined values with the same value field are not allowed.
  • The label must be unique.
    Different predefined values with the same label field are not allowed.
    Exception: Values from equipment groups with the same labels are permitted if they are not in the same area of the tree. The same labels for root elements and the same labels for elements with the same superordinate nodes thus lead to errors.
    Attention: A value without label can also lead to a duplicate if its label matches another predefined value.

attention Attention

The parameter validation by the zenon Analyzer server is not a precaution against attacks via SQL injection but only a check of valid report values. Counteractions against attacks must be done by the designer of the SQL stored procedures.

Other topics in this chapter

Default input field

Boolean selection dialog

Input or selection of several values

Date and time

Time span

Equipment group

Lot and shift

Filter

Sorting of filter elements


Default input field

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Default input field

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The default input field permits to enter exactly one value for a parameter. This input field is displayed for all parameters which do not call for a specialized dialog.


Boolean selection dialog

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Boolean selection dialog

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Boolean selection dialog makes it possible to select one of the values for Boolean parameter which can receive a label:

  • True
  • False


Input or selection of several values

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Input or selection of several values

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Input several values

This dialog allows entering several values for a parameter. Here each line corresponds to a value. Empty lines are ignored.

To enter values:

  1. Click on the input field.

    The input field is opened.

  2. Enter the values line by line or select these from the drop-down list.
  3. Click next to the input field.

    The input field is closed. The values are displayed separated by semicolon.

Selection of a value from several predefined values

This dialog allows the selection of one value from several predefined values. The values are always displayed in alphabetical order.

To select a value:

  1. Click on the input field.

    The input field is opened.

  2. Filter the entries or select a value.
  3. Click next to the input field.

    The input field is closed. The value is displayed in the input field.

The dialog can be displayed filtered.

Selection of several values from several predefined values

This dialog allows the selection of several values from several predefined values. The values are always displayed in alphabetical order. The selection takes place by activating the check box in front of the entry. As soon as more than one entry is displayed, the list has a check box for selecting/deselecting all values.

To select several values:

  1. Click on the input field.

    The input field is opened.

  2. Filter the entries or select the desired values.
  3. Click on Select all values to select all values
    In doing so, the following applies:
    • The first click in the Select all values checkbox selects all entries.
    • The second click cancels the selection.
    • This selection always affects the currently-displayed values only; values that have been filtered out are not affected.
  4. Click next to the input field.

    The input field is closed. The values are displayed separated by semicolon.

The dialog can be displayed filtered.


Date and time

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Date and time

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The dialog for date and time have different selection possibilities, depending on the configuration of the report:

  • Year: Selection of the year
  • Month: Selection of the month
  • Day: Selection of a day
  • Hours: Selection of the hours
  • Time: Selection of the hours and minutes

Basics

  • The calendar week and the beginning of the week in the selection dialog complies with norm ISO 8601. Therefore:
    • the first weekday is always a Monday
    • and January 4 is always in the first calendar week of a year
  • The display of the time in 24-hour format or 12-hour format depends on the setting of language culture in the browser.

Other topics in this chapter

Year

Month

day

Hours

Time


Year

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Date and time -> Year

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the year for display in the report. The time period ranges from 1900 to the next year from the current date.

Selection of year

Parameters

Description

Header

In the header you can jump to the decade view of the previous or next decade by clicking on the arrows. The arrows are only displayed if they are available.

Click on:

  • Arrow left: Switches to the previous decade.
  • Arrow right. Switches to the subsequent decade.

In view 1900 - 1910 you cannot navigate to the previous decade. In the view of the decade that contains the year after next starting from the current date, it is not possible to navigate to the next decade.

Selection of year

The selected year is displayed in bold. If there is no value set, the current year is displayed in bold.

Clicking on a year accepts the year as a time point and closes the dialog. The day and time are defined using the two control elements Beginning of the year and End of the year.

Beginning of the year
  • Active: January 1st, 00:00:00 is configured as the day and time.

End of the year
  • Active: January 1st of the subsequent year, 00:00:00 is configured.


Month

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Date and time -> Month

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of a month for display in the report.

Selection of month

Parameters

Description

Header

It is possible to change to other years in the header by clicking on the arrows. The arrows are only displayed if they are available.

Click on:

  • Arrow left: Switches to the previous year.
  • Arrow right. Switches to the following year.
  • Year: Opens the dialog to select the year.

Selection of month

The selected month is displayed in bold. If there is no value, the current month is displayed in bold.

Clicking on a month accepts the month as a time point and closes the dialog. The day and time are defined using the two control elements Beginning of the month and End of the month.

Beginning of the month
  • Active: The first day of the month, 00:00:00, is configured as the day and time.

End of the month
  • Active: The first day of the following month, 00:00:00, is configured as the day and time.


day

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Date and time -> day

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of a day in a month for display in the report.

Selection of day

Parameters

Description

Header

It is possible to change to other months in the header by clicking on the arrows. The arrows are only displayed if they are available.

Click on:

  • Arrow left: Switches to the previous month.
  • Arrow right. Switches to the following month.
  • Year: Opens the dialog to select a month.

Selection of day

The selected day is displayed in bold. If there is no value, the current day is displayed in bold.

Clicking on a day accepts the day as a time point and closes the dialog. The time is defined using the two control elements Beginning of the month and End of the month.

Beginning of the day
  • Active: 00:00:00 is configured as a time.

End of the day
  • Active: 00:00:00 of the following day is configured as a time.


Hours

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Date and time -> Hours

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of a day and an hour in a month for display in the report.

Selection of day

Parameters

Description

Header

It is possible to change to other months in the header by clicking on the arrows. The arrows are only displayed if they are available.

Click on:

  • Arrow left: Switches to the previous month.
  • Arrow right. Switches to the following month.
  • Year: Opens the dialog to select a month. The header can be used for date navigation:

Selection of day

The selected day is displayed in bold. If there is no value, the current day is displayed in bold.

Clicking on a day accepts the day as a time point and opens the dialog to select an hour.

Today

Accepts the current day as a date and opens the dialog to select the hour.

Beginning of this week

Sets Monday of the current calendar week with the start of the day (00:00:00) as the time.

End of this week

Sets Monday of the following calendar week with the start of the day (00:00:00) as the time.

Beginning of this month

Sets the first day of the current month with the start of the day (00:00:00) as the time.

End of this month

Sets the first day of the following month with the start of the day (00:00:00) as the time.

Selection of hour

Parameters | Description
Header | A click on the header opens the month view to navigate dates.
Entry of time | The time is selected by means the drop-down list. The selection is made by clicking on the arrow of the spin control or by clicking on the desired time in the drop-down list that has been opened or by direct input using the keyboard (arrow and number keys). Minutes are displayed as 00 and cannot be changed.
00:00 means the end of the day | Active: 00:00 is interpreted as the end of the day.
Back | Opens month view for navigation of dates.
Accept | Applies settings and closes the dialog. To cancel the input, click on the calendar symbol next to the input field.


Time

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Date and time -> Time

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The time is selected according to the setting of the language of the browser in 24-hour time or in 12-hour time.

24-hour time format

Parameters

Description

Header

A click on the header opens the month view to navigate dates.

Entry of time

The time is selected by means of two drop-down lists. Clicking on the list opens these. The selection is made by clicking on the arrow of the spin control or by clicking on the desired time in the drop-down list that has been opened or by direct input using the keyboard (arrow and number keys):

  • The first (left) drop-down list is for selecting the hour.
    The arrow on the right next to the first drop-down list increases and reduces the set hour by the value 1. At the end of the list, it goes to the start if it is increased. At the start of the list, it goes to the end if it is reduced.
  • The second (right) drop-down list is for selecting the minute. The list contains the values 0 to 59. If the drop-down list is opened, a value can also be selected via the keyboard (arrow and number keys).

00:00 means the end of the day
  • Active: 00:00 is interpreted as the end of the day.

Back

Opens month view for navigation of dates.

Accept

Applies settings and closes the dialog.

To cancel the input, click on the calendar symbol next to the input field.

12-hour time format

Parameters

Description

Header

A click on the header opens the month view to navigate dates.

Entry of time

The time is selected by means of two drop-down lists. Clicking on the list opens these. The selection is made by clicking on the arrow of the spin control or by clicking on the desired time in the drop-down list that has been opened or by direct input using the keyboard (arrow and number keys):

  • The first (left) drop-down list is for selecting the hour.
    The arrow on the right next to the first drop-down list increases and reduces the set hour by the value 1. At the end of the list, it goes to the start if it is increased. At the start of the list, it goes to the end if it is reduced.
  • The second (right) drop-down list is for selecting the minute. The list contains the values 0 to 59. If the drop-down list is opened, a value can also be selected via the keyboard (arrow and number keys).
  • AM: Morning (ante meridiem)
  • PM: Afternoon (post meridiem)

12:00 AM means end of the day

Active: 12:00 AM is interpreted as the end of the day.

Back

Opens month view for navigation of dates.

Accept

Applies settings and closes the dialog.

To cancel the input, click on the calendar symbol next to the input field.


Time span

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Time span

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This dialog makes it possible to enter a time period, depending on the configuration of the report.

To configure a time period:

  1. Select the end time
    The possibilities for selection available depend on the report:
    • Year
    • Month
    • day
    • Hour
    • Minute
  2. Select the interval duration.
    The interval duration defines the time period until the end time. The possibilities for selection depend on the report.
  3. The selected configuration is displayed in the Preview area. Error messages are displayed here if there is an incorrect configuration.

Other topics in this chapter

Year

Month

day

Hour

Minute


Year

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Time span -> Year

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Entry of the time range in years.

Parameters

Description

End of the interval

Definition of the end time.

Minutes and hours are always set to 0, days are always set to 1. January. These elements cannot be configured.

Set current date and time

Set the current time stamp when clicked.

Year

Input of year. Select from drop-down list.

Beginning of the year
  • Active: The end time is 00:00 on January 1 of the selected year.

End of the year
  • Active: The end time is 00:00 on January 1 of the following year.

Interval definition

Duration of the period of time that is to be analyzed.

  • Text input field: Defines quantity.
    Input of a number between 1 and 99999.
    The quantity can be increased or reduced with the arrows.
  • Drop-down list: Defines granularity.
    Fixed setting: Years

Preview

Display of the current configuration settings in local time.

Errors are displayed by the corresponding error messages.

  • From: Start of the interval. Display only.
  • To: End of the interval. Display only.

Accept

Click on this button to accept the inputs, if they are valid, and close the dialog.

Time stamp is converted to UTC.

To leave the dialog without saving, click on the calendar symbol or in the toolbar with the drop-down dialog.


Month

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Time span -> Month

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Entry of the time range in months.

Parameters

Description

End of the interval

Definition of the end time.

Minutes and hours are always set to 0, days are always set to 1. These elements cannot be configured.

Set current date and time

Set the current time stamp when clicked.

Year

Input of year. Select from drop-down list.

Month

Input of month. Select from drop-down list.

Beginning of the month
  • Active: The end time is 00:00 on the first day of the selected month.

End of the month
  • Active: The end time is 00:00 on the first day of the following month.

Interval definition

Duration of the period of time that is to be analyzed.

  • Text input field: Defines quantity.
    Input of a number between 1 and 99999.
    The quantity can be increased or reduced with the arrows.
  • Drop-down list: Defines granularity. Selection of years or months.

Preview

Display of the current configuration settings in local time.

Errors are displayed by the corresponding error messages.

  • From: Start of the interval. Display only.
  • To: End of the interval. Display only.

Accept

Click on this button to accept the inputs, if they are valid, and close the dialog.

Time stamp is converted to UTC.

To leave the dialog without saving, click on the calendar symbol or in the toolbar with the drop-down dialog.


day

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Time span -> day

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Entry of the time range in days.

Parameters

Description

End of the interval

Definition of the end time.

Minutes and hours are always set to 0 and cannot be configured.

Set current date and time

Set the current time stamp when clicked.

Year

Input of year. Select from drop-down list.

Month

Input of month. Select from drop-down list.

day

Input of day. Select from drop-down list.

Beginning of the day
  • Active: The end time is 00:00 on the selected day.

End of the day
  • Active: The end time is 00:00 on the selected day of the following day.

Interval definition

Duration of the period of time that is to be analyzed.

  • Text input field: Defines quantity.
    Input of a number between 1 and 99999.
    The quantity can be increased or reduced with the arrows.
  • Drop-down list: Defines granularity. Selection between years, months and days.

Preview

Display of the current configuration settings in local time.

Errors are displayed by the corresponding error messages.

  • From: Start of the interval. Display only.
  • To: End of the interval. Display only.

Accept

Click on this button to accept the inputs, if they are valid, and close the dialog.

Time stamp is converted to UTC.

To leave the dialog without saving, click on the calendar symbol or in the toolbar with the drop-down dialog.


Hour

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Time span -> Hour

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Entry of the time range in hours.

Parameters

Description

End of the interval

Definition of the end time.

Minutes are always set to 0 and cannot be configured.

Set current date and time

Set the current time stamp when clicked.

Year

Input of year. Select from drop-down list.

Month

Input of month. Select from drop-down list.

day

Input of day. Select from drop-down list.

Hour

Input of hour. Select from drop-down list.

Interval definition

Duration of the period of time that is to be analyzed.

  • Text input field: Defines quantity.
    Input of a number between 1 and 99999.
    The quantity can be increased or reduced with the arrows.
  • Drop-down list: Defines granularity. Selection between years, months, days and hours.

Preview

Display of the current configuration settings in local time.

Errors are displayed by the corresponding error messages.

  • From: Start of the interval. Display only.
  • To: End of the interval. Display only.

Accept

Click on this button to accept the inputs, if they are valid, and close the dialog.

Time stamp is converted to UTC.

To leave the dialog without saving, click on the calendar symbol or in the toolbar with the drop-down dialog.


Minute

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Time span -> Minute

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Entry of the time range in minutes.

Parameters

Description

End of the interval

Definition of the end time.

Set current date and time

Set the current time stamp when clicked.

Year

Input of year. Select from drop-down list.

Month

Input of month. Select from drop-down list.

day

Input of day. Select from drop-down list.

Hour

Input of hour. Select from drop-down list.

Minute

Input of minute. Select from drop-down list.

Interval definition

Duration of the period of time that is to be analyzed.

  • Text input field: Defines quantity.
    Input of a number between 1 and 99999.
    The quantity can be increased or reduced with the arrows.
  • Drop-down list: Defines granularity. Selection between years, months, days, hours and minutes.

Preview

Display of the current configuration settings in local time.

Errors are displayed by the corresponding error messages.

  • From: Start of the interval. Display only.
  • To: End of the interval. Display only.

Accept

Click on this button to accept the inputs, if they are valid, and close the dialog.

Time stamp is converted to UTC.

To leave the dialog without saving, click on the calendar symbol or in the toolbar with the drop-down dialog.


Equipment group

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Equipment group

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Equipment groups can be displayed with a different depth of the level displayed when opening the drop-down list. The following are available:

  • Only the upper-most level
  • All levels
  • A defined depth of levels (up to 25)

This output display is configured using the report designer in ZAMS. This control element is available for all report templates that contain equipment models.

attention Attention

Each equipment group in zenon may only be assigned to one individual time model.

If several time model groups are assigned, the Analyzer Wizard Export uses the first that it finds and exports this to the metadata of the Analyzer. Other time model groups are ignored.

Labels

Labels for an equipment group do not need to be unique. Values from equipment groups with the same labels are permitted if they are not in the same area of the tree. Identical labels for root elements and identical labels for elements with the same superordinate nodes leads to errors.

Selection of an entry from the equipment model

This selection dialog makes it possible to select an entry from the equipment model. The entries are displayed via a tree structure and sorted alphabetically in each level.

Subordinate elements of a level can be hidden. A plus in front of the entry means that: the element contains additional subordinate elements. They are not displayed in the current view. Click on the plus sign to open the display of the sub elements. The plus sign changes to a minus sign. Click on the minus sign to close the level again.

To select an element:

  1. Open the respective group if the element is a sub element and therefore is not displayed
  2. Select the desired element with a mouse click.
  3. Close the dialog by clicking in the area next to the dialog.

The dialog can be displayed filtered. At this the filter criterion is only used on entries which do not have any subordinate elements.

Selection of several entries from the equipment model

This selection dialog makes it possible to select several entries from the equipment model. The entries are displayed via a tree structure and sorted alphabetically in each level.

Subordinate elements of a level can be hidden. A plus in front of the entry means that: the element contains additional subordinate elements. They are not displayed in the current view. Click on the plus sign in order to open the display of the sub elements. The plus sign changes to a minus sign. Click on the minus sign in order to close the level.

At showing/hiding selected entries (tick in the check box) are also shown/hidden. The status (selected or deselected) remains the same. Double clicking a checkbox marks all hierarchically-subordinate checkboxes that are visible at that time or removes the marking.

To select several elements:

  1. Highlight the desired object by clicking on the checkbox in front of the element.
  2. Open the respective group if the element is a sub element and therefore is not displayed
  3. If the selected element has sub-levels, the levels bellow are also selected with the control element.
  4. Close the dialog by clicking in the area next to the dialog.

The dialog can be displayed filtered. At this the filter criterion is only used on entries which do not have any subordinate elements.

Structure for predefined values

Pre-defined values require a certain structure for both dialogs:

  • The name to be displayed is always in the labeling of the value.
  • For root entries (no superordinate node exists) only the ID is in the value.
  • For subordinate entries the value consists of ID of the entry and the ID of the superordinate entry separated by a linking character (pipe character |).
    Syntax: [ID of the entry] | [ID of the superordinate entry]

Double click in the tree structure

Different browsers react differently to a double click on a node in the tree structure:

  • Internet Explorer:
    The opposite of the currently visible stats of the node that has been clicked on is passed on to the lower objects and transferred to the nodes.
    For example: The checkbox of the node is not ticked. Double clicking ticks the checkboxes of the node and all its sub-items.
  • Chrome and Firefox:
    The current status does not change and is passed on to the lower objects.
    For example: The checkbox of the node is not ticked. Double clicking does not tick the checkboxes of the node and all its sub-items.


Lot and shift

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Lot and shift

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This selection dialog configures the display of lots and shiftdata. Each predefined value corresponds to one line. The user can select a lot by clicking on the respective cell.

The selection dialog contains the following columns:

  • Name (for lot or shift)
  • Start date
  • Start time
  • End date
  • End time
  • Duration

The dialog can be sorted and filtered. For details, see the Filter lots chapter.

Structure of predefined values

Predefined values call for a certain structure for this dialog:

  • The lot name is always in the label of the value.
  • The value filed of the label consists of:
    • [start time]
    • Linking character "|"
    • [end time]

      The format of a time is YYYY-MM-DD hh:mm:ss in UTC.
      The time is converted to the local time of the server for display.

From this the following values are generated for displaying in columns:

  • Lot name
  • Date on which the lot started: Input in date format of the language culture of the user;
    Date and time are displayed in local time of the server
  • Time when the lot started: Input in time format of the language culture of the user;
    Date and time are displayed in local time of the server
  • Date on which the lot ended: Input in date format of the language culture of the user;
    Date and time are displayed in local time of the server
  • Time when the lot ended: Input in time format of the language culture of the user;
    Date and time are displayed in local time of the server
  • Lot duration:
    Format: [#Days][Day abbreviation in the culture of the user] [#Hours]:[#Minutes]:[#Seconds]

Evaluation of lot groups

A mechanism for evaluating lot groups is available. This is based on the equipment model:

  1. The necessary variables and the lot archive in which they are logged are found via the equipment model.
  2. All lots for the selected point in time are obtained from the lot archives. In doing so, lots from several archives with the same lot names but different point in time are compiled into one entry.
  3. The lots are displayed in a lot selection dialog via report parameters.
  4. When creating a report, the lots for the respective archives are read again and the data for the time period of the lot in the archive is obtained.


Filter

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Filter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Some dialogs can be displayed in a filtered way. For example dialogs for:

  • Input or selection of several values: Filter method see below
  • Equipment group selection: Filter method see below
  • Lot selection: For the filter method, see Lot selection

To filter the predefined values:

  1. Enter the filter criterion in the input field.
  2. Press key Enter.
  3. The list is rebuild and only contains values which correspond to the filter criterion

To display all values:

  1. Delete the filter criterion from the input field.
  2. Press key Enter.
  3. The list is rebuild and contains all predefined values.

Filter criteria for dialogs which can be filtered

  • The filtering is not case-sensitive.
  • A question mark (?) is a wildcard for exactly one character.
  • An asterisk (*) is a wildcard for any number of character.
  • If there is neither * nor ? in a filter criterion, a * is appended to the filter criterion internally.
  • If values are selected, they are still displayed when filtering even if they do not match the criterion.
  • Equipment group: The filter criterion is only applied to entries which do not have subordinate elements (e.g. they never existed or they were filtered out previously)

Examples

Filter | finds
e or E or e* or E* finds | all entries starting with "e" or "E".
*3 | finds all entries ending with "3".
?r* or ?R* | finds all entries with "r" or "R" as second character.
*9* | finds all entries containing "9".

Other topics in this chapter

Filter lots


Filter lots

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Filter -> Filter lots

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The entries in the lot selection dialog can be filtered and sorted.

Filter values

To filter the predefined values:

  1. In each desired column enter the filter criterion in the input field.
  2. Press key Enter.
  3. The list is rebuild and only contains values which correspond to the filter criterion

To display all values:

  1. Delete the filter criterion from the input field.
  2. Press key Enter.
  3. The list is rebuild and contains all predefined values.

For the filtering the following is true:

  • Each column has its own filter box.
  • If a filter box is empty, it is not filtered after this column.
  • For an entry to be displayed, it must fulfill the filter criteria of all columns.
  • The filtering is triggered by pressing key Enter in any filter box.
  • The following filters are used for the individual columns:
    • The lot name uses the text filter in the same way as the dialog for selecting one of several predefined values.
    • Start date uses the date filter.
    • Start time uses the time filter.
    • End date uses the date filter.
    • End time uses the time filter.
    • Duration uses the duration filter.

Lot name

For this filter the following is true:

  • The filtering is not case-sensitive.
  • A question mark (?) is a wildcard for exactly one character.
  • An asterisk (*) is a wildcard for any number of character.
  • If there is neither * nor ? in a filter criterion, a * is appended to the filter criterion internally.
  • If values are selected, they are still displayed when filtering even if they do not match the criterion.

Date filter

For this filter the following is true:

  • The date must be entered in the date format of the language culture of the user.
  • Leading zeros can be left out.
  • For single elements (day, month, year) you may use * as wildcard.

    For example:
    May 2011: *.5.2011
    Year 2011: *.*.2011

  • To filter from/up to a special day you may use the following at the beginning:
    • <
    • >
    • <=
    • >=

    * is not allowed.
    For example:

    from 1 May 2011: > 30.4.2011 or >= 1.5.2011
    up to 31 May 2011: < 1.6.2011 or <= 31.5.2011

  • If a filter criterion does not match these conditions (e.g. < and * are combined, elements are missing or are entered in the wrong date format), the whole filtering process is canceled.

Time filter:

For this filter the following is true:

  • The time must be entered in the time format of the language culture of the user.
  • Leading zeros can be left out.
  • For single elements (hours, minutes, seconds) you may use * as wildcard.
    For example:
    12 o' clock: 12:*:* (24-hours) or 12:*:* PM (12-hours)
    13:45: 13:45:* (24-hours) or 1:45:* PM (12-hours)
  • To filter from/up to a special time you may use the following at the beginning:
    • <
    • >
    • <=
    • >=

    * is not allowed.
    For example:
    Morning including noon: < 12:00:01 or <= 12:00:00 (24-hours) or < 12:00:01 PM or <= 12:00:00 PM (12-hours)
    Everything starting at 8 o' clock: > 7:59:59 or >= 8:0:0 (24-hours) or > 7:59:59 AM or >= 8:0:0 AM (12-hours)

  • If a filter criterion does not match these conditions (e.g. < and * are combined, elements are missing or are entered in the wrong time format), the whole filtering process is canceled.

Duration filter

For this filter the following is true:

  • The duration must be entered in the format defined above.
  • Leading zeros can be left out.
  • For single elements (hours, minutes, seconds) you may use * as wildcard.
    For example:
    Duration: 1 day: 1d *:*:*
  • To filter from/up to a certain duration you may use the following at the beginning:
    • <
    • >
    • <=
    • >=

    * is not allowed.
    For example:

    Longer than 1 day: > 1d 0:0:0 or >= 1d 0:0:1
    Less than 12 hours: < 0d 12:0:0 or <= 0d 11:59:59

  • If a filter criterion does not match these conditions (e.g. < and * combined, elements missing), the whole filtering process is canceled.

Sort values

The report can be sorted ascending or descending on any column. The current sorting order is displayed in the column after which it is sorted.

To sort a column:

  1. click on the desired column title
  2. the sorting is started
  3. the arrow next to the column header displays whether the sorting is ascending or descending
  4. another click on the column header changes the sorting order

Filtering and sorting can be used in parallel and do not influence one another.


Sorting of filter elements

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Parameters - input and selection -> Sorting of filter elements

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of a value from predefined values or Selection of several values from predefined values type elements have, as standard, a predefined sorting for the display of filter elements.

This applies if the parameter:

  • is one of the following data types:
    • Integer
    • Float
    • Date & Time
    • Text
  • Has a list of predefined values
  • Is not hidden and not write-protected

The standard sorting is defined when the report template is created and cannot be changed by report developers in the Report Builder.

The following sorting is available:

Sorting | Description
A-Z: | Sorting is in alphabetical order according to the display text of the predefined values. This is the standard action. This also applies if no special sorting has been saved.
Z-A: | Sorting is in reverse alphabetical order according to the display text of the predefined values.
Values upwards: | Sorting direction is upwards according to the predefined values. The data type of the parameter is not taken into account in the process.
Values downwards: | Sorting direction is downwards according to the predefined values. The data type of the parameter is not taken into account in the process.
In sequence: | The values are written to the list in the order in which they were provided by the SQL Server Reporting Services web service.
In reverse sequence: | The values are written to the list in the reverse order to the order in which they were provided by the SQL Server Reporting Services web service.


Site Settings

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Site Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Via the site settings you configure

  • General settings of the zenon Analyzer

Note: User rights are set and administered in the ZAMS.

Other topics in this chapter

General


General

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Site Settings -> General

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

General settings for naming the zenon Analyzer and processing the reports.

Parameters

Description

Name

Name which is displayed in the header of the report generators.

Report History

Defined number of reports saved for the history. Possible settings:

  • unlimited number
  • define maximum number

Reportimeout

Defines timeout for processing reports. Possible settings:

  • no timeout
  • Restriction to a second value

Start URL for user-defined Report Generator

Address for user-defined Report Generator.

Apply

Takes over changed settings

Attention: If you leave the site without clicking Apply, all changes will be lost.


Data source

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Data source

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To edit a data source:

  1. Highlight the data source.
  2. Click on the arrow.
  3. Select the desired command from the context menu.

Database context menu

The context menu of databases contains commands for their administration. The context menu is identical for both views of the Report Launcher.

Parameters | Description
Move | Opens menu for selecting the new saving location.
Delete | Deletes selected reports.
Generate Report Model | Opens the dialog to generate a new model for the data source.
View Dependent Items | Displays all reports based in this data source and makes it possible to delete or move them.
Manage | Opens the dialog to administer the database.

You can find detailed instructions for the configuration of Microsoft Reporting Services on the Microsoft homepage:

  • German
  • English
  • French
  • Italian

Other topics in this chapter

Properties


Properties

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Data source -> Properties

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In window properties you define the basic properties of the data source and the connection parameters.

Parameters

Description

Delete

Deletes data source.

Move

Moves data source.

Generate Model

Opens dialog for creating a new model.

Name

Name of the data source.

Description

Optional, detailed description

Hide in side-by-side/one-below-the-other view

Active: is hidden in side-by-side/one-below-the-other view.

Enable this data source

Active: Data source is used.

Data source type

Selection of the type via drop-down list.

Connection string

String for establishing the connection.

Establish connection via

Selection of the connection method.

Provided login information of the user who executes the report

User must state information.

It is possible to display an instruction

The information can be marked as Window login information.

Login information which are saved securely on the report server

Login information is saved on the server.

User name and password must be entered.
The following are available as an option:

  • Use of Windows authentication when connecting to the data source.
  • Assumption of the identity of the user entered after establishing a connection.

Integrated Windows security

Windows security.

No login information required

No login information is necessary.

Test Connection

Checks connection and displays a success/failure message below the button.

Apply

Applies all settings.

Change password

It can happen that the password for the data source can no longer be changed.
Procedure to allow access to the Password option again:

  1. In the A user-defined data source section, activate the No login information required property.
  2. Click on test connection.

The User name and Password properties can now be changed.

Other topics in this chapter

Generate Report Model


Generate Report Model

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Data source -> Properties -> Generate Report Model

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This dialog makes it possible to create new models for the data source.

Parameters | Description
Name | Name of the new data source.
Description | Optional, detailed description.
Saving location/change saving location | Opens dialog for defining the saving location.
OK | Confirms changes and opens the properties.
Cancel | Discards all changes and closes the dialog.


Folder

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Folder

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports are collected and grouped in folders.

Folders are configured and managed via:

  • menu item New folder in the toolbar
  • menu item Folder settings in the toolbar
  • the drop-down list of the folder (is displayed at mouse over)

Context menu folder

The context menu of folders contains different commands, regardless of the Report Launcher view.

Tile view

Parameters | Description
Move | Opens dialog for selecting the new saving location.
Delete | Deletes selected folder.
Manage | Opens the dialog for managing the folder.

Detail view

Parameters | Description
Move | Opens dialog for selecting the new saving location.
Delete | Deletes selected folder.
Manage | Opens the dialog for managing the folder.
New folder | Opens dialog to create a new folder.
New Data Source | Opens the dialog to select a new data source.
Upload File | Opens the dialog for uploading a new file.

Create new folder

To create a new folder:

  1. click on menu item New folder in the toolbar
  2. the dialog for creating a new folder is opened

Parameters

Description

Name

Name of the folder

Name:

  • must not be empty
  • Must not consist of periods or spaces
  • Must not contain non-permitted characters;
    The following are not permitted: ;?:@&=+$,\*<>|"/

The complete path must not have more than 260 characters.

Description

Optional description of the folder content.

Hide in symbol view
  • Active: Folder is not displayed in the symbol view.
    This setting can later be changed via menu item Management in the drop-down list of the folder.

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.

Other topics in this chapter

Properties


Properties

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Folder -> Properties

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The folder properties display information about the folder and offer the possibility to:

  • move
  • delete
  • rename
  • Show or hide in the symbol view


Upload file

zenon Analyzer -> Report Launcher -> Report Launcher: Configuration and operation -> Upload file

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports, models and other resources which are edited offline can be uploaded to the Report Server.

To upload resources:

  1. In the toolbar click on icon Upload file.

    The dialog for uploading will be opened.

  2. Select the desired file.
  3. Select the desired options.
  4. Confirm your selection by clicking OK.

Parameters

Description

File to be uploaded

Selection of the file which is to be uploaded. Click on button Browse to open the file manager. Multi-select is not possible.

Name

Freely definable name.
The file name of the selected file is taken over as default value.

Overwrite existing element
  • Active: If an element with the same name already exists at the Report Server, it is overwritten.

OK

Information is applied, the file is uploaded and the dialog is closed.

Cancel

Discards all changes and closes the dialog.


Create report

zenon Analyzer -> Report Launcher -> Create report

Reports can be created with:

  • ZAMS - zenon Analyzer Management Studio
  • Microsoft Report Builder 3.0

For zenon an own wizard for exporting the meta data from the global project and the variables from the local projects is available. For more information about this wizard see also chapter Analyzer Export Wizard in section Data abstraction and data inclusion.

Other topics in this chapter

Report Builder

Upload reports


Report Builder

zenon Analyzer -> Report Launcher -> Create report -> Report Builder

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports can be created manually with the help of the Microsoft Report Builder.
Note: If there is not yet a Report Builder present on your system, you can download this in the Report Launcher using a button.

info Information

The Report Builder is not suitable as an editor for reports with CRI (Gantt Chart) as it cannot process CRIs.

To start the Microsoft Report Builder:

  1. In the menu bar, click on the Report Builder button.

    Depending on the settings, the Getting Started or Report Builder dialog can be opened directly:

You can get support for the creation of reports with the Report Builder using the integrated help for the Report Builder.

You can find detailed instructions for the configuration of Microsoft Reporting Services on the Microsoft homepage:

  • German
  • English
  • French
  • Italian

Recommendation: Create reports in the zenon Analyzer Management Studio on the basis of report templates provided.


Upload reports

zenon Analyzer -> Report Launcher -> Create report -> Upload reports

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports which were created offline can be uploaded to the Server with the help of the zenon Analyzer.

To upload resources:

  1. In the toolbar click on icon Upload file.

    The dialog for uploading will be opened.

  2. Select the desired file.
  3. Select the desired options.
  4. Confirm your selection by clicking OK.

Parameters

Description

File to be uploaded

Selection of the file which is to be uploaded. Click on button Browse to open the file manager. Multi-select is not possible.

Name

Freely definable name.
The file name of the selected file is taken over as default value.

Overwrite existing element
  • Active: If an element with the same name already exists at the Report Server, it is overwritten.

OK

Information is applied, the file is uploaded and the dialog is closed.

Cancel

Discards all changes and closes the dialog.


Call up report

zenon Analyzer -> Report Launcher -> Call up report

Reports can be called up and configured in the browser on the client computer.

info Information

The timeout for the execution of reports in the web browser is 30 minutes. If a report needs longer than 30 minutes to be completed and displayed, the web browser cancels the display with a timeout error message.

To call up a report:

  1. Double click the folder which contains the report
    or select open in the context menu
  2. Double click the desired report.

    The report is opened in the browser.

Navigation

Element | Description
Navigation | Allows navigation from the current element to the main directory.
Home | Switches to the main view.
Site Settings | Opens the administration of general settings of the site.
Help | Opens the online-help for the Report Launcher.

Configuration

Element | Description
Control elements | Control elements for configuration of the report. The type of control element depends on the report template. Control elements can depend on one another. In this case, they can only be configured if the previous one has been configured correctly.
Separator | Separates control elements from the toolbar. Clicking on the separator shows or hides the bar with control elements.
Toolbar | Contains symbols for navigation in the report and for further processing of the report.

Display report

Elements

Description

Report display field

Shows the report with the elements defined in the template:

  • Name of the report
  • Configured elements
  • Graphics
  • Table


Toolbar Report

zenon Analyzer -> Report Launcher -> Toolbar Report

Parameters

Description

Navigation arrows and <1 from 1>

Navigation in multi-sided reports:

  • |<: to the start
  • <: back one page
  • Field: Entry of the page to which a jump is to be made; press the Enter key to execute
  • >: forward one page
  • >|: to the last page

Search field

Enter a search term.

Search

Searches defined term and displays first occurrence.

Next

Searches for the next occurrence.

Icon disk

Export of the report. Click to open the drop-down list with export formats. Possible formats:

  • XML
  • CSV
  • PDF
  • Web archive
  • Excel
  • TIFF
  • Word

Icon rotating arrow

Updates data for report display.

Icon printer

Opens dialog for printing the report.

Icon book

Export in RSS feed.


Configure and export reports

zenon Analyzer -> Report Launcher -> Configure and export reports

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Different parameters can be selected depending on the report type. For example:

  • Time period for the report: for comparing reports two time periods are provided for configuration
  • Projects whose data is being edited
  • Archives
  • Compression
  • Variables
  • Alarm groups
  • Alarm Classes
  • Equipment groups and media

Configuring the report

To configure to a report:

  1. open the report
  2. select the desired parameters
  3. click on display report

Separator

In value fields of parameters that allow several values, the following are permitted:

  • Comma
  • Carriage return

Export Report

Reports can be exported to different formats.

To export a report:

  1. Click on the symbol for the export (disk).

    The drop-down list with the export formats is opened.

  2. Select the desired format.
  3. Save or open the document in the selected format.

export format

For the export the following options are available:

Parameters | Description
XML | Report is saved as XML file. Click to open the dialog for saving/displaying the XML file.
CSV | Report is saved as comma-separated text file (CSV). Click to open the dialog for saving/displaying the CSV file.
PDF | Report is saved as PDF file. Click to open the dialog for saving/displaying the web archive.
MHTML | Report is saved as web archive (.mhtml). Click to open the dialog for saving/displaying the web archive.
Excel | Report is saved as Excel file (.xls, for Excel 97 - 2003). Click to open the dialog for saving/displaying the XLS file. Diagram is embedded as graphic; values can be changed manually. Values changes do not effect the embedded graphic.
TIFF | Report is saved as graphic in the TIFF format. Click to open the dialog for saving/displaying the TIFF file.
Word | Report is saved as Word file (.doc, for Word 97 - 2003). Click to open the dialog for saving/displaying the DOC file. Diagram is embedded as graphic; values can be changed manually. Values changes do not effect the embedded graphic.

info Information

Reports are always defined for a certain output medium (see export formats). If they are output to other media, this can lead to the appearance being corrupted.

For example: A report configured for HTML can create page breaks that are unsuitable for PDFs. To create a report on several media, create a separate report for each medium.


Manage reports

zenon Analyzer -> Report Launcher -> Manage reports

Reports are managed via the drop-down list at the report.

Click on Manage to open the dialog for managing the reports:

Parameters | Description
Properties | Properties of the report.
Parameters | Configuration of the parameters of the report.
Data Sources | Selection of data sources.
Processing Options | Configuration of the editing of the report.
Cache Refresh Options | Creation and editing of the plans for the cache updating.
Report History | Allows snapshots of reports to be combined into a history.
Snapshot Options | Configuration of snapshots.

Other topics in this chapter

Properties

Parameters

Data Sources

Processing Options

Cache Refresh Options

Report History

Snapshot Options


Properties

zenon Analyzer -> Report Launcher -> Manage reports -> Properties

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In window Properties basic properties are displayed and configured.

Toolbar

Symbol | Description
Delete | Delete report.
Move | Opens the dialog for moving a report to another folder.
Create linked report | Opens dialog for creating a linked report. Linked reports make it possible to use different security settings for a report.
Download | Opens dialog for downloading a report.
Replace | Opens the dialog for uploading a report definition in order to replace the existing one.

Properties

Parameters

Description

Report data

Display of:

  • Date of change
  • Person who changed the report
  • Date of creation
  • Person who created the report
  • Size

Name

Name of the report.

Name:

  • must not be empty
  • Must not consist of periods or spaces
  • Must not contain non-permitted characters;
    The following are not permitted: ;?:@&=+$,\*<>|"/

The complete path must not have more than 260 characters.

Description

Description.

Hide in symbol view
  • Active: Report is not displayed in symbol view.

Apply

Applies changes.


Parameters

zenon Analyzer -> Report Launcher -> Manage reports -> Parameters

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Displays the parameter of the report and makes it possible to:

  • assign default values
  • hide parameter for user
  • to configure the text with which the parameter in the report is displayed

The options that are shown depend on the type of report.

Parameters

Description

Parameter Name

Name of the parameter.

Display only.

Parameter Type

Type of the parameter. Display only.

Displays whether:

  • a parameter allows one or more values
  • it is a specialized filter control (Bool Shift/Lot, TimeSpan, Tree)
  • the parameter serves for the input of values or the selection of a value from a drop-down list of pre-defined values

For non-specialized controls, the data type is also shown.

Has Default
  • Active: Default value is preset in the report for the input.
  • Active and grayed out: Standard values of a parameter come from a form or a data set. Standard values cannot be changed.
  • Inactive: No value is preset.

Each change to the check status of this checkbox made by the user is immediately forwarded to the server.

Default Value

The corresponding filter element for the parameter is shown here. Each parameter with the option activated must be given a standard value in this column, in order for the configuration to be valid. Each change of value by the user is immediately forwarded to the server. Possible elements:

  • Text element: Is displayed if the Has standard value option is active and grayed out and contains the reason why.
  • Drop-down list: Contains selection of parameters for configurable parameters. Drop-down list can be filtered. It can be operated if the standard value of the parameter can be changed and the option Has standard value has been selected.
    Value changes are only accepted if the drop-down list has been closed.
  • Input field: Allows the input of parameters for configurable parameters. Entry is possible if the standard value of the parameter can be changed and the option has standard value has been selected.
    Value changes are only accepted if the input field is no longer in focus.

Hide
  • Inactive: Parameter is shown.
    The Display text option must contain a value in order for the configuration to be valid.
  • Active: Parameter is hidden.
    The Display text option is emptied.

A parameter can only be hidden if it has a valid standard value (has standard value option has been selected and standard value has been selected).

If a parameter cannot be hidden, the checkbox is not selected and deactivated.

Each change to the check status is immediately forwarded to the server.

Display Text

Enter the text with which the parameter will be displayed in the report.

Only active if the Hide option has not been selected.

The input field only recognizes changes it it is not in focus.

Apply

Clicking on the button accepts settings if all options have been correctly configured.

If there are configuration errors, these are displayed next to the corresponding option.

If the configuration has been saved, this is displayed below the button.

Note: Internal parameters that control filter controls used for other parameters or limits for diagrams or markers for archive distribution have standard values and are not shown. These parameters (name starts with ChartStart, ChartEnd or Hidden or name ends with _Type) are visible in the Report Builder, but it is not recommended that these are changed.

attention Attention

Error messages for parameters:

For some parameters, the values available must be loaded via a Stored Procedure of Microsoft SQL Server. If this Stored Procedure is not successfully called up or the Stored Procedure returns an error, an error message is activated in the Report Launcher. For example, if Runtime cannot be reached, the SQL connector has not been created, etc.

For some parameters, no standard value can be issued under some circumstances, because a parameter that is to be handled beforehand does not contain a value.
For example: Time filters are based on shifts, but there is no shift data available. in this case, the issue of standard values is only possible if at least 1 shift has been written.


Data Sources

zenon Analyzer -> Report Launcher -> Manage reports -> Data Sources

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Assigns a report to the data source.

Parameters

Description

An approved data source
  • Active: An approved database is used.

The name is displayed under options. Clicking on the Search button opens the dialog to select a data source.

A user-defined data source

Configuration of a user-defined data source.

Data source type

Selection of the type via drop-down list.

Connection string

String for establishing the connection.

Establish connection via

Selection of the connection method.

Provided login information of the user who executes the report

User must state information.

It is possible to display an instruction

The information can be marked as Window login information.

Login information which are saved securely on the report server

Login information is saved on the server.

User name and password must be entered.
The following are available as an option:

  • Use of Windows authentication when connecting to the data source.
  • Assumption of the identity of the user entered after establishing a connection.

Integrated Windows security

Windows security.

No login information required

No login information is necessary.

Test Connection

Checks connection and displays a success/failure message below the button.

Apply

Applies all settings.

Change password

It can happen that the password for the data source can no longer be changed.
Procedure to allow access to the Password option again:

  1. In the A user-defined data source section, activate the No login information required property.
  2. Click on test connection.

The User name and Password properties can now be changed.


Processing Options

zenon Analyzer -> Report Launcher -> Manage reports -> Processing Options

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this window you define how the report should be filled out:

  • Configuration of the buffering and process of temporary copies.
  • Creation of the report based on a snapshot.
  • Definition of the time out at the creation of the report

Parameters

Description

Always execute this report with the most recent data
  • Active: The report is always executed with the current data.

Selection of an option for temporary copies:

  • Do not cache a temporary copy of this report.
  • Cache a temporary copy of this report. Plus configuration of the fixed duration of time that is applicable for this copy.
  • Cache a temporary copy of this report. Plus configuration of a schedule that defines the validity of the copy.

Render this report as a snapshot
  • Active: The report is rendered as a snapshot.

Can be configured as an option.

  • Create report snapshot according to the schedule.
  • Creation of a snapshot when applying the configuration.

Report timeout

Configuration of the timeout for the report.

Apply

Applies configuration.

Other topics in this chapter

Schedule


Schedule

zenon Analyzer -> Report Launcher -> Manage reports -> Processing Options -> Schedule

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of schedules for the preparation of reports.

Parameters

Description

Selection of interval

Selection of the interval:

  • Hour
  • Day
  • Week
  • Month
  • Once

Details are configured in the Schedule option.

Schedule

Configuration of the selected interval. Options available depend on the interval.

Start and end date

Configuration of the start date. The expiry date can also be established as an option.

OK

Applies settings and closes the dialog.

Cancel

Discards all changes and closes the dialog.


Cache Refresh Options

zenon Analyzer -> Report Launcher -> Manage reports -> Cache Refresh Options

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Makes it possible to create and to edit schedules for cache update.

Click on edit in order to open the dialog for creating and editing a schedule.

Parameters | Description
Description | Name for plan.
Update cache in accordance with the following schedule | Selection of the schedule. Click on button Configure in order to open the dialog for creating a schedule.
State parameter values for this cache entry | Enter the parameters for the report.
OK | Accepts input and closes dialog.
Cancel | Discards entries and closes the dialog.

info Information

This cache update function only relates to the Report Launcher and is not identical to the update cache action in the ZAMS.


Report History

zenon Analyzer -> Report Launcher -> Manage reports -> Report History

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Assembles snapshots of reports to a history.


Snapshot Options

zenon Analyzer -> Report Launcher -> Manage reports -> Snapshot Options

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Options for snapshots.

Parameters

Description

Allow report history to be created manually:

Active: Manual snapshots are possible.

Save all report snapshots in the history

Active: each snapshot is also displayed in the report history.

Schedule

Selection of the schedule or creation of a new schedule.

Number of snapshots

Define how many snapshots should be saved. Options:

  • Use default settings
  • All
  • define number


Validation of formulas

zenon Analyzer -> Report Launcher -> Validation of formulas

Formulas are validated in reports. This affects reports in the Analysis with custom formulas group and all efficiency class analysis reports that use custom formulas.

Validation errors are:

  • No data or invalid data
  • Incorrect setting of parameters.
    (Notice: Incorrect setting of parameters is not possible in ZAMS, but can occur as a result of the RDL being edited directly.)

If validation errors are discovered when calculating a formula value, this formula is not executed. No value is thus written. With time-stamp-related calculations, only the formula for the time stamp in question is not executed.

Validations occur for:

  • Calculated fields before aggregation (separate for each time stamp; prescribed by the formula)
  • Aggregation (over intervals or over the complete time period: at least one value in the time period)
  • Calculated fields after aggregation (for each interval or complete time period; prescribed by the formula)

Validations per formula:

Action | Validation
Addition | Both operands have a value.
Subtraction | Both operands have a value.
Multiplication | Both operands have a value.
Division | Both operands have a value. Divisor is not 0.
Absolute | Operand has a value.
Natural logarithm | Operand has a value > 0.
Base 10 logarithm | Operand has a value > 0.
e^x | Operand has a value.
x^n | Operand has a value. Exponent > 1.
b^x | Operand has a value. Base > 1.
Root | Operand has a value >= 0. Order > 1.
Rounding up to next integer: | Operand has a value.
Rounding down to next integer: | Operand has a value.
Rounding with precision | Operand has a value.
Sine | Operand has a value.
cosine | Operand has a value.
Tangent | Operand has a value. Cosine (value) not 0.
Cotangent | Operand has a value. Sine (value) not 0.
arc sine | Operand has a value. Value in range -1 to 1
arc cosine | Operand has a value. Value in range -1 to 1.
arc tangent | Operand has a value.
Rad -> Deg | Operand has a value.
Deg -> Rad | Operand has a value.
SUM | All operands have a value.
AVG | All operands have a value.
MIN | All operands have a value.
MAX | All operands have a value.
Base N logarithm | Operand has a value > 0. Base > 1.


Error logging

zenon Analyzer -> Report Launcher -> Error logging

zenon Analyzer uses the zenon Diagnosis Viewer logging service to collect and display error messages.

Note: The connector cannot forward messages to the Diagnosis Viewer under Windows XP. In this case, error messages are saved locally.

Other topics in this chapter

Diagnosis Viewer

Error messages, zenon Analyzer general


Diagnosis Viewer

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

All zenon modules such as Editor, Runtime, drivers, etc. as well as zenon Analyzer write messages to a joint log file. These can be read and configured with the Diagnosis Viewer program. The Diagnosis Viewer allows the reading of existing log files, online logging, saving of the current view, setting parameters for the Diagnosis Clients and the Diagnosis Server.

tutorial License information

Part of the standard license of the Editor and Runtime.

Starting the Diagnosis Viewer

The Diagnosis Viewer will be installed in the folder: %Program Files (x86)%\Common Files\COPA-DATA\STARTUP. Call it up under:

  • Windows 8: Enter "Diagnosis Viewer" on the desktop for Apps
  • Windows 7: Start/All Programs/zenon/Version Independent Tools -> Diagnosis Viewer.

The Diagnosis Viewer is only available in English.

Using IPv6

The Diagnosis Server also works with Diagnosis Clients which addresses via IPv6 addresses. For this the format of the log file has been adapted. The Diagnosis Viewer only reads the new format of the log files. If files from older zenon versions are opened (or vice versa), the IP address of the Diagnosis Client is not displayed correctly.

Driver analysis

zenon driver log all errors in the LOG files. The default folder for the LOG files is subfolder LOG in directory ProgramData, example:

%ProgramData%\COPA-DATA\LOG. LOG files are text files with a special structure.

Attention: With the default settings, a driver only logs error information. With the Diagnosis Viewer you can enhance the diagnosis level for most of the drivers to "Debug" and "Deep Debug". With this the driver also logs all other important tasks and events.

In the Diagnosis Viewer you can also:

  • Follow newly-created entries in real time
  • customize the logging settings
  • change the folder in which the LOG files are saved

Note:

  1. The Diagnosis Viewer displays all entries in UTC (coordinated world time) and not in local time.
  2. The Diagnosis Viewer does not display all columns of a LOG file per default. To display more columns activate property Add all columns with entry in the context menu of the column header.
  3. If you only use Error-Logging, the problem description is in the column Error text. For other diagnosis level the description is in the column General text.
  4. For communication problems many drivers also log error numbers which the PLC assigns to them. They are displayed in Error text or Error code or Driver error parameter (1 and 2). Hints on the meaning of error codes can be found in the driver documentation and the protocol/PLC description.
  5. At the end of your test set back the diagnosis level from Debug or Deep Debug. At Debug and Deep Debug there are a great deal of data for logging which are saved to the hard drive and which can influence your system performance. They are still logged even after you close the Diagnosis Viewer.

attention Attention

In Windows CE errors are not logged per default due to performance reasons.


General

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> General

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The zenon Diagnosis System logs error messages from zenon and zenon Analyzer. It consists of three parts:

  • Diagnosis Server: local or defined in zenon6.ini defined zenLogSrv
  • Diagnosis Clients: all modules, drivers, services, etc. which write messages
  • Diagnosis Viewer: Analysis program

Versions

From version zenon 7.00 on the service zenLogSrv is used instead of the zenSysSrv for the diagnosis system. That means:

  • Diagnosis systems up to version 6.51 and from version 7.00 are each compatible among themselves.
  • The diagnosis mechanism of zenon 6.51 SP0 and zenon 7.00 SP0 are not compatible.
Compatibility | Diagnosis Server 6.51 SP0 and earlier | Diagnosis Server 7.00 SP0 and higher
Diagnosis Client 6.51 SP0 and earlier | compatible | incompatible
Diagnosis Viewer 6.51 SP0 and earlier | compatible | incompatible
Diagnosis Client 7.00 SP0 and higher | incompatible | compatible
Diagnosis Viewer 7.00 SP0 and higher | incompatible | compatible

With the Diagnosis Viewer version 7.00 SP0 and higher you can open log files which were created by Diagnosis Server version 6.51 SP0 (or earlier). It does not work the other way round.

Default ports

  • Version 7 and higher: 50780 (port of service zenLogSrv)
  • up to 6.51: 1101 (port of service zenSysSrv)

If the port cannot be opened, the service closes itself.

attention Attention

If the port to which the Diagnosis Viewer should connect is closes, then it is tried to start the local Diagnosis Server. This makes sure that local logging is carried out if no Diagnosis Server is available in the network.

Memory occupancy

Service zenLogSrv buffers log entries until they can be written in the LOG file. If the memory consumptions increases continuously by zenLogSrv, it is an indicator that the LOG file cannot be written.


Topology of the diagnosis system

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Topology of the diagnosis system

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The topology of the diagnosis system differs for versions up to 6.51 SP0 and from 7.00 SP0 on.

Topology before zenon 7.00 SP0

The diagram displays all possible connections for which zenSysSrv is responsible. Each arrow represents a network connection between the applications. All applications connect to the zenSysSrv on port 1101 regardless of whether Client and Server are on the same computer or communicate with each other via a network.

  1. The Editor sends log entries, commands and data of the Remote Transport to zenSysSrv. zenSysSrv sends the configuration of the Diagnosis Clients (Editor, Runtime, driver, Web Server, Web Client, etc.) and the Remote Transport data to the Editor.
  2. The Diagnosis Viewer sends diagnosis commands, diagnosis configurations and log entries to zenSysSrv. zenSysSrv sends diagnosis data and the Diagnosis Client configuration to the Diagnosis Viewer.
  3. zenSysSrv sends the Diagnosis Client configuration to the Diagnosis Clients. The Diagnosis Clients send log entries to zenSysSrv.

zenSysSrv reacts correspondingly to each incoming message:

  • Log entries are written in log files.
  • Remote Transport commands (start Runtime, write/read back data, etc.) are executed.
  • Diagnosis commands (set Server/Client configuration, start online logging, etc.) are executed.

Topology as of zenon 7.00 SP0

The diagram displays all possible connections for which zenSysSrv and zenLogSrv (as of version 7.00 SP0) are responsible. Each arrow represents a network connection between the applications. All applications connect to zenLogSrv on port 50780. The editor connects to zenSysSrv on port 1101. It is regardless of whether Client and Server are on the same computer or communicate with each other via a network.

  1. The Editor sends commands and data of the Remote Transport to zenSysSrv. zenSysSrv sends data of the Remote Transport to the Editor.
  2. The Editors send log entries to zenLogSrv. zenLogSrv sends the Diagnosis Client configuration to the Editor.
  3. The Diagnosis Viewer sends diagnosis commands, diagnosis configurations and log entries to zenLogSrv. zenLogSrv sends diagnosis data and the Diagnosis Client configuration to the Diagnosis Viewer.
  4. The zenSysSrv sends LOG entries to zenLogSrv. The zenLogSrv sends the Diagnosis Client configuration to the zenSysSrv.
  5. zenLogSrv sends the Diagnosis Client configuration to the Diagnosis Clients. The Diagnosis Clients send LOG entries to zenLogSrv.

The zenSysSrv reacts to: incoming Remote Transport commands.
The zenLogSrv reacts to incoming diagnosis commands and log entries

Example

IN an environment with a central Diagnosis Server the Runtime is started on a device. Based on the Runtime version the configuration is read from zenon6.ini. Versions before 7.00 SP0 read entry LOG_CONFIG from [SYS_REMOTE], later versions read this entry from [LOGGING_SYSTEM]. This configuration is used to establish a diagnosis connection. (For details see Standard procedure.) Each additional component loaded by the Runtime (driver, zenNetSrv, etc.) also establish a diagnosis connection.


Standard procedure

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Standard procedure

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

As default only error messages (errors) are sent from the Clients to the Diagnosis Server.

The Diagnosis Server saves the received messages in TXT files with a special structure. The default folder for the log files is subfolder LOG in folder ProgramData. For example: %ProgramData%\COPA-DATA \LOG.
For more information see manual Installation and Updates chapter File structure.

Note: Under Windows CE error messages are also not created per default due to resource issues.

In order to report not only error messages to the Diagnosis Server but also other information important for the diagnosis, the according settings have to be defined for the Client.

You can also configure the behavior of the Server.

Configuration

The configuration of the connection is done in zenon6.inI divided in:

  • Diagnosis Clients
  • Diagnosis Server
  • Versions to make sure that the configuration of the versions does not affect each other

The configuration of the Diagnosis Viewer also enables you to configure settings for the connection:

  • Settings of the server
  • Connection settings Diagnosis Server connection
  • Diagnosis Client
  • Diagnosis Viewer - Analysis Program

We recommend to do the configuration of the connection for Server and Client via zenon6.ini.

Procedure

The Diagnosis Server is:

  • a service at the PC.
    The service starts automatically when the operating system boots. The local service can only be started once.
  • an application under CE.
    Under CE only one process can use the port. Additionally started processes terminate themselves as the port cannot be opened. If the local configuration of the Diagnosis Server is set under CE in such a way that only the user interface is displayed (INIT=2), several processes could emerge by the Diagnosis Clients trying to start the local Diagnosis Server.

As soon as a Diagnosis Client gets active, the following steps are carried out:

  1. The Diagnosis Client reads and uses the configuration from zenon6.ini. If no configuration is available in zenon6.ini, the default configuration (Diagnose Server=localhost:50780) is used.
  2. The Diagnosis Client tries to establish a connection to the Diagnosis Server:

    Establishing successful:

    1. The diagnosis connection has been established and the log entries are sent.

    Establishing failed:

    1. The Diagnosis Client tries to start and use the local Diagnosis Server.
      On a PC it tries to start the service.
      Under CE it tries to create the process.
    2. The Diagnosis Client tries to establish a connection to the local Diagnosis Server. If it succeeds, the diagnosis connection is established and the log entries are sent.

    If it fails, no log entries are created.


Entries in zenon6.ini

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Standard procedure -> Entries in zenon6.ini

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

zenSysSrv and zenLogSrv are configured in zenon6.ini. At this it is differentiated between version 7.00 and up and versions 6.51 and earlier. With this you can configure old and new Diagnosis Clients and Diagnosis Servers independent of each other on one device. For example, the LOG entries of old Diagnosis Clients are diverted, without the LOG entries of new clients being affected.

Diagnosis Server before Version 7.00 SP0

INI entry

Description

[SYS_REMOTE]

Section in zenon6.ini.

Contains parameters for zenSysSrv (Remote Transport and Diagnosis Server).

LOGDirectory=

Defines folder for the LOG files.

If there is no entry, the LOG folder in the %ProgramData% folder is used as a default value.

Example:
LOGDirectory= %ProgramData%\COPA-DATA\zenon651\LOG

CONFIG=

Configuration string for the Diagnosis Server and zenSysSrv . Remote Transport and the diagnosis system use the same server configuration up to and including version 6.51 SP0. The string consists of the following parts: DEVICE=[Device];HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: Sets the communication type used.
    TCP/IP and serial are available.
  • HOST: is set to the computer name of the Diagnosis Server.
  • PORT: states the port to be used.
  • TIMEOUT: Provides the timeout time for the connection is seconds.
  • BAUD: provides the connection speed of a serial connection.

PC configuration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=1101
  • TIMEOUT=10

CE configuration:

  • DEVICE=COM1
  • BAUD=115200

LOGMinFreeDiskSpace=

Defines minimum memory (in MB) that must be available on the hard drive. LOG files are deleted before this value is gone below.

Default: 1024

LOGMaxUsedDiskSpace=

Defines the maximum memory on the hard drive in MB used for LOG files. LOG files are deleted if this value is exceeded.

Default: 1024

LOGMinUsedDiskSpace=

Defines memory on the hard drive (in MB) that is used even if there are no LOG files.

Default: 5

LOGLogLifeTime=

Defines the lifecycle of the LOG files in seconds. Older LOG files are deleted.

Default: 1209600 (corresponds to 14 days)

LOGImageCnt=

Defines the number of LOG entries, after which all incremental LOG files are written.

  • 0: inactive (default)

LOGLogUpdateTime=

Number of milliseconds, after which the LOG entries received are written to a LOG file.

Default: 2000

LOGMaxBufferedRecs=

Defines the number of LOG entries that are buffered if they cannot be written to files.

Default: 10240

LOGMaxLogFileSize=

Maximal size of a log file in bytes. If a log file reaches this size, it is closed and a new log file is created.

Default: 5242880 (corresponds to 5 MB)

LOGCheckDiskTime=

Defines the interval in seconds, in which the memory occupied by LOG files is checked.

Default: 60

INIT=

Action when starting the application with Windows CE:

  • 0: end immediately
  • 1 (or other value greater than 2): Open listening port in minimize to system tray
  • 2: only display surface

Default: 1

Note: As part of the separation of zenSysServ and zenLogServ for zenon 7.00, this default value was also changed for other versions. The default value was previously 2.

Diagnosis Server from Version 7.00 SP0

INI entry

Description

[LOGGING_SYSTEM]

Section in zenon6.ini.

Contains parameters for the Diagnosis Server. Only affects zenLogSrv and has no effect on zenSysSrv.

LOGDirectory=

Defines the folder for the LOG files.

If there is no entry, the following is used as a standard value:

  • The path extracted from the Registry,
    for example: %ProgramData%\COPA-DATA\LOG
  • the LOG folder in the ProgramData folder of the zenLogSrv, if no path is defined in the registry,
    e. g. %ProgramData%\COPA-DATA\zenon700\LOG

CONFIG=

Configuration string for the Diagnosis Server. The string consists of the following parts: DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: Sets the communication type used and must always be set to TCP/IP
  • HOST: is set to the computer name of the Diagnosis Server.
  • PORT: states the port to be used.
  • TIMEOUT: Provides the timeout time for the connection is seconds.

Configuration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=50780
  • TIMEOUT=10

LOGMinFreeDiskSpace=

Defines minimum memory (in MB) that must be available on the hard drive. LOG files are deleted before this value is gone below.

Default: 1024

LOGMaxUsedDiskSpace=

Defines the maximum memory on the hard drive in MB used for LOG files. LOG files are deleted if this value is exceeded.

Default: 1024

LOGMinUsedDiskSpace=

Defines memory on the hard drive (in MB) that is used even if there are no LOG files.

Default: 5

LOGLogLifeTime=

Defines the lifecycle of the LOG files in seconds. Older LOG files are deleted.

Default: 1209600 (corresponds to 14 days)

LOGImageCnt=

Defines the number of LOG entries, after which all incremental LOG files are written.

Default: 0

LOGLogUpdateTime=

Number of milliseconds, after which the LOG entries received are written to a LOG file.

Default: 2000

LOGMaxBufferedRecs=

Defines the number of LOG entries that are buffered if they cannot be written to files.

Default: 10240

LOGMaxLogFileSize=

Maximal size of a log file in bytes. If a log file reaches this size, it is closed and a new log file is created.

Default: 5242880 (corresponds to 5 MB)

LOGCheckDiskTime=

Defines the interval in seconds, in which the memory occupied by LOG files is checked.

Default: 60

INIT=

Action when starting the application with Windows CE:

  • 0: end immediately
  • 1 (or other value greater than 2): Open listening port in minimize to system tray
  • 2: only display surface

Default: 1

Diagnosis Client before Version 7.00 SP0:

INI entry

Description

[SYS_REMOTE]

Section in zenon6.ini.

Contains parameters for the Diagnosis Client.

LOG_CONFIG=

A configuration string for the Diagnosis Client is stored here. The string consists of the following parts: DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: Sets the communication type used and must always be set to TCP/IP
  • HOST: is set to the computer name of the Diagnosis Server.
  • PORT: states the port to be used.
  • TIMEOUT: Provides the timeout time for the connection is seconds.

Configuration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=1101
  • TIMEOUT=10

Diagnosis Client from Version 7.00 SP0

INI entry

Description

[LOGGING_SYSTEM]

Section in zenon6.ini.

Contains parameters for the Diagnosis Client.

LOG_CONFIG=

A configuration string for the Diagnosis Client is stored here. The string consists of the following parts:

DEVICE=TCP/IP;HOST=[Hostname];PORT=[Port];TIMEOUT=[Timeout]

  • DEVICE: Sets the communication type used and must always be set to TCP/IP
  • HOST: is set to the computer name of the Diagnosis Server.
  • PORT: states the port to be used.
  • TIMEOUT: Provides the timeout time for the connection is seconds.

Configuration:

  • DEVICE=TCP/IP
  • HOST=localhost
  • PORT=50780
  • TIMEOUT=10

Note:

INIT under CE

Under Windows CE we urgently recommend to not set entry INIT= (in section [LOGGING_SYSTEM] or [SYS_REMOTE]) to value 2.

Reason: The value 2 means that both SysSrvCE and LogSrvCE only display the user interface and do not open the listening port.
If now a Diagnosis Client wants to establish a connection, it will fail. As in this case the Diagnosis Clients start process LogSrvCE and the process does not open the port, each Diagnosis Client starts such a process. This leads to several parallel LogSrvCE processes and to a delay in starting the Diagnosis Clients as it waits for the timeout of the connection while establishing the diagnosis connection.

zenLogSrv on a system with different versions

If zenLogSrv is used on a system with different versions as a central local diagnosis server, the entry LOG_CONFIG in the [SYS_REMOTE] must be as follows:
DEVICE=TCP/IP;HOST=localhost;PORT=5780;TIMEOUT=10

Reason: Older clients then use zenLogSrv as the Diagnosis Server. New clients do this automatically. This service is switched on automatically on the PC when the system is started; it must be started manually with CE.

Attention: If the port cannot be reached, older clients start zenSysSrv and retry connecting to it.


Windows CE

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Standard procedure -> Windows CE

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Under Windows CE the Diagnosis Server is started as an application.

At the configuration of the connection consider the recommendation for parameter INIT:

Under Windows CE we urgently recommend to not set entry INIT= (in section [LOGGING_SYSTEM] or [SYS_REMOTE]) to value 2.

Reason: The value 2 means that both SysSrvCE and LogSrvCE only display the user interface and do not open the listening port.
If now a Diagnosis Client wants to establish a connection, it will fail. As in this case the Diagnosis Clients start process LogSrvCE and the process does not open the port, each Diagnosis Client starts such a process. This leads to several parallel LogSrvCE processes and to a delay in starting the Diagnosis Clients as it waits for the timeout of the connection while establishing the diagnosis connection.

User interface under CE

Transport Service (zenSysSrv)

Parameters

Description

Start

Opens the Listening port and enables zenSysSrv to receive Remote Transport commands.

Browse

Opens the dialog for browsing the file system.

Stop

Terminates the receiving of Remote Transport commands and closes the Listening port.

Configuration

Selection of an existing server configuration from drop-down list. New connections cannot be configured. See section Entries in zenon6.ini for the configuration of the connection.
Available are:

  • Configuration from zenon6.ini
  • Standard configuration for TCP/IP
  • Standard configuration for COM1 to COM4

Hide

Minimizes the user interface into the task bar.

Exit

Terminates the application and closes the Listening port if necessary.

X
(button top right)

Minimizes the user interface into the task bar.

Logging Service (zenLogSrv)

Parameters

Description

Start

Opens the Listening port and enables zenLogSrv to receive log entries.

Stop

Terminates the receiving of log entries and closes the Listening port.

Configuration

Selection of an existing configuration from drop-down list. New connections cannot be configured. See section Entries in zenon6.ini for the configuration of the connection.
Available are:

  • Configuration from zenon6.ini
  • Standard configuration for TCP/IP

Hide

Minimizes the user interface into the task bar.

Exit

Terminates the application and closes the Listening port if necessary.

X
(button top right)

Minimizes the user interface into the task bar.


Diagnosis Server

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Diagnosis Server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Diagnosis Server:

  • Creates and manages log files.
  • The Server is:
    • implemented from zenon 7.00 on as zenLogSrv
    • up until zenon 6.51 integrated in the zenSysSrv.
  • The configuration of the server is read from the zenon6.ini.
  • The server writes the received log data into the log file.
  • The saving location for the files has to be configured. Standard: %ProgramData%\COPA-DATA\LOG\
  • Log files are named after the following fashion LOG<YYMMTThhmmss>.txt.
  • The server is multi client able. Several evaluations can connect to the server simultaneously.
  • It is possible to connect to the server online, to see the current logging messages.
  • It is possible to connect to diagnosis servers other than the local and to execute the same tasks (configuring server, configuring clients, online logging) as on the local server.
  • The parameters of the current server (with which the Diagnosis Viewer is connected) can be modified. If a modification of another diagnosis server is needed, the server connection can be changed in the menu under File – Connect to….
  • The menu entry Settings – Server configuration is only available, if online logging is not used at the moment.


System integrity monitoring

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Diagnosis Server -> System integrity monitoring

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

At the start of the Runtime a monitoring thread with high priority is also started. The monitoring thread checks critical parameters every ten seconds and writes corresponding warnings or errors in module Supervisor of the Diagnosis Server.

The following parameters are monitored.

Parameters | Limit
Warning threshold for used handles | > 5000
Error threshold for used handles | > 9000
Warning threshold for used GDI objects | > 5000
Error threshold for used GDI objects | > 9000
Warning threshold for CPU use for the main thread | > 70 %
Error threshold for CPU use for the main thread | > 90 %
Warning threshold for total CPU use | > 70 %
Warning threshold for total CPU use | > 90 %
Warning threshold for free main memory | < 30 %
Error threshold for free main memory | < 10 %
Warning threshold for OnTimer in the main frame | > 1000 ms
Error threshold for OnTimer in the main frame | > 5000 ms


Settings of the server

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Diagnosis Server -> Settings of the server

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Diagnosis Server can be configured via entries in file zenon6.ini or via dialog Server configuration in the Diagnosis Client. We recommend to do the settings in file zenon6.ini.

Configuration via zenon6.ini

See section Entries in zenon6.ini.

Configuration via dialog

To configure the Diagnosis Server via the dialog:

  1. start the Diagnosis Viewer
  2. open entry File Connect to....
  3. configure the desired Server
    (Take care of the correct port selection depending on the version!)
  4. open entry Settings -> Server configuration
  5. configure the events which should be logged
  6. Close the dialog by clicking on OK.

Note: All changes are written to zenon6.ini when the dialog is confirmed.

Configuration of the events which should be logged by the Diagnosis Viewer:

Parameters | Description
Modules | Selection of the modules which you want to configure.
Messagelevel | Selection of the events which should be logged. Default: Errors
LOGImageCnt | Number of records, after which all incremental fields will be written. Default: 0 (not active)
LOGMinFreeDiskSpace | It is continuously checked, if less than the configured minimal free disk space is available. The oldest log files are deleted. Minimal free disk space in MB, before log files are deleted. Default: 1024 MB
LOGMaxUsedDiskSpace | Maximal used disk space for the log in MB. Default: 1024 MB
LOGMinUsedDiskSpace | Minimal used disk space in MB independent whether LOGMinFreeDiskSpace is under-run. Default: 5 MB
LOGLogUpdateTime | Time in ms, after which the received entries are saved. Default: 2000 ms
LOGMaxBufferedRecs | The server buffers the contents of all incremental log fields for diverse applications, in order to be able to write images of them into the log file. With the start of a log file and after configurable number of log entries a complete image for all addresses is written into the log file. Received data are written to the log files. The entry is done via temporary buffer. It can be configured whether the data should be written immediately or delayed. Number of buffered entries if they cannot be saved. Default: 10240
LOGMaxLogFileSize | The server writes the received log data into the log file. If this log file reaches the configured size, a new file is started. Maximal size of a single log file in bytes. Default: 5 MB
LOGDirectory | Folder in which the log files are written. Default: %ProgramData%\COPA-DATA\LOG\
LOGLogLifeTime | It is continuously checked, if the lifetime of the log files is exceeded. The oldest log files are deleted. Number of seconds to keep the log files. Default: 14 days
LOGCheckDiskTime | Time in sec, in which the used disk space id checked. Default: 60 s
Message level for all modules | Settings are taken over for all modules.
Default values | Restore default settings.
Accept | Take over settings for this module.
Cancel | Discards changes and closes dialog.
OK | Applies changes and closes dialog.


Diagnosis Client

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Diagnosis Client

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

All programs which create log entries are Diagnosis Clients. These log entries are sent to the Diagnosis Server via TCP/IP. Server computer and port are read - dependent on the used version - from the local zenon6.ini and contacted. If the connection fails the following procedure is carried out cyclically:

  • If the Diagnosis Server cannot be reached, a attempt to reconnect is made every 500 ms.
  • If no connection could be established after half the timeout time, the system tries to start the service zenSysSrv or zenLogSrv.

The settings are configured via entry LOG_CONFIG= in section [SYS_REMOTE] (up to 6.51) or [LOGGING_SYSTEM] (from 7.00).

Configuration Diagnosis Client

To configure the Diagnosis Client via the dialog:

  1. start the Diagnosis Viewer
  2. open entry Settings -> Client configuration
    (only available if logging is inactive)
  3. highlight a Client
  4. Click on List of parameters
  5. The dialog for configuration is opened
  6. configure the Client
  7. Close the dialog by clicking on OK.
  8. repeat the procedure for other Clients if necessary

Client list

Parameters | Description
Clients | Lists all available Clients.
Refresh | Updates the list of the Clients.
List of parameters | Opens the dialog for configuring the selected Client.
Close | Closes the dialog.

Configure Client

The available standard modules:

Parameters

Description

Modules

Selection of the modules which you want to configure.

The list is made up of standard modules and modules dependent on the respective client.

  • General: General messages
  • Net: Network messages
  • Proxy: Messages of the zenon Proxy
  • Db: Messages from ZenDbSrv
  • SysSrv: Messages from ZenSysSrv
  • Driver: Messages from a driver
  • LOG: Messages from logging
  • SAT: SICAM 230 specific messages

Messagelevel

Type of information which should be logged.

All

Selects all.

None

Deselects all.

Message Level for all Modules

Assigns highlighted message levels to all modules.

Max Buffered records

Number of records to be buffered if no connection to the server is established.
Default: 256

OK

Applies all changes and closes dialog.

Cancel

Discards all changes and closes the dialog.

Accept

Applies all changes. The dialog remains open.

Default values

Enters the default values.


Diagnosis Viewer - Analysis Program

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Diagnosis Viewer - Analysis Program

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Diagnosis Viewer is used to display the log data. It connects to the Diagnosis Server in order to display data online or read back historic log files. Log files contain not only the log data, additional information which is important for the analysis such as column headings are also saved in them.

To display a log file:

  1. select File -> Open
  2. the dialog for selecting a log file is opened with focus on the configured default folder
  3. select the desired file
  4. the log file is displayed

  5. Double click an entry to open the detail view

Recognizing queue overflow at driver

If messages of a driver are deleted because of queue overflow, the Diagnosis Client and the Diagnosis Server set a marker in the new entry when writing a new entry for all activated modules that older entries were deleted from the queue. The overflow recognitions contained in the opened log files are counted:

Parameters | Description
Column Record version | This column must be part of the column selection. It shows the version of the data record. Version 8x tags overflows.
Counter 82 | 8 refers to overflow, 2 refers to the concerned version of the data record.
Status line queue overflows | If status bar is active, the number of overflows is displayed there.

Note: Not all entries written in the log file are displayed. If a not displayed log data record is tagged with an overflow, it will be displayed at the next visualized data record of this client. If several not displayed entries in a row are tagged with an overflow, the counter in the status bar can deviate from the number of data records with overflow tags.


Global settings

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Diagnosis Viewer - Analysis Program -> Global settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The entries are in the English language.

Parameters

Description

File

Commands in menu File.

Open

Opens dialog for selecting a log file saved in TXT format. Each newly opened log file is displayed in its own window.

Open to active document

Each new log file is added to the active window.

Close

Closes the active window.

Save

Saves the log files of the active window.

Save as

Saves the current view of the active window (e.g. filter settings) to a file to be selected.

Remote Download

Only available, if a connection to a Remote Diagnosis Server exists. Enables the download of logging files of the Remote Server to the local log folder. A subdirectory with the name of the PC is created. Only file, which have changed or which are new, are available.

Connect to

Opens the dialog for the Connection selection.

Online

Activates the online error view.
If online logging is started, all incoming entries are displayed. The same filter dialog as for reading files can also be set here.

Difference: If no log connection is selected, all incoming log entries will be displayed, otherwise only the ones from the selected clients.

If the filter of the log connection is modified, all entries not fulfilling the filter criteria will be lost. (Logging file nevertheless is created and all entries are saved.) Displayed entries can be saved.

Offline

Deactivates the online error view. (Default)

Exit

Closes the Diagnosis Viewer.


Connection settings Diagnosis Server connection

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Diagnosis Viewer - Analysis Program -> Global settings -> Connection settings Diagnosis Server connection

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com
Connection settings Diagnosis Server connection

The Diagnosis Viewer automatically connects to a selected standard Server at the start. If no standard server is defined, localhost is used as standard server. The Server configuration can also be done via zenon6.ini (recommended).

Select Diagnosis Server

Click on File -> Connect to... to open the dialog to select a server:

Parameters

Description

List Server

Lists all configured Servers and displays them:

  • Status
  • Name
  • Port
  • Timeout

OK

Applies settings and closes the dialog.

Cancel

Discards settings and closes the dialog.

New Server

Opens the dialog for configuring a new Server.

Delete Server

Selected Server entry is deleted from the list.

Edit Server

Opens the dialog for configuring the selected Server.

Connect to

Establishes a connection to the selected Server.

As default

Selected server becomes the standard server.

Create and edit Diagnosis Server

Click on New Server or Edit Server in dialog Diagnosis Server connection to open the dialog for configuring the Server:

Parameters | Description
Server name | Name of the PC to which to connect. The following must run on the PC: up to version 6.51: zenSysSrv from version 7.00: zenLogSrv
Port | Port of the service on the target computer: up to version 6.51: 1101 from version 7.00 on: 50780
Timeout | Time in seconds to wait for a response from the Sysservice. Default: 10 s
OK | Applies settings and closes the dialog.
Cancel | Discards settings and closes the dialog.


Column settings

Column settings

You can select the columns that are to be displayed in the menu under Settings -> Column settings. The selection is only applicable for the time period in which the file is opened. Column settings can however be saved as profiles.

Parameters | Description
available | available columns
selected | Columns which are displayed
> | adds columns selected at "available" to "selected"
>> | adds all available columns at "available" to "selected"
< | removes selected columns from "selected"
<< | removes all available columns from "selected"
^ | sorts selected entries one level higher (multi-select is possible)
v | sorts selected entries one level lower (multi-select is possible)
OK | Applies settings and closes the dialog.
Cancel | Discards settings and closes the dialog.

Columns can also be configured via the context menu:

Parameters | Description
Add all columns with entry | Adds all columns which contain entries.
Remove Column | Hides the selected column.
Remove all empty columns | Hides all columns which do not contain entries.
Column width automatic | The width of the selected column is automatically adjusted to the longest entry
All columns widths automatic | The width of all columns is automatically adjusted to the longest entry


Possibilities of Filtering

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Possibilities of Filtering

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To define filters open the corresponding filter dialog via the corresponding symbol or the tab of the filter.

Symbol bar filter

To use the symbol bar, you must activate it in menu View via menu item Icon bar.

Symbol | Tool tip | Description
1 | Change pre-filter settings | Opens dialog with five tabs for defining filters.
2 | Change pre-filter for IP-ProcessID-LogID | Opens tab IP address - Process No - Log ID.
3 | Change pre-filter for modules | Opens tab Modules.
4 | Change pre-filter for additional columns | Opens tab Additional columns.
5 | Change pre-filter for time interval | Opens tab Time interval.
6 | Change pre-filter for coloring | Opens tab Colors.

Filter dialog

Tabs | Description
IP-ProcessID-LogID | Opens tab IP address - Process No - Log ID for configuring the connection which should be logged.
Modules | Opens tab Modules for the modules which should be logged.
Additional columns | Opens tab Additional columns for selecting additional columns which should be displayed.
Time interval | Opens tab Time interval for defining time filter.
Colors | Opens tab Colors for selecting the color-coding of information.


IP address - Process No - Log ID

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Possibilities of Filtering -> IP address - Process No - Log ID

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the connections and processes which should be displayed.

Parameters | Description
available | List of available connections.
selected | List of selected connections.
Pfeiltasten | Add selected (>) or all (>>) connections to list selected or removes them from the list (< or <<).
OK | Applies all changes on all tabs and closes the dialog.
Abbrechen | Discards all changes on all tabs and closes the dialog.


Modules

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Possibilities of Filtering -> Modules

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the modules which should be displayed.

Parameters | Description
Module filter active | Active: It is filtered on modules. With this only log data records are displayed which are assigned to a selected module.
available | Available modules.
selected | Selected modules.
Cursor keys | Add selected (>) or all (>>) connections to list selected or removes them from the list (< or <<).
OK | Applies all changes on all tabs and closes the dialog.
Cancel | Discards all changes on all tabs and closes the dialog.


Additional columns

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Possibilities of Filtering -> Additional columns

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the columns which should be displayed additionally.

Parameters | Description
available | List of the available columns. All field definitions existing in the file are displayed.
selected | List of the selected columns.
Cursor keys | Add selected (>) or all (>>) connections to list selected or removes them from the list (< or <<).
OK | Applies all changes on all tabs and closes the dialog.
Cancel | Discards all changes on all tabs and closes the dialog.


Time interval

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Possibilities of Filtering -> Time interval

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the time filter for displaying the entries.

Parameters | Description
Start time: | Selection of the date and point in time from which entries should be displayed. Default: actual date
End time: | Selection of the date and point in time up to which entries should be displayed. Default: actual date
Reset time interval | Sets filter back to default value.
OK | Applies all changes on all tabs and closes the dialog.
Cancel | Discards all changes on all tabs and closes the dialog.


Colors

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Possibilities of Filtering -> Colors

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the color-coding of the information.

Parameters | Description
Colors for: | Selection of the color
IP address | Active: Different IP addresses are colored differently.
Modules | Active: Different modules are colored differently.
Log connection | Active: Different names of the log connection are colored differently.
no colors | Active: Entries are not colored.
OK | Applies all changes on all tabs and closes the dialog.
Cancel | Discards all changes on all tabs and closes the dialog.


Reading the log files

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Reading the log files

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

One or more log files can be opened in an analysis at the same time. A pre-filter has to be set to limit the display. This is possible with five property pages. This filter can be modifies later on. If the filter is set, only the entries fulfilling these filter criteria are displayed. The entries are listed chronologically.

Filter columns

Another filter possibility is available with the filter columns. Filter criteria can be entered for each column in the input field below the column header. The fields support Regular Expressions, so that also complex filter criteria can be defined. The list can be sorted ascending or descending by clicking the column headers. Displayed entries can be saved. Fields to be displayed can be selected using the Settings -> Column settings menu entry.

Standard fields in the log file:

ID | Parameters | Description
i | IP address | IP address. These fields identify the clients and allow the message to be assigned.
i | Log ID | entry ID These fields identify the clients and allow the message to be assigned.
i | Message Level | Name of the message level for which the message was entered.
i | Module | Name of the module, which entered the message.
i | Process ID | ID of the project. These fields identify the clients and allow the message to be assigned.
i | Record type | Type of entry.
i | Record version | Version number of the entry.
i | Thread ID | ID of the thread, from which the message was entered.
i | Timestamp | Time of the message in UTC.

Optional fields with fix ID.

ID | Constant | Description
1 | Name of log connection | Name of logging connection
2 | Thread name | Name of the threads.
3 | Name of source files | Name of the source file.
4 | Source line | Source line
5 | Assert condition | Assert condition
6 | Computer name | Computer name
7 | Function name | Function name
8 | Project name | Project name
9 | Project GUID | GUID of the project.
10 | Project path | Project path
11 | Sent Data | Sent data
12 | Received data | Received data
13 | no. serial interface | Number of the serial interface.
14 | Baudrate | Baud rate
15 | dtr setting | DTR setting.
16 | rts setting | RTS setting.
17 | Serial char. length | Serial character length
18 | Parity | Parity
19 | No. stopbits | Number of stop bits
20 | CTS | CTS.
21 | dsr | DSR
22 | dsr sensitivity | DSR sensitivity.
23 | Network port no. | Port number in the network.
24 | Server name | Server name.
25 | Standby name | Name of standby server
26 | Client name | Client name.
27 | Server IP | IP address server.
28 | Standby IP | IP address standby.
29 | Client IP | IP address client.
30 | Binary buffer | Binary buffer.
31 | Pointer | Pointer
32 | Class name | Class name
33 | Error code | Error code:
34 | DLL instance handle | DLL instance handle
35 | DLL name | DLL name
36 | Driver error parameter 1 | Driver error parameter 1
37 | Driver error parameter 2 | Driver error parameter 2
38 | Trace Message | Trace message
39 | Errortext | Error text
40 | Error file name | Name of error file.
41 | Success condition | Condition for success
42 | Value if successful | Value when successful
43 | Net adress | Net address:
44 | Datablock | Data block.
45 | Offset | Offset:
46 | Bit number | Bit number
47 | Area in PLC | Area in the PLC.
48 | Communication direction | Shows the direction of the communication in a string.
49 | General text | General text
50 | Main version no. | Number of main version.
51 | Sub version no. | Number of sub-version.
52 | Build no. | Build number.
53 | Servicepack | Service Pack.
54 | Hotfix no. | Hotfix number
55 | Sending client | Client, which sent the command
56 | Target client for command | Client that is the target of the command.
57 | Database no. | Number of database.
58 | Datapoint no. | Datapoint number (channel number)
59 | Datapoint value | Value of datapoint
60 | Datapoint status | Status of datapoint
61 | Datapoint timestamp | Time stamp of datapoint in seconds
62 | Duration in ms | Error wait time in milliseconds.
63 | Number, counter | number, counter.


Structure of the log file

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Structure of the log file

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Log files are ANSI text files. The single fields are separated by tabs. The final character is CR+LF. So, the Notepad can be opened to display the files.

Log files contain information sequentially, not chronologically sorted.


Message levels

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Structure of the log file -> Message levels

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Eight groups exist for the subdivision of log messages. They are bit coded and therefore can be combined.

1 | Error messages
2 | Warnings
4 | Success message
8 | TRACE
16 | ASSERT
32 | Log messages
64 | Debug
128 | Extended debug


Search function

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Structure of the log file -> Search function

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

With View/Find the current window can be searched. All hits are marked.


Profiles

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Structure of the log file -> Profiles

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Column settings can be saved as profiles.

To save profiles:

  1. Enter a name into the filed in the toolbar.
  2. Click on the symbol with the disk.

To load profiles:

  1. Select a saved profile from the drop-down list.
  2. Click on the symbol with the disk.

The profiles are saved as a *.lvs file.


Handling of errors and messages for the Diagnosis Viewer

zenon Analyzer -> Report Launcher -> Error logging -> Diagnosis Viewer -> Handling of errors and messages for the Diagnosis Viewer

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Error

Error

Possible causes

The port cannot be opened.
  • Another application uses the port.
    Check via "netstat".
  • The ports for entries
    [SYS_REMOTE] CONFIG and
    [LOGGING_SYSTEM] CONFIG
    are identical. zenLogSrv and zenSysSrv then try to open the same port.

Diagnosis Clients do not start the zenLogSrv.
  • zenAdminSrv was ended. Without it the service cannot be started.
  • zenLogSrv is not registered as a service at the PC. In this case enter the following in the command line: zenLogSrv.exe –Service
  • Diagnosis Clients are not of version 7.00 SP0 or higher. The zenLogSrv is only supported from this version on.
  • Under Windows CE: The individual components (Runtime, SysSrvCE, LogSrvCE) are located in different folders. They must be located in the same folder. Otherwise the components do not find one another.

Under CE many processes are created by SysSrvCE.exe or LogSrvCE.exe.
  • One of the two entries in zenon6.ini
    [SYS_REMOTE] INIT or
    [LOGGING_SYSTEM] INIT
    has the value 2.
    As a result the application only displays the user interface and does not open the Listening port. Each Diagnosis Client then tries to start the process as it cannot connect to the Diagnosis Server.

Several processes crash.

(Unhandled Exceptions of the Diagnosis Server at receiving log messages or configuration commands or of the Diagnosis Client and Diagnosis Viewer during booting or during receiving the configuration)
  • The versions do not match. Diagnosis Clients, Diagnosis Server and Diagnosis Viewer must either all have version 7.00 SP0 or higher or all version 6.51 SP0 or earlier (see Compatibility).

LOG entries

Entry

Description

SysSrv received not supported network message!

zenSysSrv received a network telegram which is not supported. Example: Log entries.

LogSrv received not supported network message!

zenLogSrv received a network telegram which is not supported. Example: Remote Transport commands

Could not open listening port. Server will be stopped.

The zenLogSrv or the zenSysSrv could not open its Listening port. The error message is logged as follows:

  • zenLogSrv and zenSysSrv on the PC:
    Entry in the Windows event display.
  • zenSysSrv under CE:
    Message box for the user and log entry to the Diagnosis Server.
  • zenLogSrv under CE:
    Message box for the user.

The following log entries are assigned to different systems. The first part of the messages states whether service or Client are effected:

  • SysSrv: zenSysSrv
  • SysCli: Client for zenSysSrv
  • LogSrv: zenLogSrv
  • LogCli: Diagnosis Client
Entry | Description
[SysSrv/LogSrv/SysCli/LogCli] Info InitString [String] | A network connection has been initialized with the displayed configuration string. Server opens ports and Clients connect to the Server.
[SysSrv/LogSrv/SysCli/LogCli] WINSOCK ERROR | An exception occurred during a network operation. The details are also displayed.
[SysSrv/LogSrv] Accept Failed! | An incoming connection from a Client could not be accepted.
[SysSrv/LogSrv/SysCli/ LogCli] Write Faild | Not all data which should be sent could be sent. The number of the sent bytes and the number of the bytes which should be sent is displayed.
[SysSrv/LogSrv] Client [String] in List Delete! | The Client log off from the Server.
[SysSrv/LogSrv] Client [String] in List Insert | The Client log on to the Server.


Error messages, zenon Analyzer general

zenon Analyzer -> Report Launcher -> Error logging -> Error messages, zenon Analyzer general

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Report Launcher

General

Message | Description
Javascript error message: Error 500 | Possible cause: Variable name contains two or more consecutive spaces.

Report Launcher LOG

Entry

Level

Description

Application_Error: [Fehlerinformationen]

ERRORS

An error has triggered the ASP.Net application error event.

Report Launcher Application Start

DEBUG

The ASP.Net web application is being started up.

Application_AuthenticateRequest: User=[Benutzername], HTTP Method=[HTTP-Methode], URL=[URL]

DEEPDEBUG

An authentication query was received.

Application_BeginRequest: User=[Benutzername], HTTP Method=[HTTP-Methode], URL=[URL]

DEEPDEBUG

An HTTP query was received.

Application_EndRequest: User=[Benutzername], HTTP Method=[HTTP-Methode], URL=[URL]

DEEPDEBUG

An HTTP query was handled.

TRACE for [Komponente]: [Meldung]

Depending on the trace level:

  • ALL
  • ERRORS
  • WARNINGS
  • DEBUG
  • DEEPDebug

A trace message was received.

WebService method „[Methode]" called with [Parameterliste]

DEEPDEBUG

A WebService method of the Reporting Services Web Service end points is being called up.

WebService method „[Methode]" returned [Rückgabewert]

DEEPDEBUG

A WebService method of the Reporting Services Web Service end points has provided a return value.

WebService method „[Methode]" returned [Rückgabewert] and set [Output-Parameterliste]

DEEPDEBUG

A WebService method of the Reporting Services Web Service end points has provided a return value and set an output parameter.

Eventlog entry for [Eventlog-ID]: [Meldung]

Depending on the event log type:

  • ERRORS
  • WARNINGS
  • DEBUG
  • DEEPDebug

An event log message was received.

Exception caught in method „[Methodenname]" of type „[Klasenname inklusive Namespace]": [Exception-Dump]

ERRORS

An exception was caught.

ZAMS

All messages of the output window are sent to the zenLogSrv.

Connector container

All message box messages that lead to the zrsConnector.exe process being ended are logged as ERRORS. In addition, the following messages are saved:

Entry | Level | Description
The logging connection could not be established! | ERRORS | Log connection could not be established.
The logging functions could not be loaded! | ERRORS | The necessary functions could not be loaded from the DLLs.
The logging helper DLL could not be loaded! | ERRORS | The necessary DLLs could not be loaded.
Client [IP-Adresse & Port] [accepted/processed] | DEBUG | Client connection was accepted or handled.
Using connector version [Version] | DEBUG | Version number was set for a query.
The required connector „[Connector]" could not be loaded. Errorcode=[HEX-Fehlercode], Errortext=[Fehlertext] | ERRORS | The requested connector could not be loaded.
The required connector „[Connector]" has been loaded. | DEBUG | The requested connector was loaded.
zenonV6: Query for [Anfragetyp] received | DEBUG | Receive query.
zenonV6: Query for [Anfragetyp] resulted in error. Errorcode=[HEX-Fehlercode], Errortext=[Fehlertext] | ERRORS | Query has triggered an error.
zenonV6: Query for [Anfragetyp] processed | DEBUG | Query has been handled successfully.
zenonV6: Query shift is not supported | ERRORS | Query not supported.
zenonV6: Query type is not supported | ERRORS | Query not supported.

zrsLicSrv

All entries that were previously sent to EventLog are logged. ERRORS are only sent to EventLog, unless EXTENDEDLOG is set in zenAnalyzer.ini. This flag has no effect on the sending of messages to the zenLogSrv.

Entry | Level | Description
Client [IP-Adresse & Port] [accepted/processed] | DEBUG | Client connection was accepted or handled.
The logging connection could not be established! | ERRORS | Log connection could not be established
The logging functions could not be loaded! | ERRORS | The necessary functions could not be loaded from the DLLs.
The logging helper DLL could not be loaded! | ERRORS | The necessary DLLs could not be loaded.
Command [Kommando mit Parametern] has been processed. | DEBUG | A query was processed. (this message is written by every query type)
Deprecated command [Kommando mit Parametern] has been processed. | DEBUG | An obsolete inquiry was received and responded to with "negative" (always negative, because it is an obsolete inquiry).

zrsProvider

The following new log messages have been added:

Entry | Level | Description
The cryptographic service provider could not be initialized! | ERRORS | Provider for hash could not be initialized
Reading the hash data failed! | ERRORS | Reading of hash data failed.
The data could not be hashed! | ERRORS | Data hashing failed.
The hash object could not be created! | ERRORS | Hash object could not be created.
The cryptographic service provider is not usable! | ERRORS | Provider for hash cannot be used.
Domain [Name] released. | DEBUG | Domain approved
Reading data for [domain/project] [Name]. | DEBUG | Start of loading of data for the domain or project
Datasource could not be opened. Errorcode=[HEX-Fehlercode] | ERRORS | Data source could not be opened.
Session not be opened. Errorcode=[HEX-Fehlercode] | ERRORS | Session could not be opened.
[Anzahl] [Objekttyp] read. | DEBUG | Read object data from database.
[Objekttype] data could not be read. Errorcode=[HEX-Fehlercode] | ERRORS | Object data could not be read from the database.
Reading data for [domain/project] [Name] completed. | DEBUG | Loading of data for domain or project completed.
The logging connection could not be established! | ERRORS | Log connection could not be established
The logging functions could not be loaded! | ERRORS | The necessary functions could not be loaded from the DLLs.
The logging helper DLL could not be loaded! | ERRORS | The necessary DLLs could not be loaded.
Socket could not be created. Errorcode=[Fehlercode] | ERRORS | The network connection could not be opened.
Both server and standby server for the project could not be reached. | ERRORS | A connection could not be established to either the Server or the Standby (if defined).
Connecting to [IP-Adresse & Port] | DEBUG | Connection establishment
Connecting to [IP-Adresse & Port] failed | ERRORS | Connection Failed
There was no response to the initialization request. | ERRORS | Initialization query remained unanswered.
Using connector version [Version] | DEBUG | Connection version handled.
There was no response to the query. | ERRORS | Query remained unanswered.
Query [Anfragetyp]: [Parameterliste] | DEBUG | Receive query.
Invalid call: [Fehlerinformation] | ERRORS | Invalid query.
Connector error: [Fehlerinformation] | ERRORS | Error during communication with the connector container or the connector container has reported an error when editing the query.
Unexpected connector error: [Fehlerinformation] | ERRORS | An exception has occurred.
Query [Anfragetyp] processed: [Anzahl] result rows returned. | DEBUG | Query completed successfully and data restored.


Analyzer Wizards

zenon Analyzer -> Analyzer Wizards

The zenon Analyzer has wizards that support correct setting of parameters for the SCADA system and the export of data from the SCADA system. The zenon SCADA system is currently supported.

Wizards:

  • Export Wizard for Analyzer 2.10: supports the export of metadata from zenon for the zenon Analyzer, version 2.10.
  • Export Wizard for Analyzer 2.20: supports the export of metadata from zenon for the zenon Analyzer, version 2.10.
  • Meaning and Waterfall Chart Wizard: Helps you prepare a zenon project for the processing of variable information in zenon Analyzer.
  • Analyzer Export Wizard: supports the export of metadata from zenon from version 7.10 SP0 for the zenon Analyzer.
  • Sankey Wizard: supports you when creating Sankey diagrams that you can see in the Runtime or which are used in zenon Analyzer.

The wizards for zenon Analyzer are automatically installed when installing zenon 7.20. The Analyzer Export Wizard has its own DLL. Meaning and Waterfall Chart Wizard and Sankey Wizard share a DLL. Installation and maintenance thus differ from other zenon wizards. Analyzer wizards are automatically kept up to date with the updates from zenon from version 7.20. The update can, if required, also be carried out manually via the build file contained in the zenon Analyzer installation medium for zenon from version 7.10. These wizards are not updated by means of the update mechanism of the zenon wizard. For details, see the Installation and Update chapter in the zenon Analyzer manual.

Syntax for inputs in zenon

Input in in zenon depends on the version of zenon that is used.

Up to zenon 7.11

Up to and including zenon version 7.11, the meaning and waterfall model is entered in the zenon Resources label property. These can contain meanings for several categories.

The following is applicable to entries in the resource label property:

  • Categories are separated by a semicolon (;).
  • Areas within a category are separated by a comma (,).
  • Categories are marked by an index:
    • ME=: Identifies a (Meaning).
      Syntax: ME=[main meaning as text],[additional meaning as text],[additional meaning as text],…;
      Example: ME=Station_1,Station_2;
    • WF=: Identifies a variable for the waterfall display.
      Syntax: WF=[model name text],[line index INT],[index in column INT],[color code as text #XXXXXX];
    • Every other entry is also understood as a Meaning

Complete syntax for the Resources label property: ME=[meaning1],[meaning2],…,[meaningN];WF=[model name],[row index],[index in row],[color code];

Attention: The Resources label property is limited to 256 characters in the zenon Editor.

From zenon 7.20

From zenon 7.20, there are separate properties in zenon for the definition of Meaning and waterfall, as well as the input of a display name. These entries do not need an identification in front of them.

The following properties in the zenon Analyzer variable properties group provide information for reports in the zenon Analyzer:

  • Visual name: Entry of a display name of the variable in zenon Analyzer. This must be unique in the project. The check is not carried out when issued in zenon, but when imported into zenon Analyzer. If this property is changed after the first export to a zenon Analyzer, these changes are not applied in the zenon Analyzer.
  • Meaning: Entry of the (Meaning) of a variable in the zenon Analyzer. Entry is manual or by means of the Meaning and Waterfall Chart Wizard. Several meanings are separated by a comma.
    Syntax:[Meaning1],[Meaning2],…,[MeaningN]
  • Parameter for waterfall diagram: Parameters of a variable for a waterfall diagram in zenon Analyzer. Entry is manual or by means of the Meaning and Waterfall Chart Wizard. The individual parameters are separated by a comma. Several waterfalls are divided by a semicolon.
    Syntax: [model name],[row index],[index in row],[color code];

Attention: All these input fields are limited to 256 characters in the zenon Editor.

When exporting to zenon Analyzer, both the previous property and the new one are checked. If both are assigned, the entries of the new properties are taken on. Entries that are created using the Meaning and Waterfall Chart Wizard are always entered into the new properties.

Other topics in this chapter

Analyzer Wizards - Compatibility

Export Wizard for Analyzer 2.10

Export Wizard for Analyzer 2.20

Export Wizard for Analyzer 3.00

Meaning and Waterfall Chart Wizard

Sankey Wizard


Analyzer Wizards - Compatibility

zenon Analyzer -> Analyzer Wizards -> Analyzer Wizards - Compatibility

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The different wizards are available for different versions of zenon Analyzer and zenon:

Wizard \ zenon version | 7.50 | 7.20 | 7.11 | 7.10 | 7.00
Meaning and Waterfall Chart Wizard | X | X | X | X | --
Sankey Wizard | X | X | X | X | --
Export Wizard for Analyzer 3.00 | X | X | X | -- | --
Export Wizard for Analyzer 2.20 | X | X | X | X | --
Export Wizard for Analyzer 2.10 | X | X | X | X | X
Export Wizard for Analyzer 2.00 | -- | -- | -- | X | X

Key:

  • X: available
  • --: Not available


Export Wizard for Analyzer 2.10

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The zenon Export Wizard for Analyzer 2.10 supports the export of metadata from zenon from version 7.10 SP0 for the zenon Analyzer 2.10.

The following can be exported:

  • Data from the global project
    • Equipment models
    • Alarm/event classes
    • Alarm/event groups
    • Users
  • Data from selected projects:
    • Archives
    • Variables

Note: The wizard is only available in English.

Compatibility:

The Analyzer Export Wizard works with zenon from version 7.10 SP0. There is a separate wizard available for each supported version of zenon.

Other topics in this chapter

Install and call up wizard

Start window

Configuration

Close wizard


Install and call up wizard

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Install and call up wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard is automatically installed with zenon for each supported version of zenon Analyzer.

Starting the wizard

For wizards to be displayed, the settings for VBA or VSTA must be set correctly in file zenon6.ini:

[VBA]

EIN=1

[VSTA]

ON=1

If VSTA wizards are not displayed although the settings are correct, set entry LOADED= to 1 in area [VSTA].

To start the wizard:

  1. in zenon open menu File
    or press the shortcut Alt+F12
  2. select the entry Wizards...
  3. the selection dialog is opened
  4. navigate to the Analyzer node
  5. select the Analyzer Export Wizard

  6. Start the wizard by clicking on OK


Start window

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Start window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When the wizard is opened, you receive an overview page that lists all exportable objects.

The individual objects are configured for the export on individual tabs.

Click on the button with the arrow to navigate through the configuration of the export.


Configuration

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When exporting with the Analyzer Export Wizard, all modules selected in the Settings tab are offered in sequence for detailed configuration. You get to the next level by clicking on the button with the right arrow. You can select individual tabs directly by clicking on the title of the tab.

The following tabs are available for configuration of the export:

  • Settings:
    Options for collection metadata
  • Equipment model :
    Export of the model groups from the global project
  • Event classes:
    Alarm/Event classes from global project
  • Event Event groups:
    Alarm/event groups from global project
  • Users:
    User from global project
  • Projects:
    Projects from workspace
  • Historian:
    Archives of the selected projects
  • Variables:
    Variables of the selected projects
  • Finish:
    Start of the export and output of the result

Attention: Only one global project can be exported to the database! Workspaces with projects that are to be exported to the database must include this global project.

Other topics in this chapter

Navigation

Settings

Equipment model

Alarm/event classes

Event groups

Users

Projects

Historian

Variables

Finish


Navigation

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Navigation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Navigation through the tabs is carried out by means of the navigation bar in the lower area of the wizard window:

Button

Description

Arrow left

Goes back one tab in the wizard process.

Arrow right

Goes forward one tab in the wizard process.

Export

Exports the data to the Analyzer database.

Is only active if the Finish tab is opened.

Cancel

Closes the wizard without exporting.

When closing, a dialog asks if the configuration is to be saved

  • Yes: writes the settings configured in the Settings tab to the registry and closes the wizard; the wizard is opened with these settings the next time it is restarted
  • No: closes the wizard without saving the configuration

The configuration is saved for each specific user.

Individual tabs can also be selected by clicking directly on the title of the tab.


Settings

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab:

  1. You define the database to which the wizard connects
  2. You define general options for exporting
  3. You start the data readout

Parameters

Description

Settings

Information and hints about current export processes.

Database settings

Connection settings to the Analyzer server.

DB host

Computer on which the database is located.

DB instance

Instance of the database.

DB name

Name of the database.

Authentication

Type of authentication:

  • Windows Authentication: Windows login information is used.
  • SQL Server Authentication: Login with data from an SQL server user.

User name

Entry of the user name.

Only for login with SQL Server Authentication. Display only with Windows Authentication.

Password

Entry of the password.

Only for login with SQL Server Authentication. No input possible with Windows Authentication.

Remember password

Password is saved for next connection.

Only for login with SQL Server Authentication. Inactive for Windows Authentication.

Options

General options for the export.

Load every project of this workspace into the memory

Active: Loads all projects present in the workspace, even if they are not active and not set to Keep project in memory.

Keep the exisiting data in the Analyzer database

Active: Only entries from the workspace are written to the database.

Inactive: Entries in the database are also updated or deleted.
Exception: Projects are not deleted

Preselect existing Analyzer database content

Active: Entries already present in the database are preselected in the individual areas.

Load Data

Load Data

Clicking on the button loads, depending on the Load every project of this workspace into the memory parameter - the data from the currently loaded project into the wizard.

In doing so, a check is made to see if data is present in the Analyzer database. Pre-existing data is combined with the data from the workspace and loaded into the wizard. In the event of naming conflicts, a dialog to rectify the error is called up.

If the loading of data has been successfully concluded, the export can be configured in the following tabs.

Renaming objects

Objects must always be named the same in the Analyzer database and in zenon. If objects that are already present in the database are renamed in zenon, these changes can be accepted or rejected when the data is combined. Rejection of the changes leads to the wizard being closed, because only objects with identical names can be handled correctly.

Dialog for renaming

In the event of conflicts in the naming of objects, a dialog for dealing with the error is opened:

Parameters

Description

List of amended objects

Contains all objects that were changed. Previous name and new name are displayed. The following renamed objects are displayed in the list:

  • Name of the equipment models
  • Names of the alarm/event classes
  • Names of the alarm/event groups
  • Project name
  • Variable name

Exceptions:

  • Users are always recreated
  • Archive names are only created once in the database as a visual name and can be overwritten in the zenon Analyzer

Rename

Renames all objects listed in the database, closes the dialog and stops reading in data.

Cancel

Leaves the previous name in the database, finishes reading in data and closes the wizard.


Equipment model

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Equipment model

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the model group which should be exported from the global project.

attention Attention

Each equipment group in zenon may only be assigned to one individual time model.

If several time model groups are assigned, the Analyzer Wizard Export uses the first that it finds and exports this to the metadata of the Analyzer. Other time model groups are ignored.

Parameters

Description

Equipment modeling

Information and notes on exporting.

Selection of equipment/medium

Drop-down list to select what is offered in List of equipment models/media for configuration:

  • Plant: displays equipment models
  • Media: displays media

List of equipment models/media

List field with the possibility to select equipment models and model groups or media. To select an entry, activate the check box in front of the entry.

In the list field the name, as it is stored in the database, is always displayed in the individual nodes. If the name was changed, the original name from the zenon project is displayed in brackets.

Equipment groups that were deleted in the global project are no longer displayed.

If, in the Settings tab, the option Keep the existing data in the Analyzer database was selected, amended objects in the database are deleted or updated.

Select all

Clicking on the button selects all equipment groups

Deselect all

Clicking on the button deselects all equipment groups.


Alarm/event classes

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Alarm/event classes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the alarm/event classes which should be exported from the global project.

Parameters

Description

Alarm/event classes

Information and notes on exporting.

List of the alarm/event classes

List field with the possibility to select the alarm/event classes. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several rows are highlighted, a click in the check box sets the options for all selected rows.

Alarm/event classes that were deleted in the global project are no longer displayed here.

If, in the Settings tab, the option Keep the existing data in the Analyzer database was selected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Event groups

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Event groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the alarm/event groups which should be exported from the global project.

Parameters

Description

Alarm/event groups

Information and notes on exporting.

List of the alarm/event groups

List field in which you can select alarm/event groups. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several rows are highlighted, a click in the check box sets the options for all selected rows.

Alarm/event classes that were deleted in the global project are no longer displayed here.

If, in the Settings tab, the option Keep the existing data in the Analyzer database was selected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Users

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Users

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the user which should be exported from the global project.

Parameters

Description

Users

Information and notes on exporting.

User List

List field with selection possibility for users. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several rows are highlighted, a click in the check box sets the options for all selected rows.

If, in the Settings tab, the option Keep the existing data in the Analyzer database was selected, amended objects in the database are deleted or updated.

If a user was renamed in zenon they are considered new and recreated in the project. The previous user is deleted.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Projects

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Projects

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the local projects which should be exported. The names for the server and standby-server can be changed here. To do this:

  1. Highlight the project in the list of projects
  2. Enter the desired name for the server and standby-server

If the name of the server or standby server is changed in the zenon project, then this is only updated in th analyzer database if the Network active setting was activated in the project properties.

Parameters

Description

Projects

Information and notes on exporting.

Project list

List field with selection possibility for projects. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several rows are highlighted, a click in the check box sets the options for all selected rows.

If, in the Settings tab, the option Keep the existing data in the Analyzer database was selected, amended objects in the database are deleted or updated.

Server

Address of the server for the project selected in the list window.

Standby

Address of the server for the project selected in the list window.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Historian

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Historian

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the archive from the selected projects. Only base archives are displayed. Aggregated archives are not displayed in the list, but are also selected with the base archives and written to the database.

Parameters

Description

Historian

Information and notes on exporting.

Archive list

List field with possibility to select for archives. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several rows are highlighted, a click in the check box sets the options for all selected rows.

If, in the Settings tab, the option Keep the existing data in the Analyzer database was selected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Variables

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the variables from the local project which should be exported. When selecting variables, the entries offered can be prefiltered.

Parameters

Description

Variables

Information and notes on exporting.

Variable Filter

Selection of the variable filter using the following option fields:

  • Show all: All variables are displayed.
  • Historians only: Only archive variables are displayed.
  • Equipment groups only: Only variables are displayed which are part of the selected Equipment model.
  • Show not selected only: Only variables that were not selected are displayed.

Filter row

Input of alphanumerical characters according to which the List of variables is to be filtered.

List of variables

List field with possibility to select variables. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several rows are highlighted, a click in the check box sets the options for all selected rows.

If, in the Settings tab, the option Keep the existing data in the Analyzer database was selected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.

Rules for the export of variables with reaction matrices

If linked variables are exported with reaction matrices, the limit value text and the status value of the reaction matrix statuses are also exported to the STATUSNAME table in the metadata database of the Analyzer. Because only certain states can be evaluated in the reports, they must be pre-sorted using the wizard.

The following statuses of the reaction matrices can be exported or excluded:

Rema

Rules

Numeric
  • The default status is ignored.
  • If several statuses with the same status and limit value condition are set, then only the first status and its status text are exported.
  • Only statuses with a value that is equal to a limit value are exported (limit value condition).
  • The limit value conditions greater than, less than, as desired and range are ignored.

Multi numeric
  • Correspond to the rules for numeric.
  • Substatuses are also ignored.

Binary

  • Only statuses that have value bits set consistently from right to left in the bit mask (0 or 1) are set.
    For example:
    ........ ....10.. 1
    ........ .....100 .
    ........ .....100 1
    The following are ignored, for example
    ........ ........ 1
    ........ ......00 1
    ........ .10..100 1

Multi binary
  • Correspond to the rules for Binary.
  • In addition, substatuses and statuses are also ignored with edge definitions in the bit mask.

String

  • Are completely ignored and not exported.


Finish

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Configuration -> Finish

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To export the configured data:

  1. In the Finish tab, click on the Export button

  2. the export is started
  3. The exported elements are shown in the output window with the attendant success and error messages
    In addition, the number of objects that have been added, replaced or deleted, and the number of errors that occurred are shown.

  4. Click on Close to close the wizard

Reconfiguring the wizard

To reconfigure the wizard:

  1. Open the Settings tab
  2. click on button Load data
  3. Configure the tabs


Close wizard

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.10 -> Close wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To close the wizard:

  • Click on the Cancel button
  • a dialog prompts whether the configuration should be saved
    • Clicking on Yes writes the settings configured in the Settings tab to the registry and closes the wizard; the wizard is opened with this configuration next time it is started
    • Click on No closes the wizard and the configuration is not saved.


Export Wizard for Analyzer 2.20

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The zenon Analyzer Export Wizard 2.20 supports the export of metadata from zenon from version 7.0 SP0 for the zenon Analyzer 2.20.

The following can be exported:

  • Data from the global project
    • Equipment models
    • Alarm/event classes
    • Alarm/event groups
    • Users
  • Data from selected projects:
    • Archives
    • Variables, with:

      - Visual name (see visual names section)

      - Meaning (see meaning section)

      - Parameter for waterfall diagram (see parameter waterfall chart section)

  • Sankey diagrams (see Sankey charts section)

Note: The wizard is only available in English.

Compatibility:

The Analyzer Export Wizard works with zenon from version 7.10 SP0. There is a separate wizard available for each supported version of zenon.

Other topics in this chapter

Sankey diagrams

Install and call up wizard

Start window

Configuration

Close wizard


Sankey diagrams

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Sankey diagrams

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard automatically reads the definition for Sankey diagrams from all activated projects and the global project. These are in the zenon project folder \Files\Others.
In doing so, the following applies:

  • Only valid XML files that were created for the zenon Analyzer are taken into account.
    Diagrams that have the Trueand Valid attributes set to True in the Sankey XML file are valid. All other Sankey diagrams are ignored and not loaded.
  • All Sankey diagram definitions are written to the zenon Analyzer metadata database in the SANKEY_DIAGRAMM, SANKEY_OBJECT and SANKEY_VARIABLE tables.
  • Diagrams are added depending on the setting for the Keep the existing data in the Analyzer database option:
    • Active: Only new diagrams are added to the Analyzer database.
    • Inactive: New diagrams are added and existing diagrams are updated.
  • Diagrams deleted in zenon (XML files) are not deleted in the Analyzer. Diagrams can only be deleted in the database directly in zenon Analyzer.
  • For the adding or updating of diagrams, the following must apply to all required zenon variables:
    • Be selected via the Variables tab
      or
    • already be in the database

    If variables that are required for the Sankey diagram are not selected for export, the Sankey diagram is not exported.

  • If the Sankey diagram already exists, the metadata database tables are updated according to the changes.
  • Clicking on the Export button in the Finish tab starts the export of the Sankey diagrams from zenon in to zenon Analyzer.
    The diagrams are only exported once all other data such as projects or variables have been exported. The success of the export is shown in the message list of the Finish tab.

attention Attention

The import of Sankey diagrams is carried out automatically in the background. There are no user interface or configuration options available.


Install and call up wizard

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Install and call up wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard is automatically installed with zenon for each supported version of zenon Analyzer.

Starting the wizard

For wizards to be displayed, the settings for VBA or VSTA must be set correctly in file zenon6.ini:

[VBA]

EIN=1

[VSTA]

ON=1

If VSTA wizards are not displayed although the settings are correct, set entry LOADED= to 1 in area [VSTA].

To start the wizard:

  1. In zenon open menu File
    or press the shortcut Alt+F12
  2. Select the entry Wizards.
  3. The selection dialog is opened
  4. Navigate to the Analyzer node
  5. Select the desired version of the Analyzer Export Wizard.

  6. Start the wizard by clicking on OK


Start window

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Start window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When the wizard is opened, you receive an overview page that lists all exportable objects.

The individual objects are configured for the export on individual tabs.

Click on the button with the arrow to navigate through the configuration of the export.


Configuration

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When exporting with the Analyzer Export Wizard, all modules available for export are offered for detailed configuration. Only the selected data is exported. The export of Sankey diagrams is carried out in the background, without the possibility of configuration. You get to the next level by clicking on the button with the right arrow. You can also select individual tabs directly by clicking on the title of the tab.

The following tabs are available for configuration of the export:

  • Settings: Options for the export of metadata
  • Equipment models: Export of the equipment groups from the global project
  • Event classes: Alarm/Event classes from global project
  • Event groups: Alarm/event groups from global project
  • Users: User from global project
  • Projects. Projects from workspace
  • Archives: Archives of the selected projects
  • Variables: Variables of the selected projects
  • Finish: Start of the export and output of the result

Other topics in this chapter

Navigation

Settings

Equipment models

Alarm/event classes

Event groups

Users

Projects

Archives

Variables

Finish


Navigation

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Navigation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Navigation through the tabs is carried out by means of the navigation bar in the lower area of the wizard window:

Button

Description

Arrow left

Goes back one tab in the wizard process.

Arrow right

Goes forward one tab in the wizard process.

Export

Exports the data to the Analyzer database.

Is only active if the Finish tab is opened.

Cancel

Closes the wizard without exporting.

When closing, a dialog asks if the configuration is to be saved

  • Yes: Writes the settings set in the Settings tab to the registry and closes the wizard. The wizard is opened with this configuration the next time it is started.
  • No: Closes the wizard without saving the configuration

The configuration is saved for each specific user.

Individual tabs can also be selected by clicking directly on the title of the tab.


Settings

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab:

  1. You define the database to which the wizard connects
  2. You define general options for exporting
  3. You start the data readout

Settings

Parameters | Description
Settings | Information and hints about current export processes.

Database settings

Parameters

Description

Database settings

Connection settings to the Analyzer server.

DB host

Computer on which the database is located.

DB instance

Instance of the database.

DB name

Name of the database.

Authentication

Type of authentication:

  • Windows Authentication: Windows login information is used.
  • SQL Server Authentication: Login with data from an SQL server user.

User name

Entry of the user name.

Only for login with SQL Server Authentication.
Display only for Windows Authentication.

Password

Entry of the password.

Only for login with SQL Server Authentication.
No input possible with Windows Authentication.

Remember password

Password is saved for next connection.

Only for login with SQL Server Authentication.
Inactive with Windows Authentication.

Projects

Parameters

Description

Projects

List of the available projects in the current zenon workspace. The checkbox shows whether the data of the project is used:

  • Active: Project is used.

Projects that are active in the memory are pre-selected. Inactive projects can be added by means of selection with a checkbox.

Options

Parameters

Description

Options

General options for the export.

Keep the existing data in the Analyzer database
  • Active: Only completely new entries from the workspace are written to the database.
    Note: If linkings from variables, archives etc. are changed or new ones are created, these are not transferred. If these are also transferred, the checkbox must be set to Inactive
  • Inactive: Entries in the database are also updated or deleted. New entries are created, amended entries are updated and deleted entries are removed.
    Exception: Projects and Sankey diagrams are not deleted.

Preselect existing Analyzer database content
  • Active: Entries already present in the database are preselected in the individual areas.

Load Data

Load Data

Clicking on the button loads, depending on the Load every project of this workspace into the memory parameter - the data from the currently loaded project into the wizard.

In doing so, a check is made to see if data is present in the Analyzer database. Pre-existing data is combined with the data from the workspace and loaded into the wizard. In the event of naming conflicts, a dialog to rectify the error is called up.

If the loading of data has been successfully concluded, the export can be configured in the following tabs.

Renaming objects

Objects must always be named the same in the Analyzer database and in zenon. If objects that are already present in the database are renamed in zenon, these changes can be accepted or rejected when the data is combined. Rejection of the changes leads to the wizard being closed, because only objects with identical names can be handled correctly.

Dialog for renaming

In the event of conflicts in the naming of objects, a dialog for dealing with the error is opened:

Parameters

Description

List of amended objects

Contains all objects that were changed. Previous name and new name are displayed. The following renamed objects are displayed in the list:

  • Name of the equipment models
  • Names of the alarm/event classes
  • Names of the alarm/event groups
  • Project name
  • Variable name

Exceptions:

  • Users are always recreated
  • Archive names are only created once in the database as a Visualname and can be overwritten in the zenon Analyzer

Rename

Renames all objects listed in the database, closes the dialog and stops reading in data.

Cancel

Leaves the previous name in the database, finishes reading in data and closes the wizard.


Equipment models

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Equipment models

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the model group which should be exported from the global project.

attention Attention

Each equipment group in zenon may only be assigned to one individual time model.

If several time model groups are assigned, the Analyzer Wizard Export uses the first that it finds and exports this to the metadata of the Analyzer. Other time model groups are ignored.

Parameters

Description

Equipment models

Information and notes on exporting.

Selection of equipment/medium

Drop-down list to select a model that is offered in the Equipment models/media list for configuration.

List of equipment models/media

List field with the possibility to select equipment models and model groups or media. To select an entry, activate the check box in front of the entry.

In the list field the name, as it is stored in the database, is always displayed in the individual nodes. If the name was changed, the original name from the zenon project is displayed in brackets.

Equipment groups that were deleted in the global project are no longer displayed.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Clicking on the button selects all equipment groups

Deselect all

Clicking on the button deselects all equipment groups.


Alarm/event classes

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Alarm/event classes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the alarm/event classes which should be exported from the global project.

Parameters

Description

Event classes

Information and notes on exporting.

List of the alarm/event classes

List field with the possibility to select the alarm/event classes. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

Alarm/event classes that were deleted in the global project are no longer displayed here.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Event groups

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Event groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the alarm/event groups which should be exported from the global project.

Parameters

Description

Event groups

Information and notes on exporting.

List of the alarm/event groups

List field in which you can select alarm/event groups. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

Alarm/event classes that were deleted in the global project are no longer displayed here.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Users

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Users

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the user which should be exported from the global project.

Parameters

Description

Users

Information and notes on exporting.

User List

List field with selection possibility for users. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

If a user was renamed in zenon they are considered new and recreated in the project. The previous user is deleted.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Projects

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Projects

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the local projects which should be exported. The names for Server 1 and Server 2 can be changed here.

To change the name of a Server or Standby Server:

  1. Highlight the project in the list of projects.
  2. Enter the desired name for Server 1 and Server 2.

If the name of Server 1 or Server 2 is changed in the zenon project, then this is only updated in th analyzer database if the Network active setting was activated in the project properties.

Parameters

Description

Projects

Information and notes on exporting.

Project list

List field with selection possibility for projects. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Server 1

Address of the Server 1 for the project selected in the list window.

Server 2

Address of the Server 2 for the project selected in the list window.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Archives

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Archives

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the archive from the selected projects. Only base archives are displayed. Aggregated archives are not displayed in the list, but are also selected with the base archives and written to the database.

Parameters

Description

Archives

Information and notes on exporting.

Archive list

List field with possibility to select for archives. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Variables

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the variables to be exported from the selected local projects. When selecting variables, the entries offered can be prefiltered.

Parameters

Description

Variables

Information and notes on exporting.

Display

Selection of which variables are displayed, via the following option fields:

  • All: All variables are displayed.
  • Selected: Only variables that have already been selected are displayed.
  • Unselected: Only variables that have not yet been selected are displayed.

Variable filter

Selection of the variable filter using the following option fields:

  • All: All variables are displayed.
  • Archives: Only archive variables are displayed.
  • Equipment groups: Only variables are displayed which are part of the selected Equipment model.

Filter row

Input of alphanumerical characters according to which the List of variables is to be filtered.

List of variables

List field with possibility to select variables. To select an entry, activate the check box in front of the entry.

The following are displayed:

  • Name (Analyzer): Name in zenon Analyzer.
  • Name (Workspace): Can be issued from zenon 7.20 in the Editor by means of the Visual name property. Must be unique in the project. See also chapter Visual name
  • Meaning: Can be issued from zenon 7.20 in the Editor by means of the Meaning property. See also chapter Meaning
  • Ressource label: corresponds to the Resources label property in zenon. Is used for zenon up to and including version 7.11 for meaning and parameter waterfall diagram. From version 7.20, there are separate properties available for this in zenon.
  • Identification: It corresponds to the Identification property in zenon.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.

Rules for the export of variables with reaction matrices

If linked variables are exported with reaction matrices, the limit value text, the limit value color and the status value of the reaction matrix statuses are also exported to the STATUSNAME table in the metadata database of the Analyzer. Because only certain states can be evaluated in the reports, they must be pre-sorted using the wizard.

The following statuses of the reaction matrices can be exported or excluded:

Rema

Rules

Numeric
  • The default status is ignored.
  • If several statuses with the same status and limit value condition are set, then only the first status and its status text are exported.
  • Only statuses with a value that is equal to a limit value are exported (limit value condition).
  • The limit value conditions greater than, less than, as desired and range are ignored.

Multi numeric
  • Correspond to the rules for numeric.
  • Substatuses are also ignored.

Binary

  • Only statuses that have value bits set consistently from right to left in the bit mask (0 or 1) are set.
    For example:
    ........ ....10.. 1
    ........ .....100 .
    ........ .....100 1
    The following are ignored, for example
    ........ ........ 1
    ........ ......00 1
    ........ .10..100 1

Multi binary
  • Correspond to the rules for Binary.
  • In addition, substatuses and statuses are also ignored with edge definitions in the bit mask.

String

  • Are completely ignored and not exported.

Import of variable information from zenon

The following properties in the zenon Analyzer variable properties group provide information for reports in the zenon Analyzer:

  • Visual name: Entry of a display name of the variable in zenon Analyzer. This must be unique in the project. The check is not carried out when issued in zenon, but when imported into zenon Analyzer. If this property is changed after the first export to a zenon Analyzer, these changes are not applied in the zenon Analyzer.
  • Meaning: Entry of the (Meaning) of a variable in the zenon Analyzer. Entry is manual or by means of the Meaning and Waterfall Chart Wizard. Several meanings are separated by a comma.
    Syntax:[Meaning1],[Meaning2],…,[MeaningN]
  • Parameter for waterfall diagram: Parameters of a variable for a waterfall diagram in zenon Analyzer. Entry is manual or by means of the Meaning and Waterfall Chart Wizard. The individual parameters are separated by a comma. Several waterfalls are divided by a semicolon.
    Syntax: [model name],[row index],[index in row],[color code];

Other topics in this chapter

Visual name

Meaning

Parameter waterfall diagram


Visual name

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Variables -> Visual name

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard reads the Analyzer/Visual name property when loading the zenon workspace from zenon 7.20 and displays this for each variable in the Variables tab. The following applies for visual names:

  • The name must be unique for each project.
  • Names in a project that appear several tines are highlighted in red.
  • The Visual name are entered when writing the data to the metadata database.
  • In the event of duplicated name within a project, the Visual name is only entered for the first variable found. For the second variable, the Name of the variables is entered in zenon.
  • The Visual name is only set when the variable is exported for the first time. If this is subsequently changed in the Editor, this change is no longer applied in the metadata database. Changes are of course applied to a new metadata database when exporting to a new database.
  • With a version of zenon before 7.20, the visual name is always taken from the zenon Identification property.


Meaning

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Variables -> Meaning

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

From zenon 7.20, the wizard reads the Analyzer/Meaning property and displays this for each variable in the Variables tab.
The following applies for meanings:

  • If there are entries for Meaning, the corresponding entries in the Resources label are ignored.
  • If there are no entries, corresponding entries from the Resources label are accepted.
  • The identification ME= is no longer necessary but can continue to be used. If a variable is assigned several meanings, a comma is used as a separator.
  • With a version of zenon before 7.20, the meaning is always taken from the zenon Resources label property.


Parameter waterfall diagram

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Variables -> Parameter waterfall diagram

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard reads the Analyzer/Parameter for waterfall diagram property when loading the zenon workspace from zenon 7.20 and displays this for each variable in the Variables tab. The following applies for waterfall:

  • If there are entries for Parameter for waterfall diagram, the corresponding entries in the Resources label are ignored.
  • If there are no entries, corresponding entries from the Resources label are accepted.
  • The identification WF= is no longer necessary but can continue to be used. The individual elements of a model are separated by a comma. If several waterfall models are assigned to a variable, a semicolon is used as a separator.
  • With versions of zenon before 7.20, the waterfall parameters are always taken from the zenon Resources label property.


Finish

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Configuration -> Finish

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To export the configured data:

  1. In the Finish tab, click on the Export button.

  2. the export is started
  3. The exported elements are shown in the output window with the attendant success and error messages
    In addition, the number of objects that have been added, replaced or deleted, and the number of errors that occurred are shown.

  4. Click the Close button to close the wizard

Reconfiguring the wizard

To reconfigure the wizard:

  1. Open the Settings tab.
  2. Click on the Load data button.
  3. Configure the tabs.


Close wizard

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 2.20 -> Close wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To close the wizard:

  • Click on the Cancel button .
  • A dialog prompts whether the configuration should be saved.
    • Yes: Writes the settings set in the Settings tab to the registry and closes the wizard. The wizard is opened with this configuration the next time it is started. The configuration is saved for each specific user.
    • No: Closes the wizard without saving the configuration


Export Wizard for Analyzer 3.00

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The zenon Export Wizard for Analyzer 3.00 supports the export of metadata from zenon from version 7.00 SP0 for the zenon Analyzer 3.00.

The following can be exported:

  • Data from the global project
    • Equipment models
    • Alarm/event classes
    • Alarm/event groups
    • Users
  • Data from selected projects:
    • Archives
    • Variables, with:

      - Visual name (see visual names section)

      - Meaning (see meaning section)

      - Parameter for waterfall diagram (see parameter waterfall chart section)

  • Sankey diagrams (see Sankey diagrams section)

Note: The wizard is only available in English.

Compatibility:

The Analyzer Export Wizard works with zenon from version 7.10 SP0. There is a separate wizard available for each supported version of zenon.

Other topics in this chapter

Sankey diagrams

Waterfall diagram

Install and call up wizard

Start window

Configuration

Close wizard


Sankey diagrams

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Sankey diagrams

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard automatically reads the definition for Sankey diagrams from all activated projects and the global project. These are in the zenon project folder \Files\Others.
In doing so, the following applies:

  • Only valid XML files that were created for the zenon Analyzer are taken into account.
    Diagrams that have the Trueand Valid attributes set to True in the Sankey XML file are valid. All other Sankey diagrams are ignored and not loaded.
  • All Sankey diagram definitions are written to the zenon Analyzer metadata database in the SANKEY_DIAGRAMM, SANKEY_OBJECT and SANKEY_VARIABLE tables.
  • Diagrams deleted in zenon (XML files) are not deleted in the Analyzer. Diagrams can only be deleted in the database directly in zenon Analyzer.
  • For the adding or updating of diagrams, the following must apply to all required zenon variables:
    • Be selected via the Variables tab
      or
    • already be in the database

    If variables that are required for the Sankey diagram are not selected for export, the Sankey diagram is not exported.

  • If the Sankey diagram already exists, the metadata database tables are updated according to the changes.
  • Clicking on the Export button in the Finish tab starts the export of the Sankey diagrams from zenon in to zenon Analyzer.
    The diagrams are only exported once all other data such as projects or variables have been exported. The success of the export is shown in the message list of the Finish tab.

attention Attention

The import of Sankey diagrams is carried out automatically in the background. There are no user interface or configuration options available.


Waterfall diagram

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Waterfall diagram

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

A waterfall diagram can be used for either line-based reports or for machine-based reports. The parameters for the diagram are stored in the Analyzer/Parameter for waterfall diagram variable property from zenon 7.20. These can be entered manually or created with the Meaning and Waterfall Chart Wizard.

Export

The wizard reads the Parameter for waterfall diagram property when loading the zenon workspace. If there are correct entries, these these are exported in the background and written to the database of the zenon Analyzer.

Structure of the entries

Depending on the structure of the entries, a decision is made on whether it is entries for machine-based or line-based diagrams.

  • Machine based: Structure with 4 digits, separated by a comma; ended with a semicolon.

    Syntax: [model name],[line index],[column index],[color code code];
    Example: MyWaterfall,4,2,#80FF00;

  • Line-based: Structure with 7 digits, separated by a comma; ended with a semicolon.

    Syntax: [model name],[line index],[column index],[color code],[loss of auxiliary machine],[add loss of auxiliary machine],[subtract loss of auxiliary machine];
    Example: MyLineAnlaysis,4,2, #80FF00,0,0,0;

Rules for reading:

The following is applicable for reading:

  • If there are entries for Parameter for waterfall diagram, corresponding entries in the Resources label field are ignored.
    The structure decides whether the entry can be evaluated as machine-based or line-based.
  • The identification WF= is not necessary but can to be used. The individual elements of a model are separated by a comma. If several waterfall models are assigned to a variable, a semicolon is used as a separator.
  • If there are no entries, corresponding entries from the Resources label are accepted. The identification WF= must be prefixed here.
  • With versions of zenon before 7.20, the waterfall parameters are taken from the zenon Resources label property.


Install and call up wizard

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Install and call up wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard is automatically installed with zenon for each supported version of zenon Analyzer.

Starting the wizard

For wizards to be displayed, the settings for VBA or VSTA must be set correctly in file zenon6.ini:

[VBA]

EIN=1

[VSTA]

ON=1

If VSTA wizards are not displayed although the settings are correct, set entry LOADED= to 1 in area [VSTA].

To start the wizard:

  1. In zenon open menu File
    or press the shortcut Alt+F12
  2. Select the Wizards entry.
  3. The selection dialog is opened.
  4. Navigate to node Analyzer.
  5. Select the desired version of the Analyzer Export Wizard.

  6. Start the wizard by clicking on OK


Start window

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Start window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When the wizard is opened, you receive an overview page that lists all exportable objects.

The individual objects are configured for the export on individual tabs.

Click on the button with the arrow to navigate through the configuration of the export.


Configuration

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When exporting with the Analyzer Export Wizard, all modules available for export are offered for detailed configuration. Only the selected data is exported. The export of Sankey diagrams is carried out in the background, without the possibility of configuration. You get to the next level by clicking on the button with the right arrow. You can also select individual tabs directly by clicking on the title of the tab. Entries already present in the database are preselected in the individual areas.

The following tabs are available for configuration of the export:

  • Settings: Options for the export of metadata
  • Equipment models : Export of the equipment groups from the global project
  • Event classes: Alarm/Event classes from global project
  • Event groups: Alarm/event groups from global project
  • Users: User from global project
  • Projects: Projects from workspace
  • Archives: Archives of the selected projects
  • Variables: Variables of the selected projects
  • Efficiency classes: Display of the efficiency classes to be exported.
  • Finish: Start of the export and output of the result

Other topics in this chapter

Navigation

Settings

Equipment models

Event classes

Event groups

Users

Projects

Archives

Variables

Efficiency classes

Finish


Navigation

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Navigation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Navigation through the tabs is carried out by means of the navigation bar in the lower area of the wizard window:

Button

Description

Arrow left

Goes back one tab in the wizard process.

Arrow right

Goes forward one tab in the wizard process.

Export

Exports the data to the Analyzer database.

Is only active if the Finish tab is opened.

Cancel

Closes the wizard without exporting.

When closing, a dialog asks if the configuration is to be saved

  • Yes: Writes the settings set in the Settings tab to the registry and closes the wizard. The wizard is opened with this configuration the next time it is started.
  • No: Closes the wizard without saving the configuration

The configuration is saved for each specific user.

Individual tabs can also be selected by clicking directly on the title of the tab.


Settings

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab:

  1. You define the database to which the wizard connects
  2. You define general options for exporting
  3. You start the data readout

Settings

Parameters | Description
Settings | Information and hints about current export processes.

Database settings

Parameters

Description

Database settings

Connection settings to the Analyzer server.

DB host

Computer on which the database is located.

DB name

Name of the database.

Authentication

Type of authentication:

  • Windows Authentication: Windows login information is used.
  • SQL Server Authentication: Login with data from an SQL server user.

User name

Entry of the user name.

Only for login with SQL Server Authentication.
Display only for Windows Authentication.

Password

Entry of the password.

Only for login with SQL Server Authentication.
No input possible with Windows Authentication.

Remember password

Password is saved for next connection.

Only for login with SQL Server Authentication.
Inactive with Windows Authentication.

Projects

Parameters

Description

Projects

List of the available projects in the current zenon workspace. The checkbox shows whether the data of the project is used:

  • Active: Project is used.

Projects that are active in the memory are pre-selected. Inactive projects can be added by means of selection with a checkbox.

Options

Parameters

Description

Options

General options for the export.

Don't modify existing data in the Analyzer metadata database
  • Active: Only completely new entries from the workspace are written to the database.
    Note: If linkings from variables, archives etc. are changed or new ones are created, these are not transferred. If these are also transferred, the checkbox must be set to Inactive
  • Inactive: Entries in the database are also updated or deleted. New entries are created, amended entries are updated and deleted entries are removed.
    Exception: Projects and Sankey diagrams are not deleted.

Update Visual names

Only available if the Don't modify existing data in the Analyzer metadata database option has been deactivated.

  • Active: In zenon, amended display names are overwritten when exporting to the metadata database of zenon Analyzer.
  • Inactive: Amended display names are not changed in zenon Analyzer.

Default: Inactive
The setting is not saved. The checkbox is set to deactivated each time the wizard is started.

Behavior:

If the checkbox is activated, display names amended in zenon are also amended in zenon Analyzer for:

  • Equipment models
  • Event classes
  • Event groups
  • Projects
  • Archives
  • Variables

The display names for Users cannot be changed. These are recreated in the event of changes.

Changes to display names are displayed in the individual lists.

Example:

Initial situation:

  • Display name in the zenon project: Z
  • Display name in the zenon Analyzer: A

Action:

  • A = Z:
    nothing happens.
  • A <> Z:
    Z is applied if the name has not yet been issued in the metadata table. If Z is already present in the table, A remains unchanged and an error message is given.

Load Data

Load Data

Clicking on the button loads, depending on the Load every project of this workspace into the memory parameter - the data from the currently loaded project into the wizard.

In doing so, a check is made to see if data is present in the Analyzer database. Pre-existing data is combined with the data from the workspace and loaded into the wizard. In the event of naming conflicts, a dialog to rectify the error is called up.

If the loading of data has been successfully concluded, the export can be configured in the following tabs.

Renaming objects

Objects must always be named the same in the Analyzer database and in zenon. If objects that are already present in the database are renamed in zenon, these changes can be accepted or rejected when the data is combined. Rejection of the changes leads to the wizard being closed, because only objects with identical names can be handled correctly.

Dialog for renaming

In the event of conflicts in the naming of objects, a dialog for dealing with the error is opened:

Parameters | Description
List of amended objects | Contains all objects that were changed. Previous name and new name are displayed. Exception: Users are always recreated.
Rename | Renames all objects listed in the database, closes the dialog and stops reading in data.
Cancel | Leaves the previous name in the database, finishes reading in data and closes the wizard.


Equipment models

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Equipment models

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the model group which should be exported from the global project.

attention Attention

Each equipment group in zenon may only be assigned to one individual time model.

If several time model groups are assigned, the Analyzer Wizard Export uses the first that it finds and exports this to the metadata of the Analyzer. Other time model groups are ignored.

Parameters

Description

Equipment models

Information and notes on exporting.

Selection of equipment/medium

Drop-down list to select a model that is offered in the Equipment models/media list for configuration.

List of equipment models/media

List field with the possibility to select equipment models and model groups or media. To select an entry, activate the check box in front of the entry.

In the list field the name, as it is stored in the database, is always displayed in the individual nodes. If the name was changed, the original name from the zenon project is displayed in brackets.

Equipment groups that were deleted in the global project are no longer displayed.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Clicking on the button selects all equipment groups

Deselect all

Clicking on the button deselects all equipment groups.


Event classes

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Event classes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the alarm/event classes which should be exported from the global project.

Parameters

Description

Event classes

Information and notes on exporting.

List of the alarm/event classes

List field with the possibility to select the alarm/event classes. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

Alarm/event classes that were deleted in the global project are no longer displayed here.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Event groups

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Event groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the alarm/event groups which should be exported from the global project.

Parameters

Description

Event groups

Information and notes on exporting.

List of the alarm/event groups

List field in which you can select alarm/event groups. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

Alarm/event classes that were deleted in the global project are no longer displayed here.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Users

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Users

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the user which should be exported from the global project.

Parameters

Description

Users

Information and notes on exporting.

User List

List field with selection possibility for users. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

If a user was renamed in zenon they are considered new and recreated in the project. The previous user is deleted.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Projects

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Projects

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the local projects which should be exported. The names for Server 1 and Server 2 can be changed here.

To change the name of a Server or Standby Server:

  1. Highlight the project in the list of projects.
  2. Enter the desired name for Server 1 and Server 2.

Note: Changes here are only possible if, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option has been deactivated. The information that is displayed for the server depends on the settings in the project and the database. For details, see the Display of server settings section.

Parameters

Description

Projects

Information and notes on exporting.

Project list

List field with selection possibility for projects. To select an entry, activate the check box in front of the entry.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Server 1

Address of the Server 1 for the project selected in the list window.
Source (project or database) depending on configuration.

Server 2

Adress of the Server 2 for the project selected in the list window.
Source (project or database) depending on configuration.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.

Display of server settings

The following is applicable for the display and configuration of the server in this tab:

  • In the zenon project, the Network active property is activated:
    Server 1 and Server 2 from the project are displayed.
  • In the zenon project, the Network active property is deactivated:
    Server 1 and Server 2 from the database are displayed.
  • In the zenon project, the Network active property is deactivated and there are no entries present for the server in the database:
    Empty entries are displayed for Server 1 and Server 2.


Archives

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Archives

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection of the archive from the selected projects. Only base archives are displayed. Aggregated archives are not displayed in the list, but are also selected with the base archives and written to the database.

Parameters

Description

Archives

Information and notes on exporting.

Archive list

List field with possibility to select for archives. To select an entry, activate the check box in front of the entry.

  • Name (Analyzer): Name of the archive in zenon Analyzer.
  • Name (Project): Name of the archive in the project.
  • Archive ID (Project): ID of the archive in the project.
  • Project: Project from which the archive comes.
  • Description: Individual description of the project.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.


Variables

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the variables to be exported from the selected local projects. When selecting variables, the entries offered can be prefiltered.

Parameters

Description

Variables

Information and notes on exporting.

Display

Selection of which variables are displayed, via the following option fields:

  • All: All variables are displayed.
  • Selected: Only variables that have already been selected are displayed.
  • Unselected: Only variables that have not yet been selected are displayed.

Variable filter

Selection of the variable filter using the following option fields:

  • All: All variables are displayed.
  • Archives: Only archive variables are displayed.
  • Equipment groups: Only variables are displayed which are part of the selected Equipment model.

Filter row

Input of alphanumerical characters according to which the List of variables is to be filtered.

Attention: The filter makes a distinction between upper-case and lower case letters (it is case sensitive).

List of variables

List field with possibility to select variables. To select an entry, activate the check box in front of the entry.

The following are displayed:

  • Name (Analyzer): Name in zenon Analyzer.
  • Name (Workspace): Can be issued from zenon 7.20 in the Editor by means of the Visual name property. Must be unique in the project. See also chapter Visual name
  • Meanings: Can be issued from zenon 7.20 in the Editor by means of the Meaning property. See also chapter Meaning
  • Project: Project from which the variable comes.
  • Identification: It corresponds to the Identification property in zenon.

Sorting: Clicking on the column identifier sorts the entries after this column upwards or downwards.

Multiple selection: If several lines are highlighted, the selection applies for all selected lines.

If, in the Settings tab, the Don't modify existing data in the Analyzer metadata database option is deselected, amended objects in the database are deleted or updated.

Select all

Selects all entries in the list and activates the checkboxes.

Deselect all

Selects all entries in the list and deactivates the check boxes.

Rules for the export of variables with reaction matrices

If linked variables are exported with reaction matrices, the limit value text, the limit value color and the status value of the reaction matrix statuses are also exported to the STATUSNAME table in the metadata database of the Analyzer. Because only certain states can be evaluated in the reports, they must be pre-sorted using the wizard.

The following statuses of the reaction matrices can be exported or excluded:

Rema

Rules

Numeric
  • The default status is ignored.
  • If several statuses with the same status and limit value condition are set, then only the first status and its status text are exported.
  • Only statuses with a value that is equal to a limit value are exported (limit value condition).
  • The limit value conditions greater than, less than, as desired and range are ignored.

Multi numeric
  • Correspond to the rules for numeric.
  • Substatuses are also ignored.

Binary

  • Only statuses that have value bits set consistently from right to left in the bit mask (0 or 1) are set.
    For example:
    ........ ....10.. 1
    ........ .....100 .
    ........ .....100 1
    The following are ignored, for example
    ........ ........ 1
    ........ ......00 1
    ........ .10..100 1

Multi binary
  • Correspond to the rules for Binary.
  • In addition, substatuses and statuses are also ignored with edge definitions in the bit mask.

String

  • Are completely ignored and not exported.

Import of variable information from zenon

The following properties in the zenon Analyzer variable properties group provide information for reports in the zenon Analyzer:

  • Visual name: Entry of a display name of the variable in zenon Analyzer. This must be unique in the project. The check is not carried out when issued in zenon, but when imported into zenon Analyzer. If this property is changed after the first export to a zenon Analyzer, these changes are not applied in the zenon Analyzer.
  • Meaning: Entry of the (Meaning) of a variable in the zenon Analyzer. Entry is manual or by means of the Meaning and Waterfall Chart Wizard. Several meanings are separated by a comma.
    Syntax:[Meaning1],[Meaning2],…,[MeaningN]
  • Parameter for waterfall diagram: Parameters of a variable for a waterfall diagram in zenon Analyzer. Entry is manual or by means of the Meaning and Waterfall Chart Wizard. The individual parameters are separated by a comma. Several waterfalls are divided by a semicolon.
    Syntax: [model name],[row index],[index in row],[color code];

Other topics in this chapter

Visual name

Meaning


Visual name

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Variables -> Visual name

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard reads the Analyzer/Visual name property when loading the zenon workspace from zenon 7.20 and displays this for each variable in the Variables tab. The following applies for visual names:

  • The name must be unique for each project.
  • Names in a project that appear several tines are highlighted in red.
  • The Visual name are entered when writing the data to the metadata database.
  • In the event of duplicated name within a project, the Visual name is only entered for the first variable found. For the second variable, the Name of the variables is entered in zenon.
  • The Visual name is only set when the variable is exported for the first time. If this is subsequently changed in the Editor, this change is no longer applied in the metadata database. Changes are of course applied to a new metadata database when exporting to a new database.
  • With a version of zenon before 7.20, the visual name is always taken from the zenon Identification property.


Meaning

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Variables -> Meaning

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

From zenon 7.20, the wizard reads the Analyzer/Meaning property and displays this for each variable in the Variables tab.
The following applies for meanings:

  • If there are entries for Meaning, the corresponding entries in the Resources label are ignored.
  • If there are no entries, corresponding entries from the Resources label are accepted.
  • The identification ME= is no longer necessary but can continue to be used. If a variable is assigned several meanings, a comma is used as a separator.
  • With a version of zenon before 7.20, the meaning is always taken from the zenon Resources label property.


Efficiency classes

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Efficiency classes

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection and configuration of the efficiency classes to be exported. In doing so, zenon reaction matrices (REMAs) are displayed, the status of which correspond to the rules of the efficiency class structure. Only reaction matrices that meet certain conditions are read.

zenon reaction matrix requirements

In order for a reaction matrix to be read as an efficiency class, it must meet the following conditions:

  • Numeric or multi-numeric type
  • Status configured correctly
  • Limit value text present

Status configuration

The statuses to be configured must meet the following conditions:

  • The first status is less than a defined value. The area is open downwards.

    Status n1: <x

  • The last status is greater than the last value defined beforehand. This area is open upwards.

    Status n4: >z

  • Fixed ranges are defined between the first and last value. These areas must follow one another exactly.

    Status n2: x-y

    Status n3: y-z

Configuration in the wizard

To select efficiency classes for export:

  1. Select the desired efficiency classes.
  2. Configure the normalization.
    Attention: The None value is reserved for a subsequent expansion stage and must not be selected.

    All pre-existing efficiency classes in the metadata database are deleted during export if they have been created by the wizard. However, efficiency classes that come from the Metadata Editor are retained. All selected efficiency classes are then written to the metadata database.

Parameters

Description

Efficiency Class Name

Selection of the efficiency class to be exported by means of
Activation of checkbox in front of the name.

Normalisation

Selection of the normalization from a drop-down list.

  • Minimum: 1 minute
  • Maximum: 1 year

Default: 15 minutes

Attention: None must not be selected. This value is reserved for a subsequent expansion level and leads to invalid configurations.

attention Attention

Reaction matrices are identified in zenon by means of their name. If the name of a reaction matrix is amended in zenon, the attendant efficiency class is recreated during export and the previous efficiency class is deleted.


Finish

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Configuration -> Finish

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To export the configured data:

  1. In the Finish tab, click on the Export button.

  2. the export is started
  3. The exported elements are shown in the output window with the attendant success and error messages
    In addition, the number of objects that have been added, replaced or deleted, and the number of errors that occurred are shown.

  4. Click the Close button to close the wizard

Reconfiguring the wizard

To reconfigure the wizard:

  1. Open the Settings tab.
  2. Click on the Load data button.
  3. Configure the tabs.


Close wizard

zenon Analyzer -> Analyzer Wizards -> Export Wizard for Analyzer 3.00 -> Close wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To close the wizard:

  • Click on the Cancel button .
  • A dialog prompts whether the configuration should be saved.
    • Yes: Writes the settings set in the Settings tab to the registry and closes the wizard. The wizard is opened with this configuration the next time it is started. The configuration is saved for each specific user.
    • No: Closes the wizard without saving the configuration


Meaning and Waterfall Chart Wizard

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Meaning and Waterfall Chart Wizard helps you prepare a zenon project for the processing of variable information in the zenon Analyzer.

Note: The wizard is only available in English.

attention Attention

If the Multi-User is used with a project with distributed engineering (Multi-User), then Enable changes must be activated in the zenon Editor for:

  • The project (context menu of the project)
  • The variables (context menu of the variables or the Variables module)

Otherwise the changes made by the Meaning and Waterfall Chart Wizard cannot be applied. These are then discarded.

The Meaning and Waterfall Chart Wizard helps you, when engineering projects in zenon, to configure:

  • Meanings (Meaning)
  • Waterfall charts for machine-based reports and line-based reports.

The wizard writes the configuration in the corresponding properties of the variables selected in the wizard. The target properties depend on the version of zenon that is used.

attention Attention

Only equipment models from the global project are available.

From zenon 7.20

  • Meanings:

    The Meanings are written in the Analyzer/Meaning property. Several entries are separated by a comma (,).

  • Waterfall:

    The parameters for waterfall diagrams are written in the Analyzer/Parameter for waterfall diagram property. The parameters for a diagram are separated by a comma (,). Several diagrams are separated by a semi colon (;)

    • Syntax machine-based: [model name],[line index],[column index],[color code code];
    • Syntax line-based: [model name],[line index],[column index],[color code],[loss of auxiliary machine],[add loss of auxiliary machine],[subtract loss of auxiliary machine];

The following applies for both properties: If there are still entries in the General/Resources label property from previous versions of zenon, these are deleted and entered in the corresponding properties for zenon 7.20.

Up to zenon 7.11:

Meanings and parameters for waterfall diagrams are written to the Resources label variable property. In doing so, the prefix WF= is added for meanings and the prefix WF= is added for waterfall parameters.

For further information, see the Analyzer Wizards chapter.

Other topics in this chapter

Install and call up wizard

Start window

Configuration


Install and call up wizard

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Install and call up wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard is automatically installed together with zenon.

Starting the wizard

For wizards to be displayed, the settings for VBA or VSTA must be set correctly in file zenon6.ini:

[VBA]

EIN=1

[VSTA]

ON=1

If VSTA wizards are not displayed although the settings are correct, set entry LOADED= to 1 in area [VSTA].

To start the wizard:

  1. In zenon open menu File
    or press the shortcut Alt+F12
  2. Select the entry Wizards
  3. The selection dialog is opened
  4. Navigate to node Analyzer.
  5. Select the Meaning and Waterfall Chart Wizard.

  6. Start the wizard by clicking on OK .


Start window

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Start window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When opening the wizard, you receive an overview that lists and explains all objects that can be configured. Configuration starts with the Settings tab.

Meaning

zenon variables often receive technically-orientated names in the project. This naming is often not meaningful enough for display in a zenon Analyzer report. The variables can be given an unique name for display in the zenon Analyzer report. This name is saved to the corresponding variable property depending on the zenon version. Target property and entry are automatically selected by the wizard.

After import into zenon Analyzer, this name is used for reports without the existing variable name needing to be changed. For details, see the Analyzer Wizards chapter in the online help.

Waterfall chart

Some zenon Analyzer reports can display a waterfall diagram using zenon variables. To do this, information on the appearance of the diagram must already be present in the resource label of the selected variable. The structure and appearance of a waterfall diagram for machine-based reports or line-based reports can be defined with a wizard. The waterfall information is saved to the corresponding variable property depending on the zenon version. Target property and entry are automatically selected by the wizard. For details, see the Analyzer Wizards chapter in the online help.

Navigation

Click on the button with the arrow to navigate through the configuration of the export.


Configuration

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The Meaning and Waterfall Chart Wizard is configured with the following tabs:

  • Settings: Loading the data from the projects.
    Only once the data to be loaded is selected are other tabs available for meanings or waterfall diagrams.
  • Meaning filter: Filter settings for meanings.
  • Meaning: Selection and assignment of the meanings.
  • Waterfall filter: Filter settings for machine-based waterfall diagram.
  • Waterfall: Selection of variables and configuration of machine-based waterfall diagram.
  • Line Analysis filter: Filter settings for line-based waterfall diagram.
  • Line Analysis: Selection of variables and configuration of line-based waterfall diagram.
  • Finish: Acceptance of configuration and configuration by the wizard.

The tabs that can be shown depend on the configuration of the Settings tab.

Other topics in this chapter

Navigation

Settings

Meanings

Machine

Line

General rules for waterfall diagrams

Finish


Navigation

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Navigation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Navigation through the tabs is carried out by means of the navigation bar in the lower area of the wizard window:

Button | Description
Arrow left | Goes back one tab in the wizard process.
Arrow right | Goes forward one tab in the wizard process.
Finish | Writes all changes to the zenon variable in the Editor and closes the wizard.
Cancel | Ends the wizard without making changes.

Individual tabs can also be selected by clicking directly on the title of the tab.


Settings

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Selection and loading of the tabs to be configured.

Parameters

Description

Settings

Setting for which tabs are to be loaded.

Load every project of this workspace into the memory
  • Active: Projects from the workspace that are not in the memory are loaded. Once the wizard has been ended or once the Finish action has been executed, these are removed.

Define Meanings

  • Active: The Meaning filter and Meaning tabs are loaded.

Define Waterfall Chart

Selection of waterfall chart:

  • Active: A waterfall chart is created.

Selection of the waterfall type by means of the radio button:

  • Machine: A machine-based waterfall chart is created. The Waterfall filter und Waterfall tabs are loaded.
  • Line: A line-based waterfall chart is created. The Line Analysis filter and Line Analysis tabs are loaded.

Load data

Clicking on the button searches through the variables of all projects loaded in the workspace and loads the required information for the filter and editing the variables. The corresponding tabs are displayed in the wizard.

A progress bar is displayed during the loading process.

After loading, the tabs are available for the selected data, for configuration.


Meanings

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Meanings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of the meanings using the Meaning filter and Meaning tabs.

Other topics in this chapter

Meaning filter

Meaning


Meaning filter

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Meanings -> Meaning filter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The variables to be edited are pre-filtered with this tab. If an object is not selected in any group, all variables are available in the Meaning tab.

attention Attention

Only equipment models from the global project are available.

Parameters | Description
List of equipment groups | Filtering for individual models by activating the respective checkboxes. No selection: Variables of all equipment models are selected.
List of projects | Filtering for individual checkboxes by activating the respective checkboxes. No selection: Variables of all projects are selected.
List of archives | Filtering for individual archives by activating the respective checkboxes. No selection: Variables of all archives are selected.


Meaning

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Meanings -> Meaning

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The meanings of the variables are edited in this tab. Variables can be selected and given new meanings, and existing meanings can be removed.

Variable selection

Parameters

Description

Search meaning

Input of a search term lists all variables with their corresponding meanings.

The list is immediately updated with the entry of a character. Placeholders cannot be used.

List Variablen

List of the variables available after filtering.

Selection of variables for editing: Activation of the checkbox before the variables.

Existing meanings of the variables are shown in the Meanings column. In doing so, only meanings are displayed. Other entries or entries for the waterfall chart are hidden or ignored when editing.

The variables can be sorted by clicking on a column label.

Select all

Clicking this selects all variables for editing.

Deselect all

Clicking this deselects all variables.

Display statistics

Display how many variables:

  • Are present in the list
  • Have been selected
  • Have been changed

Reset

Resets all changes that have been made by clicking on Update meaning.

Note: Changes are only accepted finally after clicking on Finish.

Add meanings

Add new meanings | Allows meanings to be added to variables. New meanings are entered in the input field, added to the list and assigned to the selected variables using the Update meaning button.
Eingabefeld | Entry of a new meaning. Maximum length: 50 characters
Liste Meanings | Lists all meanings that have been created.
Add to list | Adds entry from text field to the list of meanings.
Remove from list | Deletes selected entry from the list of Meanings.
Remove all | Deletes all entries from the list of Meanings.
Update meaning | Clicking this assigns a new meaning to all entries in the list ofMeanings. The meanings to be added are displayed in the Meanings (preview) column; the row with the variables has a green background.

Remove meanings

Remove existing meanings | Allows meanings to be removed from variables. If a variable is selected, all assigned meanings are displayed in the list of Meanings. Meanings that are to be retained are deleted from the list by clicking on the Remove from list button. Clicking on the Update meaning button removes the meanings from the selected variables.
List Meanings | Lists all of the meanings assigned to the selected variables.
Remove from list | Deletes selected entry from the list of Meanings.
Remove all | Deletes all entries from the list of Meanings.
Update meaning | Clicking this removes all entries in the list of Meanings from the selected variables. The row with the variables has a red background.

Attention: Changes and new entries are only written to the zenon variable once the Finish action in the Finish tab has been executed.

Example of color identification

  • Red: All Meanings of the variable have been deleted.
  • Green: Variable has received a new Meaning.


Machine

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Machine

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of a waterfall model for machine-based reports using the Waterfall chart filter and Waterfall chart tabs.

Other topics in this chapter

Waterfall chart filter

Waterfall chart


Waterfall chart filter

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Machine -> Waterfall chart filter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You define the machine-based waterfall diagram in this tab. To do this, all variables must be assigned to the same equipment group. If variables from an archive are used, the archive and the variables must be assigned to the same equipment group.

attention Attention

Only equipment models from the global project are available.

Parameters | Description
List of equipment groups | Selection of an equipment group.
List of projects | Selection of a project.
List of archives | Select an archive.

An equipment group and a project must be selected. As a option, it is also possible to select an archive from the appropriate equipment group.

No variables can be displayed in the Waterfall tab:

  • No project was selected
  • No equipment group was selected
  • Objects were selected that are not assigned to the same equipment group


Waterfall chart

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Machine -> Waterfall chart

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Waterfall definitions can be created and edited on this tab:

Parameters

Description

New

Active: A new waterfall definition is created.

Update

Active: An existing waterfall definition is edited. Select from drop-down list.

Chart

Entry of a name for a new waterfall definition.

Save

Clicking on the button saves the entries.

Note: All changes are only written to the zenon variable once the Finish action in the Finish tab has been executed.

Variablenliste

Lists all variables that correspond to the configuration on the Waterfall filter tab. Bool and String variables are not displayed.

The list can also be sorted by clicking on the column heading. Existing waterfall definitions are displayed in the Waterfalls column. New or amended waterfall definitions are displayed in the Waterfalls (preview) column.

Chart

Waterfall definitions can be created or amended here by dragging & dropping.

Note: All changes are only written to the zenon variable once the Finish action in the Finish tab has been executed.

Creating a waterfall definition

To create a new waterfall definition:

  1. Select New.
  2. Move the desired variable by drag&drop in sequence in the Chart area
  3. Arrange the bar according to the rules
  4. Enter a name in the Chart input field
  5. Click Save.
  6. The configuration is saved in the Waterfalls (preview) column
  7. Switch to tab Finish.
  8. Click Finish.


Line

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Line

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration of a waterfall model for line-based reports using the Waterfall chart filter and Waterfall chart tabs.

Other topics in this chapter

Waterfall chart filter

Waterfall chart


Waterfall chart filter

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Line -> Waterfall chart filter

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You define the line-based waterfall diagram in this tab. To do this, all variables and archives must be assigned to the same equipment group.

attention Attention

Only equipment models from the global project are available.

Parameters | Description
Main machine | Configuration of the main machine.
Equipment | List of the existing equipment models. Selection of a model by activating the checkbox. The selection defines the archives that can be used. Only one model can be selected.
Project | Existing projects. The list of archives can be filtered using the selection of projects. The selection is optional.
Archive | List of existing archives. Selection of an archive by activating the checkbox. Only one archive can be selected.
Side machines | Configuration of the auxiliary machines
Equipment | List of the existing equipment models. Selection of a model by activating the checkbox. The selection defines the archives that can be used. As many models as desired can be selected.
Project | Existing projects. The list of archives can be filtered using the selection of projects. The selection is optional.
Archive | List of existing archives. Selection of an archive by activating the checkbox. As many archives as you want can be selected.

Rules

The following is applicable for the selection of the main machine:

  • Precisely one equipment group must be selected.
  • The archive selection can be prefiltered using the Project filter.
    Only one project can be selected.
  • Precisely one archive can be selected.

The following is applicable for the selection of the auxiliary machines:

  • Several equipment groups can be selected. However these must be from the same level as the main machine.
  • If an equipment group has been selected for the main machine, only equipment groups at the same level as the main machine can be selected for the auxiliary machines. The equipment group of the main machine is precluded in the process.
  • The archive selection can be prefiltered using the Project filter.
    Several projects can be selected.
  • At least one archive must be selected. If a variable is already used in the archive of the main machine, it is not available for the auxiliary machine.

attention Attention

In order for variables to be available for the diagram, they must always be linked to the same equipment group as the archive in which the variables are located. This applies to main machines and auxiliary machines.


Waterfall chart

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Line -> Waterfall chart

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Waterfall definitions can be created and edited on this tab:

Note the rules for filtering on the Line Analysis filter tab: Precisely the same variable filter settings must be set for main and auxiliary machines.

Parameters

Description

New

Active: A new waterfall definition is created.

Update

Active: An existing waterfall definition is edited. Select from drop-down list.

Chart

Entry of a name for a new waterfall definition.

Save

Clicking on the button saves the entries.

Note: All changes are only written to the zenon variable once the Finish action in the Finish tab has been executed.

Legend

Key for the assignment of the variables:

  • Sub: Losses of auxiliary machines are subtracted from the main machine.
  • Add: Losses of auxiliary machines are added to the main machine.
  • SMa: Auxiliary machines .

Variables main machine

Lists all variables available for the main machine.

The list can also be sorted by clicking on the column heading.

Variables side machine

Lists all the variables available for the auxiliary machines.

The list can also be sorted by clicking on the column heading.

Chart

Waterfall definitions can be created or amended here by dragging & dropping.

Note: All changes are only written to the zenon variable once the Finish action in the Finish tab has been executed.

Creating a waterfall definition

To create a new waterfall definition:

  1. Select New.
  2. Move the desired variable by drag&drop in sequence in the Chart area
  3. Arrange the bar according to the rules
  4. Enter a name in the Chart input field
  5. Click Save.

    The configuration is displayed in the list in the Waterfall def. preview (preview) column.

  6. Switch to tab Finish.
  7. Click Finish.

Editing a waterfall definition

To edit an existing waterfall definition:

  1. Select Update.
  2. Select the desired definition from the drop-down list.

    The existing definition is displayed in the diagram field.

  3. Edit the definition.
  4. Click Save.
  5. The configuration is displayed in the list in the Waterfall def. preview (preview) column.
  6. Switch to tab Finish.
  7. Click Finish.

Rules when drawing the diagram:

When drawing, the following rules are applicable, in contrast to a machine-based diagram:

Position | Rule | Definition | Code
Last line, first column | Entries for main machines only. | SUBTRACT_SIDE_MACHINE_LOSSES | Sub
n-column, last line and not 1st column. | Main machine entries. | Default: ADD_SIDE_MACHINE_LOSSES = 0 | (none)
 |  | Alternative: Clicking on the cell with the right mouse button opens, after the dialog, a further dialog to select colors. Confirmation with Yes changes the definition to: ADD_SIDE_MACHINE_LOSSES = 1 | Add
n-column, last line and not 1st column. | Auxiliary machine entries. | LOSS_FROM_SIDE_MACHINE = 1 | SMa

Dialog: Add auxiliary machine losses

Under the following conditions, after the color selection dialog has been closed, an additional dialog to add losses from auxiliary machines is displayed:

  • Click on the right mouse button in the diagram
  • On a variable of the main machine
  • In the last line
  • From the second column

Parameters | Description
Add side machine losses | Query of whether losses from auxiliary machines are to be added.
Yes | The value for DD_SIDE_MACHINE_LOSSES is set to 1. The losses of the auxiliary machine are added.
No | The value for DD_SIDE_MACHINE_LOSSES is set to 0. The losses of the auxiliary machine are subtracted.
Cancel | The status remains as it was before the dialog was called up.


General rules for waterfall diagrams

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> General rules for waterfall diagrams

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The following rules apply when creating and editing waterfall definitions:

  1. For the first bar, the variable in the upper left corner of the character area must be dragged.
  2. The second bar can only be inserted below the first bar.
  3. All other bars can be inserted either below the existing bar or to the right of an existing bar.
    • The first row can only contain one bar.
    • If a bar is inserted to the right of an existing bar, the bar above this is extended.
  4. The selected variable is displayed in green.
  5. Each variable can only be used once.
  6. The bar contains an index:
    • First number: Row index
    • Second number: Column index
  7. The name of the selected variable is displayed in the tooltip of the bar.
  8. For line-based diagrams only: Variables of auxiliary machines can only be entered in the last line.

Note: Note the rules for filtering and diagram design for line-based diagrams.

Saving a waterfall definition

To save a waterfall definition:

  1. Enter a name in the Chart input field
  2. Click on the Save button.
  3. The definition is saved in the variable list and the new entry is displayed in the Waterfall def. preview (preview) column
  4. The new waterfall definition is only written to the zenon variable after clicking on the Finish button in the Finish tab.

Editing a waterfall definition

To edit a new waterfall definition:

  1. Select Update.
  2. Select the desired waterfall definition from the drop-down list.

    Attention: Only definitions that correspond to the configuration in the Waterfall filter tab are offered

  3. The waterfall definition is displayed in the Chart area
  4. Change the definition in accordance with the rules:
    • Adding a bar: Move the variable to the desired position: The variable is colored green.
    • Deleting a bar: Drag the bar to the deletion area. The variable is displayed again without a highlighting color.
    • Moving a bar: Move the bar to the desired location.
    • Changing the color: Assign the bar the desired color with a right-click.
  5. Click Save.
  6. All changes are displayed in the list in the Waterfall def. preview (preview) column
  7. Switch to tab Finish.
  8. Click on Finish.

Deleting a bar

Bars can be deleted if:

  • It is a short bar
  • There is no other bar below or to the right

To delete a bar, drag & drop it to a free location outside the Chart field (but not in the variable list).

The bar is deleted. All other bars are moved accordingly. Moving the bar

Bars can be moved if:

  • It is a short bar
  • The movement is within a row

To move a bar, drag & drop it to the new position. All other bars between the old and the new position are moved by one place.

Changing the color of a bar

To change the color of a bar:

  1. Right-click on the bar
  2. The dialog to select the color opened:
  3. select the desired color
  4. Click on OK.


Finish

zenon Analyzer -> Analyzer Wizards -> Meaning and Waterfall Chart Wizard -> Configuration -> Finish

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In this tab, the changes are written to the variables in zenon and the result is displayed in the output field.

Clicking on the 'Finish' button writes the changes to the zenon variable in the Editor.

The changes made are displayed in the output field:

  • Update MEANINGS variable definition: Changes to the variables that are carried out and that concern the meanings.
  • Update WATERFALL variable definition: Changes to the variables that have been carried out and that concern the waterfall definition
  • Notes on new and deleted entries, warnings and error messages.

    When importing into zenon, the length of the entry is checked for the corresponding properties. This must not consist of more than 250 characters If the entry is longer, the sequence is cut off after the 250th character and an error message is written in the output field of the 'Finish' tab.


Sankey Wizard

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard

A Sankey diagram is a graphic display of quantity flows. The quantities are displayed by arrows with a thickness proportional to the quantity. Sankey diagrams are important aids for the visualization of energy and material flows, as well as inefficiencies and potential for saving when using resources.

The Sankey Wizard supports you when creating Sankey diagrams that you can see in zenon Runtime and in zenon Analyzer.

The following scenarios are possible:

  • Create a new Sankey diagram.
  • Use a pre-existing Sankey diagram as a template.
  • Edit an existing Sankey diagram.
  • Delete an existing Sankey diagram.

The Sankey diagram is saved in an XML file.

Note: The wizard is only available in English.

tutorial License information

Part of the standard license of the Editor and Runtime.

Other topics in this chapter

Installing the Sankey wizard

Starting the Sankey wizard

Start window

Navigation

Action - select action

Variables - select variables

Diagram - create diagram

Finish - complete


Installing the Sankey wizard

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Installing the Sankey wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The wizard is automatically installed together with zenon.


Starting the Sankey wizard

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Starting the Sankey wizard

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For wizards to be displayed, the settings for VBA or VSTA must be set correctly in file zenon6.ini:

[VBA]

EIN=1

[VSTA]

ON=1

If VSTA wizards are not displayed although the settings are correct, set entry LOADED= to 1 in area [VSTA].

To start the Sankey wizard, proceed as follows:

  1. Start the zenon Editor.
  2. Click on File in the toolbar on the left.
  3. Click on Wizards.

Note: You can also open the selection window with the available wizards with the key combination Alt+F12.

The selection window with the available wizards opens.

  1. Expand the Analyzer node
  2. Then click on Sankey Wizard.
  3. Start the wizard by clicking on OK .


Start window

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Start window

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

When opening the wizard, you receive an overview that lists and explains all objects that can be configured. Configuration starts with the Action tab.

Click on the button with the arrow or on the title of the tab to navigate through the configuration of the export.


Navigation

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Navigation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Navigation through the tabs is carried out by means of the navigation bar in the lower area of the wizard window:

Button | Description
Arrow left | Goes back one tab in the wizard process.
Arrow right | Goes forward one tab in the wizard process.
Finish | Writes all changes to the zenon variable in the Editor and closes the wizard.
Cancel | Ends the wizard without making changes.

Individual tabs can also be selected by clicking directly on the title of the tab.


Action - select action

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Action - select action

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Select, in the Action tab, the desired action by activating it.

There are the following three possibilities:

Parameters | Description
Create diagram | Creates a new diagram.
Use existing diagram as template | Uses an existing diagram as a template. Note: In this case, variables must be linked to node connections again. The variable linkings of existing diagrams are not shown in the template.
Edit or delete diagram | Allows the editing or deletion of an existing diagram. The diagram to be edited or deleted can be selected from the list of the created diagrams.

List of the diagrams that have been created

The window in the middle shows a list with the diagrams that have already been created. The entries are grayed out if Create_Diagram has been selected. The following information for this is visible:

Parameters | Description
Project | Name of the project in which the diagram is saved
Diagram | Shows the name of the diagram.
Description | Shows the description of the diagram.
Analyzer | Active: The diagram can be used in the Analyzer and in Runtime. Inactive: The diagram can only be used in Runtime.
Valid | Active: The diagram is valid. Inactive: The diagram is not valid. You cannot use the diagram in either the Analyzer or in Runtime. Note: In this case, edit the diagram and amend it until it is valid.
Delete | Deletes the selected diagram. A dialog requesting confirmation is called up before the selected diagram is deleted.

Project Settings

You can change the following settings for the project in this area:

Parameters | Description
Name | Enter a name for the project here. Note: The name must be unique. Otherwise a warning dialog will make you aware of this. A newly-created program with a name that already exists would replace the existing one if the warning dialog is confirmed. However if you click on No in the warning dialog, _1 is automatically added to the name.
Save into project | Here you select the project in which your diagram is to be saved.
Description | Enter a description here. Note: This is optional.
Create diagram for Analyzer | Active: Only variables that are in archives are shown. Note: The variables that you want to use must first be exported with the Analyzer Export Wizard. Inactive: Selection of the variables is possible without limitations, however the diagram cannot be used in zenon Analyzer, only in zenon Runtime.

Note: Once this tab is left, it is no longer possible to edit the settings that have been made.

Dialog: Delete diagram

A dialog requesting confirmation is called up before the selected diagram is deleted.

Parameters | Description
Ja | Deletes the selected diagram.
Nein | The deletion process is canceled. The dialog is closed and the selected diagram is not deleted


Variables - select variables

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Variables - select variables

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You can select variables for your project in this tab.

Select project

Parameters | Description
Select project | List of all active zenon projects. Select the project(s) from which you want to select variables for your diagram here. Note: Multiple selection is possible.

Select data source

Parameters

Description

Select data source

Select the data source here (archives).
Note: The Online Data option is available for all other variables that do not come from archives. This option can only be selected if you have not activated the create for Analyzer option in the Action tab. Live values, i.e. online values, are used for Runtime. Historical values are used for zenon Analyzer.

  • Short name
    Short identification of the archive
  • Long name
    Full name of the archive
  • Project
    Project name of the archive
  • Parent archive
    Version of the archive used

Variables

Parameters

Description

Project variables

Select the variables that you want to link to your diagram here. Multiple selection is possible.

Possibilities for this:

  • Double-click on the desired variable.
  • Highlight the desired variable and then click on Add->.
  • Hold down the Ctrl key, highlight several variables, click on Add->.
  • Click on Add all-> to select all variables.

Variable list:

  • Name
    Variable name
  • Project
    Name of the project of the variable
  • Archive:
    Short identification of the archive
  • Aggregation:
    Aggregation type of the archive
    • AVG(Average)
    • Max(Maximum value)
    • Min(Minimum value)
    • Sum(Sum)
    • RAW(Raw data format - without aggregation)

Button Add ->

Adds selected variable(s) to the list of Diagram variables.

Button Add all ->

Adds all variables to the list of Diagram variables.

Button <- Delete

Removes selected variable(s) from the list of the Diagram variables.

Button <- Delete all

Removes all variables form the list of Diagram variables.

Diagram variables

Parameters

Description

Diagram variables

You can see all selected variables here. These are relevant for the next tab when creating the diagram.

To delete variables again:

  • Highlight the variable that you want to delete and click on <-Delete.
  • Hold down the Ctrl key, highlight several variables that you want to delete at the same time and click on <-Delete.
  • Click on <-Delete all to delete all selected variables again.

Variable list:

  • Name
    Variable name
  • Project
    Name of the project of the variable
  • Archive:
    Short identification of the archive
  • Aggregation:
    Aggregation type of the archive
    • AVG(Average)
    • Max(Maximum value)
    • Min(Minimum value)
    • Sum(Sum)
    • RAW(Raw data format - without aggregation)

Note: Once you have left this tab, changes to the settings that have been made here are possible.


Diagram - create diagram

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Diagram - create diagram

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You are able to draw a diagram in this tab.

Drawing area

You position your nodes and connections in the drawing area.

Node

Parameters | Description
Name | Node name
Color | Color of the node. Displays the last selected color. Clicking on the button opens the color selection dialog.
Create | Creates nodes and positions these on the drawing area.
Delete | Deletes selected nodes from the drawing area. Only active if at least one node in th drawing area has been selected.

Diagram

Parameters

Description

Validate

Checks whether all nodes have been linked and/or whether the links are occupied with a variable.

The result of the validation is displayed in a dialog.

  • Node xx is not connected!
    The node is not connected to another node.
  • A connection of node xx has no variable linked!
    The linking of the node does not have an assigned variable.

Save

Saves the current project configuration. A check is also carried out before saving.

Reset

Deletes all nodes and previously-configured connections.

Diagram settings

Parameters

Description

Loss detection

Automatic loss detection with an additional connection that visualizes the differential flow.

  • activated: The automatic loss detection is calculated.
  • deactivated: No automatic loss detection is calculated.

Default: deactivated

Unknown Loss

If, for a node, the quantity of inflows exceeds the quantity of outflows, a differential flow in the selected color is displayed.

Only active if property Loss detection is active.

Note: This differential flow is only displayed in zenon Runtime or in zenon Analyzer.

Undefined Input

If, for a node, the quantity of outflows exceeds the quantity of inflows, a differential flow is displayed in the selected color.

Only active if property Loss detection is active.

Note: This differential flow is only displayed in zenon Runtime or in zenon Analyzer.

Connections (Variables)

Parameters | Description
Connections (Variables) | List of all the variables available for linking. If a variable is already linked to a connection, this variable is shown in green in the selection list. Note: These variables are provided in the Variables tab.
Link variable | Links the selected variable to the selected connection. Not active if no connection is selected. Note: If a second node and a variable is selected, the connection is also drawn in addition to the linking.
Delete | Deletes selected connection. Multiple selection of connections is possible. Not active if no connection is selected.

Other topics in this chapter

Create diagram

Display of Sankey diagram in zenon Analyzer

Examples of views: Wizard - zenon Analyzer


Create diagram

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Diagram - create diagram -> Create diagram

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This is how you create a Sankey diagram with the Sankey wizard:

Creating nodes and connections:

  1. Enter, in the Node window, under the Name field, a name for the node to be created.
  2. Select a color for the node by clicking on the Color field.
  3. Then click on Create.
  4. Create as many nodes as you want and sort them as you want.
  5. Connect the nodes by dragging a node output (to the right of the node) to a node input (to the left of the node).

Note: A node can have connections to several nodes or several nodes can have connections to one node. The size of the output node changes depending on how many connections there are. Nodes that are only connected on one side are displayed as round or oval. Nodes that have connections on both sides are shown as angular.

There are the following possibilities with regard to node connections:

Back-coupling: Establish a connection from the output of a node to its input

To do this:

  • Double-click on the node on which you want to create the back-coupling.

or

  • Drag the connection from the output of the node to its input.

Establish a connection between 2 nodes and link a variable to it at the same time:

To do this:

  1. Highlight both nodes that you want to connect and the variable that you want to link to it.
  2. Click Link Variable.

Linking variables to connections:

There are several possibilities for linking variables to connections:

Drag&Drop

  • Drag the desired variable from the Connections (Variables) window to the desired node connection.

Note: Provided that you have already established the connection between the nodes.

Button Link Variable

  1. Highlight the desired node connection
  2. Highlight the variable that you want to link to the connection.
  3. Click on the Link Variable button.

Note: You can only link one variable to each connection.

Linking a variable to several node connections:

  1. Hold down the Ctrl key and highlight several node connections.
  2. Highlight the desired variable
  3. Click on Link Variable.

    or

  4. Drag the variable to the highlighted node connections.

Note: In order to see the name of the variable that is linked to the connection, move the mouse to above the connection.

Diagram settings:

If you activate the Loss Detection option, loss detection is calculated automatically. An additional connection then visualizes the differential flow.

You can select the colors that are to be used for the display of the differential flows in the Unknown Loss and Undefined Input fields. To select a color, click in the field. The color palette for selecting a color is opened

Concluding the drawing of the diagram:

Once you have finished drawing your diagram,

  • Click on the button Validate:

If all your connections are correct, a dialog appears informing you that the diagram is valid. Otherwise a dialog appears informing you that there are still nodes that are not connected or that variables are not linked to the connections.
In order for a diagram to be valid:

  • All nodes must be connected
  • All connections must be occupied with a variable
  • No nodes can overlap if they are moved towards inputs (left) or outputs (right)

To save your diagram,

  • Click on the Save button.

The diagram you have created is validated. The diagram is saved and marked as valid or invalid. You are shown the project in which it is saved.

To redraw the diagram,

  • Click on the Reset button.

All the nodes you have drawn and your connections are thus deleted.

info Information

Clicking on the Validate or Save buttons orientates the nodes to the right and left side of the drawing area.

Note: Nodes must not overlap in the process.

Editing nodes:

Once you have created some nodes, you can

Issue several nodes with the same name:

  1. Hold down the Ctrl key.
  2. Highlight the nodes that you want to name.
  3. Enter a name.

Select the same color for several nodes:

  1. Hold down the Ctrl key.
  2. Highlight the nodes that you want to color.
  3. Then select a color.

Moving several nodes at the same time:

  1. Hold down the Ctrl key.
  2. Select the node that you want to move.
  3. Move the nodes. Your connections are also moved.

Note: You can also edit a node individually by highlighting it and make the desired change.

Deleting nodes:

  1. Highlight the node that you want to delete.
  2. Click, in the Node window, on Delete or use the Delkey.

Deleting several nodes at the same time:

  1. Hold down the Ctrl key and highlight the node that you want to delete.
  2. Click, in the Node window, on Delete or use the Delkey.

Note: When the node is deleted, its connections are also deleted.

Deleting connections:

  1. Highlight the connection that you want to delete.
  2. Click, in the Connections (Variables) window, on Delete or use the Delkey.

Deleting several connections at the same time:

  1. Hold down the Ctrl key and highlight the connections that you want to delete.
  2. Click, in the Connections (Variables) window, on Delete or use the Delkey.


Display of Sankey diagram in zenon Analyzer

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Diagram - create diagram -> Display of Sankey diagram in zenon Analyzer

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The nodes are always rearranged in zenon Analyzer and do not follow the exact positioning in the wizard in the process. The display of the Sankey diagram is automatically optimized in zenon Analyzer for legibility and clarity.

The width of the connection is taken into account specially for this arrangement. This width is dependent on the respective values shown (the more there are, the thicker it is).

Horizontal arrangement

Nodes are distributed horizontally over the whole width in proportion to their number.

Example: With three nodes, the display of the first connection will end in the middle of the display.

Vertical arrangement

The vertical arrangement of the nodes is always carried out in a vertical line in zenon Analyzer. This means that the first level is always arranged in a vertical line, regardless of the project configuration in the wizard.

The end nodes are automatically arranged from top to bottom at equal distances.

info Information

Please note the following examples of views.


Examples of views: Wizard - zenon Analyzer

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Diagram - create diagram -> Examples of views: Wizard - zenon Analyzer

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Example of horizontal arrangement

Sankey wizard configuration

zenon Analyzer view

Example of vertical arrangement

Sankey wizard configuration

zenon Analyzer view

Example of mixed arrangement

Sankey wizard configuration

zenon Analyzer view


Finish - complete

zenon Analyzer -> Analyzer Wizards -> Sankey Wizard -> Finish - complete

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In the Finish tab, you can see whether the diagram you have created is valid and the location where the diagram you have created has been saved.

  • Click on the Finish button.

To close the Sankey wizard:

  • Click on the Close button.

info Information

The configuration of your Sankey diagram is saved in an XML file.

This is in the project manager of the selected project in the Files node in the Other folder.

With the Analyzer Export Wizard, you can accept the modeled Sankey diagram for use in zenon Analyzer.

You can read details of this export in the Analyzer Export Wizard. manual


First steps

zenon Analyzer -> First steps

This manual displays the configuration of zenon Analyzer reports for the analysis of alarms and production data. You find out how you configure data, in order for it to be displayed in certain cycles.

Note: This document is limited to the display of fundamental first steps. zenon Analyzer provides far more functionality than is shown here. Some functions can be have a different appearance in different product versions. This documentation is based on the use of zenon Analyzer 3.00 and zenon 7.50.
Recommendation: For further information, we recommend a corresponding training course. You can get details of this from your COPA-DATA contact partner.

Procedure

This tutorial guides you through the configuration of fundamental reports:

  • In the first stage, you import the required data into zenon Analyzer.
  • In the second stage, you configure the report templates in ZAMS.

Other topics in this chapter

Export Wizard

ZAMS: Preparing and providing reports


Export Wizard

zenon Analyzer -> First steps -> Export Wizard

With the Export Wizard, you extract the necessary data from zenon in order to provide it to zenon Analyzer.

The Export Wizard for Analyzer is automatically installed with the zenon Supervisor. For each version of the zenon Analyzer, there is a respective version of the Wizard. The versions can have different functionality and a different user interface.

Note: The Efficency classes tab is not used in this project. It is for the selection and configuration of the efficiency classes to be exported. You can also find further information on this and the wizard in the wizard documentation.

Starting the wizard

To start the wizard:

  1. In zenon open menu File
    or press the shortcut Alt+F12
  2. Select the Wizards entry.
  3. The selection dialog is opened

  4. Navigate to node Analyzer.
  5. Select the desired version of the Export Wizard for Analyzer.
    Select Export Wizard for Analyzer 3.00 for this tutorial.

    Note: Wizards only offer an English-language user interface.
    The configuration can vary for different versions of zenon Analyzer.

Configuring the wizard

You determine which data is loaded from the zenon projects and prepared for zenon Analyzer in the individual tabs of the wizard. The data is fed into the desired database by the wizard at the end.

Other topics in this chapter

Settings: Connection and basic settings

Equipment Models

Event classes and event groups

Users

Projects

Archives

Variables

Finish


Settings: Connection and basic settings

zenon Analyzer -> First steps -> Export Wizard -> Settings: Connection and basic settings

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In the Settings tab, you configure:

  • Database for which the data is prepared (the data in the screenshot is an example).
  • Access data for the database: You can use Windows authentication or SQL access data.
  • zenon projects whose data is to be loaded.
  • Selection of whether existing data in the database is to be changed.
  • Selection of whether existing variable names are also to be amended in zenon after being amended in the database.

As soon as there is a connection, you can load the data from all selected projects using the Load Data button.
Note: Entries that already exist in the database are pre-selected in the following steps. Up to and including version 2.20, the Preselect existing Analyzer database content option must be selected for this. From version 3.00, this option is activated automatically and can no longer be configured in the user interface. The corresponding entry has been removed.


Equipment Models

zenon Analyzer -> First steps -> Export Wizard -> Equipment Models

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You select the desired equipment models and equipment groups in the Equipment models tab. These are required in order to determine the content of the reports and the aggregation of data. For example, with alarms, you can select a wider perspective on data from a complete equipment group instead of just individual alarms.

Note:

  • Only equipment models from the global project are used during export.
  • Select only the equipment models and equipment groups that you also want to use in reports.


Event classes and event groups

zenon Analyzer -> First steps -> Export Wizard -> Event classes and event groups

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Event classes and event groups are to pre-filter information. For example, with alarm classes you can very easily distinguish between alarms for Engineering, lots and quality, and thus design targeted reports for error messages.


Users

zenon Analyzer -> First steps -> Export Wizard -> Users

In the Users tab, you select the users who are to be exported in zenon Analyzer.


Projects

zenon Analyzer -> First steps -> Export Wizard -> Projects

In the Projects tab, you select projects that are to be exported to zenon Analyzer and which project data you want to use for archives and variables. In the following tabs, you only get data that comes from the projects selected here.


Archives

zenon Analyzer -> First steps -> Export Wizard -> Archives

You select the desired archive in the Archives tab. Only archives that are in the previously-selected projects are available. You can only select basic archives. The attendant aggregated archives are exported automatically.

In the Report Launcher, archives can be selected in the reports, depending on the configuration.

We have selected all archives for our example. The decision of which ones are actually used is then made when configuring the report in the Report Launcher.


Variables

zenon Analyzer -> First steps -> Export Wizard -> Variables

You select the variables required for your reports in the Variables tab. Only variables that are included in one of the selected projects are available.

There are usually many variables present in a project. However the number of variables that are needed in the report is generally very small. It is recommended that you pre-select carefully. You thus ensure that the number of variables in the Report Launcher does not become overwhelming.


Finish

zenon Analyzer -> First steps -> Export Wizard -> Finish

All data in accordance with its configuration is exported by clicking on the Export button in the Finish tab. It is now available for provision in reports in ZAMS and for display in Report Launcher.

If the requirements for reports change or data in zenon has been changed, the data can be exported again with the wizard.

Further configuration is carried out in ZAMS.


ZAMS: Preparing and providing reports

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports are pre-configured in ZAMS and provided for use in Report Launcher. The configuration is described in detail in the alarm aggregation chapter. All other report configurations expand on this description.

Note shifts: In our examples, shifts are configured with fixed times. It is, of course, possible to log shifts flexibly with the zenon module PFS and evaluate this in zenon Analyzer.

Other topics in this chapter

Alarm Aggregation

Alarm List

Top N Alarms

Trend reports

Loss times and productivity - meanings and waterfall

Production analysis Line Based - Gantt chart

Administer standard parameters in the Report Launcher


Alarm Aggregation

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This report template displays aggregated alarm data in graphics and tables. The alarm filtering can contain projects, equipment groups, alarm classes, alarm groups and alarm comments.

Two examples of reports:

  • Alarms, grouped according to equipment model.
    Time range: a certain lot

  • Alarms, grouped according to equipment model.
    Time period: one month

In this document, you become familiar with examples for the following filters:

  • Course of a lot
  • one week
  • one month
  • Relative to the current day
  • One month from the first day of the month
  • Morning shift A
  • Afternoon shift B
  • Night shift C

Other topics in this chapter

Configuration

Report for a lot

Report for a week

Report for a month up to today

Report for a calendar month

Report for a shift

Special features for alarm aggregation

Deploy report


Configuration

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation -> Configuration

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To configure a report for the aggregated display of alarms:

  1. Start the selection dialog by clicking on New report:

  2. Select the theme of Alarm and Event Analysis.
  3. Select the Alarm Aggregation report template.
  4. Select the name and save location for the report definition file (*.zams_rep).

    The report template is displayed in ZAMS.


Report for a lot

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation -> Report for a lot

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The following configuration creates a report for a lot:

File path

  1. The file path for the save location of the report is preconfigured. You can amend it in this dialog if required:

  2. To do this, click on the Select report file path button.

Time filter

Select the desired time filter.

To do this:

  1. Click on the time filter configuration button.

    The selection dialog is opened.

  2. Select the desired type from the drop-down list. In our examples, relative time filter or lot selection with relative time pre-filtering:

In these instructions, you can find examples for:

  • Lot selection with relative time prefilter:
    Selection of data that that relates to the lots executed.
  • Relative time filter:
    Selection of data that takes into account time ranges such as week, month (form the start to end), month (month to date) and daily shift reports.

Lot selection with relative time prefilter

In our example, the relative time filter defines the time range in which executed lots are selected. The actual time range comes from the start and end time of the lot archive. The report looks back over a day, in order to find all lots that have been executed.

Attention: The lot that is currently being executed is also listed. It is thus possible to create Dashboard reports on the basis of the data that is currently active.

Selection of time filter type

  • Time filter type: Select Lot selection with relative time pre-filtering.
  • Project: Select the project that executed the lot.
  • Lot archive: Select the archive for the lot.

Default time range configuration

With the standard time range configuration, you select the actual time period within the time filter type that relates to the report.
The following sections show the different configurations that are used by all reports that are based on the preset time.

  • End of time range: Select Current time stamp with amendment.
  • Look back time: Select 1 day.


Report for a week

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation -> Report for a week

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Configuration for one week, starting from today's date:

  1. Select the relative time filter as a time filter type.

  2. For End of the time range, select the Current time stamp with adjustment option.
  3. Select 7 days as a look-back time.


Report for a month up to today

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation -> Report for a month up to today

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The configuration corresponds to that of a lookback over a week. However the lookback time must of course be amended accordingly.

  1. Select the relative time filter as a time filter type.

  2. For End of the time range, select the Current time stamp with adjustment option.
  3. Select 1 month as a look-back time.


Report for a calendar month

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation -> Report for a calendar month

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The report time can be amended so that the complete current month up to today is displayed:

  1. Select the relative time filter as a time filter type.

  2. For End of time range, select Current time stamp with fixed components and adjustment.
  3. For time range settings, set both Minutes and Hours each to 0 and Day and Month each to 1.
  4. Select 1 month as a value for the Adjustment option.
  5. Select 1 month as a value for the look-back time.

A report for the complete month is shown with these settings.


Report for a shift

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation -> Report for a shift

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

You can also configure reports for individual shifts. In this example, we assume:

  • Shift A: Morning shift
  • Shift B: Afternoon shift
  • Shift C: Night shift

Shift A

For the display of shifts, we use simple time filters, in order to select the appropriate start time and duration.

Shift A is the morning shift from 06.00 to 14.00.

  1. Select the relative time filter as a time filter type.

  2. For End of time range, select Current time stamp with fixed components and adjustment.
  3. Set the following as time range settings:
    1. Minutes to 0
    2. Hours to 6
  4. Select 8 hours as a value for the Adjustment option.
  5. Select 8 hours as a value for the look-back time option.

The morning shift in the report thus goes every day from 06.00 to 14.00.

Shift B

Shift B is the afternoon shift from 14.00 to 22.00.

The time filters are amended accordingly.

  1. Select the relative time filter as a time filter type.
  2. For End of time range, select Current time stamp with fixed components and adjustment.
  3. Set the following as time range settings:
    1. Minutes to 0
    2. Hours to 14
  4. Select 8 hours as a value for the Adjustment option.
  5. Select 8 hours as a value for the look-back time option.

The afternoon shift in the report thus goes from 14.00 to 22.00 every day.

Shift C

Shift C is the night shift from 22.00 to 06.00.

The configuration of the time filter is somewhat different from Shift A and B:

A relative time filter is still set. However, we must take into account that a new day starts within the shift. We therefore only set the end time and a corresponding lookback time.

  1. Select the relative time filter as a time filter type.
  2. For End of time range, select Current time stamp with fixed components and adjustment.
  3. Set the following as time range settings:
    1. Minutes to 0
    2. Hours to 6
  4. Select 0 hours as a value for the Adjustment option.
  5. Select 8 hours as a value for the look-back time option.

The night shift in the report thus goes from 22.00 of the day before to 06.00.


Special features for alarm aggregation

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation -> Special features for alarm aggregation

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

To keep our example as simple as possible, we use the standard configuration of the report template.

We only need to make a selection for the alarm filter (dynamic).

The standard settings in the screenshot show:

There are static filters for alarm groups and alarm classes. You can, for example, distinguish between process alarms and quality assurance alarms by means of alarm classes that are defined in the zenon variables. The former inform you about the performance and you use the latter for the creation of Reports By Exception - RBE.

The dynamic alarm filter makes it possible to only make the actual selection during configuration in the Report Launcher.

For our example, we select project and equipment group.

Hint: Combine static alarm filters with dynamic alarm filters. You can thus create very different reports with the same data basis.


Deploy report

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm Aggregation -> Deploy report

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Now we have:

  • Exported data from zenon into the zenon Analyzer database
  • Configured different alarm aggregation reports that:
    • Are based on all data of a project
    • Portray individual areas using equipment models
    • Relate to different time configurations:
      Lots
      Weeks
      Month
      Calendar month
      Shifts A, B and C

The reports can now be prepared.
To do this, click on the Prepare report button in the configuration of the report template in ZAMS.

There are queries via dialogs for the saving and overwriting of files. Always select All and confirm this by clicking on OK.

Hint: You can prepare several reports at the same time. To do this, click on the symbol for Prepare all reports in the toolbar.

All data is thus saved for the reports open in ZAMS and the reports are prepared. This is the quickest method for the preparation of many reports.


Alarm List

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Alarm List

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This report template lists all current individual alarms, which corresponds to the conventional alarm list in zenon.

The illustration shows all alarms without pre-filtering for a certain lot:

The same settings for time and selection as for alarm aggregation also work for these reports. Identical settings were thus also used for this report - with one exception: For the Alarm filter (dynamic) option, Project only was selected.

We thus get a complete alarm list for the whole project.

Use the dynamic filter if you need the equipment model, for example, in order to offer a certain perspective on equipment areas in the report.


Top N Alarms

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Top N Alarms

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Top N alarm reports show a selection of alarms that have occurred most frequently.

This report for Top N alarms is aimed at problem areas.

Here, the focus is on individual report setting for the Top N calculation and standard value for N options, as well as the time period.

We select for:

  • Top N calculation: Most frequent alarms per project

  • Default value for N: 6


Trend reports

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Trend reports

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

For a trend report for individual process variables in the course of a lot or a certain time section, we use the Historian trend in our example.

By using the same time filter as for alarm aggregation to filter data from the progression of a lot, a week, a month or a shift, diagrams for individual and grouped variables can be displayed.

Configure report in ZAMS

To configure the report:

  1. Select the Historian trend template in the Historian analysis theme.

    The template is opened:

  2. Configure the default settings.
  3. Configure the curve type and the data display:

  4. Save the report and provide it.

Open report in the Report Launcher

The following information must be provided when opening the report in the Report Launcher:

  • Archive in which data is saved.
  • Variables that are required for the diagram

This information can be selected each time a report is called up or as a standard parameter.


Loss times and productivity - meanings and waterfall

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Loss times and productivity - meanings and waterfall

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In the next section, we will look at examples of reports for machine-based production analysis:

  • Productivity Indicators Analysis
  • Loss analysis
  • Comprehensive productivity analysis as a combination of both other reports

These reports need special variables in zenon Supervisor in order to focus on certain information. To link these variables, Meanings are defined in both the Analyzer as well as in zenon Supervisor. zenon Analyzer looks for these meanings in certain reports.

In zenon Supervisor, the Meaning for each variable, depending on the zenon version are given in the following property:

  • Meaning in the Analyzer group (from version 7.20)
    Or
  • Resources label in the General group (up to and including version 7.11)

info Information

For details, see also the Meaning and Waterfall Chart Wizard chapter in the manual.

Analyses for loss times and productivity can also provide an overview of lot productions over a longer period of time. To do this, lots of the same equipment models are compared.

Other topics in this chapter

Productivity indicators

Loss times

Comprehensive Productivity Analysis

Productivity Indicators Lot History

Losses Lot History

Comprehensive Productivity Lot History


Productivity indicators

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Loss times and productivity - meanings and waterfall -> Productivity indicators

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze archive data and calculate aggregated productivity indicators for a time period, based on an equipment group. The four central OEE indicators can be displayed as a bar chart or in four measurement devices. The additional optional indicators are displayed in a table.

In order to be able to filter our the required data for this report in the required time range, time filters and equipment models are configured accordingly.

The following is applicable in our example:

  • The data filter is left empty.
  • Production indicators are mandatory. They lead directly to the zenon project that contains the key values.

Meanings

In the Configure indicators dialog, you can set individual meanings for each required variable.

Indicator | Description
Loading time | Complete planned duration including planned downtime such as cleaning, switching, handover. Default: Loading Time
Operating time | Actual running time. Sum of effective running time and downtimes. Default: Operating Time
Net operating time | Net duration without interruptions. Default: NetOperating Time
Valuable operating time | Valuable running time. Result of the net operating time minus losses due to a lack of quality or damage. Default: ValuableOperating Time

The Meanings for each variable must be added in zenon Supervisor.
You can query these directly in the Analyzer/Meaning variable properties. The variables for use in zenon Analyzer are thus linked.

Use the Meaning and Waterfall Chart Wizard to add the meanings in the correct format.

info Information

You must do the following in order to be able to link variables:

  • Have an equipment model
  • Contained in the corresponding archive

The following is also applicable:

  • The archive must be linked to the same equipment group as the variable.
  • The variable must only be included in one archive.

Note: Up to and including zenon 7.11, the Meaning is defined in the Resources label property.
Use the following syntax there: ME=, e.g. ME=LoadingTime.

Example for zenon 7.11:

Meaning and Waterfall Chart Wizard

To start the wizard:

  1. In zenon open menu File
    or press the shortcut Alt+F12
  2. Select the entry Wizards
  3. The selection dialog is opened.
  4. Navigate to node Analyzer.
  5. Select the Meaning and Waterfall Chart Wizard.

  6. Start the wizard by clicking on OK .
  7. If the wizard has been started, select Define Meannings in the Settings tab first and load the project data. Only active projects are loaded. If you want to load data from all projects, deactivate the Load every project of this workspace into the memory option.
  8. Then switch to the Meaning filter tab and configure the required equipment models, projects and archives.

  9. Switch to tab Meaning.
    All configurable variables are displayed here.
  10. Select the variables that you want to use for a Meaning.

  11. Add the desired text and click on Update meaning.

    If the variables have been configured correctly, the Finish button is available in the Finish tab.

Clicking on Finish sets the Meaning-text in the zenon projects. The project must then be exported with the appropriate Analyzer Export Wizard for zenon Analyzer.

Important steps

When configuring, ensure that all required data is available:

  • These reports require variables from the zenon project.
  • The variables from the zenon project are linked to zenon Analyzer using Meanings.
  • Meanings are issued, depending on the zenon version, in different zenon properties.
  • In order to assign Meanings correctly, use the Meaning and Waterfall Chart Wizard.
  • Each linked variable requires an equipment model and must be contained in an archive that is linked to the same equipment model.
  • The variable must only be included in one archive.

Optional configuration

There are also optional configurable indicators available.

In our example, we also select total units and Good units as a quality indicator for the goods produced.

In the Configure indicators dialog, open the Optional indicators tab and activate Total units and Good units.

These indicators have an assigned Meaning text. All Meaning texts can be amended in the Meanings for optional indicators tab so that they follow a specific convention.

These meanings must be created with the Meaning and Waterfall Chart Wizard in the zenon project again.

Afterwards, the project must be exported into zenon Analyzer again with the appropriate Analyzer Export Wizard.

Complete report

The report is now linked to the required variables. To complete the configuration, areas can be established for visibility:

The report can then be prepared.


Loss times

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Loss times and productivity - meanings and waterfall -> Loss times

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze archive data and calculate aggregated loss times for a time period, based on an equipment group and a waterfall model. The results can be displayed as a Waterfall diagram, Pareto diagram or as a table.

Display in detail:

Compact display:

Configuration in ZAMS is as usual:

  1. Configure the required time filters, depending on the time filter type.

  2. Define the equipment model or lot archive.
  3. Select the project for the required data.
    The data filter is not required in our example.
  4. Select the desired type of waterfall diagram.

  5. Select the desired type of loss display (Pareto chart).

Variables selection

The selection of the variables that are used in the report is configured in zenon Supervisor with the Meaning and Waterfall Chart Wizard:

  1. Like the configuration of the Meanings, you activate, in the Settings tab, the Define Waterfall checkbox and load the data.
  2. Then open the Waterfall filter tab and select the desired variables.
  3. Open the Waterfall tab.

  4. Drag variables to the diagram area by means of drag&drop.
  5. Give the waterfall chart a name.
  6. Save the configuration.

    Note: You can configure more than one waterfall chart. You select the respective diagram that is needed in the report.

  7. Click on the Finish button in the Finish tab. The configuration is thus saved.
  8. Export the project to the zenon Analyzer again with the appropriate Analyzer Export Wizard.

Illustration: A variable can contain several Meanings and waterfall displays.


Comprehensive Productivity Analysis

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Loss times and productivity - meanings and waterfall -> Comprehensive Productivity Analysis

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

This template combines the Losses Analysis and Productivity Indicators Analysis report templates.

Reports that are based on this template analyze archive data and calculate aggregated loss times and aggregated productivity indicators for a time period, based on an equipment group and a waterfall model. The four central OEE indicators can be displayed as a bar chart or in four measurement devices. The additional optional indicators are displayed in a table. The loss times can be displayed as a Waterfall diagram, Pareto diagram or as a table.

The configuration uses the same input elements as the individual reports.


Productivity Indicators Lot History

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Loss times and productivity - meanings and waterfall -> Productivity Indicators Lot History

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The reports that are based on this template analyze archive data and calculate aggregated loss times and productivity indicators for each lot in a time period, based on an equipment group. The results can be displayed as a bar chart or as a line chart. The additional optional indicators are displayed in a table.

In addition to changing the perspective of the productivity indicators report template, the configuration contains a section with the settings for the archive and the project to which the report relates.

Because the report serves to provide an overview of many lots. it makes sense to define a filter that lasts longer than a lot and is not determined by a lot duration.


Losses Lot History

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Loss times and productivity - meanings and waterfall -> Losses Lot History

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The reports that are based on this template analyze archive data and calculate aggregated loss times and productivity indicators for each lot in a time period, based on an equipment group. The results can be displayed as a bar chart or as a table.

As in the productivity lot history report template, the project and lot archive can be defined.

In contrast to the loss times report template, there is in this template the possibility to apply two tables with different variables to the criteria:
One for relative loss times, the other for absolute loss times.

The variables for this are:

  • Defined in zenon Supervisor with the Meaning and Waterfall Chart Wizard

  • and assigned in ZAMS using the Configure display of loss times option:


Comprehensive Productivity Lot History

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Loss times and productivity - meanings and waterfall -> Comprehensive Productivity Lot History

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

The report template combines the templates Losses Lot history and Productivity Indicators Lot History.

The reports that are based on this template analyze archive data and calculate compressed loss times and productivity indicators for each lot in a time period, based on an equipment group. The four central OEE indicators can be displayed as a bar chart or as a line chart. The additional optional indicators are displayed in a table. The losses can be displayed as a bar chart or as a table.

The configuration uses the same input elements as the individual reports.


Production analysis Line Based - Gantt chart

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Production analysis Line Based - Gantt chart

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

Reports that are based on this template analyze lots, shifts and variables - specified through meanings, from AML, CEL or archive - and display the results as a Gantt chart and as a table.

With the same filter as before and Meanings that are linked to special variables, the diagram is configured quickly. For a better overview of the status of the production line, shifts and lots can be displayed.

Configuration of the Meanings and diagram specifics:

  1. In the Configure Gantt chart analysis configuration dialog in the Shifts and lots tab, select what you want:

  2. Issue labels for the Meanings in the analysis groups tab.

  3. Configure the diagram settings.

  4. Close the configuration with the validation.

The time range and lot name are then displayed as the lot information in the report.

We have defined two analysis groups in our example:

  1. Status: Shows the operating status of the equipment as in operation, defective, being cleaned, or standstill.
  2. Operating mode: for example automatic, semi-automatic or manual.

The number of definable groups is unlimited for this type of report. There is a Meaning for each group. And for each item of equipment, there must be the same label issued in zenon for the Meaning for each item of equipment in the report.

The following illustration shows the two analysis groups Status and operating type for the equipment AirWash, Capper and Cartoner:

In zenon:

The Meanings must be exported to the zenon Analyzer.

The report output can contain all information in one report. However, a selection of the information can also be configured in the data display option and output as desired.


Administer standard parameters in the Report Launcher

zenon Analyzer -> First steps -> ZAMS: Preparing and providing reports -> Administer standard parameters in the Report Launcher

Previous chapter Next chapter Show all Show all Hide all Hide all
© Ing. Punzenberger COPA-DATA GmbH. E-Mail: documentation@copadata.com

In ZAMS, different dynamic filters can be configured, depending on the selected report template.
For example: For an alarm aggregation report with the Project and equipment group option selected in the alarm filter (dynamic), the desired project and one or more equipment groups must be selected when the report is opened in Report Launcher.

The report can be left so that this information must be entered each time it is opened. However we can also define standard parameters with which the report is executed each time.

Defining standard parameters

To define parameters as a standard:

  1. Go to the report selection in the Report Launcher.
  2. Move the mouse over the report.
  3. A colored frame is displayed around the report, with a triangle on the right-hand side.
  4. Click on the triangle.

    a drop-down list is opened

  5. Click on Manage.

    A dialog is opened.

  6. Click on Parameters.

  7. Select the desired standard requirements.
    1. Select the parameters by activating the Has standard value checkbox.
    2. Select the desired entries in the drop-down list for standard value.
      Clicking on the triangle closes the drop-down list again.
    3. You can also hide the display of the options. To do this, activate the Hide checkbox.
      In this case, the parameters can no longer be amended in the report.
      Hint: Leave parameters visible and allow them to be edited if many elements such as curves or equipment models are to be processed,

If a report has all necessary parameters, it is automatically created immediately when opened. It is not necessary to click on Show report.

Examples

Standard projects:

Standard archives:

Standard equipment groups: